精华内容
下载资源
问答
  • 基于eNSP的华为设备--单臂路由配置,静态路由配置,RIP动态路由配置,OSPF动态路由配置华为模拟器配置单臂路由功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码...

    基于eNSP的华为设备--单臂路由配置,静态路由配置,RIP动态路由配置,OSPF动态路由配置

    华为模拟器配置单臂路由

    拓扑图如下在这里插入图片描述

    拓扑图简介:
    两个二层交换机下,有vlan 10 和vlan 20 ,网关在路由器,设置一个单臂路由使vlan 10 与vlan 20可以通信。

    路由器R1:
    #
    interface GigabitEthernet0/0/0.1
     dot1q termination vid 10
     ip address 192.168.1.1 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet0/0/0.2
     dot1q termination vid 20
     ip address 192.168.2.1 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet0/0/1
     ip address 10.10.1.1 255.255.255.0
    #
    //配置时记得进行dot1q进行封装:
     dot1q termination vid 10       /dot1q封装,对应所属vlan
     arp broadcast enable         /启用arp广播
     //创建以及开启VLAN
     int vlan 10
     vlan 10
     
    

    对于交换机LSW1 与LSW2
    设置vlan 将其放入相应端口

    LSW1:
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/5
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/10
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/11
     port link-type access
     port default vlan 20
     #
    

    将PC设置好静态地址,则可以Ping通。

    华为模拟器配置静态路由

    拓扑图如下:
    在这里插入图片描述

    实验目的:配置静态路由,使两边PC能够ping通。

    路由器R12 与R13:

    R-12:
    interface GigabitEthernet0/0/0
     ip address 10.10.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.1.1 255.255.255.0
     dhcp select global
    
    ip route-static 192.1.4.0 255.255.255.0 10.10.1.2
    //华为模拟器和思科模拟器在静态路由配置上的区别。
    
    //DHCP 的配置:
    
    dhcp enable  //打开dhcp
    ip pool test   //配置地址池的名字
    gateway-list  192.168.1.1  //配置网关地址
    network 10.1.1.0 mask 24 //配置地址池地址
    excluded-ip-address 10.1.1.2 10.1.1.5   //不允许分配的地址
    
    R -13配置等同类似
    

    华为模拟器配置RIP路由

    拓扑如图:
    在这里插入图片描述目的:为三个路由器配置rip协议,实现动态路由

    R2上的配置:
    //Rip -v2的配置
    rip 1
     undo summary
     version 2
     network 192.168.1.0
     network 192.168.2.0
    #
    //包括其后的端口及ip配置
    //以及PC上静态配置ip
    

    R3上的配置

    #
    interface GigabitEthernet0/0/0
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.3.1 255.255.255.0
    #
    rip 1
     undo summary  //自动取消汇总
     version 2
     network 192.168.2.0
     network 192.168.3.0
    #
    
    //查看路由命令
     display ip routing-table 
     display ip routing-table protocol rip 
    

    华为模拟器配置单区域OSPF

    在这里插入图片描述
    配置OSPF为什么最好设置一个环回口呢?意义和好处是什么?

    A:回环口IP可以做为路由器的管理IP,而且回环口IP是路由器ID取值的第一标准,如果配置了回环口IP,那么这个IP就是路由器的ID,如果没有配置回环口IP,那么路由器ID就选取物理接口上IP最大的作为ID,而且环回口都是UP状态,除非路由器挂掉,不会频繁变动,因此路由器不必频繁重新向邻居介绍自己或者是更新路由状态,可以减少不必要的开销。

    答疑以后,下面是命令

    设置回环口:

    //  设置回环口,并设置IP地址
    
    [Huawei]int LoopBack 5
    [Huawei-LoopBack5]ip add 10.10.2.4 24
    
    

    配置OSPF的命令:

    ospf 1 router-id 10.0.1.1
     area 0.0.0.0
      network 10.0.1.0 0.0.0.255
      network 10.0.12.0 0.0.0.255
    #
    

    华为模拟器配置多区域OSPF

    拓扑图如下:
    在这里插入图片描述

    //用红线标出来的地方,分别是area 1 ,area 0 和 area 2

    设置环回口,设置接口及其IP地址,设置OSPF及不同区域,将不同的区域中添加上不同的网段即可。

    R-14的配置:

    #
    interface GigabitEthernet0/0/0
     ip address 10.0.0.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.0
    #
    ospf 1 router-id 1.1.1.1
     area 0 
      network 1.1.1.0 0.0.0.255
      network 12.0.0.0 0.0.0.255
     area 1
      network 10.0.0.0 0.0.0.255
    #
    其他的以此类推!
    
    展开全文
  • 静态路由配置

    万次阅读 多人点赞 2018-11-23 03:37:57
    静态路由配置 配置指令 路由设置 (config)# ip route 目标网段掩码 下一跳ip地址 例如路由A设置:#ip route 192.168.30.0 255.255.255.0 192.168.20.2 ①路由A设置f0/1(10.0网段)设置网关 f0/0接口设置ip地址192....

    静态路由配置

    配置指令 路由设置
    (config)# ip route 目标网段掩码 下一跳ip地址
    例如路由A设置:#ip route 192.168.30.0 255.255.255.0 192.168.20.2

    在这里插入图片描述
    ①路由A设置f0/1(10.0网段)设置网关
    f0/0接口设置ip地址192.168.20.1

    路由A设置

    (config)#interface f0/1 (进入接口f0/1)
    (config-if)#ip address 192.168.10.254 255.255.255.0 (设置接口ip地址和子网掩码)
    #no shutdown (启用接口)

    (config)#interface f0/0
    (config-if)#ip address 192.168.2.1 255.255.255.0
    (config-if)#no shutdown

    ②路由B设置f0/1(30.0网段)设置网关
    f0/1接口设置ip地址192.168.30.254

    (config)#interface f0/1 (进入接口f0/1)
    (config-if)#ip address 192.168.30.254 255.255.255.0 (设置接口ip地址和子网掩码)
    #no shutdown (启用接口)

    (config)#interface f0/0
    (config-if)#ip address 192.168.20.2 255.255.255.0
    (config-if)#no shutdown

    路由设置 ip route 目标网段掩码 下一跳ip地址
    路由A(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2
    路由B(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.1

    最后测试网络是否ping通
    10.0网段与30.0网段主机ping通

    在这里插入图片描述

    展开全文
  • React 路由配置

    千次阅读 2019-04-18 22:29:50
    一、路由配置 二、路由传值 2.1 静态传值 2.2动态传值 2.3 es6模板传值 2.4 传多个值 2.5 get 传值 三、配置子路由 四、编程式路由 4.1 同级路由跳转 4.2 子父路由跳转 一、路由配置 1.安装路由 cnpm ...

    目录

    一、路由配置

    二、路由传值

    2.1 静态传值

    2.2 动态传值

    2.3 es6模板传值

    2.4 传多个值

    2.5 get 传值

     三、配置子路由

    四、编程式路由

    4.1 同级路由跳转

    4.2 子父路由跳转


    一、路由配置

    • 1.安装路由
    cnpm install react-router-dom –save
    • 2.配置路由

    新建一个Main文件来封装路由,创建三个组件Home.jsx,News.jsx,My.jsx,在main.jsx 文件中配置这三个组件的路由

    配置路由时要先导入路由,最后要在App.js中导入Main.jsx

    import {BrowserRouter as Router,Route,Link} from "react-router-dom"
    import React,{Component} from "react";
    
    //在哪使用路由 就在哪导入路由
    import {BrowserRouter as Router,Route,Link} from "react-router-dom"
    
    //导入组件
    import Home from "./Home";
    import News from "./News";
    import My from "./My";
    
    class Main extends Component {
        constructor(props) {
            super(props);
            this.state = {  };
        }
        render() {
            return (
                <Router>
                   {/* 路由入口 */}
                <Link to="/">Home</Link>
                <Link to="/news">News</Link>
                <Link to="/my">My</Link>
    
                   {/* 配置路由 */}
                <Route path="/" component={Home}></Route>
                <Route path="/news" component={News}></Route>
                <Route path="/my" component={My}></Route>
                </Router>
            );
        }
    }
    
    export default Main;

    二、路由传值

    2.1 静态传值

    import React,{Component} from "react";
    
    //在哪使用路由 就在哪导入路由
    import {BrowserRouter as Router,Route,Link} from "react-router-dom"
    
    //导入组件
    import Home from "./Home";
    import News from "./News";
    import My from "./My";
    
    class Main extends Component {
        constructor(props) {
            super(props);
            this.state = {  
               
            };
        }
        render() {
            return (
                <Router>
                   {/* 路由入口 */}
                <Link to="/">Home</Link>
                {/* 1.固定传值 */}
                <Link to="/news/1">News</Link> 
                <Link to="/my">My</Link>
                   {/* 配置路由 */}
                <Route path="/" component={Home}></Route>
                <Route path="/news/:id" component={News}></Route>
                <Route path="/my" component={My}></Route>
                </Router>
            );
        }
    }
    
    export default Main;

    2.2 动态传值

    import React,{Component} from "react";
    
    //在哪使用路由 就在哪导入路由
    import {BrowserRouter as Router,Route,Link} from "react-router-dom"
    
    //导入组件
    import Home from "./Home";
    import News from "./News";
    import My from "./My";
    
    class Main extends Component {
        constructor(props) {
            super(props);
            this.state = {  
                id:10,
               
            };
        }
        render() {
            return (
                <Router>
                   {/* 路由入口 */}
                <Link to="/">Home</Link>
                {/* 2.动态传值  + 拼接    在子组件中接收值*/}
                {/* <Link to={"/news/"+this.state.id}>News</Link> */}           
                <Link to="/my">My</Link>
    
                   {/* 配置路由 */}
                <Route path="/" component={Home}></Route>
                <Route path="/news/:id" component={News}></Route>
                <Route path="/my" component={My}></Route>
                </Router>
            );
        }
    }
    
    export default Main;

    2.3 es6模板传值

    import React,{Component} from "react";
    
    //在哪使用路由 就在哪导入路由
    import {BrowserRouter as Router,Route,Link} from "react-router-dom"
    
    //导入组件
    import Home from "./Home";
    import News from "./News";
    import My from "./My";
    
    class Main extends Component {
        constructor(props) {
            super(props);
            this.state = {  
                id:10,
            };
        }
        render() {
            return (
                <Router>
                   {/* 路由入口 */}
                <Link to="/">Home</Link>           
                {/* 3.es6模板传值 */}
                {/* ``不是单引号 tab上方的键 */}
                <Link to={`/news/${this.state.id}`}>News</Link> 
    
                <Link to="/my">My</Link>
    
                   {/* 配置路由 */}
                <Route path="/" component={Home}></Route>
                <Route path="/news/:id" component={News}></Route>
                <Route path="/my" component={My}></Route>
                </Router>
            );
        }
    }
    
    export default Main;

    2.4 传多个值

    import React,{Component} from "react";
    
    //在哪使用路由 就在哪导入路由
    import {BrowserRouter as Router,Route,Link} from "react-router-dom"
    
    //导入组件
    import Home from "./Home";
    import News from "./News";
    import My from "./My";
    
    class Main extends Component {
        constructor(props) {
            super(props);
            this.state = {  
                id:10,
                name:"jia"
            };
        }
        render() {
            return (
                <Router>
                   {/* 路由入口 */}
                <Link to="/">Home</Link>
                {/* 4.传多个值 */}
               <Link to={`/news/${this.state.id}/${this.state.name}`}>News</Link>  
                <Link to="/my">My</Link>
    
                   {/* 配置路由 */}
                <Route path="/" component={Home}></Route>
                <Route path="/news/:id/:name" component={News}></Route>
                <Route path="/my" component={My}></Route>
                </Router>
            );
        }
    }
    
    export default Main;

    以上几种方法在对应的组件中接收值

    渲染完成之后 接收传值   componentDidMount()生命周期

    import React,{Component} from "react";
    class News extends Component {
        constructor(props) {
            super(props);
            this.state = {  };
        }
    
        //渲染完成之后 接收传值
        componentDidMount(){
            console.log(this.props.match.params)
        }
        render() {
            return (
                <div>News</div>
            );
        }
    }
    
    export default News;

    2.5 get 传值

    相当于在路径上加?id=1

    import React,{Component} from "react";
    
    //在哪使用路由 就在哪导入路由
    import {BrowserRouter as Router,Route,Link} from "react-router-dom"
    
    //导入组件
    import Home from "./Home";
    import News from "./News";
    import My from "./My";
    
    class Main extends Component {
        constructor(props) {
            super(props);
            this.state = { };
        }
        render() {
            return (
                <Router>
                   {/* 路由入口 */}
                <Link to="/">Home</Link>
                <Link to="/news">News</Link>
    
                //get传值
                <Link to="/my/?id=1&name=2">My</Link>
    
                   {/* 配置路由 */}
                <Route path="/" component={Home}></Route>
                <Route path="/news/:id/:name" component={News}></Route>
                <Route path="/my" component={My}></Route>
                </Router>
            );
        }
    }
    
    export default Main;

    在My.jsx组件中接收值

    对于这样的值可以自己写算法解析  也可以导入node的url模块进行解析

    算法解析

    import React,{Component} from "react";
    class My extends Component {
        constructor(props) {
            super(props);
            this.state = {  };
        }
        componentDidMount(){
            console.log(this.props.location.search) //?id=1&name=2
           // 对于这样的值可以自己写方法解析  也可以导入node的url模块进行解析
           let url=this.props.location.search;
           this.changeUrl(url);
        }
        changeUrl=(url)=>{
        let u=url.replace("?","");
        console.log(u)
        let ua=u.replace(/=/g,":").replace("&",",");
        console.log(ua)
        console.log(ua.split(",")[0].split(":")[1]);
        //把一个字符串分割成字符串数组:
        }
        render() {
            return (
                <div>My</div>
            );
        }
    }
    
    export default My;

    导入url模块解析

    安装url

    cnpm install url --save
    import React,{Component} from "react";
    
    //导入url
    import url from "url"
    
    class My extends Component {
        constructor(props) {
            super(props);
            this.state = {  };
        }
        componentDidMount(){
          console.log(this.props.location.search) //?id=1&name=2
          let localurl=this.props.location.search
          let src=url.parse(localurl,true)
          console.log(src)
        }
      
        render() {
            return (
                <div>My</div>
            );
        }
    }
    
    export default My;

     三、配置子路由

    import React,{Component} from "react";
    import {BrowserRouter as Router,Route,Link} from "react-router-dom";
    
    import Child from "./Child"
    class Home extends Component {
        constructor(props) {
            super(props);
            this.state = {  
                id:10
            };
        }
        render() {
            return (
                <div>Home
                 <Router>
                    <Link to={"/home/child/"+this.state.id}>child</Link>
                    <Route path="/home/child/:id" component={Child}></Route>
                 </Router>
                </div>
            );
        }
    }
    
    export default Home;

    四、编程式路由

    4.1 同级路由跳转

    在News.jsx组件中写编程式路由跳转到同级路由 My.jsx

    import React,{Component} from "react";
    class News extends Component {
        constructor(props) {
            super(props);
            this.state = {  };
        }
    
        //渲染完成之后 接收传值
        componentDidMount(){
            console.log(this.props.match.params)
        }
    
         //编程式路由  路由条状
         toMy=()=>{
                this.props.history.push("/my")
        }
        render() {
            return (          
                <div>
                    News
                    <button onClick={this.toMy}>跳转到同级路由</button>
                </div>
            );
        }
    }
    
    export default News;

    4.2 子父路由跳转

    从News.jsx组件跳到父路由组件Home.jsx,以及跳动同级路由My.jsx组件

    (不能跳转到爷路由)

    跳转路由时可以传参

    import React,{Component} from "react";
    import {BrowserRouter as Router,Route,Link} from "react-router-dom";
    
    import Child from "./Child";
    class News extends Component {
        constructor(props) {
            super(props);
            this.state = {  };
        }
    
        //渲染完成之后 接收传值
        componentDidMount(){
            console.log(this.props.match.params)
        }
    
         //编程式路由  路由跳转
         toHome=()=>{
             //跳转路由是可以传值
             this.props.history.push("/",{id:1})
            // this.props.history.push("/")
         }
    
         toMy=()=>{
            this.props.history.push("/my")
        }
        
        render() {
            return (          
                <div>
                    News
                    <button onClick={this.toHome}>跳转到父级路由</button>
    
                    <button onClick={this.toMy}>跳转到同级路由</button>
    
                    <Router>
                    <Link to={"/news/child"}>child</Link>
                    <Route exact path="/news/child" component={Child}></Route>
                 </Router>
                </div>
                    
            );
        }
    }
    
    export default News;

     

    展开全文
  • 静态路由配置与管理 静态路由是一种最简单的路由,需手工配置,用一条指令指定静态路由的目的IP地址、子网掩码、下一跳IP地址,或者出接口、优先级等主要参数值就可以了。还可根据实际需要配置静态路由与BFD或者NQA...

    静态路由配置与管理

    静态路由是一种最简单的路由,需手工配置,用一条指令指定静态路由的目的IP地址、子网掩码、下一跳IP地址,或者出接口、优先级等主要参数值就可以了。还可根据实际需要配置静态路由与BFD或者NQA的联动。

    一、路由基础

    “路由”简单说就是报文从源端到目的端的整条传输路径。当报文从路由器到目的网段有多条路由可达时,路由器可以根据路由表中最佳路由进行转发。最佳路由的选取与发现此路由的路由协议的优先级、所配置的路由度量有关。当多条路由的协议优先级与路由度量都有关系时,可以实现负载分担;当多条路由的协议优先级与路由度量不同时,可以构成路由备份,提高网络的可靠性

    一)路由的分类

    根据路由的来源不同,可把路由分为以下三大类:

    ①通过链路层协议发现的路由称为直连路由(Direct),不需要配置

    ②通过网络管理员手动配置的路由称为静态路由(Static)。

    ③通过动态路由协议发现的路由称为动态路由(分为RIPOSPFIS-ISBGP等多种)

    “静态路由”是一种特殊的路由,因为它没有自己的路由算法,不能自动生成,纯粹靠管理员为它们一级级指明下一跳路径,所以静态路由的运行和维护比较简单,适用拓扑结构简单且稳定的小型网络,或中大型网络中动态路由的补充。缺点是不能自动适应网络拓扑的变化(不具有主动网络收敛功能)。

    “动态路由”有自己的路由算法,能够根据用户配置自动生成对应的动态路由表项,且能够主动适应网络拓扑的变化,更适用于具有一定数量三层设备的网络。

    根据采用的不同路由算法,动态路由协议又有RIPRouting Information Protocol,路由信息协议)、OSPFOpenShortest Path First,开放最短路径优先)、IS-ISIntermedia System-Intermedia System,中间系统到中间系统)和BGPBorderGateway Protocol,边界网关协议)。根据作用范围不同,这些动态路由协议可分为以下两种:

    IGPInteriorGateway Protocol,内部网关协议):在一个自治系统内部运行。常见的IGP包括RIPOSPFIS-IS

    EGPExterior GatewayProtocol,外部网关协议):运行于不同自治系统之间,目前常见的EGP就是BGP

    根据使用的路由算法不同,动态路由协议又可分为以下两种:

    ①距离矢量协议(Distance-VectorProtocol):包括RIPBGPBGP也被称为路径矢量协议(Path-Vector Protocol)。

    ②链路状态协议(Link-StateProtocol):包括OSPFIS-IS

    当网络规模比较大,使用多种路由协议时,不同的路由协议间通常需要发布其他路由协议发现的路由,各动态路由协议都可以引入其他路由协议的路由,包括直连路由和静态路由,但直连路由和静态路由不能引入其他类型的路由

    二)路由表和FIB

    路由器在进行报文转发过程中要依据两种“表”——路由表(RoutingTable)和FIBForwarding Information Base,转发信息库)表。路由器通过路由表选择用于报文转发的路由,然后通过FIB表中对应转发表项指导报文的转发。

    1、路由表

    每台运行动态路由协议的路由器中都至少有两张“路由表”,一张是保存了所有最佳路由表项的本地核心路由表(即通常说的IP路由表),另一张则是保存对应路由协议路由表项的协议路由表,如RIP路由表、BGP路由表等。

    1)本地核心路由表

    “本地核心路由表”用来保存本地路由器到达网络中各目的地的当前各种最佳(依据到达同一目的地的各种协议路由的优先级和度量值来选取优先路由)协议路由(包括直连路由、静态路由和各种动态路由),只有到达某一目的地的最佳路由才会在本地核心路由表中出现,并负责把这些最佳路由下发到FIB表,生成对应的FIB表项,指导报文的转发

    对于支持L3VPNLayer 3Virtual Private Network,三层VPN)的路由器,每个VPN-Instance拥有一个自己的本地核心路由表。

    2)协议路由表

    协议路由表中存放着该协议已发现的所有路由信息,但就所有路由表来说,协议路由表中的路由不一定是最佳路由,也就是说不一定会最终用来进行数据报文路由。路由协议可以引入并发布其他协议生成的路由。如在路由器上运行OSPF协议,需要使用OSPF协议通告直连路由、静态路由或者IS-IS路由时,则要先将这些路由引入OSPF协议的路由表

    在路由器中执行displayip routing-table命令可查看路由器的IP路由表信息(均为有效的最佳路由,非有效、最佳路由不会在IP路由表中显示)。

    IP路由表中包含了下列字段:

    Destination表示此路由的目的地址。用来标识IP包的目的地址或者目的网络。

    Mask表示此目的地址的子网掩码长度。与目的地址一起来标识目的主机或目的网络所在的网段地址。

    Proto表示学习此路由的路由协议,包括静态路由(Static)、直连路由(Direct)和各种动态路由。

    PrePreference,表示此路由的路由协议优先级。这是用来比较不同协议类型、相同目的地址的多条路由的优先级。同一目的地址可能存在不同的下一跳、出接口等多条路由,这些不同的路由可能是由不同的路由协议发现的,也可以是手工配置的静态路由。优先级高(数值小)者将成为当前的最佳路由

    Cost路由开销,这是用来比较同一种协议类型、相同目的地址的多条路由的优先级。但不同类型协议路由的开销类型不同,如距离矢量协议采用的是“距离”,即将“跳数”作为路由开销,而链路状态协议采用的是“链路状态”(由链路带宽、网络传输性能等参数共同决定)作为路由开销。当到达同一目的地的多条路由具有相同的路由优先级时,路由开销最小的将成为当前的最佳路由。

    NextHop表示此路由的下一跳IP地址。指明数据转发路径中的下一个三层设备

    Interface表示此路由从本地设备发出的出接口。

    如下图的网络中,路由器A3个网络直接相连,因此在其IP路由表中有2个目的IP地址、下一跳和出接口的直连路由。

    2FIB表的匹配

    IP路由表选择好要使用的路由表项后,IP路由表会将这些路由表项下发到FIB表中,以生成对应的FIB表项(所以FIB表中的表项是与IP路由表中的表项有对应关系的)。当对应目的地址的报文到达路由器时,会通过查找FIB表中的对应项进行转发FIB表中每条表项都指明到达某网段或某主机的报文应通过路由器的哪个物理接口或逻辑接口发送,这样就可到达该路径的下一个路由器,或者不再经过别的路由器而传送到直接相连的网络中的目的主机。可使用displayfib命令查看FIB表信息。

    FIB表中包括DestinationMaskNexthopFlagTimeStampInterfaceTunnelID字段,其中DestinationMaskNexthopInterface字段是与IP路由表的对应字段一样,其他3个字段说明:

    Flag转发表项的标志,可能是GHUSDBL中一个或多字母组合。

    GGateway网关路由):表示下一跳是网关。

    HHost主机路由):表示该路由为主机路由。

    UUp可用路由):表示该路由状态是Up

    SStatic静态路由):表示该路由为手动配置路由。

    DDynamic 动态路由):表示该路由为根据路由算法自动生成路由。

    BBlack Hole 黑洞路由):表示下一跳是空接口。

    LVlink Route):表示Vlink类型路由

    TimeStamp转发表项的时间戳,表示该表项已存在的时间,单位是s

    TunnelID表示转发表项索引。该值不为0时,表示匹配该项的报文通过对应的隧道进行转发。该值为0时,表示报文不通过隧道转发。

    因为在IP封装中,IP报头只封装了源IP地址和目的IP地址,没有封装对应的子网掩码,所以这时如果在FIB表中有多条同时到达同一目的地,但处于相同自然网段的子网转发项时,就涉及最终选择哪条转发表的问题了。这就是FIB表中的“最长掩码”匹配原则,也即最精细路由匹配原则。具体方法是,在查找FIB表时,先将报文的目的地址与FIB中各表项的掩码按位进行“逻辑与”运算,得到匹配的网络地址(可能有多个),然后在这些对应的FIB表项中选择一个最长掩码的FIB表项进行报文转发。

    如上例FIB表,假如有一个目的地址是“9.1.2.1”的报文进入路由器,首先,将目的地址:9.1.2.1FIB表中各表项的掩码长度“0816”所对应的掩码进行“逻辑与”,得到下面几个网段地址:0.0.0.0/09.0.0.0/89.1.0.0/16。根据最长掩码匹配原则,最终选择9.1.0.0/16表项从接口GE2/0/0转发报文。

    实际上FIB表项只选择与报文中的目的地址第一个八位组相同的各子网和自然网段的转发表项,再加上所有缺省路由转发表项,从中选择子网掩码最长的转发。

    三)路由协议的优先级

    对于不同的目的地,不同的路由协议(包括静态路由)可能发现不同的路由,但在某一时刻,到某一目的地的当前路由仅能由唯一的路由协议来决定。为了判断最佳路由,各路由协议都被赋予一个优先级,当存在多个路由信息源时,具有较高优先级(取值较小)的路由协议发现的路由将成为最佳路由,并将最佳路由放入IP路由表中。

    路由协议的优先级又分“外部优先级”和“内部优先级”两种选择路由时比较路由的外部优先级,当不同的路由协议配置了相同的外部优先级时,系统才会通过内部优先级决定哪个路由协议发现的路由(内部优先级最高的)将成为最佳路由

    外部优先级是指用户可以手动为各路由协议配置的优先级,我们通常所说的路由协议优先级就是指外部优先级。缺省各路由协议的外部优先级如下(优先级数值越小,优先级越高):

    0表示直接连接的路由,255表示任何来自不可信源端的路由,静态路由的优先级比OSPFIS-IS中的路由优先级要低(这点与Cisco中的不一样)。除直连路由(DIRECT)外,各种路由协议的优先级都可以由用户手动进行配置。

    路由协议的内部优先级则不能被用户手动修改,仅当到达同一目的地的多条路由的外部优先级相同时才会比较他们的内部优先级。

    例如到达同一目的地10.1.1.0/24有两条路由可供选择,一条静态路由,一条OSPF路由,且这两条路由的外部优先级都被配置为5,则根据内部优先级进行判断,因为OSPF协议的内部优先级是10,高于静态路由的内部优先级60,选择OSPF协议路由为最佳路由。

    四)负载分担与路由备份

    当多条路由的路由优先级和路由度量都相同,这几条路由就称为等价路由多条等价路由可以实现负载分担。当几条路由为非等价路由时,就可以实现路由备份

    1、负载分担

    路由器支持多路由模式,即允许配置多条目的地相同,且优先级也相同的路由。当到达同一目的地存在同一路由协议发现的多条路由时,且这几条路由的开销值也相同,那么就满足负载分担的条件。当实现负载分担时,路由器根据五元组(源IP地址、目的IP地址、源端口、目的端口、协议)进行转发。当五元组相同时,路由器总是选择与上次相同的下一跳IP地址发送报文;当五元组不同时,路由器会选择相对空闲的路径进行转发

    如上图,RouterA已经通过接口GE1/0/0转发到目的地址10.1.1.0/24的第一个报文P1,随后又需要分别转发报文到目的地址10.1.1.0/2410.2.1.0/24。其转发过程如下:

    ①当转发到达10.1.1.0/24的第2个报文P2时,发现此报文与到达10.1.1.0/24的第1个报文P1的五元组一致,所以之后到达该目的地的报文都从GE1/0/0转发。

    ②当转发到达10.2.1.0/24的第1个报文P1时,发现此报文与到达10.1.1.0/24的第一个报文P1的五元组不一致,所以选择较空闲的GE2/0/0转发,并且之后到达给目的地址的报文都从GE2/0/0转发。

    2、路由备份

    为提高网络的可靠性,可配置到同一目的地的多条路由,其中一条路由的优先级最高,作为主路由,其余作为备份路由。正常情况下,路由器采用主路由转发数据,主链路出现故障,主路由变为非激活,路由器选择备份路由中优先级最高的路由转发数据。

    五)路由的收敛

    路由收敛是指网络拓扑变化引起的通过重新计算路由而发生替代路由的行为。随着网络的融合区分服务的需求越来越强烈。某些路由指导关键业务(VoIP,视频会议,组播等)转发,关键业务路由需要尽快收敛。系统需要对不同路由按不同的收敛优先级处理。

    按优先级收敛是指系统为路由设置不同的收敛优先级,从高到低分别为critical(临界)、high(高)、medium(中)、low(低)4种。

    如下图所示,网络上运行OSPFIS-IS协议,组播接受者在RouterA端,组播源服务器10.10.10.10/32RouterB端,要求到组播服务器的路由优先于其他路由收敛。这时可以配置路由10.10.10.10/32的收敛优先级高于路由12.10.10.0/24的收敛优先级,这样当网络路由重新收敛时,就能确保到组播源的路由10.10.10.10/32优先收敛,保证组播业务的转发。

    二、静态路由基础

    静态路由是一种需要手动配置的特殊路由,比动态路由使用更少的带宽,不占用CPU资源来计算和分析路由更新。但不会自动收敛。

    一)静态路由的组成

    静态路由包括5个主要参数:目的IP地址和子网掩码、出接口和下一跳IP地址、优先级。

    1、目的IP地址/子网掩码

    目的IP地址就是路由要到达的目的主机或目的网络的IP地址,子网掩码就是目的地址所对应的子网掩码。当目的地址和子网掩码都为零时,表示静态缺省路由

    2、根据不同的出接口类型,在配置静态路由时,可指定出接口,也可指定下一跳IP地址,还可以同时指定出接口和下一跳IP地址。

    ①对于点到点类型的接口(如PPP链接接口),只需指定出接口。当然也可同时指定下一跳IP地址,但这时已没有意义了。因为在点对点网络中,对端是唯一的,指定了发送接口即隐含指定可下一跳IP地址,这时认为与该接口相连的对端接口地址就是路由器的下一跳IP地址。

    ②对于NBMANonBroadcast Multiple Access,非广播多路访问)类型的接口(如FRATM接口),只需要配置下一跳IP地址。当然,也可同时指定出接口,但这时已没有意义,因为除了配置IP路由外,这类接口还需在链路层建立IP地址到链路层地址的映射,相当于指定了出接口。

    ③对于广播类型的接口(如以太网接口)和VTVirtual-Template)接口,必须指定下一跳IP地址,有些情况下还需要同时指定出接口。因为以太网接口是广播类型的接口,而VT接口下可以关联多个虚拟访问接口(Virtual Access Interface),这都会导致出现多个下一跳,无法唯一确定下一跳。而在广播型网络中,还可能有多个出接口到达同一个下一跳IP地址,此时就必须同时指定出接口。

    3、静态路由优先级

    对于不同的静态路由,可以配置不同的优先级。配置到达相同目的地的多条静态路由,如果指定相同优先级,则可实现负载分担;如果指定不同优先级,则可实现路由备份

    二)静态路由的主要特点

    1、手动配置

    2、路由路径相对固定:网络拓扑变动也不会修改,除非管理员修改

    3、不可通告性:静态路由信息在缺省情况下是私有的,不会主动通告给其他路由器,但管理员可以在本地设备的动态路由中引入静态路由,然后以对应动态协议路由进行通告,使得网络中其他路由器也可获此静态路由。

    4、单向性:静态路由具有单向性,它仅为数据提供沿着下一跳的方向进行路由,不提供反向路由。所以如果想要使源节点与目标节点或网络进行双向通信,必须同时配置回程静态路由。

    如果想使得PC1(已配置A节点IP地址10.16.1.2/24作为网关)能够pingPC2,必须同时配置以下两条静态路由:

    ①在R1上配置了到达PC2的正向静态路由(以PC210.16.3.2/24作为目标节点,以C节点IP地址10.16.2.2/24作为下一跳IP地址)

    ②在R2上配置到达PC1的回程静态路由(以PC110.16.1.1/24作为目标节点,以B节点IP地址10.16.2.1/24作为下一跳IP地址),以提供Ping过程回程ICMP消息的路由路径。

    5、接力性

    如果某条静态路由中间经过的跳数大于1(即整条路由路径经历了3个或3个以上路由器节点),则必须在除最后一个路由器外的其他路由器上依次配置到达相同目标节点或目标网络的静态路由,这就是静态路由的“接力”特性。

    路由器各端口上直接连接的各个网络都是直接互通的,因为他们之间缺省就有直连路由,无需另外配置其他路由,即连接在同一路由器的各网络之间的跳数为0。如上图,R1上连接了10.16.1.0/2410.16.2.0/24R2上连接10.16.2.0/2410.16.3.0/24网络,R3上连接了10.16.3.0/2410.16.4.0/24网络,都是直接互通的,所以不需要配置从R2R3路由器以及从R2R1路由器的静态路由。

    6、迭代性

    许多人存在一个错误认识:认为静态路由的“下一跳”必须是与本地路由器直接连接的下一个路由器接口,这是错误的!!!静态路由没有建立邻接关系的Hello包,静态路由也不会被通告邻居路由器,所以他的下一跳纯粹是由配置的“下一跳IP地址”直接指定的,或通过配置“出接口”间接指定。理论上说,静态路由的下一跳可以是路径中其他路由器中的任意一个接口,只是能保证到达下一跳就行了。这就是静态路由的“迭代性”。

    7、适用小型网络

    三、静态路由主要特性及应用

    IPv4静态路由的主要特性有静态缺省路由、静态路由与BFD联动、静态路由与NQA联动、静态路由优先级和静态路由永久发布。

    一)静态缺省路由

    缺省路由是另外一种特殊的路由,分静态缺省路由和动态缺省路由两类。缺省路由是没有在路由表中找到匹配的路由表项时才使用的候补路由。如果路由器中没有配置缺省路由,且报文的目的地址不在路由表中,那么该报文将被丢弃,并向源端返回一个ICMP报文,报告该目的地址或网络不可达

    在路由表中,缺省路由以到网络0.0.0.0(掩码也为0.0.0.0)的路由形式出现。可通过display ip routing-table查看。

    二)静态路由与BFD联动

    静态路由自身没有检测和网络收敛机制,可通过静态路由与BFD联动特性进行绑定,利用BFD会话来快速的检测静态路由所在链路的状态,实现毫秒级快速主备切换。

    1、当某条静态路由上的BFD会话检测到链路故障时,BFD会将故障上报系统,促使该路由失效,使该路由在IP路由表中不可见。

    2、当某条静态路由上的BFD会话检测到故障的链路重新建立成功时,BFD会上报系统,重新激活该条路由,使该路由重新出现在IP路由表中。

    三)静态路由与NQA联动

    在一些不支持BFD的链路环境中,可以通过把静态路由与NQA特性进行绑定来实现链路故障检测和快速的主备链路切换,且只要求互通设备的其中一端支持NQA即可,不受二层设备的限制。

    1、如果NQA检测例检测到链路故障,路由器将这条静态路由设置为“非激活”状态(从IP路由表中删除)

    2、如果NQA检测例检测到链路恢复,路由器将这条静态路由设置为“激活”状态(路由可用,并添加到IP路由表中)

    静态路由与NQA联动时仅采用ICMP测试例来检测源端到目的端的路由是否可达,且每条静态路由只可以绑定一个NQA测试例。

    四)静态路由优先级

    可以为不同静态路由配置不同的优先级,优先级值越小,对应的优先级越高。通过为多条到达同一目的地址的静态路由配置相同或不同的优先级,可分别实现多条相同目的地址的静态路由的负载分担和路由备份。

    1、负载分担

    如果到达相同目的地址的多条静态路由指定相同优先级,则可实现负载分担。

    2、路由备份

    如果到达相同目的地址的多条静态路由指定不同优先级,则可实现路由备份。

    10-8图是负载分担,两条路由均在IP路由表中存在,同时承担数据转发。10-9是路由备份,正常情况下,静态路由B被激活,主链路承担数据转发,静态路由D不在路由表中体现。

    1)主链路故障,静态路由B在路由表中被删除,静态路由D作为备份路由被激活,备份链路承担数据转发。

    2)主链路恢复后,静态路由B重新被激活,主链路承担数据转发。静态路由D在路由表中删除。这条备份路由也叫浮动静态路由

    五)静态路由永久发布

    静态路由永久发布为客户提供一种低成本、部署简单的链路检测机制,在客户希望确定业务流量的转发路径,不希望流量从其他路径穿越时,静态路由永久发布可以通过Ping静态路由目的地址的方式来测试链路的有效性而达到业务监控的目的。配置永久发布属性后,之前无法发布的静态路由仍然被优选并添加到IP路由表中。具体分两种情况:

    1)静态路由配置了出接口,且出接口的IP地址存在时,无论出接口的状态是U还是Down,只要配置了永久发布属性,则该静态路由都会被优选并添加到IP路由表。

    2)静态路由没有配置出接口时,无论静态路由是否能迭代到出接口,只要配置了永久发布属性,路由都会被优选并添加到IP路由表中。

    这样通过控制静态路由的优先级和前缀长度,使Ping报文始终通过静态路由转发,就可以检测出链路的有效性。但是,该特性不判断路由是否可达,而是一直会将静态路由保留在IP路由表中,如果实际路径不可达,静态路由可能形成黑洞路由。

    BR1BR2BR3分属ISP1ISP2ISP3.BR1BR2有两条链路(LinkALinkB)可达,但ISP1希望流量都通过LinkA直接转发到ISP2,而不从ISP3穿越。这时可以配置ISP1ISP2的静态路由为永久发布的。

    BR1BR2之间建立直连单跳EBGP邻居,同时为了进行业务状态监控,在BR1上配置到对端(BR2BGP邻居地址(10.1.1.2/24)的静态路由(吹摁扣为与BR2直连的本地接口),并使能路由永久发布。网络监控系统周期性的Ping 10.1.1.2,可通过Ping结果来判断LinkA的状态,进而间接的监控BGP业务状态。

    LinkA正常时,Ping数据包都通过LinkA进行转发。如LinkA故障,即使能通过LinkB到达BR2,但由于静态路由使能了静态路由永久发布,所以Ping数据包还是通过LinkA转发,此时不通。对于BGP数据包也是相同的情况,故障会导致BGP邻居断开,监控系统可以通过Ping结果间接地检测到业务问题,并通知维护人员。

    四、静态路由配置与管理

    静态路由的主要配置:

    ①创建静态路由

    ②(可选)配置静态路由的缺省优先级

    ③(可选)使能静态路由按递归深度优先选择

    ④(可选)配置静态路由永久发布

    ⑤(可选)静态路由与静态BFD联动

    ⑥(可选)静态路由与静态NQA联动

    一)配置静态路由基本功能

    静态路由基本功能包括以下配置任务

    1)创建静态路由

    在创建静态路由时,可以同时指定出接口和下一跳。对不同出接口类型,可以只指定出接口或只指定下一跳。

    ①对于点对点接口,只需指定出接口(可同时指定下一跳)

    ②对于NBMA接口,只需指定下一跳(可同时指定出接口)

    ③对于以太网接口和VT接口,必须指定下一跳(有时需同时指定出接口)

    2)(可选)配置静态路由的缺省优先级

    缺省优先级值(60),也可改变缺省优先级,以影响路由的选路顺序。

    3)(可选)使能静态路由按递归深度优先选择

    路由迭代是通过路由的下一跳信息来找到直连出接口的过程。迭代深度指路由迭代中查找路由的次数,次数越少迭代深度越小。当系统中存在若干条同一前缀,迭代深度不同的静态路由时,迭代深度较小的路由稳定性较高。配置了基于迭代深度的优选之后,系统会选择迭代深度较小的静态路由作为活跃路由,并下发FIB

    4)(可选)配置静态路由永久发布

    静态路由永久发布就是通过Ping静态路由目的地址的方式来检测链路的有效性。

    创建静态路由时要区分是在公共网络中创建,还是在具体的VPN实例网络中创建,不同类型网络中所允许携带的参数不同。


    二)配置静态路由与静态BFD联动

    在配置静态路由与静态BFD联动之前,需要配置好对应的静态BFD会话。

    BFD会话绑定仅可在公网(非特定VPN实例网络)静态路由进行配置,配置的方法很简单,在系统视图下执行ip route-static ip-address {mask | mask-length} {nexthop-address | interface-typeinterface-number [ nexthop-address]}[preference preference | tag tag]* track bfd-session cfg-name[description text]命令即可。参数track bfd-session cfg-name就是要指定用来与所指定的公网静态路由绑定的BFD会话名称(所绑定的静态BFD会话要事先配置好)。要确保BFD会话和静态路由在同一链路上。

    三)配置静态路由与NQA联动

    如果互联设备不支持BFD功能,可以配置静态路由与NQA联动,利用NQA测试例对链路状态进行检测,提高网络可靠性。NQA把测试两端称为客户端和目的端(或服务器端),并在客户端发起测试,目的端接收报文后,返回给源端(客户端)相应的回应信息。

    下表为配置步骤,2~8步为NQA测试例的创建与配置,第10步为静态路由与NQA测试例联动。



    四)静态路由管理

    display iprouting-table:查看IPv4路由表摘要信息

    display iprouting-table verbose:查看IPv4路由表详细信息。

    display bfdsession all verbose】:查看BFD会话信息

    displaycurrent-configuration | include bfd:查看静态路由与BFD联动的配置

    displaycurrent-configuration | include nqa:查看静态路由与NQA联动的配置

    display nqaresults collection】【test-instance admin-name test-name】:查看NQA测试结果。NQA测试不会在终端自动显示测试结果,必须使用本命令查看测试结果。

    五)静态路由配置示例

    上图的网络拓扑,要求通过配置静态路由实现不同网段的任意两台主机之间互通。

    1、基本配置思路

    静态路由配置主要是5个参数:目的IP/子网掩码、下一跳IP、出接口、优先级。另外在配置静态路由一定要注意单向性,也就是要使双方能互相访问,必须同时配置往返路径的两条静态路由。

    2、具体配置步骤

    ①配置各路由器接口IP,以RouterA上的接口为例

    ②配置静态路由,这里可以在RouterARouterC上仅通过配置缺省路由来实现(当然也可以用具体的静态路由),在RouterB上则分别配置到达PC1PC3所在网段的两条静态路由。

    ③配置主机PC1的缺省网关为1.1.1.1,主机PC2的缺省网关为1.1.2.1,主机PC3的缺省网关为1.1.3.1

    在各路由器上执行displayip routing-table

    IP路由表中的“Flags”是路由标记,可以是R(表示该路由是迭代路由)和D(表示该路由已下发到FIB表)字母,或者是它们的组合。但IP路由表中的所有路由均有D标记,因为它们都下发到FIB中。

    六)静态路由与BFD联动配置示例

    上图拓扑,RouterA通过配置静态路由,经由RouterB与外部相连,要求在RouterARouterB之间实现毫秒级故障感知。

    1、基本配置思路

    实现毫秒级故障感知,只有通过与BFD会话进行绑定。在RouterARouterB上分别创建双向BFD会话,并绑定ROuterA到达外部网络的静态路由(这种单一出口网络中可直接使用静态缺省路由)。

    2、具体配置步骤

    ①配置好各路由器接口IP

    [RouterA]interface gigabitethernet 1/0/0

    [RouterA-GigabitEthernet1/0/0]ip address 1.1.1.1 24

    ②在RouterA上配置与RouterB之间的BFD会话

    ③在RouterB上配置与RouterA之间的BFD会话。

    ④在RouterA上配置到外部网络的静态缺省路由,并绑定BFD会话

    [RouterA]ip route-static0.0.0.0 0.0.0.0 1.1.1.2 track bfd-session aa

    配置完后在RouterARouterB上执行displaybfd session all,可看到BFD会话已经建立且状态为Up。在系统视图下执行display current-configuration | include bfd,可看到静态路由已经绑定BFD会话。

    执行display iprouting-table

    RouterBGE1/0/0接口执行shutdown模拟故障,然后查看路由表,发现除了直连路由,静态缺省路由0.0.0.0/0不存在了。因为静态缺省路由绑定了BFD会话,当BFD检测到故障,会迅速通知所绑定的静态路由不可用。

     

    七)静态路由与NQA联动配置示例

    如上图拓扑,在RouterBRouterC上都配置了到用户交换机的静态路由,RouterB为主路由器,RouterC为备用路由器。正常情况下,SwitchA上的用户业务用流量走主用链路RouterB-àswitchA,主用链路故障切换到备用链路RouterCàSwitchA

    1、基本配置思路

    ①在各路由器上配置IP地址以及OSPF路由协议,并配置不同链路的路由开销值,最终使得RouterB为主用路由器,RouterC为备用路由器。

    ②在RouterBSwitchA之间建立ICMP类型的NQA测试例,同时分别配置RouterBRouterCSwitchA上连接的用户网络的静态路由,并将在RouterB配置的静态路由与NQA测试例联动。

    2、配置步骤

    ①配置各路由器的IP地址。

    [RouterA]interfacegigabitethernet 1/0/0

    [RouterA-GigabitEthernet1/0/0]ipaddress 172.16.3.1 24

    [RouterA-GigabitEthernet1/0/0]quit

    [RouterA]interfacegigabitethernet 2/0/0

    [RouterA-GigabitEthernet2/0/0]ipaddress 172.16.4.1 24

    ②在RouterARouterBRouterC上配置OSPF动态路由协议,使它们之间三层可达。(以RouterA为例)

    ③为了保证RouterA有到达用户网络的路由,需要在RouterBRouterC上配置OSPF动态路由协议引入静态路由,然后通告给RouterA。为了使RouterB成为主路由器,需要在RouterB引入静态路由时开销值更小。

    ④在RouterB上配置RouterBSwitchA之间的NQA ICMP测试例。

    ⑤在RouterBRouterC上分别配置到达SwitchA静态路由(在广播网络中要同时指定出接口和下一跳IP),但在RouterB上配置静态路由时要与配置的NQA ICMP测试例进行联动。

    [RouterB]ip route-static172.16.7.0 255.255.255.255.0 gigabitethernet 1/0/0 172.16.1.2 track nqa aa bb

    [RouterC]ip route-static172.16.7.0 255.255.255.0 gigabitethernet 3/0/0 172.16.6.2

    配置完后,在RouterB的系统视图下执行displaycurrent-configuration | include nqa,可看到静态路由已经绑定NQA测试例;执行displaynqa results命令可看到NQA测试例已经建立。

    通过display iprouting-table查看RouterB上的IP路由表:

    RouterA上查看IP路由表:

    从中可以看到有一条到172.16.7.0/24的路由,下一跳指向172.16.3.2cost值为10,因此业务流量会优先走链路RouterB—>SwitchA

    通过shutdown关闭RouterBGE1/0/0,通过displaynqa results查看NQA测试结果:

    此时在通过displayip routing-table查看RouterB上的IP路由表,发现原来的这条到达SwitchA的静态路由消失了,因为NQA已通知路由模块对应链路出现故障,所以路由模块立即删除这条静态路由。在RouterA上查看IP路由表:

    可以看到原来的路由消失了(Cost值为10,下一跳为172.16.3.2的路由),改为了通过SwitchC,因为RouterA仅能从RouterC处学习到通往172.16.7.0/24的路由了。

     

    展开全文
  • ~~ 静态路由配置和动态路由划分以及rip配置图解 ~~
  • BGP路由配置与管理 BGP是个复杂而又庞大的距离矢量类型动态路由协议,涉及非常复杂的配置。与RIP、OSPF、IS-IS路由协议属于内部网关协议(IGP)不同,BGP路由协议属于外部网关协议(EGP)。BGP本身不产生路由,而是...
  • ENSP配置 实例二 单臂路由配置 单臂路由配置 配置 路由: interface EigabitEthernet0/0/0 ip address 10.0.1.1 24 interface EigabitEthernet0/0/0.1 dot1q termination vid 10 ip address 192.168.1.254 24 arp...
  • 华为静态路由配置

    千次阅读 多人点赞 2019-11-12 09:11:59
    静态路由是由管理员手动配置和管理的路由,静态路由配置简单,因此,被广泛应用于结构简单网络中,静态路由还可以实现负载均衡与路由备份。 拓扑 PC1位于192.168.1.0网段,它的IP是192.168.1.2,网关是192.168....
  • zuul路由配置总结

    万次阅读 2018-06-01 20:51:37
    先说明两个概念:路由配置和路由规则,路由配置是指配置某请求路径路由到指定的目的地址;路由规则是指匹配到路由配置之后,再进行自定义的规则判断,规则判断可以更改路由目的地址 zuul的配置: 1. zuul默认的...
  • IP路由及静态路由配置

    千次阅读 2016-07-08 17:17:31
    IP路由及静态路由配置 一.IP路由: IP路由就是根据IP地址在不同网络之间转发数据的过程。它决定了IP数据包从 源网络到目的网络怎么走,也就是规划一条到目的地的路径。实现这个功能的设 备就是路由器,每个...
  • OSPF路由配置与管理 Ospf(开放式最短路径优先)是一个基于链路状态进行路由计算的动态路由协议,主要用于大中型网络。AR G3系列路由器支持OSPFv2和OSPFv3两种版本,OSPFv2仅支持IPv4,OSPFv3同时支持IPv4和IPv6。 ...
  • RIP路由配置与管理 RIP路由是最简单的动态路由协议,主要用于中小网络。基本配置仅需在各路由器上创建所需的RIP进程,然后宣告各RIP路由器接口直接连接的网段所对应的自然网段就可以把各接口上连接的网段路由向邻居...
  • #路由配置以及华为路由协议优先级

    万次阅读 2018-11-17 10:44:09
    #路由配置以及华为路由协议优先级 掌握目标 一、配置设备名称与 IP 地址: 二、配置静态路由 三、配置浮动路由用于备份 四、配置默认路由 五、了解华为不同路由协议的优先级 一、配置设备名称与 IP 地址: ...
  • 静态路由与默认路由配置 1、打开ensp,建立如下拓扑图 配置PC1的IP地址、子网掩码、网关 配置PC2的IP地址、子网掩码、网关 框选所有设备,点击启动 2、配置路由器R1 0端口:IP地址配置为20.0.0.1/24 1端口:IP...
  • R1和R2之间用静态路由配置,pc1和pc2之间用vlan 间单臂路由配置,pc1和pc2连接在一个交换机上,交换机连接一个路由器R1,R1与R2相连,R2与pc3相连,怎么配让三个都能互通,详细点,最好有图配置
  • RIP动态路由配置

    千次阅读 2019-05-01 16:55:23
    RIP动态路由配置 问题 在相对较小而且结构不变的网络中,静态路由是很好的解决方案,它配置简单而且不过多消耗设备资源(动态路由协议在运行时要消耗路由器内部资源,在与其他路由器更新信息时又会消耗网络资源)。 ...
  • Beego的路由配置

    万次阅读 2016-12-07 22:19:53
    Beego的路由配置
  • nginx 路由配置

    千次阅读 2018-09-08 17:37:41
    nginx 路由配置  nginx中location对url匹配;  语法:location [=|~|~*|^~] /uri/ { … }  当匹配中符合条件的location,则执行内部指令;如果使用正则表达式,必须使用~*表明不区分大小写或者~区分大小写匹配...
  • 浮动静态路由配置

    千次阅读 2018-08-08 16:18:37
    浮动路由配置 左边配置rip 右边边配置静态路由 在分支路由器router4上配置静态路由的AD(管理距离值) 管理距离的作用是:当一个网络出现多种路由协议的时候,并且每种路由协议都可以到达目的地,默认会走AD...
  • 三层交换机路由配置

    万次阅读 多人点赞 2018-03-10 16:18:05
    2.rip动态路由配置 3.ospf动态路由配置 4.默认路由配置 拓扑图: 步骤: 1.配置静态路由 一:给两台pc设置IP、掩码和网关 pc0:192.168.1.2 255.255.255.0 pc1:192.168.2.2 255.255.255.0 二:给两台...
  • 配置接口IP地址并通过静态路由、默认路由配置实现全网互通1.对Router-R1/R3进行默认路由配置,R2为静态路由配置 2.配置好PC机的IP地址,子网掩码,网关之后,开始配置路由R1/2/3/的IP地址。 <Huawei> //用户...
  • ENSP配置 实例三 静态路由配置

    千次阅读 2020-06-19 11:50:44
    ENSP配置 实例三 静态路由配置 R1配置命令 system-view [R1]interface Ethernet 0/0/0 [R1-Ethernet0/0/0]ip add 192.168.1.254 24 [R1-Ethernet0/0/0]quit [R1]interface tEthernet 0/0/1 [R1-Ethernet0/0/1]ip ...
  • zuul路由配置详解

    千次阅读 2018-09-10 08:03:02
    Spring Cloud 在 Zuul 的 routing 阶段实现了几个过滤器,这些过滤器决定如何进行路由工作。 简单路由(SimpleHostRoutingFilter...#zuul路由配置 zuul: routes: #表示http://localhost:9100/person/speaks地...
  • 静态路由配置练习

    千次阅读 2018-03-21 11:42:00
    静态路由的配置:  关于路由器配置之前要先了解一下什么是路由?  就我自己的话来说就是能够帮助信息正确,快速,合理选择路径的转发。那么路由器就相当这样的一个设备。...在静态路由配置命...
  • 思科路由模拟器 -- (1)路由配置

    万次阅读 2017-10-11 13:58:28
    本文主要是使用思科路由模拟器实现下文中的网络拓扑结构,了解路由器的使用方法、静态路由配置及默认路由配置。 需要解决的问题: (a)配置各路由器的各个接口IP地址,并测试直连链路的连通性; (b)先分析路由...
  • 华为路由器默认路由配置

    千次阅读 2019-05-01 00:43:15
    问题:配置接口IP地址并通过静态路由、默认路由配置实现全网互通。 1 配置路由器AR1端口0,IP地址配置为192.168.1.1、、端口1,IP地址配置为192.168.2.1路由器配置为默认路由,下一跳IP为192.168.2.2 2 配置路由器AR3...
  • vue-router——路由配置及动态路由

    千次阅读 2019-08-13 12:12:39
    路由配置 动态路由 动态路由参数获取 两种使用方式: CDN引入:直接使用 <script src='https://unpkg.com/vue-router/dist/vue-router.js'></script> NPM下载:需要配置 npm install vue-r...
  • 路由之静态路由配置

    2020-08-13 19:29:25
    路由器之间的连接需要配置静态路由 首先创建一个局域网,给pc0和pc1分别配置ip地址。 创建三个不同网段的局域网分别给电脑配置ip地址,将三个连接到一个路由上。为路由器与局域网相连的端口,在路由器上配置...
  • Ionic4路由配置

    千次阅读 2019-01-18 10:56:14
    ionic 4路由配置方法: 步骤一:先新建一个page页面 $ ionic g page excute 步骤二:在tabs.module.ts里导入 import { ExcutePageModule } from ‘…/pages/sub/excute/excute.module’; @NgModule({ imports: [ ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 58,942
精华内容 23,576
关键字:

路由配置