精华内容
下载资源
问答
  • vlan划分

    2019-07-01 17:47:17
    文章目录vlan 划分 vlan 划分

    集中式办公的 vlan 划分

    可根据用途不同“连续”划分 【以 192.168.0.0/16为例】;

    • 用于工作站的地址段:192.168.0.0/24〜192.168.63.0/24 ; 这样连续有64个C类地址段,每个地址可以容纳253台计算机,一样可以支持 16000 个左右的计算机。在划分 VLAN 时,每个楼层根据工作站数量可以使用一个或多个 VLAN。
      一般不使用 192.168.0.0/24、192.168.1.0/24 这两个地址段
    • 用于服务器的地址段:192.168.128.0〜192.168.159.0/16 ;这样连续有32个C类地址段,每个地址可以容纳253台服务器,一共大约 8000 个地址,足以满足需要。
    • 用于 VPN 客户端的地址,192.168.160.0〜192.168.191.0/16 ,这样连续有32个C类地址段,足以满足VPN客房端访问需要。
    • 用于默认路由的地址。192.168.254.0/16 ,足够交换机 “上联” 路由器(或着防火墙与代理服务器)的“默认路由”使用,或着连接其它网络,在此有一个C类地址段就够了。
    • 在划分VLAN的时候,为每个VLAN设置一个相同的地址作为网关地址,例如,可以将每个网段的最后一个地址作为网关地址。如对于 192.168.0.0/16的网段,其网关地址是192.168.0.254 。这样划分的好处。
      • 当工作站的地址段不够时,可以继续使用192.168.64.0〜192.168.127.0/16 的地址段,而其它网段(如路由器或代理服务器、VPN客户端)有需要访问工作站的路由时,只需要添加192.168.0.0/18(代表292.168.160.0〜192.168.63.0/16)或着192.168.0.0/17(代表292.168.160.0〜192.168.127.0/16)一条静态路由就可以访问。
      • 在其它网段访问服务器时,只需添加 192.168.128.0/19一条静态路由就可以访问。
      • 这样划分后仍然有许多地址可以备用,即使大型网络,这样划分也可以满足需要。
      • 将最后一个地址作为网关地址,1〜253作为可用地址,这样人们在采用“手动方式”设置IP地址时,不容易冲突。如果将每一个地址作为网关地址,有可能人们在设置IP 地址时,设置第一个地址作为工作的地址,这样容易引起冲突。

    分散式 VLAN 划分

    • 工作站规划:
      以 172.16.0.0/12为例,划分VLAN:
    	市委楼: 172.16.11.0/24172.16.15.0/24
    	政府楼: 172.16.21.0/24172.16.25.0/24
    	政协楼: 172.16.31.0/24172.16.35.0/24
    	人事楼: 172.16.41.0/24172.16.45.0/24
    	西楼: 172.16.51.0/24172.16.53.0/24
    	东楼: 172.16.61.0/24172.16.63.0/24
    
    • 服务器地址规划:
      使用 172.17.0.0/16 的地址范围划分 VLAN:
    1.管理服务器地址:
    	1.1 服务器的底层管理地址 172.16.1.1172.16.1.5
    	1.2 安装虚拟化后的管理地址 172.16.1.101172.16.1.105
    2.应用服务器地址 172.16.2.0/24
    3.对外服务器地址 172.16.3.0/24
    
    • 交换机地址规划:
      使用 172.18.0.0/16 的地址范围划分 VLAN:
    1.每个楼都有一个汇聚交换机,每个楼层都有12个接入交换机
    2.核心交换机地址是 172.18.1.254 没有汇聚交换机
    3.
    	市委楼: 汇聚交换机172.18.1.10 各楼层交换机172.18.1.11172.18.1.19
    	政府楼: 核心交换机172.18.1.254 接入交换机 172.18.1.2199
    	政协楼: 汇聚交换机172.18.1.30 各楼层交换机172.18.1.31172.18.1.39
    	人事楼: 汇聚交换机172.18.1.40 各楼层交换机172.18.1.41172.18.1.49
    	西楼: 汇聚交换机172.18.1.50 各楼层交换机172.18.1.51172.18.1.53
    	东楼: 汇聚交换机172.18.1.60 各楼层交换机172.18.1.61172.18.1.62
    
    • 10.0.0.0/8 网段划分采用 10.(0~255).0.0/16这间的任一B类地址段
    	北京 10.1.0.0/16
    	南京 10.2.0.0/16
    	上海 10.3.0.0/16
    	东京 10.4.0.0/16
    	纽约 10.5.0.0/16
    1.工作站 划分 128 个 vlan 10.1.1.0/2410.1.127.0/24
    2.服务器 32 个 vlan 10.1.128.0/2410.1.159.0/24
    3.设备管理采用 10.1.252.0/2410.1.255.0/24
    4.保留地址 10.1.160.0/2410.1.251.0/24  一共 92C类地址
    5.vpn 地址 netmask 255.255.255.252 互联地址段 10.255.0.0/16
    
    展开全文
  • VLAN划分

    千次阅读 2018-12-17 15:30:28
    1.VLAN划分方式 可以基于接口、MAC地址、子网、网络层协议、匹配策略方式来划分VLAN。不同方式的VLAN划分比 较。 VLAN划分方式差异 1.VLAN划分方式 基于端口原理:根据交换设备的端口编号来划分VLAN。为交换机的每...
     1.VLAN划分方式
      可以基于接口、MAC地址、子网、网络层协议、匹配策略方式来划分VLAN。不同方式的VLAN划分比
    

    较。
    VLAN划分方式差异
    1.VLAN划分方式
    基于端口原理:根据交换设备的端口编号来划分VLAN。为交换机的每个端口配置不同PVID,即一个端口缺省属于的VLAN.
    优点:定义成员简单,
    缺点:成员移动需要重新配置VLAN。
    2.VLAN划分方式
    基于MAC地址
    原理:根据PC网卡的MAC地址来划分VLAN,MAC地址和 VLAN ID映射关系表。
    优点:PC移动位置可以变更。
    缺点:PC网卡不能轻易变更且MLAN成员需预先定义。
    3.VLAN划分方式
    基于子网原理:根据报文中的IP地址信息来划分VLAN.
    优点:减轻配置任务,利于管理。
    缺点:需要提前做好地址规划。
    4.VLAN划分方式
    基于协议原理:根据接口接收到的报文所属的协议(族)类型及封装格式来划分VLAN.配置以太网帧中的协议域和VLAN ID的映射关系表。
    优点:方便管理和维护
    缺点:需要对所有网络类型与VLANID进行映射。
    5.VLAN划分方式
    基于匹配策略原理:基于MAC地址、IP地址、接口组合策略划分VLAN在交换机上配置终端的MAC地址和IP地址,并于VLAN关联。
    优点:安全性非常高
    缺点:每条策略均需手工配置
    2.VLAN划分方式的匹配优先级
    如果入方向 Untagged帧同时匹配多种划分VLAN的方式,则优先级顺序从高至低依次是:基于匹配策略
    划分VLAN>基于MAC地址划分VLAN或基于子网划分VLAN>基于协议划分VLAN>基于接口划分VLAN。
    (1)如果报文同时匹配了基于MAC地址划分VLAN和基于子网划分VLAN,缺省情况下,优先基于
    MAC地址划分VLAN。可以通过命令改变基于MAC地址划分VLAN和基于子网划分VLAN的优先级,从而
    决定优先划分VLAN的方式
    (2)基于接口划分VLAN的优先级最低,但却是最常用的VLAN划分方式…

    展开全文
  • VLan划分命令、详细的VLAN划分方法
  • vlan 划分

    2006-11-14 20:13:00
    如何配置三层交换机创建VLAN 以下的介绍都是基于Cisco交换机的VLAN。Cisco的VLAN实现通常是以端口为中心的,与节点相连的端口将确定它所驻留的VLAN。将端口分配给VLAN的方式有两种,分别是静态的和动态的. 形成静态...

     

    如何配置三层交换机创建VLAN

    以下的介绍都是基于Cisco交换机的VLAN。Cisco的VLAN实现通常是以端口为中心的,与节点相连的端口将确定它所驻留的VLAN。将端口分配给VLAN的方式有两种,分别是静态的和动态的.
    形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我们先在VTP (VLAN Trunking Protocol)Server上建立VLAN,然后将每个端口分配给相应的VLAN的过程。这是我们创建VLAN最常用的方法。
    动态VLAN形成很简单,由具体的机器决定自己属于哪个VLAN。即我们先建立一个VMPS(VLAN Membership Policy Server)VLAN管理策略服务器,里面包含一个文本文件,文件中存有与VLAN映射的MAC地址表。交换机根据这个映射表决定将端口分配给何种VLAN。这种方法有很大的优势,但创建数据库是一项非常艰苦而且非常繁琐的工作。

    下面以实例说明如何在一个典型的快速以太局域网中实现VLAN。

    所谓典型局域网就是指由一台具备三层交换功能的核心交换机接几台分支交换机(不一定具备三层交换能力)。我们假设核心交换机名称为:COM;分支交换机分别为:PAR1、PAR2、PAR3,分别通过Port 1的光线模块与核心交换机相连;并且假设VLAN名称分别为COUNTER、MARKET、MANAGING……

    需要做的工作:
    1、设置VTP DOMAIN(核心、分支交换机上都设置)
    2、配置中继(核心、分支交换机上都设置)
    3、创建VLAN(在server上设置)
    4、将交换机端口划入VLAN
    5、配置三层交换


    1、设置VTP DOMAIN。 VTP DOMAIN 称为管理域。

    交换VTP更新信息的所有交换机必须配置为相同的管理域。如果所有的交换机都以中继线相连,那么只要在核心交换机上设置一个管理域,网络上所有的交换机都加入该域,这样管理域里所有的交换机就能够了解彼此的VLAN列表。

    COM#vlan database 进入VLAN配置模式
    COM(vlan)#vtp domain COM 设置VTP管理域名称 COM
    COM(vlan)#vtp server 设置交换机为服务器模式

    PAR1#vlan database 进入VLAN配置模式
    PAR1(vlan)#vtp domain COM 设置VTP管理域名称COM
    PAR1(vlan)#vtp Client 设置交换机为客户端模式

    PAR2#vlan database 进入VLAN配置模式
    PAR2(vlan)#vtp domain COM 设置VTP管理域名称COM
    PAR2(vlan)#vtp Client 设置交换机为客户端模式

    PAR3#vlan database 进入VLAN配置模式
    PAR3(vlan)#vtp domain COM 设置VTP管理域名称COM
    PAR3(vlan)#vtp Client 设置交换机为客户端模式

    注意:这里设置核心交换机为Server模式是指允许在该交换机上创建、修改、删除VLAN及其他一些对整个VTP域的配置参数,同步本VTP域中其他交换机传递来的最新的VLAN信息;Client模式是指本交换机不能创建、删除、修改VLAN配置,也不能在NVRAM中存储VLAN配置,但可同步由本VTP域中其他交换机传递来的VLAN信息。

    2、配置中继为了保证管理域能够覆盖所有的分支交换机,必须配置中继。

    Cisco交换机能够支持任何介质作为中继线,为了实现中继可使用其特有的ISL标签。ISL(Inter-Switch Link)是一个在交换机之间、交换机与路由器之间及交换机与服务器之间传递多个VLAN信息及VLAN数据流的协议,通过在交换机直接相连的端口配置ISL封装,即可跨越交换机进行整个网络的VLAN分配和进行配置。

    在核心交换机端配置如下:

    COM(config)#interface gigabitEthernet 2/1
    COM(config-if)#switchport
    COM(config-if)#switchport trunk encapsulation isl 配置中继协议
    COM(config-if)#switchport mode trunk

    COM(config)#interface gigabitEthernet 2/2
    COM(config-if)#switchport
    COM(config-if)#switchport trunk encapsulation isl 配置中继协议
    COM(config-if)#switchport mode trunk

    COM(config)#interface gigabitEthernet 2/3
    COM(config-if)#switchport
    COM(config-if)#switchport trunk encapsulation isl 配置中继协议
    COM(config-if)#switchport mode trunk

    在分支交换机端配置如下:

    PAR1(config)#interface gigabitEthernet 0/1
    PAR1(config-if)#switchport mode trunk

    PAR2(config)#interface gigabitEthernet 0/1
    PAR2(config-if)#switchport mode trunk

    PAR3(config)#interface gigabitEthernet 0/1
    PAR3(config-if)#switchport mode trunk

    ……

    此时,管理域算是设置完毕了。


    3、创建VLAN一旦建立了管理域,就可以创建VLAN了。

    COM(vlan)#Vlan 10 name COUNTER 创建了一个编号为10 名字为COUNTER的 VLAN
    COM(vlan)#Vlan 11 name MARKET 创建了一个编号为11 名字为MARKET的 VLAN
    COM(vlan)#Vlan 12 name MANAGING 创建了一个编号为12 名字为MANAGING的 VLAN

    ……

    注意,这里的VLAN是在核心交换机上建立的,其实,只要是在管理域中的任何一台VTP 属性为Server的交换机上建立VLAN,它就会通过VTP通告整个管理域中的所有的交换机。但如果要将具体的交换机端口划入某个VLAN,就必须在该端口所属的交换机上进行设置。


    4、将交换机端口划入VLAN

    例如,要将PAR1、PAR2、PAR3……分支交换机的端口1划入COUNTER VLAN,端口2划入MARKET VLAN,端口3划入MANAGING VLAN……

    PAR1(config)#interface fastEthernet 0/1 配置端口1
    PAR1(config-if)#switchport access vlan 10 归属COUNTER VLAN

    PAR1(config)#interface fastEthernet 0/2 配置端口2
    PAR1(config-if)#switchport access vlan 11 归属MARKET VLAN

    PAR1(config)#interface fastEthernet 0/3 配置端口3
    PAR1(config-if)#switchport access vlan 12 归属MANAGING VLAN


    PAR2(config)#interface fastEthernet 0/1 配置端口1
    PAR2(config-if)#switchport access vlan 10 归属COUNTER VLAN

    PAR2(config)#interface fastEthernet 0/2 配置端口2
    PAR2(config-if)#switchport access vlan 11 归属MARKET VLAN

    PAR2(config)#interface fastEthernet 0/3 配置端口3
    PAR2(config-if)#switchport access vlan 12 归属MANAGING VLAN


    PAR3(config)#interface fastEthernet 0/1 配置端口1
    PAR3(config-if)#switchport access vlan 10 归属COUNTER VLAN

    PAR3(config)#interface fastEthernet 0/2 配置端口2
    PAR3(config-if)#switchport access vlan 11 归属MARKET VLAN

    PAR3(config)#interface fastEthernet 0/3 配置端口3
    PAR3(config-if)#switchport access vlan 12 归属MANAGING VLAN

    ……


    5、配置三层交换

    到这里,VLAN已经基本划分完毕。但是,VLAN间如何实现三层(网络层)交换呢?这时就要给各VLAN分配网络(IP)地址了。给VLAN分配IP地址分两种情况,其一,给VLAN所有的节点分配静态IP地址;其二,给VLAN所有的节点分配动态IP地址。下面就这两种情况分别介绍。

    假设给VLAN COUNTER分配的接口Ip地址为172.16.58.1/24,网络地址为:172.16.58.0,
    VLAN MARKET 分配的接口Ip地址为172.16.59.1/24,网络地址为:172.16.59.0,
    VLAN MANAGING分配接口Ip地址为172.16.60.1/24, 网络地址为172.16.60.0
    ……
    如果动态分配IP地址,则设网络上的DHCP服务器IP地址为172.16.1.11。

    (1)给VLAN所有的节点分配静态IP地址。

    首先在核心交换机上分别设置各VLAN的接口IP地址。核心交换机将vlan做为一种接口对待,就象路由器上的一样,如下所示:

    COM(config)#interface vlan 10
    COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP

    COM(config)#interface vlan 11
    COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP

    COM(config)#interface vlan 12
    COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP

    ……

    再在各接入VLAN的计算机上设置与所属VLAN的网络地址一致的IP地址,并且把默认网关设置为该VLAN的接口地址。这样,所有的VLAN也可以互访了。

    (2)给VLAN所有的节点分配动态IP地址。

    首先在核心交换机上分别设置各VLAN的接口IP地址和同样的DHCP服务器的IP地址,如下所示:

    COM(config)#interface vlan 10
    COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP
    COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

    COM(config)#interface vlan 11
    COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP
    COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

    COM(config)#interface vlan 12
    COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP
    COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

    ……

    再在DHCP服务器上设置网络地址分别为172.16.58.0,172.16.59.0,172.16.60.0的作用域,并将这些作用域的“路由器”选项设置为对应VLAN的接口IP地址。这样,可以保证所有的VLAN也可以互访了。

    最后在各接入VLAN的计算机进行网络设置,将IP地址选项设置为自动获得IP地址即可。

    展开全文
  • VLAN划分与互联.ppt

    2019-09-08 19:20:07
    VLAN划分方法 基于端口划分的VLAN 基于MAC地址划分VLAN 基于网络层协议划分VLAN 根据IP组播划分VLAN
  • VLAN划分实验

    2020-11-21 08:16:06
    VLAN划分实验 如下图四台PC的网段均为192.168.1.0/24.,在末划分vlan前都可以相互平通,在这里我就不测试了,读者可以自行测试。 任务:把vlan10划分到PC1和PC4,vlan20划分到PC2和PC3 命名交换机为S1,S2 测试PC1和...

    VLAN划分实验

    • 如下图四台PC的网段均为192.168.1.0/24.,在末划分vlan前都可以相互平通,在这里我就不测试了,读者可以自行测试。
    • 任务:把vlan10划分到PC1和PC4,vlan20划分到PC2和PC3
    • 命名交换机为S1,S2
    • 测试PC1和PC4能ping通
    • P1和PC2不能ping通
    • 注:记得打开两台交换机之间的trunk
    • int f0/24
    • switchport mode trunk

    在这里插入图片描述

    • S1的配置
    Switch>enable 
    Switch#conf
    Switch#configure 
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#host S1
    S1(config)#vlan 10
    S1(config-vlan)#int vlan 10
    S1(config-if)#
    %LINK-5-CHANGED: Interface Vlan10, changed state to up
    S1(config-if)#exit
    S1(config)#vlan 20
    S1(config-vlan)#int vlan 20
    S1(config-if)#
    %LINK-5-CHANGED: Interface Vlan20, changed state to up
    S1(config-if)#exit
    S1(config)#int f0/1
    S1(config-if)#switchport access vlan 10
    S1(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    S1(config-if)#int f0/2
    S1(config-if)#switchport access vlan 20
    S1(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
    S1(config-if)#
    S1(config-if)#int f0/24
    S1(config-if)#switchport mode trunk 
    S1(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
    S1(config-if)#
    
    • S2的配置
    Switch>enable 
    Switch#configure 
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#host S2
    S2(config)#vlan 10
    S2(config-vlan)#int vlan 10
    S2(config-if)#
    %LINK-5-CHANGED: Interface Vlan10, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    S2(config-if)#vlan 20
    S2(config-vlan)#int vlan 20
    S2(config-if)#
    %LINK-5-CHANGED: Interface Vlan20, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
    S2(config-if)#int f0/2
    S2(config-if)#switchport access vlan 10
    S2(config-if)#
    S2(config-if)#int f0/1
    S2(config-if)#switchport access vlan 20
    S2(config-if)#
    S2(config-if)#
    
    • 命令配置完后先测试PC1ping PC2是不通的
      在这里插入图片描述
    • PC1和PC4能通
    • PC2和PC3能通

    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • (2)掌握VLAN的原理及基于交换机端口的VLAN划分方法。实验设备:交换机一台,主机四台,直通线四根实验步骤:1、给交换机划分VLAN100和VLAN200。(1)打开交换机的命令操作行,首先进入特权模式下Switch>enable(2)...
  • 本文将详细介绍思科2950交换机VLAN划分,需要的朋友可以参考下
  • 在实际工程中,VLAN划分和子网划分是同时进行的,通常情况下,一个VLAN对应一个子网,不同的VLAN和子网之间没有路由是无法进行通信的,需要经过三层交换机实现不同VLAN之间的通信。 划分VLAN的原因 使用交换机组成的...
  • vlan划分和子网划分的区别: VLAN是二层的,子网是三层的。 VLAN可以有很多种方式划分,基于IP,基于端口甚至基于协议,而子网只能通过掩码划分。 VLAN能够将广播进行隔离,较子网具有更高的安全性。 vlan是可以隔离...
  • vlan划分实验报告计算机网络实验报告实验名称: VLAN划分实验分组号:实 验 人:班 级:学 号:实验指导教师:实验场地:实验时间:成 绩:一、实验目的1、掌握VLAN原理2、熟练掌握二层交换机VLAN的划分方法二、实验...
  • 一、VLAN划分实验 1.创建VLAN Switch>enable Switch#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan 10 //创建vlan 10 Switch(config-vlan)#name tes.....
  • VLAN划分 划分VLaN其实是分割广播域,把一个大的广播域划分成更多小的广播域,一个VLAN就是一个广播域,既然一个VLAN就是一个广播域,那么计算机之间的通信其实是通过MAC地址实现的,所以一个VLAN中的计算机想跟另外...
  • 交换机vlan划分

    2020-12-28 17:42:39
    交换机vlan划分 一、交换机 1.MAC地址由48为二进制数组成通常分为6段用16进制表示前24bits是供应商表示后24bits是网卡的唯一编号 2.以太网帧格式Ethernet II 帧格式 前导码(7字节)+帧起始定界符(1字节)+目的地址...
  • 交换机的vlan划分 vlan即虚拟局域网,交换机的不同接口划分到不同的vlan下,则同一个vlan下的接口连接的计算机之间才能通信,不同vlan下的接口所连接的计算机之间是无法通讯的 单交换机的vlan划分 如图,交换机...
  • VLAN划分的方式:基于接口划分VLAN: 根据交换机接口分配VLAN ID。配置简单,可以用于各种场景。基于MAC划分VLAN: 根据报文的源MAC地址分配VLAN ID。经常用在用户位置变化,不需要重新配置VLAN的场景。基于子网划分...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,702
精华内容 1,880
关键字:

vlan划分