精华内容
下载资源
问答
  • PAGE PAGE 1 计算机网络与通信实验设计性综合性实验方案 实验1网络综合服务 实验目的 利用DHCPDNSIIS和简单网页制作的知识建立一个网络综合服务站点提高站点发布的综合能力 实验设备 交换机PC机 实验环境 实验步骤 ...
  • 《数据通信与计算机网络设计性实验指导书 数据通信与计算机网络 数据通信与计算机网络 数据通信与计算机网络
  • O 引言  局域网技术发展十分迅速,Ethernet (以太网)是目前使用广泛的局域网技术。... 计算机网络实验平台的硬件框图如图1所示,它主要由C805lF310、CS8900A和MAX232以及外围电路组成。  1.1 单片机C80
  • 针对当前计算机网络实验教学中设计与创新能力不足的问题,将python编程引入到计算机网络实验中,以提高学生网络实践能力和创新能力为目标,进行基于Python编程的层次式的网络实验项目设计,并对实验教学方法进行了探索。...
  • 计算机网络实验 ping程序设计 PING程序是我们使用的比较多的用于测试网络连通的程序。PING程序基于ICMP,使用ICMP的回送请求和回送应答来工作。由计算机网络课程知道,ICMP是基于IP的一个协议,ICMP包通过IP的封装...
  • 1.1需求分析 想要设计与开发出计算机网络虚拟实验平台教学必须在系统有足够的发展空间基础上来进行[1]因此在对此平台开发以及后续部署时要对其给予高度的关注避免出现影响系统运行效率或实用等情况的出现基于此对...
  • 计算机网络是一门实践较强的技术,课堂教学应该和实践环节紧密结合。计算机网络实验培养学生具有独立进行计算机网络架构和设计能力,提高学生的网络设备使用水平,以及将理论与实践相结合的能力。 12.2 实验环境...
  • 计算机网络实验计算机网络基础课程中重要的实践环节是计算机网络基础课程不可分割的组成部分是将计算机网络的理论知识用于实践的重要过程是培养高技能应用人才不可缺少的重要手段之一本课程包括计算机网络的验证...
  • 本书是学习计算机网络课程的实验指导教材,全书由13个精心设计实验组成,其内容涵盖了异步串行通信、局域网组网技术、网络数据包捕获、路由技术,以及域名服务、Web服务、邮件服务和网络安全、网络仿真等内容。...
  • 基于eNSP的计算机网络实验 2019-05-13 11:06:34 tags: [eNSP] [计算机网络] 基于eNSP的相关计算机网络实验    这个实验记录随着学习进度的进行不断进行更新,主要为基于华为eNSP环境下进行的熟悉计算机网络的相关...

    基于eNSP的相关计算机网络实验


    2019-05-13 11:06:34

    更新的下一篇内容:基于eNSP结合实际操作的的计算机网络实验(二)
    next:实验(三)
    终结篇:实验(终章)


       这个实验记录随着学习进度的进行不断进行更新,主要为基于华为eNSP环境下进行的熟悉计算机网络的相关实验,这个实验主要为熟悉掌握计算机网络的结构和工作原理,深入理解交换机、路由器、无限网络的工作原理,目前这个实验包括下面几个内容:

    • 单台PC机联通交换机的实验配置
    • 单台交换机上使用VLAN来隔离PC
    • 跨交换机实现不同VLAN的通信与隔离
    • 不同VLAN间实现通信

    实操图如下 (#_#)
    在这里插入图片描述
    在这里插入图片描述

    单台PC机联通交换机的实验配置

    相关操作如下所示:

    1. 进入系统视图
    2. 交换机接口配置
    3. 添加交换机虚拟ip
    4. 尝试ping

    在这里插入图片描述

       在eNSP上交换机的设置脚本如下所示:

    The device is running!
    
    <Huawei>
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]
    May 14 2019 10:26:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 4, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]
    May 14 2019 10:27:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]interface vlanif1
    [sw1-Vlanif1]ip address 10.10.10.6 255.255.255.0
    [sw1-Vlanif1]
    May 14 2019 10:28:58-08:00 sw1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
     on the interface Vlanif1 has entered the UP state.
    [sw1-Vlanif1]display currn
    May 14 2019 10:29:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 6, the c
    hange loop count is 0, and the maximum number of records is 409
    #
    sysname sw1
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
     ip address 10.10.10.6 255.255.255.0
    
    [sw1-Vlanif1] User interface con0 is available
    

    在这里插入图片描述

    在这里插入图片描述


    单台交换机上使用VLAN来隔离PC

    相关操作如下所示:

    1. 在单台交换机上使用不同的vlan域来对进行PC隔离
    2. 交换机端口配置
    3. 配置PC的ip地址
    4. 划分vlan区域

    在这里插入图片描述
       在eNSP上交换机的设置脚本如下所示:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]
    May 14 2019 10:33:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]
    May 14 2019 10:34:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 7, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]
    May 14 2019 10:34:27-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 9, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port link-type access
    [sw1-Ethernet0/0/3]
    May 14 2019 10:34:47-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 10, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/3]port default vlan 10
    [sw1-Ethernet0/0/3]
    May 14 2019 10:34:53-08:00 sw1 %%01IFNET/4/IF_STATE(l)[0]:Interface Vlanif1 has 
    turned into DOWN state.
    May 14 2019 10:34:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/3] User interface con0 is available
    

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    实现效果图如下所示:

    在这里插入图片描述


    跨交换机实现不同VLAN的通信与隔离

    相关操作如下所示:

    1. 配置两台交换机的接口VLAN
    2. 配置交换机与PC的端口连接
    3. 配置交换机端口间的连接方式
    4. 配置PC的ip地址
    5. 验证PC机两两之间的连通性

    在这里解释一下两台交换机之间进行的trunk,trunk是端口进行汇聚的意思,它允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行进行连接,同时传输来提供更高的带宽、更大的吞吐量,大幅度提高整个网络能力。VLAN trunk是指设置了多个VLAN之后,想通过一个端口来传输我们设置的多个VLAN,我们就需要在交换机这里设置这个端口为trunk。trunk技术使得一条物理线路可以传送多个VLAN的数据,更加具体的细节你想了解的话可以去查查资料。

    在这里插入图片描述
       在eNSP上交换机的设置脚本如下所示:

    <Huawei>sys 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]
    May 14 2019 10:38:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 4, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]port default v
    May 14 2019 10:39:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
                                      ^
    Error:Incomplete command found at '^' position.
    [sw1-Ethernet0/0/1]q
    [sw1]
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]
    May 14 2019 10:39:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 6, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]
    May 14 2019 10:39:47-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 7, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port defa
    May 14 2019 10:40:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 8, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-port-group-defa]port default vlan 20
    [sw1-port-group-defa]q
    [sw1]
    May 14 2019 10:40:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 9, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/2
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]int e
    May 14 2019 10:40:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 10, the 
    change loop count is 0, and the maximum number of records is 4095.
                       ^
    Error: Unrecognized command found at '^' position.
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port link-type trunk
    [sw1-Ethernet0/0/3]port trunk
    May 14 2019 10:43:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-port-group-trunk]port trunk allow-pass 
    May 14 2019 10:44:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 12, the 
    change loop count is 0, and the maximum number of records is 4095.
                                                ^
    Error:Incomplete command found at '^' position.
    [sw1-port-group-trunk]q
    [sw1]int e0/0/3
    [sw1-Ethernet0/0/3]port trunk allow-pass vlan 10 20
    [sw1-Ethernet0/0/3]
    May 14 2019 10:44:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 13, the 
    change loop count is 0, and the maximum number of records is 4095.
    

    另一个交换机的设置也是差不多的,这里就不展示了
    在这里插入图片描述

    在这里插入图片描述
    在这里插入图片描述

    不同VLAN间实现通信

    相关操作如下所示:

    1. 交换机接口配置
    2. 创建多个VLAN域
    3. 设置PC的ip地址、网关配置

    在这里插入图片描述
       在eNSP上交换机的设置脚本如下所示:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname sw1
    [sw1]
    May 14 2019 10:50:47-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 4, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]vlan batch 10 20
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]
    May 14 2019 10:50:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 5, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]
    May 14 2019 10:51:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 6, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/1]port default vlan 10
    [sw1-Ethernet0/0/1]int
    May 14 2019 10:51:37-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 7, the c
    hange loop count is 0, and the maximum number of records is 4095.
                       ^
    Error: Unrecognized command found at '^' position.
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port link-type access
    [sw1-Ethernet0/0/2]port 
    May 14 2019 10:51:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 8, the c
    hange loop count is 0, and the maximum number of records is 4095.
                            ^
    Error:Incomplete command found at '^' position.
    [sw1-Ethernet0/0/2]port default vlan 20
    [sw1-Ethernet0/0/2]
    May 14 2019 10:52:06-08:00 sw1 %%01IFNET/4/IF_STATE(l)[0]:Interface Vlanif1 has 
    turned into DOWN state.
    May 14 2019 10:52:07-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 9, the c
    hange loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/2]int vlanif10
    [sw1-Vlanif10]
    May 14 2019 10:52:21-08:00 sw1 %%01IFNET/4/IF_STATE(l)[1]:Interface Vlanif10 has
     turned into UP state.
    [sw1-Vlanif10]ip address 192.168.1.254 24
    [sw1-Vlanif10]
    May 14 2019 10:53:16-08:00 sw1 %%01IFNET/4/LINK_STATE(l)[2]:The line protocol IP
     on the interface Vlanif10 has entered the UP state.
    May 14 2019 10:53:17-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 10, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Vlanif10]int  vlanif20
    [sw1-Vlanif20]
    May 14 2019 10:53:28-08:00 sw1 %%01IFNET/4/IF_STATE(l)[3]:Interface Vlanif20 has
     turned into UP state.
    [sw1-Vlanif20]ip address 192.168.2.254 24
    [sw1-Vlanif20]
    May 14 2019 10:53:57-08:00 sw1 %%01IFNET/4/LINK_STATE(l)[4]:The line protocol IP
     on the interface Vlanif20 has entered the UP state.
    May 14 2019 10:53:57-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Vlanif20]q
    [sw1]display ip interface brief
    *down: administratively down
    ^down: standby
    (l): loopback
    (s): spoofing
    The number of interface that is UP in Physical is 3
    The number of interface that is DOWN in Physical is 2
    The number of interface that is UP in Protocol is 3
    The number of interface that is DOWN in Protocol is 2
    
    Interface                         IP Address/Mask      Physical   Protocol  
    MEth0/0/1                         unassigned           down       down      
    NULL0                             unassigned           up         up(s)     
    Vlanif1                           unassigned           down       down      
    Vlanif10                          192.168.1.254/24     up         up        
    Vlanif20                          192.168.2.254/24     up         up        
    [sw1]
    

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    总结: …等试验内容更完了再写

    展开全文
  • 计算机组网实验综合报告 网络工程设计 计算机组网实验综合报告 网络工程设计
  • 综合设计性实验报告网络故障与分析大型网络故障诊断与排除 综合设计性实验报告网络故障与分析大型网络故障诊断与排除 PAGE / NUMPAGES 综合设计性实验报告网络故障与分析大型网络故障诊断与排除 综合性设计性实验...
  • 计算机网络实验(园区网设计与实施)

    千次阅读 多人点赞 2019-08-03 12:03:58
    计算机网络》 一、设计任务 本任务模拟了一个企业网,该企业的组织架构如图1所示,企业总部设在上海,技术部和市场部分设在深圳和上海2个地方,各部门主机配置如表所示。 图1 公司组织架构图 在上海总部:...

    《计算机网络》

    一、设计任务
    本任务模拟了一个企业网,该企业的组织架构如图1所示,企业总部设在上海,技术部和市场部分设在深圳和上海2个地方,各部门主机配置如表所示。

    在这里插入图片描述
    图1 公司组织架构图

    在这里插入图片描述

    在上海总部:总经理室、公共事务部、财务部在一个楼层办公,技术部和市场部在另一个楼层办公;在深圳总部,所有部门在同一个楼层办公。为便于管理,每个部门划分一个 VLAN,技术部上海研发中心维护1台内部web服务器、1台应用程序服务器和2台数据库服务器(可选)。局域网路由器选用动态路由协议OSPF。

    二、基本思路及所涉及的相关理论
    1、基本思路:(1)划分子网(配置VLAN) (2)单臂路由配置 (3)接口封装(trunk) (4)配置VTP (5)配置三层交换机vlan间的通信 (6)配置合适的路由协议,实现全公司的互联(7)配置ACL(8)配置NAT
    2、相关理论:
    (1)VlAN即虚拟局域网。可以把同一个物理网络划分为多个逻辑网段。
    (2)VTP即VLAN中继协议。VTP通过网络保持VLAN配置统一性,只要在vtp server做相应设置,vtp client会自动学习vtp server上的相应信息。
    (3)ACL(访问控制列表),即根据数据包的报头中的IP地址、协议端口号等信息进行过滤,用它来设定访问权限。
    (4)三层交换机具备网络层的功能,利用三层交换机的路由功能,通过识别数据包的IP地址,查找路由表进行选路转发,三层交换机利用直连路由实现不同VLAN之间的相互访问。
    (5)单臂路由:是为实现VLAN间通信的三层网络设备路由器。它只需要一个以太网,通过创建子接口可以承担所有VLAN的网关。而在不同的VLAN间转发数据。
    (6)OSPF(开放式最短路径优先),是一个内部网关协议,用于在单一自治系统内决策路由。
    在这里插入图片描述
    三、方案设计(包含主要网络设备、网络拓扑结构设计图、方案的设计原理等)
    1、主要的网络设备:
    路由器(2811)3台、交换机(三层交换机1台和二层交换机3台)、主机35台、服务器2台、直连线、交叉线。
    2、网络拓扑结构设计图:

    3、方案的设计原理:
    根据任务要求,搭建网络,实现该企业的网络使用,根据公司部门将大概框架搭建起来,然后划分子网,配置VLAN,接着进行路由器和交换机的配置,选择合适的路由选择协议——OSPF实现真个网络的联通。

    四、实验步骤:
    1、基本配置:
    (1)为每台主机分配适当的IP地址及默认网关;为服务器配置IP地址及默认网关;配置路由器R0/R1/R5各接口;为设备各端口分配适当的IP地址,列表如下:
    在这里插入图片描述在这里插入图片描述
    (3)为交换机Switch0、 Switch1 、Switch2 、Switch3分别命名,并设置特权用户访问密码:
    以Switch0为例
    在这里插入图片描述

    (4)为路由器Router0,Router1,Router5分别命名为R0/R1/R5;配置路由器R0/R1/R5各接口;
    以Switch5为例
    在这里插入图片描述

    (5)为Web Server架设公司网站,概要介绍公司各部门情况;
    在这里插入图片描述在这里插入图片描述
    2、交换部分配置

    (1)[VLAN]:根据需求,在3个二层交换机上分别创建vlan 10~50,用便于识记的英文名称命名;并把相应的接口划分到所属vlan中;
    在这里插入图片描述

    以ShSw0,SzSw2为例:
    在这里插入图片描述在这里插入图片描述
    (2)[单臂路由]:在深圳总部的二层交换机和路由器上配置单臂路由,实现深圳总部各VLAN之间的互联:
    在SzSw2操作:
    在这里插入图片描述在这里插入图片描述在这里插入图片描述
    (3)[Trunk]:ShSw0、ShSw1和SzSw2的Fa0/1口, ShSw3的Fa0/2、Fa0/3口封装为Trunk;
    以SzSw3为例:
    在这里插入图片描述
    (4)[VTP]:在上海总部的三层交换机和二层交换机上配置VTP:ShSw3作为VTP server,ShSw0/ShSw1作为VTP client,VTP域名为abcCompany;
    ShSw0:
    在这里插入图片描述
    ShSw1:
    在这里插入图片描述
    ShSw3:
    在这里插入图片描述
    (5)[设置三层交换机VLAN间通信]:在ShSw3上创建VLAN10~50的虚拟接口,并配置虚拟接口的IP地址,以实现上海总部各VLAN之间的互联;开启ShSw3的路由功能,并配置相关协议;
    以ShSw3上的vlan40为例:
    在这里插入图片描述在这里插入图片描述
    (6)[ACL]:在ShSw3上做ACL访问限制,所有用户都可以ping通AppServer,除PC11以外,其他用户都可以访问内部网站;
    在这里插入图片描述
    (三)路由部分配置要求
    (1)[路由]:配置合适的路由协议,实现全公司内部的互联;
    以R5为例:
    在这里插入图片描述
    (2)[NAT]:在R0、R1上配置NAT。
    在R0上配置:
    在这里插入图片描述

    在R1上配置:
    在这里插入图片描述
    (四)验证截图
    (1)交换机命名和密码,以ShSw3为例:
    在这里插入图片描述
    (2)vlan划分,以ShSw0为例:

    在这里插入图片描述

    		(3)VTP配置,以ShSw0为例:
    

    在这里插入图片描述

    		(4)ACL配置:
    

    在这里插入图片描述
    (5)NAT配置:

    在这里插入图片描述

    五、调试过程中出现的问题及解决方法
    (1)在配置上海虚拟接口vlan10-50的IP地址后,vlan中主机不能ping通上海其他vlan中的主机
    解决方法:开启ShSw3的路由功能,并配置相关协议。

    (2)在配置了路由器R0,R1,R5的路由协议后,上海与深圳不能ping通
    解决方法:在ShSw3上配置端口fa0/1的路由协议

    (3)在配置NAT后,深圳分部的PC无法访问web服务器网页
    解决方法:将web服务器的IP用NAT静态转换成外网IP

    六、个人体会及建议
    在一周的计算机网络课程设计的过程中,通过参考资料,与他人交流和自学,最终完成了课程设计任务,也收获了许多。首先要对总体设计使用理论知识进行思考,把握解决问题的方向。而在任务详细要求上,因为小任务比较繁琐,即使掌握了理论知识,实际操作还是需要自学和尝试。对于遇到问题,需要查阅资料,消化所了解的内容,并通过反复实验,最后才能解决问题。
    在本次课设过程中,熟悉掌握了 Cisco Packet Tracer的使用方法。了解并完成了园区网设计与实施的任务。课设是对书本知识实践,也巩固了所学知识,使平时学到的知识有了实际意义。

    七、参考资料
    《思科三层交换机配置》 http://blog.51cto.com/13725021/2113295
    《ACL配置大全及命令》 https://wk.baidu.com/view/62fc4a2158fb770bf78a55bd?pcf=2
    《NAT详解》 https://blog.csdn.net/freeking101/article/details/77962312
    《VTP-------详解》 https://blog.csdn.net/tyrantu1989/article/details/73435633
    《细说VLAN与Trunk》 https://blog.csdn.net/chenyulancn/article/details/78996858

    展开全文
  • 基于Packet Tracer 的校园网络设计方案(计算机网络与通信技术课程实验)(一)——子网划分方案规划 项目要求 A楼内有两个子网 A1 A2 A1设计规模为 40台计算机, A2设计规模为 90台计算机。B楼内有 1个服务器子网 ...


    项目要求

    A楼内有两个子网 A1 A2 A1设计规模为 40台计算机, A2设计规模为 90台计算机。B楼内有 1个服务器子网 B1,设计规模为 10台服务器,需要考虑较高的带宽,有一个管理子网 B2,规模为 20台计算机 C楼有 1个子网 C1,设计规模为 70台计算机 。现在,我们要对IP地址进行规划,根据需求为每个子网分配合适的 IP子网,并为主要的计算机、路由器分配 IP地址。

    校园网设计综述

    校园网是一个具有交互功能和专业性很强的局域网络,具有教务、行政和总务管理等功能。根据网络覆盖范围的大小,可以把网络分为局域网( LAN, Local Area Network)、城域网( MAN, Metropolitan Area Network)和广域网(WAN, Wide Area Network) 。校园网( Campus Network)介于局域网和城域网之间,一般覆盖几公里的范围 。
    Tracert命令作为一个路由跟踪、诊断实用程序,在 DOS和 UNIX系统下都有此命令,它通过发送 Internet 控制消息协议 (ICMP) 回显请求和回显答复消息,产生关于经过每个路由器的命令行报告输出,从而跟踪路径。该程序是网管必备的 TCP/IP工具之一,经常被用于测试网络的连通性,确定故障位置。因此,我们有必要通过对 Tracert路由跟踪数据包的精确解析,完整了解 Tracert命令的运行过程。

    校园网设计实验基本知识

    (一) 三种网络类型

    1.A类地址
    (1)A类地址第 1字节为网络地址,其它 3个字节为主机地址。它的第 1个字节的第一位固定为 0.
    (2)A类地址网络号范围: 1.0.0.0-126.0.0.0
    (3)A类地址中的私有地址和保留地址:
    ① 10.x.x.x是私有地址(所谓的私有地址就是在互联网上不使用,而被用在 局域网络中的地址)。范围(10.0.0.0-10.255.255.255)
    ②127.x.x.x是保留地址,用做循环测试。

    2. B类地址
    (1)B类 IP地址范围 128.0.0.0-191.255.255.255(二进制表示为 10000000000000000000000000000000-10111111111111111111111111111111,最后一个是广播地址。
    (2)B 类IP 地址的子网掩码为255.255.0.0,每个网络支持的最大主机数为2562 -2=65534台。

    3. C类地址
    (1)C 类IP 地址中网络的标识长度为24 位,主机标识的长度为8 位,
    类网络地址数量较多,有209 万余个网络。适用于小规模的局域网络,每个网络最多只能包含254 台计算机。
    (2)C 类IP 地址范围192.0.0.0-223.255.255.255 ( 二进制表示为: 11000000000000000000000000000000 - 11011111111111111111111111111111)
    (3)C 类IP 地址的子网掩码为255.255.255.0,每个网络支持的最大主机数为256-2=254 台。

    (二) 子网掩码

    ① RFC 950 定义了子网掩码的使用,子网掩码是一个32 位的2 进制数,其对应网络地址的所有位置都为1,对应于主机地址的所有位置都为0。
    ② 因此,A 类网络的默认子网掩码是255.0.0.0,B 类网络的默认子网掩码是255.255.0.0,C 类网络的默认子网掩码是255.255.255.0。将子网掩码和IP 地址按位进行逻辑“与”运算,得到IP 地址的网络地址,剩下的部分就是主机地址,从而区分出任意IP 地址中的网络地址和主机地址。

    (三) 子网聚合(超网)

    “超网”,也称无类别域间路由选择(CIDR),它是集合多个同类互联网地址的一种方法,是与子网类似的概念——IP 地址根据子网掩码被分为独立的网络地址和主机地址。但是,与子网把大网络分成若干小网络相反,它是把一些小网络组合成一个大网络——超网。
    “超网”的优点是可以充分利用C 类网络空间资源。在多数情况下,使用“超网”地址分配使分配的网络空间与实际所需的结点数量相匹配,因而提高了地址空间的利用率。

    子网划分方案规划

    (一)A楼子网规划分析

    在这里插入图片描述

    (二)B楼子网规划分析

    在这里插入图片描述

    (三)C楼子网规划分析

    在这里插入图片描述
    在这里插入图片描述

    子网分配与计算机IP地址分配

    我们可以用IP的第 一位为对应子网的网关,因此,各楼对应的 IP地址如下:
    在这里插入图片描述
    3. C楼IP地址、子网掩码与网关设计

    楼层IP地址子网掩码网关
    C min10.0.1.2255.255.255.12810.0.1.1
    C max10.0.1.71255.255.255.12810.0.1.1

    路由器 IP地址规划分析

    由以上分析可知,对于10.0.0.0网段而言, IP在 10.0.0.192-10.0.0.254之间的地址未被使用;对于 10.0.1.0网段而言, IP在 10.0.1.176-10.0.1.254之间的地址未被使用。按照要求,我们需要优化地址规划,减少浪费,因此可以考虑将未使用的 IP地址划分给路由器。 因此,路由器 IP分配如下。其中, A、 B、 C分别代表 A、 B、 C三栋楼。
    路由器IP地址分配
    在这里插入图片描述
    在这里插入图片描述

    其中,子网掩码的计算和上面的计算过程一致。由于每个网段有两台路由器,且22>2,所以子网掩码设置为11111111.11111111.11111111.11111100,即 255.255.255.252.
    经过此次对路由器IP地址的设置,我们可以看到 IP地址仍然有余量。

    展开全文
  • 基于eNSP的计算机网络实验-----完结篇一、路由器基本配置和静态路由1.背景知识2.ENSP模拟过程3.实际网络设备操作二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】1.背景知识2.ENSP模拟过程3.实际网络...



    之前实验:
    基于eNSP模拟结合实际操作的计算机网络实验(三)
    基于eNSP模拟结合实际操作的计算机网络实验(二)
    基于eNSP模拟结合实际操作的计算机网络实验(一)

    • 对静态路由进行配置,测试网络连通性
    • 路由器动态配置(RIP、OSPF协议),对动态路由进行配置,测试网络连通性
    • 运用基本ACL来进行访问控制配置,测试网络连通性


    一、路由器基本配置和静态路由

    1.背景知识

        3台路由器分别连接到不同的网络,在路由器上进行适当配置,实现不同网段之间PC机之间的相互通信。

    配置静态路由相关指令命令:
        ip route-static :静态路由配置命令(command)
        Network:目标网络(destination network)
        mask:网络掩码(subnet mask)
        Address:下一跳地址(Next-hop address)
        Interface:本地出接口(Local outgoing interface)
        Distance:管理距离(administrative distance )

    路由:是把一个数据从一个网络转发到另一个网络的过程,完成这个过程的设备就是路由器。
    路由器:是网络层设备,是一个根据IP包头信息,选择最佳路径,将数据包转发出去的设备,路由器中的路由数据包有目的地址、源地址、可能路由、最佳路由、维护和更新路由信息组成。
    生成路由项
      配置路由表接口IP地址和子网掩码 —— 直连路由
      手工配置 —— 静态路由
      协议自动配置 —— 动态路由

    路由过程中的数据包交换:
    (1) 主机A发B的数据在网络层封装IP数据包,包首部包含源地址和目标地址;
    (2) 主机A用本机24IP掩码与目标地址进行与运算。若不在一个网段,则将ip数据包发到网关;
    (3) 发往网关前A通过ARP请求获得网关MAC地址。将IP数据包封装成帧。再发往网关,也就是路由器一个接口;
    (4) 网关路由器接收到以太网数据帧,如目标MAC地址是自己某个端口物理地址,路由器把以太网帧封装去掉,路由器会认为这个IP数据包要通过自己进行转发,接着就匹配路由表,匹配后,将包发往下一条地址。
    总之,路由器转发数据包始终不改IP ,只改MAC地址。

    2.ENSP模拟过程

    模拟组网内容描述:
    (1) R1、R2、R3三台路由器,R1连接PC1,R3连接PC2,PC1、PC2处于不同网段
    (2) 配置R1、R2、R3,使处于不同网段的PC1、PC2能够ping通
    (3) 模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

    对路由器设置:

    R1:[R1] int g0/0/0
        [R1-GigabitEthernet0/0/0] ip add 192.168.53.1 24
        [R1-GigabitEthernet0/0/1] int g0/0/1 
        [R1-GigabitEthernet0/0/1] ip add 192.168.50. 254 24
        [R1] ip route-static 192.168.60.0 24 192.168.53.2
         
    R2:[R2] int g0/0/0
        [R2-GigabitEthernet0/0/0] ip add 192.168.53.2 24
        [R2-GigabitEthernet0/0/1] int g0/0/1 
        [R2-GigabitEthernet0/0/1] ip add 192.168.57. 1 24
        [R2] ip route-static 192.168.60.0 24 192.168.57.2
        [R2] ip route-static 192.168.50.0 24 192.168.53.1
    
    R3:[R3] int g0/0/0
    	[R3-GigabitEthernet0/0/0] ip add 192.168.57.2 24
        [R3-GigabitEthernet0/0/0] int g0/0/1 
        [R3-GigabitEthernet0/0/1] ip add 192.168.60. 254 24
        [R3] ip route-static 192.168.50.0 24 192.168.57.1
    

    在这里插入图片描述
    上图可见,我们模拟成功,进入实际设备操作环节;

    3.实际网络设备操作

    设备名称接口接口类型所属VLANIP地址、掩码和网关
    PC1Ethernet0/0/1access/192.168.100.2
    255.255.255.0
    192.168.100.1
    PC2Ethernet0/0/1access/192.168.103.100
    255.255.255.0
    192.168.103.1
    R1GigabitEthernet0/0/0子接口
    子接口
    -ip add 192.168.1.254 24
    ip add 192.168.2.254 24
    PC1Ethernet0/0/1accessvlan 10192.168.1.1
    255.255.255.0
    192.168.1.254
    PC2Ethernet0/0/1accessvlan 20192.168.1.2
    255.255.255.0
    192.168.2.254

    路由器R1:
    在这里插入图片描述
    在这里插入图片描述

    【就贴一个R1的图吧,图太多太乱不想找了,就这样吧,实际设备问题挺多的,但是和模拟的流程差不多】

    结果:
    在这里插入图片描述

    二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】

    1.背景知识

    动态路由是路由协议自动建立和管理的路由,常见动态路由协议有:
        RIP(Routing Information Protocol) 最古老的路由协议;
        IGRP(Interior Gateway Routing Protocol)思科私有路由协议,现已基本淘汰;
        EIGRP(Enhance Interior Gateway Routing Protocol);
        OSPF(Open Shortest Path First)思科私有路由协议,高级的距离矢量;
        BGP(Backbone Getway Protocol)外部网关协议,企业内部不适用;
    不可路由协议,NetBEUI协议。
        对于不同的路由协议到一个目的地的路由信息,路由器选择信任哪个路由信息源?管理距离AD 管理距离:是标识路由可信度的信任等级。AD值越低,优先级越高。

    RIP协议简介:
        RIP协议是基于距离矢量算法的。它使用“跳数” 来衡量到达目标地址的路由距离。路由器交换信息是通过定期广播整个路由表所能到达的适用网络号码。(网络规模大时路由表大,难维护。

    OSPF协议简介:
        OSPF协议采用链路状态算法。执行该算法的路由器不是简单的从相邻的路由器学习路由,而是把路由器分成区域,收集区域内所有路由器的链路状态信息,根据链路状态信息生成网络拓扑结构,每一个路由器再根据拓扑结构图计算出路由。(配置相对复杂)
    在这里插入图片描述

    2.ENSP模拟过程

    RIP调试命令

    display ip routing-table           /*显示路由表*/
    undo route rip                     /*删除RIP路由配置*/
    display ip interface br            /*查看接口的启用ip地址*/
    display interfaces                 /*显示接口信息*/
    debugging hdlc all serial0         /*显示所有信息*/
    debugging hdlc event serial0       /*调试事件信息*/
    debugging hdlc packet serial0      /*显示包的信息*/
    

    OSPF调试命令

    ospf 1                             /*1代表进程号,如果没注明,默认进程为1*/
    area 0                             /*声明ospf区域为area 0*/
    Network 192.168.100.0 0.0.0.255    /*发布自身直连的网段,后加反掩码*/ 
    

    模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

    基于RIP协议下路由器的设置如下:
    R1:

    [R1] int g0/0/0
    [R1-GigabitEthernet0/0/0] ip add 192.168.53.1 24
    [R1-GigabitEthernet0/0/1] int g0/0/1 
    [R1-GigabitEthernet0/0/1] ip add 192.168.50. 254 24
    [R1] rip 1                            
    [R1-rip-1] version 2
    [R1-rip-1] network 192.168.50.0
    [R1-rip-1] network 192.168.53.0
    [R1-rip-1] q
    

    R2:

    [R2] int g0/0/0
    [R2-GigabitEthernet0/0/0] ip add 192.168.53.2 24
    [R2-GigabitEthernet0/0/1] int g0/0/1 
    [R2-GigabitEthernet0/0/1] ip add 192.168.57. 1 24
    [R2] rip 1
    [R2-rip-1] version 2
    [R2-rip-1] network 192.168.53.0
    [R2-rip-1] network 192.168.57.0
    [R2-rip-1] q
    

    R3:

    [R3] int g0/0/0
    [R3-GigabitEthernet0/0/0] ip add 192.168.57.2 24
    [R3-GigabitEthernet0/0/0] int g0/0/1 
    [R3-GigabitEthernet0/0/1] ip add 192.168.60. 254 24
    [R3] rip 1
    [R3-rip-1] version 2
    [R3-rip-1] network 192.168.57.0
    [R3-rip-1] network 192.168.60.0
    [R3-rip-1] q
    

    3.实际网络设备操作


    啊,我好懒,上面的设备表懒得打了,直接贴实际操作代码了
    R1:

    <Huawei>sys
    [Huawei]sysn R1-OSPF
    [R1-OSPF]int g0/0/0
    [R1-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.1 24
    [R1-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R1-OSPF-GigabitEthernet0/0/1]ip add 192.168.50.254 24
    [R1-OSPF-GigabitEthernet0/0/1]q
    [R1-OSPF]ospf 1 router-id 2.2.2.2
    [R1-OSPF-ospf-1]area 0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.50.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]q
    


    R2:

    [Huawei]sysn R2-OSPF
    [R2-OSPF]int g/0/0/0
    [R2-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.2 24
    [R2-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R2-OSPF-GigabitEthernet0/0/1]ip add 192.168.57.1 24
    [R2-OSPF-GigabitEthernet0/0/1]q
    [R2-OSPF-ospf-1]area 0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]q
    


    R3:

    [Huawei]sysn R3-OSPF
    [R3-OSPF]int g0/0/1
    [R3-OSPF-GigabitEthernet0/0/1]ip add 192.168.60.254 24
    [R3-OSPF-GigabitEthernet0/0/1]intg0/0/0
    [R3-OSPF-GigabitEthernet0/0/0]ip add 192.168.57.2 24
    [R3-OSPF-GigabitEthernet0/0/0]q
    [R3-OSPF]ospf 1 router-id 3.3.3.3
    [R3-OSPF-ospf-1]area 0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]network 192.168.60.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0]
    

    在这里插入图片描述
    在这里插入图片描述 在这里插入图片描述


    三、ACL和NAT配置

    1.背景知识

    1.1 ACL

    运用基本ACL配置来实现对于一个网络进行访问控制,其实验拓扑图如下所示:
    在这里插入图片描述
        这里的话我们就用两台电脑来实现访问控制,在实际场景下的我们可以通过对不同的接口进行选取来实现两台PC进行访问控制列表ACL
        主要的实验要求就是两个PC之间只有休息时间可以进行通信,其余时间不能够进行通信,我们通过设置两对端口之间能够正常进行通信,另外两个端口这些时间不能进行通信。

    基本ACL配置步骤:
      (1) 配置路由器端口地址
      (2) 配置路由
      (3) 配置ACL生效时间
      (4) 创建ACL列表
      (5) 配置ACL规则
      (6) 在接口下应用ACL

    配置访问控制列表ACL相关指令命令
        acl [ number ] 命令用来创建一个ACL,并进入ACL视图
        rule [ rule-id ] { deny | permit } source { source-address source-wildcard | any } 命令用来增加或修改ACL的规则。deny用来指定拒绝符合条件的数据包,permit用来指定允许符合条件的数据包,source用来指定ACL规则匹配报文的源地址信息,any表示任意源地址。
        traffic-filter { inbound | outbound }acl{ acl-number }命令用来在接口上配置基于ACL对报文进行过滤。
        本示例中,主机A发送的流量到达RTA后,会匹配ACL2000中创建的规则rule deny source192.168.1.0 0.0.0.255,因而将被拒绝继续转发到Internet。主机B发送的流量不匹配任何规则,所以会被RTA正常转发到Internet。

    ACL还有很多原理和规则自己百度,我很懒,不想打了。

    1.2 NAT

    在这里插入图片描述
    NAT基本配置实验原理
        NAT是指把局域网内部私有地址与Internet全局地址(公网地址)建立对应关系,这种关系称为映射;
        使用内部地址的主机在访问Internet时或被Internet上的主机访问时,数据报均在该局域网的网关(路由器)上进行地址之间的转换;
        NAT设置在内部网域外部公用网连接处的路由器上,路由器至少有一个内部端口以及一个外部端口,内部端口连接内部网络用户使用内部专用ip地址,外部端口连接的是外部的网络,如internet,使用的是公网ip地址;

    NAT分类:
        (1) 静态NAT:将内部专用地址与全局合法地址进行一对一的转换,需要指定和哪个合法地址进行转换;
        (2) 动态NAT:pool NAT执行专用地址与全局地址的一对一转换,但全局地址与专用地址的对应关系不是一成不变的,它是从全局地址池(pool)中动态的选择一个全局地址与一个内部专用地址相对应;
        (3) 复用地址转换:Port NAT可以允许多个内部本地地址共用一个全局合法地址,当只申请到少量全局合法ip地址,但却经常同时有多个用户上外部网络时,这种转换是很有用的;

    NAT工作流程什么的自己百度,不再详述。

    2.ENSP模拟过程

    2.1 ACL

    这个实验我们是基于之前所做的动态路由来做的,所以经过如下配置,我们能够使PC1 ping 通PC2,我们在路由器R3上进行ACL的设置,使之能够拒绝PC1网段的访问,那么,我们所期待的结果就是经过设置ACL后,PC1无法ping通PC2

    模拟实验中各处ip地址安排如下:

    PC1:192.168.50.1     
    PC2:192.168.60.1
    R1::GE0/0/0 :192.168.53.1
    R1::GE0/0/1 :192.168.50.254
    R2::GE0/0/0 :192.168.53.2
    R2::GE0/0/1 :192.168.57.1
    R3::GE0/0/0 :192.168.57.2
    R3::GE0/0/1 :192.168.60.254
    

                                jiang学主义好!!
                             ▅▅▅▅▅▆▇▅▅▄▄▄▄▄▄▄
                            ▄▅▅▅▇█▇▆▆▆▇▆▄▄▄▄
                            ▄▄▄▆▇▆▅▄▃▃▄▆▆▄▄▄
                            ▄▄▄█▇▅▄▃▃▃▃▅▇▄▄▄
                            ▃▄▄█▇▆▄▃▃▃▃▄▇▄▄▃
                            ▃▃▃▇█▇▆▅▅▅▄▅▆▃▃▃
                            ▃▃▃▆▇▆▅▆▆▅▄▅▄▃▃▂
                            ▂▃▂▅▇▅▄▆▄▅▄▄▃▂▂▂
                            ▂▂▂▄▇▆▅▆▄▄▄▃▂▂▂▂
                            ▂▂▂▂▆▆▆▆▄▄▄▃▂▂▂▁
                            ▁▂▁▁▆▇▆▅▄▃▄▂▁▁▁▁
                            ▁▁▁▄▇▇▇▅▄▄▃ ▁▁▁▁
                              ▃▇██▆▆▇▆▅▅▅▂   
                            ▅█████▄▃▅▁▅██▆▃ 
                            ██████▅▄▇▄▅████▆

    对于各个路由器的设置如下:
    R1:

    [Huawei]sysn R1-OSPF
    [R1-OSPF]int g0/0/0
    [R1-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.1 24
    [R1-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R1-OSPF-GigabitEthernet0/0/1]ip add 192.168.50.254 24
    [R1-OSPF-GigabitEthernet0/0/1]q
    [R1-OSPF]ospf 1 router-id 1.1.1.1
    [R1-OSPF-ospf-1]area 0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.50.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R1-OSPF-ospf-1-area-0.0.0.0]q
    

    R2:

    [Huawei]sysn R2-OSPF
    [R2-OSPF]int g/0/0/0
    [R2-OSPF-GigabitEthernet0/0/0]ip add 192.168.53.2 24
    [R2-OSPF-GigabitEthernet0/0/0]int g0/0/1
    [R2-OSPF-GigabitEthernet0/0/1]ip add 192.168.57.1 24
    [R2-OSPF-GigabitEthernet0/0/1]q
    [R2-OSPF]ospf 1 router-id 2.2.2.2
    [R2-OSPF-ospf-1]area 0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.57.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]network 192.168.53.0 255.255.255.0
    [R2-OSPF-ospf-1-area-0.0.0.0]q
    

    R3:

    [Huawei]sysn R3-OSPF
    [R3-OSPF]int g0/0/1
    [R3-OSPF-GigabitEthernet0/0/1] ip add 192.168.60.254 24
    [R3-OSPF-GigabitEthernet0/0/1] int g0/0/0
    [R3-OSPF-GigabitEthernet0/0/0] ip add 192.168.57.2 24
    [R3-OSPF-GigabitEthernet0/0/0] q
    [R3-OSPF] ospf 1 router-id 3.3.3.3
    [R3-OSPF-ospf-1] area 0
    [R3-OSPF-ospf-1-area-0.0.0.0] network 192.168.57.0 255.255.255.0
    [R3-OSPF-ospf-1-area-0.0.0.0] network 192.168.60.0 255.255.255.0
    [R3] time-range lc 06:00 to 22:59 working-day
    [R3] acl number 3000
    [R3-acl-adv-3000] rule 0 deny ip source 192.168.50.0 0.0.0.255 destionation 192.168.60.0 0.0.0.255 time range lc
    [R3-acl-adv-3000] int g0/0/1
    [R3-GigabitEthernet0/0/1] traffic-filter outbound acl 3000
    

    2.2 NAT

    如上图实验拓扑图所示,我们对于NAT实验的各类IP设置如下所示:

    内网PC ip 为:192.168.50.1
    外网PC ip 为:202.1.1.9
    

    3.实际网络设备操作

    3.1访问控制列表ACL实际实验

    在这里插入图片描述
    在这里插入图片描述

    3.2 网络地址转换NAT实际实验

    在这里插入图片描述

    4.ACL和NAT实验结果:

    4.1 ACL实验结果

    在这里插入图片描述
    在这里插入图片描述

    4.2 NAT实验结果

    在这里插入图片描述

    展开全文
  • 摘要为提高推进我国高等教育的进程高等职业教育的发展是推动我国全面实现大众化高等教育的主要途径计算机网络实验课程是一门集实践应用为一体同时又是一门综合学术课程对于如何实现特色教学如何设计出好的教学课程...
  • 利用抓包软件获取报文,进行协议分析 在capture菜单中选中options,可以设置抓包选项
  • 计算机网络实验二:网络基础编程实验

    万次阅读 多人点赞 2019-04-16 13:49:46
    通过本实验,学习采用Socket(套接字)设计简单的网络数据收发程序,理解应用数据包是如何通过传输层进行传送的。 二、实验内容 Socket(套接字)是一种抽象层,应用程序通过它来发送和接收数据,就像应用程序...
  • 计算机网络实验ns2实验

    千次阅读 2017-06-26 15:06:00
    安装并运行网络仿真器NS2,了解其功能模块及配套工具的使用,掌握利用NS2进行网络仿真的方法,为进一步的网络系统性能分析设计创造良好的条件。   2. 实验条件 硬件:一台计算机 软件:Ubu
  • 计算机网络实验2 实验要求 实验目的 理解滑动窗口协议的基本原理;掌握 GBN 的工作原理;掌握基于 UDP 设计并实现一个 GBN 协议的过程与技术。 实验内容 基于UDP设计一个简单的GBN协议,实现单向可靠数据...
  • 计算机网络 实验六 网络协议分析

    千次阅读 2020-07-01 13:54:47
    如果对我的内容感兴趣,可以考虑一下我的计算机网络实验专栏 计算机网络实验专栏链接
  • 摘要针对当前计算机网络实验教学不能满足学生需求存在的问题在工程教育认证背景下分析探讨了网络实验方案设计方法提出以Linux系统为实验节点的网络实验组网平台特别是在实验内容选择实验路由交换设备实验项目和方法...
  • 计算机网络课程是一门理论和实践都非常强的课程,学生在理解了计算机网络的基本概念、原理、协议的基础上,还必须通过一些实验训练才能真正掌握其内在的含义。本书从实际应用出发,为培养学生的实际动手能力,...
  • 计算机网络实验总结

    万次阅读 2018-06-12 19:46:01
    实验目的理解ICMP,掌握ICMP帧结构,掌握IP协议原理,理解IP帧结构2.实验步骤 1、观察ICMP目标不可达消息使用Ping命令,去ping一个不存在的主机IP,如10.104.125.344。使用wireshark 捕获数据包,并进行分析。命令...
  • 计算机网络课程设计 某高中校园网设计

    千次阅读 多人点赞 2020-05-27 09:53:35
    实现目的 ...实验组网总拓扑 技术运用:OSPF,STP,vlan,NAT,单臂路由 实现目的: 1.内网用户之间的互通 2.内网可以访问外网,外网不可以访问内网 3.资源共享,所有均可访问FTP服务器 等等等… 设备配
  • 一. 实验目的 掌握网络扫描技术的原理。 学会使用 Nmap 扫描工具。
  • 如果对我的内容感兴趣,可以考虑一下我的计算机网络实验专栏 计算机网络实验专栏链接
  • 计算机网络实验之局域网的配置

    千次阅读 2019-11-21 16:44:13
    计算机网络实验之局域网的配置
  • 计算机网络工程课程设计

    千次阅读 2019-06-18 09:50:38
    实现目的 安阳某高级中学校园网设计 1.调查某高中校园网用户需求;从校园规模,功能划分,安全需求入手。...实验组网总拓扑 技术运用:OSPF,STP,vlan,NAT,单臂路由 实现目的: 1.内网用户之...
  • 如果对我的内容感兴趣,可以考虑一下我的计算机网络实验专栏 计算机网络实验专栏链接

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 90,821
精华内容 36,328
关键字:

计算机网络设计性实验