精华内容
下载资源
问答
  • 2022-03-30 09:12:59

    0.软件安装包

    叶焕新:网络工程师软件安装包合集​

    网络工程师软件安装包合集 - 知乎22-02-09 更新了华三模拟器HCL21-12-09 更新了eve-ng安装包和安装视频、更新学习视频内容、更新ENSP不被和谐0.华三模拟器0.1.H3C HCL链接: https://pan.baidu.com/s/1C7_soM1aCbt8GSQlv8mNfw 提取码: iwge 1.华为…https://zhuanlan.zhihu.com/p/442906734

    理论内容请回顾之前内容

    虚拟化堆叠技术-典型配置H3C IRF - 知乎icon-default.png?t=M276https://zhuanlan.zhihu.com/p/465254812

    1.需求

    1) 配置两台物理设备为一台逻辑设备虚拟化-堆叠

    2) 将线路进行端口捆绑

    3) 测试网络端口故障的切换效果

    4) 测试设备故障时的切换效果

    2.实验拓扑

    3.IRF配置命令

    3.1.主设备配置命令

    1) 设备命名

    [H3C]sysname SW1

    2) 先关闭堆叠的接口

    [SW1]int Ten-GigabitEthernet 1/0/52

    [SW1-Ten-GigabitEthernet1/0/52]shutdown

    3) 配置设备的优先级

    [SW1]irf member 1 priority 2

    注:优先级默认为1,越大越优,优先为主设备。

    4) 关联堆叠接口

    [SW1]irf-port 1/1

    [SW1]port group interface ten-gigabitethernet 1/0/52

    5) 启用堆叠的接口

    [SW1]int Ten-GigabitEthernet 1/0/52

    [SW1-Ten-GigabitEthernet1/0/52]undo shutdown

    6) 激活irf配置

    [SW1] irf-port-configuration active

    3.2.从设备配置命令

    1) 设备命名

    [H3C]sysname SW2

    2) 先关闭堆叠的接口

    [SW2]int Ten-GigabitEthernet 1/0/52

    [SW2-Ten-GigabitEthernet1/0/52]shutdown

    3) 关联堆叠接口

    [SW2]irf-port 1/2

    [SW2]port group interface ten-gigabitethernet 1/0/52

    4) 启用堆叠的接口

    [SW2]int Ten-GigabitEthernet 1/0/52

    [SW2-Ten-GigabitEthernet1/0/52]undo shutdown

    5) 激活irf配置

    [SW2] irf-port-configuration active

    4.其他配置命令

    4.1.端口捆绑配置命令

    堆叠设备上配置捆绑

    [SW1]int Bridge-Aggregation 2

    [SW1]int ran ten 1/0/50 ten 2/0/51

    [SW1-if-range]port link-aggregation group 2

    [SW1]int Bridge-Aggregation 2

    [SW1-Bridge-Aggregation2]port link-type trunk

    [SW1-Bridge-Aggregation2]port trunk permit vlan all

    其他设备配置捆绑

    [S5820] int Bridge-Aggregation 2

    [S5820]int ran ten 1/0/50 ten 1/0/51

    [S5820-if-range]port link-aggregation group 2

    [S5820]int Bridge-Aggregation 2

    [S5820-Bridge-Aggregation2]port link-type trunk

    [S5820-Bridge-Aggregation2]port trunk permit vlan all

    4.2.配置svi地址

    堆叠设备上配置SVI

    vlan 10

    int vlan 10

    ip add 10.1.1.1 24

    其他设备上配置SVI

    vlan 10

    int vlan 10

    ip add 10.1.1.2 24

    5.验证

    5.1.设备状态

    [SW1]dis irf

    MemberID Role Priority CPU-Mac Description

    *+1 Master 2 361b-d50e-0104 ---

    2 Standby 1 361b-dc16-0204 ---

    --------------------------------------------------

    * indicates the device is the master.

    + indicates the device through which the user logs in.

    The bridge MAC of the IRF is: 361b-d50e-0100

    Auto upgrade : yes

    Mac persistent : 6 min

    Domain ID : 0

    5.2.切换测试

    S5820上发起ping堆叠设备

    ping -c 100000 10.1.1.1

    Ping 10.1.1.1 (10.1.1.1): 56 data bytes, press CTRL_C to break

    56 bytes from 10.1.1.1: icmp_seq=0 ttl=255 time=1.000 ms

    56 bytes from 10.1.1.1: icmp_seq=1 ttl=255 time=1.000 ms

    5.3.端口断线测试

    关闭堆叠设备的1/0/50接口

    58 packet(s) transmitted, 58 packet(s) received, 0.0% packet loss

    round-trip min/avg/max/std-dev = 0.000/0.638/1.000/0.481 ms

    没有发现丢包

    启用堆叠设备的1/0/50接口

    58 packet(s) transmitted, 58 packet(s) received, 0.0% packet loss

    round-trip min/avg/max/std-dev = 0.000/0.845/2.000/0.407 ms

    关闭堆叠设备的2/0/51接口

    56 packet(s) transmitted, 56 packet(s) received, 0.0% packet loss

    round-trip min/avg/max/std-dev = 0.000/0.857/2.000/0.479 ms

    没有发现丢包

    启用堆叠设备的2/0/51接口

    28 packet(s) transmitted, 28 packet(s) received, 0.0% packet loss

    round-trip min/avg/max/std-dev = 0.000/0.679/2.000/0.538 ms

    没有发现丢包

    5.4.设备关机测试

    关闭堆叠主用设备

    119 packet(s) transmitted, 116 packet(s) received, 2.5% packet loss

    round-trip min/avg/max/std-dev = 0.000/0.828/2.000/0.530 ms

    发现丢包3个

    <SW1>dis irf

    MemberID Role Priority CPU-Mac Description

    *+2 Master 1 361b-dc16-0204 ---

    --------------------------------------------------

    * indicates the device is the master.

    + indicates the device through which the user logs in.

    The bridge MAC of the IRF is: 361b-d50e-0100

    Auto upgrade : yes

    Mac persistent : 6 min

    Domain ID : 0

    启动堆叠主用设备

    536 packet(s) transmitted, 536 packet(s) received, 0.0% packet loss

    round-trip min/avg/max/std-dev = 0.000/0.746/4.000/0.552 ms

    没有发现丢包

    <SW1>dis irf

    MemberID Role Priority CPU-Mac Description

    1 Standby 2 361b-d50e-0104 ---

    *+2 Master 1 361b-dc16-0204 ---

    --------------------------------------------------

    * indicates the device is the master.

    + indicates the device through which the user logs in.

    The bridge MAC of the IRF is: 361b-d50e-0100

    Auto upgrade : yes

    Mac persistent : 6 min

    Domain ID : 0

    54 packet(s) transmitted, 54 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 0.000/1.037/11.000/1.621 ms

    6.总结

    整体经典配置得到预期的效果,两台物理设备虚拟化为一台逻辑设备,统一化管理,并具有逻辑设备进行链路聚合功能,在极端情况下物理设备中断,恢复丢包可控制在5个以内,具有良好的风险控制。

    但堆叠具有同厂家同型号才能进行,具有排外性,而且技术上是厂家私有的黑盒子,凡事有利有弊。

    更多相关内容
  • H3C IRF堆叠、链路聚合实验hcl模拟器工程文件(已经完整的配置好了) 启动时导入到HCL即可,由于模拟器性能原因DHCP需要等待几分钟PC才能获取IP地址 详细实验文档 https://www.orcy.net.cn/2330.html
  • H3C模拟器】华三交换机配置IRF堆叠

    千次阅读 多人点赞 2020-12-01 16:19:06
    IRF(Intelligent Resilient Framework,智能弹性架构)是H3C自主研发的软件虚拟化的技术。它的核心思路是将多太设备通过IRF物理端口连接在一起,进行必要的配置后,虚拟化成一台“分布式设备”。理解为堆叠有助于...

    目录

    1、IRF的概述

    2、工作原理

    3、常用名词

    4、IRF配置实例

    5、IRF检测机制

    BFD-MAD检测

    LACP-MAD检测


    本篇主要讲的是华三交换机的IRF堆叠,这个在行业用的有很多。

    1、IRF的概述

    IRF(Intelligent Resilient Framework,智能弹性架构)是H3C自主研发的软件虚拟化的技术。它的核心思路是将多太设备通过IRF物理端口连接在一起,进行必要的配置后,虚拟化成一台“分布式设备”。理解为堆叠有助于我们更快的理解。

    堆叠是指将一台以上的交换机组合起来共同工作,以便在有限的空间内提供 尽可能多的端口。多台交换机经过堆叠形成一个堆叠单元。堆叠和级联这两个概念既有区别又有联系。堆叠可以看作级联的一种特殊形式。它们的不同之处在于:级联的交换机之间可以相距很远(在媒体许可范围内),而一个堆叠单元内的多台交换机之间的距离非常近,一般不超过几米;级联一般采用普通端口,而堆叠采用专用的堆叠模块和堆叠线缆。(来自百度百科)

    2、工作原理

    IRF分为四个阶段:(1)物理连接。(2)设备间通过IRF端口进行信息收集。(3)选举主备关系。(4)IRF自行维护。

    只需要了解选举规则以及分裂处理机制,其它的信息不必深入。

    选举规则:根据IRF的优先级进行选举,Priority最大的则为Master,值小的为Slave。

    分裂机制:

    (1)IRF分裂分为两种情况,主机或者备机整机down掉,那么就直接更换设备即可。

    (2)如果是IRF链路或者端口down掉了,主备之间需要IRF的心跳线(MAD检测)彼此互换IRF信息。为了避免二层信息混乱,IRF是让备机完全处于停机的状态。

    3、常用名词

    IRF合并、IRF分裂、IRF端口、IRF角色、IRF主备。

    4、IRF配置实例

     

    (1)配置S5820V2-54QS-GE_1 交换机为Master

    设置成员号以及优先级(最大值为32,默认值(最小值)为1)

    [S5820V2-54QS-GE_1]irf member 1 priority 32(将设备优先级调整为32,确保选举为Master)

    把需要加入irf-port的端口down掉,shutdown XGE 1/0/51,XGE 1/0/52。并加入到相应的IRF group组

    [S5820V2-54QS-GE_1]interface range Ten-GigabitEthernet 1/0/51 to Ten-GigabitEthernet 1/0/52(进入到接口范围)

    [S5820V2-54QS-GE_1-if-range]shutdown(关闭接口)

    [S5820V2-54QS-GE_1]irf-port 1/2(创建一个IRF虚拟接口)

    [S5820V2-54QS-GE_1-irf-port1/1]port group interface Ten-GigabitEthernet 1/0/51(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_1-irf-port1/1]port group interface Ten-GigabitEthernet 1/0/52(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_1-irf-port1/1]quit(退出接口视图)

    将XGE 1/0/51,XGE 1/0/52这两个接口undo shutdown。

    [S5820V2-54QS-GE_1]interface range Ten-GigabitEthernet 1/0/51 to Ten-GigabitEthernet 1/0/52(进入到接口范围)

    [S5820V2-54QS-GE_1-if-range]undo shutdown(开启接口)

    激活IRF,然后保存配置

    [S5820V2-54QS-GE_1]irf-port-configuration active(激活IRF配置)

    [S5820V2-54QS-GE_1]save force(保存配置)

    (2)S5820V2-54QS-GE_2 交换机为Slave

    设置成员号及优先级,将设备号的1(因为华三设备号默认是1)改为2,因为我们要把这台做备份。

    [S5820V2-54QS-GE_2]irf member 1 renumber 2(将设备号的1改为2)

    [S5820V2-54QS-GE_2]save force (保存配置)

    <S5820V2-54QS-GE_2>reboot (重启设备)

    把需要加入irf-port的端口down掉,shutdown XGE 2/0/51,XGE 2/0/52。并加入到相应的IRF group组

    [S5820V2-54QS-GE_2]interface range Ten-GigabitEthernet 2/0/51 to Ten-GigabitEthernet 2/0/52(进入到接口范围)

    [S5820V2-54QS-GE_2-if-range]shutdown(关闭接口)

    [S5820V2-54QS-GE_2]irf-port 2/1(创建一个IRF虚拟接口)

    [S5820V2-54QS-GE_2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/51(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/52(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_2-irf-port2/1]quit(退出接口视图)

    将XGE 2/0/51,XGE 2/0/52这两个接口undo shutdown。

    [S5820V2-54QS-GE_2]interface range Ten-GigabitEthernet 2/0/51 to Ten-GigabitEthernet 2/0/52(进入到接口范围)

    [S5820V2-54QS-GE_2-if-range]undo shutdown(开启接口)

    激活IRF,然后保存配置

    [S5820V2-54QS-GE_2]save force(保存配置)(这一步保存至关重要,如果没保存配置;IRF建立将会以失败告终)

    [S5820V2-54QS-GE_2]irf-port-configuration active(激活IRF配置)

    到了这步之后配置就基本上完成了,设备会自动进行Master竞选,失败的设备会自动重启,作为备份设备(Slave);

    我们可以使用这条命令可以查看IRF是否建立成功,display irf,如果出现以下的显示,就表示配置成功了。

    5、IRF检测机制

    BFD-MAD检测

    (1)配置S5820V2-54QS-GE_1 交换机为Master

    设置成员号以及优先级(最大值为32,默认值(最小值)为1)

    [S5820V2-54QS-GE_1]irf member 1 priority 32(将设备优先级调整为32,确保选举为Master)

    把需要加入irf-port的端口down掉,shutdown XGE 1/0/51,XGE 1/0/52。并加入到相应的IRF group组

    [S5820V2-54QS-GE_1]interface range Ten-GigabitEthernet 1/0/51 to Ten-GigabitEthernet 1/0/52(进入到接口范围)

    [S5820V2-54QS-GE_1-if-range]shutdown(关闭接口)

    [S5820V2-54QS-GE_1]irf-port 1/2(创建一个IRF虚拟接口)

    [S5820V2-54QS-GE_1-irf-port1/1]port group interface Ten-GigabitEthernet 1/0/51(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_1-irf-port1/1]port group interface Ten-GigabitEthernet 1/0/52(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_1-irf-port1/1]quit(退出接口视图)

    将XGE 1/0/51,XGE 1/0/52这两个接口undo shutdown。

    [S5820V2-54QS-GE_1]interface range Ten-GigabitEthernet 1/0/51 to Ten-GigabitEthernet 1/0/52(进入到接口范围)

    [S5820V2-54QS-GE_1-if-range]undo shutdown(开启接口)

    激活IRF,然后保存配置

    [S5820V2-54QS-GE_1]irf-port-configuration active(激活IRF配置)

    [S5820V2-54QS-GE_1]save force(保存配置)

    (2)S5820V2-54QS-GE_2 交换机为Slave

    设置成员号及优先级,将设备号的1(因为华三设备号默认是1)改为2,因为我们要把这台做备份。

    [S5820V2-54QS-GE_2]irf member 1 renumber 2(将设备号的1改为2)

    [S5820V2-54QS-GE_2]save force (保存配置)

    <S5820V2-54QS-GE_2>reboot (重启设备)

    把需要加入irf-port的端口down掉,shutdown XGE 2/0/51,XGE 2/0/52。并加入到相应的IRF group组

    [S5820V2-54QS-GE_2]interface range Ten-GigabitEthernet 2/0/51 to Ten-GigabitEthernet 2/0/52(进入到接口范围)

    [S5820V2-54QS-GE_2-if-range]shutdown(关闭接口)

    [S5820V2-54QS-GE_2]irf-port 2/1(创建一个IRF虚拟接口)

    [S5820V2-54QS-GE_2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/51(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/52(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_2-irf-port2/1]quit(退出接口视图)

    将XGE 2/0/51,XGE 2/0/52这两个接口undo shutdown。

    [S5820V2-54QS-GE_2]interface range Ten-GigabitEthernet 2/0/51 to Ten-GigabitEthernet 2/0/52(进入到接口范围)

    [S5820V2-54QS-GE_2-if-range]undo shutdown(开启接口)

    激活IRF,然后保存配置

    [S5820V2-54QS-GE_2]save force(保存配置)(这一步保存至关重要,如果没保存配置;IRF建立将会以失败告终)

    [S5820V2-54QS-GE_2]irf-port-configuration active(激活IRF配置)

    到了这步之后配置就基本上完成了,设备会自动进行Master竞选,失败的设备会自动重启,作为备份设备(Slave);

    我们可以使用这条命令可以查看IRF是否建立成功,display irf,如果出现以下的显示,就表示配置成功了。

    下面开始我们开始配置MAD检测机制,这里我们采用BFD-MAD检测。当IRF建立成功后,这两台设备统称为IRF设备。

    IRF设备配置:(因为我们已经做了IRF,所以当我们在Master做配置时,配置也会同步到Standby)。

    [S5820V2-54QS-GE_1]vlan 10(创建用于检测的vlan10)

    [S5820V2-54QS-GE_1-vlan10]quit

    [S5820V2-54QS-GE_1]interface Vlan-interface 10(进入到vlanif10中)

    [S5820V2-54QS-GE_1-Vlan-interface10]mad bfd enable(开启bfd-mad检测)

    [S5820V2-54QS-GE_1-Vlan-interface10]mad ip address 192.168.1.1 24 member 1(配置一个属于设备1的ip地址)

    [S5820V2-54QS-GE_1-Vlan-interface10]mad ip address 192.168.1.2 24 member 1(配置一个属于设备2的ip地址)

    [S5820V2-54QS-GE_1]interface range GigabitEthernet 1/0/1 GigabitEthernet 2/0/1(进入到接口G1/0/1和G2/0/1中)

    [S5820V2-54QS-GE_1-if-range]undo stp enable(由于BFD MAD检测与生成树互斥,所以进入互连接口关闭生成树协议)

    这时我们的BFD-MAD检测机制就配置完成了。

    1、IRF正常运行时,只有主设备上配置的MAD IP地址生效,从设备上配置的MAD IP地址不生效,BFD会话处于down状态;

    2、分裂时变为两台设备,bfd会瞬时up;mad检测就会生效会让其中一台设备失效,备设备irf变为recovery状态,禁用端口后,bfd状态就又会变为down

    LACP-MAD检测

    作用:防止IRF 链路故障导致 IRF 分裂、网络中存在两个配置冲突的 IRF,需要启用 MAD检测功能。  在IRF配置完成后的基础上增加如下配置

    注:LACP MAD 和 BFD MAD、ARP MAD 冲突处理的原则不同,不能同时配置。BFD MAD、ARP MAD 这两种方式独立工作,彼此之间互不干扰,可以同时配置。

    LACP MAD 检测用于基于 LACP 的组网检测需求

    配置:先建立IRF连接后,在配置MAD检测机制

    IRF基本配置:

    (1)配置S5820V2-54QS-GE_1 交换机为Master

    设置成员号以及优先级(最大值为32,默认值(最小值)为1)

    [S5820V2-54QS-GE_1]irf member 1 priority 32(将设备优先级调整为32,确保选举为Master)

    把需要加入irf-port的端口down掉,shutdown XGE 1/0/51,XGE 1/0/52。并加入到相应的IRF group组

    [S5820V2-54QS-GE_1]interface range Ten-GigabitEthernet 1/0/51 to Ten-GigabitEthernet 1/0/52(进入到接口范围)

    [S5820V2-54QS-GE_1-if-range]shutdown(关闭接口)

    [S5820V2-54QS-GE_1]irf-port 1/2(创建一个IRF虚拟接口)

    [S5820V2-54QS-GE_1-irf-port1/1]port group interface Ten-GigabitEthernet 1/0/51(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_1-irf-port1/1]port group interface Ten-GigabitEthernet 1/0/52(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_1-irf-port1/1]quit(退出接口视图)

    将XGE 1/0/51,XGE 1/0/52这两个接口undo shutdown。

    [S5820V2-54QS-GE_1]interface range Ten-GigabitEthernet 1/0/51 to Ten-GigabitEthernet 1/0/52(进入到接口范围)

    [S5820V2-54QS-GE_1-if-range]undo shutdown(开启接口)

    激活IRF,然后保存配置

    [S5820V2-54QS-GE_1]irf-port-configuration active(激活IRF配置)

    [S5820V2-54QS-GE_1]save force(保存配置)

    (2)S5820V2-54QS-GE_2 交换机为Slave

    设置成员号及优先级,将设备号的1(因为华三设备号默认是1)改为2,因为我们要把这台做备份。

    [S5820V2-54QS-GE_2]irf member 1 renumber 2(将设备号的1改为2)

    [S5820V2-54QS-GE_2]save force (保存配置)

    <S5820V2-54QS-GE_2>reboot (重启设备)

    把需要加入irf-port的端口down掉,shutdown XGE 2/0/51,XGE 2/0/52。并加入到相应的IRF group组

    [S5820V2-54QS-GE_2]interface range Ten-GigabitEthernet 2/0/51 to Ten-GigabitEthernet 2/0/52(进入到接口范围)

    [S5820V2-54QS-GE_2-if-range]shutdown(关闭接口)

    [S5820V2-54QS-GE_2]irf-port 2/1(创建一个IRF虚拟接口)

    [S5820V2-54QS-GE_2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/51(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_2-irf-port2/1]port group interface Ten-GigabitEthernet 2/0/52(将这个物理接口与IRF虚拟接口做绑定)

    [S5820V2-54QS-GE_2-irf-port2/1]quit(退出接口视图)

    将XGE 2/0/51,XGE 2/0/52这两个接口undo shutdown。

    [S5820V2-54QS-GE_2]interface range Ten-GigabitEthernet 2/0/51 to Ten-GigabitEthernet 2/0/52(进入到接口范围)

    [S5820V2-54QS-GE_2-if-range]undo shutdown(开启接口)

    激活IRF,然后保存配置

    [S5820V2-54QS-GE_2]save force(保存配置)(这一步保存至关重要,如果没保存配置;IRF建立将会以失败告终)

    [S5820V2-54QS-GE_2]irf-port-configuration active(激活IRF配置)

    到了这步之后配置就基本上完成了,设备会自动进行Master竞选,失败的设备会自动重启,作为备份设备(Slave);

    我们可以使用这条命令可以查看IRF是否建立成功,display irf,如果出现以下的显示,就表示配置成功了。

    下面开始我们开始配置LACP MAD检测机制,这里我们采用LACP MAD检测。当IRF建立成功后,这两台设备统称为IRF设备。

    [S5820V2-54QS-GE_1]int Bridge-Aggregation 2 (创建一个名为2的聚合端口组)

    [S5820V2-54QS-GE_1-Bridge-Aggregation2]link-aggregation mode dynamic  (将此端口组的模式改为动态)

    [S5820V2-54QS-GE_1-Bridge-Aggregation2]mad enable (开启mad检测)

    [S5820V2-54QS-GE_1-Bridge-Aggregation2]quit  (退出接口视图)

    [S5820V2-54QS-GE_1]int range GigabitEthernet1/0/1 GigabitEthernet2/0/2  (同时进入这两个接口)

    [S5820V2-54QS-GE_1-if-range]port link-aggregation group 2 (将他们加入到这个接口组2中)

    SA配置:

    [SA]int Bridge-Aggregation 2  (创建一个名为2的聚合端口组)
    [SA-Bridge-Aggregation2]link-aggregation mode dynamic   (将此端口组的模式改为动态)
    [SA-Bridge-Aggregation2]quit (退出接口视图)
    [SA]int range g1/0/1 to g1/0/2  (进入到这两个接口)
    [SA-if-range]port link-aggregation group 2  (将这两个端口组加入到接口组2中)

    这时我们的LACP-MAD检测机制就配置完成了

    (有一些实例参考了博主:炒菜何必放盐

     

    展开全文
  • H3C HCL模拟器 交换机的irf堆叠配置方法 H3C HCL模拟器 交换机的链路聚合配置方法 H3C HCL模拟器telnet远程登录配置 H3C HCL模拟器web界面的配置 H3C HCL模拟器的vlan的划分和多端口的加入配置方法录配置命令 H3C ...
  • H3C_RIP基础配置案例

    2022-04-15 16:05:57
    H3C_RIP基础配置案例,原创文档。 适用于H3CV7版本的网络设备,包括交换机、路由器等。 搭建环境为HCL3.0.1,适用于刚入门的网络工程师学习参考。
  • 基于华三模拟器V3.0.1版本做的IRF堆叠实验
  • H3C交换机堆叠的基本配置

    千次阅读 2021-01-14 01:26:04
    刚刚新建了一口深信服aDesk桌面云机房,其中用于接入的两台交换机是H3C的5130S-EI。两台交换机采用堆叠方式,堆叠之后将四个光口做链路聚合上联至汇聚交换机。由于以前接触的H3C交换机都是基于V5平台的,这次的两台...

    刚刚新建了一口深信服aDesk桌面云机房,其中用于接入的两台交换机是H3C的5130S-EI。两台交换机采用堆叠方式,堆叠之后将四个光口做链路聚合上联至汇聚交换机。

    由于以前接触的H3C交换机都是基于V5平台的,这次的两台交换机采用的是V7平台。V7较之于之前的V5,在命令上有一些变化。这里就将基本配置过程做一个简要记录。

    拓扑图如下:

    因为HCL模拟器中只有一种型号的交换机,因此也就没得选择了,简要做个示意图。

    交换机1的49、50端口分别与交换机2的49、50端口相连。在做堆叠配置之前,先将光纤跳线断开,等到配置做完并保存之后再将光纤跳线插好。防止交换机做堆叠过程中自动重启造成配置没有保存。

    一、堆叠配置

    因为这两台交换机要进行堆叠,并且有些操作只有在堆叠之后才能做,所以第一步就是要对交换机进行堆叠操作。

    机房里面两台5130S-EI各有48个电口+4个SFP接口。48个电口均为千兆接口,用于连接桌面云终端和一台教师机。4个SFP接口,其中49和50分别由于堆叠,51和52用于链路聚合。下面有开始堆叠配置。

    拿到一台新设备,习惯性的恢复出厂设置,执行下面的命令

    reset saved-configuration,清除保存的配置信息

    reboot,选择N,不保存当前配置。然后选择Y,重启交换机。

    先在交换机2上面操作:

    system-view

    irf member 1 renumber 2

    save

    reboot

    重启之后,可以看到端口编号都变成2开头的了。

    system-view

    irf domain 1

    interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/50

    shutdown

    quit

    irf-port 2/2

    port group interface Ten-GigabitEthernet2/0/49

    port group interface Ten-GigabitEthernet2/0/50

    quit

    interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/50

    undo shutdown

    quit

    irf-port-configuration active

    quit

    save

    交换机1上面的配置:

    system-view

    irf member 1 priority 32

    irf domain 1

    interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/50

    shutdown

    quit

    irf-port 1/1

    port group interface Ten-GigabitEthernet1/0/49

    port group interface Ten-GigabitEthernet1/0/50

    quit

    interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/50

    undo shutdown

    quit

    irf-port-configuration active

    quit

    save

    如果以上配置没有问题,交换机重启之后堆叠成功。现在物理上的两台交换机成为逻辑上的一台交换机。查看关于堆叠配置信息如下:

    二、telnet与ssh登陆配置

    system-view

    telnet server enable

    ssh server enable

    local-user test class manage

    password simple 123456

    service-type telnet ssh terminal

    authorization-attribute user-role network-admin

    quit

    line console 0 1

    authentication-mode scheme

    quit

    user-interface vty 0 4

    authentication-mode scheme

    user-role network-admin

    protocol inbound all

    quit

    interface Vlan-interface 1

    ip address 192.168.88.28 24

    quit

    ip route-static 0.0.0.0 0 192.168.88.254

    ssh user testservice-type stelnet authentication-type password

    public-key local create rsa //创建密钥对,输入2048,默认已经存在,也可以不创建

    三、端口聚合

    interface Bridge-Aggregation 1

    quit

    interface range GigabitEthernet 1/0/51 to g 1/0/52 GigabitEthernet 2/0/51 to GigabitEthernet 2/0/52

    port link-aggregation group 1

    dhcp snooping trust

    quit

    interface Bridge-Aggregation 1

    port link-type trunk

    port trunk permit vlan all

    dhcp snooping trust

    quit

    四、其他配置

    dhcp enable

    dhcp snooping enable

    ntp-service unicast-server 139.78.100.163

    ntp-service unicast-server 133.100.9.2

    clock timezone CST add 08:00:00

    通过以上的配置,一台H3C的交换机初始配置就算是基本完成了,剩余的配置操作就可以不用到交换机现场,通过网络就可以远程进行配置了。

    展开全文
  • 之前发布了【H3C模拟器】静态路由与路由器实现Telnet服务 的文章,现在来还愿了。后续的实验就开始了,动态路由协议的RIP协议和OSPF协议,就在本章介绍了。 这里有个 Host 服务器主机:50.0.0.1/24。是需要在 ...

    之前发布了【H3C模拟器】静态路由与路由器实现Telnet服务 的文章,现在来还愿了。后续的实验就开始了,动态路由协议的RIP协议和OSPF协议,就在本章介绍了。

    这里有个 Host 服务器主机:50.0.0.1/24。是需要在 Oracle VM VirtualBox 管理器中创建 虚拟操作系统 的,操作系统的自身的网卡要设置为仅主机模式,并配置相应的IP地址以及相对应的交换机和路由器的网关。(其实跟在 Vmware WorkStation 创建虚拟机一个道理)才能在HCL中使用。Host 服务器主机其实可以更好的贴近生产环境,不过只是进行实验,可以不怎么需要配置Host 服务器主机。

    实验环境

    首先介绍该实验不动的配置信息:两台PC机(PCA,PCB)

    PCA 的配置:

    PCB 的配置:

    打开  Oracle VM VirtualBox,新建 => 新建虚拟电脑 => 使用ISO格式的操作系统镜像。后面就以同学的实际环境操作。这里就不做演示了。

    本机创建了一台 Ubuntu 2004 操作系统。 注意:网卡需要设置为仅主机(Host-Only)模式。并且将 Ubuntu 2004 的 IP地址设置为 50.0.0.1/24,这样就可以使用该主机了。在HCL中,就会找 Oracle VM VirtualBox 的主机是否有 50.0.0.1/24 IP地址的主机,有的话,就会自动接到 Host 主机中。

    RIP 动态路由的实验操作:

    RIP(Routing Information Protocol,路由信息协议)就是最典型的距离矢量路由协议,常用于在小型网络钟交互路由信息,它是最先得到广泛使用的IGP(内部网关协议:在自治系统AS内部使用的路由协议),由于其工作机制相对简单。

    目前RIP存在三个版本,分别是面向IPv4的RIPv1和RIPv2以及面向IPv6的RIPng。

    RTA 的配置:

    配置 RTA 的端口 IP 地址:

    <H3C>system-view

    System View: return to User View with Ctrl+Z.

    [H3C]sysname Router-RTA

    [Router-RTA]

    [Router-RTA]interface GigabitEthernet 0/0

    [Router-RTA-GigabitEthernet0/0]ip address 10.0.0.2 24

    [Router-RTA-GigabitEthernet0/0]quit

    [Router-RTA]interface GigabitEthernet 0/1

    [Router-RTA-GigabitEthernet0/1]ip address 20.0.0.1 24

    [Router-RTA-GigabitEthernet0/1]quit

    配置 RTA 的 RIP 动态路由协议:

    [Router-RTA]rip

    [Router-RTA-rip-1]version ?
      INTEGER<1-2>  RIP version

    [Router-RTA-rip-1]version 2

    [Router-RTA-rip-1]network 10.0.0.0?
      X.X.X.X  Network number

    [Router-RTA-rip-1]network 10.0.0.0

    [Router-RTA-rip-1]network 20.0.0.0

    查看 RTA 的 RIP 动态路由协议:

    [Router-RTA]display rip 1 database
       10.0.0.0/8, auto-summary
           10.0.0.0/24, cost 0, nexthop 10.0.0.2, RIP-interface
       20.0.0.0/8, auto-summary
           20.0.0.0/24, cost 0, nexthop 20.0.0.1, RIP-interface
       30.0.0.0/8, auto-summary
       30.0.0.0/8, cost 1, nexthop 20.0.0.2
       40.0.0.0/8, auto-summary
       40.0.0.0/8, cost 2, nexthop 20.0.0.2
       50.0.0.0/8, auto-summary
       50.0.0.0/8, cost 3, nexthop 20.0.0.2

    RTB 的配置:

    配置 RTB 的端口 IP 地址:

    <H3C>system-view

    System View: return to User View with Ctrl+Z.

    [H3C]sysname Router-RTB

    [Router-RTB]

    [Router-RTB]interface GigabitEthernet 0/0

    [Router-RTB-GigabitEthernet0/0]ip address 30.0.0.1 24

    [Router-RTB-GigabitEthernet0/0]quit

    [Router-RTB]interface GigabitEthernet 0/1

    [Router-RTB-GigabitEthernet0/1]ip address 20.0.0.2 24

    [Router-RTB-GigabitEthernet0/1]quit

    配置 RTB 的 RIP 动态路由协议:

    [Router-RTB]rip

    [Router-RTB-rip-1]version 2

    [Router-RTB-rip-1]network 20.0.0.0

    [Router-RTB-rip-1]network 30.0.0.0

    查看 RTB 的 RIP 动态路由协议:

    [Router-RTB]display rip 1 database
       10.0.0.0/8, auto-summary
       10.0.0.0/8, cost 1, nexthop 20.0.0.1
       20.0.0.0/8, auto-summary
           20.0.0.0/24, cost 0, nexthop 20.0.0.2, RIP-interface
       30.0.0.0/8, auto-summary
           30.0.0.0/24, cost 0, nexthop 30.0.0.1, RIP-interface
       40.0.0.0/8, auto-summary
       40.0.0.0/8, cost 1, nexthop 30.0.0.2
       50.0.0.0/8, auto-summary
       50.0.0.0/8, cost 2, nexthop 30.0.0.2

    RTC 的配置:

    配置 RTC 的端口 IP 地址:

    <H3C>system-view

    System View: return to User View with Ctrl+Z.

    [H3C]sysname Router-RTC

    [Router-RTC]

    [Router-RTC]interface GigabitEthernet 0/0

    [Router-RTC-GigabitEthernet0/0]ip address 30.0.0.2 24

    [Router-RTC-GigabitEthernet0/0]quit

    [Router-RTC]interface GigabitEthernet 0/1

    [Router-RTC-GigabitEthernet0/1]ip address 40.0.0.1 24

    [Router-RTC-GigabitEthernet0/1]quit

    配置 RTC 的 RIP动态路由协议:

    [Router-RTC]rip

    [Router-RTC-rip-1]version 2

    [Router-RTC-rip-1]network 30.0.0.0

    [Router-RTC-rip-1]network 40.0.0.0

    [Router-RTC-rip-1]quit

    查看 RTC 的 RIP 动态路由协议:

    [Router-RTC]display rip 1 database
       10.0.0.0/8, auto-summary
       10.0.0.0/8, cost 2, nexthop 30.0.0.1
       20.0.0.0/8, auto-summary
       20.0.0.0/8, cost 1, nexthop 30.0.0.1
       30.0.0.0/8, auto-summary
           30.0.0.0/24, cost 0, nexthop 30.0.0.2, RIP-interface
       40.0.0.0/8, auto-summary
           40.0.0.0/24, cost 0, nexthop 40.0.0.1, RIP-interface
       50.0.0.0/8, auto-summary
       50.0.0.0/8, cost 1, nexthop 40.0.0.2

    RTD 的配置:

    配置 RTD 的端口 IP 地址:

    <H3C>system-view

    System View: return to User View with Ctrl+Z.

    [Router-RTD]interface GigabitEthernet 0/1

    [Router-RTD-GigabitEthernet0/1]ip address 40.0.0.2 24

    [Router-RTD-GigabitEthernet0/1]quit

    [Router-RTD]interface GigabitEthernet 0/0

    [Router-RTD-GigabitEthernet0/0]ip address 50.0.0.2 24

    [Router-RTD-GigabitEthernet0/0]quit

    配置 RTD 的 RIP动态路由协议:

    [Router-RTD]rip

    [Router-RTD-rip-1]version 2

    [Router-RTD-rip-1]network 40.0.0.0

    [Router-RTD-rip-1]network 50.0.0.0

    查看 RTD 的 RIP 动态路由协议:

    [Router-RTD]display rip 1 database
       10.0.0.0/8, auto-summary
       10.0.0.0/8, cost 3, nexthop 40.0.0.1
       20.0.0.0/8, auto-summary
       20.0.0.0/8, cost 2, nexthop 40.0.0.1
       30.0.0.0/8, auto-summary
       30.0.0.0/8, cost 1, nexthop 40.0.0.1
       40.0.0.0/8, auto-summary
           40.0.0.0/24, cost 0, nexthop 40.0.0.2, RIP-interface
       50.0.0.0/8, auto-summary
           50.0.0.0/24, cost 0, nexthop 50.0.0.2, RIP-interface

    PC1 ping 通 PC2

    如果不通,可以逐个检查一下设备的路由表,看一下有没有学习到RIP的动态路由协议。

    RTD 路由器上做 Telnet 服务器

    1.1 密码登录

    [Router-RTD]telnet server enable

    [Router-RTD]user-interface vty ?(user-interface 是指用户界面)
      INTEGER<0-63>  Number of the first line

    [Router-RTD]user-interface vty 0 4(全称为Virtual Teletype Terminal,指虚拟终端。不带vty的,就是实实在在的端口。0是初始值,4是结束值。表示可同时打开5个会话,进入交换机去配置命令,并且使用的配置都是一样的。)

    [Router-RTD-line-vty0-4]authentication-mode ?(使用何种认证类型)
      none      Login without authentication
      password  Password authentication
      scheme    Authentication use AAA
    [Router-RTD-line-vty0-4]authentication-mode password(使用密码登录认证)

    [Router-RTD-line-vty0-4]set authentication password simple 123456(设置密码)

    1.2 测试密码登录

    2.1 用户名 + 密码登录

    # 创建用户

    [Router-RTD]local-user h3c

    [Router-RTD-luser-manage-h3c]password simple 123456

    [Router-RTD-luser-manage-h3c]service-type ?
      ftp       FTP service
      http      HTTP service type
      https     HTTPS service type
      pad       X.25 PAD service
      ssh       Secure Shell service
      telnet    Telnet service
      terminal  Terminal access service

    [Router-RTD-luser-manage-h3c]service-type telnet(用户设置 telnet 服务)

    [Router-RTD]user-interface vty 0 4

    [Router-RTD-line-vty0-4]authentication-mode ?
      none      Login without authentication
      password  Password authentication
      scheme    Authentication use AAA

    [Router-RTD-line-vty0-4]authentication-mode scheme

    [Router-RTD-line-vty0-4]user-role level-3(设置登录用户权限)

    2.2 测试用户名 + 密码登录

    OSPF 动态路由的实验操作:

    要在路由器上配置OSPF,必须首先进入系统视图,然后执行ospf [ process-id | router-id router-id]命令以使能OSPF进程,并且进入OSPF视图。

    执行ospf 命令时,如果不输入 process-id (该参数表示OSPF进程编号)的值,则 process-id 默认取值为1。router-id是一共32比特的二进制数,也经常表示为点分十进制数。如果在执行ospf 命令时不指定router-id,则路由器会根据某种规则自动生成一个值来作为router-id。

    [Router-RTA]ospf ?
      INTEGER<1-65535>  Process ID
      mib-binding       Bind MIB to an OSPF process
      router-id         OSPF Private Router ID
      vpn-instance      VPN instance
      <cr>

    (1)process-id为进程号,缺省值为1。

    路由器支持OSPF多进程,可以根据业务类型划分不同的进程。进程号是本地概念,不影响与其它路由器之间的报文交换。因此,不同的路由器之间,即使进程号不同也可以进行报文交换。

    (2)router-id router-id为路由器的ID号。

    缺省情况下,路由器系统会从当前接口的IP地址中自动选取一个最大值作为Router ID。手动配置Router ID时,必须保证自治系统中任意两台Router ID都不相同。通常的做法是将Router ID配置为与该设备某个接口的IP地址一致

    说明:

    每个OSPF进程的Router ID要保证在OSPF网络中唯一,否则会导致邻居不能正常建立、路由信息不正确的问题。建议在OSPF设备上单独为每个OSPF进程配置全网唯一的Router ID。

    (3)vpn-instance vpn-instance-name表示VPN实例。

    如果指定了VPN实例,那么此OSPF进程属于指定的VPN实例,如果未指定则属于公网实例。

    (4)area id

    区域是从逻辑上将设备划分为不同的组,每个组用区域号(AreaID)来标识。区域的边界是设备,而不是链路。一个网段(链路)只能属于一个区域,或者说每个运行OSPF的接口必须指明属于哪一个区域。

    因为 OSPF 比较试用于大型的网络,所以我们可以改造一下这个拓扑图。打算将静态路由,动态路由,设备之间的堆叠,以及设备telnet的使用。汇聚在一块。

    要求(实现没有先后顺序,只要能达到就行):

    1.在Router-01的区域主机之间相互ping通,即PC-A,PC-B 可以ping通,外部网络可以相互ping通,即PC-C,PC-D,PC-E,Server 1可以相互ping通。

    2.SW-C和SW-D使用静态路由到Area 1和Area 2

    3.使用OSPF(Area 0 ,Area 1 ,Area 2 ,Area 3,Area 4)将整个网络架构连接起来

    4.SW-A和SW-B ,SW-C和SW-D使用堆叠技术

    5.Server1可以 telnet Router-02

    顺序本人是打乱的,大家做实验可以先按自己的方式进行配置。

    设备接口配置信息
    设备接口名称接口IP地址

    Switch-A-Master(Switch-B-Slave)

    GE1/0/1(To:PC-A)Vlan-Interface 10:10.0.0.254/24
     GE1/0/2(To:Router-01)Vlan-Interface 1010:10.0.10.1/24
     GE2/0/1(To:PC-B)Vlan-Interface 20:20.0.0.254/24
     GE2/0/2(To:Router-01)Vlan-Interface 1020:20.0.10.1/24
    Router-01GE0/0(To:Switch-C-Master)192.168.20.1/24

     

    GE0/1(To:Switch-A-Master)10.0.10.2/24
     GE0/2(To:Switch-B-Slave)20.0.10.2/24

    Switch-C-Master(Switch-D-Slave)

    GE1/0/1(To:Router-01)Vlan-Interface 1920:192.168.20.2/24
     GE1/0/2(To:Router-04)Vlan-Interface 1910:192.168.10.2/24
     GE2/0/1(To:Router-05)Vlan-Interface 1710:172.31.10.2/24
     

    GE2/0/2(To:Router-02)

    Vlan-Interface 1720:172.31.20.1/24
    Router-02GE0/0(To:Switch-D-Slave)172.31.20.2/24
     GE0/1(To:PC-C)40.0.0.2/24
     GE0/2(To:Server1)50.0.0.2/24
    Router-03GE0/1(To:PC-D)192.168.1.254/24
     GE0/2(To:Router-04)192.168.2.1/24
    Router-04

    GE0/1(To:Switch-C-Master)

    192.168.10.1/24
     GE0/2(To:Router-03)192.168.2.2/24
    Router-05GE0/1(To:Switch-D-Slave)172.31.10.1/24
     GE0/2(To:Router-06)172.31.2.2/24
    Router-06GE0/1(To:PC-E)172.31.1.254/24
     GE0/2(To:Router-05)172.31.2.1/24
    PC机的相关配置信息
    PC机名称IP地址网关IP地址
    PC-A

    10.0.0.1/24

    10.0.0.254/24

    PC-B

    20.0.0.1/24

    20.0.0.254/24

    PC-C

    40.0.0.1/24

    40.0.0.2/24

    PC-D

    192.168.1.1/24

    192.168.1.254/24

    PC-E

    172.31.1.1/24

    172.31.1.254/24

    Server1

    50.0.0.1/24

    50.0.0.2/24

    1 配置交换机堆叠技术

    1.1.将SW-A-Master交换机和SW-B-Slave交换机做堆叠(添加描述)

    <H3C>system-view (加入到全局模式)
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Switch-A (设置交换机名称)

    [Switch-A]interface range FGE1/0/53 to FGE1/0/54 (将 FGE1/0/53 和 FGE1/0/54 关闭接口,shutdown掉)

    [Switch-A-if-range]shutdown

    [Switch-A]irf-port 1/2 (设置 IRF 堆叠)

    [Switch-A-irf-port1/2]port group interface FGE1/0/53 (添加接口)

    You must perform the following tasks for a successful IRF setup:
    Save the configuration after completing IRF configuration.
    Execute the "irf-port-configuration active" command to activate the IRF ports.

    [Switch-A-irf-port1/2]port group interface FGE1/0/54(添加接口)

    [Switch-A-irf-port1/2]display this (查看配置)
    #
    irf-port 1/2
     port group interface FortyGigE1/0/53
     port group interface FortyGigE1/0/54
    #
    return

    [Switch-A]interface range FortyGigE1/0/53 to  FortyGigE1/0/54(将 FGE1/0/53 和 FGE1/0/54 开启接口,undo shutdown)

    [Switch-A-if-range]undo shutdown

    [Switch-A]irf member 1 priority 30 (设置优先级)

    <Switch-A>save force (保存配置)

    [Switch-A]irf-port-configuration active (激活 IRF 配置)

    <H3C>system-view
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Switch-B

    [Switch-B]interface range FGE1/0/53 to FGE1/0/54

    [Switch-B-if-range]shutdown

    [Switch-B]irf member 1 renumber 2
    Renumbering the member ID may result in configuration change or loss. Continue?[Y/N]y

    <Switch-B>save force

    <Switch-B>reboot

    [Switch-B]interface range FGE2/0/53 to FGE2/0/54

    [Switch-B-if-range]shutdown

    [Switch-B]irf-port 2/1

    [Switch-B-irf-port2/1]port group interface FGE2/0/53
    You must perform the following tasks for a successful IRF setup:
    Save the configuration after completing IRF configuration.
    Execute the "irf-port-configuration active" command to activate the IRF ports.

    [Switch-B-irf-port2/1]port group interface FGE2/0/54

    [Switch-B-irf-port2/1]quit

    [Switch-B]int range FGE2/0/53 to FGE2/0/54

    [Switch-B-if-range]undo shutdown

    [Switch-B]irf member 2 priority 20

    <Switch-B>save force

    [Switch-B]irf-port-configuration active

    检查并添加描述

    [Switch-A]interface FGE1/0/53
    [Switch-A-FortyGigE1/0/53]description Switch-A-IRF-INT
    [Switch-A-FortyGigE1/0/53]quit

    [Switch-A]interface FGE1/0/54
    [Switch-A-FortyGigE1/0/54]description Switch-A-IRF-INT
    [Switch-A-FortyGigE1/0/54]quit

    [Switch-A]interface FGE2/0/53
    [Switch-A-FortyGigE2/0/53]description Switch-B-IRF-INT
    [Switch-A-FortyGigE2/0/53]quit

    [Switch-A]interface FGE2/0/54
    [Switch-A-FortyGigE2/0/54]description Switch-B-IRF-INT
    [Switch-A-FortyGigE2/0/54]quit

    [Switch-A]display irf

    [Switch-A]display irf configuration

    1.2.将SW-C-Master交换机和SW-D-Slave交换机做堆叠(添加描述)

    <H3C>system-view
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Switch-C

    [Switch-C]interface range FortyGigE1/0/53 to FortyGigE1/0/54

    [Switch-C-if-range]shutdown

    [Switch-C]irf-port 1/2

    [Switch-C-irf-port1/2]port group interface FortyGigE1/0/53
    You must perform the following tasks for a successful IRF setup:
    Save the configuration after completing IRF configuration.
    Execute the "irf-port-configuration active" command to activate the IRF ports.

    [Switch-C-irf-port1/2]port group interface FortyGigE1/0/54

    [Switch-C-irf-port1/2]quit

    [Switch-C]interface range FortyGigE1/0/53 to FortyGigE1/0/54

    [Switch-C-if-range]undo shutdown

    [Switch-C]irf member 1 priority 30

    [Switch-C]save force

    [Switch-C]irf-port-configuratio

    <H3C>system-view
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Switch-D

    [Switch-D]irf member 1 renumber 2
    Renumbering the member ID may result in configuration change or loss. Continue?[Y/N]y

    [Switch-D]save force
    <Switch-D>reboot

    [Switch-D]interface range FGE2/0/53 to FGE2/0/54

    [Switch-D-if-range]shutdown

    [Switch-D]irf-port 2/1

    [Switch-D-irf-port2/1]port group interface FGE2/0/53
    You must perform the following tasks for a successful IRF setup:
    Save the configuration after completing IRF configuration.
    Execute the "irf-port-configuration active" command to activate the IRF ports.

    [Switch-D-irf-port2/1]port group interface FGE2/0/54

    [Switch-D]interface range FGE2/0/53 to FGE2/0/54

    [Switch-D-if-range]undo shutdown

    [Switch-D-if-range]quit

    [Switch-D]irf member 2 priority 20

    [Switch-D]save force

    [Switch-D]irf-port-configuration active

    检查并添加描述

    [Switch-C]interface FGE1/0/53
    [Switch-C-FortyGigE1/0/53]description Switch-C-IRF-INT
    [Switch-C-FortyGigE1/0/53]quit

    [Switch-C]interface FGE1/0/54
    [Switch-C-FortyGigE1/0/54]description Switch-C-IRF-INT
    [Switch-C-FortyGigE1/0/54]quit

    [Switch-C]interface FGE2/0/53
    [Switch-C-FortyGigE2/0/53]description Switch-D-IRF-INT
    [Switch-C-FortyGigE2/0/53]quit


    [Switch-C]interface FGE2/0/54
    [Switch-C-FortyGigE2/0/54]description Switch-D-IRF-INT
    [Switch-C-FortyGigE2/0/54]quit

    [Switch-C]display irf

    [Switch-C]display irf configuration

    堆叠的部分就完成了,接着将拓扑图中的各个主机的IP地址进行配置。这部分就不做演示了。

    2.交换机以及路由器之间的接口进行配置

    Area 0区域的路由器以及交换机的配置:

    <H3C>system-view
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Router-04

    [Router-04]]interface GigabitEthernet 0/1

    [Router-04-GigabitEthernet0/1]ip address 192.168.10.1 24

    [Router-04-GigabitEthernet0/1]description To:Switch-C-Master

    [Router-04]interface GigabitEthernet 0/2

    [Router-04-GigabitEthernet0/2]ip address 192.168.2.2 24

    [Router-04-GigabitEthernet0/2]description To:Router-03

    <H3C>system-view
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Router-05

    [Router-05]interface GigabitEthernet 0/1

    [Router-05-GigabitEthernet0/1]ip address 172.31.10.1 24

    [Router-05-GigabitEthernet0/1]description To:Switch-D-Slave

    [Router-05-GigabitEthernet0/1]quit

    [Router-05]interface GigabitEthernet 0/2

    [Router-05-GigabitEthernet0/2]ip address 172.31.2.2 24

    [Router-05-GigabitEthernet0/2]description To:Router-06

    [Router-05-GigabitEthernet0/2]quit

    因为做了堆叠技术,所以 Switch-C 和 Switch-D 是一台设备,要在相对应的接口进行配置IP地址和划分VLAN(每设置一个接口之后,跟直连的设备进行ping操作)

    [Switch-C]vlan 1920
    [Switch-C-vlan1920]vlan 1910
    [Switch-C-vlan1910]vlan 1710
    [Switch-C-vlan1710]vlan 1720

    [Switch-C]interface Vlan-interface 1920

    [Switch-C-Vlan-interface1920]ip address 192.168.20.2 24

    [Switch-C-Vlan-interface1920]description To:Router-01

    [Switch-C-Vlan-interface1920]quit

    [Switch-C]interface Vlan-interface 1910

    [Switch-C-Vlan-interface1910]ip address 192.168.10.2 24

    [Switch-C-Vlan-interface1910]description To:Router-04

    [Switch-C-Vlan-interface1910]quit

    [Switch-C]interface Vlan-interface 1710

    [Switch-C-Vlan-interface1710]ip address 172.31.10.2 24

    [Switch-C-Vlan-interface1710]description To:Router-05

    [Switch-C-Vlan-interface1710]quit

    [Switch-C]interface Vlan-interface 1720

    [Switch-C-Vlan-interface1720]ip address 172.31.20.1 24

    [Switch-C-Vlan-interface1720]description To:Router-02

    [Switch-C-Vlan-interface1720]quit

    [Switch-C]interface GigabitEthernet 1/0/1

    [Switch-C-GigabitEthernet1/0/1]port link-type trunk

    [Switch-C-GigabitEthernet1/0/1]port trunk pvid vlan 1920

    [Switch-C-GigabitEthernet1/0/1]port trunk permit vlan all

    [Switch-C-GigabitEthernet1/0/1]description To:Router-01

    [Switch-C]interface GigabitEthernet 1/0/2

    [Switch-C-GigabitEthernet1/0/2]port link-type trunk

    [Switch-C-GigabitEthernet1/0/2]port trunk pvid vlan 1910

    [Switch-C-GigabitEthernet1/0/2]port trunk permit vlan all

    [Switch-C-GigabitEthernet1/0/2]description To:Router-04

    [Switch-C]interface GigabitEthernet 2/0/1

    [Switch-C-GigabitEthernet2/0/1]port link-type trunk

    [Switch-C-GigabitEthernet2/0/1]port trunk pvid vlan 1720

    [Switch-C-GigabitEthernet2/0/1]port trunk permit vlan all

    [Switch-C-GigabitEthernet2/0/1]description To:Router-02

    [Switch-C]interface GigabitEthernet 2/0/2

    [Switch-C-GigabitEthernet2/0/2]port link-type trunk

    [Switch-C-GigabitEthernet2/0/2]port trunk pvid vlan 1710

    [Switch-C-GigabitEthernet2/0/2]port trunk permit vlan all

    [Switch-C-GigabitEthernet2/0/2]description To:Router-05

    Area 1区域的路由器的配置:

    <H3C>system-view
    System View: return to User View with Ctrl+Z.
    [H3C]sysname Router-03

    [Router-03]interface GigabitEthernet 0/1
    [Router-03-GigabitEthernet0/1]ip address 192.168.1.254 24
    [Router-03-GigabitEthernet0/1]description To:PC-D
    [Router-03-GigabitEthernet0/1]quit

    [Router-03]interface GigabitEthernet 0/2
    [Router-03-GigabitEthernet0/2]ip address 192.168.2.1 24
    [Router-03-GigabitEthernet0/2]description To:Router-04
    [Router-03-GigabitEthernet0/2]quit

    Area 2区域的路由器的配置:

    <H3C>system-view
    System View: return to User View with Ctrl+Z.
    [H3C]sysname Router-06

    [Router-06]interface GigabitEthernet 0/1

    [Router-06-GigabitEthernet0/1]ip address 172.31.1.254 24

    [Router-06-GigabitEthernet0/1]description To:PC-E

    [Router-06-GigabitEthernet0/1]quit

    [Router-06]interface GigabitEthernet 0/2

    [Router-06-GigabitEthernet0/2]ip address 172.31.2.1 24

    [Router-06-GigabitEthernet0/2]description To:Router-05

    [Router-06-GigabitEthernet0/2]quit

    Area 3区域的路由器以及交换机的配置:

    因为做了堆叠技术,所以 Switch-A 和 Switch-B 是一台设备,要在相对应的接口进行配置IP地址和划分VLAN(每设置一个接口之后,跟直连的设备进行ping操作)

    [Switch-A]vlan 10 to 20

    [Switch-A]interface Vlan-interface 10

    [Switch-A-Vlan-interface10]ip address 10.0.0.254 24

    [Switch-A]interface GigabitEthernet 1/0/1

    [Switch-A-GigabitEthernet1/0/1]description To:PC-A

    [Switch-A-GigabitEthernet1/0/1]port link-type access

    [Switch-A-GigabitEthernet1/0/1]port access vlan 10

    [Switch-A-GigabitEthernet1/0/1]ping 10.0.0.1
    Ping 10.0.0.1 (10.0.0.1): 56 data bytes, press CTRL_C to break
    56 bytes from 10.0.0.1: icmp_seq=0 ttl=255 time=3.000 ms

    [Switch-A]interface Vlan-interface 20

    [Switch-A-Vlan-interface20]ip address 20.0.0.254 24

    [Switch-A-Vlan-interface20]quit

    [Switch-A]interface GigabitEthernet 2/0/1

    [Switch-A-GigabitEthernet2/0/1]description To:PC-B

    [Switch-A-GigabitEthernet2/0/1]port link-type access

    [Switch-A-GigabitEthernet2/0/1]ping 20.0.0.1
    Ping 20.0.0.1 (20.0.0.1): 56 data bytes, press CTRL_C to break
    56 bytes from 20.0.0.1: icmp_seq=0 ttl=255 time=5.000 ms

    [Switch-A]vlan 1010 to 1020

    [Switch-A]interface Vlan-interface 1010

    [Switch-A-Vlan-interface1010]ip address 10.0.10.1 24

    [Switch-A-Vlan-interface1010]quit

    [Switch-A]interface Vlan-interface 1020

    [Switch-A-Vlan-interface1020]ip address 20.0.10.1 24

    [Switch-A-Vlan-interface1020]quit

    [Switch-A]interface GigabitEthernet 1/0/2

    [Switch-A-GigabitEthernet1/0/2]port link-type access

    [Switch-A-GigabitEthernet1/0/2]port access vlan 1010

    [Switch-A]interface GigabitEthernet 2/0/2

    [Switch-A-GigabitEthernet2/0/2]port link-type access

    [Switch-A-GigabitEthernet2/0/2]port access vlan 1020

    Router-01 路由器配置: 

    <H3C>system-view
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Router-01

    [Router-01]interface GigabitEthernet 0/1

    [Router-01-GigabitEthernet0/1]ip address 10.0.10.2 24

    [Router-01-GigabitEthernet0/1]description Switch-A-Master

    [Router-01]interface GigabitEthernet 0/2

    [Router-01-GigabitEthernet0/2]ip address 20.0.10.2 24

    [Router-01-GigabitEthernet0/2]description Switch-B-Slave

    [Router-01]interface GigabitEthernet 0/0

    [Router-01-GigabitEthernet0/0]ip address 192.168.20.1 24

    [Router-01-GigabitEthernet0/0]description Switch-C-Master

    Area 4区域的路由器的配置:

    <H3C>system-view
    System View: return to User View with Ctrl+Z.

    [H3C]sysname Router-02

    [Router-02]interface GigabitEthernet 0/0

    [Router-02-GigabitEthernet0/0]ip address 172.31.20.2 24

    [Router-02-GigabitEthernet0/0]quit

    [Router-02]interface GigabitEthernet 0/1

    [Router-02-GigabitEthernet0/1]ip address 40.0.0.2 24

    [Router-02-GigabitEthernet0/1]quit

    [Router-02]interface GigabitEthernet 0/2

    [Router-02-GigabitEthernet0/2]ip address 50.0.0.2 24

    [Router-02-GigabitEthernet0/2]quit

    SW-C和SW-D使用静态路由到Area 1和Area 2

    因为做了堆叠技术,所以 Switch-C 和 Switch-D 是一台设备,只要配置相应的静态路由即可。当然其实后面的OSPF动态路由也可以实现。

    这里为了巩固其静态路由的工作原理。检验的方式就是Switch-C可以ping通PC-E,PC-D

    路由器配置静态路由:

    Router-03,Router-04,Router-05,Router-06配置静态路由

    [Router-03]ip route-static 192.168.10.0 24 192.168.2.2

    [Router-04]ip route-static 192.168.1.0 24 192.168.2.1

    [Router-05]ip route-static 172.31.1.0 24 172.31.2.1

    [Router-06]ip route-static 172.31.10.0 24 172.31.2.2

    交换机配置静态路由:

    Switch-C 配置静态路由

    [Switch-C] ip route-static 172.31.1.0 24 172.31.10.1
    [Switch-C] ip route-static 172.31.2.0 24 172.31.10.1
    [Switch-C] ip route-static 192.168.1.0 24 192.168.10.1
    [Switch-C] ip route-static 192.168.2.0 24 192.168.10.1

    检验:Switch-C可以ping通PC-E,PC-D

    使用OSPF将整个网络架构连接起来

    可以看出使用静态路由配置比较大型的网络会显得十分吃力,这个时候就需要使用动态路由协议来帮助网络工程师实现网络的互联互通。使用OSPF动态路由协议将网络结构连接起来。注意使用OSPF时,需要使用反掩码。

    路由器Router-01,Router-02,Router-03,Router-04,Router-05,Router-06分别对应OSPF中Router-id的1.1.1.1,2.2.2.2,3.3.3.3,4.4.4.4,5.5.5.5,6.6.6.6。

    交换机SW-A-Master,SW-C-Master分别对应OSPF中Router-id的11.11.11.11,22.22.22.22。当然OSPF有时候也是需要跟静态路由配合使用。

    OSPF Area 0 区域:

    [Switch-C]ospf 1
    [Switch-C-ospf-1]display this
    #
    ospf 1 router-id 22.22.22.22
     area 0.0.0.0
      network 172.31.10.0 0.0.0.255
      network 192.168.10.0 0.0.0.255
     area 0.0.0.3
      network 192.168.20.0 0.0.0.255
     area 0.0.0.4
      network 172.31.20.0 0.0.0.255
     area 0.0.0.5
      network 10.0.0.0 0.0.0.255
     area 0.0.0.6
      network 20.0.0.0 0.0.0.255
    #
    return

    [Router-04]ospf 1
    [Router-04-ospf-1]display this
    #
    ospf 1 router-id 4.4.4.4
     area 0.0.0.0
      network 192.168.10.0 0.0.0.255
     area 0.0.0.1
      network 192.168.2.0 0.0.0.255
    #
    return

    [Router-05]ospf 1
    [Router-05-ospf-1]display this
    #
    ospf 1 router-id 5.5.5.5
     area 0.0.0.0
      network 172.31.10.0 0.0.0.255
     area 0.0.0.2
      network 172.31.2.0 0.0.0.255
    #
    return

    OSPF Area 1 区域:

    [Router-03]ospf 1 router-id 3.3.3.3

    [Router-03-ospf-1]area 1

    [Router-03-ospf-1-area-0.0.0.1]network 192.168.1.0 0.0.0.255

    [Router-03-ospf-1-area-0.0.0.1]network 192.168.2.0 0.0.0.255

    OSPF Area 2 区域:

    [Router-06]ospf 1 router-id 6.6.6.6

    [Router-06-ospf-1]area 2

    [Router-06-ospf-1-area-0.0.0.2]network 172.31.1.0 0.0.0.255

    [Router-06-ospf-1-area-0.0.0.2]network 172.31.2.0 0.0.0.255

    OSPF Area 3 区域:

    [Router-01]ospf 1
    [Router-01-ospf-1]display this
    #
    ospf 1 router-id 1.1.1.1
     area 0.0.0.0
      network 192.168.20.0 0.0.0.255
     area 0.0.0.3
      network 10.0.10.0 0.0.0.255
      network 20.0.10.0 0.0.0.255
    #
    return

    OSPF Area 4 区域:

    [Router-02]ospf 1 router-id 2.2.2.2

    [Router-02-ospf-1]area 4

    [Router-02-ospf-1-area-0.0.0.4]network 40.0.0.0 0.0.0.255

    [Router-02-ospf-1-area-0.0.0.4]network 50.0.0.0 0.0.0.255

    [Router-02-ospf-1-area-0.0.0.4]network 172.31.20.0 0.0.0.255

    OSPF Area 5 Area 6区域:

    [Switch-A]ospf 1
    [Switch-A-ospf-1]display this
    #
    ospf 1 router-id 11.11.11.11
     area 0.0.0.3
      network 10.0.10.0 0.0.0.255
      network 20.0.10.0 0.0.0.255
     area 0.0.0.5
      network 10.0.0.0 0.0.0.255
     area 0.0.0.6
      network 20.0.0.0 0.0.0.255
    #
    return

    PC-A 和 PC-B互通

    PC-C与Server 1 PC-E,PC-D互通

    Server1可以telnet Router-02

    1.1 密码登录

    [Router-02]ssh server enable

    [Router-02]telnet server enable

    [Router-02]user-interface vty 0 4

    [Router-02-line-vty0-4]authentication-mode password

    [Router-02-line-vty0-4]set authentication password simple 123456

    1.2 测试密码登录

     

    2.1 用户名 + 密码登录(telnet)

    # 创建用户

    [Router-02]local-user h3c
    New local user added.
    [Router-02-luser-manage-h3c]password simple 123456
    [Router-02-luser-manage-h3c]service-type ssh telnet

    [Router-02]user-interface vty 0 4

    [Router-02-line-vty0-4]authentication-mode ?
      none      Login without authentication
      password  Password authentication
      scheme    Authentication use AAA

    [Router-02-line-vty0-4]authentication-mode scheme

    [Router-02-line-vty0-4]user-role level-3(设置登录用户权限)

    2.2 测试用户名 + 密码登录

     

    展开全文
  • 虚拟化堆叠技术-典型配置H3C IRF

    千次阅读 2022-03-30 09:17:29
    华三模拟器0.1.H3C HCL链接: https://pan.baidu.com/s/1C7_soM1aCbt8GSQlv8mNfw 提取码: iwge 1.华为…https://zhuanlan.zhihu.com/p/442906734 1.简介 虚拟化技术是将多台物理的网络设备变成为一台逻辑设备,从...
  • H3C -S5130S接入层部署堆叠

    万次阅读 2018-02-28 21:03:09
    接入层堆叠的意义:&lt;1&gt;方便管理,登录一台可管理所有成员;不利是增加MSTP计算。 &lt;2&gt;上行链路如果是汇聚或核心,可连坐LACP MAD; 但是接入层不需要太麻烦,多台设备堆叠,只要有两条...
  • HCL配置 IRF 堆叠实验

    千次阅读 2020-07-20 20:35:13
    掌握 IRF 堆叠配置方法 实验拓扑 注意:配置 IRF 需要用万兆接口,即FGE 或 XGE 开头的接口 实验过程 实验任务一:配置 IRF 堆叠 SWA和SWB配置 IRF,堆叠为一台交换机 步骤一:查看设备编号 使用命令display irf...
  • 硬件虚拟化IRF(智能弹性框架)带来的优势:组网简化:如下图所示,传统的3层架构,核心交换机之间使用了以太捆绑,和接入层交换机运行STP,此时导致接入交换机之间只有部分处于转发状态(可以通过MSTP调整优化不同...
  • 数据中心交换机都用上了,你还在玩堆叠?vrrp?确定不用上DRNI/VPC/M-LAG ? 先上拓扑。由于笔者去年某日受到一同行大佬的“指点”(chao feng),“你连M-LAG都不知道?那你配什么VPC?”所以,笔者一直想要自己...
  • HCL是新华三集团推出的全真网络设备模拟软件。HCL可以模拟路由器、交换机、防火墙等网络设备及PC的全部功能,是大家学习、测试基于H3C公司ComwareV7平台的网络设备的必备工具。
  • 华三交换机重启命令(范文篇).doc

    千次阅读 2020-12-23 17:53:26
    华三交换机重启命令(范文篇).doc华三交换机重启命令(范文3篇)以下是网友分享的关于华三交换机重启命令的资料3篇,希望对您有所帮助,就爱阅读感谢您的支持。[华三交换机重启命令篇一]重启交换机命令程控交换机中RF...
  • 模拟器的交换机没有sn码,那就dis irf靠设备的自身唯一的桥MAC来试一试,笔记本下载HFS简易http服务器软件,上传startup.cfg,还有一个main.cfg,第一个给SW1做启动文件,第二个给SW2做启动文件。dhcp服务器配置:...
  • H3C常见问题

    万次阅读 2017-05-11 11:10:17
    H3C 官方网站的 MSR36-20 ( V7 )配置指导手册。 4.      模拟器上的设备如何指定用户优先级? 模拟器上选用的设备均为 Comware V7 平台的设备,与我们常见的 Comware V5 平台的在用户优先级上的...
  • 华三STP、RSTP、MSTP的详解

    千次阅读 2021-08-02 11:08:08
    配置代码: [H3C-GigabitEthernet1/0/2]stp root-protection [H3C-GigabitEthernet1/0/2]%Aug 2 10:06:39:103 2021 H3C STP/4/STP_ROOT_PROTECTION: Instance 2's ROOT-Protection port GigabitEthernet1/0/2 ...
  • 发现有许多读者对Cisco交换机中的堆叠连接及两种连接方式还是搞不清,特别是它们的连接原理,所以在此把我在《Cisco/H3C交换机配置与管理完全手册》(第二版)中介绍的最新Cisco交换机堆叠技术摘选如下: ...
  • 1)熟悉H3C 模拟器的使用 2)项目设计中相关技术理论的学习和回顾 交换部分:VLAN、链路聚合、MSTP(STP)、 VRRP、 路由部分: OSPF、NAT、无线 应用:DHCP、WEB 安全:防火墙 3)分析用户需求 4)分别在...
  • 史上最具人气、最受好评的网络设备图书领域“四大金刚”的全新升级版本再现江湖了,他们分别是:《Cisco交换机配置与管理完全手册》(第二版)、《H3C交换机配置与管理完全手册》(第二版)、《Cisco路由器配置与...
  • 安装h3c的问题!!!

    2019-03-14 08:52:31
    一、 安装类问题 HCL安装完成后,启动HCL后,虚拟设备启动特别慢,点击打开命令行,弹出对话框后不显示任何信息,也不能输入命令问题? 该问题是由于宿主机的VT-x或AMD-V功能没有打开,导致虚拟机运行缓慢。...H...
  • HCL是新华三集团推出的全真网络设备模拟软件。HCL可以模拟路由器、交换机、防火墙等网络设备及PC的全部功能,是大家学习、测试基于H3C公司ComwareV7平台的网络设备的必备工具。
  • h3c规格类问题

    2019-03-06 21:55:56
    一、HCL支持的设备有哪些?...1.不仅是QOS存在此问题QOS,MQC和ACL计数统计功能等需要硬件芯片来实现,模拟器不支持此功能。三、HCL是否支持IRF2?在HCL的目前版本中,仅S5820V2支持IRF2功能,最多支持4台...
  • 在中国,您知道的交换机品牌,一闪而过更多的是思科,华为,H3C,JUNIPER ,甚至QUANTA 交换机,其它我们可以看到时2018 年Gartner数据中心网络魔力象限图中,Gartner再次把戴尔放在了最有创新性最有远见的数据象限中...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,338
精华内容 535
关键字:

h3c模拟器堆叠