精华内容
下载资源
问答
  • 2021-09-03 09:17:06

           这些全部是我自己总结和结论,感觉我提供的知识点不错的,可以给我点个关注!也可以进行私聊讨论。

    交换机1:

    #

    interface GigabitEthernet0/0/0

     ip address 192.168.10.1 255.255.255.0

    #

    interface GigabitEthernet0/0/1

     ip address 12.0.0.1 255.255.255.0

    #

    ip route-static 0.0.0.0 0.0.0.0 12.0.0.2

    #

    交换机2:

    #

    interface GigabitEthernet0/0/0

     ip address 12.0.0.2 255.255.255.0

    #

    interface GigabitEthernet0/0/1

     ip address 192.168.20.1 255.255.255.0

    #

    ip route-static 0.0.0.0 0.0.0.0 12.0.0.1

    #

     

    更多相关内容
  • 华为交换机配置策略路由

    千次阅读 2020-06-19 18:57:39
    https://support.huawei.com/enterprise/zh/doc/EDOC1000069432?section=j00f 工作繁重,时间紧迫,先留图流链接。待来日有时间再整理。

    学习链接:https://support.huawei.com/enterprise/zh/doc/EDOC1000069432?section=j00f

     

    策略路由与路由策略(Routing Policy)存在以下不同:

    • 策略路由的操作对象是数据包,在路由表已经产生的情况下,不按照路由表进行转发,而是根据需要,依照某种策略改变数据包转发路径。
    • 路由策略的操作对象是路由信息。路由策略主要实现了路由过滤和路由属性设置等功能,它通过改变路由属性(包括可达性)来改变网络流量所经过的路径。

    目的

        传统的路由转发原理是首先根据报文的目的地址查找路由表,然后进行报文转发。但是目前越来越多的用户希望能够在传统路由转发的基础上根据自己定义的策略进行报文转发和选路。配置策略路由可以将到达接口的三层报文重定向到指定的下一跳地址。

    前置任务

    在配置策略路由前,需要完成以下任务:

    • 配置相关接口的IP地址和路由协议,保证路由互通。

    • 如果使用ACL作为策略路由的流分类规则,配置相应的ACL。

     

    背景信息

    早先已经对接了一个BGP网络,故交换机已经配置了一个默认网关;

    现因业务需要,新增了一段电信IP。

    BGP网络和电信网络分别是通过不同内网IP互联互通,简单的默认路由没办法同时配置两段公网。

    所以想到用策略路由方式:源IP为电信IP段的数据包,重定向到电信网络的内网互联IP。

    配置思路

    采用重定向方式实现策略路由,进而提供差分服务,具体配置思路如下:

    1. 创建VLAN并配置各接口,实现公司和外部网络设备互连。
    2. 配置ACL规则,匹配源IP地址为电信IP段的报文。
    3. 配置流分类,匹配规则为上述ACL规则,使设备可以对报文进行区分。
    4. 配置流行为,使满足电信数据包规则的报文重定向到上联运营商172.16.5.137。
    5. 配置流策略,绑定上述流分类和流行为,并应用到接口vlan if 901的入方向上,实现策略路由。

    操作步骤

    #先创建vlan 用于电信网络
    <Nxera-YC> system-view
    [Nxera-YC] sysname Switch
    [Nxera-YC] vlan 901
    
    #创建VLANIF901,并配置各虚拟接口IP地址。
    [Nxera-YC] int vlan 901                                                                                                   [Nxera-YC-vlan901] ip addr 1XX.1XX.2XX.1 24
    [Nxera-YC-vlan901] quit
    
    #在Switch上创建编码为3002的高级ACL,规则允许源IP地址为1XX.1XX.2XX.0/24的报文通过。
    [Nxera-YC] acl 3002
    [Nxera-YC-acl-adv-3002] rule permit ip source 1XX.1XX.2XX.0 0.0.0.255
    [Nxera-YC-acl-adv-3002] quit
    
    #在Switch上创建流分类c2,匹配规则ACL 3002。
    [Nxera-YC] traffic classifier c2 operator or
    [Nxera-YC-classifier-c2] if-match acl 3002
    [Nxera-YC-classifier-c2] quit
    
    #在Switch上创建流行为b2,指定重定向到172.16.5.137的动作。
    [Nxera-YC] traffic behavior b2
    [Nxera-YC-behavior-b2] redirect ip-nexthop 172.16.5.137
    [Nxera-YC-behavior-b2] quit
    
    # 在Switch上创建流策略p2,将流分类和对应的流行为进行绑定。
    [Nxera-YC] traffic policy p2
    [Nxera-YC-trafficpolicy-p1] classifier c2 behavior b2
    [Nxera-YC-trafficpolicy-p1] quit
    
    # 将流策略p2应用到接口vlan if 901的入方向上。
    [Nxera-YC] int vlan 901
    [Nxera-YC-vlan901] traffic-policy p2 inbound
    [Nxera-YC-vlan901] return

     

    验证配置结果(可以参考官文中的验证方法)

    # 查看ACL规则的配置信息。
    <Switch> display acl 3001
    Advanced ACL 3001, 1 rule
    Acl's step is 5
     rule 5 permit ip source 192.168.100.0 0.0.0.255 (match-counter 0)
    <Switch> display acl 3002
    Advanced ACL 3002, 1 rule
    Acl's step is 5
     rule 5 permit ip source 192.168.101.0 0.0.0.255 (match-counter 0)
    
    
    # 查看流分类的配置信息。
    <Switch> display traffic classifier user-defined
      User Defined Classifier Information:
        Classifier: c2
         Precedence: 10
         Operator: OR
         Rule(s) :if-match acl 3002
            
        Classifier: c1
          Precedence: 5
          Operator: OR
          Rule(s) : if-match acl 3001
    
    Total classifier number is 2  
    
    
    # 查看流策略的配置信息。
    <Switch> display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c1
        Operator: OR
         Behavior: b1
          Redirect: no forced
            Redirect ip-nexthop
            10.1.20.1
       Classifier: c2
        Operator: OR
         Behavior: b2
          Redirect: no forced
            Redirect ip-nexthop
            10.1.30.1

     

    展开全文
  • 华为交换机配置静态路由

    千次阅读 2019-10-29 11:07:33
    处于不同交换机下(不同网段)的PC机,相互进行通信 配置思路 采用如下的思路配置IPv4静态路由: 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通。 在各主机上配置IP缺省...

    组网需求:

    处于不同交换机下(不同网段)的PC机,相互进行通信

    配置思路

    采用如下的思路配置IPv4静态路由:

    1. 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通。
    2. 在各主机上配置IP缺省网关,在各台Switch上配置IPv4静态路由或者静态缺省路由,实现不配置动态路由协议,使不同网段的任意两台主机之间能够互通

    路由信息:

    SW1:
    
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.2
    
    SW2:
    ip route-static 10.1.1.0 255.255.255.248 10.2.4.1
    ip route-static 10.1.2.0 255.255.255.248 10.2.4.6
    ip route-static 10.1.3.0 255.255.255.248 10.2.4.10
    SW3:
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.5
    SW4:
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.9

    SW1配置,其它类似:

    [SW1] sysname SW1

    [SW1] vlan batch 10 30

    [SW1] interface Vlanif 10

    [SW1] ip address 10.2.4.1 255.255.255.252

    [SW1] dhcp enable

    [SW1] interface Vlanif 30

    [SW1] ip address 10.1.1.1 255.255.255.248

    [SW1] port-group vlan30

    [SW1] group-member GigabitEthernet0/0/1 to GigabitEthernet0/0/5

    [SW1] port link-type access

    [SW1] port default vlan 30

    [SW1] interface Eth-Trunk 1

    [SW1] mode lacp-static

    [SW1] trunkport GigabitEthernet 0/0/23 to 0/0/24

    [SW1] port link-type trunk

    [SW1] port trunk allow-pass vlan 10

    [SW1] ip route-static 0.0.0.0 0.0.0.0 10.2.4.2

    <SW1>save

     

    测试:

    查看SW2路由表:

    <SW2>dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           10.1.1.0/29  Static  60   0          RD   10.2.4.1        Vlanif10
           10.1.2.0/29  Static  60   0          RD   10.2.4.6        Vlanif20
           10.1.3.0/29  Static  60   0          RD   10.2.4.10       Vlanif40
           10.2.4.0/30  Direct  0    0           D   10.2.4.2        Vlanif10
           10.2.4.2/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.2.4.4/30  Direct  0    0           D   10.2.4.5        Vlanif20
           10.2.4.5/32  Direct  0    0           D   127.0.0.1       Vlanif20
           10.2.4.8/30  Direct  0    0           D   10.2.4.9        Vlanif40
           10.2.4.9/32  Direct  0    0           D   127.0.0.1       Vlanif40
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    

    SW1配置文件:

    [SW1]dis current-configuration 
    #
    sysname SW1
    #
    vlan batch 10 30
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    dhcp enable
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
    
    Oct 29 2019 10:42:51-08:00 SW1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 26, the ch
    ange loop count is 0, and the maximum number of records is 4095. local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif10
     ip address 10.2.4.1 255.255.255.252
    #
    interface Vlanif30
     ip address 10.1.1.1 255.255.255.248
     dhcp select interface
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
    #
    interface GigabitEthernet0/0/20
    #
    interface GigabitEthernet0/0/21
    #
    interface GigabitEthernet0/0/22
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.2
    #
    user-interface con 0
    user-interface vty 0 4
    #
    port-group vlan30
     group-member GigabitEthernet0/0/1
     group-member GigabitEthernet0/0/2
     group-member GigabitEthernet0/0/3
     group-member GigabitEthernet0/0/4
     group-member GigabitEthernet0/0/5
    #
    return

    SW2配置文件:

    [SW2]dis current-configuration 
    #
    sysname SW2
    #
    vlan batch 10 20 40
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif10
     ip address 10.2.4.2 255.255.255.252
    #
    interface Vlanif20
     ip address 10.2.4.5 255.255.255.252
    #
    interface Vlanif40
     ip address 10.2.4.9 255.255.255.252
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10
     mode lacp-static
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 20
     mode lacp-static
    #
    interface Eth-Trunk3
     port link-type trunk
     port trunk allow-pass vlan 40
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface GigabitEthernet0/0/3
    #
    interface GigabitEthernet0/0/4
    #
    interface GigabitEthernet0/0/5
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
     eth-trunk 2
    #
    interface GigabitEthernet0/0/20
     eth-trunk 2
    #
    interface GigabitEthernet0/0/21
     eth-trunk 3
    #
    interface GigabitEthernet0/0/22
     eth-trunk 3
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 10.1.1.0 255.255.255.248 10.2.4.1
    ip route-static 10.1.2.0 255.255.255.248 10.2.4.6
    ip route-static 10.1.3.0 255.255.255.248 10.2.4.10
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return

    SW3配置文件:

    [SW3]dis current-configuration 
    #
    sysname SW3
    #
    vlan batch 20 50
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    dhcp enable
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif20
     ip address 10.2.4.6 255.255.255.252
    #
    interface Vlanif50
     ip address 10.1.2.1 255.255.255.248
     dhcp select interface
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 20
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
    #
    interface GigabitEthernet0/0/20
    #
    interface GigabitEthernet0/0/21
    #
    interface GigabitEthernet0/0/22
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.5
    #
    user-interface con 0
    user-interface vty 0 4
    #
    port-group vlan50
     group-member GigabitEthernet0/0/1
     group-member GigabitEthernet0/0/2
     group-member GigabitEthernet0/0/3
     group-member GigabitEthernet0/0/4
     group-member GigabitEthernet0/0/5
    #

    SW4配置文件:

    [SW4]dis cur
    #
    sysname SW4
    #
    vlan batch 40 60
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    dhcp enable
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface Vlanif40
     ip address 10.2.4.10 255.255.255.252
    #
    interface Vlanif60
     ip address 10.1.3.1 255.255.255.248
     dhcp select interface
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 40
     mode lacp-static
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 60
    #
    interface GigabitEthernet0/0/6
    #
    interface GigabitEthernet0/0/7
    #
    interface GigabitEthernet0/0/8
    #
    interface GigabitEthernet0/0/9
    #
    interface GigabitEthernet0/0/10
    #
    interface GigabitEthernet0/0/11
    #
    interface GigabitEthernet0/0/12
    #
    interface GigabitEthernet0/0/13
    #
    interface GigabitEthernet0/0/14
    #
    interface GigabitEthernet0/0/15
    #
    interface GigabitEthernet0/0/16
    #
    interface GigabitEthernet0/0/17
    #
    interface GigabitEthernet0/0/18
    #
    interface GigabitEthernet0/0/19
    #
    interface GigabitEthernet0/0/20
    #
    interface GigabitEthernet0/0/21
    #
    interface GigabitEthernet0/0/22
    #
    interface GigabitEthernet0/0/23
     eth-trunk 1
    #
    interface GigabitEthernet0/0/24
     eth-trunk 1
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.2.4.9
    #
    user-interface con 0
    user-interface vty 0 4
    #
    port-group vlan60
     group-member GigabitEthernet0/0/1
     group-member GigabitEthernet0/0/2
     group-member GigabitEthernet0/0/3
     group-member GigabitEthernet0/0/4
     group-member GigabitEthernet0/0/5
    #
    return

     

     

     

     

     

     

    展开全文
  • 在核心交换机上设置策略路由,使核心交换机根据预先设置好的ACL流的匹配来决定将数据库丢往三个出口的其中一个。简单配置步骤如下: 一、网络说明 设备管理地址: 核心交换机:型号Quidway S8508,IP 192.168.0....

    网络中有VLAN用户若干,有三条出口。在核心交换机上设置策略路由,使核心交换机根据预先设置好的ACL流的匹配来决定将数据库丢往三个出口的其中一个。

    简单配置步骤如下:

    一、网络说明

    设备管理地址:
    核心交换机:型号Quidway S8508,IP 192.168.0.254(vlan1)
    楼层交换机:型号Quidway 3600-28TP-SI,IP 192.168.0.20 – 192.168.0.28(vlan1)

    内网VLAN及IP地址:
    192.168.0.0/24,vlan1,服务器及用户A段IP
    192.168.1.0/24,vlan2,用户B段IP
    192.168.2.0/24,vlan3,用户C段IP
    192.168.3.0/24,vlan4,用户D段IP
    10.8.0.0/24,vlan5,用户E段IP

    三个出口设备内网IP地址:
    外网1出口防火墙内网IP地址:192.168.0.11,所在核心交换机端口:inter gig 3/3/1
    外网2出口防火墙内网IP地址:192.168.0.12,所在核心交换机端口:inter gig 3/3/2
    外网3出口防火墙内网IP地址:192.168.0.13,所在核心交换机端口:inter gig 3/3/3

    分布:
    楼宇A:所在核心交换机端口:inter gig 6/1/1,存在vlan:vlan1、vlan3、vlan5
    楼宇B:所在核心交换机端口:inter gig 6/1/2,存在vlan:vlan1、vlan4、vlan5
    楼宇C:所在核心交换机端口:inter gig 6/1/3,存在vlan:vlan1、vlan2、vlan4、vlan5
    楼宇D:所在核心交换机端口:inter gig 6/1/4,存在vlan:vlan1、vlan2、vlan3、vlan5
    网络中心服务器群:所在核心交换机端口:inter gig 3/1/1,存在vlan:vlan1

    网络拓扑图:

    二、实现功能

    1、当楼宇A、B、C、D中vlan1、vlan2及vlan3的用户电脑访问网络时从外网1也就是核心交换机的gig 3/3/1端口上出去
    2、当这些楼宇中的vlan4的用户电脑访问网络时从外网2出口出去
    3、当这些楼宇的vlan5中的用户电脑访问网络时从外网3出口出去
    4、所有vlan均能访问vlan1的服务器群网段

    三、配置步骤

    思路:首先建立一个普通的三层网络,在核心交换机上利用默认路由将楼宇交换机来的数据包全部丢到核心的192.168.0.11上也就是外网1出口上,然后在接楼宇端口上利用核心交换机的traffic-redirect功能通过源地址acl流匹配将vlan4和vlan5的数据包丢到192.168.0.12(外网2)或192.168.0.13(外网3)上。

    1、在核心上建立三层网络,并配置好各楼宇交换机,这里略过。然后在核心交换机上添加一条默认路由,这样所有的数据包就都从外网1出口出去:

    ip route-static 0.0.0.0 0.0.0.0 192.168.0.11 preference 60

    2、因为在接楼宇端口上应用traffic-redirect后数据包就直接丢到外网的内网口了,这样vlan4和vlan5访问vlan1的服务器群就有问题了。所以我们先在端口上做acl。

    建立acl:

    [center] acl number 3001
    [center acl number 3001] rule 0 permit ip source 192.168.3.0 0.0.0.255 destination 192.168.0.0 0.0.0.255
    [center acl number 3001] rule 1 permit ip source 10.0.8.0 0.0.0.255 destination 192.168.0.0 0.0.0.255

    下发楼宇A端口:

    [center] inter gig 6/1/1
    [center-GigabitEthernet6/1/1] packet-filter inbound ip-group 3001

    其他楼宇端口下发方法相同,这里略过。另外,对于是vlan1属性的inter gig 3/1/1,因为端口下只有一个vlan,所以就不需要做策略路由。在下发顺序上也是应该也下发acl规则,然后再下发策略路由。这样就可以先匹配内网的访问需求了。

    3、在连接楼宇交换机的核心交换机端口上做策略路由

    建立vlan4的acl流匹配规则:

    [center] acl number 3002
    [center-acl number 3002] rule 0 permit ip source 192.168.3.0 0.0.0.255

    建立vlan5的acl流匹配规则:

    [center] acl number 3003
    [center-acl number 3003] rule 0 permit ip source 10.8.0.0 0.0.0.255

    下发针对vlan4的楼宇A端口的下一跳路由:

    [center] inter gig 6/1/1
    [center-GigabitEthernet6/1/1] traffic-redirect inbound ip-group 3002 next-hop 192.168.0.12

    下发针对vlan5的楼宇A端口的下一跳路由:

    [center] inter gig 6/1/1
    [center-GigabitEthernet6/1/1] traffic-redirect inbound ip-group 3003 next-hop 192.168.0.13

    这样配置后,vlan1至vlan3仍然从核心交换机的默认路由192.168.0.11外网1出口出去。如果源地址为192.168.3.0网络地址进入核心交换机的连接楼宇的端口后,针对源地址为192.168.3.0的acl规则3002就被匹配,这样就被路由至192.168.0.12的外网2出口上。同理如果是源地址为10.8.0.0网络的地址流入核心交换机的端口上则根据端口定义好的下一跳路由它将被送往192.168.0.13的外网3网络上。

    最后附上核心交换机的完整配置:

    #
    sysname center
    #
    radius scheme system
    server-type huawei
    primary authentication 127.0.0.1 1645
    primary accounting 127.0.0.1 1646
    user-name-format without-domain

    domain system
    radius-scheme system
    access-limit disable
    state active
    idle-cut disable
    self-service-url disable

    domain default enable system
    #
    local-server nas-ip 127.0.0.1 key huawei
    #
    Xbar load-single
    #
    temperature-limit 3 10 65
    temperature-limit 4 10 50
    temperature-limit 5 10 50
    temperature-limit 6 10 65
    #
    dot1x
    #
    acl number 3001
    rule 0 permit ip source 10.10.6.0 0.0.0.255 destination 192.168.0.0 0.0.0.255
    rule 0 permit ip source 192.168.3.0 0.0.0.255 destination 192.168.0.0 0.0.0.255
    acl number 3002
    rule 0 permit ip source 192.168.3.0 0.0.0.255
    acl number 3003
    rule 0 permit ip source 10.8.0.0 0.0.0.255
    #
    vlan 1
    description bangong_and_server
    #
    vlan 2
    description user_a
    #
    vlan 3
    description user_b
    #
    vlan 4
    description user_c
    #
    vlan 5
    description user_d
    #
    interface Vlan-interface1
    description bangong_and_server
    ip address 192.168.0.254 255.255.255.0
    #
    interface Vlan-interface2
    description user_a
    ip address 192.168.1.254 255.255.255.0
    #
    interface Vlan-interface3
    description user_b
    ip address 192.168.2.254 255.255.255.0
    #
    interface Vlan-interface4
    description user_c
    ip address 192.168.3.254 255.255.255.0
    #
    interface Vlan-interface5
    description user_d
    ip address 10.8.0.254 255.255.255.0
    #
    interface Aux4/0/1
    #
    interface M-Ethernet4/0/0
    #
    interface GigabitEthernet3/1/1
    description to_server-group
    #
    interface GigabitEthernet3/1/2
    #
    interface GigabitEthernet3/1/3
    #
    interface GigabitEthernet3/1/4
    #
    interface GigabitEthernet3/2/1
    #
    interface GigabitEthernet3/2/2
    #
    interface GigabitEthernet3/2/3
    #
    interface GigabitEthernet3/2/4
    #
    interface GigabitEthernet3/3/1
    description to_waiwang1
    #
    interface GigabitEthernet3/3/2
    description to_waiwang3
    #
    interface GigabitEthernet3/3/3
    description to_waiwang3
    #
    interface GigabitEthernet3/3/4
    #
    interface GigabitEthernet6/1/1
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 1
    packet-filter inbound ip-group 3001 rule 1 system-index 2
    traffic-redirect inbound ip-group 3002 rule 0 system-index 3 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 4 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/1/2
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 5
    packet-filter inbound ip-group 3001 rule 1 system-index 6
    traffic-redirect inbound ip-group 3002 rule 0 system-index 7 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 8 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/1/3
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 9
    packet-filter inbound ip-group 3001 rule 1 system-index 10
    traffic-redirect inbound ip-group 3002 rule 0 system-index 11 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 12 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/1/4
    port link-type trunk
    port trunk permit vlan all
    packet-filter inbound ip-group 3001 rule 0 system-index 14
    packet-filter inbound ip-group 3001 rule 1 system-index 15
    traffic-redirect inbound ip-group 3002 rule 0 system-index 16 next-hop 192.168.0.12
    traffic-redirect inbound ip-group 3003 rule 0 system-index 17 next-hop 192.168.0.13
    #
    interface GigabitEthernet6/2/1
    #
    interface GigabitEthernet6/2/2
    #
    interface GigabitEthernet6/2/3
    #
    interface GigabitEthernet6/2/4
    #
    interface GigabitEthernet6/3/1
    #
    interface GigabitEthernet6/3/2
    #
    interface GigabitEthernet6/3/3
    #
    interface GigabitEthernet6/3/4
    #
    interface NULL0
    #
    ip route-static 0.0.0.0 0.0.0.0 192.168.0.11 preference 60
    #
    snmp-agent
    snmp-agent local-engineid 80507DBD05757576F5DD55A46877
    snmp-agent community write jsisaa
    snmp-agent sys-info version all
    #
    user-interface con 0
    user-interface aux 0
    user-interface vty 0 4
    user privilege level 3
    set authentication password simple winsaaa
    #
    return

    展开全文
  • 华为交换机实现VLAN间路由实例

    千次阅读 2020-12-29 03:51:57
    Cisco 三层交换机实现VLAN间路由华为三层交换机VLAN间路由配置: (1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划到VLAN2、VLAN3; (2)将二层交换机与三层交换机相连的端口F0/1都定义为trunk模式; (3)在...
  • 默认路由是一种特殊的路由,当路由表中与数据包的目的地址没有匹配的表项时,数据包根据默认路由条目进行转发。在末梢网络中,默认路由可以大大简化路由器配置,减轻网络管理员的工作负担。可以负载均衡和路由备份 ...
  • 展开全部如下是修改NE40E 各路由优先级:1.bgp[HUAWEI] bgp 100[HUAWEI-bgp] ipv4-family unicast[HUAWEI-bgp-af-ipv4] preference 20 200 200命令格式preference { external internal local | route-policy route-...
  • 路由协议或路由种类 | 相应的默认路由优先级(Preference) direct | 0 OSPF | 10 IS-IS | 15 Static | 60 RIP | 100 IBGP | 130 OSPF ASE/import | 150 EBGP | 170 UNKNOWN | 255 二.思科 Route Source | Default AD ...
  • 华为路由器配置静态路由&默认路由

    万次阅读 多人点赞 2020-01-06 15:35:24
    Huawei>system-view [Huawei]sysname R1 [R1]interface g0/0/0 [R1-GigabitEthernet0/0/0]ip address 10.10.10.1 255.255.255.0 [R1-GigabitEthernet0/0/0]interface g0/0/1 [R1-Gigabit...
  • #不同网段两台华为交换机怎么互通# !!!解决方案(三层交换机默认路由
  • q [R1]ip route-static 0.0.0.0 0.0.0.0 192.168.2.1 交换机不用配置,交换机只是将这两个路由连起来,没什么卵用。 检测结果 PC1 ping PC3 PC>ping 192.168.3.2 Ping 192.168.3.2: 32 data bytes, Press Ctrl_C to ...
  • 实验拓扑实验需求1、C1与C3属于VLAN10,C2与C4属于VLAN20,在SW1上创建VLAN100做上行VLAN2、在SW1上终结所有VLAN3、在所有VLAN成员使用DHCP获取IP4、全网互通IP规划VLAN10 :192.168.10.0/24VLAN20 :192.168.20.0/...
  • 展开全部一般都是admin,也有可能是用户名是huawei,密码是admin,或是huawei@...它根据MAC地址寻址,通过站表选择路由,站表的建立和维护由CISCO思科交换机自动进行。路由器属于OSI第三层即网络层设备,它根据IP地...
  • 四、配置默认路由 五、了解华为不同路由协议的优先级 拓扑 一、配置设备名称与IP地址: R1: system-view Enter system view, return user view with Ctrl+Z. [Huawei]sysname R1 [R1]interface g0/0/1 [R1-...
  • 1、同一交换机vlan之间通信:只需配置VLANif IP地址即可(要求在不同IP子网中,如172.16.1.0/24与92.168.1.0/24可通信),因为华为交换机在同一交换机上默认启用IP路由功能,也就是同一交换机上是直连路由。...
  • 华为交换机配置

    2022-06-17 11:07:54
    华为交换机配置
  • 华为路由器、交换机配置命令

    万次阅读 多人点赞 2018-12-29 21:38:41
    华为路由器交换机配置命令是大家使用时经常遇到的,顾名思义关于交换机的计算机命令,路由器命令,交换机命令和动静态命令都将在文中提到。 史上最全华为路由器交换机配置命令大合集,熟练掌握下面的华为路由器...
  • 有一些朋友对华为配置命令不是很熟悉,...定义:VRP (Versatile Routing Platform)即通用路由平台,是华为在通信领域多年的研究经验结晶,是华为所有基于IP/ATM构架的数据通信产品操作系统平台。运行VRP操作系统的...
  • 华为交换机配置命令

    2013-09-19 16:38:57
    建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。 在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控...
  • 1.修改交换机名称为S1,路由器名称为R1 2.在AR1上配置子接口G0/0/0.1G0/0/0.2G0/0/0.3 3.分别在子接口上做适当配置,使得3个VLAN之间能够通信 三、配置命令与原因分析: (一)在左侧拓扑完成: 多臂路由配置,使得...
  • 内容包括: “华为数通学习(一)带你认识华为VRP系统【基本配置,Telnet SSH 查看、保存、清空、重启路由器配置等】” “华为数通学习(二)静态路由、浮动路由、默认路由配置以及华为路由协议优先级总结” ...
  • 进入vlan10接口视图与vlan 10命令进入的地方不同 [Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定义vlan10管理IP三层交换网关路由 [Quidway-Vlanif10] quit 5、配置默认网关: [Quidway]ip ...
  • 华为路由交换机端口的三种模式

    千次阅读 2021-03-04 21:35:46
    1、 Access模式:如果交换机的一个接口模式为 access,并且划分到vlan10,数据包进入的时候会插入VLAV标签,数据包的离开的时候会刺离VLAN标签。 2、 Trunk模式:允许所有的vlan数据包通过默认只允许vlan通过,如 果想让...
  • 华为交换机初始设置

    2020-12-24 11:23:49
    1、初始化过程:连上console线后,设置超级终端,(参数选默认)进入后resetsaved-configuration选择main,切记交换机加电重启,否则不生效;(此时,交换机会变成出厂默认状态)2、进行设置A、syetem进入配置模式B、...
  • [Quidway]discur;...显示路由信息 [Quidway]displayversion;显示版本信息 [Quidway]superpassword;修改特权用户密码 [Quidway]sysname;交换机命名 [Quidway]interfaceethernet0/1;进入接口视图
  • 华为模拟器静态路由/默认路由设置及VLAN配置 文章目录华为模拟器静态路由/默认路由设置及VLAN配置一、路由器的工作原理1.1、路由器接口配置ip命令1.2、设置静态路由/默认路由二、VLAN的介绍2.1、VLAN分3种类型端口...
  • 划分VLAN还有很多种方法,如华为交换机默认的 hybird 配置、单臂路由、三层交换机等。 一、华为VLAN hybird  华为 hybrid vlan 混合端口(人为控制经过端口时是否脱去vlan标签)。  Hybrid 接口 是华为设备的特殊...
  • 1.修改交换机名称为S1,路由器名称为R1 2.在AR1上配置子接口G0/0/0.1G0/0/0.2G0/0/0.3 3.分别在子接口上做适当配置,使得3个VLAN之间能够通信 (二)在右侧拓扑完成: 1.修改交换机名称为S2S3 2.在S2S3上做适当配置,...
  • 交换机S3700:配置两个vlan,两个A口,一个T口 配置vlan命令: vlan batch 10to 20 //创建vlan 10和vlan 20 端口Ethernet0/0/1配置命令: interface Ethernet0/0/1 //进入端口 port link-type access //端口...
  • 华为设备路由协议默认优先级 华为设备路由协议默认优先级 路由协议 路由协议外部优先级 路由协议内部优先级 直连 0 0 OSPF 10 10 IS-IS 15 15(Level-1)18(Level-2) Static ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,529
精华内容 2,211
关键字:

华为交换机默认路由