精华内容
下载资源
问答
  • OSPF下发默认路由

    2009-05-20 09:37:32
    ospf-下发默认路由 主要是讲OSPF下发默认路由的一些东西,很有用。
  • OSPF下放默认路由的方法及场景

    千次阅读 2020-02-24 14:26:45
    OSPF下放默认路由的方法及场景

    OSPF下放默认路由的方法及场景

    一、OSPF下放默认路由的方法

    default-route-advise (always)

    如果本路由器没有默认路由但是需要下放默认路由这个时候才需要加上always 。

    二、OSPF下放默认路由的场景

    1. 在出口路由器中下放默认路由。如图,我们在内网运行ospf,现在访问ISP上的一个地址8.8.8.8,R1作为出口路由器配置了一条默认路由。R1可以正常访问8.8.8.8。
      在这里插入图片描述
      R1可以正常访问8.8.8.8,但是R2、R3是没有去8.8.8.8的路由的,所以此时需要在R1上下放默认路由。在这里插入图片描述
      查看R2、R3的路由表是否收到默认路由。
      在这里插入图片描述
      在这里插入图片描述
      测试能否ping通8.8.8.8。
      在这里插入图片描述在这里插入图片描述
    2. ABR 在stub和totally-stub上下发默认路由。如图所示,在R1、R2、R3之间配置ospf area 0 ,在R2、R5之间配置ospf stub 。
      在这里插入图片描述
      查看R5的路由表,发现收到了一条默认路由,(此时我没有在任何路由器上下放默认路由)所以在stub上的ABR 会自动下放默认路由。

    在这里插入图片描述
    将stub区域修改为totally-stub区域,并重启ospf进程查看路由表,发现而在totally-stub区域中与stub区域是一样的也会自动下放默认路由,与stub区域的区别就是,totally-stub区域会连三类LSA一起过滤只剩这条自动下放的默认。
    在这里插入图片描述
    3. ABR在 nssa和完全totally-nssa上下发默认路由。如图所示,按照图中的区域配置ospf 。
    在这里插入图片描述
    在R3中查看路由表,在没有手动配置下放默认路由的情况下,nssa区域的ABR自动下放默认路由。
    在这里插入图片描述
    现在把nssa区域配置修改为totally-nssa区域,并重启ospf进程,再查看R3的路由表。发现在totally-nssa区域中的这条默认路由是3类。
    在这里插入图片描述

    展开全文
  • Ospf是可以通过import-route命令引入外部路由的,但很少有人会注意到,在默认情况下,ospf是不会引入来自外部路由的缺省路由的。但ospf有一个变通的方法,就是通过default-route-advertise命令,将自己作为默认路由...

    先进入ospf 1
    然后default-route-advertise 就可以了,其它所有ospf路由都有默认路由了

    1、关于default-route-advertise命令
    Ospf是可以通过import-route命令引入外部路由的,但很少有人会注意到,在默认情况下,ospf是不会引入来自外部路由的缺省路由的。但ospf有一个变通的方法,就是通过default-route-advertise命令,将自己作为默认路由的下一跳宣告到ospf区域内,这样,ospf里的其他路由器就会将缺省流量发送给自己,然后本路由器再根据其他协议的路由表进行转发。
    2、关于always选项如果没有配置always,则default-route-advertise有两种情况:有效/无效。

    啥时候会有效?啥时候会无效?这依赖于来自其他协议的缺省路由是否有效,换句话说,如果本路由器的缺省路由是可用的,则会在ospf区域内招呼,大家把缺省路由指向我啊,我这里有路出去。

    如果本路由器发现自身的缺省路由有问题,比如链路断了,下一条不可达,则会马上在ospf区域内撤销通告,使自己不再接受来自ospf区域内其他路由器的缺省流量。

    展开全文
  • R3(config)#ip route 0.0.0.0 0.0.0.0 se2/0 R3(config)#router ospf 1 R3(config-router)#default-information originate 向OSPF网络注入一条默认路由 4.在ISP的边界路由器上配置去企业网内部的静态路由,使得到...

    在这里插入图片描述
    1.配置各台路由器IP地址
    部分参考代码如下,请自行完善:
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip address 172.16.1.1 255.255.255.0
    R1(config-if)#no shutdown

    R2(config)#interface Fa0/0
    R2(config-if)#ip add 192.168.1.5 255.255.255.252
    R2(config-if)#no shutdown

    R3(config)#interface s2/0
    R3(config-if)#ip add 202.10.10.1 255.255.255.0
    R3(config-if)#clock rate 64000
    R3 (config-if)#no shutdown

    2.OSPF的配置
    R1(config)#router ospf 1
    R1(config-router)#network 172.16.1.0 0.0.0.255 area 0

    R2(config)#router ospf 1
    R2(config-router)#network 192.168.1.4 0.0.0.3 area 0
    R2(config-router)#network 172.16.1.0 0.0.0.255 area 0

    R3(config)#router ospf 1
    R3(config-router)#network 192.168.1.4 0.0.0.3 area 0

    3.在企业边界路由器R3上配置到Internet的默认路由,同时向内部的OSPF区域内注入一条默认路由。
    R3(config)#ip route 0.0.0.0 0.0.0.0 se2/0
    R3(config)#router ospf 1
    R3(config-router)#default-information originate 向OSPF网络注入一条默认路由

    4.在ISP的边界路由器上配置去企业网内部的静态路由,使得到企业网内部能够通信
    ISP(config)#ip route 172.16.1.0 255.255.255.0 202.10.10.1
    ISP(config)#ip route 192.168.1.4 255.255.255.252 202.10.10.1

    5.在R1上启用ospf的明文认证
    R1(config)#interface f0/0
    R1(config-if)#ip ospf authentication 启用ospf认证
    R1(config-if)#ip ospf authentication-key cisco 使用明文密码进行认证

    6.在R2上启用ospf的认证
    R2(config)#interface f1/0
    R2(config-if)#ip ospf authentication
    R2(config-if)#ip ospf authentication-key cisco

    7.配置基于md5的密码接口认证如下,配置完成后,请查看R1的路由表。
    R1(config)#interface f0/0
    R1(config-if)#ip ospf authentication message-digest
    R1(config-if)#ip ospf message-digest-key 1 md5 cisco
    R2(config)#interface f1/0
    R2(config-if)#ip ospf authentication message-digest
    R2(config-if)#ip ospf message-digest-key 1 md5 cisco

    展开全文
  • 配置OSPF引入缺省路由

    千次阅读 2020-08-22 09:34:05
    从路由器上注射一条默认 0/0 路由OSPF 中去,只允许用 OSPF 自身的机制,禁止使用静态 0/0 再分发的方法。 解决: OSPF 不能通过 import-route 命令从其它协议引入缺省路由,如果想把缺省路由引入到OSPF 路由区域...

    问题
    从路由器上注射一条默认 0/0 路由到 OSPF 中去,只允许用 OSPF 自身的机制,禁止使用静态 0/0 再分发的方法。

    解决:
    OSPF 不能通过 import-route 命令从其它协议引入缺省路由,如果想把缺省路由引入到OSPF 路由区域,必须要使用下面命令配置 OSPF 引入缺省路由。

    <H3C>system-view     //进入系统视图
    [H3C]ospf    //进入OSPF视图
    [H3C-ospf-1]default-route-advertise always    //缺省情况下,不引入缺省路由
    
    展开全文
  • 华为OSPF NSSA区域对默认路由的处理 题注: 用华为eNSP做OSPF多区域实验时,发现NSSA区域存在ABR自动导入Type 7default route的问题。记录下来供探讨学习。 一、实验环境 eNSP,所有路由器使用Route模拟。根据...
  • 在此总结练习中,您将配置 在此总结练习中,您将配置 PPP、OSPF、DHCP、NAT 和到 ISP 的默认路由。然后您需要检验您的配置。。然后您需要检验您的配置。
  • type access port default vlan 12 interface GigabitEthernet0/0/5 eth-trunk 1 interface GigabitEthernet0/0/6 eth-trunk 1 interface LoopBack0 ip address 11.11.11.11 255.255.255.255 ospf 1 router-id 11.11...
  • OSPF动态路由协议实验

    2021-09-13 19:37:23
    标题 题目 1.R1-3为区域0,R3到R4为区域0,其中R3的环回也...2.激活动态路由协议OSPF,并宣告路由所属区域(查看邻居表确认) 3.配置DR,通过设置优先级实现,(测试:r1:Ping 4.4.4.4) 4.R4强制下发缺省路由给area0.
  • 本期分享:系列15点到...1、stub区域为OSPF的末节区域,能够过滤掉 4类、5类LSA(这样就不会接收到OSPF域外的路由),能够减小链路状态数据库及路由表。 2、该区域的ABR会为stub区域产生一条域间的O *IA 0/0的默认...
  • OSPF路由协议 在同一个OSPF自制系统内每一台运行OSPF协议的路由器总是将本地网络的连接状态用LSA(链路状态通告)描述,并广播到整个自制系统中去。这样,每台路由器都收到了自制系统中所有路由器生成的LSA,这些...
  • OSPF路由协议整理

    2020-06-09 23:04:58
    一、动态路由概念及特性     动态路由(算法):各台路由之间运行某种动态路由协议,之后通过收发数包的形式获取未知网段的路径。 动态路由分类 按范围划分为:      ...
  • ospf路由协议

    2011-03-18 22:12:48
    ospf路由协议 2010-05-17 15:55 <OSPF(Open Shortest Path First)> 开放最短路径优先协议 OSPF的基本特性: ·OSPF属于...
  • 单区域OSPF路由配置实验基础知识常用命令实验流程1.配置主机IP地址2.配置路由器各端口IP地址3.封装OSPF协议4.验证主机连通 基础知识 OSPF路由协议是一种典型的链路状态(Link-state)的路由协议,一般用于同一个...
  • cisco ospf命令总结

    千次阅读 2014-11-04 14:32:27
    OSPF配置命令Router(config)#router ospf 10 进程号只在本地有效Router(config)#network 192.168.10.0 0.0.0.255 area 0 正反掩码均可Show ip ... route 查看路由表Show ip route ospf 查看路由表中的OSPF路由项S...
  • cisco ospf 命令总结

    2013-01-29 10:11:11
    OSPF配置命令 Router(config)#router ospf 10 进程号只在本地有效 Router(config)#network 192.168.10.0 0.0.0.255 area 0 正反掩码均可 Show ip protocols ...Show ip route ospf 查看路由...
  • 动态路由RIP OSPF

    2021-09-12 20:11:18
    拓展配置三、OSPF追加知识点 一、动态路由 静态路由:有网络管理员手工添加的路由 动态路由:所有路由器上运行相同的路由协议,之后,通过路由器之间的沟通交流,最终计算生成的路由条目。 1.静态路由和动态路由的...
  • 动态路由OSPF

    2020-01-27 21:12:36
    OSPF:开放式最短路径优先协议 1)基本概念 OSPF版本:v2-ipv4 v3-ipv6 组播更新:224.0.0.5/6 基本更新方式:触发更新 存在周期更新30分钟 OSPF需要结构化部署:1、区域划分 链路状态型路由协议的距离矢量特征–...
  • CISCO OSPF命令总结

    千次阅读 2010-11-13 10:19:00
    花了一天时间把ospf的基本命令 都总结了.绝对心血啊. 好的话就支持顶一个哦 <br />OSPF 配置命令 Router(config)#router ospf 10 进程号只在本地有效...Show ip route 查看路由 表<br
  • BGP 产生默认路由的方式

    千次阅读 2014-12-09 14:42:45
    1、写默认路由并通告ip route 0.0.0.0 0.0.0.0 null 0写一条默认路由,指向空接口,并将其通告至BGP中,这样该路由器会将该默认路由通告给他的所有BGP邻居;在R4中配置静态路由,并将其通告至BGP中,然后查看路由表...
  • 思科OSPF及OSPFV3协议的详细解析

    千次阅读 2020-07-28 09:52:39
    无类路由,支持CIDR 封装在三层,协议号89 SPF最短路径树算法 链路状态数据结构 邻居表 • 也被称为邻接数据库 • 包含已经被识别的邻居列表 •命令 Show ip ospf neighbor Topology table: 拓扑表 • 通常被称为...
  • OSPF:开放式最短路径优先协议;OSPF的三表五包七状态;OSPF的工作过程;LSA详解;OSPF的特殊区域;OSPF的选路规则及其总结。
  • 入门OSPF就这一篇足够了

    千次阅读 2020-05-28 18:45:21
    下发默认路由: 1.重分发静态; 2.到拥有默认路由的设备上, router ospf 1 default-information originate 《always》 不加always时,下发默认路由的路由器本身必须要有默认路由; 加always,不管有没有,都可以...
  • CiscoOSPF实验应用

    2018-08-24 17:18:49
    该实验详细的综合了OSPF的多个知识点 拓扑要求: (1)R1/R2/R3与SW在area 1内;R3/R4/R5/R6/R7在area 0内;R6/R11R/12在area 2内;R12的两个环回在EIGRP内;R7/R8/R9在area 3内;R9/R10在area 4内 (2)R4为...
  • 动态路由协议之OSPF

    2016-05-18 12:36:52
    OSPF(Open Shortest Path First)>开放最短路径优先协议OSPF的基本特性:·OSPF属于IGP,是Link-State协议,基于IP Pro 89。·采用SPF算法(Dijkstra算法)计算最佳路径。·快速响应网络变化。·以较低频率(每...
  • 第二章静态路由1静态路由较之动态路由有哪两项优点?(请选择两项。)A.静态路由随着网络不断发展而进行扩展B. 由于静态路由不通过网络进行通告,因此比较安全C. 正确实施静态路由所需的网络知识很少D. 静态路由比动态...
  • IGP(内部网关协议):AS之内使用–RIP、OSPF、EIGRP(cisco私有)、ISIS EGP(外部网关协议):AS之间使用–BGP 2、IGP协议的分类: 1.基于工作特点: DV型:距离矢量型—共享路由表,传闻型协议 ,更新量小,RIP/

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 413
精华内容 165
关键字:

思科ospf下发默认路由