精华内容
下载资源
问答
  • Cisco思科三层交换机配置DHCP服务

    万次阅读 多人点赞 2020-01-22 16:53:01
    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢? 在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省...

    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢?

    在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省网络设备的性能,另外图形界面,也方便查看。

    业务需求:
    将三层交换机配置为DHCP服务器,为每个VLAN分配IP地址,每个VLAN有自己的网段
    人事部、财务部、生产部、采购部分别属于VLAN10、VLAN20、VLAN30、VLAN40
    VLAN10: 192.168.10.0/24       网关:192.168.10.1
    VLAN20: 192.168.20.0/24       网关:192.168.20.1
    VLAN30: 192.168.30.0/24       网关:192.168.30.1
    VLAN40: 192.168.40.0/24       网关:192.168.40.1
    注意:创建DHCP地址池要将网关地址做排除。Switch5和Switch8的F0/4端口已经被管理性关闭了,开启的话会使SW0/SW5/SW8产生网络回路,引起网络风暴,下一篇博客我会写打开这个端口而如何避免这样的问题。

     

    网络拓扑:

    网络配置:

    Switch5:
    SW5#conf t
    SW5(config)#vlan 10					        //创建两个VLAN
    SW5(config-vlan)#vlan 20
    SW5(config-vlan)#int f0/2					//给端口分别划分VLAN
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 10
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/3
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/1					        //设置端口为trunk模式
    SW5(config-if)#switchport mode trunk
    SW5(config-if)#switchport trunk allowed vlan 10,20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    
    Switch8:
    SW8#conf t
    SW8(config)#vlan 30
    SW8(config-vlan)#vlan 40
    SW8(config-vlan)#int f0/2
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 30
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/3
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/1
    SW8(config-if)#switchport mode trunk
    SW8(config-if)#switchport trunk allowed vlan 30,40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    
    Switch0
    SW0#conf t
    SW0(config)#vlan 10					//创建4个VLAN
    SW0(config-vlan)#vlan 20
    SW0(config-vlan)#vlan 30
    SW0(config-vlan)#vlan 40
    SW0(config-vlan)#int f0/1
    SW0(config-if)#switchport mode trunk			//设置端口1为trunk模式,允许VLAN10,20,30,40的流量通过
    SW0(config-if)#switchport trunk allowed vlan 10,20,30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/2
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 10,20
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/3
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    
    Multilayer Switch2
    SW2#conf t
    SW2(config)#vlan 10						//创建4个VLAN
    SW2(config-vlan)#vlan 20
    SW2(config-vlan)#vlan 30
    SW2(config-vlan)#vlan 40
    SW2(config-vlan)#int f0/1					//设置f0/1的端口模式
    SW2(config-if)#switchport trunk allowed vlan 10,20,30,40	//三层交换机不用先配置为trunk模式
    SW2(config-if)#exit
    SW2(config)#ip dhcp excluded-address 192.168.10.1		//对DHCP地址池地址做排除
    SW2(config)#ip dhcp excluded-address 192.168.20.1
    SW2(config)#ip dhcp excluded-address 192.168.30.1
    SW2(config)#ip dhcp excluded-address 192.168.40.1
    SW2(config)#int vlan 10						//设置VLAN10的IP地址。三层交换机与路由器的不同之处,不能用单臂路由,划分子端口,所以用此方法分别设置VLAN的地址作为每个DHCP地址池的网关地址
    SW2(config-if)#ip address 192.168.10.1 255.255.255.0
    SW2(config-if)#ip routing					//开启VLAN间路由的功能
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 10					//创建DHCP地址池10
    SW2(config-dhcp)#network 192.168.10.0 255.255.255.0		//设置DHCP地址池网段
    SW2(config-dhcp)#default-router 192.168.10.1			//设置默认网关地址。这里设置为VLAN10的IP地址,所有VLAN10的主机通过这个网关地址获取IP
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 20						
    SW2(config-if)#ip address 192.168.20.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 20					//创建DHCP地址池20
    SW2(config-dhcp)#network 192.168.20.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.20.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 30
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 30					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.30.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.30.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 40
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 40					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.40.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.40.1
    SW2(config-dhcp)#exit

    本文原创,转载请注明出处。

     

    展开全文
  • 思科交换机 DHCP 服务配置

    万次阅读 2019-01-12 15:16:04
    说明:有 3 个 VLAN,...服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP 服务器则在后续中继的过程中使用到。 地址规划 VLAN 2:20.1.1.0/24,网关 20.1.1.254,DNS 88.1.1.253 VLAN 3:30.1.1.0/24...

    在这里插入图片描述
    说明:有 3 个 VLAN,VLAN2 与 VLAN3 是用户 VLAN,而 VLAN 88 则是 DHCP 服务器的 VLAN,在实验演示一中,DHCP
    服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP 服务器则在后续中继的过程中使用到。
    地址规划
    VLAN 2:20.1.1.0/24,网关 20.1.1.254,DNS 88.1.1.253
    VLAN 3:30.1.1.0/24,网关 30.1.1.254,DNS 88.1.1.253
    VLAN 88:88.1.1.0/24,网关 88.1.1.254,DNS 88.1.1.253
    实验演示一的配置思路
    1、二层配置 VLAN,把对应的接口加入到对应的 VLAN 内
    2、二层交换机与三层交换机之间配置 trunk
    3、三层交换机上面配置 DHCP 服务
    4、验证 PC 是否能够获取到
    5、优化端口与地址排除
    具体配置
    1、二层配置 VLAN,把对应的接口加入到对应的 VLAN 内
    2、二层交换机与三层交换机之间配置 trunk
    说明:二层交换机需要配置的就是,把用户的 VLAN 2 3 创建,然后上行链路定义为 trunk,把下行接入用户的接口划入到
    对应的 VLAN 里面。
    switch-S260(config)#vlan 2
    switch-S260(config-vlan)#vlan 3
    switch-S260(config)#int f0/1
    switch-S260(config-if)#switchport mode access
    switch-S260(config-if)#switchport access vlan 2
    switch-S260(config-if)#int f0/2
    switch-S260(config-if)#switchport mode access
    switch-S260(config-if)#switchport access vlan 3
    switch-S260(config-if)#int f0/3
    switch-S260(config-if)#switchport mode trunk
    说明:其中 F0/1 与 2 是接用户的接口,F0/3 是接三层交换机的接口。
    3、三层交换机上面配置 DHCP 服务
    说明下:这里三层交换机并没有配置这两条命令
    switchport trunk encapsulation dot1q
    switchport mode trunk
    这是因为 3560 默认是 DTP 模式的 auto,只要另外一段配置了 on 或者是对应的模式会自动协商为 trunk,之前强制了二层
    交换机而 trunk,这里 3560 就自然的形成了 trunk。
    三层交换机的初始化配置
    switch-S3560(config)#vlan 2
    switch-S3560(config-vlan)#vlan 3
    switch-S3560(config-vlan)#int vlan 2
    switch-S3560(config-if)#ip address 20.1.1.254 255.255.255.0
    switch-S3560(config-if)#int vlan 3
    switch-S3560(config-if)#ip address 30.1.1.254 255.255.255.0
    说明:配置了 SVI 地址用户作为客户端的网关,后续 DHCP 也根据对应的 VLAN 找到对应的地址池分配。
    DHCP 配置
    switch-S3560(config)#service dhcp (可选,默认情况下思科大部分设备都是开启了该服务的)
    基于 VLAN2 的地址池
    switch-S3560(config)#ip dhcp pool vlan2 (创建一个地址池,命名为 VLAN2)
    switch-S3560(dhcp-config)#network 20.1.1.0 255.255.255.0 (分配的网段为 20.1.1.0/24)
    switch-S3560(dhcp-config)#default-router 20.1.1.254 (分配的网关为 20.1.1.254)
    switch-S3560(dhcp-config)#dns-server 88.1.1.253 (分配的 DNS 为 88.1.1.253,可以有 2 个)
    说明:这些是常见的配置,配置 DHCP 最基础 也最需要用到的,当然还有一些配置。
    1、lease:思科设备默认为 1 天,可以修改为自己需要的时间 lease 0 1,表示 0 天,1 小时
    2、domain-name:域名cbc.com
    3、netbios-name-server:wins 服务器
    4、Option:DHCP 的一些选项,比如语音服务器的 150,告诉 AC 地址的 option43 等
    基于 VLAN3 的地址池
    switch-S3560(config)#ip dhcp pool vlan3
    switch-S3560(dhcp-config)#network 30.1.1.0 255.255.255.0
    switch-S3560(dhcp-config)#default-router 30.1.1.254
    switch-S3560(dhcp-config)#dns-server 88.1.1.253
    4、验证 PC 是否能够获取到
    5、优化端口与地址排除
    在常见的 DHCP 部署中,很容易遇到的问题就是,当客户端接入进去,获取地址很慢,或者是获取不到地址,但是 DHCP
    是没问题的,很常见的问题就是生成树导致的,PC 接入的时候,生成树要计算,花费 30s 的时间,所以容易造成获取地址
    不到的情况,可以配置 STP 的快速端口,来解决该问题,跳过生成树的检查。
    switch-S260(config)#interface range f0/1 - 2
    switch-S260(config-if-range)#spanning-tree portfast
    地址排除问题
    地址排错的机制是为了排除掉,已经用掉的地址,比如网关,DNS 已经固定了,需要在分配的网段内排除掉,不分配个下面
    的客户端。
    switch-S3560(config)#ip dhcp excluded-address 20.1.1.254
    switch-S3560(config)#ip dhcp excluded-address 30.1.1.254
    这里就是说,排除掉已经用在网关的地址,不过现在大部分的 DHCP 服务器已经不需要排除了,有检测机制来完成.
    问题:为什么交换机能够知道 VLAN2 就分配 20.1.1.0 网段,而 VLAN3 就是 30.1.1.0 呢?
    这个跟配置的 SVI 有关,当 VLAN2 的用户发送 DHCP 请求后,三层交换机的 VLAN2 收到后,由于 VLAN2 的 SVI 对应的是 20.1.1.254,它会查找 DHCP 的配置有没有 20.1.1.0 这个网段的地址池,查找到了就通过该地址池分配一个没有使用的地址给用户,VLAN3 同理。
    在交换机里面应用 DHCP 中继功能有时候我们企业环境的 DHCP 是单独用 Windows 或者 Linux 服务器搭建的,而并不是部署在网络设备上面,那么我们就需要用到一种技术,叫做中继功能,因为 DHCP 是广播形式发送的,也就是说在同一个 VLAN 或者广播域内,DHCP 是可以响应请求,但是在跨网段也就是不是同一个广播域内,那么就没办法响应请求了,这时候需要通过中继技术,把广播转换为单播请求发送给 DHCP 服务器。修改与需要添加的配置(3560 上)

    展开全文
  • 这里我们主要讲解了思科交换机配置DHCP的相关内容。我们对网络拓扑先进行一下了解,然后对于其在进行一下说明,之后对于配置的代码和命令再进行一下解析。 思科交换机配置DHCP一、网络拓扑 思科交换机配置DHCP...

    这里我们主要讲解了思科交换机配置DHCP的相关内容。我们对网络拓扑先进行一下了解,然后对于其在进行一下说明,之后对于配置的代码和命令再进行一下解析。

    思科交换机配置DHCP一、网络拓扑

     

    思科交换机配置DHCP二、说明

    1、拓扑说明:汇聚层交换机为CATALYST4506,核心交换机为CATALYST6506,接入层交换机为CATALYST2918。4506上启用IP DHCP SNOOPING和DAI以及IPSG,4506上连和下连的端口均配置为TRUNKING;6506上配置VLAN路由和DHCP服务器;2918配置基于端口的VLAN。

    2、DHCP SNOOPING就像一个工作在非信任端口(连接主机或网络设备)和信任端口(连接DHCP SERVER或者网络设备)之间的防火墙,其DHCP SNOOPING BINDING DATABASE中保存着非信任端口下所连设备的MAC address, the IP address, the lease time, the binding type, the VLAN number, and the interface information等信息,但不保存信任端口所连设备的信息;在交换机上开启IP DHCP SNOOPING后,接口将工作在二层桥接状态,截取和保护通往二层VLAN的DHCP消息;在VLAN上开启IP DHCP SNOOPING后,交换机将工作在同一个VLAN域内的二层桥接状态。

    3、思科交换机在全局配置模式下开启IP DHCP SNOOPING后,所有端口默认处于DHCP SNOOPING UNTRUSTED模式下,非信任端口接收到的DHCP OFFER、DHCP ACK、DHCP NAK、DHCP LEASEQUERY报文将被丢弃;信任端口正常接收转发,不进行监测。

    4、交换机在RELOAD或重启后会丢失DHCP SNOOPING BINDING数据库,因此要将此表保存在交换机的FLASH或者保存在一个TFTP服务器中,使交换机在RELOAD或重启后可以从中读取信息,重新形成DHCP SNOOPING BINDING数据库。比如下面这条命令:renew ip dhcp snoop data tftp://192.169.200.1/snooping.dat。

    5、思科交换机在全局配置模式下开启IP DHCP SNOOPING后,所有的DHCP RELAY INFORMATION OPTION功能全部关闭。

    6、根据思科的英文资料来看,说一个汇聚层交换机开启DHCP SNOOPING后,当其下连一个具有嵌入DHCP option-82 information的边缘交换机,且下连端口为非信任端口时,汇聚层交换机将丢弃从此端口接收到的具有option-82 information的DHCP报文;但当在汇聚层交换机上开启IP DHCP SNOOPING INFORMATION OPTION ALLOW-UNTRUSTED功能后,此时下连边缘交换机的端口虽然仍为非信任端口,但可以正常从此端口接收具有option-82 information的DHCP报文。

    根据上面的分析,我理解如下,不知道对不对:思科交换机在全局配置模式下开启IP DHCP SNOOPING后,所有端口默认处于DHCP SNOOPING UNTRUSTED模式下,但DHCP SNOOPING INFORMATION OPTION功能默认是开启的,此时DHCP报文在到达一个SNOOPING UNTRUSTED端口时将被丢弃。因此,必须在4506配置IP DHCP SNOOPING INFORMATION OPTION ALLOW-UNTRUSTED命令(默认关闭),以允许4506从DHCP SNOOPING UNTRUSTED端口接收带有OPTION 82的DHCP REQUEST报文。建议在交换机上关闭DHCP INFORMATION OPTION,即全局配置模式下NO IP DHCP SNOOPING INFORMATION OPTION。

    7、对于允许手工配置IP地址等参数的客户端,可以手工添加绑定条目到DHCP SNOOPING BINDING数据库中。ip dhcp snooping binding 00d0.2bd0.d80a vlan 100 222.25.77.100 interface gig1/1 expiry 600表示手工添加一条MAC地址为00d0.2bd0.d80a,IP地址为222.25.77.100,接入端口为GIG1/1,租期时间为600秒的绑定条目。

    8、IPSG即IP SOURCE GUARD是在DHCP SNOOPING功能的基础上,形成IP SOURCE BINDING表,只作用在二层端口上。启用IPSG的端口,会检查接收到所有IP包,只转发与此绑定表的条目相符合的IP包。默认IPSG只以源IP地址为条件过滤IP包,如果加上以源MAC地址为条件过滤的话,必须开启DHCP SNOOPING INFORMAITON OPTION 82功能。

    9、DAI即DYNAMIC ARP INSPECTION也是以DHCP SNOOPING BINDING DATABASE为基础的,也区分为信任和非信任端口,DAI只检测非信任端口的ARP包,可以截取、记录和丢弃与SNOOPING BINDING中IP地址到MAC地址映射关系条目不符的ARP包。如果不使用DHCP SNOOPING,则需要手工配置ARP ACL。

    思科交换机配置DHCP三、配置

    1、2918

    Switch# configure terminal //全局配置模式

    Switch(config)# interface range fa0/1 - 12

    Switch(config-if-range)# switchport access vlan 100

    Switch(config-if-range)# interface range fa0/13 - 24

    Switch(config-if-range)# switchport access vlan 200

    Switch(config-if-range)# interface gig0/1 //上连4506的端口

    Switch(config-if)# //这里可不做配置,也可手工配置TRUNK

    2、4506

    Switch# configure terminal

    Switch(config)# vtp version 2

    Switch(config)# vtp mode client

    Switch(config)# vtp domain gzy

    Switch(config)# vtp password gzy123

    Switch(config)# vlan 100

    Switch(config)# vlan 200

    Switch(config)# ip dhcp snooping //开启交换机的dhcp snooping功能

    Switch(config)# ip dhcp snooping vlan 100,200 //在VLAN100和200中开启dhcp snooping功能

    Switch(config)# no ip dhcp snooping information option //禁止在DHCP报文中嵌入和删除option 82信息

    Switch(config)# ip dhcp snooping database tftp://192.168.200.1/snooping.dat

    //将dhcp snooping database保存在tftp服务器(IP地址192.168.200.1)的snooping.dat文件中

    Switch(config)# ip arp inspection vlan 100,200 //在VLAN100和200中开启DAI功能

    Switch(config)# ip arp inspection validate src-mac ip //以源MAC和IP检测ARP包是否合法

    Switch(config)# interface gig1/1 //上连6506的端口

    Switch(config-if)# switchport trunk encapsulation dot1q

    Switch(config-if)# switchport mode trunk

    Switch(config-if)# ip dhcp snooping trust

    Switch(config-if)# ip arp inspection trust

    Switch(config-if)# interface gig2/2 //下连2918的端口

    Switch(config-if)# switchport trunk encapsulation dot1q

    Switch(config-if)# switchport mode trunk

    Switch(config-if)# ip arp inspection limit none

    Switch(config-if)# ip verify source vlan dhcp-snooping

    Switch(config-if)# end

    Switch(config)# copy run start

    思科交换机配置DHCP四、备注

    写到后面越来越懒了,基本上就是这样了。6506上的配置不写了,很简单。因为2918不支持上述功能,因此只能在4506上做,但这样就只能在4506下连2918的端口上来启用这些功能,在2918上发生的欺骗就无法防止了。没办法,思科的做法很奇怪。现在很多国内厂家的接入层交换机都可以实现这些功能,比如Quidway、H3C、神洲数码、锐捷等。由于水平有限,写的不对的地方请高手指正。

    转载于:https://www.cnblogs.com/guozhiping/p/5868328.html

    展开全文
  • 思科三层交换机配置DHCP中继

    千次阅读 2021-03-20 11:52:04
    三层交换机配置DHCP中继 实验目的: 通过本实验掌握如何给不同网段配置DHCP,掌握DHCP中继配置。 实验拓扑: 对交换机SW1进行预配置。 Switch>en Switch#conf t Enter configuration commands, one per line. ...

    三层交换机配置DHCP中继

    实验目的:
    通过本实验掌握如何给不同网段配置DHCP,掌握DHCP中继配置。

    实验拓扑:
    这里用到的三层交换机是PT中的3560,左边的交换机为SW1,右边的交换机为SW2

    1. 对交换机SW1进行预配置。
    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#no ip domain-lookup
    Switch(config)#line con 0
    Switch(config-line)#no exec-t
    Switch(config-line)#logg syn
    Switch(config-line)#host SW1
    

    //划分vlan,配置接口的ip地址(配置IP地址可以不使用VLAN,可以通过在端口敲no switchport命令进行配置,这里为了检验学习成果,故使用)。

    在这里插入图片描述
    在这里插入图片描述

    SW1(config)#vlan 100
    SW1(config-vlan)#int f0/1
    SW1(config-if)#switchport mode access 
    SW1(config-if)#switchport access vlan 100
    SW1(config-if)#spanning-tree portfast 
    
    SW1(config)#vlan 200
    SW1(config-vlan)#int f0/2
    SW1(config-if)#switchport mode access 
    SW1(config-if)#switchport access vlan 200
    SW1(config-if)#spanning-tree portfast 
    
    SW1(config-if)#int Vlan100
    SW1(config-if)#ip address 12.0.0.1 255.255.255.0
    
    SW1(config-if)#interface Vlan200
    SW1(config-if)# ip address 192.168.1.1 255.255.255.0
    //配置远程登录的用户名和密码,如果用户的级别为15,远程登录之后可以直接进入特权模式
    SW1(config)#username admin privilege 15 password 0 admin
    SW1(config)#line vty 0 4
    SW1(config-line)# login local
    
    1. 对交换机SW2进行预配置
    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#no ip domain-lookup
    Switch(config)#line con 0
    Switch(config-line)#no exec-t
    Switch(config-line)#logg syn
    Switch(config-line)#host SW2
    

    //划分vlan,配置接口的ip地址。

    SW2(config)#vlan 100
    SW2(config-vlan)#int f0/1
    SW2(config-if)#switchport mode access 
    SW2(config-if)#switchport access vlan 100
    SW2(config-if)#spanning-tree portfast 
    
    SW2(config)#vlan 200
    SW2(config-vlan)#int f0/2
    SW2(config-if)#switchport mode access 
    SW2(config-if)#switchport access vlan 200
    SW2(config-if)#spanning-tree portfast 
    
    SW2(config-if)#int Vlan100
    SW2(config-if)#ip address 12.0.0.2 255.255.255.0
    
    SW2(config-if)#interface Vlan200
    SW2(config-if)# ip address 172.16.1.1 255.255.255.0
    //配置远程登录的用户名和密码,如果用户的级别为15,远程登录之后可以直接进入特权模式
    SW2(config)#username admin privilege 15 password 0 admin
    SW2(config)#line vty 0 4
    SW2(config-line)#login local
    
    1. 在SW1运行动态路由协议,配置DHCP

    //配置动态路由协议,保证两个不同的网段可以相互通信

    //提示未开启ip routing,把它打开就好了
    SW1(config)#router rip
    IP routing not enabled
    
    SW1(config)#ip routing 
    SW1(config)#router rip
    SW1(config-router)#version 2
    SW1(config-router)#no auto-summary 
    SW1(config-router)#network 12.0.0.1
    SW1(config-router)#network 192.168.1.1
    SW1(config-router)#exit
    

    //开启DHCP服务

    SW1(config)#service dhcp 
    SW1(config)#ip dhcp pool PC1_Subnet
    SW1(dhcp-config)# network 192.168.1.0 255.255.255.0
    SW1(dhcp-config)# default-router 192.168.1.1
    SW1(dhcp-config)# option 150 ip 192.168.1.10
    SW1(dhcp-config)# dns-server 61.134.1.4
    SW1(dhcp-config)# domain-name cisco.com
    SW1(dhcp-config)#exit
    SW1(config)#ip dhcp excluded-address 192.168.1.1
    SW1(config)#ip dhcp excluded-address 192.168.1.10
    
    SW1(config)#ip dhcp pool PC2_Subnet
    SW1(dhcp-config)#network 172.16.1.0 255.255.255.0
    SW1(dhcp-config)#default-router 172.16.1.1
    SW1(dhcp-config)#option 150 ip 172.16.1.10
    SW1(dhcp-config)#dns-server 61.134.1.4
    SW1(dhcp-config)#domain-name norvel.com
    SW1(config)#ip dhcp excluded-address 172.16.1.1
    SW1(config)#ip dhcp excluded-address 172.16.1.10
    
    1. 在SW2运行动态路由协议,配置辅助地址
    SW1#telnet 12.0.0.2
    Trying 12.0.0.2 ...Open
    
    
    User Access Verification
    
    Username: admin
    Password: 
    SW2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    SW2(config)#
    SW2(config)#router rip
    IP routing not enabled
    SW2(config)#ip routing
    SW2(config)#router rip
    SW2(config-router)#version 2
    SW2(config-router)#no auto-summary 
    SW2(config-router)#network 12.0.0.2
    SW2(config-router)#network 172.16.1.1
    

    //配置DHCP中继地址

    SW2(config-if)#int vlan 200
    SW2(config-if)#ip helper-address 12.0.0.1
    
    SW1#show ip int brief 
    Vlan100                12.0.0.1        YES manual up                    up 
    Vlan200                192.168.1.1     YES manual up                    up
    
    1. 在PC1和PC2上查看获得IP地址信息
      首先需要在电脑上点击DHCP获取IP。
      PC1:
      在这里插入图片描述
      PC2:
      在这里插入图片描述
    2. 查看交换机IP地址池和动态绑定信息
    SW1#show ip dhcp binding 
    IP address       Client-ID/              Lease expiration        Type
                     Hardware address
    192.168.1.2      000A.41C6.02DC           --                     Automatic
    172.16.1.2       0003.E40B.96D3           --                     Automatic
    
    SW1#show ip route 
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         12.0.0.0/24 is subnetted, 1 subnets
    C       12.0.0.0 is directly connected, Vlan100
         172.16.0.0/24 is subnetted, 1 subnets
    R       172.16.1.0 [120/1] via 12.0.0.2, 00:00:14, Vlan100
    C    192.168.1.0/24 is directly connected, Vlan200
    
    
    1. 测试全网互联互通。
    SW1#ping 172.16.1.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
    .!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/1 ms
    

    发现主机1能ping通主机2,说明可以全网互通。

    展开全文
  • cisco交换机开启dhcp服务

    千次阅读 2017-11-27 13:57:00
    拓扑图如下: 上述设备用途说明: 1、使用R1做dhcp server 2、使用R2和R3代替电脑做... 3、SW1用做傻瓜交换机dhcp server配置(R1配置): 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 2...
  • 思科交换机VLAN,DHCP配置模拟实例

    千次阅读 2020-10-10 15:15:04
    2.开始准备工作,f0/1接左边交换机,f0/2接右边交换机,实际工作中,一定要接这个口,你要是接反了或者接到其他口去,获取的IP就不对了 3.点击最上面那个交换机,开始配置(图里的交换机型号有误,应该是2960) 4....
  • 交换机配置DHCP侦听

    2021-04-30 21:30:19
    简述思科交换机DHCP侦听设置
  • 拓扑 DHCP服务在网络中应用很常见,但是也容易被干扰,为什么这么说呢,主要是因为DHCP的机制很简单,而且谁先响应先用谁的,并没有什么验证以及安全机制,这样...说明:正常情况下由三层交换机来提供DHCP地址服...
  • 说明:有3个VLAN,VLAN2与VLAN3是用户VLAN,而VLAN 88则是DHCP服务器的VLAN,在实验演示一中,DHCP服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP服务器则在后续中继的过程中使用到。 地址规划 VLAN...
  • IPV4 DHCP中继服务器之思科交换机配置 标题:IPV4 DHCP中继服务器配置 + 思科交换机配置 + DHCP服务器配置 一、DHCP服务器配置 网络拓扑图 DHCP服务器分配3个子网,分别为100.100.100.0/24 100.100.20.0/24 100.100....
  • cisco交换机DHCP分配静态IP

    千次阅读 2019-09-18 06:58:10
    这里我们以vlan31进行描述 ip dhcp pool vlan31network 172.31.255.0 255.255.255.0default-router 172.31.255.254 ...1、先将特殊IP地址从dhcp中剔除掉,以免后面造成ip地址冲突ip dhcp excluded-address 172.31.25...
  • 然后开启交换机上的路由功能。2、将vlan 2,3加入端口后在对应的端口配置对应vlan的网关地址,再配置路由器与交换机相连的端口的IP。3、在路由器上配置连接交换机接口的IP地址。并配置去往两网关的路由表。4、在...
  • 思科设备配置DHCP命令

    万次阅读 多人点赞 2019-03-24 14:16:45
    DHCP(Dynamic Host Configuration Protocol)基本知识点: 1 、DHCP协议在RFC2131中定义,使用udp协议进行数据报传递,使用的端口是67(DHCP服务器)和68(DHCP客户端)。 2 、DHCP最常见的应用是,自动给终端...
  • 点配置,到Slots,增加两个NM-1FE-TX,开机并命名为dhcp2、增加一台router c3600,点配置,到Slots,增加一个NM-16ESW(使这台机成为交换机),开机并命名为relay3、增加一台host4、dhcp的f0/0连接reply的f0/0,...
  • Cisco交换机DHCP Snooping功能详解+实例

    千次阅读 2018-03-31 10:56:57
    一、采用DHCP服务的常见问题 架设DHCP服务器...但在DHCP服务的管理上存在一些问题,常见的有: ·DHCP Server的冒充 ·DHCP Server的DOS***,如DHCP耗竭***·某些用户随便指定IP地址,造成IP地址冲突 1、DHCP Ser...
  • 思科防止dhcp攻击

    2020-05-11 00:06:59
    什么是DHCPDHCP(Dynamic Host Configuration Protocol,动态主机配置协议)是一个局域网的网络协议,前身是BOOTP协议, 使用UDP协议工作,常用的2个端口:67(DHCP server),68(DHCP client)。DHCP通常被用于...
  • 这些全部是我自己总结和结论,感觉我提供的知识点不错的,可以给我点个关注!也可以进行私聊讨论。 实验 注:vlan10-192.168.10.0/24 ...Vlan20-192.168.20.0/24 ...在R1上配置DHCP,在SW1上配置...
  • 思科 三层交换 DHCP 的配置

    千次阅读 2018-12-22 16:06:54
    思科 三层交换 DHCP 的配置 :   拓扑结构:   步骤: 在SW1和SW2上分别完成VLAN配置,并在VLAN中添加相应的端口成员,同时配置Trunk端口      在L3Switch 上创建VLAN10 和VLAN20 ,并配置VLAN10 的虚...
  • DHCP监听DHCP监听(DHCP Snooping)是一种保护DHCP服务器的安全机制,它可以过滤来自网络中的主机或其他设备的非信任DHCP报文,以保证客户端能从正确的DHCP服务器获得IP地址,DHCP监听可以避免DHCP服务器欺骗和DHCP...
  • 思科模拟器配置DHCP的几种方式

    万次阅读 多人点赞 2019-10-29 16:44:51
    思科模拟器配置DHCP的几种方式 第一种:基于三层交换机+路由器的DHCP拓扑图 1.知识点梳理: 二层交换机: 配置vlan 端口划分进vlan 连向三层的端口配置trunk模式 三层交换机: 配置vlan vlan端口配置ip 连向路由...
  • 注意:二层交换机是没有DHCP功能的,IP是三层的,所以只有三层交换机和路由器才有DHCP功能。 二、配置步骤 创建地址池 分配地址池的范围 分配网关 分配DNS 给路由配置端口IP 如果有需要则配置不自动分配的地址段或...
  • 关于思科三层交换机和作为路由,DHCP获取的学习记录 关于思科三层交换机和作为路由,DHCP获取的学习记录 入门网络互联技术,刚入手网络互联的学习,所以很多都不懂,学校老师教得也是偏理论,实践方面更多的都是...
  • 一、采用DHCP服务的常见问题 架设DHCP服务器可以为客户端自动分配IP地址、掩码、默认网关、DNS服务器等网络参数,简化了 网络配置,提高了管理效率。但在DHCP服务的管理上存在一些问题,常见的有:  ●DHCP ...
  • 思科DHCP配置命令

    千次阅读 2021-09-24 10:55:45
    DHCP配置 ip dhcp pool VLAN10 //定义DHCP地址池VLAN10为vlan id network 172.16.2.0 255.255.255.0 //配置地址池的网络和掩码 default-router 172.16.2.254 //配置默认网关 domain-name cisco.com //域名,可选...
  • 思科 DHCP服务器配置及DHCP中继

    千次阅读 2018-01-15 14:00:26
    思路:1、配置 DHCP 客户端 确保每个 PC 为 自动获取IP地址的方式;2、配置 SW1 # 创建 VLAN 10 , 20 # 将相关的端口,放入到对应的 VLAN ; # 配置交换机之间的互联链路 - Trunk ;3、配置 SW # 创建 VLAN 10 ...
  • 思科模拟器-DHCP配置

    千次阅读 2019-04-29 14:55:00
    一、如图做好以下拓扑图(下图我取消显示端口号) 二、配置最下面的四台上网终端为自动获取ip 三、配置中间的二层交换机:添加vlan,同时所有端口设为access类型并将其...六、配置dhcp并启动dhcp服务 七、...
  • 思科DHCP的配置和DHCP中继的配置

    千次阅读 多人点赞 2019-06-02 19:38:46
    主要应用于小型企业上,直接在三层设备上开启DHCP服务,为用户分配地址 直接在三层设备(SW1)上配置 interface Vlan10 ip add 192.168.10.254 255.255.255.0 interface Vlan20 ip add 192.168.20.254 255....
  • 一、网络拓扑 二、说明 1、拓扑说明:汇聚层交换机为CATALYST4506,核心交换机为CATALYST6506,接入层交换机为CATALYST2918。4506上启 用IP DHCP SNOOPING和DAI以及IPSG,4506上连和下连的端口均配置为TRUNKING;...
  • 使用cisco搭建实验环境一. 、配置 DHCP 客户端; 二,配置交换机sw1sw1(config)#vlan 10sw1(config-vlan)#exsw1(config)#vlan 20sw1(config-vlan)#exsw1(config)#int fa0/1sw1(config-if)#switchport mode accesss.....

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,542
精华内容 616
关键字:

思科交换机开启dhcp