精华内容
下载资源
问答
  • 思科路由器qos配置
    2010-01-02 22:43:43
    以下是为公司在CISCO上写的,不是为了路由,而是为了比较实用的NAT与访问表管理。机上有两个端口,分别为向外的Ethernet0/0与向内的Ethernet0/1。
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname isgod  <--本机名
    !
    boot system flash
    no logging buffered
    enable secret 5 $1$x178$CakJRLZIrFmpnfA2gv0jX1
    !
    ip subnet-zero
    !
    interface Ethernet0/0  <--向外端口
     ip address 111.111.111.20 255.255.255.0  <--端口IP
     ip nat outside  <--表记向外NAT
    !
    interface Ethernet0/1  <--向内端口
     ip address 192.168.101.3 255.255.254.0 secondary  <--端口的第二个IP,可设多个
     ip address 192.168.101.1 255.255.254.0  <--主IP
     ip nat inside  <--表记向内NAT
    !
    ip nat translation tcp-timeout 1200 <-当客户端多时,加上此句(20分钟关闭tcp端口)否则端口满时,有些会连不上。缺省为24小时
    ip nat pool nat-1 111.111.111.20 111.111.111.20 netmask 255.255.255.0  <--设置一个公网上的IP池,在这里只有一个公用IP,它的别名为nat_1。
    ip nat inside source list 100 pool nat-1 overload  <--对内端口使用NAT,并使用访问表1
    ! 注意如果只有一个对外的IP,以上两行也可用此行代替:ip nat inside source list 100 interface Ethernet0/0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 111.111.111.11  <--缺省路由
    no ip http server  <--不提供机上的HTTP服务
    !
    !设端口输入时运用扩展访问表组,组号100。普通访问表组为1-99,扩展的为100-199。两者区别为扩展的能使用端口号
    access-list 100 permit ip 192.168.100.32 0.0.0.7 any  <-- 对访问表100,192.168.100.32后8个地址向外能访问
    access-list 100 permit tcp 192.168.100.0 0.0.1.255 any eq www  <-- 192.168.100.0/23能访问HTTP
    access-list 100 permit tcp 192.168.100.0 0.0.1.255 any range ftp-data smtp  <--能访问FTP,发邮件等,端口20-25
    access-list 100 permit tcp 192.168.100.0 0.0.1.255 any eq pop3  <--能收邮件
    access-list 100 permit tcp 192.168.100.0 0.0.1.255 any eq 443  <--能HTTPS
    access-list 100 permit udp 192.168.100.0 0.0.1.255 any eq domain <--能DNS
    access-list 100 permit icmp 192.168.100.0 0.0.1.255 any  <--能对外PING
    !
    line con 0
     password XXXX
     login
     transport input none
    line aux 0
    line vty 0 4
     password XXXX
     login
    !
    end
    2007.10.10修改,关于这个路由器的流量控制,以后再添上。
    下面是常用语句:
    show run
    show ip nat translations [verbose]
    show ip nat statistics

    转载于:https://blog.51cto.com/sunrc/254842

    更多相关内容
  • Cisco路由器QoS配置过程

    千次阅读 2010-03-03 15:29:46
    对不同IP组进行流量限制实例...Cisco(config)#ip access-list extendedBOSS Cisco(config-ext-nacl)#permit ip host 192.168.1.8 any Cisco(config-ext-nacl)#permit ip host 192.168.1.18 any Cisco(config-ext...

     对不同IP组进行流量限制实例:

    Cisco(config)#ip access-list extended BOSS
    Cisco(config-ext-nacl)#permit ip host 192.168.1.8 any
    Cisco(config-ext-nacl)#permit ip host 192.168.1.18 any
    Cisco(config-ext-nacl)#permit ip host 192.168.1.38 any
    Cisco(config-ext-nacl)#permit ip host 192.168.1.48 any
    Cisco(config-ext-nacl)#permit ip host 192.168.1.58 any
    Cisco(config-ext-nacl)#permit ip host 192.168.1.68 any
    Cisco(config-ext-nacl)#end
    Cisco#config t
    Cisco(config)#ip access-list extended COMMON
    Cisco(config-ext-nacl)#deny ip host 192.168.1.8 any
    Cisco(config-ext-nacl)#deny ip host 192.168.1.18 any
    Cisco(config-ext-nacl)#deny ip host 192.168.1.38 any
    Cisco(config-ext-nacl)#deny ip host 192.168.1.48 any
    Cisco(config-ext-nacl)#deny ip host 192.168.1.58 any
    Cisco(config-ext-nacl)#deny ip host 192.168.1.68 any
    Cisco(config-ext-nacl)#permit ip 192.168.0.0 0.0.255.255 any
    Cisco(config-ext-nacl)#end
    Cisco#config t
    Cisco(config)#route-map QoS permit 10
    Cisco(config-route-map)#match ip address BOSS
    Cisco(config-route-map)#set ip precedence ?
        <0-7>             Precedence value
        critical          Set critical precedence (5)
        flash             Set flash precedence (3)
        flash-override    Set flash override precedence (4)
        immediate         Set immediate precedence (2)
        internet          Set internetwork control precedence (6)
        network           Set network control precedence (7)
        priority          Set priority precedence (1)
        routine           Set routine precedence (0)
        <cr>
    Cisco(config-route-map)#set ip precedence critical
    Cisco(config-route-map)#exit
    Cisco(config)#route-map QoS permit 20
    Cisco(config-route-map)#match ip address COMMON
    Cisco(config-route-map)#set ip precedence priority
    Cisco(config-route-map)#exit
    Cisco(config)#class-map match-any NORMAL
    Cisco(config-cmap)#match ip precedence 0 1 2 
    Cisco(config-cmap)#class-map match-any PREMIUM
    Cisco(config-cmap)#match ip precedence 0 1 2
    Cisco(config-cmap)#exit
    Cisco(config)#policy-map QoS_OUTPUT
    Cisco(config-pmap)#class PREMIUM
    Cisco(config-pmap-c)#bandwidth 2048
    Cisco(config-pmap-c)#police 2048000 bc 19200 38400
    Cisco(config-pmap-c-police)#conform-action transmit
    Cisco(config-pmap-c-police)#exceed-action transmit 
    Cisco(config-pmap-c-police)#class NORMAL
    Cisco(config-pmap-c)#bandwidth 512
    Cisco(config-pmap-c)#police cir 51000 bc 1200 be 1200
    Cisco(config-pmap-c-police)#conform-action transmit 
    Cisco(config-pmap-c-police)#exceed-action drop 
    Cisco(config-pmap-c-police)#end
    Cisco#config t
    Cisco(config)#interface G 0/0
    Cisco(config-if)#ip nat inside
    Cisco(config-if)#ip policy route-map QoS
    Cisco(config)#interface G 0/1
    Cisco(config-if)#ip nat outside
    Cisco(config-if)#service-policy output QoS_OUTPUT

    ----------------------------------------------------------------------------

    marking
    1.
    定义class-map.
    class-map [match-all/match-any] {map-name}
    默认不打的话是match-all
    2.
    定义匹配命令match
    match access-group {NO}
    match input-interface {interface}
    match class-map {map-name}                class-map
    嵌套
    match source-address {mac-address}           
    mac地址
    match destination-address {mac-address}      
    目的mac地址
    match vlan {vlan-ID}
    match ip dscp {DSCP}
    match ip precedencc {precedence}
    match protocol {protocol}                    
    基于NBAR

    Router(config) class-map FOO
    Router(config-cmap)#match ?
           access-group             Access group
           any                      Any packets
           class-map                Class map
           cos                      IEEE 802.1Q/ISL class of service/user priority values
           destination-address      Destination address
           input-interface          Select an input interface to match
           ip                       IP specific values
           mpls                     Multi Protocol Label Switching specific values
           not                      Negate this match result
           protocol                 Protocol
           qos-group                Qos-group
           source-address           Source address
    3.
    设置policy-map
    policy-map {policy-name}
    4.
    调用class-map
    class-map {map-name}
    5.
    设置标记
    set ip dscp {DSCP}
    set ip precedence {PRECEDENCE}
    set cos {COS}
    priority {Kbps|percent PERCENT} [bc]       
    定义优先级流量的带宽以及突发流量
    bandwidth {Kbps|percent PERCENT}           
    定义保留带宽
    random-detect                              
    启用WRED
    police {CIR BC BE} conform-action {action} exceed-action {action} [violated-action {action}]     
    使用令牌桶限速
    queue-limit {PACKETS}                      
    定义队列中数据报的最大个数
    service-policy {policy-name}               
    调用其它的策略进行嵌套
    shape {average|peak} {CIR [BC] [BE]}       
    ×××
    drop
    6.
    在接口模式下调用policy-map
    service-policy [input|ouput] {POLICY-NAME}
    察看命令:
    show policy-map [policy-name]
    show policy-map interface [INTERFACE]
    show class-map [class-name]
    show ip nbar pdlm
    show ip nbar port-map        
    显示NBAR使用的协议到端口的映射

    NBAR
    应用:
    使用限制:
    1.
    快速以太网信道
    2.
    隧道接口或加密的接口
    3.SVI
    (交换虚拟接口)
    4.
    拨号接口
    5.
    多链路PPP(MLP)
    使用前先要敲命令:ip cef
    class-map {name}
    match protocol ...
    ip nbar pdlm flash://bittorrent.pdlm     
    加载bittorrent.pdlm 到路由器闪存里(事先要把pdlm复制到flash中)
    match procotol http url "*.jpeg|*.jpg" (
    匹配url中带有jpegjpg的连接)
    match procotol http url "*.gif" (
    匹配url中有gif的连接)

    拥塞管理
    WFQ

    特点:
    1.
    基于流(5元素)分类,队列数N可以配置
    2.
    出队后按IP优先级来分配带宽,优先级越低则带宽越小
    3.
    在其它队列空闲时抢占它们的带宽,又有流量时归还带宽
    4.
    是低于2.048Mbps串行接口的默认配置
    配置命令:
    接口模式下fair-queue
    show queueing fair
    show queue [interface]
    PQ:
    缺点:1.只能静态配置,不能适应网络拓扑的变化2.不支持隧道接口3.要通过数据分类卡,FIFO
    配置:
    1.
    定义优先级队列,可以基于协议和基于进站接口
    基于协议poriority-list {list-number} protocol {PROTOCOL-NAME} {high|medium|normal|low}
    基于进站接口poriority-list {list-number} interface {interface} {high|medium|normal|low}
    2.
    定义默认优先级队列,未被分类的数据报被送到此处,默认级别为normal
    priority-list {list-number} default {high|medium|normal|low}
    3.
    定义每个队列中数据报的个数,从高到低,默认为20,40,60,80
    priority-list {list-number} queue-limit {high-limit medium-limit normal-limit low-limit}
    4.
    把优先级队列运用在接口上
    priority-group {list-number}
    察看命令:
    show queue [interface]
    show queueing priority

    RTP(Real Time Protocol)
    支持端口号为偶数的udp报文
    可以进行限速,超过的可丢弃,也可以配置带宽,不会占用超出规定的带宽
    命令:
    ip rtp priority {starting-rtp-port-number port-number-range} {bandwidth}
    max-reserved-bandwidth PERCENT
    show queue [interface]
    debug priority

    CRTP(
    压缩实时协议): 用来压缩ip/udp/rtp报头
    压缩分为三种:链路压缩,有效负载压缩,报头压缩
    二层报头--tcp/ip报头--有效负载
    1.
    链路压缩:对整个分组进行压缩,包括报头和有效负载。独立于协议的。只适用于点到点链路。两种算法:PredictorSTAC
    2.
    有效负载压缩:只压缩数据部分,对报头没有影响。适用于frame-relayATM网络。
    3.tcp/ip
    报头压缩:针对协议的,适用于几个字节数据的小型分组。
    配置:
    HDLC,LAPB: compress [predictor|stac|mppc]
    ppp: ip compress [predictor|stac]
    frame-relay点到点接口或子接口启用stac压缩: frame-relay payload-compress
    启用crtp
    1. ip rtp header-compression [passive]
    若不启用passive,则对所有RTP数据流压缩;若启用passive,则只有当进入端口的RTP分组被压缩时,软件才能对离开该接口的RTP分组压缩
    2. ip rtp compression-connections {NUMBER}
    更改CRTP压缩的条数,默认为16
    3. 
    启用tcp报头压缩: ip tcp header-compression [passive]     若没有启用passive, 则必须指定关键字active,将对所有IP/UDP/RTP包头进行压缩 
    ip tcp compression-connections {NUMBER}
    frame-relay
    中的 crtp
    在物理接口上启用CRTP,则在它的子接口上将继承特性
    frame-relay ip rtp header-compression [passive]   
    frame-relay ip rtp compression-connections {NUMBER}
    只针对特定的PVC启用CRTP
    frame-relay map ip {ip-address} {dlci} [broadcast] rtp header-compression [active|passive] [connections number]
    察看命令:
    show ip rtp header-compression [interface] [detail]
    show frame-relay ip rtp header-compression [interface]

    WRR(weighted round-robin)
    一种队列调度机制,根据每个出站队列的权值来分配带宽,权值与带宽成正比。
    仅当发生拥塞时才会使用WRR,不拥塞时不会分配带宽。
    步骤:
    1.
    全局启用mls qos
    2.
    进入接口模式
    3.
    通过COS将数据报分配到不同的队列中去。
    wrr-queue cos-map QUEUE-ID THROSHOLD COS1... COSn     
    它用于配置cos值到出站队列的映射关系。
    对队列进行编号时,从低优先级开始,到严格优先级结束。
    配置严格优先级队列:wrr-queue priority-queue 
    4.
    配置WRR队列的权重
    wrr-queue bandwidth WEIGHT1 WEIGHT2 WEIGHT3 WEIGHT4
    计算每个队列的方法是:
    example
    wrr-queue bandwith 1 2 3 4
    则带宽队列1:权重1/总权重=1/10
    5.
    定义传输队列长度的比例,取值为1-100%
    wrr-queue queue-limit LOW-PRIORITY-QUEUE-WEIGHT MEDIUM-PRIORITY-QUEUE-WEIGHTS HIGH-PRIORITY-QUEUE-WEIGHTS
    高优先级队列因为延时小,数据量小,所以不需要太大的缓存区。往往将大部分缓冲区用于低优先级队列。

    拥塞避免
    1.
    尾丢弃
    对所有通信流平等对待,将导致TCP全局同步
    wrr-queue threshold QUEUE-ID THR1% 100%         THR1%
    是开始丢弃通信流时输出队列的填满程度,后面一个是100%是尾丢弃
    2.WRED
    WRED
    RED的区别在于前者引入IP优先权DSCP值来区别丢弃策略,可以为不同IP优先级DSCP设定不同的队列长度、队列阈值、丢弃概率。并且RED只对TCP流量有用
    通过对队列数据流传输速度的平均值计算来决定是否丢弃,防止了对突发流量的不公平待遇。
    WRED
    LLQ矛盾
    WRED
    往往和WRR一起使用。
    WRED
    可以在接口上进行配置,也可以在policy上进行配置,可以针对于precedence进行RED,也可以针对于DSCP值进行RED,当然,两者之间只能选择一个。
    (1)
    基于DSCP
    random-detect dscp-based   
    random-detect dscp {DSCP} {min max mark}
    (2)
    基于ip precedence
    random-detect 
    random-detect precedence {PRECEDENCE} {min max mark}
    WRED
    WRR连用:
    wrr-queue random-detect min-throshold QUEUE-ID THR1% [THR2% [THR3% ...]]
    wrr-queue random-detect max-throshold QUEUE-ID THR1% [THR2% [THR3% ...]]
    min-throshold
    表示开始丢弃某些数据包时的最大填满程度
    max-throshold
    表示丢弃所有数据包时的最大填满程度
    example:
    int G1/1
    wrr-queue bandwidth 50 75
    wrr-queue queue-limit 100 50
    wrr-queue random-detect min-throshold 1 50 70
    wrr-queue random-detect max-throshold 1 75 100
    wrr-queue cos-map 1 1 0 2
    wrr-queue cos-map 1 2 3
    wrr-queue cos-map 2 1 4
    wrr-queue cos-map 2 2 6
    priority-queue cos-map 1 1 5 7
    rcv-queue cos-map 1 1 0
    switchport
    解释:共有两个队列。当队列1的填满程度达到50%70%时,交换机分别对映射到闸值1和闸值2的数据包进行WRED(即开始丢弃),当队列1的填满程度达到75%100%时,交换机分别对映射到闸值1和闸值2的数据包全部丢弃。注意:队列2没有采取WRED
    基于流的WREDWREDWFQ结合起来使用)
    小的流丢弃的概率小,大的流丢弃的概率大,保护小的流。
    命令:
    1.
    启用基于流的WRED
    random-detect flow
    2.
    设置平均深度因素(average depth factor)的值,值必须为2的幂,默认值为4.可选:
    random-detect flow average-depth-factor {scaling-factor} 
    这个参数是改变一个乘法的比例因数.从而改变队列的大小,其实就是改变队列的长度。
    3.
    设置基于流的WRED 的数据流数目,默认值为256
    random-detect flow count {number}

    流量策略
    qos
    的流程:1.基于流或基于类的分类;2.结合令牌桶进行policingshaping(CARGTS)3.拥塞避免(尾丢弃或WRED)4.拥塞管理(各种队列机制)5.出队。
    标记在什么地方进行??(标记可以在进行CAR的时候进行,CAR也可以进行重新标记)
    CAR(Committed Access Rate)
    CAR
    通过使用令牌桶TC来进行流量控制。分类后,不需要流控的流量直接继续发送,而需要进行流控的流量就要经过令牌桶。只有当令牌桶中有令牌时,相应的流量才能通过。若没有足够的令牌,要么流量被直接丢弃(policing),要么缓存起来(shaping),等有了足够的令牌后再发送出去。
    CAR
    还可以用来做markremark(即可以用来设置ip优先级或重新设置ip优先级)
    CAR
    可以为不同类别的报文设置不同的流量特性和标记特性,即可以对每个类进行CARCAR的策略还可以串联处理,比如先对总的流量进行一次限速,然后再对各个类进行小范围的限速。
    CAR
    一般用在网络边界路由器上。可以在一个接口上设置多个CAR策略,数据包依次和多个CAR策略匹配,若没有匹配的,则默认操作时转发数据包。
    CAR
    的使用有以下限制:1.只能对IP流量限速;2.不支持fast EtherChannel;3.不支持隧道接口;4.不支持ISDN PRI接口。
    命令:
    rate-limit {output|input} {CIR BC BE} conform-action {action} exceed-action {action}
    注意:CIR单位是bit/s;BCBE的单位是byte/s
    conform-action
    的条件是指当要发的数据小于正常突发(bc)的时候。exceed-action是指要发的数据大于普通突发,小于最大突发(be)的时候。
    action
    的选项共有如下这些:
    continue                           
    继续执行下一条CAR语句
    drop                               
    丢弃数据包
    tranmsit                            
    转发数据包 
    set-prec-continue {precedence}     
    设置IP优先级并继续执行下一条CAR语句
    set-prec-transmit {precedence}      
    设置IP优先级并转发数据包
    set-dscp-continue {dscp}           
    设置dscp值并继续执行下一条CAR语句
    set-dscp-transmit {dscp}            
    设置dscp值并转发数据包
    上面都是只能基于整个接口的流量进行CAR,下面的可以分别针对某个流量或ip precedencedscp值或MAC地址进行CAR
    扩展的配置
    1.
    针对dscp值进行CAR
    rate-limit {output|input} [dscp DSCP] {CAR BC BE} conform-action {action} exceed-action {action}
    2.
    针对ACL进行CAR
    rate-limit {output|input} access-group {ACL NUM} {CAR BC BE} conform-action {action} exceed-action {action}
    3.
    针对限速ACL进行CAR
    rate-limit {output|input} access-group rate-limit {ACL NUM} {CAR BC BE} conform-action {action} exceed-action {action}
    限速ACL只是一种调用关系:access-list rate-limit {ACL NUM} {precedence|mac-address}     可以匹配优先级,也可以匹配MAC地址
    察看命令:
    1.
    查看限速ACLshow access-lists rate-limit [ACL]
    2.
    查看接口的限速信息:show interfaces [interface] rate-limit
    policy map
    CAR操作
    police {CIR BC BE} conform-action {action} exceed-action {acion} violated-action {acion}
    action
    的选项同上。

    流量×××(shaping)
    通常通过缓冲区和令牌桶来完成,当报文的发送速度过快时,首先在缓冲区进行缓存,在令牌桶的控制下再均匀地发送这些被缓冲的报文。
    采用的技术为GTS(通用流量×××)。
    GTS
    CAR的主要区别在于:利用CAR进行报文流量控制时对不符合流量特性的报文进行丢弃,而GTS对于不符合流量特性的报文则是进行缓冲,减少了报文的丢弃,同时满足报文的流量特性。
    若报文不需要进行GTS,则不经过令牌桶的处理直接发送。
    当因为缺乏足够的令牌而采用GTS后,GTS按一定的周期从队列中取出报文进行发送。每次发送都会与令牌桶中的令牌数作比较。直到令牌桶中的令牌数减少到队列中的报文不能再发送或是队列中的报文全部发送完毕为止。
    一般在路由器的出口进行shaping,入口进行policing
    命令:
    1.
    基本的GTStraffic-shape rate {CIR BC BE}
    2.
    基于ACLGTS: traffic-shape group {ACL} {CIR BC BE}
    察看:
    1.
    查看GTS 的配置信息:show traffic-shape [interface]
    2.
    查看GTS 的统计信息:show traffic-shape statistics [interface]
    GTS
    Frame Relay上的实现
    1.
    在接口上启用GTS:
    traffic-shape rate {CIR [Bc [Be]]}
    2.
    当接口收到向后显性拥塞通知(BECN),估算流量速率的最低值:
    traffic-shape adaptive {CIR}
    3.
    以向前显性拥塞通知(FECN)做为BECN 的响应.可选:
    traffic-shape fecn-adapt
    GTS
    policy map上的实现
    GTS
    还可以定义平均值和峰值的流量×××,并且可以在配置GTS 的时候采用CBWFQ
    配置基于分类的流量×××的步骤如下:
    1.
    定义平均值和峰值的CIR,Bc Be:
    (config-pmap-c)#shape {average|peak} {CIR [Bc] [Be]}     average
    指的是平均值,peak说得是峰值
    2.
    定义缓冲区上限,默认值为1000.可选:
    (config-pmap-c)#shape max-buffers {number-of-buffers}
    3.
    在策略上应用CBWFQ。可选:
    (config-if)#service-policy output {policy-name}

    转载于:https://blog.51cto.com/wyb7821/280248

    展开全文
  • Cisco路由器QoS配置过程,介绍Cisco Router配置QoS
  • cisco路由器QOS限速 rate-limit。QOS
  • 1、CISCO交换机QOS限速配置

    千次阅读 2017-11-03 18:52:00
    CISCO交换机QOS限速配置步骤: 1、启用全局qos 2、设置ACL匹配的流量 3、设置一个class-map,来匹配第二步设置的ACL 4、设置一个policy-map匹配class-map,然后再在这里面定义一系列策略,限制的带宽按位(bit)为...

    CISCO交换机QOS限速配置步骤:

    1、启用全局qos

    2、设置ACL匹配的流量

    3、设置一个class-map,来匹配第二步设置的ACL

    4、设置一个policy-map匹配class-map,然后再在这里面定义一系列策略,限制的带宽按位(bit)为计算,突发量按字节(byte)计算

    5、将policy-map应用到相应的接口上



    mls qos

    ip access-list extended list83

    permit ip host 192.168.120.83 any

    class-map class83

    match access-group name list83

    policy-map policy83

    class class83

    trust dscp

    police 5000000 80000 exceed-action drop

    interface f0/11

    service-policy input policy83



          本文转自开源殿堂 51CTO博客,原文链接:http://blog.51cto.com/kaiyuandiantang/1882652,如需转载请自行联系原作者


    展开全文
  • 1、QOS模型尽力而为服务模型(Best-effort)集成服务模型(Integrated Services)差分服务模型(Differentiated Services)2、差分服务模型结构3、分类与标记标记可以使用IP包头中TOS的高三位(IP优先级)或高六位...

    1、QOS模型

    尽力而为服务模型(Best-effort)

    集成服务模型(Integrated Services)

    差分服务模型(Differentiated Services)


    2、差分服务模型结构


    3、分类与标记

    标记可以使用IP包头中TOS的高三位(IP优先级)或高六位(DSCP)做标记。


    在R1上将ICMP流量的优先级设置为2,将HTTP流量的DSCP值设置为AF22,其他没匹配到的流量优先级设置为1,在ISP上查看标记是否生效。


    ISP配置如下:


    ip http server

    access-list 100 permit ip any any dscp af22

    access-list 100 permit ip any any precedence 1

    access-list 100 permit ip any any precedence 2

    interface FastEthernet2/0

     service-policy input MARK


    R1配置如下:

    access-list 110 permit icmp any any

    access-list 120 permit tcp any any eq www


    class-map match-all ICMP

     match access-group 110

    class-map match-all WWW

     match access-group 120


    policy-map MARK

     class ICMP

      set precedence 2

     class WWW

      set dscp af22

     class class-default

      set precedence 1

      

    interface FastEthernet2/0

     service-policy input MARK


    TEST上的测试命令

    ping 33.1.1.1

    telnet 33.1.1.1 80


    查看命令

    show ip access-lists 

    show class-map                

    show policy-map               

    show policy-map interface s0/1



    4、队列技术(拥塞管理)

    队列技术应用于接口的出方向,一个接口只能使用一种队列技术。

    路由器的接口上有一个软件队列和一个硬件队列。数据包先进入软队列,然后使用队列技术对数据包进行调度进入硬件队列,硬件队列始终采用先进先出的方式发送数据包。

     

    常用的队列技术:FIFO、PQ、CQ、WFQ、LLQ都是CLI工具,而CBWFQ是MQC工具。

    先进先出队列(FIFO)

    优先级队列(PQ)

    自定义队里(CQ)

    加权公平队列(WFQ)

    低延时队列(LLQ)

    实时传输队列(RTP PQ):

    基于类加权公平队列(CBWFQ)


    队列技术三大组件:分类组件、插入丢弃组件、调度组件


    先进先出队列(FIFO)

    默认时:当接口的速度大于2.048Mbps是,路由器采用FIFO进行调度。


    优先级队列(PQ)

    队列数:高、中、普通、低共4个队列

    分类:根据事先分类放入不同队列

    插入丢弃:可以设置队列长度,队列满后,数据包将被尾丢弃

    调度:按照高、中、普通、低的顺序调度,只用高优先级的队列为空才会调度中优先级,依次类推。

    优点:保证高优先数据包优先转发

    缺点:高优先队列不为空,低优先级队列永远得不到转发


    指定不符合任何类型的数据包将进入的队列(默认normal)

    priority-list 1 default high 

    根据数据包的入口分类并将其放入到某个队列

    priority-list 1 interface serial 0/0 high 

    根据数据包的协议类型分类并将其放入到某个队列

    priority-list 1 protocol ip high tcp telnet

    指定各队列的大小

    priority-list 1 queue-limit 10 10 10 10

    在接口上应用队列

    priority-group 1


    =================================================================

    R1

    =================================================================

    priority-list 1 interface FastEthernet2/0 high

    priority-list 1 protocol ip normal tcp www

    priority-list 1 default low

    priority-list 1 queue-limit 10 20 30 40


    interface Serial0/1

     priority-group 1


    查看接口上的队列

    show int s0/1

    查看队列配置

    show queueing priority

    测试队列是否生效

    debug priority 

    show queueing interface s0/1


    自定义队列(CQ)

    队列数:CQ有17个队列,其中队列0为优先级队列。只有队列0为空,才为其他队列服务。

    分类:根据事先分类放入不同队列

    插入丢弃:可以设置队列长度,队列满后,数据包将被尾丢弃

    调度:为第1个队列转发一定字节数的数据包后,就转为为第2个队列转发,依次轮询

    优点:保证每个队列都有被服务的机会


    指定不符合任何类型的数据包将进入的队列(默认队列1)

    queue-list 1 default 1

    根据数据包的入口分类并将其放入到某个队列

    queue-list 1 interface serial 0/0 1 

    根据数据包的协议类型分类并将其放入到某个队列

    queue-list 1 protocol ip 1 tcp telnet

    指定每次轮询时各队列被转发的数据包字节数

    queue-list 1 queue 1 byte-count 100 

    指定各队列的大小

    queue-list 1 queue 1 limit 100

    指定优先级队列(例如此时为2,则队列0和1都是优先级队列)

    queue-list 1 lowest-custom 2

    在接口上应用队列

    custom-queue-list 1


    =================================================================

    R1

    =================================================================

    queue-list 1 interface FastEthernet2/0 2

    queue-list 1 protocol ip 3 tcp www           

    queue-list 1 queue 1 byte-count 100 limit 100

    queue-list 1 queue 2 byte-count 200 limit 200

    queue-list 1 queue 3 byte-count 300 limit 300

    queue-list 1 lowest-custom 4                 


    interface Serial0/1

     custom-queue-list 1


    查看接口上的队列

    show int s0/1

    查看队列配置

    show queueing custom 

    测试队列是否生效

    debug custom-queue

    show queueing interface s0/1



    加权公平队列(WFQ)

    默认时:当接口的速度小于2.048Mbps时,路由器采用WFQ进行调度。


    分类:具有相同协议类型,源IP,目的IP,源端口,目的端口,TOS值的数据包看成一个流,同一个流的数据包将放到一个队列中。

    插入丢弃:队列满后,数据包将执行WFQ丢弃,丢弃最差完成时间的数据包

    调度:先调度最快能转发完毕的数据包,包的大小采用虚拟包大小(虚拟包大小=实际包大小/(IP优先级+1))

    优点:优先级越高、包越小的数据包优先得到转发



    WFQ丢弃机制:(丢弃最差完成时间的数据包)

    HQO(Hold Queue Out Limit):整个WFQ系统所能存放的最大数据包数量,这个值为各队列之和。

    CDT(Congestive Discard Threshold):WFQ丢弃机制的门限值,当各队列数据包数量之和达到CDT就开始丢弃数据包。


    =================================================================

    R1

    ================================================================= 

    interface Serial0/1

     fair-queue 512 64 (指定CDT为512,最大会话数为64)

     hold-queue 1500 out (指定HQO为1500)


    查看接口上的队列

    show int s0/1



    基于类的加权公平队列(CBWFQ) 


    分类:允许自定义类,把数据放入不同队列,最多可以定义64个类,不匹配分类的数据放到系统默认类class-default中

    插入丢弃:可以设置队列长度,队列满后,数据包将被尾丢弃

    调度:对每个队列保留指明带宽,每个队列默认采用FIFO调度,但也可以结合WFQ调度。如何保证带宽及各队列数据包如何被调度到硬件队列无从知晓。

    优点:保证流量的最小带宽,而不是限制最多带宽


    =================================================================

    R1

    =================================================================

    access-list 1 permit 192.168.1.100

    access-list 2 permit 192.168.1.1

      

    class-map match-all 100

     match access-group 1

    class-map match-all 1

     match access-group 2


    policy-map MARK

     class 100

      bandwidth 500

     class 1

      bandwidth 500


    interface Serial0/1

     service-policy output MARK


     

    查看命令

    show class-map                

    show policy-map               

    show policy-map interface s0/1


    低延时队列(LLQ)


    LLQ配置类似CBWFQ,调度机制类似PQ。LLQ通常和CBWFQ一起使用。

    =================================================================

    R1

    =================================================================

    class-map match-any CLASS-MAP3

      match ip precedence 5 

    class-map match-all CLASS-MAP2

      match protocol telnet

    class-map match-any CLASS_MAP1

      match protocol http

      match protocol ftp


    policy-map MY-POLICY

      class CLASS_MAP1

       bandwidth 512

      class CLASS-MAP2

       bandwidth 128

       queue-limit 128

      class CLASS-MAP3

       priority 128


    interface Serial0/0

     bandwidth 1024

     service-policy output MY-POLICY


    这个例子中结合使用了LLQ和CBWFQ。

    CLASS-MAP3使用LLQ,保证带宽为128kbps,优先于CLASS-MAP1,CLASS-MAP2转发

    CLASS-MAP1,CLASS-MAP2使用WFQ,保证带宽分别为512kbps,128kbps。

     

    查看命令

    show class-map                

    show policy-map               

    show policy-map interface s0/0


    RTP优先队列

    RTP优先队列是一种解决语音服务质量的简单技术,期原理就是将承载语音的RTP数据包送入优先级队列使其得到优先转发。

    RTP识别语音的UDP数据包端口,这些数据包通常使用16384~32767的偶数端口发送。

    RTP优先队列可以和前面的任何一种队列包括FIFO、PQ、CQ、WFQ、CBWFQ、LLQ结合使用,但是它的优先级是最高的。即使RTP和LLQ一起使用,RTP的优先级也比LLQ高。


    interface Serial0/0

    ip rtp priority 16384 16383 256

    16384最低UDP端口号,16383端口增量,带宽256kbps



    5、拥塞避免

    随机早期预检测(RED)

    给队列设定两个门限值:最小门限和最大门限,当队列的平均长度小于最小门限时,不丢弃数据包;

    当队列的平均长度在最小门限和最大门限之间时,RED开始随机丢弃数据包;当队列的平均长度大于最高门限时,丢弃尾部所有的数据包。


    加权随机早期预检测(WRED)

    WRED和RED的原理一样,但是WRED可以根据不同的IP优先级或DSCP值,设定不同的最小门限、最大门限和丢弃概率,从而对不同优先级的数据包提供不同的丢弃特性。

    WRED不能和PQ、CQ、WFQ队列同时使用。


    配置基于IP Precedence的WRED

    random-detect

    根据IP优先级设置数据包的最小门限值、最大门限值、丢弃数据包的丢弃概率(该例中概率应该为1/10)

    random-detect precedence 1 10 20 10

    配置基于DSCP的WRED

    random-detect dscp-based 

    根据DSCP设置数据包的最小门限值、最大门限值、丢弃数据包的丢弃概率(该例中概率应该为1/10)

    random-detect dscp af22 10 20 10

    设置计算队列平均长度的权重因子(默认值为9)

    random-detect exponential-weighting-constant 9


    查看WRED队列配置

    show queueing int s0/0


    基于流的加权随机早期预检测(FB-WRED)

    WRED中,只用TCP流会对丢包做出反应并降低速率;而UDP等非自适应流并不会对丢包做出反应,因此UDP等非自适应流在拥塞时发送分组的速率将比自适应流高得多。

    FB-WRED对WRED除了改进,他对占用队列资源多余公平份额的流将得到惩罚。


    FB-WRED根据流和IP优先级(或者DSCP值)把到达的数据包放到不同的队列中,并且计算每个活动流的公平队列资源份额(队列长度/活动流的数目),

    对于占用队列资源多余公平份额的流将得到惩罚。方法是通过降低队列的WRED最大门限值来加大分组的丢弃概率。

    新的最大门限值=最小门限值+{(最大门限值-最小门限值)/ 2}


    配置FB-WRED(必须先配置WRED)

    random-detect flow 

    设置平均深度因素(即放大因子,默认值为4)

    random-detect flow average-depth-factor 4

    设置基于流的WRED的数据流数目

    random-detect flow count 32


    查看WRED队列配置

    show queueing int s0/0


    基于类的加权随机早期预检测(CB-WRED)

    CB-WRED可以和CBWFQ、Shaping结合,而不能与FB-WRED、LLQ、Policing结合。


    class-map match-any HTTP-FTP

      match protocol http

      match protocol ftp


    policy-map MY-POLICY

      class HTTP-FTP

       bandwidth 512

       random-detect

       random-detect precedence 0   20    30    10  

       

    interface Serial0/0

     bandwidth 1024

     service-policy output MY-POLICY

     

    此例启用基于优先级的WRED与CBWFQ结合。



    查看命令

    show class-map          

    show policy-map 

    show policy-map int s0/0



    6、流量×××(Shaping)                           

    流量×××的目的是平滑流量,流量×××会把超出规定速率的数据缓冲起来,不是丢弃,链路的平均流量速率较大,但会造成数据的延时加大或延时抖动。


    令牌桶的相关名词:

    CIR:承诺信息速率,单位bps

    PRI:承诺信息速率,单位bps

    Bc:正常突发量的大小,单位为字节

    Be:超额突发量的大小,单位为字节

    Tc: 时间间隔

    CIR=Bc/Tc


    当个令牌桶,桶的大小为Bc+Be;

    令牌以CIR的速率添加到令牌桶中;

    当数据包要转发出去,如果无法从令牌桶中获取足够的令牌,就将数据包缓存起来,都有足够的令牌在发送。数据包发送的平均速率不超过CIR,但某时刻可以一超过CIR的速率Bc+Be发送。


    GTS通用流量×××实在软件队列之前又增加一个队列来实施,这一队列采用的是WFQ。GTS可以与FIFO、PQ、CQ、WFQ配合使用。


    CLI配置法

    interface Serial0/1

     traffic-shape rate 8000 1500 1000 1000


    MQC配置法

    access-list 100 permit icmp any any


    class-map match-all ICMP

     match access-group 100

     

    policy-map TEST

     class ICMP

      shape average 8000 1000 1000


    interface Serial0/1

     service-policy output TEST


    查看命令

    show traffic-shape 

    show traffic-shape statistics 




    7、流量监管(Policing)

    流量监管可以应用在接口的出和入两个方向上。分为单桶单速双色、双桶单速三色、双桶双速三色。

    流量监管的目的是限速,流量监管会把超出规定速率的丢弃或者标记便于后继的路由器进行处理,链路的流量速率有较大起伏,整体平均带宽低,但是不会造成数据包延时增加。


    令牌桶的相关名词:

    CIR:承诺信息速率,单位bps

    PRI:承诺信息速率,单位bps

    Bc:正常突发量的大小,单位为字节

    Be:超额突发量的大小,单位为字节

    Tc: 时间间隔

    CIR=Bc/Tc


    单桶单速双色


    单个令牌桶,桶的大小为Be,而不是Bc+Be;

    令牌以CIR的速率添加到令牌桶中;

    当数据包要转发出去,如果可以从令牌桶中获取足够的令牌,则成为Conforn,此时桶内的令牌数为之前的令牌数减去数据包的大小;如果如法从令牌桶中获取足够的令牌,则成为Exceed,此时桶内的令牌数不变。


    CLI配置法

    interface Serial0/1

     rate-limit output 8000 1500 2000 conform-action transmit exceed-action drop


    MQC配置法

    access-list 100 permit icmp any any


    class-map match-all ICMP

     match access-group 100


    policy-map TEST

     class ICMP

       police cir 8000 bc 1500 be 1000

         conform-action transmit 

         exceed-action drop 


    interface Serial0/1

     service-policy input TEST


    查看命令

    show class-map          

    show policy-map 

    show policy-map int s0/0


    双桶单速三色


    两个令牌桶,TB1的大小为Bc,TB2的大小为Be;

    令牌以CIR的速率添加到令牌桶中TB1中,当TB1满后,令牌溢出到TB2中。

    当数据包要转发出去,如果可以从令牌桶TB1中获取足够的令牌,则成为Conforn,此时TB1的令牌数为之前的令牌数减去数据包的大小,TB2的令牌数不变;

    当数据包要转发出去,如果无法从令牌桶TB1中获取足够的令牌,但能从令牌桶TB2中获取足够的令牌,则成为Exceed,此时TB1的令牌数不变,TB2的令牌数为之前的令牌数减去数据包的大小;

    当数据包要转发出去,如果无法从令牌桶TB1中获取足够的令牌,也无法从令牌桶TB2中获取足够的令牌,则成为Violate,此时TB1、TB2的令牌数不变。


    access-list 100 permit icmp any any


    class-map match-all ICMP

     match access-group 100

     

    policy-map TEST

     class ICMP

       police cir 8000 bc 1500 be 1000

         conform-action transmit 

         exceed-action drop 

         violate-action drop 


    interface Serial0/1

     service-policy input TEST


    查看命令

    show class-map          

    show policy-map 

    show policy-map int s0/0


    双桶双速三色

    两个令牌桶,TB1的大小为Be,TB2的大小为Bc;

    令牌以PIR的速率添加到令牌桶中TB1中,以CIR的速率添加到令牌桶中TB2中,PIR>=CIR;

    当数据包要转发出去,如果可以从令牌桶TB1中获取足够的令牌,也可以从令牌桶TB2中获取足够的令牌,则成为Conforn,此时TB1的令牌数为之前的令牌数减去数据包的大小,TB2的令牌数也为之前的令牌数减去数据包的大小;

    当数据包要转发出去,如果可以从令牌桶TB1中获取足够的令牌,但不能从令牌桶TB2中获取足够的令牌,则成为Exceed,此时TB1的令牌数为之前的令牌数减去数据包的大小,TB2的令牌数不变;

    当数据包要转发出去,如果无法从令牌桶TB1中获取足够的令牌,也无法从令牌桶TB2中获取足够的令牌,则成为Violate,此时TB1、TB2的令牌数不变。


    access-list 100 permit icmp any any


    class-map match-all ICMP

     match access-group 100

     

    policy-map TEST

     class ICMP

       police cir 8000 bc 1500 pir 8000 be 1500

         conform-action transmit 

         exceed-action drop 

         violate-action drop 


    interface Serial0/1

     service-policy input TEST


    查看命令

    show class-map          

    show policy-map 

    show policy-map int s0/0


    转载于:https://blog.51cto.com/kaiyuandiantang/1917872

    展开全文
  • 思科路CISCO大名鼎鼎的路由器鼻祖思科路CISCO旗下的路由器可以说是互联网世界当中要求最为严格...思科路CISCO由器虚拟局域网(VLAN)配置手册帮助运维人员搞定思科路由器。思科路CISCO由器虚拟局域网(VLAN)配置手册为...
  • 有位歪果仁在论坛上兴叹“CISCO路由器Qos项目监控是永远的痛”,诚然如此,一般路由器的流量监控,采用Cacti来进行,更由于升级版本号的不同,和路由器IOS版本不同,而十分困难,有的方案甚至要tftp下载边写好的tcl...
  • cisco路由器QOS技术

    2007-06-28 20:24:38
    传送QoS请求的信令是RSVP(Resource Reservation Protocol),它通知路由器应用程序的QoS需求。 2.3 DiffServ Diffserv即区别服务模型,它可以满足不同的QoS需求。与Integrated service不同,它不需要信令,即...
  • QoSCisco 2600系列路由器的应用.pdf
  • Cisco交换机QOS(限速)详解

    千次阅读 2017-11-16 19:38:00
    Cisco IOS 系统上作QOS,一般要有以下五步: 1、启用全局qos 2、设置ACL匹配的流量 3、设置一个class-map,来匹配第二步设置的ACL 4、设置一个policy-map匹配class-map,然后再在这里面定义一系列策略 5、将policy...
  • Cisco QoS配置说明(CBWFQ/LLQ/PQ/CQ/WFQ)

    千次阅读 2010-06-15 07:47:00
    QOS-CBWFQ <br />CBWFQ 基于类别的加权公平排队,通常使用ACL定义数据流类别,并将注入宽带和队列限制等参数应用于这些类别. CBWFQ特点: 1)能够给不同的类保障一定的带宽 2)对传统的WFQ作...
  • Cisco最全配置命令

    2018-12-13 15:36:34
    把一台cisco路由器配置为帧中继交换机 122 帧中继上的RIP 124 帧中继上集成IS-IS 126 帧中继上点到点子接口下集成的IS-IS 127 帧中继上的OSPF 129 IPV6 131 IPv6 静态路由 131 IPv6 RIPng 131 OSPFv3 133 IPv6 EIGRP...
  • 二、QOS模型

    2022-07-08 15:02:56
    QOS模型
  • CISCO路由器的ACL的各项设置

    千次阅读 2019-05-27 11:05:44
    基础知识:用于网络流量过滤 ...匹配流量:Qos、VPN感兴趣流量匹配, 用作NAT的转换(私有网络→公网,多对一转换) ACL种类: GW(config)#access-list ? <1-99> IP standard access list ...
  • 在Cisco网络设备上使用服务质量(QoS),可以为某些类型的网络流量...笔者会向大家介绍如何通过我们的设置模板,轻松的为Cisco路由器和交换机配置 QoS。网络管理员可以通过QoS为某类网络流量指定所需的带宽和优先级。
  • 利用 Cisco SDM 用户不但能轻松地在 Cisco 路由器配置路由、交换、安全和服务质量 (QoS) 服务还能通过性能监控进行主动管理。现在 Cisco SDM 用户可以远程配置和监控 Cisco 路由器而不再需要使用 Cisco IOS ...
  • 如何备份思科cisco路由器配置文件 本资料之提供大家参考学习^*^ 有什么不懂的地方在博客中留言 QQ:569535658发布时间:2009-4-08 15:52:13 发布人:fengyifan 在路由器的配置过程中,经常会用到COPY这个命令。...
  • QOS技术之QOS policy 配置范例

    千次阅读 2020-06-20 13:16:28
    最近因为网里总有人偷偷下载大流量文件,便在Ciscorouter上使用QOS的一些方法来达到一个限制下载速度的目的。 具体做法参考如下: 1,先定义一个扩展访问控制列表: ip access-list extended lan-wan-limit-group...
  • cisco路由器SDM配置攻略

    千次阅读 2011-02-17 17:43:00
    cisco路由器SDM配置攻略 SDM(Security Device Manager)是Cisco公司提供的全新图形化路由器管理工具。该工具利用WEB界面、Java技术和交互配置向导使得用户无需了解命令行接口(CLI)即可轻松地完成IOS路由器...
  • 思科路由器指南

    2013-11-01 15:06:56
    思科路由器是智能信息网络的基础,提供低间断性,全面安全性,集成无线功能,易管理性以及高级服务质量(QOS),适用于当今要求最为严格的网络服务,包括IP通信,视频,客户关系管理,金融交易以及其他实时应用……
  • Cisco路由器手册

    2012-09-27 09:12:22
    第2章 Cisco路由器硬件 14 2.1 Cisco路由器网络分层 14 2.2 在线插拔 16 2.3 Cisco 12000系列 17 2.3.1 12000系列的使用 19 2.3.2 12000交换处理器 20 2.3.3 12000系列的存储器 20 2.3.4 12000系列的线卡 21 2.3.5 ...
  • Cisco QoS模板配置

    2013-01-16 10:57:34
    笔者会向大家介绍如何通过我们的设置模板,轻松 的为 Cisco路由器和交换机配置 QoS。网络管理员可以通过QoS为某类网络流量指定所需的带宽和优先级。 首先我们要理解带宽和优先级之间的区别。当我们在网络设备...
  • 史上最具人气、最受好评的网络设备图书领域“四大金刚”的全新升级版本再现江湖了,他们分别是:《Cisco交换机配置与管理完全手册》(第二版)、《H3C交换机配置与管理完全手册》(第二版)、《Cisco路由器配置与...
  • cisco QOS限速

    2017-11-12 14:54:00
    Cisco IOS 系统上作QOS,一般要有以下五步: 1、启用全局qos 2、设置ACL匹配的流量 3、设置一个class-map,来匹配第二步设置的ACL 4、设置一个policy-map匹配class-map,然后再在这里面定义一系列策略 5、将policy...
  • Cisco VoIP与QOS.rar

    2019-07-09 08:48:43
    IT业界巨人Cisco公司已经将VoIP业务定为在中国市场开展的三大主流业务之一...Cisco不同版本的IOS提供了多种途径来实现在IP骨干网上的QOS 如早期随即检测RED Random Early Detect 和加权早期随即检测WRED 定制队列CQ ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,237
精华内容 1,694
关键字:

思科路由器qos配置