精华内容
下载资源
问答
  • 思科ospf多区域配置
    千次阅读
    2021-09-16 19:19:35

    实验目的:配置OSPF多区域,使得不同网段的PC互相ping通。
    网络拓扑如下:
    在这里插入图片描述
    R0的配置
    Router>en
    Router#conf t
    Router(config)#int g0/1
    Router(config-if)#ip add 192.168.1.1 255.255.255.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#int g0/0
    Router(config-if)#ip add 192.168.2.1 255.255.255.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#router ospf 100
    Router(config-router)#router-id 1.1.1.1
    Router(config-router)#net 192.168.1.0 0.0.0.255 area 1
    Router(config-router)#net 192.168.2.0 0.0.0.255 area 0
    Router(config)#exit
    Router#show ip ospf neighbor
    Neighbor ID Pri State Dead Time Address Interface
    2.2.2.2 1

    更多相关内容
  • 思科路由器ospf多区域配置

    千次阅读 2022-04-26 22:37:18
    思科路由器ospf多区域配置

    PC0的IP设置:

    PC1同理

    router0配置

    Router>enable 
    Router#configure terminal 
    Router(config)#int f0/0
    Router(config-if)#ip address 192.168.2.0 255.255.255.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#int f1/0
    Router(config-if)#ip address 192.168.3.0 255.255.255.0
    Router(config-if)#no shut
    

    其他路由同理

    router0的ospf设置

    Router(config)#router ospf 10
    Router(config-router)#router-id  2.2.2.2
    Router(config-router)#network  192.168.2.0 0.0.0.255 area 1
    Router(config-router)#network  192.168.3.0 0.0.0.255 area 0

    特别注意:ospf的多区域的进程号必须一致否则一些区域的路由无法发送路由表到另外的区域的路由。

    查看路由表

     执行ping语句

     

    展开全文
  • OSPF多区域实验

    2018-05-31 10:18:24
    用三层交换机和路由器实现多区域OSPF配置详细过程,可以用锐捷、思科的设备,也可用模拟器实现
  • ospf多区域配置思科和中兴)

    千次阅读 2019-10-13 19:39:30
    掌握了OPSF动态路由协议的工作原理,以及OSPF区域划分的作用和原理,了解路由器中OSPF动态路由区域划分的基本配置方法和结果验证。 二、实验内容 完成中兴路由器OSPF动态路由区域划分的基本配置和结果验证 三、...

    *中兴
    一、实验目的
    掌握了OPSF动态路由协议的工作原理,以及OSPF区域划分的作用和原理,了解路由器中OSPF动态路由多区域划分的基本配置方法和结果验证。
    二、实验内容
    完成中兴路由器OSPF动态路由多区域划分的基本配置和结果验证
    三、实验流程
    (一)配置任务说明
    如图1-1所示,在路由器R1和路由器R2上运行OPSF,并将网络划分为三个区域,请完成OSPF 多区域的基本配置,实现是三个区域之间的互联互通。
    在这里插入图片描述
    图1-1
    (二)实验配置过程
    1、路由器R1的基本配置
    R1#configure terminal
    R1(config)#ip routing
    R1(config)#interface loopback1
    R1(config-if-loopback1)#ip address 1.1.1.1 255.255.255.255
    R1(config-if-loopback)#exit
    R1(config-if)#interface gei-2/1
    R1(config-if-gei-2/1)#ip address 171.37.1.254 255.255.255.0
    R1(config-if-gei-2/1)#no shutdown
    R1(config-if-gei-2/1)#exit
    R1(config-if)#interface gei-2/2
    R1(config-if-gei-2/2)#ip address 171.37.3.1 255.255.255.0
    R1(config-if-gei-2/2)#no shutdown
    R1(config-if-gei-2/2)#exit
    R1(config)#router ospf 1
    R1(config-ospf-1)#router-id 1.1.1.1
    R1(config-ospf-1)# area 23
    R1(config-ospf-1-area-23)#network 171.37.1.0 0.0.0.255
    R1(config-ospf-1)#area 0
    R1(config-ospf-1-area-0)#network 171.37.3.0 0.0.0.255
    R1(config-ospf-1-area-0)#network 1.1.1.1 0.0.0.0
    2、路由器R2的基本配置
    R2#configure terminal
    R2(config)#ip routing
    R2(config)#interface loopback1
    R2(config-if)#ip address 1.1.1.2 255.255.255.255
    R2(config-if)#exit
    R2(config)#interface gei-2/1
    R2(config-if-gei-2/1)#ip address 171.37.2.254 255.255.255.0
    R2(config-if-gei-2/1)#no shutdown
    R2(config-if-gei-2/1)#exit
    R2(config-if)#interface gei-2/2
    R2(config-if-gei-2/2)#ip address 171.37.3.2 255.255.255.0
    R2(config-if-gei-2/2)#no shutdown
    R2(config-if-gei-2/2)#exit
    R2(config)#router ospf 1
    R2(config-ospf-1)#router-id 1.1.1.2
    R2(config-ospf-l)#area 24
    R2(config-ospf-l-area-24)#network 171.37.2.0 0.0.0.255
    R2(config-ospf-l)#area 0
    R2(config-ospf-l-area-0)#network 171.37.3.0 0.0.0.255
    R2(config-ospf-l-area-0)#network 1.1.1.2 0.0.0.0
    四、查看和验证
    (一)实验结果查看
    R1:
    show ip forwwording route
    在这里插入图片描述
    在这里插入图片描述
    show ip ospf:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    R2:
    show ip ospf neighbor
    在这里插入图片描述
    show ip forwording route
    在这里插入图片描述

    show ip opsf :
    在这里插入图片描述
    在这里插入图片描述

    (二)实验结果验证
    在这里插入图片描述
    在这里插入图片描述
    思科
    一、实验目的
    掌握了OPSF动态路由协议的工作原理,以及OSPF区域划分的作用和原理,了解路由器中OSPF动态路由多区域划分的基本配置方法和结果验证。
    二、实验内容
    完成路由器OSPF动态路由多区域划分的基本配置和结果验证
    三、实验流程
    (一)配置任务说明
    如图1-1,所示,在路由器R1和路由器R2上运行OPSF,并将网络划分为三个区域,请完成OSPF 多区域的基本配置,实现是三个区域之间的互联互通
    在这里插入图片描述
    图1-1
    (二)实验配置过程
    1、路由器R1的基本配置
    R1#configure terminal
    R1(config)#ip routing
    R1(config)#interface loopback1
    R1(config-if)#ip address 1.1.1.1 255.255.255.255
    R1(config-if)#exit
    R1(config)#interface f0/0
    R1(config-if)#ip address 171.11.1.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#interface f1/0
    R1(config-if)#ip address 171.11.2.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#router ospf 10
    R1(config-router)#router-id 1.1.1.1
    R1(config-router)#network 171.11.1.0 0.0.0.255 area 1
    R1(config-router)#network 171.11.2.0 0.0.0.255 area 0
    R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
    2、路由器R2的基本配置
    R2#configure terminal
    R2(config)#ip routing
    R2(config)#interface loopback1
    R2(config-if)#ip address 1.1.1.2 255.255.255.255
    R2(config-if)#exit
    R2(config)#interface f0/0
    R2(config-if)#ip address 171.11.3.1 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#exit
    R2(config)#interface f1/0
    R2(config-if)#ip address 171.11.2.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#exit
    R2(config)#router ospf 10
    R2(config-router)#router-id 1.1.1.2
    R2(config-router)#network 171.11.3.0 0.0.0.255 area 2
    R2(config-router)#network 171.11.2.0 0.0.0.255 area 0
    R2(config-router)#network 1.1.1.2 0.0.0.0 area 0
    四、查看和验证
    (一)实验结果查看
    R1:
    在这里插入图片描述
    在这里插入图片描述

    R2:
    在这里插入图片描述
    在这里插入图片描述
    (二)实验结果验证
    在这里插入图片描述

    展开全文
  • 简单的来说:OSPF是一个分区域的路由协议,有一个核心的骨干区域area0,其他不是骨干区域必须和骨干区域直接相连。 如上图配置ip地址和环回地址 配置虚链路使得a2与a0跨区域通信: R3: area 1 virtual-link ...

    简单的来说:OSPF是一个分区域的路由协议,有一个核心的骨干区域area0,其他不是骨干区域必须和骨干区域直接相连。

     

    如上图配置ip地址和环回地址

    配置虚链路使得a2与a0跨区域通信:

    R3:

    area 1 virtual-link 5.5.5.5

    R5:

    area 1 virtual-link 3.3.3.3

    示例配置R1的ip地址和环回地址:

    Router(config)#interface loopback 0           //环回口要一样
    Router(config-if)#ip address 1.1.1.1 255.255.255.255
    Router(config-if)#no shutdown 
    Router(config-if)#ex
    
    Router(config)#interface GigabitEthernet0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#ex

    R1:

    Router(config)#router ospf 1    //进程号
    Router(config-router)#network 192.168.1.0 0.0.0.255 area 0     //宣告网段和区域
    Router(config-router)#network 1.1.1.1 0.0.0.0 area 0           //宣告回环网段
    Router(config-router)#router-id 1.1.1.1           //标识网络位置
    Router(config-router)#exit 

     R2:

    Router(config)#router ospf 1
    Router(config-router)#network 192.168.1.0 0.0.0.255 area 0    //宣告网段和区域
    Router(config-router)#network 192.168.2.0 0.0.0.255 area 0      //宣告网段和区域
    Router(config-router)#network 2.2.2.2 0.0.0.0 area 0        //宣告环回网段和区域
    Router(config-router)#router-id 2.2.2.2              
    Router(config-router)#exit 

    R3:

    Router(config)#router ospf 1
    Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
    Router(config-router)#network 192.168.3.0 0.0.0.255 area 1   //宣告3.0网段在1区域里
    Router(config-router)#network 3.3.3.3 0.0.0.0 area 0
    Router(config-router)#router-id 3.3.3.3
    Router(config-router)#area 1 virtual-link 5.5.5.5        //虚链路交界点
    Router(config-router)#exit 
    

    R4:

    R5: 

    
    Router(config)#router ospf 1
    Router(config-router)#network 192.168.4.0 0.0.0.255 area 1
    Router(config-router)#network 192.168.5.0 0.0.0.255 area 2
    Router(config-router)#network 5.5.5.5 0.0.0.0 area 1
    Router(config-router)#router-id 5.5.5.5
    Router(config-router)#area 1 virtual-link 3.3.3.3    //交界点做虚链路
    Router(config-router)#exit 

    R6:

    Router(config)#router ospf 1
    Router(config-router)#network 192.168.5.0 0.0.0.255 area 2
    Router(config-router)#network 6.6.6.6 0.0.0.0 area 2
    Router(config-router)#router-id 6.6.6.6
    Router(config-router)#ex

    查看邻居:show ip ospf neighbor     这边查看的R3:
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    2.2.2.2           1   FULL/BDR        00:00:38    192.168.2.1     GigabitEthernet0/0
    5.5.5.5           0   EXSTART/  -     00:00:38    192.168.4.2     OSPF_VL0
    4.4.4.4           1   FULL/DR         00:00:38    192.168.3.2     GigabitEthernet0/1

    展开全文
  • OSPF多区域配置实验

    2019-10-16 17:21:21
    OSPF多区域配置实验 多区域配置时,只需要在单区域基础上,申明各个网段都属于哪个区域。 R1配置过程: ip routing interface loopback1 ip address 1.1.1.1 255.255.255.255 exit interface fa1/0 ip address 173....
  • 本实验报告里有详细的华为和思科关于ospf多区域配置,还有抓包分析,有需要的话可以私信作者发源码
  • 思科模拟器配置多区域ospf

    千次阅读 2022-04-23 22:55:40
    注意:所有的区域都必须与骨干区域(area0)相连 (也可以使用虚连接让非骨干区域与骨干区域建立一条逻辑上的连接通道) 目的:R1 ping通 R4 R1: interface GigabitEthernet0/0 ip address 172.16.10.1 255....
  • //R1 conf t interface Loopback0 ip address 1.1.1.1 255.255.255.0 no shut interface FastEthernet0/0 ip address 11.1.1.1 255.255.255.0 no shut ...router ospf 1 network 11.1.1.0 0.0.0.2...
  • OSPF区域配置实验(Cisco

    万次阅读 2018-11-02 11:08:53
    OSPF区域配置实验(Cisco) (内容来自个人笔记,详细内容存储于有道云,查看请点击如下链接) 拓扑+操作截图 详细内容链接:http://note.youdao.com/noteshare?id=47d696156a5210275e378505854a74bf OSPF区域...
  • OSPF多区域配置

    千次阅读 2021-12-14 14:25:55
    为了适应大型的网络,OSPF在AS内划分区域 每个OSPF路由器只维护所在区域的完整链路状态信息(LSA) 区域ID 区域ID可表示成一个十进制数的数字(思科区域IP可以表示成十进制数字,也可以表示成IP) 也可以表示...
  • ospf多区域配置练习

    2022-05-26 10:16:00
    1. 首先按照编址表配置ip地址 创建三个环回接口模拟三个路由器的下挂网段 2. 分别在r7,r8,r9创建area 0,并对其直连网段进行通告;再分别在r9,r10创建area 1,并对其直连网段进行通告。 因为r9是一台ABR所以...
  • 思科OSPF区域配置

    2017-10-27 10:16:53
    实验拓扑图R1路由器的配置R1# R1#conf tEnter configuration commands, one per line. End with CNTL/Z.R1(config)#int e0/0R1(config-if)#ip address 192.168.20.1 255.255.255.0R1(config-if)#no shR1(config...
  • 实验6 OSPF区域配置

    2022-05-24 19:59:47
    掌握OSPF配置方法 掌握通过display命令查看OSPF运行状态的方法 实验环境 Windows 10 eNSP 实验内容(步骤、方法、算法、程序) 【实验拓扑】 ...
  • 区域多区域OSPF协议配置,OSPFV2和OSPFV3,DR和BDR的选举关系。包含了详细配置,详细文档和每一部分的pkt文档(4个pkt文档和一个word文档)。(用于学习的很好资源)
  • 3、掌握OSPF Stub区域配置方法。 4、掌握OSPF Stub区域配置要求: Stub区域没有ASBR,它至少拥有一个ABR。 实验拓扑: 步骤1:接口配置 R1(config)#interface f0/0 R1(config-if)#ip address 12.12.12.1 255....
  • 通过配置ospf路由协议,实现多区域之间主机的通信。 三 实验环境 GNS3,Windows10操作系统,SecureCRT8.0 四 实验过程 1.对路由器R1,R2,R3,R4进行接口ip配置: R1: conf t int f0/0 ip add 192.168.2.1 255.255....
  • 思科单区OSPF配置

    2021-06-03 09:44:59
    使用ospf动态路由协议,实现全网互通 实验拓扑: 配置清单: R1 interface Loopback0 ip address 131.108.4.1 255.255.255.128 interface Loopback1 ip address 131.108.4.129 255.255.255.128 interface ...
  • 配置OSPF区域

    千次阅读 2022-04-17 18:05:21
    1、OSPF协议简介 OSPF是Open Shortest Path First(即“开放最短路由优先协议”)的缩写。它是IETF(Internet Engineering Task Force)组织开发的一个基于链路状态的自制系统内部路由协议(IGP),用于在单一自治...
  • 配置OSPF多区域

    千次阅读 2022-05-05 18:31:05
    目录 一、相关知识 1、基本配置命令 2、OSPF为什么是无自环的? 3、何时需要运行OSPF协议 ...三、配置命令 ...1、ZY-R-A路由配置命令 ...2、ZY-R-B路由配置命令 ...3、ZY-R-C路由配置命令 ...配置OSPF区域:[Quidway-ospf-1]a
  • OSPF是一种常用的动态路由... OSPF可适应各种大规模网络,可支持区域划分,可基于带宽来选择最佳路由,无路由自环等优点。 OSPF划分区域的好处是减少LSA的数量和屏蔽了网络变化波及的范围。 OSPF路由协议是一种...
  • 计算机网络 OSPF区域DHCP配置实验
  • 还发现了该末梢区域之外的区域的信息条目,因为路由器1会把左边链路...2、按图配置IP地址,链路左边的接口都配置为1,链路右边的接口都配置为2。我们再次打开路由器3的接口,等一会儿路由器5的负载路由又回来了。......
  • 实训三十七 路由器 OSPF 末梢区域配置 一、实验目的 1.掌握 OSPF 末梢区域和完全末梢区域配置 2.理解 OSPF 末梢区域和完全末梢区域的意义 二、应用环境 在大规模网络中,我们通常划分区域减少资源消耗...
  • OSPF多区域配置实验(思科配置脚本)一、实验目的二、实验内容三、实验流程四、查看和验证 一、实验目的 掌握路由器中ospf动态路由区域划分的基本配置方法和验证结果; 进一步理解网络配置的基本原理; 二、实验...
  • OSPF区域配置实验

    2021-04-20 15:51:16
    OSPF区域配置实验 一、实验目的   1、掌握OSPF动态路由单区域的基本配置方法和结果验证。 二、实验内容   1、完成中兴1800路由器OSPF动态路由单区域的基本配置和结果验证。 三、实验过程 1、实验任务说明   ...
  • OSPF特殊区域NSSA配置实验一、实验目的二、实验内容三、实验...完成思科路由器OSPF特殊区域NSSA区域的基本配置和结果验证; 三、实验流程 (一)配置任务说明 如下图所示:区域0是骨干域,将区域1设置为nssa区域,完成
  • 0基础学RS(二十五)思科OSPF配置

    千次阅读 2022-05-08 11:42:50
    一、单区域OSPF配置 二、多区域OSPF配置 三、OSPF连接外部网络的配置 四、OSPF虚链路 五、OSPF下发默认路由 六、OSPF路由汇总 七、OSPF认证 八、OSPF特殊区域 STUB NSSA
  • 路由器多区域 OSPF 配置

    千次阅读 2021-10-08 03:52:24
    路由器多区域 OSPF 配置 实训三十四 路由器多区域 OSPF 配置 定义:OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法的内部网关协议(IGP),在单一自治系统(AS)内部工作。...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,025
精华内容 2,410
关键字:

思科ospf多区域配置