精华内容
下载资源
问答
  • 2018-09-28 21:44:00

    "流量监管" (Traffic Policing) 就是对流量进行控制,通过监督进入交换机端口的流量速率,对超出部分的流量进行"惩罚" (采用监管方式时是直接丢弃),使进入端口的流量被限制在一个合理的范围之内。例如可以限制HTTP报文不能占用超过50%的网络带宽,否则QoS流量监管功能可以选择丢弃报文,或重新配置报文的优先级。

    "流量整形"为控制最大输出通信速率提供可能,以确保通信符合配置的最大传输速率规定。符合某种配置的通信可能被整形,以使它符合下游设备的通信速率需求,处理任何失配的数据传输速率。流量整形通常使用缓冲区和令牌桶来完成,当报文的发送速率过快时,首先在缓冲区进行缓存,在令牌桶的控制下再均匀地发送这些被缓冲的报文。当下游设备的接口速率小于上游设备的端口速率或发生突发流量时,在下游设备入端口处可能出现流量拥塞的情况。此时用户可以通过在下游设备的出端口配置流量整形将上游不规整的流量进行削峰填谷,输出一条比较平整的流量,从而解决下游设备的拥塞问题。流量整形是一种可应用于接口、子接口或队列的流量控制技术,可以对从接口上经过的所有报文或某类报文进行速率限制

    流量整形和流量监管都是作用于网络边缘,对进入设备端口的流量进行的一种处理方式。它们的主要区别在于:流量监管直接丢弃不符合速率要求的报文,丢弃的报文比较多,可能引发重传;而流量整形是将不符合速率要求的报文先行缓存,当令牌桶有足够的令牌时再均匀地向外发送这些被缓存的报文,较少丢弃报文,但引入时延和抖动,需要较多的缓冲资源缓存报文 。所以这两种功能的应用领域也不尽相同,流量监管适用于对丢弃率不敏感,而对时延和抖动比较敏感的网络应用,如一些普通的话音和视频通信;流量整形适用于对时延和抖动不敏感的网络应用,如数据传输、 www 访问等 。

    转载于:https://www.cnblogs.com/ricksteves/p/9721116.html

    更多相关内容
  • 流量监管和流量整形

    万次阅读 多人点赞 2018-05-27 08:36:10
    流量监管和流量整形概述 流量监管和流量整形通过监督进入网络的流量速率,用来限制流量及其资源的使用,保证更好的为用户提供服务。 如果报文的发送速率大于接收速率,或者下游设备的接口速率小于上游设备的接口...

    流量监管和流量整形概述

    流量监管和流量整形通过监督进入网络的流量速率,用来限制流量及其资源的使用,保证更好的为用户提供服务。

    如果报文的发送速率大于接收速率,或者下游设备的接口速率小于上游设备的接口速率,就会引起网络拥塞。如果不限制用户发送的业务流量,大量用户不断突发的业务数据会使网络更加拥挤。为了使有限的网络资源能够更好地发挥效用,更好地为更多的用户服务,必须对用户的业务流量加以限制。

    流量监管和流量整形就是一种通过对流量规格的监督,来限制流量及其资源使用的流控策略。

    流量监管:

    流量监管TP(Traffic Policing)就是对流量进行控制,通过监督进入网络的流量速率,对超出部分的流量进行“惩罚”,使进入的流量被限制在一个合理的范围之内,从而保护网络资源和用户的利益。

    流量整形:

    流量整形TS(Traffic Shaping)是一种主动调整流量输出速率的措施。当下游设备的入接口速率小于上游设备的出接口速率或发生突发流量时,下游设备入接口处可能出现流量拥塞的情况,此时用户可以通过在上游设备的接口出方向配置流量整形,将上游不规整的流量进行削峰填谷,输出一条比较平整的流量,从而解决下游设备的拥塞问题。

    流量整形与流量监管的主要区别在于,流量整形对原本要被丢弃的报文进行缓存,当令牌桶有足够的令牌时,再均匀的向外发送这些被缓存的报文。流量整形与流量监管的另一区别是,整形可能会增加延迟,而监管几乎不引入额外的延迟。

    监管和整形的区别:

    1. 应用方式:

      监管可以同时应用在接口的出入方向。

      整形值能用在接口的出方向。

    2. 监管可以实现报文的重标记。

      整形不支持报文的重标记。

    3. 监管针对超出的流量采用直接丢弃的方式。

      整形针对超出的流量不直接丢弃,而是放入缓存(shaping queue(默认使用WFQ队列机制))中并等待后续发送,如果缓存占满后执行Tail-Drop,丢弃方式可以更改为wred.

    4. 监管比较适合用于对延时要求较高的业务,例如:语音。但是会带来数据的重传。

      整形比较适合用于对可靠性要求较高的业务,但是不适合对延时要求较高的业务,因为缓存的数据会造成延时的增大。

    5. 流量监管:Car(Committed Access Rate)约定访问速度、CB policing、Line rate

      流量整形:GenericTraffic Shaping(通用流量整形,简称GTS、FRTS、DTS、CB Shapping、物理接口总速率限制,简称LR

    令牌桶技术

    令牌桶可以看作是一个存放一定数量令牌的容器。系统按设定的速度向桶中放置令牌,当桶中令牌满时,多出的令牌溢出,桶中令牌不再增加。

    在使用令牌桶对流量进行评估时,是以令牌桶中的令牌数量是否足够满足报文的转发为依据的。如果桶中存在足够的令牌可以用来转发报文,称流量遵守或符合约定值,否则称为流量超标或不符合约定值。

    关于令牌桶处理报文的方式,RFC中定义了两种标记算法:

    • 单速率三色标记(single rate three color marker,srTCM,或称为单速双桶算法)算法,主要关注报文尺寸的突发。
    • 双速率三色标记(two rate three color marker,trTCM,或称为双速双桶算法)算法,主要关注报文速率的突发。

    两种算法的评估结果都是为报文打上红、黄、绿三种颜色的标记,所以称为“三色标记”。QoS会根据报文的颜色做相应的处理,两种算法都可以工作于色盲模式和色敏模式下。以下以色盲模式为例对标记算法进行详细介绍。

    单速双桶:

    单速双桶采用RFC2697的单速三色标记器srTCM(A Single Rate Three Color Marker)算法对流量进行测评,根据评估结果为报文打颜色标记,即绿色、黄色和红色。

    这里写图片描述

    图:单速双桶示意图

    如上图所示:为方便描述将两个令牌桶称为C桶和E桶,用Tc和Te表示桶中的令牌数量。单速双桶有3个参数:

    • CIR(Committed Information Rate):承诺信息速率,表示向C桶中投放令牌的速率,即C桶允许传输或转发报文的平均速率;
    • CBS(Committed Burst Size):承诺突发尺寸,表示C桶的容量,即C桶瞬间能够通过的承诺突发流量;
    • EBS(Excess Burst Size):超额突发尺寸,表示E桶的容量,即E桶瞬间能够通过的超出突发流量。

    系统按照CIR速率向桶中投放令牌:

    • 若Tc<CBS,Tc增加;
    • 若Tc=CBS,Te<EBS,Te增加;
    • 若Tc=CBS,Te=EBS,则都不增加。

    对于到达的报文,用B表示报文的大小:

    • 若B≤Tc,报文被标记为绿色,且Tc减少B;
    • 若Tc<B≤Te,报文被标记为黄色,且Te减少B;
    • 若Tc<B并且Te<B,报文被标记为红色,且Tc和Te都不减少。

    双速双桶:

    双速双桶采用RFC2698的双速三色标记器trTCM(A Two Rate Three Color Marker)算法对流量进行测评,根据评估结果为报文打颜色标记,即绿色、黄色和红色。

    这里写图片描述

    图:双速双桶示意图

    如上图所示,为方便描述将两个令牌桶称为P桶和C桶,用Tp和Tc表示桶中的令牌数量。双速双桶有4个参数:

    • PIR(Peak information rate):峰值信息速率,表示向P桶中投放令牌的速率,即P桶允许传输或转发报文的峰值速率,PIR大于CIR;
    • CIR:承诺信息速率,表示向C桶中投放令牌的速率,即C桶允许传输或转发报文的平均速率;
    • PBS(Peak Burst Size):峰值突发尺寸,表示P桶的容量,即P桶瞬间能够通过的峰值突发流量;
    • CBS:承诺突发尺寸,表示C桶的容量,即C桶瞬间能够通过的承诺突发流量。

    系统按照PIR速率向P桶中投放令牌,按照CIR速率向C桶中投放令牌:

    • 当Tp<PBS时,P桶中令牌数增加,否则不增加。
    • 当Tc<CBS时,C桶中令牌数增加,否则不增加。

    对于到达的报文,用B表示报文的大小:

    • 若Tp<B,报文被标记为红色;
    • 若Tc<B≤Tp,报文被标记为黄色,且Tp减少B;
    • 若B≤Tp并且B≤Tc,报文被标记为绿色,且Tp和Tc都减少B。

    色敏模式:

    色敏模式下,如果到达的报文本身已经被标记为红、黄、或者绿等颜色,令牌桶对流量的评估会参考报文已标记颜色,即报文本身已携带颜色会影响令牌桶的评估结果,评估机制简单的来说遵循以下原则:

    • 如果报文已被标记为绿色,则令牌桶的评估机制与色盲模式保持一致。
    • 如果报文已被标记为黄色,则令牌桶根据报文长度和令牌数的大小,为符合流量规定的报文标记为黄色,为不符合的报文标记为红色。
    • 如果报文已被标记为红色,则令牌桶直接将到达报文标记为红色。

    流量监管

    流量监管就是对流量进行控制,通过监督进入网络的流量速率,对超出部分的流量进行“惩罚”,使进入的流量被限制在一个合理的范围之内,从而保护网络资源和企业网用户的利益。

    流量监管的原理:

    这里写图片描述

    图:流量监管组件图

    流量监管由三部分组成:

    • Meter:通过令牌桶机制对网络流量进行度量,向Marker输出度量结果。

    • Marker:根据Meter的度量结果对报文进行染色,报文会被染成green、yellow、red三种颜色。

    • Action:根据Marker对报文的染色结果,对报文进行一些动作,动作包括:

      • pass:对测量结果为“符合”的报文继续转发。
      • remark + pass:修改报文内部优先级后再转发。
      • discard:对测量结果为“不符合”的报文进行丢弃。

      默认情况下,green报文、yellow报文进行转发,red报文丢弃。

    经过流量监管,如果某流量速率超过标准,设备可以选择降低报文优先级再进行转发或者直接丢弃。默认情况下,此类报文被丢弃。

    流量整形

    流量整形是一种主动调整流量输出速率的措施,其作用是限制流量与突发,使这类报文以比较均匀的速率向外发送。流量整形通常使用缓冲区和令牌桶来完成,当报文的发送速度过快时,首先在缓冲区进行缓存,在令牌桶的控制下,再均匀地发送这些被缓冲的报文。

    当下游设备的接口速率小于上游设备的接口速率或发生突发流量,在下游设备接口处可能出现流量拥塞的情况,此时用户可以通过在上游设备的接口出方向配置流量整形,将上游不规整的流量进行削峰填谷,输出一条比较平整的流量,从而解决下游设备的拥塞问题。

    处理流程:

    流量整形是一种应用于接口、子接口或队列的流量控制技术,可以对从接口上经过的所有报文或某类报文进行速率限制。

    下面以接口或子接口下采用单速单桶技术的基于流的队列整形为例介绍流量整形的处理流程,其处理流程如下图所示:

    这里写图片描述

    图:流量整形处理流程

    具体处理流程如下:

    1. 当报文到来的时候,首先对报文进行分类,使报文进入不同的队列。
    2. 若报文进入的队列没有配置队列整形功能,则直接发送该队列的报文;否则,进入下一步处理。
    3. 按用户设定的队列整形速率向令牌桶中放置令牌:
      • 如果令牌桶中有足够的令牌可以用来发送报文,则报文直接被发送,在报文被发送的同时,令牌做相应的减少。
      • 如果令牌桶中没有足够的令牌,则将报文放入缓存队列,如果报文放入缓存队列时,缓存队列已满,则丢弃报文。
    4. 缓存队列中有报文的时候,系统按一定的周期从缓存队列中取出报文进行发送,每次发送都会与令牌桶中的令牌数作比较,直到令牌桶中的令牌数减少到缓存队列中的报文不能再发送或缓存队列中的报文全部发送完毕为止。

    队列整形后,如果该接口和子接口同时配置了接口整形,则系统还要逐级按照子接口整形速率、接口整形速率对报文流进行速率控制。其处理流程与队列整形相似,但不需要步骤1和步骤2.

    自适应流量整形:

    流量整形主要是为了解决下游设备的接口速率小于上游设备的接口速率,从而导致下游设备接口入方向丢包的问题。但有些场景下,下游设备的接口速率是不确定的,上游设备无法确定应该把整形参数设置为多少。此时可以配置自适应模板来实现自适应流量整形,通过在上游设备和下游设备间开启NQA检测,根据NQA检测到的下游设备丢包率动态调整整形参数。

    自适应模板规定了:

    • NQA测试例:通过此测试例检测下游设备接口入方向丢包率,根据检测结果调整整形参数。
    • 整形速率范围:上游设备接口出方向的整形速率上下限,整形速率在此范围内动态调整。
    • 整形速率调整步长:动态调整整形速率时,每次调整的速率大小。
    • 丢包率范围:下游设备接口入方向允许的丢包率范围。当丢包率在此范围之内时,不调整整形速率;当丢包率过大,减小上游设备整形速率;当丢包率过小,且上游设备发生拥塞,增大上游设备整形速率。
    • 整形速率增大的时间间隔:当丢包率在阈值附近频繁变化时,就需要频繁调整整形速率,用户可以通过设置此参数,限制增大整形速率的时间间隔,避免频繁更新。

    系统根据NQA检测结果中的丢包率等调整整形速率:

    触发条件(必须同时满足所有条件)动作
    NQA检测到丢包率大于自适应模板配置的丢包率上限减小整形速率
    NQA检测到丢包率小于自适应模板配置的丢包率下限。 上游发送端接口拥塞。 距离上次增大整形速率的时间间隔超过自适应模板配置的速率增大时间间隔增大整形速率
    NQA检测到丢包率小于自适应模板配置的丢包率下限上游发送端接口不拥塞保持当前整形速率
    丢包率在自适应模板配置的丢包率范围内保持当前整形速率
    检测失败自适应模板配置的整形速率上限

    流量整形与流量监管配置

    ##常用命令行:

    bandwidth
    //配置基于MQC实现流量监管的承诺信息速率占接口带宽的百分比基值。
    car
    //在流行为中创建流量监管动作。
    /*
      cir:承诺信息速率,即保证能够通过的平均速率。
      pct:指定承诺信息速率占接口带宽的百分比。
      pir:峰值信息速率,即能够通过的最大速率。
      share:指定对流做共享CAR,使绑定了同一流行为的流分
    类中的所有的规则共享CAR参数。
      cbs:指定承诺突发尺寸,即瞬间能够通过的承诺突发流量。
      pbs:指定峰值突发尺寸,即瞬间能够通过的峰值突发流量。
      mode:HQoS的父策略行为,指定流量监管采取的颜色模
    式,如果不是HQoS的父策略行为,指定该参数无效。
      color-blind:指定色盲模式。这种模式下,子策略行为
    对报文的着色不影响本次流量监管的动作。
      color-aware:指定色敏模式。这种模式下,本次流量监
    管动作考虑子策略行为对报文的着色。
    */
    display qos adaptation-profile
    //查看已配置的自适应模板信息。
    gts
    //流行为中创建流量整形动作。
    gts adaptation-profile
    //在流行为中绑定自适应模板。
    port-schedule high
    //配置接口的优先级为高。
    qos adaptation-profile
    //创建自适应模板,并进入自适应模板视图。
    qos car
    //配置流量监管。
    qos gts
    //对接口配置流量整形。
    qos gts adaptation-profile
    //在接口下应用自适应模板。
    qos lr
    //配置物理接口发送报文的速率占接口带宽的百分比。
    qos overhead layer { link | physics }
    //配置在流量监管或流量整形时报文长度的计算方式。
    /*
      layer:指定流量监管或流量整形计算报文长度时是否包括
    报文的物理层或链路层补偿信息。
       link:指定流量监管或流量整形计算报文长度时仅包括报
    文的链路层补偿信息。
       physics:指定流量监管或流量整形计算报文长度时包括
    报文的物理层和链路层的补偿信息。此为缺省配置。
    */
    queue gts
    //配置各队列的流量整形。
    qos-profile
    //创建QoS模板并进入QoS模板视图,
    rate-adjust increase interval
    //配置自适应模板中整形速率增大的时间间隔。
    //缺省情况下,整形速率增大的时间间隔为30秒。
    rate-adjust loss
    //配置自适应模板的丢包率范围。
    //缺省情况下,丢包率范围为10%~20%
    rate-adjust step
    //配置自适应模板的整形速率调整步长。
    //缺省情况下,整形速率调整步长为64kbit/s。
    rate-range
    //配置自适应模板的整形速率范围。
    track nqa
    //为自适应模板绑定NQA测试例。
    

    流量监管和流量整形配置示例:

    实验拓扑如下:

    这里写图片描述

    图:流量监管和流量整形配置实验拓扑

    实验要求:

    如上图:VLAN10属于数据业务,VLAN20为语音业务,VLAN30为视频业务。在AR1上配置流量监管和流量整形,完成对不同的业务有不同的要求。

    配置文件:

    AR1:

    <AR1>dis cur
    #
     sysname AR1
    #
    vlan batch 10 20 30
    #
    acl number 2000  
     rule 5 permit source 192.168.0.0 0.0.255.255
      //用来匹配内网网段,做easy IP。
    #
    qos queue-profile qp
      //基于队列的流量整形
      queue 2 gts cir 2000 cbs 50000
      queue 5 gts cir 4000 cbs 10000
      queue 6 gts cir 256 cbs 6400
      schedule wfq 0 to 5 pq 6 to 7
    #
    //流分类,匹配vlan-id
    traffic classifier video operator or
     if-match vlan-id 30
    traffic classifier date operator or
     if-match vlan-id 10
    traffic classifier voice operator or
     if-match vlan-id 20
    #
    //流行为,对于流量监管,配置合理的速率。
    //对于流量整形,对于匹配到的流标记规定的802.1q优先级
    traffic behavior video
     car cir 4000 cbs 752000 pbs 1252000 green pass yellow pass red discard
     statistic enable
     //使能接口的流量统计功能。
     remark 8021p 5
    //标记优先级为5
    traffic behavior date
     car cir 2000 cbs 376000 pbs 626000 green pass yellow pass red discard
     statistic enable
     remark 8021p 2
    traffic behavior voice
     car cir 256 cbs 48128 pbs 80128 green pass yellow pass red discard
     statistic enable
     remark 8021p 6
    #
     //流策略,绑定对应的流分类与流行为
    traffic policy video
     classifier video behavior video
    traffic policy date
     classifier date behavior date
    traffic policy voice
     classifier voice behavior voice
    #
    interface GigabitEthernet0/0/0
     ip address 12.1.1.1 255.255.255.0 
     qos queue-profile qp
     //在接口应用队列模板
     qos gts cir 8000 cbs 200000
      //将端口速率限制在8000kbit/s.
     nat outbound 2000
      //做nat,easy ip
    #
    interface GigabitEthernet0/0/1
     trust 8021p
     //接口信任802.1q优先级
     qos car inbound cir 10000 cbs 1880000 pbs 
     3130000 green pass yellow pass red discard
     //配置入口的速率限制在10000kbit/s.
    #
    interface GigabitEthernet0/0/1.10
     dot1q termination vid 10
       //配置子接口Dot1q终结的单层VLAN ID。
     ip address 192.168.10.254 255.255.255.0 
     traffic-policy date inbound
     //应用流策略
     arp broadcast enable
     //使能终结子接口的ARP广播功能。
    #
    interface GigabitEthernet0/0/1.20
     dot1q termination vid 20
     ip address 192.168.20.254 255.255.255.0 
     traffic-policy voice inbound
     arp broadcast enable
    #
    interface GigabitEthernet0/0/1.30
     dot1q termination vid 30
     ip address 192.168.30.254 255.255.255.0 
     traffic-policy video inbound
     arp broadcast enable
    #
    ip route-static 0.0.0.0 0.0.0.0 12.1.1.2
       //出外网的默认路由
    #
    return
    

    AR2:

    [AR2]dis current-configuration 
    #
     sysname AR2
    #
    interface GigabitEthernet0/0/0
     ip address 12.1.1.2 255.255.255.0 
    #
    return
    

    SW:

    <SW>dis current-configuration 
    #
    sysname SW
    #
    vlan batch 10 20 30
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 30
    #
    return
    

    配置结果:


    这里写图片描述

    图:流策略应用记录

    这里写图片描述

    图:流策略状态

    这里写图片描述

    图:队列模板情况

    这里写图片描述

    图:接口应用队列模板情况统计


    参考文档:华为HedEx文档


    展开全文
  • 今天给大家介绍QoS中的两个重要概念——流量监管和流量整形。阅读本文,您需要有一定的QoS的基础,如果您对此还存在疑惑,欢迎查阅我博客的其他文章,相信您一定会有收获。 相关文章链接: 浅谈QoS——QoS概述、QoS...

    今天给大家介绍QoS中的两个重要概念——流量监管和流量整形。阅读本文,您需要有一定的QoS的基础,如果您对此还存在疑惑,欢迎查阅我博客的其他文章,相信您一定会有收获。
    相关文章链接:
    浅谈QoS——QoS概述QoS基本原理网络层QoS分类和标记字段详解QoS中队列简介QoS队列调度技术详解QoS队列调度技术详解QoS中拥塞避免机制详解——WRED技术详解华为QoS中CBQ队列详解

    一、概述

    在计算机网路中,拥塞现象非常常见,如果不限制用户发送的业务流量,大量用户不断突发的业务数据就会使网络更加拥挤。为了使有限的网络资源能够更好的发挥效用(也为了各大ISP可以更好的赚钱),必须对用户的流量加以限制。
    流量监管和流量整形就是一类通过对流量加以监督来限制流量及其资源使用的流控技术。

    二、流量监管

    流量监管,其实可以通俗的理解为对流量进行限速,当某一类型的流量超过配置的额定阈值后,就会丢弃该流量的部分数据包。
    为了减少流量负载,流量监管通常在靠近源的地方配置。通常在企业出口路由器的内网测接口配置流量监管,限制总流量的同时保证各类流量的最低带宽。
    流量监管后,流量示意图如下:
    在这里插入图片描述
    从图中可以看出,流量监管的作用就是**“削峰”**。
    流量监管的优点就是可以实现流量限速,由于实现方式简单,因此对网络设备压力较小,其缺点是采用了直接丢包的方式,手段简单粗暴,同时造成了链路带宽浪费等问题,丢弃的流量可能要进行重传,也带来了很高的丢包率。

    三、流量整形

    相比流量监管,流量整形则采用了更为“温和”的手段。流量整形引入了缓存机制,对超过阈值的数据包进行缓存,使得突发流量减小。同时在流量速率降低后,会将缓存中的流量发送出去,起到了“削峰填谷”的作用。
    流量整形示意图如下所示:
    在这里插入图片描述
    流量整形的优点是减少了带宽浪费和高丢包率。缺点是可能会增加时延,此外,由于引入了缓存机制,因此加重了网络设备的处理负担,无形中降低了网络设备转发效率。
    流量整形一般用于多个分支发往总部的出接口方向上,以实现到达总部的流量比较平稳。

    四、比较

    流量监管和流量整形两者都是为应对网络拥塞而采取的流控措施,而在具体的实施和应用中,必须要根据业务特点谨慎的选择流控方式。流量监管和流量整形的优缺点、应用场景已经在上文中阐明,在这里就不过多赘述了。此外,流量整形只能够用在接口出方向上,而流量监管既可以用在接口出方向上,也可以用在接口入方向上。
    原创不易,转载请说明出处:https://blog.csdn.net/weixin_40228200/article/details/118889488

    展开全文
  • 流量监管TP(Traffic Policing)是指对进入设备的流量进行监控,确保其没有滥用网络 资源。通过监控进入网络的某一流量的规格,限制它在一个允许的范围之内,若某个 连接的报文流量过大,就丢弃报文,或重新设置该...
  • 流量监管TP(Traffic Policing)是指对进入设备的流量进行监控,确保其没有滥用网络资源。通过监控进入网络的某一流量的规格,限制它在一个允许的范围之内,若某个连接的报文流量过大,就丢弃报文,或重新设置该报文...
  • 流量监管TP(Traffic Policing)是指对进入设备的流量进行监控,确保其没有滥用网络 资源。通过监控进入网络的某一流量的规格,限制它在一个允许的范围之内,若某个 连接的报文流量过大,就丢弃报文,或重新设置该...
  • 介绍流量监管流量整形的基本概念、实现原理。 1 流量监管 2 配置基于接口的流量监管 3 配置基于复杂流分类的流量监管 4 配置流量整形 5 维护流量监管流量整形
  • 尽管流量监管和流量整形都能实现流量限速,但二者存在一定的差别: 流量监管:如果流量超速,则直接丢弃超出部分的流量。一般用于入方向,就像高速路,只有在入口限制进入高速公路车辆的数量。 流量整形:如果...

    本文介绍交换机的流量监管、流量整形和接口限速的原理,并且介绍相关参数和配置方法。
     

    01

         相关名词解释

    表1-1 简称及对应的全称

    流量监管、流量整形和接口限速是通过对流量规格进行监督,以限制流量及其资源使用的流控策略。

    尽管流量监管和流量整形都能实现流量限速,但二者存在一定的差别:

    流量监管:如果流量超速,则直接丢弃超出部分的流量。一般用于入方向,就像高速路,只有在入口限制进入高速公路车辆的数量。

    流量整形:如果流量超速,则暂时存入缓存队列,等到令牌数足够时,再均匀地发送这些被缓冲的报文。如果报文放入缓存队列时,缓存队列已满,则丢弃报文。这样使流量输出比较平稳,从而解决下游设备的拥塞问题,所以流量整形一般用于出方向。

    接口限速即限制一个接口上发送或者接收全部报文的总速率。当不需要区分报文类型而要限制通过接口全部流量速率时,可以选择配置简单的接口限速。入方向的接口限速是流量监管的一种特殊情况,即不需要分类报文的流量监管是接口限速;出方向的接口限速是流量整形的一种特殊情况,即针对所有队列的流量整形是接口限速。
     

    02

       限速的有关参数

    交换机通过令牌桶判断流量是否超速。令牌桶可以看作是一个存放一定数量令牌的容器。系统按设定的速度向桶中放置令牌,当桶中令牌满时,多出的令牌溢出,桶中令牌不再增加。每个需要被转发的报文,都要从令牌桶中领取一定数量的令牌(具体数量视报文大小而定),才可以被正常转发。如果桶中存在足够的令牌可以用来转发报文,称流量遵守或符合约定值,否则称为不符合或超标。

    令牌桶有三种测速方法,对应单速单桶、单速双桶、双速双桶三种机制:

    单速单桶:以CIR速率向C桶投放令牌。

    报文来了之后,从C桶取令牌,如果令牌够了,则进行转发,如果令牌不够,则直接丢弃。一般用于优先级较低的业务(如企业外网HTTP流量)限速,对于超过额度的流量直接丢弃保证其他业务,不考虑突发流量。

    单速双桶:以CIR速率向两个桶投放令牌。

    先投放小桶C桶,小桶满了再投放大桶E桶。报文来了之后,先使用小桶中的令牌,小桶中令牌数量不够,则放回去,再使用大桶中的令牌。对于超过C桶,而又没有超过E桶的报文标记为黄色,采用BE方式或者等网络空闲后进行转发。和单桶相比,单速双桶允许突发流量,主要用于较为重要而又不太紧急的业务,比如企业邮件数据,可避免邮件发送失败。

    双速双桶:以CIR速率向C桶投放令牌,以PIR速率向P桶投放令牌。

    报文进来之后,会同时取两个桶的令牌,C桶令牌够用则标记为绿色直接转发,如果连P桶的令牌都不够用,则标记为红色直接丢弃,介于C桶和P桶之间,则标记为黄色。和单速双桶的区别就是向两个桶投放令牌的速率不同,我们一般设置PIR>CIR,P桶投放令牌的速率更快,所以更能长时间撑住突发流量。

    使用令牌桶的总体原则:

    如果不考虑突发流量,使用单速单桶;如果要考虑突发流量,使用单速双桶;如果考虑可能会有长时间的流量突发,使用双速双桶。在令牌桶算法中,CIR的值越大,即令牌产生的速率越大,报文可以获取的令牌就越多,流向网络的流量也就越大。因此,CIR的值是控制流入网络中流量多少的关键。CBS也是一个重要参数,CBS的值越大,C桶中可以积累令牌的数目也越多,允许通过的报文尺寸就越大。
     

    由于设备进行的是逐包转发,CBS的值不应该小于当前网络上允许传输的报文的最大长度。

    例如,在单速单桶模式下,假设要把流量限定在10Mbit/s,而CBS值太小(如设置成1000byte)。如果某个时间段内流量的报文,每个报文大小都大于1000byte,那么这些报文全都被丢弃。这段时间内,没有报文被转发,报文的转发速率为0,导致网络资源被浪费,业务也出现异常。

    那是不是CBS的值越大就越好呢?显然不是。

    CBS值太大,会失去限速的意义。例如,假设要把流量限定在10Mbit/s,CBS设置成7200Mbyte。某个时刻,令牌桶中的令牌已满,如果接下来1小时内流量的报文,其报文长度不一,但共计7200Mbyte,这些报文都能获得令牌并被转发,那么这段时间内的报文速率为16Mbit/s(7200M * 8 / 3600)而不是10Mbit/s,即没有实现限速。

    同理,对于双速双桶模式,PIR和PBS的值也应设置在合理范围内。

    03

    配置基于MQC的流量监管

    配置基于MQC的流量监管包括以下四个主要步骤:

    1. 配置流分类。通过定义流分类中的匹配规则,使需要限速的流量归入此类。

    2. 配置流行为。创建并进入流行为视图后,配置CAR动作。

    3. 配置流策略。创建并进入流策略视图后,将流分类与流行为绑定。

    4. 应用流策略。将流策略应用到相应的接口、VLAN或全局视图。

    以下示例中,限制所有进入接口GE1/0/1流量的速率。在流行为b1中配置流量监管动作:承诺信息速率(保证能够通过的平均速率)为200000kbit/s,峰值信息速率(最大能够通过的速率)为2500000kbit/s,允许绿色报文正常发送,允许黄色报文通过,丢弃红色报文。

    <HUAWEI> system-view 
    [HUAWEI] traffic classifier c1 operator and   //创建流分类c1,并进入流分类视图
    [HUAWEI-classifier-c1] if-match any           //流分类c1匹配所有报文,目的是对所有报文进行流量监管
    [HUAWEI-classifier-c1] quit
    [HUAWEI] traffic behavior b1                 //创建流行为b1,并进入流行为视图
    [HUAWEI-behavior-b1] car cir 200000 pir 2500000 green pass yellow pass red discard  //创建流量监管动作
    [HUAWEI-behavior-b1] statistic enable     //使能流量统计功能,便于后续查看流量统计信息
    [HUAWEI-behavior-b1] quit 
    [HUAWEI] traffic policy p1                   //创建流策略p1,并进入流策略视图
    [HUAWEI-trafficpolicy-p1] classifier c1 behavior b1  //将流分类c1和流行为b1绑定
    [HUAWEI-trafficpolicy-p1] quit 
    [HUAWEI] interface gigabitethernet 1/0/1       
    [HUAWEI-GigabitEthernet1/0/1] traffic-policy p1 inbound //将流策略p

    配置基于MQC的流量监管后,执行display traffic policy statistics命令,可以查看流量统计信息。

    [HUAWEI] display traffic policy statistics all
    
     Interface: GigabitEthernet1/0/1                                                                                                    
     Traffic policy inbound: p1                                                                                                         
     Rule number: 1                                                                                                                     
     Current status: success                                                                                                            
     Statistics interval: 300                                                                                                           
    ---------------------------------------------------------------------                                                               
     Board : 0                                                                                                                          
    ---------------------------------------------------------------------                                                               
     Matched          |      Packets:                             0                                                                     
                      |      Bytes:                               -                                                                     
                      |      Rate(pps):                           0                                                                     
                      |      Rate(bps):                           -                                                                     
    ---------------------------------------------------------------------                                                               
       Passed         |      Packets:                             0                                                                     
                      |      Bytes:                               -                                                                     
                      |      Rate(pps):                           0                                                                     
                      |      Rate(bps):                           -                                                                     
    ---------------------------------------------------------------------                                                               
       Dropped        |      Packets:                             0                                                                     
                      |      Bytes:                               -                                                                     
                      |      Rate(pps):                           0                                                                     
                      |      Rate(bps):                           -                                                                     
    ---------------------------------------------------------------------                                                               
         Filter       |      Packets:                             0                                                                     
                      |      Bytes:                               -                                                                     
    ---------------------------------------------------------------------                                                               
         Car          |      Packets:                             0                                                                     
                      |      Bytes:                               -                                                                     
    ---------------------------------------------------------------------

    04

       配置队列流量整形

    配置队列流量整形前,需要配置优先级映射,将报文的优先级映射为PHB行为(Per-Hop Behavior,即服务等级的取值),从而使不同业务进入不同的端口队列。

    以下示例中,Switch通过接口GE2/0/1与路由器互连,来自网络侧的业务有语音、视频、数据,携带的802.1p优先级分别为6、5、2。由于来自用户局域网的流量速率大于Router接口的速率,出接口GE2/0/1处可能会发生带宽抖动。为减少带宽抖动,同时保证各类业务带宽要求,现要求:

    • 语音带宽限制为3000kbit/s,最大不超过5000kbit/s。

    • 视频带宽限制为5000kbit/s,最大不超过8000kbit/s。

    • 数据带宽限制为2000kbit/s,最大不超过3000kbit/s。

    图1-1 流量整形配置组网图

    【1】配置优先级映射。

    # 创建DiffServ域ds1,将802.1p优先级6、5、2分别映射为PHB行为CS7、EF、AF2。

    [HUAWEI] diffserv domain ds1                     //创建DiffServ域ds1
    [HUAWEI-dsdomain-ds1] 8021p-inbound 6 phb cs7    //将802.1p优先级6映射为PHB行为CS7
    [HUAWEI-dsdomain-ds1] 8021p-inbound 5 phb ef     //将802.1p优先级5映射为PHB行为EF
    [HUAWEI-dsdomain-ds1] 8021p-inbound 2 phb af2    //将802.1p优先级2映射为PHB行为AF2
    [HUAWEI-dsdomain-ds1] quit 
    [HUAWEI] interface gigabitethernet 1/0/1  
    [HUAWEI-GigabitEthernet1/0/1] trust upstream ds1 //根据流量方向,将DiffServ域应用到报文的入接口 
    [HUAWEI-GigabitEthernet1/0/1] quit

    【2】配置端口队列整形。

    # 在Switch上配置端口队列整形,使语音、视频、数据业务的带宽分别限制为3000kbit/s、5000kbit/s、2000kbit/s,最大分别不超过5000kbit/s、8000kbit/s、3000kbit/s。

    [HUAWEI] interface gigabitethernet 2/0/1       //根据流量方向,在报文的出接口配置流量整形
    [HUAWEI-GigabitEthernet2/0/1] qos queue 7 shaping cir 3000 pir 5000  //PHB行为CS7对应的队列索引为7
    [HUAWEI-GigabitEthernet2/0/1] qos queue 5 shaping cir 5000 pir 8000  //PHB行为EF对应的队列索引为5
    [HUAWEI-GigabitEthernet2/0/1] qos queue 2 shaping cir 2000 pir 3000  //PHB行为AF2对应的队列索引为2
    [HUAWEI-GigabitEthernet2/0/1] quit 

    配置队列流量整形后,执行display qos queue statistics命令,可以查看流量统计信息。以接口GE2/0/1的2号队列为例:

    [HUAWEI] display qos queue statistics interface gigabitethernet 2/0/1 queue 2
    ------------------------------------------------------------     
      Queue ID          : 2                                   
      CIR(kbps)         : 2,000                                
      PIR(kbps)         : 3,000                                           
      Used Length(byte) : 0                                        
      Passed Packets    : 0                                       
      Passed Rate(pps)  : 0                                     
      Passed Bytes      : 0                                      
      Passed Rate(bps)  : 0                                     
      Dropped Packets   : 0                                      
      Dropped Rate(pps) : 0                                      
      Dropped Bytes     : 0         
      Dropped Rate(bps) : 0  
    ------------------------------------------------------------

    05

       配置接口限速

    入方向接口限速的配置方法如下:

    1. 配置CAR参数:qos car car-name cir cir-value [ cbs cbs-value [ pbs pbs-value ] | pir pir-value [ cbs cbs-value pbs pbs-value ] ]

    2. 进入接口视图:interfaceinterface-type interface-number

    3. 在接口下应用CAR模板:qos car inbound car-name

    4. (可选)查看接口入方向的报文统计信息:

      • display qos car statistics interfaceinterface-type interface-numberinbound(显示指定接口入方向上通过和丢弃的报文统计信息)

      • display qos car statistics all [ nonzero ](显示所有应用QoS CAR后的接口入方向上的报文统计信息)

    出方向接口限速的配置方法如下:

    1. 进入接口视图:执行命令interfaceinterface-type interface-number

    2. 配置出方向的接口限速qos lr circir-value [ cbs cbs-value ] [outbound ]

    展开全文
  • 今天给大家带来QoS流量监管和流量整形配置实例。本文以华为eNSP模拟器为范例,简单配置实现了流量监管和流量整形功能。 阅读本文,您需要有一定的QoS基础,如果您对此还存在疑惑,欢迎查阅我博客中的其他文章,相信...
  • 限速: ...限速功能在华为交换机上可以作用于入接口出接口方向,路由器则一般仅支持出接口方向。 华为路由器通过qos lr命令用来配置物理接口发送报文的速率占接口带宽的百分比,qos lr命令之后跟随的cb
  • QoS技术介绍 流分类、流量监管和流量整形 拥塞管理
  • 流量监管技术:TP(Traffic Policing) 对接收或发送的流量进行限速控制,限制进入网络的突发流量,为网络提供了基本的QoS功能 优点:可实现对不同类别的报文分别进行限速 缺点:当链路空闲时,造成带宽浪费;丢弃的...
  • 1.流量监管 流量监管 TP(Traffic Policing)是指对进入设备的流量进行监控,确保其没有滥用网络资源。通过监控进入网络的某一流量的规格,限制它在一个允许的范围之内,若某个连 接的报文流量过大,就对流量进行...
  • 介绍流量监管流量整形的基本概念、实现原理。
  • 介绍流量监管流量整形的基本概念、实现原理。
  • 介绍流量监管流量整形的基本概念、实现原理。
  • 此资源详细介绍了qos中的流量监管流量整形的工作原理,提出了几种令牌桶的算法
  • 流量监管和流量整形都是限速工具 流量监管使用令牌桶技术,对于超出速率的流量进行丢弃。流量整形对超出的流量会缓存 流量监管 如果超出接口带宽,超出接口的流量就会被丢弃,入方向和出方向都可以配置 流量监管功能...
  • QOS概述(三)流量监管和流量整形

    千次阅读 2020-11-15 21:16:27
    流量监管和流量整形就是一类通过对流量规格的监督来限制流量及其资源使用的流控策略。 目录 1、流量监管技术 流量监管原理 2、流量整形技术 流量整形原理 3、两者的区别 1、流量监管技术 流量监管TP...
  • 此资源详细介绍了qos中的流量监管流量整形的工作原理,提出了几种令牌桶的算法
  • QOS流量整形

    万次阅读 多人点赞 2020-11-20 12:39:51
    文章目录 1、拓扑 2、路由器配置整形命令 3、交换机配置整形命令 4、小结
  • HCNP认证学习文档,2015年12月更新

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 623
精华内容 249
关键字:

流量整形和流量监管