精华内容
下载资源
问答
  • 思科ping测试命令
    千次阅读
    2020-04-24 15:07:44

    Cisco系列网络设备测试命令大全
    ?        1、show命令:
    1) 全局命令:
    show version ;显示系统硬件和软件版本、DRAM、Flash
    show startup-config ;显示写入NVRAM中的配置内容
    show running-config ;显示当前运行的配置内容
    show buffers ;详细输出buffer的名称和尺寸
    show stacks ;提供路由器进程和处理器利用率信息, 用stack decode
    show tech-support ;显示几个show命令的输出
    show access-lists ;查看访问列表配置
    show memory ;用于测试内存问题
    2) 接口相关命令
    show queueing [fair|priority|custom]
    show queue e0/1 ;查看接口上队列的设置和操作
    show interface e0/1 ;Cisco缺省的Ethernet封装方法是ARPA
    show ip interface e0/1 ;显示指定接口的TCP/IP配置信息
    3) 进程相关命令
    show processes cpu ;显示路由器CPU的使用率和当前的进程
    show processes memory ;显示路由器当前进程的内存使用情况
    4) TCP/IP协议相关命令
    Show ip access-list ;显示IP访问列表(1-199)
    Show ip arp ;显示路由器的ARP缓存(IP、MAC、封装类型、接口)
    Show ip protocols ;显示运行在路由器上的IP路由协议的信息
    Show ip route ;显示IP路由表中的信息
    Show ip traffic ;显示IP流量统计信息
    ?        2、debug命令
    DEBUG不应在CPU使用率超过50%的路由器上运行。
    1) 限制debug输出
    在使用DEBUG获得所需数据后,要关闭Debug
    使路由器对所有消息都配置使用时间戳:
    Router#service timestamps debug datetime msec localtime
    Router#service timestamp log datetime msec localtime
    缺省,error和debug信息仅发送到console,telnet到路由器上看不到debug和log的信息。想在telnet中看到debug和log信息:
    Router#terminal monitor
    Router#terminal monitor ;关闭信息输出
    Router#undebug all ;关闭debug进程及所有相关信息的输出
    可以应用ACL到debug以限定仅输出要求的debug信息。
    如仅查看从10.0.1.1到10.1.1.1的ICMP包:
    Router(config)#access-list 101 permit icmp host 10.0.1.1 host 10.1.1.1
    Router#debug ip packet detail 101
    2) 全局debug命令:
    3) 接口debug
    4) 协议debug
    5) IP debug
    debug ip packets
    ?        3、logging命令
    输出error和其它信息到console、terminal、路由器内部buffer或一台syslogphp?name=%B7%FE%CE%F1%C6%F7" οnclick="tagshow(event)" class="t_tag">服务器:
    Router>show logging
    Cisco路由器有8种可能的logging级:0-7
    Logging级别 名称 描述
    1 Emergencies 系统不能用的信息
    2 Alerts 直接行动
    3 Critical 紧急情形
    4 Errors 错误信息
    5 Warnings 警告信息
    6 Notifications 正常但重要的情形
    7 Informational 信息
    8 Debugging 调试
    缺省地,console、monitor、buffer的logging被设置为debugging级,而trap(syslog)服务器的logging被设置为informational.
    4、执行路由核心复制
    core dump包含一份当前系统内存中信息的精确拷贝。捕捉包含在内存中信息的方法有:
    1) 配置路由器在崩溃时执行Core Dump,存储到TFTP、FTP、RCP服务器:
    对TFTP协议,只需指定TFTP服务器IP,不需要任何附加的配置:
    Router(config)#exception dump 192.168.1.1 ;TFTP服务器的IP地址
    对FTP协议的配置:
    Router(config)#exception dump 192.168.1.1 ;FTP服务器的IP地址
    Router(config)#ip ftp username Kevin
    Router(config)#ip ftp password aloha
    Router(config)#ip ftp source-interface e0
    Router(config)#exception protocol ftp
    对RCP协议的配置:
    Router(config)#exception protocol rcp
    Router(config)#exception dump 192.168.1.1 ;RCP服务器的IP地址
    Router(config)#ip rcmd remote-username Kevin
    Router(config)#ip rcmd rcp-enable
    Router(config)#ip rcmd rsh-enable
    Router(config)#ip rcmd remote-host Kevin 192.168.1.1 kevin ;
    2) 在系统没有崩溃的情况下,执行Core Dump命令。
    Router#write core
    Core Dump仅在Cisco工程师测试和解决路由器问题时有用。

    5、ping命令
    ping用于测试整个网络可达性和连通性。可在用户EXEC模式和特权EXEC模式下使用。
    IP的ping使用ICMP协议提供连通性和可能性信息,缺省只发送5个echo信息。
    扩展Ping的选项有:源IP地址;服务类型;数据;包头选项。
    Ping的响应字符集
    ! Received an echo-reply message Q Source quench
    . Timeout M Unable to fragment
    U/H Destination unreachable A Administratively denied
    N Network unreachable ? Unknown packet-type
    P Protocol unreachable
    6、traceroute命令
    traceroute用于显示到达目标的包路径。可在用户模式和特权模式下使用。
    Traceroute的响应:
    Xx msec The RTT for each packet * Timeout
    H Host unreachable U Port unreachable
    N Network unreachable P Protocol unreachable
    A Administratively denied Q Source quench
    ? Unknown packet type
    ---------------------------------------------------------------------


    Cisco命令集


    Cisco命令集
     
    PIX515E 操作命令
    show local-host | in local host|count //PIX 515E上查看连接数
    show conn protocol tcp //PIX 515E上查看TCP连接
    show nat //PIX 515E
    show access-list //PIX 515E

    #snmp setting on the PIX515E
    snmp-server host inside 192.168.1.2 poll
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
     
    删除无用的access-list: no access-list e In_Out tcp host 172.18.20.16 any
    查看流量:show ip access-list or show access-list
    把所有的访问控制列表都保存.
    然后先在接口下面把访问控制去掉.再去访问控制列表.再把新的访问控制列表添加上去.最后再应用到接口.
    no access-group In_Out in interface inside
    no access-list e In_Out
    7.0版本Cisco PiX允许内部Ping外部,但外部不能Ping内部
      policy-map global_policy
      class inspection_default
      inspect icmp
    6.3版本Cisco Pix允许内部Ping外部,但外部不能Ping内部
      access-list 101 permit icmp any any echo-reply
      access-group 101 in interface outside

    //允许Tracert返回包
    access-list Out_In extended permit icmp any any time-exceeded

    #syslog for PIX
    logging on
    logging trap [1-7]
    show logging
    logging host [interface] ip_address
     
    #Cisco Switch Command:
    switchport port-security mac-address sticky //Mac地址绑定
    no switchport port-security //端口MAC绑定
    show ip access-lists 162 //查看访问列表
    switchport access vlan 300 //修改端口VLan
    show cdp nei detail //查看级联交换机
    show processes cpu //cpu利用率
    show processes memory //mem利用率
    单播流量40%.组播流量30%
        storm-control unicast level 40
        storm-control multicast level 30
    rate-limit 端口限速
     
    //某个Vlan,一个IP走网通,其他IP走电信
    access-list ( number ) deny ip ( ip address ) any
    access-list ( number ) permit ip any any

    //3750或者3550总出口端口限制某个vlan总带宽
    mls qos
    class-map match-all user2m
    match access-group 101
    policy-map download
    class user2m
      police 2048000 512000 exceed-action drop
    access-list 101 permit ip any 172.18.50.0 255.255.255.0
    interface g1/0/22
      service-policy input download

    //建立vlan
    vlan 233
    interface vlan 233
    ip address 172.18.233.1 255.255.255.0
    ip helper-address 172.18.10.12
    interface f0/22
    switchport access vlan 233

    //根据用户的源ip地址指定路由
    access-list 152 permit ip host 172.18.50.201 any
    access-list 152 permit ip host 172.18.50.202 any
    access-list 188 permit ip any 218.75.79.0 0.0.0.255
    access-list 188 permit ip any 58.215.76.0 0.0.0.255
    route-map VLAN500-17F permit 10
    match ip address 188 152
    set ip next-hop 172.18.33.1
    interface Vlan1
    ip address 172.18.100.2 255.255.255.0
    ip policy route-map VLAN500-17F

    #已知2950的F0/16端口流量大,察看MAC或IP
    config t
    interface f0/16
      swi port-security
      swi port-security mac-address sticky
    show run
    show arp
    show mac-address-table
    拿到MAC地址后,根据IP段扫描IP段
    nbtscan -r 192.168.15.0/24

    #SPAN(端口镜像)
    conf t
    monitor session 1 source interface fastEthernet 0/38 //需要抓包的端口,源口
    monitor session 1 destination interface fastEthernet 0/36 //监听端口,目标口
    exit
    show monitor session 1

    #syslog configuration
    device#conf t
    device(config)#logging on
    device(config)#logging a.b.c.d //日志服务器的IP地址
    device(config)#logging facilit y local1
    //facility标识, RFC3164 规定的本地设备标识为 local0 - local7
    device(config)#logging trap errors //日志记录级别,可用"?"查看详细内容
    device(config)#logging source-interface e0 //日志发出用的源IP地址
    device(config)#service timestamps log datetime localtime
    //日志记录的时间戳设置,可根据需要具体配置
    device#sh logging //检验
     
    Access-enable 允许路由器在动态访问列表中创建临时访问列表入口
    Access-group 把访问控制列表(ACL)应用到接口上
    Access-list 定义一个标准的IP ACL
    Access-template 在连接的路由器上手动替换临时访问列表入口
    Appn 向APPN子系统发送命令
    Atmsig 执行ATM信令命令
    B 手动引导操作系统
    Bandwidth 设置接口的带宽
    Banner motd 指定日期信息标语
    Bfe 设置突发事件手册模式
    Boot system 指定路由器启动时加载的系统映像
    Calendar 设置硬件日历
    Cd 更改路径
    Cdp enable 允许接口运行CDP协议
    Clear 复位功能
    Clear counters 清除接口计数器
    Clear interface 重新启动接口上的硬件逻辑
    Clockrate 设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率
    Cmt 开启/关闭FDDI连接管理功能
    Config-register 修改配置寄存器设置
    Configure 允许进入存在的配置模式,在中心站点上维护并保存配置信息
    Configure memory 从NVRAM加载配置信息
    Configure terminal 从终端进行手动配置
    Connect 打开一个终端连接
    Copy 复制配置或映像数据
    Copy flash tftp 备份系统映像文件到TFTP服务器
    Copy running-config startup-config 将RAM中的当前配置存储到NVRAM
    Copy running-config tftp 将RAM中的当前配置存储到网络TFTP服务器上
    Copy tftp flash 从TFTP服务器上下载新映像到Flash
    Copy tftp running-config 从TFTP服务器上下载配置文件
    Debug 使用调试功能
    Debug dialer 显示接口在拨什么号及诸如此类的信息
    Debug ip rip 显示RIP路由选择更新数据
    Debug ipx routing activity 显示关于路由选择协议(RIP)更新数据包的信息
    Debug ipx sap 显示关于SAP(业务通告协议)更新数据包信息
    Debug isdn q921 显示在路由器D通道ISDN接口上发生的数据链路层(第2层)的访问过程
    Debug ppp 显示在实施PPP中发生的业务和交换信息
    Delete 删除文件
    Deny 为一个已命名的IP ACL设置条件
    Dialer idle-timeout 规定线路断开前的空闲时间的长度
    Dialer map 设置一个串行接口来呼叫一个或多个地点
    Dialer wait-for-carrier-time 规定花多长时间等待一个载体
    Dialer-group 通过对属于一个特定拨号组的接口进行配置来访问控制
    Dialer-list protocol 定义一个数字数据接受器(DDR)拨号表以通过协议或ACL与协议的组合来控制控制拨号
    Dir 显示给定设备上的文件
    Disable 关闭特许模式
    Disconnect 断开已建立的连接
    Enable 打开特许模式
    Enable password 确定一个密码以防止对路由器非授权的访问
    Enable password 设置本地口令控制不同特权级别的访问
    Enable secret 为enable password命令定义额外一层安全性
    Encapsulation frame-relay 启动帧中继封装
    Encapsulation novell-ether 规定在网络段上使用的Novell独一无二的格式
    Encapsulation PPP 把PPP设置为由串口或ISDN接口使用的封装方法
    Encapsulation sap 规定在网络段上使用的以太网802.2格式Cisco的密码是sap
    End 退出配置模式
    Erase 删除闪存或配置缓存
    Erase startup-config 删除NVRAM中的内容
    Exec-timeout 配置EXEC命令解释器在检测到用户输入前所等待的时间
    Exit 退出所有配置模式或者关闭一个激活的终端会话和终止一个EXEC
    Exit 终止任何配置模式或关闭一个活动的对话和结束EXEC
    format 格式化设备
    Frame-relay local-dlci 为使用帧中继封装的串行线路启动本地管理接口(LMI)
    Help 获得交互式帮助系统
    History 查看历史记录
    Hostname 使用一个主机名来配置路由器,该主机名以提示符或者缺省文件名的方式使用
    Interface 设置接口类型并且输入接口配置模式
    Interface 配置接口类型和进入接口配置模式
    Interface serial 选择接口并且输入接口配置模式
    Ip access-group 控制对一个接口的访问
    Ip address 设定接口的网络逻辑地址
    Ip address 设置一个接口地址和子网掩码并开始IP处理
    Ip default-network 建立一条缺省路由
    Ip domain-lookup 允许路由器缺省使用DNS
    Ip host 定义静态主机名到IP地址映射
    Ip name-server 指定至多6个进行名字-地址解析的服务器地址
    Ip route 建立一条静态路由
    Ip unnumbered 在为给一个接口分配一个明确的IP地址情况下,在串口上启动互联网协议(IP)的处理过程
    Ipx delay 设置点计数
    Ipx ipxwan 在串口上启动IPXWAN协议
    Ipx maximum-paths 当转发数据包时设置Cisco IOS软件使用的等价路径数量
    Ipx network 在一个特定接口上启动互联网数据包交换(IPX)的路由选择并且选择封装的类型(用帧封装)
    Ipx router 规定使用的路由选择协议
    Ipx routing 启动IPX路由选择
    Ipx sap-interval 在较慢的链路上设置较不频繁的SAP(业务广告协议)更新
    Ipx type-20-input-checks 限制对IPX20类数据包广播的传播的接受
    Isdn spid1 在路由器上规定已经由ISDN业务供应商为B1信道分配的业务简介号(SPID)
    Isdn spid2 在路由器上规定已经由ISDN业务供应商为B2信道分配的业务简介号(SPID)
    Isdn switch-type 规定了在ISDN接口上的中央办公区的交换机的类型
    Keeplive 为使用帧中继封装的串行线路LMI(本地管理接口)机制
    Lat 打开LAT连接
    Line 确定一个特定的线路和开始线路配置
    Line concole 设置控制台端口线路
    Line vty 为远程控制台访问规定了一个虚拟终端
    Lock 锁住终端控制台
    Login 在终端会话登录过程中启动了密码检查
    Login 以某用户身份登录,登录时允许口令验证
    Logout 退出EXEC模式
    Mbranch 向下跟踪组播地址路由至终端
    Media-type 定义介质类型
    Metric holddown 把新的IGRP路由选择信息与正在使用的IGRP路由选择信息隔离一段时间
    Mrbranch 向上解析组播地址路由至枝端
    Mrinfo 从组播路由器上获取邻居和版本信息
    Mstat 对组播地址多次路由跟踪后显示统计数字
    Mtrace 由源向目标跟踪解析组播地址路径
    Name-connection 命名已存在的网络连接
    Ncia 开启/关闭NCIA服务器
    Network 把一个基于NIC的地址分配给一个与它直接相连的路由器把网络与一个IGRP的路由选择的过程联系起来在IPX路由器配置模式下,在网络上启动加强的IGRP
    Network 指定一个和路由器直接相连的网络地址段
    Network-number 对一个直接连接的网络进行规定
    No shutdown 打开一个关闭的接口
    Pad 开启一个X.29 PAD连接
    Permit 为一个已命名的IP ACL设置条件
    Ping 把ICMP响应请求的数据包发送网络上的另一个节点检查主机的可达性和网络的连通性对网络的基本连通性进行诊断
    Ping 发送回声请求,诊断基本的网络连通性
    Ppp 开始IETF点到点协议
    Ppp authentication 启动Challenge握手鉴权协议(CHAP)或者密码验证协议(PAP)或者将两者都启动,并且对在接口上选择的CHAP和PAP验证的顺序进行规定
    Ppp chap hostname 当用CHAP进行身份验证时,创建一批好像是同一台主机的拨号路由器
    Ppp chap password 设置一个密码,该密码被发送到对路由器进行身份验证的主机命令对进入路由器的用户名/密码的数量进行了限制
    Ppp pap sent-username 对一个接口启动远程PAP支持,并且在PAP对同等层请求数据包验证过程中使用sent-username和password
    Protocol 对一个IP路由选择协议进行定义,该协议可以是RIP,内部网关路由选择协议(IGRP),开放最短路径优先(OSPF),还可以是加强的IGRP
    Pwd 显示当前设备名
    Reload 关闭并执行冷启动;重启操作系统
    Rlogin 打开一个活动的网络连接
    Router 由第一项定义的IP路由协议作为路由进程,例如:router rip 选择RIP作为路由协议
    Router igrp 启动一个IGRP的路由选择过程
    Router rip 选择RIP作为路由选择协议
    Rsh 执行一个远程命令
    Sdlc 发送SDLC测试帧
    Send 在tty线路上发送消息
    Service password-encryption 对口令进行加密
    Setup 运行Setup命令
    Show 显示运行系统信息
    Show access-lists 显示当前所有ACL的内容
    Show buffers 显示缓存器统计信息
    Show cdp entry 显示CDP表中所列相邻设备的信息
    Show cdp interface 显示打开的CDP接口信息
    Show cdp neighbors 显示CDP查找进程的结果
    Show dialer 显示为DDR(数字数据接受器)设置的串行接口的一般诊断信息
    Show flash 显示闪存的布局和内容信息
    Show frame-relay lmi 显示关于本地管理接口(LMI)的统计信息
    Show frame-relay map 显示关于连接的当前映射入口和信息
    Show frame-relay pvc 显示关于帧中继接口的永久虚电路(pvc)的统计信息
    Show hosts 显示主机名和地址的缓存列表
    Show interfaces 显示设置在路由器和访问服务器上所有接口的统计信息
    Show interfaces 显示路由器上配置的所有接口的状态
    Show interfaces serial 显示关于一个串口的信息
    Show ip interface 列出一个接口的IP信息和状态的小结
    Show ip interface 列出接口的状态和全局参数
    Show ip protocols 显示活动路由协议进程的参数和当前状态
    Show ip route 显示路由选择表的当前状态
    Show ip router 显示IP路由表信息
    Show ipx interface 显示Cisco IOS软件设置的IPX接口的状态以及每个接口中的参数
    Show ipx route 显示IPX路由选择表的内容
    Show ipx servers 显示IPX服务器列表
    Show ipx traffic 显示数据包的数量和类型
    Show isdn active 显示当前呼叫的信息,包括被叫号码、建立连接前所花费的时间、在呼叫期间使用的自动化操作控制(AOC)收费单元以及是否在呼叫期间和呼叫结束时提供AOC信息
    Show isdn ststus 显示所有isdn接口的状态、或者一个特定的数字信号链路(DSL)的状态或者一个特定isdn接口的状态
    Show memory 显示路由器内存的大小,包括空闲内存的大小
    Show processes 显示路由器的进程
    Show protocols 显示设置的协议
    Show protocols 显示配置的协议。这条命令显示任何配置了的第3层协议的状态
    Show running-config 显示RAM中的当前配置信息
    Show spantree 显示关于虚拟局域网(VLAN)的生成树信息
    Show stacks 监控和中断程序对堆栈的使用,并显示系统上一次重启的原因
    Show startup-config 显示NVRAM中的启动配置文件
    Show ststus 显示ISDN线路和两个B信道的当前状态
    Show version 显示系统硬件的配置,软件的版本,配置文件的名称和来源及引导映像
    Shutdown 关闭一个接口
    Telnet 开启一个telect连接
    Term ip 指定当前会话的网络掩码的格式
    Term ip netmask-format 规定了在show命令输出中网络掩码显示的格式
    Timers basic 控制着IGRP以多少时间间隔发送更新信息
    Trace 跟踪IP路由
    Username password 规定了在CHAP和PAP呼叫者身份验证过程中使用的密码
    Verify 检验flash文件
    Where 显示活动连接
    Which-route OSI路由表查找和显示结果
    Write 运行的配置信息写入内存,网络或终端
    Write erase 现在由copy startup-config命令替换
    X3 在PAD上设置X.3参数
    Xremote 进入XRemote模
    ===========================================================================
    show access-lists ;查看访问列表配置
    show memory ;用于测试内存问题
    2) 接口相关命令
    show queueing [fair|priority|custom]
    show queue e0/1 ;查看接口上队列的设置和操作
    show interface e0/1 ;Cisco缺省的Ethernet封装方法是ARPA
    show ip interface e0/1 ;显示指定接口的TCP/IP配置信息
    3) 进程相关命令
    show processes cpu ;显示路由器CPU的使用率和当前的进程
    show processes memory ;显示路由器当前进程的内存使用情况
    4) TCP/IP协议相关命令
    Show ip access-list ;显示IP访问列表(1-199)
    Show ip arp ;显示路由器的ARP缓存(IP、MAC、封装类型、接口)
    Show ip protocols ;显示运行在路由器上的IP路由协议的信息
    Show ip route ;显示IP路由表中的信息
    Show ip traffic ;显示IP流量统计信息
    2、debug命令
    DEBUG不应在CPU使用率超过50%的路由器上运行。
    1) 限制debug输出
    在使用DEBUG获得所需数据后,要关闭Debug
    使路由器对所有消息都配置使用时间戳:
    Router#service timestamps debug datetime msec localtime
    Router#service timestamp log datetime msec localtime
    缺省,error和debug信息仅发送到console,telnet到路由器上看不到debug和log的信息。想在telnet中看到debug和log信息:
    Router#terminal monitor
    Router#terminal monitor ;关闭信息输出
    Router#undebug all ;关闭debug进程及所有相关信息的输出
    可以应用ACL到debug以限定仅输出要求的debug信息。
    如仅查看从10.0.1.1到10.1.1.1的ICMP包:
    Router(config)#access-list 101 permit icmp host 10.0.1.1 host 10.1.1.1
    Router#debug ip packet detail 101
    2) 全局debug命令:
    3) 接口debug
    4) 协议debug
    5) IP debug
    debug ip packets
    3、logging命令
    输出error和其它信息到console、terminal、路由器内部buffer或一台syslog服务器:
    Router>show logging
    Cisco路由器有8种可能的logging级:0-7
    Logging级别 名称 描述
    1 Emergencies 系统不能用的信息
    2 Alerts 直接行动
    3 Critical 紧急情形
    4 Errors 错误信息
    5 Warnings 警告信息
    6 Notifications 正常但重要的情形
    7 Informational 信息
    8 Debugging 调试
    缺省地,console、monitor、buffer的logging被设置为debugging级,而trap(syslog)服务器的logging被设置为informational。

    4、执行路由核心复制
    core dump包含一份当前系统内存中信息的精确拷贝。捕捉包含在内存中信息的方法有:
    1) 配置路由器在崩溃时执行Core Dump,存储到TFTP、FTP、RCP服务器:
    对TFTP协议,只需指定TFTP服务器IP,不需要任何附加的配置:
    Router(config)#exception dump 192.16

    欢迎光临学网,收藏本篇文章 [1] [2] [3] [4]

    $False$

    8.1.1 ;TFTP服务器的IP地址
    对FTP协议的配置:
    Router(config)#exception dump 192.168.1.1 ;FTP服务器的IP地址
    Router(config)#ip ftp username Kevin
    Router(config)#ip ftp password aloha
    Router(config)#ip ftp source-interface e0
    Router(config)#exception protocol ftp
    对RCP协议的配置:
    Router(config)#exception protocol rcp
    Router(config)#exception dump 192.168.1.1 ;RCP服务器的IP地址
    Router(config)#ip rcmd remote-username Kevin
    Router(config)#ip rcmd rcp-enable
    Router(config)#ip rcmd rsh-enable
    Router(config)#ip rcmd remote-host Kevin 192.168.1.1 kevin ;
    2) 在系统没有崩溃的情况下,执行Core Dump命令。
    Router#write core
    Core Dump仅在Cisco工程师测试和解决路由器问题时有用。
    5、ping命令
    ping用于测试整个网络可达性和连通性。可在用户EXEC模式和特权EXEC模式下使用。
    IP的ping使用ICMP协议提供连通性和可能性信息,缺省只发送5个echo信息。
    扩展Ping的选项有:源IP地址;服务类型;数据;包头选项。
    Ping的响应字符集
    字符 解释 字符 解释
    ! Received an echo-reply message Q Source quench
    . Timeout M Unable to fragment
    U/H Destination unreachable A Administratively denied
    N Network unreachable ? Unknown packet-type
    P Protocol unreachable
    6、traceroute命令
    traceroute用于显示到达目标的包路径。可在用户模式和特权模式下使用。
    Traceroute的响应:
    字符 解释 字符 解释
    Xx msec The RTT for each packet * Timeout
    H Host unreachable U Port unreachable
    N Network unreachable P Protocol unreachable
    A Administratively denied Q Source quench
    ? Unknown packet type
    二、LAN连接问题
    1、获得IP地址
    主机可以动态或静态获得IP地址。
    1) DHCP:DHCP比BootP多了地址池和租期。
    2) BootP:
    3) Helper Addresses:指定集中放置的DHCP服务器的IP地址
    Ip helperaddress ip-address ;
    No ip forward-protocol udp 137 ;
    4) 路由器上的DHCP服务:配置路由器为一台DHCP服务器
    5) DHCP和BootP故障处理
    Show dhcp server ;
    Show dhcp lease ;
    2、ARP
    ARP映射第2层MAC地址到第3层地址。
    Show arp ;显示路由器的ARP表
    Debug arp ;
    1) ARP代理:缺省Cisco路由器的ARP代理是启用的
    在下列情况下,CISCO路由器将用自身的MAC地址响应ARP请求:
    ? 接收到ARP的接口上的Proxy ARP是启用的;
    ? ARP请求的地址不在本地子网;
    ? 路由器的路由表中包含ARP请求地址的子网;
    3、TCP连接示例
    三、IP访问列表
    1、标准ACL:基于IP包的源IP地址允许或禁用
    2、扩展ACL:提供源地址、目标地址、端口号、会话层协议进行过滤。
    3、命名ACL:可以是标准ACL,也可以是扩展ACL。
    命名ACL与编号ACL的区别:命名ACL有一个逻辑名,可以删除命名ACL中单独一行。
    Ip access-list extended Example-Named-ACL
    Deny tcp any any eq echo
    Deny tcp an欢迎光临学网,点击这里查看更多文章教程 [1] [2] [3] [4]


    y any eq 37
    Permit udp host 172.16.10.2 any eq snmp
    Permit tcp any any
    第6章 TCP/IP路由协议故障处理
    一、缺省网关
    当包的目的地址不在路由器的路由表中,如路由器配置了缺省网关,则转发到缺省网关,否则就丢弃。
    Show ip route ;查看Cisco路由器的缺省网关
    二、静态和动态路由
    三、处理k_protocal/04937.htm" target="_blank">RIP故障
    RIP是距离矢量路由协议,度量值是跳数。RIP最大跳数为15,如果到目标的跳数超过15,则为不可达。
    RIP V1是有类别路由协议,RIP V2是非分类路由协议,支持CIDR、路由归纳、VLSM,使用多播(224.0.0.9)发送路由更新。
    RIP相关的show命令:
    Show ip route rip ;仅显示RIP路由表
    Show ip route ;显示所有IP路由表
    Show ip interface ;显示IP接口配置
    Show running-config
    Debug ip rip events ;
    常见的RIP故障:RIP版本不一致、RIP使用UDP广播更新
    四、处理IGRP故障
    IGRP是Cisco专用路由协议,距离矢量协议。IGRP的度量值可以基于五个要素:带宽、延时、负载、可靠性、MTU,缺省只使用带宽和延时。
    IGRP相关的show命令:
    Show ip route igrp ;显示IGRP路由表
    Debug ip igrp events ;
    Debug ip igrp transactions ;
    常见的IGRP故障:访问列表、不正确的配置、到相邻路由器的line down
    五、处理EIGRP故障
    EIGRP是链路状态协议和距离矢量混合协议,是CISCO专用路由协议。EIGRP使用多播地址224.0.0.10发送路由更新,使用DUAL算法计算路由。EIGRP的度量值可以基于带宽、延时、负载、可靠性、MTU,缺省仅使用带宽和延时。
    EIGRP使用3种数据库:路由数
    据库、拓扑数据库、相邻路由器数据库。
    EIGRP相关的show命令:
    Show running-config
    Show ip route
    Show ip route eigrp ;仅显示EIGRP路由
    Show ip eigrp interface ;显示该接口的对等体信息
    Show ip eigrp neighbors ;显示所有的EIGRP邻居及其信息
    Show ip eigrp topology ;显示EIGRP拓扑结构表的内容
    Show ip eigrp traffic ;显示EIGRP路由统计的归纳
    Show ip eigrp events ;显示最近的EIGRP协议事件记录
    EIGRP相关的debug命令:
    Debug ip eigrp as号
    Debug ip eigrp neighbor
    Debug ip eigrp notifications
    Debug ip eigrp summary
    Debug ip eigrp
    常见的EIGRP故障:相邻关系、缺省网关等的丢失、老版本IOS的路由、stuck in active。
    处理EIGRP故障时,先用show ip eigrp neighbors查看所有相邻路由器,然后再用show ip route gigrp查看路由器的路由表,再用show ip eigrp topology查看路由器的拓扑结构表,也可用show ip eigrp traffic查看路由更新是否被发送。
    六、处理OSPF故障
    OSPF是链路状态协议,维护3个数据库:相邻数据库、拓扑结构数据库、路由表。
    OSPF相关的show命令:
    Show running-config
    Show ip route
    Show ip route ospf ;仅显示OSPF路由
    Show ip ospf process-id ;显示与特定进程ID相关的信息
    Show ip ospf ;显示OSPF相关信息
    Show ip ospf border-routers ;显示边界路由器
    Show ip ospf database ;显示OSPF的归纳数据库
    Show ip ospf interface ;显示指定接口上的OSPF信息
    Show ip ospf neighbor ;显示OSPF相邻信息
    Show ip ospf request-list ;显示链路状态请求列表
    Show ip ospf summary-address ;显示归纳路由的再发布信息文章整理:学网 http://www.xue5.com (本站) [1] [2] [3] [4]

     

    Show ip ospf virtual-links ;显示虚拟链路信息
    Show ip interface ;显示接口的IP设置
    OSPF相关的debug命令:
    Debug ip ospf adj ;
    Debug ip ospf events
    Debug ip ospf flood
    Debug ip ospf lsa-generation
    Debug ip ospf packet
    Debug ip ospf retransmission
    Debug ip ospf spf
    Debug ip ospf tree
    常见的OSPF故障:OSPF的每个area不超过100台路由器,整个网络不超过700台路由器;通配符掩码配置不当;
    七、处理BGP故障
    BGP(包括IBGP和EBGP)的关键配置是邻居关系,BGP使用TCP建立相邻关系。
    BGP相关的show命令:
    Show ip bgp ;显示BGP所学习到的路由
    Show ip bgp network ;显示特定网络的BGP信息
    Show ip neighbors ;显示BGP邻居信息
    Show ip bgp peer-group ;显示BGP对待组信息
    Show ip bgp summary ;显示所有BGP连接的归纳
    Show ip route bgp ;显示BGP路由表
    BGP相关的debug命令:
    Debug ip bgp 192.1.1.1 updates
    Debug ip bgp dampening
    Debug ip bgp events
    Debug ip bgp keepalives
    Debug ip bgp updates
    典型的BGP故障:
    八、再发布路由协议
    九、TCP/IP症状和原因
    症状 原因
    本地主机不能与远程主机通讯 1) DNS工作不正常2) 没有到远程主机的路由3) 缺少缺省网关4) 管理拒绝(ACL)
    某个应用程序不能正常工作 1) 管理拒绝(ACL)2) 网络没有正常配置以处理该应用程序
    启动失败 1) BootP服务器没有MAC地址的实体2) 缺少IP helper-address3) ACL4) 修改NIC或MAC地址5) 重复的IP地址6) 不正常的IP配置
    不能ping远程主机 1) ACL2) 没有到远程主机的路由3) 没有设置缺省网关4) 远程主机down
    缺少路由 1) 没有正确配置路由协议2) 发布列表3) 被动接口4) 没有通告路由的邻居5) 路由协议版本不一致6) 邻居关系没有建立
    相邻关系没有建立 1) 不正确的路由协议配置2) 不正确的IP配置3) 没有配置network或neighbor语句4) hello间隔不一致5) 不一致的area ID
    高的CPU利用率 1) 不稳定的路由更新2) 没有关闭debug3) 进程过重
    路由触发活跃模式 1) 不一致的间隔2) 硬件问题3) 不稳定的链路
    十、TCP/IP症状和行动计划
    问题 行动计划
    DNS工作不正常 1)配置DNS主机的配置和DNS服务器,可以使用nslookup校验DNS服务器的工作
    没有到远程主机的路由 1) 用ipconfig /all检查缺省网关2) 用show ip route查看是否相应路由3) 如果没有该路由,用show ip route查看是否有缺省网关4) 如有网关,检查到目标的下一跳;如无网关,修正问题
    ACL 有分离的问题与ACL相关,必须分析ACL、或重写ACL并应用。
    网络没有配置以处理应用程序 查看路由器配置
    Booting失败 1) 查看DHCP或BootP服务器,并查看是否存在故障机的MAC实体2) 使用debug ip udp校验从主机接收的包3) 校验helper-address正确配置4) 查看ACL是否禁用包
    缺少路由 1) 在第1台路由器上用show ip route查看所学到的路由2)校验相邻路由器3)有正确的路由network和neighbor语句4) 对OSPF,校验通配符掩码5) 检查应用到接口上的distribute list6)验证邻居的IP配置7) 如果路由被再发布,验证度量值8) 验证路由被正常的再发布
    没有构成相邻关系 1) 用show ip protocol neighbors列表已构成的相邻关系2) 查看没有构成相邻关系的协议配置3)检查路由配置中的network语句4)用show ip protocol/interface查看特定的接口信息,如Hello间隔

     

    更多相关内容
  • ping 命令

    千次阅读 2019-12-31 15:28:43
    ping命令是定位网络通不通的一个重要手段。ping是用来探测本机与网络中另一主机之间是否可达的命令,如果两台主机之间ping不通,则表明这两台主机不能建立起连接。 ping 命令是基于 ICMP 协议来工作的,「 ICMP 」...


    ping命令是定位网络通不通的一个重要手段。ping是用来探测本机与网络中另一主机之间是否可达的命令,如果两台主机之间ping不通,则表明这两台主机不能建立起连接。

            ping 命令是基于 ICMP 协议来工作的,「 ICMP 」全称为 Internet 控制报文协议( Internet Control Message Protocol)。ping 命令会发送一份ICMP回显请求报文给目标主机,并等待目标主机返回ICMP回显应答。因为ICMP协议会要求目标主机在收到消息之后,必须返回ICMP应答消息给源主机,如果源主机在一定时间内收到了目标主机的应答,则表明两台主机之间网络是可达的。

    开始->cmd->回车进入DOS命令界面   输入ping -? 查看ping 命令的参数,如下图

     

    ping 命令几种常用返回结果

    1.Request timed out(请求超时)

    可能有以下几种情况

    ①对方主机不存在或已关机

    ②对方确实存在、但设置了ICMP数据包过滤

    ③如何判断对方是否存在:

            可以用带参数 -a的ping命令探测对方,如果能得到对方的主机名,则说明对方是存在的,是有防火墙设置,如果得不到,多半是对方不存在或关机,或不在同一网段内。        

    ④  错误设置IP地址        

             正常情况下,一台主机应该有一个网卡,一个IP地址,或多个网卡,多个IP地址(这些地址一定要处于不同的IP子网)。但如果一台电脑的“拨号网络适配器”(相当于一块软网卡)的TCP/IP设置中,设置了一个与网卡IP地址处于同一子网的IP地址,这样,在IP层协议看来,这台主机就有两个不同的接口处于同一网段内。当从这台主机Ping其他的机器时,会存在这样的问题:

    (a). 主机不知道将数据包发到哪个网络接口,因为有两个网络接口都连接在同一网段。  

    (b). 主机不知道用哪个地址作为数据包的源地址。      

    因此,从这台主机去Ping其他机器,IP层协议会无法处理,超时后,Ping 就会给出一个“超时无应答”的错误信息提示。


    ⑤没有设置网关  

    2.Destination host Unreachable(目标主机不可达) 

            对方与自己不在同一网段内,而自己又未设置默认的路由。这里要说明一下“destination host unreachable”和 “time out”的区别,如果所经过的路由器的路由表中具有到达目标的路由,而目标因为其他原因不可到达,这时候会出现“time out”,如果路由表中连到达目标的路由都没有,那就会出现“destination host unreachable”。

    3.Bad ip address 

    表示可能没有连接到DNS服务器,所以无法解析这个IP地址,也可能是ip地址不存在

    4.Source quench received

    表示对方或中途的服务器繁忙无法回应

    5.Unknown host

    该远程主机的名字不能被域名服务器(DNS)转换成IP地址。故障原因可能是域名服务器有故障,或者其名字不正确,或者网络管理员的系统与远程主机之间的通信线路有故障。  

    6.No answer

    这种故障说明本地系统有一条通向中心主机的路由,但却接收不到它发给该中心主机的任何信息。故障原因可能是下列之一:        

        ① 中心主机没有工作;        

        ② 本地或中心主机网络配置不正确;        

        ③  本地或中心的路由器没有工作;        

        ④通信线路有故障;        

        ⑤中心主机存在路由选择问题等        

    为了有效地找出网络故障的原因,在使用Ping命令进行测试检查时,尽量确保局域网中只配置了一个网关,同时确保本机没有启用IP安全设置策略,这样可以保证Ping命令能够正常运行并获得正确的测试结果。

    通过思科模拟器进行ping命令测试

    (1)首先不设置PC0的网关,进行ping测试,然后再设置上PC0的网关继续测试,结果如下;

    (2)不设置PC1的IP地址进行测试;

    (3)进行ACL限制

    进行测试结果如下;

    总结:ping是一个很重要的命令,能帮助我们分析问题,大家务必掌握。如果不记得参数作用 可以通过 ping -?来查看

               学以致用,多多实践!

     

    展开全文
  • 作为网工简单好用ping命令是我们每天最常用的工具了,它能用来检查网络...ping最常用的就是用来测试与某一主机的连通性,通常我们看到的ping是这个样子的 在windows下ping命令缺省发送4个ICMP包,其中我们常见的三个

    作为网工简单好用ping命令是我们每天最常用的工具了,它能用来检查网络的连通性、延迟、是否丢包等常见的网络问题,有事没事ping一下,为什么不通了?为什么又通了??以及这都能通???是我们每天都要面对的灵魂拷问。但是你真的了解ping吗?今天我们就来带大家了解各种你知道的和你不知道的ping的用法

    ping的基本操作


    ping最常用的就是用来测试与某一主机的连通性,通常我们看到的ping是这个样子的

    在windows下ping命令缺省发送4个ICMP包,其中我们常见的三个值分别是:

          bytes(字节):指的是我们用来测试连通性的ICMP包大小

          time(时间):这个时间指的是目标主机的响应时间

          TTL(Time to Live):TTL在windows下默认设置为128,最大可以设置为255,每经过一跳路由减一,当TTL归零时数据包将会被丢弃

    在实际使用中,根据需要我们可能会希望改变这些值让ping用起来更加的得心应手,于是出现了下面这些命令参数

    1. 让我们来多发几个包(ping -n ping -t)

    ping命令在windows环境下默认只发送4个ICMP包,有时候我们想要测试一下一段时间内会不会出现丢包的情况,总不能一次一次的输入命令吧,又或者我们想知道主机的平均响应时间,只用4个数据包得出的数据是不是不够可靠呢?于是我们可以使用-n命令来指定我们要发送的数据包数量

    可以看到ping根据我们想要的效果发送了10个数据包,并且会自动帮你统计一些数据,如果我们想观察的更久一点,可以使用-t参数让它一直ping,需要停止的话按ctrl+c就可以结束了。

    1. 修改数据包大小以及TTL(ping -l ping -i)

    每天与网络接触的我们什么情况都有可能遇到,有的时候需要大一点的数据包来测试网络,有的时候发现默认的TTL128不够用想要大一点,有的时候又为了测试特殊情况想要TTL小一点,这时候就该-l和-i这两个参数上场了,其中数据包大小最大为65500字节,ttl范围则是1-255。

    1. 根据域名解析ip以及根据ip解析主机名(ping -a)

    ping命令是可以直接ping域名的,这可以帮助我们检查对某一域名是否能成功的进行解析并访问

    但有时我们也可以通过-a参数去检查ip地址,通常会看到其主机名,有时也能反向解析出域名

    1. 利用ping命令追踪路由(ping -r)

    在对ping命令加上-r的参数后可以显示出追踪到的路由

    相对于tracert好处是带有响应时间等参数,缺点是最大只支持9跳,在公网使用的话效果并不理想

    1. 利用for语句避免重复劳动

    想一下假如要测试某个部门几百几千个节点的连通性,一个一个ping简直是枯燥无味又繁重,于是我们可以这样操作

    其中括号内的1,1,255代表从1开始,每次增加1,一直加到255,我们可以根据实际情况更加灵活一点,比如我们想测试偶数ip地址那可以把括号内写成(2,2,254),是不是非常方便好用。

    ping的常见故障提示

    1)request time out这种最为常见,当ping在默认时间内没有收到回复就会报出time out通常可能是没有路由或者没有回包路由造成的,当然诸如一些二层的故障也可能造成这一现象,所以还要根据具体情况进行排查

    2)ttl expired in transit这种情况一般是在传输过程中ttl耗尽导致的,可以通过-i参数增大ttl值后再次进行测试,并考虑网络中是否存在路由环路

    3)destination unreachable目标不可达,这种情况也比较常见,一般是路径中某台设备没有路由或者做了相关的策略,碰到这种回显只需要tracert一下目标地址看看追踪路由在哪里断了,一般就能定位出故障所在

    以上是常见的几种回显,当然ping的回显还有很多,这里整理出来放在下面的表格里供大家参考

    ICMP Type

    CODE

    Description

    Q/E

    0

    0

    Echo reply—ping应答

    Query

    3

    0

    Network Unreachable—网络不可达

    Error

    3

    1

    Host Unreachable—主机不可达

    Error

    3

    2

    Protocol Unreachable—协议不可达

    Error

    3

    3

    Port Unreachable—端口不可达

    Error

    3

    4

    Fragmentation needed but no frag.bit set—需要分片,但不分片置位

    Error

    3

    5

    Source routing failed—源路由失败

    Error

    3

    6

    Destination network unknown—目的网络未知

    Error

    3

    7

    Destination host unknown—目的主机未知

    Error

    3

    8

    Source host isolated –源主机被隔离(已作废)

    Error

    3

    9

    Destination network administratively prohibited—目的网络被强行禁止

    Error

    3

    10

    Destination host administratively prohibited—目的主机被强行禁止

    Error

    3

    11

    Network unreachable for TOS—由于服务类型,网络不可达

    Error

    3

    12

    Host unreachable for TOS—由于服务类型,主机不可达

    Error

    3

    13

    Communication administratively prohibited by filtering—由于过滤通信被强制禁止

    Error

    3

    14

    Host precedence violation—主机越权

    Error

    3

    15

    Precedence cutoff in effect—优先中止生效

    Error

    4

    0

    Source quench—源端被关闭(基本流控)

    展开全文
  • 路由器ping不通.原因众多...现在简单讲以下几点:使用PING判断TCP/IP故障以及Ping命令的使用注意,感兴趣的朋友可以参考下哈,希望对大家有所帮助
  • 查阅本机的网络配置与网络PING命令实现 前言 一、常用网络操作 二、DOS界面 三、 Ipconfig命令 四、Ping命令 五、Tracert命令 结语 前言 在本节中我们主要讲通过DOS页面进行命令操作,分别讲三个命令常用网络命令...


    前言

    在本节中我们主要讲通过DOS页面进行命令操作,分别讲三个命令常用网络命令操作的使用,分别是Ipconfig命令、Ping命令、Tracert命令,另外还会讲自动获取IP地址的方式、改DNS的方式等等。

    一、常用网络操作

    我们通过打开电脑的网络和共享中心,这里点击连接,进入后点击属性。
    在这里插入图片描述
    2、在弹出的对话框中的带选中Internet协议版本4(Tcp/Ipv4)再点击属性,即可在这里修改自动获取IP地址以及修改DNS、设置IP地址,子网掩码,网关等等
    在这里插入图片描述
    3、当我们在下载一些文件或者访问网站时加载不出来或者异常缓慢,这时修改DNS地址就可以解决,即点击使用下面的DNS地址修改DNS服务器地址,输入相应的首选DNS服务器以及备用DNS服务器。
    在这里插入图片描述

    二、DOS界面

    接下来,我们来通过DOS页面,分别讲三个命令常用网络命令操作的使用,这里简单讲下如何进入DOS界面,通过在搜索栏搜索cmd,即可打开DOS界面,进入后我们可以通过命令来执行电脑中的很多操作,或者通过win+r输入cmd直接进入命令提示符。
    在这里插入图片描述
    进入命令提示符:
    在这里插入图片描述

    三、 Ipconfig命令

    利用ipconfig命令可以查看和修改网络中的TCP/IP协议的有关配置。
    1、显示所有适配器的基本TCP/IP配置
    输入ipconfig,然后回车键:
    在这里插入图片描述
    2、显示所有适配器的完整TCP/IP配置
    输入ipconfig /all,然后回车键:
    在这里插入图片描述
    3、其实我们可以通过输入ipconfig /?来获得提示,里面有ipconfig的详细用法。
    在这里插入图片描述

    四、Ping命令

    ping命令是最常用的网络查询工具,主要是用于测试网络的连通性,ping命令是使用ICMP协议简单地发送一个网络包并请求应答,接收请求的目的主机则使用ICMP发回其接收的数据一样的数据,这时ping就对美国包的发送和接收报告往返时间,并报告无响应包的百分比,这在确定网络是否正确连接以及网络连接的状况(丢失率)很有用。
    1、若要不间断的给相邻主机发送数据包
    输入ping -t <相邻主机的IP地址> 然后回车键:
    在这里插入图片描述
    这里我们要知道如何查询主机的IP地址:
    (1)第一种方式,在网络属性里查找,IPV4地址旁边列出的即是IP地址,同时对于以太网网络连接也是一样:
    在这里插入图片描述
    (2)第二种在DOS界面,即刚才的输入ipconfig /all当中寻找IP地址。
    在这里插入图片描述2、向相邻主机发送一定数量以及相应大小的测试包
    输入ping -n <数量> -l <大小> <相邻主机的IP地址> 然后回车键:在这里插入图片描述

    五、Tracert命令

    用tracert命令可以查看网络的可连接性,进一步排查网络异常情况。
    1、跟踪本机网卡地址
    tracert <本机的IP地址> 然后回车键:
    在这里插入图片描述
    这里我们就可以通过这个命令的结果来判断,若跟踪不到或者速度很慢,即检查本地网络连接或网卡的问题。
    2、跟踪本地网关
    输入tracert <本机的局域网默认网关> 然后回车键:
    在这里插入图片描述
    若跟踪不到,则检查局域网连通问题。
    注:默认网关也是使用ipconfig /all查询。
    3、跟踪外网地址
    输入tracert <官网地址> 然后回车键:
    在这里插入图片描述
    这里我们跟踪的是CSDN的官网地址,可以通过tracert来检查internet连通性。

    结语

    以上就是本次计算机网络实验的全部内容,感谢您的阅读和支持,篇幅较长,若有表述以及代码中的不当之处,望指出!您的指出和建议能给作者带来很大的动力!!!

    展开全文
  • cisco路由器ping命令的设置

    万次阅读 2014-04-22 22:02:53
    R1#ping  //开始ping Protocol [ip]:  //协议选择IP Target IP address: 4.4.4.4  //目的IP设置为:4.4.4.4 Repeat count [5]: 1  //重复次
  • Cisco 思科模拟器命令

    千次阅读 多人点赞 2021-10-15 12:35:32
    文章目录基本配置**文件操作****启动配置****接口配置****路由****EIGRP****OSPF****ACL****DHCP****HDLC****PPP****FR****ARP(默认启用)****ISDN****IS-IS...R# logout (或exit) 退出Cisco设备 R# show history 查看
  • (3)用ping命令探测到本地IP软件、本机、网关、互联网上某主机的连通性; (4)用tracert命令查看到达某主机地址的路径情况; (5)用route命令查看本机的静态路由表,试着改变某条,看是否起作用。 实验步骤与...
  • Cisco基本命令配置

    2020-12-20 21:42:49
    实验一 路由器的基本命令操作1 实验目标ü 熟悉路由器的命令行操作ü 能够使用命令行帮助ü 能够查看路由器接口信息ü 能够产看路由器配置信息ü 能够配置以太网接口ü 能够配置广域网接口ü 能够设置路由器安全ü ...
  • 如果用户键入configureterminal或者configt命令就会进入全局配置模式,此时用户可以改变全局参数。要在一个接口上改变一个参数,就要用interface命令进入接口配置模式。从全局模式中,用户可以..
  • 使用ping检测MTU值

    千次阅读 2021-05-15 10:52:27
    Ping是工作在 TCP/IP网络体系结构中应用层的一个服务命令, 主要是向特定的目的主机发送 ICMP(Internet Control Message Protocol 因特网报文控制协议)Echo 请求报文,测试目的站是否可达及了解其有关状态 ...
  • ping和ipconfig命令详解

    2021-08-12 03:31:39
    ping是一个计算机网络工具,用来测试特定主机能否通过IP到达。ping的运作原理是向目标主机传出一个ICMPecho要求封包,等待接收echo回应封包。程序会按时间和反应成功的次数,估计失去封包率(丢包率)和封包来回时间...
  • Cisco Packet Tracer 命令大全基本配置文件操作启动配置密码设置接口配置CDP路由RIPIGRPEIGRPOSPFACLNAT PAT 配置负载分发DHCPHDLCPPPFRARP(默认启用)ISDNIS-ISBGP路由优化异步连接QoS 转载自:...
  • 怎么使用ping命令进行连通性测试

    千次阅读 2018-08-15 10:13:00
    关于ping命令的作用: ping 命令有助于验证网络层的连通性!一般进行网络故障排除时,可以使用ping 命令向目标计算机或IP地址发送ICMP回显请求,目标计算机会返回回显应答,如果目标计算机不能返回回显应答,说明在...
  • cisco PING

    千次阅读 2013-02-28 13:48:20
    Ping命令 Ping是最常使用的故障诊断与排除命令。它由一组ICMP回应请求...Ciscoping命令不但支持IP协议,而且支持大多数其他的桌面协议,如IPX和AppleTalk协议的ping命令。我们首先看一下支持IP协议的ping命令以用
  • Ping 命令的一些参数的介绍以及使用演示。
  • 测试网络连通性的PING命令

    万次阅读 2017-07-11 21:26:58
    本文是对网络连通性测试的常用工具ping命令较为详细的介绍 1. ping命令简介 Ping是因特网包探测器,是使用ICMP回显请求报文和ICMP回显应答报文来测试主机之间连通性,用来诊断网络的工具。  Ping使用的是ICMP回显...
  • 几乎每一名网工及弱电工程师都遇到过网络不通的情况,通常判断标准是以外网连通性及Ping测试得出结果,而ping属于ICMP协议中的一个工具。今天讲一下ICMP个协议。文末为本周福利。兄弟...
  • Ping&Tracert作为链路连通性检测和故障定位的重要手段,适用场景极广,本次课程将选取对SRv6网络进行Ping&Tracert检测的场景,以一个示例为主线,深度解析检测过程,解密报文交互与协议扩展,通过介绍关键命令的使用...
  • Ping命令测试MTU大小

    万次阅读 2011-10-25 15:06:43
    测试本地ISP的MTU大小可以通过简单的Ping命令实现。 如:ping –l 14xx –f www.163.com 参数说明:  * –l 14xx参数:发送一个定长数据包,14xx是要测试的包大小,ADSL的MTU一般在1450与1492之间,在测试过程
  • 用户模式----特权模式,使用命令"enable" 特权模式----全局配置模式,使用命令"config t" 全局配置模式----接口模式,使用命令"interface+接口类型+接口号" 全局配置模式----线控模式,使用命令"line+接口类型+接口号" ...
  • 交换机中ping命令的使用

    万次阅读 2017-01-17 09:39:32
    命令ping [ -a ip-address ] [ -c count ] [ -d ] [ -f ] [ -h ttl ] [ -i interface-type interface-number ] [ ip ] [ -n ] [ - p pattern ] [ -q ] [ -s packetsize ] [ -t timeout ] [ -tos tos ] [ -v ] h
  • 思科命令配置使用方法介绍

    千次阅读 2021-03-22 12:00:26
    的使用说明常用快捷键说明删除命令方法用户模式特权模式全局模式修改设备名称子模式介绍说明接口模式子接口模式acc模式线路(链路)模式路由模式IP地址配置相关命令查看ip配置ip设备接口开关机ICMP协议ping命令说明...
  • 有关计算机网络网络测试命令,包括ipconfig,ping,Netstat,tracert,nslookup,ARP,Telnet
  • 网络命令(ARP、PING)的使用分析

    千次阅读 2021-01-06 20:37:51
    掌握掌握ARP、PING命令的操作使用 二、实验环境 用以太网交换机连接起来的WIN2000操作系统计算机 三、实验内容及步骤: 1、ARP命令的使用 2、PING命令的操作使用 四、实验过程 1、ARP命令 1)arp命令的功能...
  • 思科设备命令大全

    千次阅读 2021-12-14 21:12:48
    模式转换命令 用户模式----特权模式,使用命令"enable" 特权模式----全局配置模式,使用命令"config t" 全局配置模式----接口模式,使用命令"interface+接口类型+接口号" 全局配置模式----线控模式,...
  • Cisco测试命令和TCP/IP连接故障处理 一、故障处理命令 1、show命令: 1) 全局命令: show version ;显示系统硬件和软件版本、DRAM、Flash show startup-config ;显示写入NVRAM中的配置内容 show running-config ...
  • Cisco(1)——ping通两台路由器

    万次阅读 多人点赞 2019-02-27 15:23:29
    实验之前: 路由器的接口名称是自己设置显示出来的,方法: ...options ----> preference ----> 勾选Always Show Port...12.然后ping 路由器0的fa0/0,如图: 此时,两台路由器已经可以进行通信了。。
  • 在配置Cisco路由器时,全局和接口命令的界限是十分明显的。在这种情况下,我们使用“全局”来标识那些不能用于接口调试或者特定的传输介质类型和协议调试的命令。 例如,在2500系列路由器中,就可以使用调试命令分析...
  • 可ssh登录到网络设备,进行ping测试,由于脚本中人性化展示,故暂时支持cisco系统的设备; 欢迎提供宝贵意见! 测试展示: ''' @Description: ssh远程脚本,增加异常处理 @Version: 1.2 @Autor: Jeffery @...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,386
精华内容 3,354
关键字:

思科ping测试命令