精华内容
下载资源
问答
  • 在使用vue ui创建新项目时出现问题: Cannot read property ‘indexOf‘ of undefined 原因分析: 主要是自己的版本太低了,node,npm和vue-cil的版本太低了 查看node版本 node-v 查看npm版本 npm -v 查看vue-...

    问题描述:

    在使用vue ui创建新项目时出现问题:

    Cannot read property ‘indexOf‘ of undefined
    

    原因分析:

    主要是自己的版本太低了,node,npm和vue-cil的版本太低了

    查看node版本
    node-v
    查看npm版本
    npm -v
    查看vue-cil
    vue -V(大写)
    

    解决方案:

    首先重装vue@cil

    npm uninstall vue-cli -g//卸载
    npm install -g @vue/cli//安装
    vue -V//查看vue/cil版本
    

    再创建项目,如果成功就解决了,还创建失败。就是node版本太低了,需要重装node
    重装node

    1. 在控制面板中删除node.js
      若有以下文件则再删除这几个文件
      c://user/xxx/node_models
      c://Program Fiels/nodejs
      c://user/xxx/AppData/Roaming/npm
      c://user/xxx/AppData/Roaming/npm-cache
    2. 在node.js官网下载,下载的是.msi的一个包。下载这个可以自动配置环境变量。如果是下.zip的压缩包,则需自己配置环境变量
    3. 双击下载的安装包,一直点next,安装路径可以自己更改。
      到此下载完成。
    node -v
    npm -v
    //查看是否安装成功
    

    最后再创建项目,就可以了(注意node重装后也要看一下有无vue-cil,没有就安装,不然vue ui指令会运行不了)

    展开全文
  • 参照这个解决方法, vue ui 创建新项目时断开连接.说是当前vue版本过高,需要卸载重装! 查看当前版本 然后卸载重装,然而重装时报错 再输入vue uivue -V,版本信息和浏览器窗口均启动不了了 尝试二 按照...

    问题

    在这里插入图片描述
    在这里插入图片描述

    解决

    尝试一

    参照这个解决方法, vue ui 创建新项目时断开连接.说是当前vue版本过高,需要卸载重装!
    查看当前版本
    在这里插入图片描述
    然后卸载重装,然而重装时报错
    在这里插入图片描述
    在这里插入图片描述
    再输入vue uivue -V,版本信息和浏览器窗口均启动不了了
    在这里插入图片描述

    尝试二

    按照报错提示,在本地文件夹找到D:\nodejs\node_global\node_modules
    在这里插入图片描述
    手动删除@vue文件夹,再次全局安装@vue/cli发现不报错了

    npm install -g @vue/cli
    

    在这里插入图片描述
    再次输入vue -Vvue ui,版本信息和浏览器均启动成功
    在这里插入图片描述

    在这里插入图片描述
    无断开链接提示!!!
    问题解决~

    展开全文
  • 在使用vue ui创建新项目时出现问题Cannot read property ‘indexOf’ of undefined 2、解决方案 可能是vue-cli的版本太低了,先卸载vue-cli,npm uninstall -g @vue/cli,再安装 npm i -g @vue/cli@3.121,亲测vue/...

    1、问题
    在使用vue ui创建新项目时出现问题Cannot read property ‘indexOf’ of undefined
    2、解决方案
    可能是vue-cli的版本太低了,先卸载vue-cli,npm uninstall -g @vue/cli,再安装 npm i -g @vue/cli@3.121,亲测vue/cli@3. 12.1可以正常使用。

    展开全文
  • vue ui创建新vue项目

    千次阅读 2019-11-24 19:17:44
    vue ui创建新vue项目 vue3.0以上才会有vue ui功能 一、创建新vue项目 1.在命令行里面输入vue ui 2.进入创建新项目页面 输入项目名称,填写git初始化提交信息,下一步 3.预设面板 可以选择以前创建过的预设...

    用vue ui创建新的vue项目

    vue3.0以上才会有vue ui功能

    一、创建新vue项目

    1.在命令行里面输入vue ui

    在这里插入图片描述

    2.进入创建新项目页面

    在这里插入图片描述

    输入项目名称,填写git初始化提交信息,下一步

    3.预设面板

    在这里插入图片描述
    可以选择以前创建过的预设,也可以重新手动配置项目,下一步

    4.进入功能面板,选择项目所需要的功能

    在这里插入图片描述
    一定要有Babel和Linter / Formatter(代码格式校验)、使用配置文件,其他根据需要选择,下一步

    5.进入配置面板

    在这里插入图片描述
    第一项,是否选择历史路由,关闭,推荐只用hash方式

    第二项,选中ESLint + Standard config标准配置文件

    第三项,Link on save只要保存,就对所写代码进行格式校验

    6.创建项目,会有弹窗“是否保存为新的预设”

    之后,等待创建项目
    在这里插入图片描述

    二、安装配置Element-ui插件

    选中左侧“插件”,点击“添加插件”
    在这里插入图片描述
    搜索vue-cli-plugin-element插件,然后选择它,安装
    在这里插入图片描述
    配置插件
    在这里插入图片描述
    第一项,想要怎么引入这个组件,默认是引入完整的,可以选择import on demand按需导入

    之后,点击完成安装即可

    三、配置axios库

    选择“依赖”,点击“安装依赖”
    在这里插入图片描述

    安装新的依赖 => 运行依赖 => 搜索axios => 安装
    在这里插入图片描述

    四、前端项目初始化步骤

    • 安装vue脚手架
    • 用过vue脚手架创建项目
    • 配置vue路由
    • 配置Element-ui组件库
    • 配置axios库
    展开全文
  • 在cmd中输入vue ui命令去打开可视化工具创建项目时,在最后一步创建项目所报的错 报错问题分析: vue-cli版本太低,版本出现问题 问题解决方案如下: 1、删除vue-cli之前的版本,在cmd中输入以下的命令: npm ...
  • 在界面上一创建项目终端就报断开连接的错误 查了很久才知道是vue版本过高的原因, 卸载原vue:cnpm uninstall -g @vue/cli 安装指定版本:cnpm install -g @vue/cli@3.11.0 然后就解决了 ...
  • Vue UI 创建项目详细步骤

    万次阅读 2020-04-28 17:12:53
    1.首先要安装最新的Vue CLI 在命令行工具里输入一下命令 npm install -g @vue/cli 或者 yarn global add @vue/cli ...在界面上可以看到第一个tab项目,点击创建这个tab ,可以来创建一个vue项目 ...
  • 就是这个样子, 不管等多久偶不会出现内容的。 换成谷歌浏览器就解决了
  • 好久没有用vue ui 创建项目 1.使用vue ui ,发现没有任何反应 2.使用vue -h 查看帮助,没有发现vue ui 3.查询了一下使用npm i -g @vue/cli,发现报错应该是有相同的文件 4.npm i -g @vue/cli --force 覆盖原来的...
  • vue ui搭建项目返回 vue cli版本@vue/cli 4.5.8和node.js版本v14.17.3
  • 我专门安装的vue脚手架3.3.0版本,然后创建项目时就报错Cannot read property ‘indexOf‘ of undefined; 猜测是npm和vue版本不匹配; 于是卸载vue脚手架,不指定版本重新安装后,再次创建成功; 3.0版本前安装: ...
  • 报错原因 经bug修复后查明是yarn问题,yarn不能使用https://registry.npm.taobao.org源,所以报出了该错误,yarn在安装...前置条件:确保vue-cli,npm,node都是版本,node在8+以上版本 方法一:清除npm缓存 npm cache cl.
  • vue利用vue ui命令创建项目

    万次阅读 多人点赞 2019-03-07 21:29:53
    vue的官方脚手架是vue-cli,但它已经很久没有大版本更新了,最近发布的vue-cli 3.x ,新增的...注意,vue-cli 3.x已经收归到vue项目下了,所以,直接输入 vue -h 可以看到: 此时我们运行命令 vue ui , 就会启动...
  • 创建 - 在此创建新项目 第四步: 第五步: 手动 - 选Babel(js转换器,es5转换Es6)、Router(路由)、LInter/Formatter(代码格式校验)、使用配置文件 - 下一步 第六步: 注意:如果创建项目不成功,报错,就...
  • 创建 - 在此创建新项目 - 输入项目名 预设 - 手动 -babel,vuex,router,css-pre-pro,linter,使用配置文件 第一项关掉,不使用history模式。less,standard-config,link on save 插件 - 添加插件 - vue-cli-...
  • vue ui 创建项目/项目配置修改

    千次阅读 2020-08-24 10:55:52
    vue ui vue ui 会自动打开一个窗口 然后配置修改即可
  • Vue UI 创建并运行前端项目

    千次阅读 2020-02-24 13:59:10
    文章目录1、检查环境2、启动 UI3、使用浏览器访问4、创建5、...vue -V 查看 vue 的版本,使用 Vue UI 是 3.0 加的特性。 C:\Users\Feng>node -v v10.15.1 C:\Users\Feng>vue -V C:\Users\Feng>"node" ...
  • 可能是vuecli的版本过低,先npm uninstall vue-cli -g 删除,然后通过下面命令重新下一个 npm install -g @vue/cli@3.12.1 我原先是3.3.0,换了个3.12.1就没有报错了
  • vue ui 创建项目详细步骤

    千次阅读 2019-12-27 13:28:53
    前提要确保你安装了node和...**首先确保你得vue版本在3.0以上才可以使用vue ui命令创建;** 1、先查看一下版本; vue -V 2、当版本支持,打开cmd命令行输入: vue ui ​ 效果(): 3、然后复制链接地址在浏览...
  • 使用Vue ui创建项目 最近在学习vue前端的东西,一般我创建项目就是命令 vue init webpack project,不过最近接触到了这个 vue ui 感觉挺方便的,目前一直使用的也是它! 这个要使用的话 得看下自己的cli版本是否达到...
  • 使用 vue ui创建项目,但当启动项目时报错如下: This relative module was not found: * ./src/main.js in multi …… 但是通过终端npm run server 命令启动项目项目可以正常启动,通过网上查了很多资料,但是都...
  • vue 项目创建需要node环境,若你的电脑中没有node先行至node官网下载node ,方法不再赘述。 安装vue环境 先新建一个空文件夹,用于创建这个vue项目。然后cmd进入到该目录下。 #下载淘宝源npm包管理工具 #可用...
  • 3.点击在此创建新项目 4.输入项目的名称点击下一步按钮 5.选择手动,点击下一步 6.根据项目的需求勾选,本项目勾选了以下几项 7.点击下一步按钮 8.让你选择模式,如果之前有的话可以选择。第二行选择标准检查...
  • linux使用vue ui 创建vue项目

    千次阅读 2020-03-03 20:07:36
    参考博客
  • 如何使用vue UI创建vue项目

    千次阅读 2020-03-24 18:32:24
    2.在打开的面板中操作,创建新项目 3.选择项目名称已经初始化 4.手动配置也可以选择以前建立的模板(这里我们手动配置) 5.选择 6.选择如图 7.是否创建模板 8.安装插件 9.安装如图插件 10.配置插件 11.安装...
  • 在通过命令行vue ui来通过Element-UI创建vue项目的时候,发现命令行没有任何反应,输入vue -h 查看帮助文档,看是否有 ui这个命令,发现没有,那就应该是版本太低了。 升级脚手架: cnpm i -g @vue/cli 注意:i 是 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 19,773
精华内容 7,909
关键字:

vueui创建新项目

vue 订阅