精华内容
下载资源
问答
  • vue安装scss报错

    2020-07-13 19:16:21
    原因: 安装sass-loader的时候选择低版本,指定安装版本 解决办法: 1.npm install node-sass --save-dev 2.npm install sass-loader@7.3.1 --save-dev 3.npm install style-loader --save-dev

    原因:
    安装sass-loader的时候选择低版本,指定安装版本
    解决办法:
    1.npm install node-sass --save-dev
    2.npm install sass-loader@7.3.1 --save-dev
    3.npm install style-loader --save-dev

    在这里插入图片描述

    展开全文
  • 引入scss 原因:sass-loader版本8过高,将package.json中的sass-loader8改为 “sass-loader”: “^7.3.1”,,删除node_modules,重新npm install ,然后再npm run dev就行

    引入scss

    原因:sass-loader版本8过高,将package.json中的sass-loader8改为 “sass-loader”: “^7.3.1”,,删除node_modules,重新npm install ,然后再npm run dev就行

    展开全文
  • vue 使用scss报错

    2021-01-29 10:19:44
    vue 使用scss报错 安装sass-load和node-sass npm install sass-loader --save-dev npm install node-sass --save 在webpack.base.conf.js中配置好了 然后发现报错了 (node:2532) ...

    vue 使用scss报错


    安装sass-load和node-sass

    npm install sass-loader --save-dev  
    npm install node-sass --save
    

    将vue样式改为scss
    在webpack.base.conf.js中配置好了
    在这里插入图片描述
    然后发现报错了
    报错
    (node:2532) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either byrRunner.js:119:14) throwing inside of an async function without a catch block, or by rejecting a promise which was not handlunner.js:120:4)ed with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandoaderRunner.js:232:2)led-rejections=strict (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 2) m.js:70:14
    (node:2532) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, prom throwing inside of an async function without a catch block, or by rejecting a promise which was not handledise rejections that are not handled will terminate the Node.js process with a non-zero exit code. d-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 2)
    34% building modules 208/209 modules 1 active …tasay-user-center\src\layout\Home.vue

    上网查询后发现是兼容性问题

    安装低版本的sass-load和node-sass即可

    npm install sass-loader@7.3.1 --save-dev  
    npm install node-sass@4.0.0 --save
    

    再次npm run dev即可
    在这里插入图片描述

    展开全文
  • [vue]scss报错

    2020-04-23 23:29:23
    vue安装node-sass编译报错 安装node-scss报错 安装node-scss报错 在搭建vue脚手架 或者是在vue项目中,想使用sass的功能, npm install node-sass --save-dev //安装node-sass npm install sass-loader --...

    vue安装node-sass编译报错

     

    安装node-scss报错

    在搭建vue脚手架 或者是在vue项目中,想使用sass的功能,

    npm install node-sass --save-dev 		//安装node-sass 
    npm install sass-loader --save-dev 		//安装sass-loader 
    npm install style-loader --save-dev 		//安装style-loader
    

    安装完成后,运行时出现了错误

    Modele build failed: TypeError: this.getResolve is not a function at Object.loader...
    

    这是因为当前sass的版本太高,webpack编译时出现了错误,这个时候只需要换成低版本的就行,下面说一下修改方法,很简单,如下,找到package.json文件,里面的 "sass-loader"的版本更换掉 就行了。

    我本地是将    "sass-loader": "^8.0.0",更换成了 "sass-loader": "^7.3.1",
    

    这时候重新跑项目,就运行成功了。

    也可以先卸载当前版本,然后安装指定的版本

     

    卸载当前版本   npm uninstall sass-loader
    安装     npm install sass-loader@7.3.1 --save-dev
    

     

    展开全文
  • Vuescss 报错

    2021-04-13 11:06:27
    错误原因来自sass-loader,node-sass@latest为v5.0.0,而sass-loader期望值为^4.0.0不相符合。 解决方案: //先卸载当前node-sass npm uninstall node-sass //在安装指定合适版本 npm install node-sass@4.14.1
  • 安装 node-sass 以及 sass-loader npm install node-sass npm intall sass-loader
  • 在搭建vue脚手架 或者是在vue项目中,想使用sass(scss)的功能,报错Module ... 参考: vue使用scss报错Module build failed: TypeError: this.getResolve is not a function at Object.loader 安装node-sass运行报错
  • vue中引入scss报错的问题

    千次阅读 2020-01-06 23:57:10
    正常我们都是在项目中直接安装scss的 npm install style-loader sass-loader node-sass --save-dev 以前安装了less是需要手动去配置的,然后就在在webpack.base.conf.js的rules中添加了 { test:...
  • 在style 使用lang="scss"报错 原因:node-sass 和sass-loader不匹配,版本问题 解决方法:在安装node-sass和sass-loader指定版本 npm install node-sass@4.9.2 --save-dev npm install sass-loader@7.3.1 --save-...
  • 报错信息: in ./src/assets/styles/global.scss Syntax Error: TypeError: this.getOptions is not a function 1.sass版本太高了,需要回退版本,把已经安装的版本卸载,重新安装安装如下 cnpm inode-...
  • node-scss报错

    2019-12-25 16:25:51
    安装node-scss报错 在搭建vue脚手架 或者是在vue项目中,想使用sass的功能, Modele build failed: TypeError: this.getResolve is not a function at 。。。。。。。。。。。。 这是因为当前sass的版本太高,...
  • 1.安装sass依赖 npm install --save-dev sass-loader //sass-loader依赖于node-sass npm install --save-dev node-sass 如果运行之后项目报错 Module build failed: TypeError: this.getResolve is not a function ...
  • vue 安装scss

    2020-09-18 14:45:38
    1、在执行npm run dev时报错: Syntax Error: _schema-utils@2.7.1@schema-utils\dist\util\hints.js:16 const current...2、解决上了上面报错,出现新的报错; Module build failed: TypeError [ERR_INVALID_ARG
  • 1、确定已经安装了node-sass / sass-loader /sass-resources-loader 2、node版本过高引起的sass-loader 报错(no such file or directory) 执行:npm rebuild node-sass 3、解决上边问题依然报错Make sure '...
  • 近期写vue项目遇到scss报错,查了上午,看了各种网友的解决方案,在此,我找到了适合自己的解决方案,因为之前直接安装的sass版本过高,如果是vue2建议:npm install sass-loader@7.3.1 --save 当然前提是要安装node...
  • 若尚未安装先参考这条链接安装和引用SCSS https://blog.csdn.net/xiasohuai/article/details/86615454 若已安装 查看下面问题 以及对应解决方法 问题1 TypeError [ERR_INVALID_ARG_TYPE]: The “path” argument ...

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 169
精华内容 67
关键字:

vue安装scss报错

vue 订阅