python3.5 安装python3-tk

在python3.5下安装好matplotlib后,准备显示一张图片测试一下,但是控制台报错说需要安装python3-tk,我天真的以为直接:


sudo apt-get install python3-tk
就可以了呢。但是不行,说是找不到对应的资源。我就开始各种百度,谷歌,网上各种帖子,依然没有解决我的问题。后来找到一个python3-tk的安装包,deb格式的。我以为这样就行了呢,开始执行:

sudo dpkg -i .....deb
发现它依赖blt,这是什么鬼,不管了,先安装再说。这又各种不行,各种依赖。就这样被折腾了好几个小时,几乎要怀疑人生了。回到最初的起点,呆呆的望着那个错误。我心里突然泛起一丝涟漪,不是说匹配不到对应的资源吗?那我就给你换一下源,我就战战兢兢的把清华的镜像源换成了ubuntu自带的源,然后更新源。就这样,更新了大约3分钟,突然在我眼前弹出一个框框,几乎让我哭出来的框框,python3-tk。我点击启动没反应,我以为就这样放弃了呢。
还是在命令行里面再试一次把


sudo apt-get install python3-tk
提示我运行一下
sudo apt-get install -f 
当我再次运行程序的时候,我亲爱的图片竟然出现在我眼前。苍天啊,幸好我没有放弃。
其实解决办法很简单,

1、换源

2、更新 sudo apt-get update

3、sudo apt-get install python3-tk

4、sudo apt-get install -f

就这样。上一下显示出来的图:


 

点击阅读全文
该词条是否帮您解决问题?
X