热门好课推荐
猜你喜欢
相关培训 相关博客
  •     最近开发需要用到qgis,首先根据网上的教程把RelWithDebInfo版本编译出来了,用了好大劲,终于编译debug版本成功,记录一下遇到的关键问题。编译QCA   由于qgis编译用到OSGeo4w,而其中提供的库都是release的,直接编译debug版本的qgis,在运行qgis.exe时会在程序QCA相关函数中崩溃,因此我先编译了QCA的debug版本,用来替换编译qgis时...
    2018-07-10 15:33:04
    阅读量:885
    评论:0
  • 使用栅格图层图层详细信息栅格图层一般包含一个或多个波段,即单波段栅格图层或多波段栅格图层。一般来说彩色图形包含红、蓝、绿三个波段。单波段图层一般用来表示连续变量(如高程)或离散变量(如土地利用)。在有些情况下,栅格图层包含一个调色板,栅格值对应的颜色会存储在调色板中,下面代码获取栅格图层的基本信息,例如长度、宽度、范围波段数、元数据等等。rlayer.width(),rlay
    2015-08-12 10:48:41
    阅读量:1734
    评论:0
  • 前段时间由于工作需要,学习使用Python为qgis制作一个插件,现在把制作插件期间遇到的问题和解决方法记录下来,以方便自己和其他朋友.
    2017-06-01 23:24:37
    阅读量:2442
    评论:0
  • 一、参考李民录老师:http://blog.csdn.net/liminlu0314/article/details/17400075JacoryGao:http://blog.csdn.net/deirjie/article/details/48216773QGIS官网:https://htmlpreview.github.io/?https://raw.github
    2018-01-28 12:03:33
    阅读量:4942
    评论:13
  • QGIS中的python3和pyqt5国庆期间我们的C++老师布置了在windows上编译qgis的作业,自然过程是非常的艰难的了,其中在cmake项目的时候,遇到发现是缺少sip和pyqt5的问题按照QGIS的官网链接:https://htmlpreview.github.io/?https://raw.github.com/qgis/QGIS/master/doc/
    2017-10-08 12:26:19
    阅读量:1426
    评论:0
  • 1、产生这个问题的原因是当前工程是Debug版本,而引用的库文件时Release版本,只需要把当前的Debug模式改成Release模式就可以了,或者打开解决方案–》属性–》链接器–》输入–》附加依赖项中引用debug版本的lib文件名称。2、release下,在库版本匹配没有问题。但是编译报错error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“...
    2019-03-11 10:15:29
    阅读量:129
    评论:0
  • 1、http://www.qgis.org/en/site/forusers/download.html# 安装OSGeo4W Network Installer (根据系统位数自行选择)2、运行安装文件,依次选择Advanced Install => Install from Internet => 选择安装路径 => 选择安装包存储路径 => Direct Connection =
    2017-07-18 09:53:54
    阅读量:670
    评论:0
  • qgis二次开发(c++篇)    之前的文章中提到用python+pyqgis做qgis二次开发,经过多方面探索,最终还是放弃了这个方案,我要做的并不是一个插件,而是一个偏重地图预览的application。放弃python的主要原因还是因为资料不多,pyqgis的掌握难度比较大。c++方式就不一样了,有qgis工程的源码可以参考,说白了还是学习成本。
    2015-06-09 19:56:28
    阅读量:3347
    评论:0
  • 1、下载软件首先向大家声明一下,我本来打算用最新的PyQt5+Python3.6+Pycharm2017.3+QGIS2.14来完成插件开发,但当我把PyQt5、QGIS-OSGeo4W-2.14.17-1-Setup-x86_64.exe安好之后,在Pycharm中配置时突然发现,QGIS2.14中自带有PyQt4和Python2.7,又考虑到有人说PyQt5不太稳定,故最后决定先用PyQt
    2018-01-11 14:16:06
    阅读量:1772
    评论:5
  • 1、下载CMake 2.8 (http://www.cmake.org/),安装到指定路径,例如:C:\GNU\CMake2.8,在环境变量PATH中添加C:\GNU\CMake2.8\bin。 2、下载GNUWin32 flex 2.5(http://gnuwin32.sourceforge.net/packages/flex.htm) 和GNUWin32bison 2.4 (http:
    2014-04-12 22:39:16
    阅读量:7742
    评论:1