远程管理_远程管理卡 - CSDN
精华内容
参与话题
  • 推荐三款最佳的远程桌面管理工具

    千次阅读 2020-06-11 17:14:52
    远程桌面是微软公司为了方便网络管理管理维护服务器而推出的一项服务。从windows 2000 server版本开始引入,网络管理员使用远程桌面连接程序连接到网络任意一台开启了远程桌面控制功能的计算机上,就好比自己操作...

    远程桌面是微软公司为了方便网络管理员管理维护服务器而推出的一项服务。从windows 2000 server版本开始引入,网络管理员使用远程桌面连接程序连接到网络任意一台开启了远程桌面控制功能的计算机上,就好比自己操作该计算机一样,运行程序,维护数据库等。
    远程桌面采用的是一种类似TELNET的技术,它是从TELNET协议发展而来的,通俗的讲远程桌面就是图形化的TELNET。
    下面向大家介绍三款最佳的远程桌面工具。

    1:IIS7服务器管理工具

    产地:中国
    在这里插入图片描述
    在这里插入图片描述
    iis7服务器管理工具下载地址:http://yczm.iis7.com/?ccxd

    2. Teamviewer

    在这里插入图片描述
    Teamviewer是最佳的远程桌面工具之一,使用它可以轻松连接到全球任意一台PC或服务器上,目前大约有2亿用户在使用Teamviewer。
    TeamViewer是一个能在任何防火墙和NAT代理的后台用于远程控制,桌面共享和文件传输的简单且快速的解决方案。为了连接到另一台计算机,只需要在两台计算机上同时运行 TeamViewer 即可,而不需要进行安装(也可以选择安装,安装后可以设置开机运行)。该软件第一次启动在两台计算机上自动生成伙伴 ID。只需要输入你的伙伴的ID到TeamViewer,然后就会立即建立起连接。
    Teamviewer面向个人使用是免费的,但会弹出烦人的广告。

    3. Splashtop

    在这里插入图片描述

    Splashtop是一款简单易用且性能优秀的远程桌面工具,它的用户已经超过1600万,被公认为是高效率和高性能的工具。甚至可以远程流畅看电影、玩游戏,并且跨平台支持Win、Mac、Linux等系统,甚至是诸如iOS、Android等移动系统。它包含服务端Streamer和客户端Remote Desktop两部分。

    1)Streamer是Splashtop公司旗下的一款主打产品,是远程控制的服务器端,用于接受远程控制,目前支持:Mac OS X、WindowsXP/Vista/Win7和Windows 8和Linux等操作系统。

    2)Remote Desktop是远程桌面的客户端,用于控制装有Streamer的电脑。它除了支持Streamer服务端所支持的全部系统之外,还支持主流的iOS、Android、WebOS、Blackberry等系统。

    Splashtop工具分个人版、商业版、企业版等,其中个人版免费。

    展开全文
  • 远程管理服务ssh

    2020-06-17 19:23:15
    实验环境:centos7.6,2G内存,50G硬盘大小,虚拟机服务端ip:172.16.1.61 客户端ip:172.16.1.7,172.16.1.741,172.16.1.41 SSh服务连接工作原理 1)客户端主动向服务端发起连接请求 2)服务端接收到信息后,将自己的公钥(/...

    实验环境:centos7.6,2G内存,50G硬盘大小,虚拟机服务端ip:172.16.1.61 客户端ip:172.16.1.7,172.16.1.41,172.16.1.31

    SSh服务连接工作原理

    1)客户端主动向服务端发起连接请求
    2)服务端接收到信息后,将自己的公钥(/etc/ssh/ssh_host_ed25519_key.pub)发送给客户端
    3)客户端会提示你是否(yes/no)连接,当输入yes后
    4)客户端将服务端发过来的公钥进行存储,放在/root/.ssh/known_hosts
    5).客户端将私钥与服务端发过来的公钥进行整合,生成密钥对,并发送给服务端
    6).服务端收到客户端发过来的密钥对,用自己的私钥解密,此时加密完成,并告诉客户端可以连接了
    7)客户端输入连接服务端的密码,然后连接

    SSH远程连接方式:

    a.基于口令的方式连接,密钥对只能完成数据加密过程,连接麻烦,还不安全
    b.基于密钥的方式连接,密钥对可以完成身份认证过程,连接方便,比较安全

    基于密钥的方式连接原理:

    1)客户端 执行命令创造密钥对
    2)客户端 建立远程连接(口令),发送公钥信息
    3)客户端 再次建立远程连接
    4)服务端 发送公钥质询信息
    5)客户端 处理公钥质询信息,将信息返回给服务端
    6)服务端 收到确认信息,建立连接

    SSH实现基于密钥连接的部署步骤

    1)客户端创建密钥对信息:

    ssh-keygen -t dsa
    

    在这里插入图片描述
    rsa只是其中一种加密方式,还有以下几种对密钥进行加密的方式
    在这里插入图片描述
    创建成功之后可以看到在/root/.ssh/目录下面多出了两个文件
    在这里插入图片描述
    2)客户端分发公钥:

    ssh-copy-id -i /root/.ssh/id_dsa.pub root@172.16.1.41
    ssh-copy-id -i /root/.ssh/id_dsa.pub root@172.16.1.31
    ssh-copy-id -i /root/.ssh/id_dsa.pub root@172.16.1.7
    

    在这里插入图片描述
    3)远程连接测试:ssh 172.16.1.41
    可以看到连接成功了
    在这里插入图片描述
    4)编写脚本进行批量分发公钥

    vim ssh_copy.sh
    #!/bin/bash
    for ip in 7 31 41
    do
    	ssh-copy-id -i /root/.ssh/id_dsa.pub root@172.16.1.$ip
    done
    

    优化

    1.免交互,进行公钥分发

    1)安装软件

    yum -y install sshpass
    

    2)执行免交互式发送公钥命令

    sshpass -p123456 ssh-copy-id -i /root/.ssh/id_dsa.pub root@172.16.1.31 
    

    在这里插入图片描述
    3)连接时不用输入yes/no

    sshpass -p123456 ssh-copy-id -i /root/.ssh/id_dsa.pub root@172.16.1.31 "StrictHostKeyChecking=no"
    

    4)当端口发生改变时的连接方式
    sshpass -p123456 ssh-copy-id -i /root/.ssh/id_dsa.pub root@172.16.1.31 -p 1314 “StrictHostKeyChecking=no”

    5)可以用过ssh不用登上查看其它服务器就能直接看到信息
    在这里插入图片描述
    在这里插入图片描述

    SSH服务配置文件:/etc/ssh/sshd_config,里面重要的几个参数说明

    Port 22 --修改服务端口信息
    ListenAddress --监听地址,指定一块网卡能够接受远程访问连接请求,只能是本地网卡上有的地址
    PermitEmptyPasswords no --是否允许远程用户使用空密码登陆,默认不允许
    PermitRootLogin yes/no --是否禁止root用户远程连接主机,建议no,不禁止
    GSSAPIAuthentication --会对IP地址继续反解析,导致连接较慢,不用的时候关闭
    UseDNS no --是否开启反向DNS解析功能,建议关闭

    SSH远程连接服务设置安全防范措施

    1.采用密钥登陆,密钥登陆更安全
    2.禁止root用户进行远程登陆,在上面的配置文件中,设为PermitRootLogin no
    3.更改服务端口,改为自己知道的端口。在配置文件中的Port修改
    4.防火墙关闭ssh,禁止外网连接,只允许内网,在配置文件中设置监听的ip地址,ListenAddress

    scp用法说明

    用法:
    scp [参数] [原路径] [目标路径]
    从本地复制到远程:

    scp -rp 1.txt root@172.16.1.41:/home/1.txt
    

    从远程复制到本地:

    scp -rp root@172.16.1.41:/home/1.txt 1.txt
    

    参数说明:

    参数 作用
    -C 允许压缩。(将-C标志传递给ssh,从而打开压缩功能)
    -p 保留原文件的修改时间,访问时间和访问权限
    -q 不显示传输进度条
    -r 递归复制整个目录
    -v 详细方式显示输出。scp和ssh(1)会显示出整个过程的调试信息。这些信息用于调试连接,验证和配置问题。
    -i --identity_file 从指定文件中读取传输时使用的密钥文件,此参数直接传递给ssh。
    -l --limit 限定用户所能使用的带宽,以Kbit/s为单位。
    P --port 注意是大写的P, port是指定数据传输用到的端口号

    sftp用法说明

    1.连接:sftp ip地址
    2.指令说明

    指令 说明
    ls 查看远程ftp服务器信息
    cd 查看远程ftp服务器信息
    pwd 查看当前服务器的路径
    lls 查看本地ftp客户端信息
    lcd 查看本地ftp客户端信息
    lpwd 查看远程服务器的路径
    get 下载信息,从远程服务器,下载到本地
    put 上传信息,从本地服务器上传到远程
    help 查看命令帮助
    bye 退出ftp连接

    在这里插入图片描述

    展开全文
  • telnet远程管理

    2019-04-30 23:17:43
    telnet远程管理 问题 在企业中为方便网络管理员对Cisco设备的配置,一般需事先在Cisco交换机及路由器上开启远程管理的服务,借助网络通过telnet方式远程访问。 方案 网络管理员通过telnet方式远程管理S1、R1、S2,...

    telnet远程管理

    问题

    在企业中为方便网络管理员对Cisco设备的配置,一般需事先在Cisco交换机及路由器上开启远程管理的服务,借助网络通过telnet方式远程访问。

    方案

    网络管理员通过telnet方式远程管理S1、R1、S2,网络拓扑如图所示。
    在这里插入图片描述
    本例中的配置练习采用思科模拟器 —— Cisco Packet Tracer 6.0来实现。

    步骤

    实现此案例需要按照如下步骤进行。

    步骤一:Telnet远程访问思科交换机、路由器

    1)配置交换机S1的管理IP

    S1(config)#interface vlan 1
    S1(config-if)#ip address 192.168.1.2 255.255.255.0    //交换机管理IP
    S1(config-if)#no shutdown
    

    2)开启S1的telnet远程管理服务

    S1(config)#line vty 0 4
    S1(config-line)#password 123      //远程管理的密码
    S1(config-line)#login 
    

    3)配置用户模式进入特权模式的密码(明文或密文之一)

    S1(config)#enable password 456
    

    4)按图-1所示的IP配置PC1的IP地址,PC1通过telnet方式远程管理S1

    PC>telnet 192.168.1.2
    Trying 192.168.1.2 ...Open
    User Access Verification
    Password:                   //输入远程管理密码123      
    S1>en
    S1>enable 
    Password:                  //输入用户模式进入特模式密码456
    S1#                         //通过telnet方式登录到S1的特权模式
    

    步骤二:PC1远程管理R1

    1)配置路由器R1的接口IP
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip address 192.168.1.254 255.255.255.0
    R1(config-if)#no shutdown 
    R1(config-if)#exit
    R1(config)#interface fastEthernet 0/1
    R1(config-if)#ip address 192.168.2.254 255.255.255.0
    R1(config-if)#no shutdown 
    2)开启R1的telnet远程管理服务
    R1(config)#line vty 0 4
    R1(config-line)#password 123      //远程管理的密码
    R1(config-line)#login 
    

    3)配置用户模式进入特权模式的密码(明文或密文之一)

    R1(config)#enable password 456
    

    4)PC1通过telnet方式远程管理R1

    PC>telnet 192.168.1.254
    Trying 192.168.1.254 ...Open
    User Access Verification
    Password:                   //输入远程管理密码123      
    R1>en
    R1>enable 
    Password:                  //输入用户进入特模式密码456
    R1#                         //通过telnet方式登录到R1的特权模式
    

    步骤三:PC1远程管理S2

    1)配置交换机S2的管理IP

    S2(config)#interface vlan 1
    S2(config-if)#ip address 192.168.2.2 255.255.255.0    //交换机管理IP
    S2(config-if)#no shutdown
    S2(config-if)#exit
    S2(config)#ip default-gateway 192.168.2.254 //不同网段主机远程管理需给交换机配置网关地址
    

    2)开启S2的telnet远程管理服务

    S2(config)#line vty 0 4
    S2(config-line)#password 123      //远程管理的密码
    S2(config-line)#login 
    

    3)配置用户模式进入特权模式的密码(明文或密文之一)

    S2(config)#enable password 456
    

    4)PC1通过telnet方式远程管理S2

    PC>telnet 192.168.2.2
    Trying 192.168.2.2 ...Open
    User Access Verification
    Password:                   //输入远程管理密码123      
    S2>en
    S2>enable 
    Password:                  //输入用户模式进入特模式密码456
    S2#                         //通过telnet方式登录到S2的特权模式
    
    展开全文
  • Linux(三)远程登录管理工具

    万次阅读 2018-05-01 02:22:26
    远程登录管理工具,是为了不需要去到电脑面前操作毕竟如果有上百台服务器,怎么可能一台一台的去操作.所以有必要用一台电脑,连接上不同的服务器操作会更方便要用远程登录,自然要先设置好网络首先打开虚拟机,这是我安装...

    远程登录管理工具,是为了不需要去到电脑面前操作

    毕竟如果有上百台服务器,怎么可能一台一台的去操作.

    所以有必要用一台电脑,连接上不同的服务器操作会更方便

    要用远程登录,自然要先设置好网络


    首先打开虚拟机,这是我安装好第一次启动的画面,默认启动图形化桌面


    先右键装好的Linux系统,选设置

    然后弹出虚拟机设置窗口

    .

    网络链接中有三种模式

    桥接,NAT,仅主机模式


    桥接模式:利用物理机的网卡,与本地物理机或其他物理机或虚拟机组成局域网,会占用网段,局域网内计算机过多时容易出现ip冲突(重叠),类似于教室实验,学校局域网中,会容易出现ip冲突,自己一个人使用不会有问题.


    NAT模式:该模式利用虚拟出来的网卡:VMnet8,仅仅与本地物理机组成局域网,不占用真实网段ip,还可以访问互联网


    仅主机(Host-only)模式:该模式利用虚拟出来的网卡:VMnet1,仅仅与本地物理机组成局域网.



    现在选仅主机模式

    然后在物理机系统里打开VMnet1网卡,查看ip

    我发现打开网卡属性,查看ipv4地址是看不到ip地址的


    所以要鼠标右击VMnet1网卡,点菜单里的状态,再点详细信息,就可以看到ip地址了

        

    然后在Linux里,如果是命令界面可以直接输入ifconfig    该命令是查询网卡信息

    如果是桌面则鼠标右击桌面空处打开终端,然后输入ifconfig

    出现2个网卡信息,Io网卡是指回环IP,所有操作系统都有

    如果你向这个ip发送数据等于给自己发送数据,一般用于测试

    eth0是第1块网卡信息,我这个发行版的Linux在开机的时候已经自动分配了ip

    但咱们还是要试一下自己分配ip

    有必要说清楚一点,物理机Windows中的虚拟网卡是用于与虚拟机中的Linux网卡连接的

    它们两是互相独立,属于于各自系统的,仅仅是连接使用,所以它俩的ip要在同一网段,但不能相同


    现在手动设置一下Linux中的网卡ip地址

    windows中的网卡ip为192.168.70.1

    Linux中最后的1改为2就ok,其实只要同网段,主机地址不相同就行了


    现在用window系统ping一下Linux的ip地址测试一下是否能连通

    先按win键(田字键)+R键,再输入cmd,打开命令提示符,输入ping 192.168.70.2

    ping命令是windows系统专门用来测试双方网络连接是否连通

    也可以直接ping网址,比如建好网站时可以直接ping网址做测试

    ok,连接成功~测试ping网址



    现在用桥接模式


    如果勾上,那么,虚拟机联网状态与物理机相同,

    物理机能联网,则虚拟机也能联网,物理机不能联网,虚拟机也不能连

    如果没勾上,则物理机与虚拟机联网状态是互相独立不关联.

    先查看一下windows中的物理网卡ip地址


    再看一下Linux中的ip地址

    这时Linux的ip地址并没变,因为没有内置更改联网模式时重新申请ip

    如果手动更改ip的话,会有概率导致ip冲突而无法联网,所以最好还是重新申请分配ip

    而且,手动更改ip地址仅仅只是临时更改

    要彻底更改还需要修改配置文件,不过联网的ip一般都是分配的,并不是每次都相同

    命令为:service network restart

    重新分配后,Linuxip地址为


    然后用虚拟机随便上一个网站


    ok了,虚拟机可以联网

    再用物理机ping一下虚拟机


    也可以连上.

    还有如果是使用笔记本在用有线网情况下选择桥接模式

    虚拟机还是不能联网,那可能是桥接到没联网的无线网卡去了,可以点击编辑


    现在使用的是桥接模式,当然是VMnet0了,然后在桥接那里选择桥接到某个网卡

    因为我使用的是台式机,所以不会有桥接出错的情况

    至于选择哪个,去百度翻译吧,毕竟每个品牌机用的网卡牌子都不同


    好了,现在可以使用远程链接管理工具了,但远程链接管理工具有很多,并不限定要用哪个,只要能连上就ok

    这是下载地址

    http://down.pc141.com:801/down/securcrt.pc141.com.rar


    打开后点左上角文件,在弹出的菜单中选择快速链接,然后在主机名输入虚拟机ip地址点链接,然后点接受并保存

    这时填登录用户名和密码,实际生产中不建议直接用root登录,某些发行版也禁止远程使用root登录,但我们现在是在学习,所以可以使用


    ok,登录成功,在这上面输入任何命令与在Linux里输入命令是同样效果,包括关机与重启


    试一下,查询ip地址,一模一样,如果修改ip地址的话,会马上断掉链接,因为是在使用远程连接


    还有一点,如果Linux中有中文传过来,在管理工具上显示可能是乱码,只需要修改一下管理工具的编码方式就ok


    点击选项,选会话选项


    选择外观,再点字体


    然后再修改字符集为中文GB2312

    字符编码选择utf-8


    然后按住Ctrl+L清屏

    再输入df,就没有乱码了,乱码的根本原因是因为使用的字符集和编码表不同


    还有一个用于Linux与windows之间文件传输的工具

    win是Windows的缩写,scp是Linux中传输文件的命令


    这个是官方网站的下载连接,有中文版

    https://cdn.winscp.net/files/WinSCP-5.13.1-Setup.exe?secure=4y7NFdI2-TBgNpqT5Mx3rQ==,1525112133

    然后登录操作与上一个软件差不多

    登录之后画面是这样


    左边是Windows,右边是Linux,要将什么文件传到哪个系统,直接拖过去就ok

    而且是加密传输

    好了远程管理工具基本就是这样,还有其他管理工具,这里就不介绍了

    展开全文
  • 4.远程管理

    2019-07-08 20:47:25
    1.远程管理 通常指的是远程管理服务器,服务器通常放置在机房中,用户无法直接接触到服务器硬件,只能采用远程管理的方式。 远程管理,实际上就是计算机之间通过网络进行数据传输的过程,就像计算机在浏览器浏览...
  • 远程管理

    2019-06-12 19:59:25
    实验01:配置远程管理实验目标:通过客户端可以远程管理路由器和交换机实验环境:在cisco模拟器上选择两台PC机,一台路由器,两台交换机实验步骤:一.配置PC0IP地址和网关:二、配置交换机1的地址,网关以及远程管理...
  • 远程管理(上)

    2019-06-13 09:59:50
    我们都在现实生活中,难免求助别人来远程管理自己的计算机,而他们所使用的一般有三种方法:首先是通过telnet远程登录管理你的计算机,也就是所谓的DOS命令的使用啦。其次是通过图形界面来连接你的计算机,到达双方...
  • 远程管理卡介绍&使用场景

    千次阅读 2017-09-02 16:17:08
    远程管理卡是安装在服务器上的硬件设备,提供一个以太网接口,使它可以连接到局域网内,提供远程访问。这种远程管理基于BMC(底板管理控制器),由集成在管理卡上的系统微处理器负责监测和管理操作系统之外的服务器...
  • windows10远程桌面的快捷方式设置

    万次阅读 2019-11-29 14:34:15
    一、推荐一款第三方的windows远程管理工具 二、使用windows自带远程桌面为快捷方式 一、推荐一款好用的第三方的windows远程管理工具 iis7远程桌面连接工具,又叫做iis7远程桌面管理软件,是一款绿色小巧,功能...
  • RDO(Remote Desktop Organizer)远程桌面工具,帮助你管理...Remote Desktop Organizer是一款 Windows 远程桌面管理软件,让你在同一个窗口内浏览到多个远程桌面的信息,方便 Windows 远程管理。 下载地址: ht...
  • 这台服务器的配置是远程管理的默认远程桌面模式,这允许最多两个用户同时进行远程
  • 任务管理器使用组合键Ctrl+Alt+End,于是打开了远程电脑的任务管理器,取消,即可返回桌面正常显示。
  • [160]八款最佳的远程桌面工具

    万次阅读 2020-06-30 21:23:58
    远程桌面是微软公司为了方便网络管理管理维护服务器而推出的一项服务。从windows 2000 server版本开始引入,网络管理员使用远程桌面连接程序连接到网络任意一台开启了远程桌面控制功能的计算机上,就好比自己操作...
  • 1下载 Windows6.1-KB958830-x64-...2安装后,在控制面板运行“打开或关闭Windows功能”,钩选“远程服务器管理工具->角色管理工具->远程桌面服务工具”,确定,等安装完成,运行tsmmsc.msc即可打开远程桌面工具。
  • 一、CTRL + ALT + DEL 调出任务管理器 二、CTRL + ALT + END 调出服务器的快捷菜单,选“启动任务管理器” 三、从任务管理器中选择“进程”标签,找到“explorer.exe”进程,结束该进程。 四、切换到“应用...
  • 最近多名网友反应阿里云云服务器ECS Windows Server 2012 R2 标准版 64位中文版无法使用远程桌面登录并提示“远程桌面由于以下原因之一无法连接到远程计算机;1)未启用对服务器的远程访问;2)远程计算机已关闭;3...
  • Windows Server2012多远程桌面配置

    万次阅读 2018-04-13 20:48:41
    一、配置相关信息1、win+R--》输入gpedit.msc--》计算机配置--》管理模板--》windows组件--》远程桌面服务--》远程桌面会话主机--》连接2、将远程桌面服务限制到单独的远程桌面会话禁用3、启用拒绝将已登录到控制台...
  • 由于计算机与远程服务器之间设置端口防护,阻断了远程连接默认的3389端口,出现以下问题,需要修改远程连接端口: 1、登录远程连接服务器,修改注册表。 1):开始->附件->运行 / 或 快捷键win+R...
  • 1、RemoteDesktopManager(需要安装) ... 2、Remote Desktop Organizer (免安装) ...不需要安装,配置好连接信息后,可直接在本软件内连接远程桌面,域可为空。 3、Remote Desktop Connection Manager (需...
  • 一.安装window 2008 R2操作系统,将计算机加入到域中,并...4.下一步,分别选择远程桌面会话主机、远程桌面授权、远程桌面连接代理、远程桌面web访问 5.下一步,应用程序兼容性提示 6.下一步,身份证验证方法
1 2 3 4 5 ... 20
收藏数 638,335
精华内容 255,334
关键字:

远程管理