python安装教程linux_linux python安装教程 - CSDN
精华内容
参与话题
  • Linuxpython3详细安装教程

    千次阅读 2018-08-31 18:59:27
    Python3.7安装: 下载安装包: wget https://www.python.org/ftp/python/3.7.0/Python-3.7.0.tgz  安装编译器: yum -y install gcc gcc-c++ 安装python3依赖: yum -y install zlib-devel bzip2 bzip2-devel ...

    Python3.7安装:

    1. 下载安装包:

    wget https://www.python.org/ftp/python/3.7.0/Python-3.7.0.tgz

    1.  安装编译器:

    yum -y install gcc gcc-c++

    1. 安装python3依赖:

    yum -y install zlib-devel bzip2 bzip2-devel readline-devel sqlite sqlite-devel openssl-devel xz xz-devel

     

    python3.7以上版本还需安装此依赖

    yum -y install libffi-devel

    1. 安装:

    tar -zxvf Python-3.7.0.tgz

    cd Python-3.7.0/

    ./configure --prefix=/usr/local/python3

    (将python3安装到/Usr/local/python3路径下) 

    make && make install

    创建软连接:

    ln -s /usr/local/python3/bin/python3.7 /usr/bin/python3
    ln -s /usr/local/python3/bin/pip3 /usr/bin/pip3

    (以上两个ln命令是为了方便在终端中直接使用python3和pip3命令)

    欢迎大家,加入我的微信公众号:代码帮 

    同时,大家可以关注我的个人博客:

    https://blog.csdn.net/ITLearnHall

    http://www.cnblogs.com/IT-LearnHall/

    人生苦短,我愿分享。本公众号将秉持活到老学到老学习无休止的交流分享开源精神,汇聚于互联网和个人学习工作的精华干货知识,一切来于互联网,反馈回互联网。

    目前研究领域:大数据、机器学习、深度学习、人工智能、数据挖掘、数据分析。 语言涉及:Java、Scala、Python、Shell、Linux等 。同时还涉及平常所使用的手机、电脑和互联网上的使用技巧、问题和实用软件。 只要你一直关注和呆在群里,每天必须有收获

    对应本平台的讨论和答疑QQ群:大数据和人工智能(总群)(779809018)

    微信公众号(代码帮)每天分享最新IT、大数据和人工智能新技术

    展开全文
  • linux安装python详细步骤

    万次阅读 2018-07-24 17:04:55
    一、安装python 1.下载安装包:https://www.python.org/ftp/python/2.7.13/Python-2.7.13.tgz 2.安装python [root@localhost mnt]# tar -xvzf Python-2.7.13.tgz [root@localhost mnt]# cd Python-2.7.13 [root...

    一、安装python

    1.下载安装包:https://www.python.org/ftp/python/2.7.13/Python-2.7.13.tgz

    2.安装python

    [root@localhost mnt]# tar -xvzf Python-2.7.13.tgz

    [root@localhost mnt]# cd Python-2.7.13

    [root@localhost Python-2.7.13]# ./configure --prefix=/usr/local/python27

    checking build system type... x86_64-unknown-linux-gnu

    checking host system type... x86_64-unknown-linux-gnu

    checking for --enable-universalsdk... no

    checking for --with-universal-archs... 32-bit

    checking MACHDEP... linux2

    checking EXTRAPLATDIR...

    checking for --without-gcc... no

    checking for gcc... no

    checking for cc... no

    checking for cl.exe... no

    configure: error: in `/mnt/Python-2.7.10':

    configure: error: no acceptable C compiler found in $PATH

    See `config.log' for more details

    如上,出错了,解决方法:安装gcc

    配置好本地yum源后,安装gcc

    [root@localhost yum.repos.d]# yum install gcc

    继续安装python

    [root@localhost Python-2.7.10]# ./configure --prefix=/usr/local/python27

    [root@localhost Python-2.7.10]# make && make install

    参考文档

    https://docs.python.org/2/using/unix.html

     

     

    二、安装pip

    pip下载地址

    https://pypi.python.org/pypi/pip

    安装pip

    [root@localhost mnt]# tar -xvzf pip-7.1.0.tar.gz

    [root@localhost mnt]# cd pip-7.1.0

    [root@localhost pip-7.1.0]# ls

    AUTHORS.txt  docs         MANIFEST.in  pip.egg-info  README.rst  setup.py

    CHANGES.txt  LICENSE.txt  pip          PKG-INFO      setup.cfg

    [root@localhost pip-7.1.0]# python setup.py install

    .....

    参考连接:

    https://pip.pypa.io/en/latest/installing.html

    三、安装robotframework

    robotframework下载地址:

    https://pypi.python.org/pypi/robotframework

    安装robotframework

    [root@localhost mnt]# chmod 777 robotframework-2.9.tar.gz

    [root@localhost mnt]# tar -xvzf robotframework-2.9.tar.gz

    [root@localhost mnt]# cd robotframework-2.9

    [root@localhost robotframework-2.9]# python setup.py install

    ……

    查看是否安装成功

    [root@localhost robotframework-2.9]# pybot --version

    Robot Framework 2.9 (Python 2.6.6 on linux2)

    [root@localhost robotframework-2.9]#

    参考连接:

    http://robotframework.org/robotframework/latest/RobotFrameworkUserGuide.html#python-installation

    问题:robotframework都安装到哪里了?

    [root@localhost robotframework-2.9]# find / -name robot

    /usr/lib/python2.6/site-packages/robotframework-2.9-py2.6.egg/robot

    /mnt/robotframework-2.9/src/robot

    /mnt/robotframework-2.9/build/lib/robot

    http://robotframework.org/robotframework/latest/RobotFrameworkUserGuide.html

    四、安装robotframework-selenium2library

    robotframework-selenium2library下载地址

    https://pypi.python.org/pypi/robotframework-selenium2library/

    [root@localhost mnt]# chmod 755 robotframework-selenium2library-1.7.3.tar.gz

    [root@localhost mnt]# tar -xvzf robotframework-selenium2library-1.7.3.tar.gz

    [root@localhost mnt]# cd robotframework-selenium2library-1.7.3

    [root@localhost robotframework-selenium2library-1.7.3]# python setup.py install

     

     

    Downloading https://pypi.python.org/packages/source/d/docutils/docutils-0.12.tar.gz#md5=4622263b62c5c771c03502afa3157768

     

    error: MD5 validation failed for docutils-0.12.tar.gz; possible download problem?

    出错了,咋办?解决方法:按提示,下载并安装docutils

    docutils下载地址

    https://pypi.python.org/pypi/docutils/

    https://pypi.python.org/packages/source/d/docutils/docutils-0.12.tar.gz

    1.安装docutils

    [root@localhost mnt]# chmod 755 docutils-0.12.tar.gz

    [root@localhost mnt]# tar -xvzf docutils-0.12.tar.gz

    [root@localhost docutils-0.12]# python setup.py install

    继续安装robotframework-selenium2library

    [root@localhost mnt] cd robotframework-selenium2library-1.7.3

    [root@localhost robotframework-selenium2library-1.7.3]# python setup.py  install

    ……

    /usr/lib/python2.6/site-packages/robotframework_selenium2library-1.7.3-py2.6.egg

    Processing dependencies for robotframework-selenium2library==1.7.3

    Searching for selenium>=2.32.0

    Reading http://pypi.python.org/simple/selenium/

    到这里可能是网络原因,又卡住了,解决方法:

    2.下载并安装selenium

    selenium下载地址

    地址1:https://pypi.python.org/simple/selenium/

    地址2:https://pypi.python.org/pypi/selenium/

    安装selenium

    [root@localhost mnt]# tar -xvzf selenium-2.47.1.tar.gz

    [root@localhost mnt]# cd selenium-2.47.1

    [root@localhost selenium-2.47.1]# python setup.py  install

    3.继续安装robotframework-selenium2library

    [root@localhost mnt]# cd robotframework-selenium2library-1.7.3

    [root@localhost robotframework-selenium2library-1.7.3]# ls

    build          demo         LICENSE.txt  README.rst              setup.py

    BUILD.rst      dist         MANIFEST.in  selenium.bmp            src

    CHANGES.rst    doc          PKG-INFO     SELENIUM_COPYRIGHT.txt

    COPYRIGHT.txt  INSTALL.rst  README       setup.cfg

     

    [root@localhost robotframework-selenium2library-1.7.3]# python setup.py install

    ……

    Using /usr/lib/python2.6/site-packages/selenium-2.47.1-py2.6.egg

    Finished processing dependencies for robotframework-selenium2library==1.7.3

    4.检测Selenium2Library是否安装成功

    [root@localhost robotframework-selenium2library-1.7.3]# python

    Python 2.6.6 (r266:84292, Nov 22 2013, 12:16:22)

    [GCC 4.4.7 20120313 (Red Hat 4.4.7-4)] on linux2

    Type "help", "copyright", "credits" or "license" for more information.

    >>> import Selenium2Library

    >>>

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    在安装过程中出现如下错误:

    ImportError: No module named setuptools

     

     

    [root@localhost MySQL-python-1.2.5]# python setup.py install

     

    Traceback (most recent call last):

     

    File "setup.py", line 7, in <module>

     

    import setuptools

     

    ImportError: No module named setuptools

     

    字面意思是:没有setuptools的模块,说明python缺少这个模块;

     

    解决方法如下:

    下载setuptools包

     

    #  wget http://pypi.python.org/packages/source/s/setuptools/setuptools-0.6c11.tar.gz

     

    解压setuptools包

     

    # tar -xvf setuptools-0.6c11.tar.gz

     

    # cd setuptools-0.6c11

     

    编译setuptools

     

    # python setup.py build

     

    开始执行setuptools安装

     

    # python setup.py install

     

    安装完成;

     

     

    Python错误:No module named setuptools 解决方法

    在安装过程中出现如下错误:

    [root@localhost MySQL-python-1.2.5]# python setup.py install

    Traceback (most recent call last):

    File "setup.py", line 7, in <module>

    import setuptools

    ImportError: No module named setuptools

    字面意思是:没有setuptools的模块,说明python缺少这个模块;

    解决方法如下:

    下载setuptools

    #  wget http://pypi.python.org/packages/source/s/setuptools/setuptools-0.6c11.tar.gz

    解压setuptools

    # tar -xvf setuptools-0.6c11.tar.gz

    # cd setuptools-0.6c11

    编译setuptools

    # python setup.py build

    开始执行setuptools安装

    # python setup.py install

    安装完成;

     

    Linux下安装oracle

     

    1.确认oracle-instantclient的basic、sqlplus、devel是否已按照成功

    2./etc/profile 中是否配置正确(类似下列指令)

    ORACLE_HOME="/usr/lib/oracle/12.1/client64"
    PATH=$PATH:$ORACLE_HOME/bin
    export PATH      
    LD_LIBRARY_PATH=$ORACLE_HOME/lib:/usr/lib:/usr/local/lib
    export LD_LIBRARY_PATH

    特别是export PATH (这一句不能少)

    3.使用sudo权限安装cx_Oracle

    如果实在不行,可去官网下载源码,自行编译安装

    下载linux oracle

    http://www.oracle.com/technetwork/database/enterprise-edition/downloads/index.html

    cc:zhengjialiang@htsc.com,b

    安装路径/usr/lib/oracle

     

    http://www.jb51.net/article/53769.htm

     

     

    6)创建相关用户和组,作为软件安装和支持组的拥有者。

    创建Oracle用户和密码,输入命令:

    ?

    1

    2

    3

    useradd -g oinstall -g dba -m oracle

     

    passwd oracle

     

    展开全文
  • Linuxpython3.7.0安装

    千次阅读 2019-03-08 18:13:51
    一、linux安装Python步骤 1、安装依赖包 1)首先安装gcc编译器,gcc有些系统版本已经默认安装,通过 gcc --version 查看,没安装的先安装gcc,yum -y install gcc,由于本人的linux系统中已经安装了,出现了下面...

    一、linux下安装Python步骤

    1、安装依赖包
    1)首先安装gcc编译器,gcc有些系统版本已经默认安装,通过  gcc --version  查看,没安装的先安装gcc,yum -y install gcc,由于本人的linux系统中已经安装了,出现了下面界面。


    2、下载python3.7.0源码,根据需求下载
    1)在https://www.python.org/ftp/python/中选择自己需要的python源码包,我下载的是python3.7.0

    cd /usr/local/
    mkdir Python     //创建一个文件夹用于存放下载的python3压缩包
    wget https://www.python.org/ftp/python/3.7.0/Python-3.7.0.tgz   //linux下载python3.7.0指令

    3、解压python3.7.0压缩包

    tar -zxvf Python-3.7.0.tgz

    4.、建立一个空文件夹py3_project,用于存放python3程序

    mkdir /usr/local/Python/py3_project

    5、执行配置文件,编译,编译安装

    cd Python-3.7.0
    ./configure --prefix=/usr/local/python3   //配置
    make && make install   //编译并且安装

    安装完成没有提示错误便安装成功了。但是,可能由于操作原因,执行完第5步,发现出现如下错误:

    6、果然发现自己少执行了一步骤:还需要安装其他依赖包,主要是openssl-devel依赖包(注:不要缺少,否则有可能安装python出错,python3.7.0以下的版本可不装 libffi-devel ),安装openssl-devel时,zlib-devel会作为依赖包被安装。所以安装了openssl-devel就不需要安装其他的了!直接安装openssl-devel:(注意,如果觉得zlib-devel 还不够,还可以把其他依赖包全部安装,执行指令是:yum -y install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel libffi-devel[/code),现在先只是安装openssl-devel:

    yum -y install openssl-devel

    出现了如下错误,因为本人没有安装“yum”,执行指令apt-get install yum 安装

    apt-get install yum
    

    7、安装好openssl-devel依赖包之后,再一次执行配置文件,编译,编译安装

    ./configure --prefix=/usr/local/python3   //配置
    make && make install   //编译并且安装

    二、建立软连接

    ln -s /usr/local/python3/bin/python3.7 /usr/bin/python3
    ln -s /usr/local/python3/bin/pip3.7 /usr/bin/pip3

    三、测试安装的Python是否可用

    输入python3,如果出现以下内容说明已经安装成功!

    [root@mini Python-3.7.0]# python3
    Python 3.7.0 (default, Jul 28 2018, 22:47:29) 
    [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)] on linux
    Type "help", "copyright", "credits" or "license" for more information.
    >>> print("hello world!")
    hello world!
    >>> exit()
    [root@mini Python-3.7.0]# pip3 --version     //如果还没有安装,会出现提示如何安装的命令
    pip 10.0.1 from /usr/local/python3/lib/python3.7/site-packages/pip (python 3.7)
    

    到此,可以看到python可以正确使用了。

    总结:注意要暗账其他依赖包的步骤,本人爱一次安装python失败就是因为忽略了那一个步骤,从而导致的失败。

     

    感谢:https://www.jb51.net/article/144740.htmhttps://blog.csdn.net/weixin_39220472/article/details/81914592

     

    展开全文
  • Linuxpython安装教程

    2019-04-28 23:20:18
    现在虚拟机中大多已经支持python环境了,如Ubuntu从13.04版本之后已经内置python2和python3的环境了,默认是python2,如果要修改为python3,可以参考这个链接:... 1.打开虚拟机终端,查看是否安装python,已及python...

    现在虚拟机中大多已经支持python环境了,如Ubuntu从13.04版本之后已经内置python2和python3的环境了,默认是python2,如果要修改为python3,可以参考这个链接:https://blog.csdn.net/qq_40808154/article/details/89252883

    1.打开虚拟机终端,查看是否安装了python,已及python版本信息:

    python2 --version
    python3 --version

    2.如果未安装,输入下面命令即可安装(虚拟机需要联网):

    sudo apt-get install python 3.5

     

    展开全文
  • Windos系统下安装python教程:https://my.oschina.net/happyran/blog/3080168 Mac os x系统下安装python教程:https://my.oschina.net/happyran/blog/3080187 【安装环境】 操作系统:...
  • linux安装python3和pip3

    万次阅读 多人点赞 2018-08-27 18:14:27
    linux系统(centos、redhat等)自带python2和pip,现在的Python新手一般从python3开始学习,偶尔又要用到python2,所以要python2和python3共存。现在网上这种教程多的是,本人根据网上教程走了太多的弯路,所以记录...
  • linux安装python3.5

    万次阅读 2017-09-10 10:56:35
    Linux下默认系统自带python2.6的版本,这个版本被系统很多程序所依赖,所以不建议删除,如果使用最新的Python3那么我们知道编译安装源码包和系统默认包之间是没有任何影响的,所以可以安装python3和python2共存。...
  • Python 3.5安装教程

    万次阅读 2016-07-23 10:00:52
    因为Python是跨平台的,它可以运行在Windows、Mac和各种Linux/Unix系统上。在Windows上写Python程序,放到Linux上也是能够运行的。 要开始学习Python编程,首先就得把Python安装到你的电脑里。安装后,你会得到...
  • 手把手教你在Linux环境下安装Python3

    万次阅读 多人点赞 2020-03-03 11:39:34
    在上一篇文章《手把手教你启用Win10的Linux子系统(超详细)》我们已经学了如何在Win10环境下装Linux子系统了,那么这一篇文章我们将学习如何在该Linux系统下安装Python3。 首先是按Win+R键调出cmd命令窗口,然后...
  • Linux安装Python2.7

    千次阅读 2019-07-07 22:03:50
    Linux安装Python2.7 以下例子基于python 2.7.16,其他版本同理。# 1、下载python# wget https://www.python.org/ftp/python/2.7.16/Python-2.7.16.tgz 2、解压、编译安装(依次执行以下5条命令)# tar -zxvf Python-...
  • Python安装: 1)下载Python。主页上有两个版本,我下载的是2.7这个版本(很费解的是,Python的官网必须通过翻墙软件才能访问,太不解了) 2)解压后,在该目录下依次运行以下命令即可安装: a) ./...
  • linux安装pip

    万次阅读 2018-12-28 15:07:24
    通过脚本安装 curl ...python get-pip.py 通过Linux软件包安装 其他版本linux安装pip教程 Debian/Ubuntu Python 2: sudo apt install python-pip Python 3: sudo apt install pyth...
  • Python零基础入门教程 2.安装python3.8

    万次阅读 2020-08-19 10:51:36
    安装python3.8 前言 windows安装python3.8 linux安装python3.8 mac安装python3.8 使用docker安装python3.8 总结
  • Linux系统安装python3.7以及pip

    万次阅读 2019-06-16 16:58:12
    1.在官网下载python3.7的压缩包https://www.python.org/downloads/source/ 2.然后通过XFTP丢到服务器上去 一般是/usr/local/xxx 3.cd 到新建的python3文件夹中 进行解压 tar -xvf xxx 4.cd 到解压完的文件中 ...
  • Linux+Python3+Tensorflow安装教程

    千次阅读 2019-05-07 20:01:40
    Linux+Python3+Tensorflow安装教程 本篇文章介绍如何在linux安装python3以及tensorflow。 系统:Ubuntu16.04 Python:3.5 准备工作 检查一下你的python版本,一般系统默认安装python2版本,鄙人觉得愿意用3...
  • linux安装python3.8开发环境

    千次阅读 2019-08-15 09:52:33
    转发质量博客,仅供学习参考,源自自博客园,原文地址: ...欢迎在评论区指出错误,我将及时修改,...环境: linux 版本:python3.8 1、依赖包安装 yum -y install zlib-devel bzip2-devel openssl-devel ncurses-devel...
  • Ubuntu16.04下安装python3.6详细步骤及anaconda安装详解

    万次阅读 多人点赞 2018-11-06 20:00:02
    最近在廖雪峰老师的网站上学习python,开始用的是Windows环境,但是越往后发现用Linux或许更好一些,环境搭建什么的比较方便,但是对于很少用Linux的同学来说,Linuxpython安装或许会出现各种令人抓狂的问题,本文...
  • Python开发环境的安装配置

    万次阅读 2019-05-07 11:35:24
    要学习Python,我们首先要安装配置好Python的运行环境。 那么安装Python 2 还是 Python 3 呢? 当然是要选择Python 3 。这里来教大家安装稳定版Python3 的版本是Python 3.7.1。 废话不多说,来整! 下面我分操作...
  • linux环境安装python3.7

    千次阅读 2018-12-21 21:47:48
    我用的是linux centos 6 1 首先安装依赖包,确认gcc是否安装,可以用查看: gcc --version   2.如果没有则进行安装,需要sudo权限:yum -y install gcc  3.安装其他依赖包(可以不安装,但是可能会安装过程...
  • python安装教程

    万次阅读 多人点赞 2018-06-07 15:44:54
    Python安装教程一、博主自言随着人工智能的快速发展,python语言越来越受大家的欢迎,博主前段时间先自学了一次,这次再次巩固,顺便分享给大家我遇到的坑。帮助大家学习的时候少走弯路。希望会对大家有所帮助,欢迎...
1 2 3 4 5 ... 20
收藏数 71,271
精华内容 28,508
关键字:

python安装教程linux