2018-09-28 15:46:08 qq_41927909 阅读数 335
  • 微信支付开发-微信公众号开发12-微信开发php

    微信公众平台开发之微信支付开发是子恒老师《微信公众平台开发》视频教程的第12部。详细讲解了用php进行微信支付的开发。内容包含获取支付密钥,微信公众号支付开发,扫码支付,微信刷卡支付,异步处理支付结果等等。欢迎反馈,微信/QQ:68183131

    27840 人正在学习 去看看 秦子恒

以我的Fedora27为例
ubuntu可以借鉴 linux安装微信开发工具
需要修改步骤:

一、下载项目

git clone https://github.com/cytle/wechat_web_devtools.git

二、进入目录

cd wechat_web_devtools

三、安装wine

fedora安装wine请点这里
在这里插入图片描述

一定要首先添加自己系统版本号的仓库地址再安装稳定版本的包
dnf config-manager --add-repo https://dl.winehq.org/wine-builds/fedora/27/winehq.repo
dnf install winehq-stable

四、自动下载最新 nw.js , 同时部署目录 ~/.config/微信web开发者工具/

./bin/wxdt install

五、修改nwjs版本号

使用以上步骤必须修改版本号,否则会导致微信开发者工具启动闪退
修改wechat_web_devtools目录下的nwjs_v 文件,将0.24.4更改为0.31.3

六、运行

./bin/wxdt
在这里插入图片描述

2017-07-07 14:47:26 byc233518 阅读数 2966
  • 微信支付开发-微信公众号开发12-微信开发php

    微信公众平台开发之微信支付开发是子恒老师《微信公众平台开发》视频教程的第12部。详细讲解了用php进行微信支付的开发。内容包含获取支付密钥,微信公众号支付开发,扫码支付,微信刷卡支付,异步处理支付结果等等。欢迎反馈,微信/QQ:68183131

    27840 人正在学习 去看看 秦子恒

上次是重装了解决了卡顿的问题;

总不能过几天就重装一次啊!

更不能忍受现在这样一点一卡, 一键一卡!

找遍菜单也没找到任何有用的选项!

开始解决:

0. 关闭微信web开发者工具;

1. 打开 finder, 按下 shift + command + G , 输入 ~/资源库


2. 找到 下面几个文件夹, 删掉这几个东西:

    Application Support --> 微信web开发者工具
   Preferences -->com.tencent.wechat.devtools.plist
   Caches -->微信web开发者工具

3. 重新打开吧

2019-07-20 12:30:56 qq_44149053 阅读数 658
  • 微信支付开发-微信公众号开发12-微信开发php

    微信公众平台开发之微信支付开发是子恒老师《微信公众平台开发》视频教程的第12部。详细讲解了用php进行微信支付的开发。内容包含获取支付密钥,微信公众号支付开发,扫码支付,微信刷卡支付,异步处理支付结果等等。欢迎反馈,微信/QQ:68183131

    27840 人正在学习 去看看 秦子恒

安装微信开发者工具时报错:依赖关系不满足:wine

安装时报错:依赖关系不满足:wine,安装版本如下:

微信开发者版本

解决

在这里插入图片描述

安装时,提示依赖关系未被配置,暂时先不看,继续执行下面的命令:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install wine

提示未能满足的依赖关系,跳出提示,按提示的命令继续执行

安装过程报错

sudo apt --fix-broken install

安装依赖

以上执行完毕之后,安装完成
安装完成

2019-03-20 09:35:55 qq_39533392 阅读数 49
  • 微信支付开发-微信公众号开发12-微信开发php

    微信公众平台开发之微信支付开发是子恒老师《微信公众平台开发》视频教程的第12部。详细讲解了用php进行微信支付的开发。内容包含获取支付密钥,微信公众号支付开发,扫码支付,微信刷卡支付,异步处理支付结果等等。欢迎反馈,微信/QQ:68183131

    27840 人正在学习 去看看 秦子恒

其几天老师让我去负责微信方面的接入工作,这不是为难我王某人吗!!!

没办法,现在需要硬着头皮装微信开发者工具。

直接用的github上的一个教程。链接:https://github.com/cytle/wechat_web_devtools

因为我的电脑之前为了装微信和qq,安装过deepin-wine环境,所以在我安装微信开发者工具时,遇到了如下报错。

此问题的解决办法为:sudo apt-get install libgconf-2-4,问题即可解决。

启动./wxdt

-------------------------------------------------------------------4/14更----------------------------------------------------------------------------------------------------------最近试用这个软件遇到的问题有:1、./wxdt一直都会有报错,但是我影响使用;2、模拟器不显示东西,我尝试卸载重装也不行;3、编译按钮点击没有反应。

解决的办法是:sudo apt install wine-stable下载了400多M的wine,然后解决了问题2和问题3。

建立快捷方式的方法为:执行./bin/install_desktop.sh。

2018-07-31 11:02:38 HD2killers 阅读数 1590
  • 微信支付开发-微信公众号开发12-微信开发php

    微信公众平台开发之微信支付开发是子恒老师《微信公众平台开发》视频教程的第12部。详细讲解了用php进行微信支付的开发。内容包含获取支付密钥,微信公众号支付开发,扫码支付,微信刷卡支付,异步处理支付结果等等。欢迎反馈,微信/QQ:68183131

    27840 人正在学习 去看看 秦子恒

安装 wine和winetricks

sudo pacman -S wine winetricks

打开winetricks,安装需要的组件
安装linux版本运行程序
github

# 下载
git clone https://github.com/cytle/wechat_web_devtools.git
# 安装(下载一个大文件,安装时可能会出现异常error,ctrlC停止就行)
cd wechat_web_devtools
./bin/wxdt install
# 运行
./bin/wxdt
没有更多推荐了,返回首页