2009-03-27 13:54:00 weixin_30467087 阅读数 3
  • 【直通华为HCNA/HCNP系列R篇3】路由器接口配置与管理

    全面介绍华为新一代企业路由器——AR G3系列路由器各种接口,特别是各种主要的WAN接口以及其对应的各种WAN技术的配置与管理方法。课程中,通过大量实验、示例直观地向大家演示了这些复杂的WAN接口和技术在各种WAN应用连接中的具体配置方法,真正做到了“拿来即用”。

    25061 人正在学习 去看看 王达

        使用Linux系统路由器的用户现在需要当心了,因为一款专门针对Linux系统路由器的新木马病毒出现了,这个木马病毒将能够获得对路由器的控制权。

        根据网站vnunet.com的报道,这款名为“psyb0t”的木马病毒首先由DroneBL公司的研究人员发现的,并且很有可能在年初的时候就已经开始了传播。 

        该木马病毒可以对基于RISC MIPS芯片采用Linux系统路由器的密码进行暴力破解,据DroneBL介绍目前至少已经有超过10万台路由器遭到了感染。 

        如果用户设置的密码安全性不高,或者仍然保持出厂设置并未进行改变,那么就会让该木马找到可乘之机。DroneBL建议用户在设置路由器密码的时候尽量复杂一些。 

        在感染了该木马病毒之后,控制者将能够通过IRC通道获得对路由器完整的控制权,并且可以拦截使用者的相关用户名、密码信息等。另外该木马还能够阻止路由器进行Firmware升级。

专门针对Linux系统路由器的新木马病毒

转载于:https://www.cnblogs.com/top5/archive/2009/03/27/1423150.html

2010-09-27 18:09:00 qc20042 阅读数 12218
  • 【直通华为HCNA/HCNP系列R篇3】路由器接口配置与管理

    全面介绍华为新一代企业路由器——AR G3系列路由器各种接口,特别是各种主要的WAN接口以及其对应的各种WAN技术的配置与管理方法。课程中,通过大量实验、示例直观地向大家演示了这些复杂的WAN接口和技术在各种WAN应用连接中的具体配置方法,真正做到了“拿来即用”。

    25061 人正在学习 去看看 王达

假设现有三台计算机

A计算机有三块网卡 eth0: 192.168.1.125 连接到Internet。 eth1:192.168.2.1 。 eth2:192.168.3.1。

B计算机 ip:192.168.2.120 默认网关:192.168.2.1

C计算机 ip:192.168.3.114 默认网关:192.168.3.1

 

现在B、C计算机要以A计算机ip为网关上网,并实现B、C网段之间的访问,A计算机相当于实现路由器功能。

 

A计算机配置:

$/sbin/ifconfig eth0 192168.1.125 netmask 255.255.255.0

$/sbin/ifconfig eth1 192168.2.1 netmask 255.255.255.0

$/sbin/ifconfig eth2 192168.3.1 netmask 255.255.255.0

不过开机重启后这些配置信息会丢失,所以添加到文件保存,如eth0的配置信息添加到/etc/sysconfig/network-scripts/ifcfg-eth0

 

# Networking Interface
DEVICE=eth0
HWADDR=00:0C:29:D3:7D:7C
ONBOOT=yes
IPADDR=192.168.1.125
BOOTPROTO=none
NETMASK=255.255.255.0
DNS2=202.96.128.68
TYPE=Ethernet
GATEWAY=192.168.1.1
DNS1=202.96.134.133
NM_CONTROLLED=yes
IPV6INIT=no
USERCTL=yes
PREFIX=24
NAME="my eth0"
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03

 

eth1和eth2类似添加

 

添加完这些后添加路由表

#/sbin/route add -net 192.168.1.0 netmask 255.255.255.0 dev eth0

#/sbin/route add -net 192.168.2.0 netmask 255.255.255.0 dev eth1

#/sbin/route add -net 192.168.3.0 netmask 255.255.255.0 dev eth2

 

使用命令查看路由表

#route

Kernel IP routing table
Destination     Gateway         Genmask    Flags Metric Ref    Use Iface
192.168.3.0     *               255.255.255.0   U     0      0            0 eth1
192.168.2.0     *               255.255.255.0   U     1      0            0 eth2
192.168.1.0     *               255.255.255.0   U     1      0            0 eth0

 

这时候还需要添加默认网关,也就是计算机A连接到网络的路由器:192.168.1.1

#route add default gw 192.168.1.1

#route

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.3.0     *               255.255.255.0           U     0      0        0 eth1
192.168.2.0     *               255.255.255.0           U     1      0        0 eth2
192.168.1.0     *               255.255.255.0           U     1      0        0 eth0
default         192.168.1.1     0.0.0.0                 UG    0      0        0 eth0

 

打开转发ip转发功能

echo 1 >/proc/sys/net/ipv4/ip_forward

或者

sysctl -w net.ipv4.ip_forward = 1

可以在命令中使用,也可以为了自动化加入rc.local中


计算机BC配置

B:ip address:192.168.2.120 mask:255.255.255.0 default gateway:192.168.2.1

c:ip address:192.168.3.120 mask:255.255.255.0 default gateway:192.168.3.1

DNS自己根据当地网络设置

 

B计算机:

ping 192.168.2.1

ping 192.168.3.1

ping 192.168.1.125

这三个应该没什么问题,继续

ping 192.168.3.114

ping 192.168.1.1

发现还是不通


查看A计算机的iptables

iptables -L

Chain INPUT (policy ACCEPT)

...

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited

 

ok, we find it! 看来iptable中转发被阻止了,删除这个组织规则就可以了

iptables -D FORWARD 1

OK!现在BC应该可以联网了

 

当然笔者在此还遇到了其他的问题,最后需求帮助得知输入如下信息

iptables -t nat -A POSTROUTING -o eth0 -s 192.168.2.0/24 -j MASQUERADE
iptables -t nat -A POSTROUTING -o eth0 -s 192.168.3.0/24 -j MASQUERADE

or

iptables -t nat -A POSTROUTING -o eth0 -s 192.168.2.0/24 -j SNAT --to 192.168.1.125
iptables -t nat -A POSTROUTING -o eth0 -s 192.168.3.0/24 -j
SNAT --to 192.168.1.125

自己分析下

nat,这个表被查询时表示遇到了产生新的连接的包

POSTROUTING链表存放修改准备出去的包

-o eth0 表示修改后的数据包由接口eth0送出

SNAT: 这个目标只适用于nat表的POSTROUTING链。它规定修改包的源地址

到此目标linux路由器配置完成了!

欢迎各位留意讨论

 

下面对为什么要进行伪装做分析:

利用之前网上看到的一个例子:

两个客户机想通信,要求网关都之指新做的这台路由上,可是在一些情况下做不到。这时可以用地址伪装实现。
比如我做了一台新linux路由器,这时他可以与其它科室的一台机可以通信(因为我的新linux路由器一块网卡与其在一个网段嘛),我的另一台客户机通过我做的新linux路由在另一个网段。这时如果我能把其它科室的机器与我的机器网关都设成我的新linux路由器就可以通信了,可是没有这种权限啊!!!
我可以在新linux路由器上通过地址伪装得以实现。
如果实现我可以访问他,他不能访问我可以这么做:
iptables -t nat -A POSTROUTING -o eth0 -s 你的IP地址段/子网掩码表示 -j MASQUERADE
如果实现他可以访问我,可以加上:
iptables -t nat -A POSTROUTING -o eth1 -s 他的IP地址段/子网掩码表示 -j
MASQUERADE
原理及分析:
如果我没有做地址伪装时,我的数据包通过了新的linux路由器,转发到了他的机器,可是因为我的IP地址不与他在同一网段,他利于网关发到了其它的地方。所以只有你对的数据包没有回来的,通过在新的linux路由器抓包可以看的很清楚。
在做了地址伪装后,数据包源地址是新的linux路由器上的地址,因为发过去后是与他在同一网段内,所以不用网关转发,直接发到新的linux路由器,然后就可以返回来。通过在新的linux路由器上抓包也可以看的很清楚。

2007-12-25 11:14:00 lhfeng 阅读数 3570
  • 【直通华为HCNA/HCNP系列R篇3】路由器接口配置与管理

    全面介绍华为新一代企业路由器——AR G3系列路由器各种接口,特别是各种主要的WAN接口以及其对应的各种WAN技术的配置与管理方法。课程中,通过大量实验、示例直观地向大家演示了这些复杂的WAN接口和技术在各种WAN应用连接中的具体配置方法,真正做到了“拿来即用”。

    25061 人正在学习 去看看 王达

linux下的路由设置(把linux作为路由器来使用) 

网络结构如下所示
pc1--------------------------------Linux------------------------------pc2
192.168.18.2------192.168.18.1--- 192.168.19.1-------192.168.19.2
linux是一个双网卡的主机,作为路由器来使用

操作步骤
1.设置IP地址
  pc1:
        IP:192.168.18.2  netmask:255.255.255.0  gateway:192.168.18.1
  pc2:
       IP:192.168.19.2  netmask:255.255.255.0  gateway:192.168.19.1
  linux:
      eth0:192.168.18.1 netmask 255.255.255.0
      eth1:192.168.19.1 netmask 255.255.255.0

2.在linux上开启路由功能
   echo "1">/proc/sys/net/ipv4/ip_forward

3.从pc1测试是否能够到达pc2
  ping 192.168.19.2

4.为了避免系统在重新启动后自动关闭路由功能
   vi /etc/rc.d/rc.local加入下面的内容.
    echo "1">/proc/sys/net/ipv4/ip_forward

5.这样一个简单的给予静态路由的linux主机路由器就设置完成了.注意如果路由太多的话一般会采用动态路由,效果更好更方便.

 

2007-07-31 12:10:00 f5key 阅读数 426
  • 【直通华为HCNA/HCNP系列R篇3】路由器接口配置与管理

    全面介绍华为新一代企业路由器——AR G3系列路由器各种接口,特别是各种主要的WAN接口以及其对应的各种WAN技术的配置与管理方法。课程中,通过大量实验、示例直观地向大家演示了这些复杂的WAN接口和技术在各种WAN应用连接中的具体配置方法,真正做到了“拿来即用”。

    25061 人正在学习 去看看 王达

用Linux打造路由器

关键词用Linux打造路由器

Linux作为一种新近崛起的操作系统,由于其性能稳定,源码开放及价格方面的优势而逐
渐被广大用户所接受。现在Linux的主要用武之地在于服务器领域,但是,经过适当的配
置之后,它还可以担当互联网的物理基石——路由器这一重要角色。

路由器是通信子网中的通信节点,每个路由器都计算并维护一张路由表,并据此指导数据
报前往最佳路径中的下一站,这便是所谓的路由。这样,经过互联网上所有路由器的通力
合作,数据报就能够沿着一条“最佳”路径到达目的地。在GNU软件Zebra的协助下,我们
可以将Linux机器打造成一台功能完备的路由器,它能够同时支持RIPv1、RIPv2、RIPng、
OSPFv2、OSPFv3、BGP-4和BGP-4+等诸多TCP/IP协议。现在我们首先了解一下 OSPF 和 B
GP 协议的运行模式和基本原理,然后介绍 Zebra 的安装配置方法,让你的 Linux 机器
变成支持 OSPF 与 BGP 的路由器。

BGP/OSPF 概述

如今,许多公司都建有多个网络,如果这些网络的类型不尽相同,则需要用路由器进行互
联。路由器是与两个或两个以上的网络连接的计算机,它根据路由协议生成并维护一个路
由表,并按照该路由表中的信息转发包。这些路由器对公司内部的网络结构了如指掌,知
道将分组送到目的地的全部细节,但对于其他公司的网络结构并不了解。像这样"在同一
机构下管理的一系列路由器和网络"被称为自治系统(AS)。由不同机构掌管的自治系统,
可以采用不同的路由选择算法;但同一自治系统内的所有路由器都使用同一路由协议,以
便于自治系统内部各个路由器互换路由信息来维持相互的连通性。每一个自治系统都有一
个16位的"自治系统(AS)编号"作为标志,就像 IP 地址一样,它是由专门机构来分配的。

自治系统内的路由器称为"内部网关",所用的协议称为"内部网关协议"。内部网关协议大
体上分为两类,一类是距离向量协议,如 RIP,EIGRP 协议;另一类是链路状态协议如 O
SPF 协议。链路状态路由协议与距离向量协议的不同之处在于,采用链路状态路由协议的
路由器不是交换到达目的地的距离,而是维护一张网络拓扑结构图。然后用数据库表示该
图,其中的表项对应网络的一条链路。路由器根据数据库的信息计算出"最佳路由",由此
指导包的转发。当网络拓扑结构发生变化时,只需将相应纪录而非整个数据库通知其他节
点。各路由器做出相应修改并重新计算路由后,就可以继续正常工作。

因为"开放式最短路径优先协议"的文档必须公开发表,所以它是"开放式的"(Open);又
因为它采用"最短路径优先"(SPF)算法来计算一个节点到所有其它节点间的最短路径,
故名为 OSPF。OSPF 具有支持多重度量制式和多重路径等诸多优点,因此成为因特网上推
荐使用的内部网关协议,RIP 却由于自身的局限性而被打入冷宫。现在,在性能上唯一能
够与 OSPF 相匹敌的内部网关协议便是 EIGRP--Cisco 的一个专有协议,但 OSPF 的“开
放”本身就是一个响亮的招牌,因为谁也不想受制于某家供应商。

前面提到,自治系统内的路由器不必知道其他自治系统的内部结构细节,从而有效地节约
了路由器的内存和 CPU 时间,并提高了网络带宽的利用率。但是,如果想与其他公司(
自治系统)通信时该怎么办呢?很简单,我们可以在自治系统内指定一个与其他自治系统
相连的路由器为"外部网关",通过它进入其他自治系统。该路由器使用的协议叫做"外部
网关协议",如边界网关协议(BGP)。相邻的两个网关必须首先互换"邻机探测"报文,协
商是否愿意成为"邻机"。成为邻机则意味着两个自治系统同意中转双方的通信流。同意后
,两个邻机互换"邻机可达性报文",来监督他们之间的链路的工作情况。接下来便是最重
要的工作,用"网络可达性报文"来交换通过各邻机所能到达的网络的信息,从而实现自治
系统之间的连通性。在外部网关的眼里只由外部网关和连接他们的链路,如此以来,自治
系统内的通信由内部网关处理,自治系统之间的通信交由外部网关处理--一个分级路由的
景象已经展现在我们面前,实际上,因特网正是由大量自治系统组成的。

建立一个高级路由器

许多人对路由器感到比较陌生,事实上作为一个防火墙使用的 Linux 系统已经是一个路
由器了,只不过还有点"简陋"而已。然而,我们的目标是用 Linux 打造一个"高级"路由
器,它必须能够利用动态路由协议(上文提到的协议皆为动态路由协议)工作。这些协议
能够使路由器互换相关信息,从而共享穿越网络时所用的那些路径--路由。这一点对于大
型网络(比如 Internet)而言是"异常"重要的,因为此时再用静态路由(也就是人工计算
设置路由)是根本不现实的。

举例来说,即使在比较理想--即不考虑路由的变化的情况下,一个边界网关协议(BGP)路
由表也至少包含 100,000 条以上的表项。这时,手工建立这样的静态路由是难以忍受的
。很明显,即使我们的网络小于 Internet--比如一个大型公司网络,我们还是更加喜欢
动态路由协议。

外部网关协议 BGP 通常作为 Internet 的骨干使用,而其它的协议(如 OSPF)则适于小
型的互连网络。开放式最短路径优先(OSPF)协议是一个应用最广的内部网关协议(IGP)。
Zebra 是一个开放源代码程序包,通过它你可以在 Linux 上运行 BGP 与 / 或 OSPF。
你既可以从 Zebra.org 网站下载 Zebra 的最新源程序,也能从 Redhat 和 Debian 中获
得它,但不一定是最新版的。从源代码中进行软件安装,你就会发现使用的是一些普通的
安装过程。简介如下:

./configure
make
make install

配置脚本会搜索系统上已经安装的 IP 栈并且自动地设置成支持他们。当前,IP 栈很可
能仅仅是指 IPv4,但是 IPv6 用户也不用担心,因为 Zebra 也会发现并且支持它。

程序安装之后,还可能必须在 /etc/services 中增加一些命令行。Zebra 的守护程序在
他们自己的虚拟终端连接(VTY)下运行,所以你的系统必须知道这些虚拟终端连接。这里
是你应该增加的一些连接∶

zebrasrv 2600/tcp # zebra service
zebra 2601/tcp # zebra vty
ripd 2602/tcp # RIPd vty
ripngd 2603/tcp # RIPngd vty
ospfd 2604/tcp # OSPFd vty
bgpd 2605/tcp # BGPd vty
ospf6d 2606/tcp # OSPF6d vty

配置 Zebra

如果你已经熟悉 Cisco IOS,那你就能在短时间内掌握 Zebra,因为你会发现两者极为相
似。Zebra 的每个守护程序使用一个单独的 VTY,这些 VTY 可以通过一个远程登录会话
进行动态配置。所以,如果你需要设置 OSPF,简单地远程登录到该 Linux 上 2604 端口
;为了修改内核的路由表或设置路由协议间的再分发,你可以远程登录到端口 2601,该
Zebra 守护程序充当内核管理器,管理其他的守护程序和系统本身之间的通信。

现在介绍如何在一个服务器上创建和运行 OSPF 和 BGP。Zebra 的守护程序运用纯文本文
件储存它们的配置。对于 OSPF/BGP 路由器,将用到三个文件∶zebra.conf、ospfd.con
f 和 bgpd.conf。举例来说,zebra.conf 文件可能会是这样:

! Zebra configuration saved from vty
! 2002/02/28 01:46:12
!
hostname LinuxRouter /*主机名为 LinuxRouter*/
password zebra /*口令为 zebra*/
enable password z3bRa /*进入特权模式时的口令为 z3bRa */
log file /var/log/zebra/zebra.log /*日志文件的地址*/
!
interface eth0 /*以太接口 eth0*/
description Interface to External Network/*对接口的描述*/
ip address 10.0.0.1/24 /*该接口的 IP 地址*/
!
interface eth1/*以太接口 eth0*/
description Interface to Internal Network/*对接口的描述*/
ip address 192.168.66.1/24/*该接口的 IP 地址*/

这里的感叹号充当注解标识或分隔符。尽管存在大量不同的网络接口类型(Ethernet、IS
DN 等等),但只要是 Linux 内核能够辨认的网络接口类型,Zebra 都可以使用。

子网掩码都带有网络位的位数(例如/24),默认掩码则不然(比如 255.255.255.0)。注
意存在两个口令,一个用于用户模式而另一个用于特权模式。这不仅有利于向非管理员提
供访问权限,而且对于创建路由服务器或者路由探测镜也是非常重要的。所有 BGP 管理
员都知道,这些探测镜是调试路由问题的关键,因为他们能够使你就象从一个外部 AS(
AS代表自治系统)一样查看路由。 BGP 路由需要用到 AS 编号,AS 编号是一些由 ARIN
(美国互联网络号码注册机构)控制的注册号码。

下一步将启动一些必要的程序。用以下命令完成∶

/usr/sbin/zebra -dk
/usr/sbin/ospfd -d
/usr/sbin/bgpd -d
第一个命令,启动 zebra,该守护程序实际上用来更新内核的路由表。-dk 告诉该程序作
为一个守护程序运行(d),它的大部分时间在后台运行。k 是另外的一个选项,告诉 Zeb
ra 维护所有已配置的路由。它用来保证在你测试 Zebra 的时候不会意外地删除路由表。
一般情况下,设置路由和接口,需要将 ifconfig 和 route 这两个命令配合使用。而 Z
ebra 完全可以替代这种路由管理方式,使用起来更为简洁。


设置OSPF


至此,基本的服务已经具备,现在让我们 Telnet 到本地机器的 2604 端口,开始配置
OSPF。为进入特权模式,键入 enable (正如在Cisco IOS 中一样),然后键入特权模式口
令。接下来,用 configuration terminal 命令切换到配置模式。值得一提的是 Zebra
也能接受命令缩写形式,这与 Cisco 极为相似,如 configuration terminal 可以简写
为 config t,这大大缩短了输入时间,使用起来更为方便。另外,如果输入 list 和 ?
,它将显示一个当前可用命令的清单,并附有一些简略解释。除此之外,还可以键入 ta
b 用于命令的自动完成。这就是说,如果你想键入命令 clock,只要键入前两个字母 cl
然后按 tab 键,机器就会自动"补全"这条命令--前提是你键入的字符足以唯一地确定这
条命令。这是一个很好的功能,尤其是当你习惯于这种用法时。

接下来,我们还需要告诉守护程序将通过 OSPF 广播哪些网络以及相关的域(area)。O
SPF 的可伸缩性允许它支持多个域。键入 router ospf 开始配置 OSPF,然后键入 netw
ork 192.168.66.0/24 area 0。这告诉路由器,我们将使用 OSPF 广播一个子网掩码为
255.255.255.0 的 192.168.66.0 网络。

在本例中,我们让 eth0 接口变成一个被动(passive)接口,以便使它不能发送路由更
新。这对于实验是非常重要的,因为在那个方向上的其他的路由器可能监听到发送的路由
更新,将接口变成一个被动(passive)接口,从而有效的避免扰乱网络的正常运行。为
此,键入命令 passive - interface eth0。如果打算将此路由器作为工作路由器使用时
,就没有这个必要了。一旦你完成修改,用 end 命令从配置模式中退出,然后用 write
file 命令保存。这里是一个快照:

labrat:~# telnet 0 2604 /*Telnet 到本地机器的 2604 端口*/
Trying 0.0.0.0...
Connected to 0.
Escape character is '^]'. /*用 '^]'退出该会话*/
Hello, this is zebra (version 0.84b)
Copyright 1996-2000 Kunihiro Ishiguro
User Access Verification
Password: /*在此键入口令,如 zebra*/
ospfd< enable/*进入特权模式*/
Password: /*输入特权模式口令,如 z3bRa*/
ospfd# configure terminal /*从终端配置路由器*/
ospfd(config)# router ospf /*配置 OSPF*/
ospfd(config-router)# network 192.168.66.0/24 area 0 /*通过 OSPF 广播网络 ne
twork
192.168.66.0,/24 指出子网掩码为 24 位,area 0 指出该网络所在的域*/
ospfd(config-router)# passive-interface eth0 /*将 eth0
接口设置成一个被动(passive)接口*/
ospfd(config-router)# end /*退出配置模式*/
ospfd# write file /*保存修改*/
Configuration saved to /etc/zebra/ospfd.conf


请记住,为了让 OSPF 或 BGP 在某接口上工作,那么该接口必须处于"运行"状态。为手
工运行一个接口,登录到端口 2601 并且在该接口上执行 no shut 命令。
BGP 与 OSPF 的配置大致相同。开始,打开一个远程登录会话到端口 2605。之后执行 c
onfigure terminal,输入 router bgp 进入 BGP 配置模式。如前所述,BGP 使用 AS 编
号建立邻机关系并路由通信流。在我们的试验中,我们将使用一个范围在 64512 到 655
34 之间的私有 AS 号码(换句话说,该号码旨在机构内部有效,而在因特网上无效)。
用 network 命令设置由 BGP 广播的那些网络,如 network 192.168.66.0/24.。与 OSP
F 不同的是,BGP 邻机必须静态指定。如同下述∶

neighbor >neighbor IP< remote-as >remote AS #<


这里是一个范例:

labrat:~# telnet 0 2605
Trying 0.0.0.0...
Connected to 0.
Escape character is '^]'.
Hello, this is zebra (version 0.84b)
Copyright 1996-2000 Kunihiro Ishiguro
User Access Verification
Password:
bgpd< enable
Password:
bgpd# configure terminal
bgpd(config)# router bgp 65530 /*配置 BGP,65530
是自治系统编号。也就是将该系统配置成自治系统 65530 上的外部网关*/
bgpd(config-router)# network 192.168.66.0/24 /*由 BGP 广播的网络*/
bgpd(config-router)# neighbor 10.0.0.5 remote-as 65531 /*静态指定自治系统 65
531 上
IP 地址为 10.0.0.5 的路由器为本机的邻机*/
bgpd(config-router)# end
bgpd# write file
Configuration saved to /etc/zebra/bgpd.conf


对于OSPF和BGP,有大量选项可用,限于篇幅不能在此一一介绍。对于每个协议,我建议
在实际使用之前,不妨先研究一番。为此,可以参考 GNU Zebra 文档,它会给你提供许
多帮助。


结束语


在网络中,路由通信流的方法有若干种。就路由器而论,虽然有用各种硬件可用,但是费用
较高--人们自然就会想到运行一个用 Linux 系统构筑的功能丰富的路由器作为代替。Ze
bra 路由守护程序已经使这一切变为现实。因为支持 IPv4、IPv6 和其它各式各样的协议
,所以 Zebra 能够满足我们所有的路由需求。它还有一个好处就是,因为 Cisco IOS 和
Zabra 极为相似,如果你以前在 Cisco IOS 环境中工作,可以轻松的过渡到 Zebra 系
统;同时,使用 Zebra 也能让你积累起丰富的类似于使用 Cisco IOS 路由器的经验和知
识。

【作者: Liberal】【访问统计:】【2006年12月31日 星期日 21:47】【 加入博采】【打印

2009-04-09 15:33:00 wxdvc 阅读数 1086
  • 【直通华为HCNA/HCNP系列R篇3】路由器接口配置与管理

    全面介绍华为新一代企业路由器——AR G3系列路由器各种接口,特别是各种主要的WAN接口以及其对应的各种WAN技术的配置与管理方法。课程中,通过大量实验、示例直观地向大家演示了这些复杂的WAN接口和技术在各种WAN应用连接中的具体配置方法,真正做到了“拿来即用”。

    25061 人正在学习 去看看 王达
 

一:

echo 1 > /proc/sys/net/ipv4/ip_forward 启动时失效
或是修改/etc/sysctl.conf把net.ipv4.ip_forward = 0改为= 1

 

 

二:

如果eth0为192.168.10.123/255.255.255.0,eth1为192.168.20.231/255.255.255.0,则命令格式如下:

 

#route add -net 192.168.10.0 netmask 255.255.255.0 dev eth0

 

#route add -net 192.168.20.0 netmask 255.255.255.0 dev eth1

 

上面的命令把发送给192.168.10.0网段的IP包交给eth0转发,把192.168.20.0网段的IP包交给eth1转发。如果还有可能有发送给其他目的IP的包,那么你肯能希望设置一个“默认网关”:

 

#route add default gw 192.168.10.1

 

上面的命令把所有发送给其他目的IP的包都转发给 192.168.10.1,而如何转发给192.168.10.1这个地址的规则已经在刚才的第一条命令中定义了(从eth0转发)。一般情况下,默认网 关已经自动设置好了,不用重复设置。可以用route命令加-n参数进行检查。

 

如果要删除某一条,命令格式为:

 

#route del -net 192.168.10.0 netmask 255.255.255.0

 

配置时的一种思路是把192.168.10.0网段路由至eth0,192.168.20.0网段路由至eth1,再设置默认路由。另一种思路是,只指定其中一个,然后把默认的0.0.0.0路由至另一个。其实效果一样,就是两种风格。

 

 

三:

一、环境:
三台直接相连的计算机主机如图
PC1PC2PC3
其中PC2上有两块网卡eth0、eth1,分别与PC3、PC1相连
------代表网线
二、需求:
将PC2配置为路由器模式,用来在PC1、PC3之间转发报文
三、方法:
将三台主机按照环境所要求用交叉线直接连网后,为三台主机分配网段并配置IP地址。
网段及IP地址分配如下:
主机名    所在网段        分配IP                   网关
PC1: 192.168.2.0/24 192.168.2.2/24     192.168.2.1
PC2: 192.168.2.0/24 192.168.2.1/24     '与PC1相连的网卡的配置' eth1
             192.168.1.0/24 192.168.1.1/24     '与PC3相连的网卡的配置' eth0
PC3: 192.168.1.0/24 192.168.1.2/24     192.168.1.1

按照上表所示分别将主机IP地址配置好,其中要注意的是,要想使PC2具有报文转发功能,在PC2
上检查/proc/sys/net/ipv4/ip_forward中的值是否为1
命令:
#more /proc/sys/net/ipv4/ip_forward
如果显示其值不为1而是0 输入以下命令:
#echo '1' > /proc/sys/net/ipv4/ip_forward
打开IP转发功能
PC2中的其它配置:
为PC2添加路由,命令:
#route add -net 192.168.1.0 netmask 255.255.255.0 dev eth0
#route add -net 192.168.2.0 netmask 255.255.255.0 dev eth1

四、验证:
PC1:
ping网关
#ping 192.168.2.1
#ping 192.168.1.1
ping PC3:
#ping 192.168.1.2
PC3:
ping网关
#ping 192.168.1.1
#ping 192.168.2.1
pint PC1
#ping 192.168.2.2
五、Bug调试:
出错的原因主要集中在PC2两个地方
1.检查PC2是否允许IP报文转发(/proc/sys/net/ipv4/ip_forward的值是否为1)
2.路由设置是否正确(#route 回车查看)

Linux变成路由器

阅读数 2949

没有更多推荐了,返回首页