exsi下安装ios
2016-11-21 14:48:02 sgliquangang 阅读数 393

一.注意:CocoaPods安装是基于ruby环境的,所以要安装CocoaPods先要安装Ruby环境,国内不能直接安装,只能通过VPN或淘宝的Ruby镜像来访问。

二.开始安装:
1.打开终端,输入 gem sources –remove https://rubygems.org/

2.输入gem sources -a https://ruby.taobao.org注意是https

3.为了验证你的Ruby镜像是并且仅是taobao,可以用以下命令查看:
gem sources -l
端终出现如下文字表明你的命令成功
* CURRENT SOURCES *
http://ruby.taobao.org

4.开始安装cocoapods:sudo gem install cocoapods

5.ok,安装成功!

2014-09-10 10:32:19 ralbatr 阅读数 579

      本文建立在已经申请好帐号的基础之上。

      因为新换了一台mac。需要重新安装xcode等。

      首先登录Member Center。


选择Certificates……,进入


选择开发者 development……


点击 + ,即可。

按照提示,下一步,即可。

把生成的证书,上传,刷新。


然后,申请ID


此处,使用*,最好


选择开发者证书


根据提示,下一步,即可





2016-08-08 14:30:46 W10207010218 阅读数 321

如果你在天朝,不能直接访问cocoapods.org,因为那堵墙阻挡了cocoapods.org。

但是我们可以用淘宝的Ruby镜像来访问cocoapods。按照下面的顺序在终端中敲入依次敲入命令:

gem sources --remove https://rubygems.org/


gem sources --a https://ruby.taobao.org/   最新的镜像为:

https://gems.ruby-china.org/ 最好用这个


为了验证你的Ruby镜像是并且仅是taobao,可以用以下命令查看:

gem sources -l



然后输入安装命令:

sudo gem install cocoapods


可能会出现以下错误提示:

Error installing cocoapods:

activesupport requires Ruby version >= 2.2.2.

这是因为MAC自带的ruby版本太低所以需要把ruby升级以下就是用rvm升级ruby的步骤:

1安装 rvm 
RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gems)

curl -L get.rvm.io | bash -s stable. //这是链接下载rvm的命令

2加载文件, 测试是否安装正常(按照提示操作)

 source ~/.bashrc  
 source ~/.bash_profile  
 source ~/.profile
 rvm -v             //这是查看当前rvm版本的命令

3 安装命令
rvm install 2.3  



备注:
 查询已经安装的ruby:  rvm list

 卸载一个已安装版本 :  rvm remove 2.0.0

 查询所有ruby版本:rvm list known

安装完成之后再次输入sudo gem install cocoapods

最后再 pod setup      //这个是从网上下载所需的文件

这就完成了


关于使用

新建一个project  podTest

在终端打开该工程路径

执行pod init

你就会发现目录下出现文件podfile


然后打开podfile编辑

target 'podTest'do

end

之间编辑你想导入的第三方库

例如

pod ‘AFNetworking’

在终端执行 pod install 这个AFNetworking就会导入到你的工程里面去了

pod 搜索功能

pod search  AFNetworking


安装pod的时间可能比较长,请耐心等待。

如果一开始的镜像更改失败,请先安装rvm(也就是ruby环境做好)才更新镜像就会成功。











2017-06-22 22:16:00 weixin_34304013 阅读数 3

Chisel简介

Github地址:Chisel
Chisel是帮助iOS开发者更方便的调试应用的拓展工具, Chisel 使用 homebrew 来安装,如果你没有安装homebrew,请先安装好homebrew。

安装Chisel

//在终端安装
brew update
brew install chisel

安装完成之后又如下信息:


==> Downloading https://github.com/facebook/chisel/archive/1.3.0.tar.gz
==> Downloading from https://codeload.github.com/facebook/chisel/tar.gz/1.3.0
######################################################################## 100.0%
==> Caveats
Add the following line to ~/.lldbinit to load chisel when Xcode launches:
command script import /usr/local/opt/chisel/libexec/fblldb.py
==> Summary
🍺  /usr/local/Cellar/chisel/1.3.0: 21 files, 136K, built in 7 seconds ```
  注意看Caveats下面的那两行,意思是把第二行的文字command script import /usr/local/opt/chisel/libexec/fblldb.py添加到.lldbinit文件中,这时执行命令**echo command script import /usr/local/opt/chisel/libexec/fblldb.py >> ~/.lldbinit**(粗体文字替换为你终端Caveats下面的第二行文字)可免去你去找.lldbinit文件,或者.lldbinit文件不出现的烦恼啊。到此步不出意外已经安装成功。

安装完成之后重新启动Xcode ,并且在Xocde中打个断点在控制台中输入 (lldb) help 成功则输出以下信息:

![Snip20170622_1.png](http://upload-images.jianshu.io/upload_images/1279084-2ba259ccd2286ab9.png?imageMogr2/auto-orient/strip%7CimageView2/2/w/1240)
2014-08-20 12:02:07 alincexiaohao 阅读数 1568

1、开发xmpp官网下载




2、打开openfire.pkg


3、点击继续


4、安装成功后打开偏好设置 ->双击poenfire->弹出窗口【好】


5、随后会弹出下面这个视图 开启 strrt openfre - > 打开网页设置界面 open admin console


如果跳出这个界面,还需要安装ava环境,下载一个javaforosx.dmg安装   下载地址:http://jdk7.java.net/macportpreview/


点击open admin console 会跳出网页设置界面 -> 选择中文 - > 继续


域:输入本地地址 127.0.0.1


选择标准数据库连接


6、在这先安装mysql:http://www.cnblogs.com/xiaodao/archive/2013/04/04/2999426.html

数据库 URL:jdbc:mysql://[host-name]:3306/[database-name]?rewriteBatchedStatements=true

  [host-name]   127.0.0.1 或 localhost

  [database-name]   openfire (数据库名)


7、


点击继续,如果出现下图错误: 则,到偏好设置,打开openfire 重启,然后重新打开新界面,重新设置即可


8、设置邮箱,继承,安装成功


登陆后台:


iOS之Cordova安装

阅读数 2902

cordova安装

博文 来自: shxwork

cocos2d -iOS 安装。

阅读数 1332

iOS Cocopods安装

阅读数 331

iOS 安装CocoaPods

阅读数 55

iOS 安装cocoapds

阅读数 32

没有更多推荐了,返回首页