php7apache 没有_5.1.0-php7.3-apache的apache版本 - CSDN
精华内容
参与话题
  • 如果是64位系统要下载x64的,x86的不行----------------------------------------------------------------------配置:# php7 supportPHPIniDir "E:/phpEnv/php"LoadModule php7_module ...
    1.要下载THREAD SAFE的,你下载的是NOT THREAD SAFE吧
    2.如果是64位系统要下载x64的,x86的不行
    ----------------------------------------------------------------------
    配置:
    # php7 support
    PHPIniDir "E:/phpEnv/php"
    LoadModule php7_module "E:/phpEnv/php/php7apache2_4.dll"
    AddType application/x-httpd-php .php .html .htm
    # configure the path to php.ini



    作者:关君
    链接:https://www.zhihu.com/question/38283209/answer/77197573
    来源:知乎
    著作权归作者所有,转载请联系作者获得授权。

     

     

     

     

     

     

     

     

     

     

    打赏分享者

              有了大家的支持,我们会更有动力,会做的更好的,谢谢各位。

     

     

    展开全文
  • centos7 apache无法解析php

    万次阅读 2018-02-20 17:34:08
    操作系统:centos7.2 x64...我觉得可能是我安装lamp的顺序不对,然后以如下顺序安装:php7、mariadb、apacheapachephp7、mariadb,发现均无法解析php文件。上网搜索解决方案,说要安装mod_php模块,我试了半天,...

    操作系统:centos7.2 x64

    使用yum安装完apache、php7、mariadb之后,发现apache可以解析html文件,但是不能解析php文件。(如图)
    图一

    我觉得可能是我安装lamp的顺序不对,然后以如下顺序安装:php7、mariadb、apache和apache、php7、mariadb,发现均无法解析php文件。上网搜索解决方案,说要安装mod_php模块,我试了半天,没有发现mod_php这个文件怎么安装,并且/etc/httpd/conf.modules.d/目录下也没有关于php的配置文件。网上说或者重新编译apache,我不想搞这么麻烦,于是就没试。
    我后来看我其他的云服务器,他们用的都是lamp,版本都和这个服务器一样,但是他们却都有一个名为php7_module的apache模块,然后我把这个模块文件(目录可以百度出来)复制到有问题的服务器上,然后复制相应的配置文件(/etc/httpd/conf.modules.d/目录下有一个叫php什么的文件,这个就是对应的配置文件),如图。
    图二
    然后重启apache,发现问题解决。

    难道每次都要弄这么麻烦?
    事后我想,能不能换用php-fpm呢?
    上网搜教程,配置apache来使用php-fpm,并写好配置文件,内容如下

    <FilesMatch \.php$>
             SetHandler "proxy:fcgi://127.0.0.1:9000"
    </FilesMatch>

    保存到/etc/httpd/conf.modules.d/10-php-fpm.conf,然后启动php-fpm,并重启apache,php文件解析成功。如图:
    图三
    可以看到,使用的是FPM模式。


    今天(2018.2.5)看到了一篇博客,发现可以直接使用yum命令来安装apache的mod_php模块:yum install mod_php71w
    如果没有这个安装包,可以尝试着添加一下源:

    rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm
    rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

    参考资料:
    http://www.onepx.com/from-apache-mod-php-to-php-fpm.html

    展开全文
  • 1、卸掉之前的本地环境(phpApache、mysql),如果本地默认开启了IIS服务,需将IIS服务关闭(端口占用),虽然可以改Apache服务端口,但是访问时带端口访问,总让人感觉别扭。 IIS服务关闭方法:win+R键,输入...

    一、安装前的准备

    1、卸掉之前的本地环境(php、Apache、mysql),如果本地默认开启了IIS服务,需将IIS服务关闭(端口占用),虽然可以改Apache服务端口,但是访问时带端口访问,总让人感觉别扭。
    IIS服务关闭方法:win+R键,输入services.msc确认,开启本地服务列表,找到IIS服务,右键选择属性,停止服务并选择为手动,如下图。
    这里写图片描述
    这里写图片描述
    2、下载需要的资源,以下资源根据自己的系统是32位和64位自行选择。
    ①php资源下载(写博客时最新版本是php7.1.10)
    php7 for windows版本资源下载地址:http://windows.php.net/download/
    版本选择:php7 for windows的版本有4个,分32位和64位,这里边又分了non thread safe 和 thread safe。如果你装的环境是IIS或者nginx那么请选择non thread safe,如果你装的环境是Apache那么请选择 thread safe。本人本地安装的是apache,选择的是 thread safe。其中原因你可以百度下non thread safe和thread safe区别,与php运行机制有关。
    ②Apache资源下载(写博客时最新版本是VC15 Apache2.4.28)
    这里有两个下载地址,选择其中一个就可以了,但是要下载Apache2.4以上版本的,因为Apache2.2版本的不支持php7,我这里选择的是VC15 Apache2.4.28版本的。
    下载地址:https://www.apachelounge.com/download/
    https://www.apachehaus.com/cgi-bin/download.plx#APACHE24VC09
    ③mysql下载(写博客时最新版本mysql5.7.20)
    在写博客时,官网下载的mysql5.7.20的64位压缩包解压之后居然没有my-default.ini文件,只能自己创建一个。你也可以选择其他版本的mysql
    最新版本下载地址:https://dev.mysql.com/downloads/mysql/
    mysql5.6下载地址:https://dev.mysql.com/downloads/mysql/5.6.html#downloads
    这里写图片描述
    ④由于php7使用了VC14的编译环境,所以我们还需要下载Visual C++ 2015,这个可以在上面三个安装完成之后,测试是否有问题再安装,因为你的windows系统可能已经给你安装了。
    下载地址:https://www.microsoft.com/en-US/download/details.aspx?id=48145

    PS:如果你懒得自己去找资源,下面是环境搭建所需资源地址(压缩包内含有php7.1.10版本压缩包(64位, thread safe版本),Apache2.4.28压缩包(64位,VC15版本),mysql5.7.20(64位),Visual C++ 2015(64位),以上资源都是windows版本):
    链接:http://pan.baidu.com/s/1eR7N3zk 密码:qr4b ——安装所需资源包


    二、开始安装

    建一个文件夹,来安放你接下来搭建你环境内容,我这里建的文件夹名字为benxiaohai
    1、php安装
    ①在benxiaohai文件夹下建一个文件夹来放php内容,将下载下来的压缩包安放在该文件夹下,解压。如下图:
    这里写图片描述
    ②修改配置文件
    1) 修改G:\benxiaohai\php7.1.1目录下的php.ini-development文件,将G:\benxiaohai\php7.1.1目录下的php.ini-development文件名修改为php.ini
    2) 修改扩展目录

    extension_dir = "G:/benxiaohai/php7.1.1/ext"

    3) 开启相关扩展
    根据需要开启相关扩展,我这边只开启了如下扩展:

    extension=php_gd2.dll
    extension=php_curl.dll
    extension=php_mbstring.dll
    extension=php_openssl.dll
    extension=php_mysqli.dll
    extension=php_pdo_mysql.dll

    注意:php7中,已移除php_mysql.dll这个扩展,由php_mysqli.dll取代了。

    2、安装apache
    ①将压缩文件httpd-2.4.28-Win64-VC15.zip解压到Apache24目录中,如下图
    这里写图片描述
    ②创建apache服务
    打开cmd,输入”G:\benxiaohai\Apache24\Apache24\bin\httpd.exe” -k install -n Apache2.4,路径是你自己安装apache的路径。如下图。回车运行后,当出现The ‘Apache2.4’ service is successfully installed时表示安装成功。
    这里写图片描述
    ③安装成功后按win+R,输入services.msc回车,你会在服务列表中找到你的Apache2.4服务
    这里写图片描述
    ④配置apache
    需要配置的文件:G:\benxiaohai\Apache24\Apache24\conf\httpd.conf
    1)配置apache安装的目录

    ServerRoot "G:/benxiaohai/Apache24/Apache24"

    2)配置你php项目的安放目录

    DocumentRoot "G:/benxiaohai/www"
    <Directory "G:/benxiaohai/www">

    3)加载php模块
    在文件最后边添加如下配置

    #php7 support
    LoadModule php7_module "G:/benxiaohai/php7.1.1/php7apache2_4.dll"
    AddHandler application/x-httpd-php .php
    #configure the path to php.ini
    PHPIniDir "G:/benxiaohai/php7.1.1"

    4)修改域名配置

    ServerName localhost:80

    或者

    ServerName 1270.0.1:80

    5)配置欢迎页(首页)

    <IfModule dir_module>
        DirectoryIndex index.html index.php index.htm
    </IfModule>

    ⑥启动apache
    在apache安装目录下点击ApacheMonitor.exe,启动apache,如下图
    这里写图片描述
    ⑦在上面配置php项目的安放目录下建一个test.php文件并在里边写入如下代码

    <?php
    phpinfo();

    ⑧打开浏览器,输入localhost/test.php,看到如下界面,就说明你安装成功了!
    这里写图片描述
    3、mysql5.7.20数据库安装
    在官网下载的mysql5.7.20的64位压缩包中,解压后里边缺少my-default.ini文件,需自己创建
    ①将下载好的压缩包解压到mysql5.7目录下,如下图
    这里写图片描述
    ②修改my-default.ini文件
    复制一份my-default.ini文件 ,并将其改名为my.ini,并添加如下配置

    sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES 
    basedir = G:/benxiaohai/mysql5.7/mysql-5.7.20-winx64
    datadir = G:/benxiaohai/mysql5.7/mysql-5.7.20-winx64/data
    character_set_server=utf8 
    port = 3306

    注:这里的data文件夹本来是不存在的,mysql会自动生成。
    ③添加环境变量,如下图,将mysql的解压目录添加到环境变量path中,我的是G:\benxiaohai\mysql5.7\mysql-5.7.20-winx64\bin,注意分号问题
    这里写图片描述
    ④安装
    1)打开cmd,将路径转换到你安装mysql的路径下,然后服务安装命令,其中mysql是服务名称,my.ini是你上面复制的my-default.ini文件,当出现Service successfully installed.时表示服务安装成功,如下图

    mysqld --install mysql --defaults-file=G:\benxiaohai\mysql5.7\mysql-5.7.20-winx64\my.ini

    这里写图片描述
    2)执行生成data文件指令(mysql初始化数据表数据,以及你以后创建表的数据目录)

    mysqld --initialize

    3)执行启动服务指令

    net start mysql

    这里写图片描述
    4)用编辑器打开G:\benxiaohai\mysql5.7\mysql-5.7.20-winx64\data目录下后缀为.err文件,第一次安装用户名一般为root,密码为空或者随机。
    这里写图片描述
    5)登陆,输入如下指令,然后会要你输入密码,如果密码为空直接回车键,如果密码不为空,则输入密码后回车键。出现下图这表示登陆成功,mysql5.7在这里也就安装完成了。

    mysql -u root -p

    这里写图片描述


    三、在安装过程中遇到的问题

    1、启动apache 提示Starting httpd: AH00558
    Starting httpd: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using localhost.localdomain. Set the ‘ServerName’ directive globally to suppress this message
    apache 启动出现这种错误的解决方法:
    将 apache 的配置文件httpd.conf中 ServerName 改成可用域名或如下配置
    ServerName localhost:80
    2、安装完apache后,在浏览器中访问localhost时,一直出现的是IIS页面,这里需要把你本地的IIS服务关掉(本文开头有关闭该服务说明),并清理浏览器缓存后再访问。
    3、在安装完apache和php后访问test.php时,出现403。可以从几个方面考虑,大多还是apache的httpd.conf配置问题
    ①首先要确保线面这个配置目录是对的

    DocumentRoot "G:/benxiaohai/www"
    <Directory "G:/benxiaohai/www">

    ②其次是配置中对该目录权限配置,下三个配置与其有关,与之前apache版本的权限配置稍有不同,可以注意下

    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted

    4、在安装完mysql之后,启动出现如下弹框。这个可以参考这个地址:http://blog.csdn.net/qq_26525215/article/details/53424152解决该问题。
    这里写图片描述
    5、另外,在安装apache时要注意80端口是否被占用
    6、如果出现提示VCRUNTIME140.dll丢失,可以安装Visual C++ 2015,文中开头有说明。

    展开全文
  • CentOS7Apache挂载PHP

    千次阅读 2018-03-29 20:31:43
    确认apache 命令行输入: httpd -v 结果如下图: 安装PHP 输入命令: yum install php 安装完成之后,确认PHP,输入命令: php -v 然后会出现如下截图: 并且在/etc/httpd/modules/目录下会新增一个so...

    确认yum

    确认方法参见 传送门

    确认apache

    命令行输入:
    httpd -v

    结果如下图:
    这里写图片描述

    安装PHP

    输入命令:

    yum install php

    安装完成之后,确认PHP,输入命令:

    php -v

    然后会出现如下截图:
    这里写图片描述

    并且在/etc/httpd/modules/目录下会新增一个so文件,libphp5.so文件。

    Apache挂载PHP

    修改apache的配置文件httpd.conf
    1. 增加php5_module

    LoadModule php5_module /etc/httpd/modules/libphp5.so

    2.增加php文件类型识别

    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

    3.重启Apache

    验证

    在apache的ServerRoot目录下,增加一个info.php文件,文件内容输入:

    <?php echo phpinfo(); ?>

    然后,在浏览器中输入 http://此处为apache服务器ip/info.php

    安装成功的话,会出现下图:
    这里写图片描述

    其他经验分享

    1 如果输入info.php地址,浏览器直接下载该文件,说明apache没有挂载php成功。需要看看是不是没有load module对php模块。

    2 如果输入info.php地址,浏览器直接显示文件中的代码,说明apache挂载php成功,但是忘了在httpd.conf中添加php文件类型识别。

    展开全文
  • 本文源自【大学之旅_谙忆的博客】 今天第一次接触PHP,配置这个环境也是搞了一个多小时。 买的PHP的这本书,上面的环境配置有些老了,Apache还是2.2的版本配置。 果断抛弃书本,然后...电脑:window7-X64 Apache:h
  • Centos7安装ApachePHP,包含配置过程

    万次阅读 2018-07-02 15:47:36
    网站是使用xpress engine建立的,所以,运行环境为apache httpd和php。如果能够直接使用xampp就好了,可是老服务器是n年前的,新的服务器环境需要兼容原来环境的版本。所以,需要单独安装apache http和php以及数据库...
  • 64位Win7环境中PHP安装文件【Apache+PHP+MySQL】

    千次下载 热门讨论 2020-07-30 23:33:25
    安装文件: httpd-2.2.19-win64.rar mysql-5.5.33-winx64.msi php-5.3.6-Win32-VC9-x64.zip 详细安装步骤请参阅本人博客: http://blog.csdn.net/yousuosi/article/details/9859507
  • 萌新在面对服务端开发使用PHP搭配Apache时会遇见Cannot load php7apache2_4.dll into server 例如 01 最最最主要的问题 ApachePHP版本不一致 cd 进入Apache的bin目录使用命令httpd -version来查看Apache...
  • 如何切换apache中的php5与php7

    千次阅读 2017-09-23 07:26:49
    1 查询官网打开官网,找到FAQhttps://...to switch Version of PHP do? Answer to the Shortcut -> PHP Version Switch switch PHP Version needed immediately.2 改变php版本在win10的开始菜单中找到 php v
  • wamp添加最新版本php7apache

    万次阅读 2016-05-03 13:58:38
    最近我把我的wamp中的php增加了php7.0.5,顺便又添加了一个高版本的apache.在此记录分享一下。 1. 配置前说明 我的电脑是win10,所用的wamp为wamp2.5 64位版本。可以到这里下载官方最新版...
  • 一、该项目有难点,就是zentao tar.gz压缩包中是自带了apache和mysql的,如果自己后面安装,会出现很多端口占用,冲突的情况。 二、所以我尝试了如下的安装,过程如下:  1、安装apache2.4:  ①、查看httpd包...
  • 在给apache配置php的过程中,如果php安装目录里没有php5apache2_2.dll,一定是下载的版本不对。  php 5.3.4有v9版和v6好几个版本  网站左边有几段文字:  which version do i choose? if you are using php with...
  • 本地Apache服务器添加php7模块

    千次阅读 2018-03-27 22:34:59
    Apache的一些基础命令 Options: -D name : define a name for use in &lt;IfDefine name&gt; directives -d directory : specify an alternate initial ServerRoot -f file : specify...
  • 在centos7系统下编译apache2.4,PHP7,mysql5.6
  • PHP7+Apache2.4+MySql 环境搭建-最新(博主亲测)自己刚安装的所有环境,看着网上的教程试了下,感觉都不是很详细,这里写一下自己的详细配置过程,如果有不清楚的地方可以q我哦。。。 工具下载 工具安装 文件配置 ...
  • 最近配置 Apache 2.4 支持PHP7,能够正常运行,扩展PHP7的extensions的时候,出现缺少:  ----libssh2.dll,libcrypto-1_1-x64.dll,LIBPQ.dll,icuuc60.dll 的报错,尝试过各种解决方案,都不行,后来直接把PHP安装...
  • Apache版本2.4.6PHP 版本7.0.27首先确保php和...该文件是否存在,若apache页面只提示下载的话,该文件一般都不存在检查/usr/lib64/httpd/modules/libphp7.so和/usr/lib64/httpd/modules/libphp7-zts.so是否存在若...
  • PHP7Apache2.4关联配置

    千次阅读 2016-02-19 00:55:55
    目前为止,php7Apache2.4都是最新的版本,我本着“喜新厌旧”的原则都是用的最新版(系统是win10)。刚才配置了Apache的httpd.conf文件之后重启服务报错如下: 配置如下:LoadModule ...
  • apache 加载 php7

    千次阅读 2015-12-23 14:17:02
    apache加载php7时报错的解决办法
1 2 3 4 5 ... 20
收藏数 294,135
精华内容 117,654
关键字:

php7apache 没有