os上安装ros 在mac_mac os x mojave ros - CSDN
精华内容
参与话题
  • RouterOS修改VRRP的MAC地址的方法

    千次阅读 2019-05-29 15:06:15
    RouterOS(以下简称ROS)的vrrp的mac地址是固定的,不能修改,一般都是00:00:5E:00:01:01开始,所以对于很多运营商来说只要封掉00:00:5E:00:xx:xx段MAC就可以封掉多拨。 对于实体机ROS来说,可以通过Bridge的方法来...

    RouterOS(以下简称ROS)的vrrp的mac地址是固定的,不能修改,一般都是00:00:5E:00:01:01开始,所以对于很多运营商来说只要封掉00:00:5E:00:xx:xx段MAC就可以封掉多拨。

    对于实体机ROS来说,可以通过Bridge的方法来修改vrrp mac地址,网上也一般是这种方法。

     

    操作方法:

    一、建一个外网的bridge。(这边演示ether3是外网网卡)

    Winbox -> Bridge -> +  -> OK(默认就可以)

    484-1.png

    Ports -> + -> Interface选择外网网口,这边是ether3,确定

    484-2.png

    /interface bridge add name=bridge1
    /interface bridge port add bridge=bridge1 interface=ether3

     

    二、设置vrrp以及pppoe拨号连接

    参考我以前的文章《RouterOS通过VRRP实现单线多拨以及PCC负载均衡》中的设置,这边就不详细写了。

    /interface vrrp
    add interface=bridge1 name=vrrp1 vrid=1
    add interface=bridge1 name=vrrp2 vrid=2
    add interface=bridge1 name=vrrp3 vrid=3
    
    /interface pppoe-client
    add interface=vrrp1 name=pppoe-out1 password=xxxx user=xxxx
    add interface=vrrp2 name=pppoe-out2 password=xxxx user=xxxx
    add interface=vrrp3 name=pppoe-out3 password=xxxx user=xxxx
    
    /ip address
    add address=192.168.10.254/24 interface=bridge1 network=192.168.10.0
    add address=192.168.10.1/24 interface=vrrp1 network=192.168.10.0
    add address=192.168.10.2/24 interface=vrrp2 network=192.168.10.0
    add address=192.168.10.3/24 interface=vrrp3 network=192.168.10.0

     

    三、通过Bridge MAC NAT来修改vrrp的mac地址

    1、首先开启Bridge的防火墙

    Bridge -> Settings,勾上Use IP Firewall,点击ok

    484-3.png

    2、把vrrp修改为你需要的mac地址,有几条vrrp做几条(这边只做一条)

    vrrp1的mac地址是00:00:5E:00:01:01,我拨号需要的mac地址是C4:D9:87:44:03:63

    Bridge -> NAT -> +,Chain选择 srcnat,Src. Mac Address地址填入vrrp1的mac地址00:00:5E:00:01:01,Src. Mac Mask默认即可

    点击Action选项卡,Action选择src-nat,To Mac Address填入需要的mac地址C4:D9:87:44:03:63,确定

    484-4.png

    Bridge -> NAT -> +,Chain选择 dstnat,Dst. Mac Address地址填入需要的mac地址C4:D9:87:44:03:63,Dst. Mac Mask默认即可

    点击Action选项卡,Action选择dst-nat,To Mac Address填入vrrp1的mac地址00:00:5E:00:01:01,确定

    484-5.png

    /interface bridge settings set use-ip-firewall=yes
    /interface bridge nat
    add action=dst-nat chain=dstnat dst-mac-address=C4:D9:87:44:03:63/FF:FF:FF:FF:FF:FF to-dst-mac-address=00:00:5E:00:01:01
    add action=src-nat chain=srcnat src-mac-address=00:00:5E:00:01:01/FF:FF:FF:FF:FF:FF to-src-mac-address=C4:D9:87:44:03:63

     

     

    四、查看MAC地址

    无法在本地查看PPPoE的拨号MAC地址。我这边通过电信的智宽生活可以看到mac地址,发现已经更新成我自己设置的mac地址

    484-6.png

    展开全文
  • 一、什么是RouterOS(ROS),ROS优点与缺点 RouterOS(简称ROS)是一种路由操作系统,基于Linux开发,兼容x86 PC的路由软件,是目前功能较强、应用较广的软路由系统,适用于中小企事业单位、网吧、宾馆和运营商。通过该...

    一、什么是RouterOS(ROS),ROS优点与缺点

    RouterOS(简称ROS)是一种路由操作系统,基于Linux开发,兼容x86 PC的路由软件,是目前功能较强、应用较广的软路由系统,适用于中小企事业单位、网吧、宾馆和运营商。通过该软件可以将标准的PC电脑变成专业路由器,在软件的开发和应用上可以不断地更新和发展,使其功能在不断增强和完善。特别在无线、认证、策略路由、带宽控制和防火墙过滤等功能上有着非常突出的功能,其极高的性价比,受到许多网络人士的青睐。

    价格优势:一般的硬件路由器价格昂贵,ROS可以让任何一台X86 PC变为专业硬路由。
    系统稳定:ROS基于Linux内核,底层系统安全,可以长期可靠运行。
    支持编程:ROS由于是Linux内核,支持创建脚本,能实现各类复杂功能。
    功能强大:ROS可以是路由器、防火墙、流控、认证设备;可以实现动态路由、数据转发、NAT、流量控制、PPPOE、WEB认证、PPTP、L2TP 等功能。
    劣势:上手难度较高,学习成本较高。

    二、Mikrotik RouterOS(ROS)授权镜像以及WinBox下载

    镜像下载:

    (X86物理机使用)Mikrotik_RouterOS_6.47.1_Stable(官方原版).iso

    (虚拟化平台使用)Mikrotik_RouterOS_CHR_6.47.1_Stable(官方原版).ova下载

    (X86物理机使用)Mikrotik_RouterOS_7.1_Beta1_Development(官方原版).iso下载

    (虚拟化平台使用)Mikrotik_RouterOS_CHR_7.1_Beta1_Development(官方原版).ova下载

    L5授权2G、L6授权60M镜像下载地址

    WinBox下载(ROS管理工具):

    WinBox x64 3.24 Windows下载

    WinBox x64 3.24.1 Mac下载

    Mikrotik RouterOS官网

    三、ESXI 宿主机网络配置

    ESXI安装教程: vSphere ESXI 7.0部署详细安装指南,奶妈级安装教程(附镜像下载)

     

    [图1]硬件网卡列表

    四、添加虚拟交换机

     

    点击ESXI中网络选项卡并切换至“虚拟交换机”面板

    1、点击添加标准虚拟交换机。

    2、输入虚拟交换机名称,建议以vSwitch+数字命名,例如:vSwitch0、vSwitch1....以此类推。

    3、上行链路中选择待分配的物理网卡,建议与vSwitch命名搭配,如vSwitch0选择vmnic0、vSwitch1选择vmnic1。

    4、安全选项中将[混杂模式]、[MAC地址更改]、[伪传输]都改为【接受】。

    5、确认无误后点击添加。

    如图1所示,设备含有12块物理网卡,分别为vmnic0~vmnic11,则虚拟交换机需添加12个,分别为vSwitch0~vSwitch11,下图为添加完成状态

     

    五、添加端口组

     

    点击ESXI中网络选项卡并切换至“端口组”面板

    1、点击添加端口组。

    2、输入端口组名称,建议以VM Network数字命名,例如:VM Network1、VM Network2....以此类推。

    3、虚拟交换机中选择要绑定的虚拟交换机名称,建议与VM Network命名搭配,如VM Network1选择vSwitch1、VM Network2选择vSwitch2。

    4、在安全选项中将[混杂模式]、[MAC地址更改]、[伪传输]都改为【接受】。

    5、确认无误后点击添加。

    在上一步已经创建了12个虚拟交换机,则端口组也需添加12个,分别为VM Network~VM Network11,每个端口组对应一个虚拟交换机,下图为添加完成状态

    默认的Management Network端口组不可修改,否则将无法控制ESXI

     

    六、创建ROS虚拟机

     

    1、在ESXI中点击新建虚拟机,并选择创建类型为“从OVF或OVA文件部署虚拟机”,输入虚拟机名称。

     

    2、官方版安装:直接导入下载好的官方OVA模版即可,官方版镜像不含授权

     

    2.1、授权版安装:将下载好的已授权镜像解压会得到.ovf和.vmdk两个文件,将这两个文件全部上传即可。

    [已授权60M镜像和2G区别:60M硬盘版本仅可升级一次系统,2G硬盘版本可一直升级,建议安装2G硬盘镜像。]

     

    3、选择虚拟机安装位置,建议选择SSD硬盘。

     

    4、因为还需进行进一步配置,所以将“自动打开电源”选项关闭,点击下一页。

     

    5、点击“完成”按钮,ROS虚拟机即创建完成。

     

    6、配置ROS:在已创建好的“ROS”虚拟机上右键选择“编辑设置”。

     

    7、配置ROS-虚拟硬件:修改CPU数量和内存大小,建议CPU可以多划分一些,NAT转发等都是靠cpu来处理,内存1G就够用了,新增网络适配器并按照顺序添加好端口组。

    如安装已授权的镜像则【硬盘大小】不可以更改!修改后授权将会失效!

     

    8、配置ROS-虚拟机选项:点击“虚拟机选项”选项卡

    8.1、将“客户机操作系统”修改为:Linux。

    8.2、将“客户机操作系统版本”修改为:其他3.x或更高版本的Linux(64位)。

    8.3、将引导选项中的“固件”修改为:BIOS。

    9、修改完成后点击保存。

     

    10、开启虚拟机电源,开机后输入账号密码,RouterOS(ROS)初始用户为“admin”,密码为空,至此RouterOS(ROS)安装完成。

    七、RouterOS(ROS)各版本授权区别

    支持正版请购买正版L4及其以上的授权,或者购买CHR P1以上的授权。

    CHR授权:

     

    CHR授权优点:可自助不限次数转移,真正意义上的终身授权,推荐购买CHR授权!


    X86授权:

     

    X86授权缺点:绑定硬盘,硬盘坏了授权失效。

    展开全文
  • OSX上安装和使用ROS

    千次阅读 2017-10-23 09:36:04
    ROS官网和Github提供了一些OSX使用ROS的方法。这里做一下总结:参考链接:https://github.com/mikepurvis/ros-install-osx安装使用要点:git clone https://github.com/mikepurvis/ros-install-osx.git cd ros...

      

    ROS官网和Github上提供了一些在OSX上使用ROS的方法。这里做一下总结:


    参考链接:https://github.com/mikepurvis/ros-install-osx

    安装使用要点:

    git clone https://github.com/mikepurvis/ros-install-osx.git
    cd ros-install-osx
    ./install


    ----

    ros-install-osx 

    This repo aims to maintain a usable, scripted, up-to-date installation procedure for ROS, currently Lunar. The intent is that the install script may be executed on a El Capitan or newer machine and produce a working desktop_full installation, including RQT, rviz, and Gazebo.

    This is the successor to my popular gist on the same topic.

    Usage

    git clone https://github.com/mikepurvis/ros-install-osx.git
    cd ros-install-osx
    ./install

    Note that if you do not yet have XQuartz installed, you will be forced to log out and in after that installation, and re-run this script.

    You will be prompted for your sudo password at the following points in this process:

    • Homebrew installation.
    • Caskroom installation.
    • XQuartz installation.
    • Initializing rosdep.
    • Creating and chowning your /opt/ros/[distro] folder.

    The installation can be done entirely without sudo if Homebrew and XQuartz are already installed, rosdep is already installed and initialized, and you set the ROS_INSTALL_DIR environment variable to a path which already exists and you have write access to.

    Step by Step

    The install script should just work for most users. However, if you run into trouble, it's a pretty big pain to rebuild everything. Note that in this scenario, it may make sense to treat the script as a list of instructions, and execute them one by one, manually.

    If you have a build fail, for example with rviz, note that you can modify the catkin build line to start at a particular package. Inside your indigo_desktop_full_ws dir, run:

    catkin build --start-with rviz
    

    If you've resolved whatever issue stopped the build previously, this will pick up where it left off.

    Troubleshooting

    Python and pip packages

    Already-installed homebrew and pip packages are the most significant source of errors, especially pip packages linked against the system Python rather than Homebrew's Python, and Homebrew packages (like Ogre) where multiple versions end up installed, and things which depend on them end up linked to the different versions. If you have MacPorts or Fink installed, and Python from either of those is in your path, that will definitely be trouble.

    The script makes some attempt at detecting and warning about these situations, but some problems of this kind will only be visible as segfaults at runtime.

    Unfortunately, it's pretty destructive to do so, but the most reliable way to give yourself a clean start is removing the current homebrew installation, and all currently-installed pip packages.

    For pip: pip freeze | xargs sudo pip uninstall -y

    For homebrew, see the following: https://gist.github.com/mxcl/1173223

    If you take these steps, obviously also remove your ROS workspace and start the install process over from scratch as well. Finally, audit your $PATH variable to ensure that when you run python, you're getting Homebrew's python. Another way to check which Python you are running is to do:

    which python # Should result in /usr/local/bin/python
    ls -l $(which python) # Should show a symlink pointing to Homebrew's Cellar

    If you are getting permission errors when you sudo uninstall pip packages, see Issue #11 and this StackOverflow Q&A.

    El Capitan support

    The install script may not work as smoothly in OS X El Capitan. Here are some pointers, tips, and hacks to help you complete the installation. This list was compiled based on the discussion in Issue #12.

    library not found for -ltbb

    See Issue #4. You need to compile using Xcode's Command Line Tools:

    xcode-select --install # Install the Command Line Tools
    sudo xcode-select -s /Library/Developer/CommandLineTools # Switch to using them
    gcc --version # Verify that you are compiling using Command Line Tools

    The last command should output something that includes the following:

    Configured with: --prefix=/Library/Developer/CommandLineTools/usr

    You'll then have to rerun the entire install script or do the following:

    rm -rf /opt/ros/indigo/* # More generally, /opt/ros/${ROS_DISTRO}/*
    rm -rf build/ devel/ # Assuming your working dir is the catkin workspace
    catkin build \
      ... # See actual script for the 4-line-long command

    dyld: Library not loaded

    If you see this after installation, when trying to execute rosrun, then you have System Integrity Protection enabled. The installation script should have detected that and suggested a quick fix. Please refer to the very last section of install


    ----




    展开全文
  • Mikrotik的官方文档中,提供了两种在mac os上运行winbox的方法: 1.Wine bottler方式; 2.使用homebrew安装Wine的方式; 第一种方式简单易行,因此,本文章暂时仅提供第一种方法的操作指导。 Winebottler方式,...

    Mikrotik的官方文档中,提供了两种在mac os上运行winbox的方法:

    1.Wine bottler方式;

    2.使用homebrew安装Wine的方式;

    第一种方式简单易行,因此,本文章暂时仅提供第一种方法的操作指导。

    Winebottler方式,需要下载两个软件winbox.exe和winebottler封装工具。

    本机macos版本10.14.1,winbox版本3.18,winebottler版本1.8.6

    winbox的可执行文件,可以从官网直接下载https://mikrotik.com/download

    Winebottler的下载链接:http://winebottler.kronenberg.org/,选择stable(稳定)版本

    安装Wine bottler:运行下载下来的dmg程序包,在弹出窗口中将Wine和WineBottler拖入“应用程序”文件夹中

    在“应用程序”中点击“WineBottler”,运行WineBottler程序,程序安装完成后的首次运行,会提示如下信息:

    需要在“系统偏好设置”-“安全性与隐私”-“通用”中对软件进行解锁,解锁时需要输入机器管理员密码:

    Winebottler运行后,直接点击“Advanced”选项卡,对已下载的winbox.exe进行封装操作:

    1.“Program Installatior”-“select File”选择已下载的winbox.exe文件的所在路径

    2.“Installation mode”选择“copy file (Program) to the App Bundle”

    3.“System Version Info”选择“7”即Windows7

    4.可以直接点击“Install”,直接对选中的winbox可执行文件进行封装操作

    5.设置封装后的软件包的文件名与存放路径

    6.软件包封装中

    7.提示app包制作完成

    将封装好的winbox包直接拖入“应用程序”中使用即可,唯一的缺点是封装后的软件包比原始可执行文件包要大很多~

    8.运行最终app包的软件界面

    展开全文
  • ROS安装

    千次阅读 2018-06-10 17:29:44
    ROS平台下:从零开始学习SLAM(Part1 ROS初探)行文结构 写这篇博文时,我特意找了一位从未接触过ROS,但接触过Ubuntu的峰峰仔同学,让他以一位初学者的身份向我提问。通过整理我们之间谈话的内容,我决定从三个...
  • Mac OS 安装ROS indigo

    万次阅读 2017-03-23 10:44:09
    刚入手一个Mac 打算抛弃ubuntu投奔Mac os 的怀抱,废话不多说 首先在安装ros之前需要安装brew(安装网站:https://brew.sh)这个超简单pass。 下面是安装ros的步骤 首先运行以下命令来添加附加软件 $ brew update $...
  • ROS2 MAC OS Install

    2019-07-21 03:07:32
    ROS2MAC OS Install(非原创),安装过程记录一下 注意: (1)如果安装了anaconda,请将~/.bash_profile文件中的export PATH="/anaconda3/bin:$PATH"屏蔽,否则默认使用anaconda中的python,导致接下来安装catkin...
  • ROS配置MAC地址过滤

    2020-01-08 13:52:52
    由于无线网卡和物理网卡桥接一起,所以mac过滤要网桥配置。 1,打开Bridge–>Filaters,配置网桥MAC过滤规则。 2,General标签中,Chain选择input,不是forward。In. Bridege选择要进行过滤的网桥。Src. ...
  • 破解光猫后拿到tr069的pppoe账号密码,建立pppoe连接时对方无响应,没有提示,...1,查看光猫中的MAC地址,联通光猫的几个pppoe接口MAC地址都不相同,所以导致了拨号失败。2,创建bridge,设置Admin. MAC Address...
  • ·1.2版本开始,Mac OS X TensorFlow不再支持GPU ·有四种安装方式: ·virtualenv ·本地 pip ·Docker ·从源代码安装 其中推荐了virtualenv,我也是使用了这种方法,十分简便没有出什么问题 // 与其他...
  • bug主要在安装ROS indigo: 主要根据易科实验室进行安装 1. 更新设置 2.2. 点击上方Other software,点击左下角add按钮 3.sudo apt-get update 4. 解决依赖 sudo -E rosdep init (自己改...
  • ros VRR改MAC地址的方法

    2020-07-30 23:30:32
    ROS VRR改MAC地址的方法,绝对可行的方法,轻松实现单线多拨!
  • 转载于:https://www.cnblogs.com/yangjig/p/6185124.html
  • ros mac 修改

    2019-05-30 23:07:45
    修改某个VRRP 的MAC的教程 { :local vrrpname vrrp20 :local mac [/int vrrp get [find name=$vrrpname] mac-address] :local mac2 [:pick $mac 9 50] :local macA ("0E:9B:dA:".$mac2) :fore i in=[/interface ...
  • PVE安装ros系统

    千次阅读 2019-11-21 20:27:23
    ROS模板(下载地址:https://pan.baidu.com/s/1HfZk4XWLoWEFrya7ivlf1A&shfl=sharepset) WinSCP客户端(下载地址:https://pan.baidu.com/s/1w7C-X_g5mBCOsGvqVZdfTg&shfl=sharepset) Winbox(下载地址...
  • 6. vSphere ESXi上安装RouterOS v5.20

    千次阅读 2016-07-15 13:52:05
    RouterOS是一款流行的路由操作系统,核心为Linux内核,安装在X86机器,使普通的PC变成专来的路由器。 RouterOS也可以安装在虚拟化服务器,以提供相应的服务。 首先将ISO镜像文件上传至本地,如下图,点击...
  • RouterOS中修改mac地址的方法 RouterOS中修改mac地址的方法admin@MikroTik] > interface ethernet pr 修改前 Flags: X - disabled, R - running # NAME MTU MAC-ADDRESS ARP 0 R e...
  • ROS Melodic版本2018年5月23日推出正式版,这是ROS第三款长期支持版本,前2版LTS分别为:indigo(14.04);kinetic(16.04)。此版本有windows版已经推出,无需更换Linux,一小时安装完成: Windows使用ROS机器人操作...
  • ROS 6x 第一步数据标记 /ip firewall mangle add action=mark-connection chain=forward disabled=yes new-connection-mark=mac \ passthrough=yes src-address=192.168.1.0/24src-mac-address=\ 18:DE:DD:80...
  • Windows10安装和使用机器人操作系统ROS补充说明

    万次阅读 热门讨论 2019-11-05 16:45:14
    适用于Windows的ROS: https://microsoft.github.io/Win-RoS-Landing-Page/#人们一直对机器人着迷。今天,先进的机器人正在改变我们的生活,无论是工作还是家里。仓库机器人已经为在线购物者提供了次日送货服务...
1 2 3 4 5 ... 20
收藏数 1,868
精华内容 747
热门标签
关键字:

os上安装ros 在mac