linux_linux 教程 - CSDN
linux 订阅
Linux,全称GNU/Linux,是一套免费使用和自由传播的类UNIX操作系统,其内核由林纳斯·本纳第克特·托瓦兹于1991年第一次释出,它主要受到Minix和Unix思想的启发,是一个基于POSIX和Unix的多用户、多任务、支持多线程和多CPU的操作系统。它能运行主要的Unix工具软件、应用程序和网络协议。它支持32位和64位硬件。Linux继承了Unix以网络为核心的设计思想,是一个性能稳定的多用户网络操作系统。Linux有上百种不同的发行版,如基于社区开发的debian、archlinux,和基于商业开发的Red Hat Enterprise Linux、SUSE、oracle linux等。 展开全文
Linux,全称GNU/Linux,是一套免费使用和自由传播的类UNIX操作系统,其内核由林纳斯·本纳第克特·托瓦兹于1991年第一次释出,它主要受到Minix和Unix思想的启发,是一个基于POSIX和Unix的多用户、多任务、支持多线程和多CPU的操作系统。它能运行主要的Unix工具软件、应用程序和网络协议。它支持32位和64位硬件。Linux继承了Unix以网络为核心的设计思想,是一个性能稳定的多用户网络操作系统。Linux有上百种不同的发行版,如基于社区开发的debian、archlinux,和基于商业开发的Red Hat Enterprise Linux、SUSE、oracle linux等。
信息
最新测试版本
5.8-rc1
最新版本
5.7.4
类    别
操作系统内核
特    点
免费、可靠、安全、稳定、多平台
更新时间
2020-04-12
创始人
林纳斯·托瓦兹
外文名
Linux
发布时间
1991年10月5日
发行版本
Debian、RedHat、Centos、Slackware、clearlinux.等
linux简介
Linux,全称GNU/Linux,是一套免费使用和自由传播的类Unix操作系统,是一个基于POSIX和Unix的多用户、多任务、支持多线程和多CPU的操作系统。伴随着互联网的发展,Linux得到了来自全世界软件爱好者、组织、公司的支持。它除了在服务器方面保持着强劲的发展势头以外,在个人电脑、嵌入式系统上都有着长足的进步。使用者不仅可以直观地获取该操作系统的实现机制,而且可以根据自身的需要来修改完善Linux,使其最大化地适应用户的需要。 [1]  Linux不仅系统性能稳定,而且是开源软件。其核心防火墙组件性能高效、配置简单,保证了系统的安全。在很多企业网络中,为了追求速度和安全,Linux不仅仅是被网络运维人员当作服务器使用,Linux既可以当作服务器,又可以当作网络防火墙是Linux的 一大亮点。 [2]  Linux 具有开放源码、没有版权、技术社区用户多等特点 ,开放源码使得用户可以自由裁剪,灵活性高,功能强大,成本低。尤其系统中内嵌网络协议栈 ,经过适当的配置就可实现路由器的功能。这些特点使得Linux成为开发路由交换设备的理想开发平台。 [3] 
收起全文
精华内容
参与话题
  • Linux从入门到精通(全套系列)

    万人学习 2020-02-26 17:50:11
    Linux从入门到系列课程,全部重点放在企业应用上面。课程主要针对互联网企业运维,因此不会花多余的时间去阐述无关紧要和企业用不到的东西,所以全程都是围绕实战运维,操作为主。
  • Linux教程+操作系统教程 -- 大全

    万次阅读 多人点赞 2018-08-16 17:19:20
    1. Linux入门教程 http://c.biancheng.net/cpp/linux/ 基础教程 Linux简介 Linux文件管理 Linux目录 Linux文件权限和访问模式 Linux环境变量 Linux打印文件和发送邮件 Linux管道和过滤器 Linux进程...
    展开全文
  • Linux常用命令大全(非常全!!!)

    万次阅读 多人点赞 2019-07-26 11:04:35
    Linux常用命令大全(非常全!!!) 最近都在和Linux打交道,感觉还不错。我觉得Linux相比windows比较麻烦的就是很多东西都要用命令来控制,当然,这也是很多人喜欢linux的原因,比较短小但却功能强大。我将我了解...

    Linux常用命令大全(非常全!!!)

    最近都在和Linux打交道,感觉还不错。我觉得Linux相比windows比较麻烦的就是很多东西都要用命令来控制,当然,这也是很多人喜欢linux的原因,比较短小但却功能强大。我将我了解到的命令列举一下,仅供大家参考:

     

    系统信息 
    arch 显示机器的处理器架构
    uname -m 显示机器的处理器架构
    uname -r 显示正在使用的内核版本 
    dmidecode -q 显示硬件系统部件 - (SMBIOS / DMI) 
    hdparm -i /dev/hda 罗列一个磁盘的架构特性 
    hdparm -tT /dev/sda 在磁盘上执行测试性读取操作 
    cat /proc/cpuinfo 显示CPU info的信息 
    cat /proc/interrupts 显示中断 
    cat /proc/meminfo 校验内存使用 
    cat /proc/swaps 显示哪些swap被使用 
    cat /proc/version 显示内核的版本 
    cat /proc/net/dev 显示网络适配器及统计 
    cat /proc/mounts 显示已加载的文件系统 
    lspci -tv 罗列 PCI 设备 
    lsusb -tv 显示 USB 设备 
    date 显示系统日期 
    cal 2007 显示2007年的日历表 
    date 041217002007.00 设置日期和时间 - 月日时分年.秒 
    clock -w 将时间修改保存到 BIOS 



    关机 (系统的关机、重启以及登出 ) 
    shutdown -h now 关闭系统
    init 0 关闭系统
    telinit 0 关闭系统
    shutdown -h hours:minutes & 按预定时间关闭系统 
    shutdown -c 取消按预定时间关闭系统 
    shutdown -r now 重启
    reboot 重启
    logout 注销 



    文件和目录 
    cd /home 进入 '/ home' 目录' 
    cd .. 返回上一级目录 
    cd ../.. 返回上两级目录 
    cd 进入个人的主目录 
    cd ~user1 进入个人的主目录 
    cd - 返回上次所在的目录 
    pwd 显示工作路径 
    ls 查看目录中的文件 
    ls -F 查看目录中的文件 
    ls -l 显示文件和目录的详细资料 
    ls -a 显示隐藏文件 
    ls *[0-9]* 显示包含数字的文件名和目录名 
    tree 显示文件和目录由根目录开始的树形结构
    lstree 显示文件和目录由根目录开始的树形结构
    mkdir dir1 创建一个叫做 'dir1' 的目录' 
    mkdir dir1 dir2 同时创建两个目录 
    mkdir -p /tmp/dir1/dir2 创建一个目录树 
    rm -f file1 删除一个叫做 'file1' 的文件' 
    rmdir dir1 删除一个叫做 'dir1' 的目录' 
    rm -rf dir1 删除一个叫做 'dir1' 的目录并同时删除其内容 
    rm -rf dir1 dir2 同时删除两个目录及它们的内容 
    mv dir1 new_dir 重命名/移动 一个目录 
    cp file1 file2 复制一个文件 
    cp dir/* . 复制一个目录下的所有文件到当前工作目录 
    cp -a /tmp/dir1 . 复制一个目录到当前工作目录 
    cp -a dir1 dir2 复制一个目录 

    cp -r dir1 dir2 复制一个目录及子目录
    ln -s file1 lnk1 创建一个指向文件或目录的软链接 
    ln file1 lnk1 创建一个指向文件或目录的物理链接 
    touch -t 0712250000 file1 修改一个文件或目录的时间戳 - (YYMMDDhhmm) 
    file file1 outputs the mime type of the file as text 
    iconv -l 列出已知的编码 
    iconv -f fromEncoding -t toEncoding inputFile > outputFile creates a new from the given input file by assuming it is encoded in fromEncoding and converting it to toEncoding. 
    find . -maxdepth 1 -name *.jpg -print -exec convert "{}" -resize 80x60 "thumbs/{}" \; batch resize files in the current directory and send them to a thumbnails directory (requires convert from Imagemagick) 



    文件搜索 
    find / -name file1 从 '/' 开始进入根文件系统搜索文件和目录 
    find / -user user1 搜索属于用户 'user1' 的文件和目录 
    find /home/user1 -name \*.bin 在目录 '/ home/user1' 中搜索带有'.bin' 结尾的文件 
    find /usr/bin -type f -atime +100 搜索在过去100天内未被使用过的执行文件 
    find /usr/bin -type f -mtime -10 搜索在10天内被创建或者修改过的文件 
    find / -name \*.rpm -exec chmod 755 '{}' \; 搜索以 '.rpm' 结尾的文件并定义其权限 
    find / -xdev -name \*.rpm 搜索以 '.rpm' 结尾的文件,忽略光驱、捷盘等可移动设备 
    locate \*.ps 寻找以 '.ps' 结尾的文件 - 先运行 'updatedb' 命令 
    whereis halt 显示一个二进制文件、源码或man的位置 
    which halt 显示一个二进制文件或可执行文件的完整路径 



    挂载一个文件系统 
    mount /dev/hda2 /mnt/hda2 挂载一个叫做hda2的盘 - 确定目录 '/ mnt/hda2' 已经存在 
    umount /dev/hda2 卸载一个叫做hda2的盘 - 先从挂载点 '/ mnt/hda2' 退出 
    fuser -km /mnt/hda2 当设备繁忙时强制卸载 
    umount -n /mnt/hda2 运行卸载操作而不写入 /etc/mtab 文件- 当文件为只读或当磁盘写满时非常有用 
    mount /dev/fd0 /mnt/floppy 挂载一个软盘 
    mount /dev/cdrom /mnt/cdrom 挂载一个cdrom或dvdrom 
    mount /dev/hdc /mnt/cdrecorder 挂载一个cdrw或dvdrom 
    mount /dev/hdb /mnt/cdrecorder 挂载一个cdrw或dvdrom 
    mount -o loop file.iso /mnt/cdrom 挂载一个文件或ISO镜像文件 
    mount -t vfat /dev/hda5 /mnt/hda5 挂载一个Windows FAT32文件系统 
    mount /dev/sda1 /mnt/usbdisk 挂载一个usb 捷盘或闪存设备 
    mount -t smbfs -o username=user,password=pass //WinClient/share /mnt/share 挂载一个windows网络共享 



    磁盘空间 
    df -h 显示已经挂载的分区列表 
    ls -lSr |more 以尺寸大小排列文件和目录 
    du -sh dir1 估算目录 'dir1' 已经使用的磁盘空间' 
    du -sk * | sort -rn 以容量大小为依据依次显示文件和目录的大小 
    rpm -q -a --qf '%10{SIZE}t%{NAME}n' | sort -k1,1n 以大小为依据依次显示已安装的rpm包所使用的空间 (fedora, redhat类系统) 
    dpkg-query -W -f='${Installed-Size;10}t${Package}n' | sort -k1,1n 以大小为依据显示已安装的deb包所使用的空间 (ubuntu, debian类系统) 



    用户和群组 
    groupadd group_name 创建一个新用户组 
    groupdel group_name 删除一个用户组 
    groupmod -n new_group_name old_group_name 重命名一个用户组 
    useradd -c "Name Surname " -g admin -d /home/user1 -s /bin/bash user1 创建一个属于 "admin" 用户组的用户 
    useradd user1 创建一个新用户 
    userdel -r user1 删除一个用户 ( '-r' 排除主目录) 
    usermod -c "User FTP" -g system -d /ftp/user1 -s /bin/nologin user1 修改用户属性 
    passwd 修改口令 
    passwd user1 修改一个用户的口令 (只允许root执行) 
    chage -E 2005-12-31 user1 设置用户口令的失效期限 
    pwck 检查 '/etc/passwd' 的文件格式和语法修正以及存在的用户 
    grpck 检查 '/etc/passwd' 的文件格式和语法修正以及存在的群组 
    newgrp group_name 登陆进一个新的群组以改变新创建文件的预设群组 



    文件的权限 - 使用 "+" 设置权限,使用 "-" 用于取消 
    ls -lh 显示权限 
    ls /tmp | pr -T5 -W$COLUMNS 将终端划分成5栏显示 
    chmod ugo+rwx directory1 设置目录的所有人(u)、群组(g)以及其他人(o)以读(r )、写(w)和执行(x)的权限 
    chmod go-rwx directory1 删除群组(g)与其他人(o)对目录的读写执行权限 
    chown user1 file1 改变一个文件的所有人属性 
    chown -R user1 directory1 改变一个目录的所有人属性并同时改变改目录下所有文件的属性 
    chgrp group1 file1 改变文件的群组 
    chown user1:group1 file1 改变一个文件的所有人和群组属性 
    find / -perm -u+s 罗列一个系统中所有使用了SUID控制的文件 
    chmod u+s /bin/file1 设置一个二进制文件的 SUID 位 - 运行该文件的用户也被赋予和所有者同样的权限 
    chmod u-s /bin/file1 禁用一个二进制文件的 SUID位 
    chmod g+s /home/public 设置一个目录的SGID 位 - 类似SUID ,不过这是针对目录的 
    chmod g-s /home/public 禁用一个目录的 SGID 位 
    chmod o+t /home/public 设置一个文件的 STIKY 位 - 只允许合法所有人删除文件 
    chmod o-t /home/public 禁用一个目录的 STIKY 位 



    文件的特殊属性 - 使用 "+" 设置权限,使用 "-" 用于取消 
    chattr +a file1 只允许以追加方式读写文件 
    chattr +c file1 允许这个文件能被内核自动压缩/解压 
    chattr +d file1 在进行文件系统备份时,dump程序将忽略这个文件 
    chattr +i file1 设置成不可变的文件,不能被删除、修改、重命名或者链接 
    chattr +s file1 允许一个文件被安全地删除 
    chattr +S file1 一旦应用程序对这个文件执行了写操作,使系统立刻把修改的结果写到磁盘 
    chattr +u file1 若文件被删除,系统会允许你在以后恢复这个被删除的文件 
    lsattr 显示特殊的属性 



    打包和压缩文件 
    bunzip2 file1.bz2 解压一个叫做 'file1.bz2'的文件 
    bzip2 file1 压缩一个叫做 'file1' 的文件 
    gunzip file1.gz 解压一个叫做 'file1.gz'的文件 
    gzip file1 压缩一个叫做 'file1'的文件 
    gzip -9 file1 最大程度压缩 
    rar a file1.rar test_file 创建一个叫做 'file1.rar' 的包 
    rar a file1.rar file1 file2 dir1 同时压缩 'file1', 'file2' 以及目录 'dir1' 
    rar x file1.rar 解压rar包 
    unrar x file1.rar 解压rar包 
    tar -cvf archive.tar file1 创建一个非压缩的 tarball 
    tar -cvf archive.tar file1 file2 dir1 创建一个包含了 'file1', 'file2' 以及 'dir1'的档案文件 
    tar -tf archive.tar 显示一个包中的内容 
    tar -xvf archive.tar 释放一个包 
    tar -xvf archive.tar -C /tmp 将压缩包释放到 /tmp目录下 
    tar -cvfj archive.tar.bz2 dir1 创建一个bzip2格式的压缩包 
    tar -jxvf archive.tar.bz2 解压一个bzip2格式的压缩包 
    tar -cvfz archive.tar.gz dir1 创建一个gzip格式的压缩包 
    tar -zxvf archive.tar.gz 解压一个gzip格式的压缩包 
    zip file1.zip file1 创建一个zip格式的压缩包 
    zip -r file1.zip file1 file2 dir1 将几个文件和目录同时压缩成一个zip格式的压缩包 
    unzip file1.zip 解压一个zip格式压缩包 



    RPM 包 - (Fedora, Redhat及类似系统) 
    rpm -ivh package.rpm 安装一个rpm包 
    rpm -ivh --nodeeps package.rpm 安装一个rpm包而忽略依赖关系警告 
    rpm -U package.rpm 更新一个rpm包但不改变其配置文件 
    rpm -F package.rpm 更新一个确定已经安装的rpm包 
    rpm -e package_name.rpm 删除一个rpm包 
    rpm -qa 显示系统中所有已经安装的rpm包 
    rpm -qa | grep httpd 显示所有名称中包含 "httpd" 字样的rpm包 
    rpm -qi package_name 获取一个已安装包的特殊信息 
    rpm -qg "System Environment/Daemons" 显示一个组件的rpm包 
    rpm -ql package_name 显示一个已经安装的rpm包提供的文件列表 
    rpm -qc package_name 显示一个已经安装的rpm包提供的配置文件列表 
    rpm -q package_name --whatrequires 显示与一个rpm包存在依赖关系的列表 
    rpm -q package_name --whatprovides 显示一个rpm包所占的体积 
    rpm -q package_name --scripts 显示在安装/删除期间所执行的脚本l 
    rpm -q package_name --changelog 显示一个rpm包的修改历史 
    rpm -qf /etc/httpd/conf/httpd.conf 确认所给的文件由哪个rpm包所提供 
    rpm -qp package.rpm -l 显示由一个尚未安装的rpm包提供的文件列表 
    rpm --import /media/cdrom/RPM-GPG-KEY 导入公钥数字证书 
    rpm --checksig package.rpm 确认一个rpm包的完整性 
    rpm -qa gpg-pubkey 确认已安装的所有rpm包的完整性 
    rpm -V package_name 检查文件尺寸、 许可、类型、所有者、群组、MD5检查以及最后修改时间 
    rpm -Va 检查系统中所有已安装的rpm包- 小心使用 
    rpm -Vp package.rpm 确认一个rpm包还未安装 
    rpm2cpio package.rpm | cpio --extract --make-directories *bin* 从一个rpm包运行可执行文件 
    rpm -ivh /usr/src/redhat/RPMS/`arch`/package.rpm 从一个rpm源码安装一个构建好的包 
    rpmbuild --rebuild package_name.src.rpm 从一个rpm源码构建一个 rpm 包 



    YUM 软件包升级器 - (Fedora, RedHat及类似系统) 
    yum install package_name 下载并安装一个rpm包 
    yum localinstall package_name.rpm 将安装一个rpm包,使用你自己的软件仓库为你解决所有依赖关系 
    yum update package_name.rpm 更新当前系统中所有安装的rpm包 
    yum update package_name 更新一个rpm包 
    yum remove package_name 删除一个rpm包 
    yum list 列出当前系统中安装的所有包 
    yum search package_name 在rpm仓库中搜寻软件包 
    yum clean packages 清理rpm缓存删除下载的包 
    yum clean headers 删除所有头文件 
    yum clean all 删除所有缓存的包和头文件 



    DEB 包 (Debian, Ubuntu 以及类似系统) 
    dpkg -i package.deb 安装/更新一个 deb 包 
    dpkg -r package_name 从系统删除一个 deb 包 
    dpkg -l 显示系统中所有已经安装的 deb 包 
    dpkg -l | grep httpd 显示所有名称中包含 "httpd" 字样的deb包 
    dpkg -s package_name 获得已经安装在系统中一个特殊包的信息 
    dpkg -L package_name 显示系统中已经安装的一个deb包所提供的文件列表 
    dpkg --contents package.deb 显示尚未安装的一个包所提供的文件列表 
    dpkg -S /bin/ping 确认所给的文件由哪个deb包提供 



    APT 软件工具 (Debian, Ubuntu 以及类似系统) 
    apt-get install package_name 安装/更新一个 deb 包 
    apt-cdrom install package_name 从光盘安装/更新一个 deb 包 
    apt-get update 升级列表中的软件包 
    apt-get upgrade 升级所有已安装的软件 
    apt-get remove package_name 从系统删除一个deb包 
    apt-get check 确认依赖的软件仓库正确 
    apt-get clean 从下载的软件包中清理缓存 
    apt-cache search searched-package 返回包含所要搜索字符串的软件包名称 



    查看文件内容 
    cat file1 从第一个字节开始正向查看文件的内容 
    tac file1 从最后一行开始反向查看一个文件的内容 
    more file1 查看一个长文件的内容 
    less file1 类似于 'more' 命令,但是它允许在文件中和正向操作一样的反向操作 
    head -2 file1 查看一个文件的前两行 
    tail -2 file1 查看一个文件的最后两行 
    tail -f /var/log/messages 实时查看被添加到一个文件中的内容 



    文本处理 
    cat file1 file2 ... | command <> file1_in.txt_or_file1_out.txt general syntax for text manipulation using PIPE, STDIN and STDOUT 
    cat file1 | command( sed, grep, awk, grep, etc...) > result.txt 合并一个文件的详细说明文本,并将简介写入一个新文件中 
    cat file1 | command( sed, grep, awk, grep, etc...) >> result.txt 合并一个文件的详细说明文本,并将简介写入一个已有的文件中 
    grep Aug /var/log/messages 在文件 '/var/log/messages'中查找关键词"Aug" 
    grep ^Aug /var/log/messages 在文件 '/var/log/messages'中查找以"Aug"开始的词汇 
    grep [0-9] /var/log/messages 选择 '/var/log/messages' 文件中所有包含数字的行 
    grep Aug -R /var/log/* 在目录 '/var/log' 及随后的目录中搜索字符串"Aug" 
    sed 's/stringa1/stringa2/g' example.txt 将example.txt文件中的 "string1" 替换成 "string2" 
    sed '/^$/d' example.txt 从example.txt文件中删除所有空白行 
    sed '/ *#/d; /^$/d' example.txt 从example.txt文件中删除所有注释和空白行 
    echo 'esempio' | tr '[:lower:]' '[:upper:]' 合并上下单元格内容 
    sed -e '1d' result.txt 从文件example.txt 中排除第一行 
    sed -n '/stringa1/p' 查看只包含词汇 "string1"的行 
    sed -e 's/ *$//' example.txt 删除每一行最后的空白字符 
    sed -e 's/stringa1//g' example.txt 从文档中只删除词汇 "string1" 并保留剩余全部 
    sed -n '1,5p;5q' example.txt 查看从第一行到第5行内容 
    sed -n '5p;5q' example.txt 查看第5行 
    sed -e 's/00*/0/g' example.txt 用单个零替换多个零 
    cat -n file1 标示文件的行数 
    cat example.txt | awk 'NR%2==1' 删除example.txt文件中的所有偶数行 
    echo a b c | awk '{print $1}' 查看一行第一栏 
    echo a b c | awk '{print $1,$3}' 查看一行的第一和第三栏 
    paste file1 file2 合并两个文件或两栏的内容 
    paste -d '+' file1 file2 合并两个文件或两栏的内容,中间用"+"区分 
    sort file1 file2 排序两个文件的内容 
    sort file1 file2 | uniq 取出两个文件的并集(重复的行只保留一份) 
    sort file1 file2 | uniq -u 删除交集,留下其他的行 
    sort file1 file2 | uniq -d 取出两个文件的交集(只留下同时存在于两个文件中的文件) 
    comm -1 file1 file2 比较两个文件的内容只删除 'file1' 所包含的内容 
    comm -2 file1 file2 比较两个文件的内容只删除 'file2' 所包含的内容 
    comm -3 file1 file2 比较两个文件的内容只删除两个文件共有的部分 




    字符设置和文件格式转换 
    dos2unix filedos.txt fileunix.txt 将一个文本文件的格式从MSDOS转换成UNIX 
    unix2dos fileunix.txt filedos.txt 将一个文本文件的格式从UNIX转换成MSDOS 
    recode ..HTML < page.txt > page.html 将一个文本文件转换成html 
    recode -l | more 显示所有允许的转换格式 



    文件系统分析 
    badblocks -v /dev/hda1 检查磁盘hda1上的坏磁块 
    fsck /dev/hda1 修复/检查hda1磁盘上linux文件系统的完整性 
    fsck.ext2 /dev/hda1 修复/检查hda1磁盘上ext2文件系统的完整性 
    e2fsck /dev/hda1 修复/检查hda1磁盘上ext2文件系统的完整性 
    e2fsck -j /dev/hda1 修复/检查hda1磁盘上ext3文件系统的完整性 
    fsck.ext3 /dev/hda1 修复/检查hda1磁盘上ext3文件系统的完整性 
    fsck.vfat /dev/hda1 修复/检查hda1磁盘上fat文件系统的完整性 
    fsck.msdos /dev/hda1 修复/检查hda1磁盘上dos文件系统的完整性 
    dosfsck /dev/hda1 修复/检查hda1磁盘上dos文件系统的完整性 



    初始化一个文件系统 
    mkfs /dev/hda1 在hda1分区创建一个文件系统 
    mke2fs /dev/hda1 在hda1分区创建一个linux ext2的文件系统 
    mke2fs -j /dev/hda1 在hda1分区创建一个linux ext3(日志型)的文件系统 
    mkfs -t vfat 32 -F /dev/hda1 创建一个 FAT32 文件系统 
    fdformat -n /dev/fd0 格式化一个软盘 
    mkswap /dev/hda3 创建一个swap文件系统 



    SWAP文件系统 
    mkswap /dev/hda3 创建一个swap文件系统 
    swapon /dev/hda3 启用一个新的swap文件系统 
    swapon /dev/hda2 /dev/hdb3 启用两个swap分区 



    备份 
    dump -0aj -f /tmp/home0.bak /home 制作一个 '/home' 目录的完整备份 
    dump -1aj -f /tmp/home0.bak /home 制作一个 '/home' 目录的交互式备份 
    restore -if /tmp/home0.bak 还原一个交互式备份 
    rsync -rogpav --delete /home /tmp 同步两边的目录 
    rsync -rogpav -e ssh --delete /home ip_address:/tmp 通过SSH通道rsync 
    rsync -az -e ssh --delete ip_addr:/home/public /home/local 通过ssh和压缩将一个远程目录同步到本地目录 
    rsync -az -e ssh --delete /home/local ip_addr:/home/public 通过ssh和压缩将本地目录同步到远程目录 
    dd bs=1M if=/dev/hda | gzip | ssh user@ip_addr 'dd of=hda.gz' 通过ssh在远程主机上执行一次备份本地磁盘的操作 
    dd if=/dev/sda of=/tmp/file1 备份磁盘内容到一个文件 
    tar -Puf backup.tar /home/user 执行一次对 '/home/user' 目录的交互式备份操作 
    ( cd /tmp/local/ && tar c . ) | ssh -C user@ip_addr 'cd /home/share/ && tar x -p' 通过ssh在远程目录中复制一个目录内容 
    ( tar c /home ) | ssh -C user@ip_addr 'cd /home/backup-home && tar x -p' 通过ssh在远程目录中复制一个本地目录 
    tar cf - . | (cd /tmp/backup ; tar xf - ) 本地将一个目录复制到另一个地方,保留原有权限及链接 
    find /home/user1 -name '*.txt' | xargs cp -av --target-directory=/home/backup/ --parents 从一个目录查找并复制所有以 '.txt' 结尾的文件到另一个目录 
    find /var/log -name '*.log' | tar cv --files-from=- | bzip2 > log.tar.bz2 查找所有以 '.log' 结尾的文件并做成一个bzip包 
    dd if=/dev/hda of=/dev/fd0 bs=512 count=1 做一个将 MBR (Master Boot Record)内容复制到软盘的动作 
    dd if=/dev/fd0 of=/dev/hda bs=512 count=1 从已经保存到软盘的备份中恢复MBR内容 



    光盘 
    cdrecord -v gracetime=2 dev=/dev/cdrom -eject blank=fast -force 清空一个可复写的光盘内容 
    mkisofs /dev/cdrom > cd.iso 在磁盘上创建一个光盘的iso镜像文件 
    mkisofs /dev/cdrom | gzip > cd_iso.gz 在磁盘上创建一个压缩了的光盘iso镜像文件 
    mkisofs -J -allow-leading-dots -R -V "Label CD" -iso-level 4 -o ./cd.iso data_cd 创建一个目录的iso镜像文件 
    cdrecord -v dev=/dev/cdrom cd.iso 刻录一个ISO镜像文件 
    gzip -dc cd_iso.gz | cdrecord dev=/dev/cdrom - 刻录一个压缩了的ISO镜像文件 
    mount -o loop cd.iso /mnt/iso 挂载一个ISO镜像文件 
    cd-paranoia -B 从一个CD光盘转录音轨到 wav 文件中 
    cd-paranoia -- "-3" 从一个CD光盘转录音轨到 wav 文件中(参数-3) 
    cdrecord --scanbus 扫描总线以识别scsi通道 
    dd if=/dev/hdc | md5sum 校验一个设备的md5sum编码,例如一张 CD 



    网络 - (以太网和WIFI无线) 
    ifconfig eth0 显示一个以太网卡的配置 
    ifup eth0 启用一个 'eth0' 网络设备 
    ifdown eth0 禁用一个 'eth0' 网络设备 
    ifconfig eth0 192.168.1.1 netmask 255.255.255.0 控制IP地址 
    ifconfig eth0 promisc 设置 'eth0' 成混杂模式以嗅探数据包 (sniffing) 
    dhclient eth0 以dhcp模式启用 'eth0' 
    route -n show routing table 
    route add -net 0/0 gw IP_Gateway configura default gateway 
    route add -net 192.168.0.0 netmask 255.255.0.0 gw 192.168.1.1 configure static route to reach network '192.168.0.0/16' 
    route del 0/0 gw IP_gateway remove static route 
    echo "1" > /proc/sys/net/ipv4/ip_forward activate ip routing 
    hostname show hostname of system 
    host www.example.com lookup hostname to resolve name to ip address and viceversa
    nslookup www.example.com lookup hostname to resolve name to ip address and viceversa
    ip link show show link status of all interfaces 
    mii-tool eth0 show link status of 'eth0' 
    ethtool eth0 show statistics of network card 'eth0' 
    netstat -tup show all active network connections and their PID 
    netstat -tupl show all network services listening on the system and their PID 
    tcpdump tcp port 80 show all HTTP traffic 
    iwlist scan show wireless networks 
    iwconfig eth1 show configuration of a wireless network card 
    hostname show hostname 
    host www.example.com lookup hostname to resolve name to ip address and viceversa 
    nslookup www.example.com lookup hostname to resolve name to ip address and viceversa 
    whois www.example.com lookup on Whois database 

     

    JPS工具

    jps(Java Virtual Machine Process Status Tool)是JDK 1.5提供的一个显示当前所有java进程pid的命令,简单实用,非常适合在linux/unix平台上简单察看当前java进程的一些简单情况。

        我想很多人都是用过unix系统里的ps命令,这个命令主要是用来显示当前系统的进程情况,有哪些进程,及其 id。 jps 也是一样,它的作用是显示当前系统的java进程情况,及其id号。我们可以通过它来查看我们到底启动了几个java进程(因为每一个java程序都会独占一个java虚拟机实例),和他们的进程号(为下面几个程序做准备),并可通过opt来查看这些进程的详细启动参数。

         使用方法:在当前命令行下打 jps(需要JAVA_HOME,没有的话,到改程序的目录下打) 。

    jps存放在JAVA_HOME/bin/jps,使用时为了方便请将JAVA_HOME/bin/加入到Path.

    $> jps
    23991 Jps
    23789 BossMain
    23651 Resin

     


    比较常用的参数:

    -q 只显示pid,不显示class名称,jar文件名和传递给main 方法的参数
    $>  jps -q
    28680
    23789
    23651

    -m 输出传递给main 方法的参数,在嵌入式jvm上可能是null

    $> jps -m
    28715 Jps -m
    23789 BossMain
    23651 Resin -socketwait 32768 -stdout /data/aoxj/resin/log/stdout.log -stderr /data/aoxj/resin/log/stderr.log

    -l 输出应用程序main class的完整package名 或者 应用程序的jar文件完整路径名

    $> jps -l
    28729 sun.tools.jps.Jps
    23789 com.asiainfo.aimc.bossbi.BossMain
    23651 com.caucho.server.resin.Resin

    -v 输出传递给JVM的参数

    $> jps -v
    23789 BossMain
    28802 Jps -Denv.class.path=/data/aoxj/bossbi/twsecurity/java/trustwork140.jar:/data/aoxj/bossbi/twsecurity/java/:/data/aoxj/bossbi/twsecurity/java/twcmcc.jar:/data/aoxj/jdk15/lib/rt.jar:/data/aoxj/jd

    k15/lib/tools.jar -Dapplication.home=/data/aoxj/jdk15 -Xms8m
    23651 Resin -Xss1m -Dresin.home=/data/aoxj/resin -Dserver.root=/data/aoxj/resin -Djava.util.logging.manager=com.caucho.log.LogManagerImpl -

    Djavax.management.builder.initial=com.caucho.jmx.MBeanServerBuilderImpl

    sudo jps看到的进程数量最全

    jps 192.168.0.77

    列出远程服务器192.168.0.77机器所有的jvm实例,采用rmi协议,默认连接端口为1099

    (前提是远程服务器提供jstatd服务)

    注:jps命令有个地方很不好,似乎只能显示当前用户的java进程,要显示其他用户的还是只能用unix/linux的ps命令。

    转自:https://www.cnblogs.com/yjd_hycf_space/p/7730690.html

    详细情况请参考sun官方文档。
    http://java.sun.com/j2se/1.7.0/docs/tooldocs/share/jps.html

    展开全文
  • 课程主要面向嵌入式Linux初学者、工程师、学生 主要从一下几方面进行讲解: 1.linux学习路线、基本命令、高级命令 2.shell、vi及vim入门讲解 3.软件安装下载、NFS、Samba、FTP等服务器配置...
  • 玩转Linux:常用命令实例指南

    万人学习 2020-07-06 15:43:16
    人工智能、物联网、大数据时代,Linux正有着一统天下的趋势,几乎每个程序员岗位,都要求掌握Linux。本课程零基础也能轻松入门。 本课程以简洁易懂的语言手把手教你系统掌握日常所需的Linux知识,每个...
  • 文章目录一、 什么是DHCP中继?二、 华为模拟器DHCP中继实验实验目的实验环境实验过程 一、 什么是DHCP中继? DHCPRelay(DHCPR,也叫做DHCP中继代理)是一个小程序,可以实现在不同子网和物理网段之间处理和转发...

    一、 什么是DHCP中继?

    DHCPRelay(DHCPR,也叫做DHCP中继代理)是一个小程序,可以实现在不同子网和物理网段之间处理和转发dhcp信息的功能。也就是在我们正常生产环境中,常常需要划分不同的vlan,而广播是不能跨越vlan的。这时候就需要DHCP来帮忙跨越vlan,发送DHCP广播并进行适当处理于转发。

    1. 当dhcp client 启动并进行dhcp 初始化时,它会在本地网络广播配置请求报文。
    2. 如果本地网络存在dhcp server,则可以直接进行dhcp 配置,不需要dhcp relay。
    3. 如果本地网络没有dhcp server,则与本地网络相连的具有dhcprelay功能的网络设备收到该广播报文后,将进行适当处理并转发给指定的其它网络上的dhcp server。
    4. dhcp server 根据dhcp client 提供的信息进行相应的配置,并通过dhcp relay 将配置信息发送给dhcp client,完成对dhcp client 的动态配置。
    5. dhcp relay设备修改dhcp消息中的相应字段,把dhcp的广播包改成单播包,并负责在服务器与客户机之间转换。

    二、 华为模拟器DHCP中继实验

    实验目的

    验证DHCP原理

    实验环境

    华为模拟器中一台三层交换机、一台二层交换机、两台主机、一台服务(cloud)连接VMware中centos7.6。

    实验过程

    在华为模拟器中建立以下拓扑图
    在这里插入图片描述

    SW2配置信息
    <Huawei>system-view 
    [Huawei]sysname SW2
    [SW2]vlan batch 10 20 100
    [SW2]int e0/0/1
    [SW2-Ethernet0/0/1]port link-type access 
    [SW2-Ethernet0/0/1]port default vlan 10
    [SW2-Ethernet0/0/1]int e0/0/2
    [SW2-Ethernet0/0/2]p l a 
    [SW2-Ethernet0/0/2]p d v 20
    [SW2-Ethernet0/0/2]int e0/0/3
    [SW2-Ethernet0/0/3]p l a 
    [SW2-Ethernet0/0/3]p d v 100
    [SW2-Ethernet0/0/3]int g0/0/1
    [SW2-GigabitEthernet0/0/1]p l t 
    [SW2-GigabitEthernet0/0/1]p t a v 10 20 100
    
    SW1配置信息
    <Huawei>system-view 
    [Huawei]sysname SW1
    [SW1]vlan batch 10 20 100
    [SW1]int g0/0/1
    [SW1-GigabitEthernet0/0/1]p l t
    [SW1-GigabitEthernet0/0/1]p t a v 10 20 100
    [SW1]int vlanif 10
    [SW1-Vlanif10]ip add 192.168.10.1 24
    [SW1-Vlanif10]int vlanif20
    [SW1-Vlanif20]ip add 192.168.20.1 24
    [SW1-Vlanif20]int vlanif 100
    [SW1-Vlanif100]ip add 192.168.100.1 24
    [SW1-Vlanif100]quit
    [SW1]dhcp enable 
    [SW1]int vlanif10 
    [SW1-Vlanif10]dhcp select relay 
    [SW1-Vlanif10]dhcp relay server-ip 192.168.100.100
    [SW1-Vlanif10]int vlanif20
    [SW1-Vlanif20]dhcp select relay
    [SW1-Vlanif20]dhcp relay server-ip 192.168.100.100
    [SW1-Vlanif20]int vlanif100
    [SW1-Vlanif100]dhcp select relay
    [SW1-Vlanif100]dhcp relay server-ip 192.168.100.100
    

    接下来我们对虚拟机进行设置,首先我们使用"yum install dhcp* -y"命令安装dhcp服务。
    然后将我们的虚拟机绑定vm2网卡,因为我们华为模拟器的cloud服务绑定的vm2网卡,并将该虚拟机的IP设置为静态,参数如下:
    在这里插入图片描述
    在这里插入图片描述
    配置好以后我们使用ping命令测试网络连通性
    在这里插入图片描述
    我们进入dhcp服务的配置文件/etc/dhcp/dhcpd.conf,将以下子选项写进去。

    在这里插入图片描述
    在这里插入图片描述
    关闭内核防护、清空防火墙规则
    在这里插入图片描述
    最后我们进入华为模拟器中,将主机获取IP地址的方式 改为DHCP。
    在这里插入图片描述
    使用ipconfig /renew获取IP地址,并使用ping命令测试网络连通性,发现能ping通,实验成功
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    实验中应该注意的点

    我们在/etc/dhcp/dhcpd的配置文件中添加地址池的时候,一定不要忘记配192.168.100.0网段的地址池。
    我们会有这样的想法,192.168.100.100只是我们用来做DHCP服务器的,不需要配地址池,如果没有配192.168.100.0网段的地址池,就会导致DHCP服务启动不成功。所以我们要记住配置。

    展开全文
  • 文章目录一、实验环境二、实验步骤三、实验总结 一、实验环境 华为ENSP模拟器、VMware Workstation 15.5、Centos 7.6 二、实验步骤 1、在ENSP中搭建如下拓扑; 2、分别配置二层交换机SW1与三层交换机RSW1 ...

    一、实验环境

    华为ENSP模拟器、VMware Workstation 15.5、Centos 7.6

    二、实验步骤

    1、在ENSP中搭建如下拓扑;
    UFAfwF.png

    2、分别配置二层交换机SW1与三层交换机RSW1

    配置二层交换机SW1

    [Huawei] sysname SW1
    [SW1] vlan batch 10 20 100
    [SW1]interface Ethernet 0/0/4
    [SW1-Ethernet0/0/4] port link-type access
    [SW1-Ethernet0/0/4] port default vlan 100
    [SW1] interface Ethernet 0/0/3
    [SW1-Ethernet0/0/3] port link-type access
    [SW1-Ethernet0/0/3] port default vlan 20
    [SW1-Ethernet0/0/3] interface Ethernet 0/0/2
    [SW1-Ethernet0/0/2] port link-type access
    [SW1-Ethernet0/0/2] port default vlan 10
    [SW1-Ethernet0/0/2] interface Ethernet 0/0/1
    [SW1-Ethernet0/0/1] port link-type trunk 
    [SW1-Ethernet0/0/1] port trunk allow-pass vlan all 
    

    配置三层交换机LSW1

    [Huawei] sysname RSW1
    [RSW1] interface GigabitEthernet 0/0/1
    [RSW1-GigabitEthernet0/0/1] port link-type trunk
    [RSW1-GigabitEthernet0/0/1] port trunk allow-pass vlan all 
    [RSW1] vlan batch 10 20 100
    [RSW1] dhcp enable
    [RSW1] interface vlanif 10
    [RSW1-Vlanif10] ip add 192.168.10.1 24
    [RSW1-Vlanif10] dhcp select relay 
    [RSW1-Vlanif10] dhcp relay server-ip 192.168.100.100
    [RSW1-Vlanif10] interface vlanif 20
    [RSW1-Vlanif20] ip add 192.168.20.1 24
    [RSW1-Vlanif20] dhcp select relay 
    [RSW1-Vlanif20] dhcp relay server-ip 192.168.100.100
    [RSW1-Vlanif20] interface vlanif 100
    [RSW1-Vlanif100] ip add 192.168.100.1 24
    [RSW1-Vlanif100] dhcp select relay 
    [RSW1-Vlanif100] dhcp relay server-ip 192.168.100.100
    

    3、接下来配置代表DHCP服务器的Cloud2
    UFAho4.png

    4、实验环境配置完成,接下来进入虚拟机配置DHCP服务器

    首先,下载搭建所需的dhcp服务软件包(我这里使用的是NAT模式)

    [root@localhost ~]# yum -y install dhcp
    

    5、安装完成后将虚拟机设置为VMnet1(仅主机模式)
    UFAWeU.md.png

    特别注意!!!在“虚拟网路编辑器”中的VM1网卡下的“使用本地DHCP服务”功能一定要关闭!
    UFA7S1.md.png

    6、设置完成后进入虚拟机命令行进行相应网络配置(每个人网卡名称都不同,我这里是ens33)

    [root@localhost ~]# vi /etc/sysconfig/network-scripts/ifcfg-ens33
    

    需要修改这些地方
    UFA5FJ.png

    修改完成后保存退出并重启网络服务

    [root@localhost ~]# service network restart
    

    7、现在来配置DHCP服务器,配置之前我们来ping一下vlan10、20、100的网关看连接是否通畅
    UFAIY9.png

    连接正常,继续试验:

    刚才安装了dhcp服务,但是配置文件在哪里呢?我们可以使用命令来查看一下:

    [root@localhost ~]# rpm -qc dhcp
    
    /etc/dhcp/dhcpd.conf    ## 这个就是我们要的配置文件!
    /etc/dhcp/dhcpd6.conf
    /etc/openldap/schema/dhcp.schema
    /etc/sysconfig/dhcpd
    /var/lib/dhcpd/dhcpd.leases
    /var/lib/dhcpd/dhcpd6.leases
    
    

    8、编辑配置文件

    [root@localhost ~]# vi /etc/dhcp/dhcpd6.conf
    

    打开以后发现只有寥寥几行内容,解读一下发现原来是要我们去另一个地方找配置模板

    #
    # DHCPv6 Server Configuration file.
    #   see /usr/share/doc/dhcp*/dhcpd6.conf.example
    #   see dhcpd.conf(5) man page
    #
    

    9、那现在就好办了,把模板复制过来替换一下不就好了

    [root@localhost ~]# cp /usr/share/doc/dhcp-4.2.5/dhcpd.conf.example /etc/dhcp/dhcpd.conf
    cp:是否覆盖"/etc/dhcp/dhcpd.conf"? yes
    

    10、编辑配置文件

    vi /etc/dhcp/dhcpd.conf
    

    首先,修改第8行的“option domain-name-servers”后面的内容,这里是设置全局DNS服务器

    然后在跳转到第27行,修改并添加如下内容:

      27 subnet 192.168.10.0 netmask 255.255.255.0 {   
         28   range 192.168.10.155 192.168.10.200;
         29   option routers 192.168.10.1;
         30   option domain-name-servers 8.8.8.8;
    【特别注意!!!】:一定要注意命令的语法,在每一行必须要以分号;结尾,否则再最后启动服务时会报错!
    

    UFAoWR.png
    UFAHQx.png

    10.0网段的我们添加好了,那还有20和100段的呢?我们也来模仿上面配置好的格式添加上去:

         33 subnet 192.168.20.0 netmask 255.255.255.0 {
         34   range 192.168.20.155 192.168.20.200;
         35   option routers 192.168.20.1;
         36   option domain-name-servers 8.8.8.8;
         37 }
         38 
         39 subnet 192.168.100.0 netmask 255.255.255.0 {
         40   range 192.168.100.155 192.168.100.200;
         41   option routers 192.168.100.1;
         42   option domain-name-servers 8.8.8.8;
         43 }
    

    UFAsWn.png

    到此,DHCP服务就配置完成了,再次检查一下命令看是否有误,没有问题就保存退出

    11、在开启DHCP服务之前,我们需要关闭系统的核心防护并清空防火墙规则(直接关闭firewalld也可以)

    [root@localhost ~]# setenforce 0  ## 关闭系统的核心防护
    [root@localhost ~]# iptables -F   ## 清空防火墙规则
    

    12、开启DHCP服务

    [root@localhost ~]# systemctl start dhcpd
    

    13、查看一下服务状态,是否启动成功,有误报错等信息

    [root@localhost ~]# systemctl status dhcpd
    

    UFAcQ0.md.png

    一切正常!

    14、回到ENSP中的两台PC机,在“基础配置中”将IPV4配置选为DHCP,单击确定按钮
    UFAyzq.md.png

    15、在命令行中输入命令尝试获取IP地址

    PC>ipconfig /renew
    

    PC1:
    UFA2LT.md.png

    PC2:
    UFAgyV.md.png

    两台PC均能正常获取IP,实验结束。

    三、实验总结

    1、本次实验的基础在于网络的配置,如果网络都没有打通怎么配置都是徒劳的,自己实验时还是要根据自身网卡的实际情况进行配置

    2、开启服务前记得将系统的防火墙等安全组件关闭

    3、注意配置文件的路径及修改编辑时命令的语法问题,很多情况下就是少了一个分号导致服务开启失败

    展开全文
  • 目录一、DHCP概述二、DHCP工作原理租约过程续约三、DHCP服务器的配置1、安装dhcp软件包1>主配置文件dhcpd.conf2>启动dhcp服务3>查看租约文件2、dhcp服务实验过程四、DHCP中继的原理与配置 ...
  • linux中的&&和&,|和||

    万次阅读 多人点赞 2017-05-24 18:28:21
    linux中,&和&&,|和||介绍如下: & 表示任务在后台执行,如要在后台运行redis-server,则有 redis-server & && 表示前一条命令执行成功时,才执行后一条命令 ,如 echo '1‘ && echo '2' | 表示管道,上一条...
  • Linux系统中的gadgetfs介绍

    千次阅读 2014-10-31 09:58:17
    Linux提供了一套API,使得嵌入式的Linux系统软件可以以USB外设的方式工作。Kernel中提供了Gadget的Framework及相关的Demo,开发者可以参考用于开发自己的USB Gadget Driver。但并非所有的开发者都希望在Kernel中编程...
  • Linux面试题(2020最新版)

    万次阅读 多人点赞 2020-05-06 14:11:06
    文章目录Linux 概述什么是LinuxUnix和Linux有什么区别?什么是 Linux 内核?Linux的基本组件是什么?Linux 的体系结构BASH和DOS之间的基本区别是什么?Linux 开机启动过程?Linux系统缺省的运行级别?Linux 使用的...
  • Linux简易命令整理

    千次阅读 多人点赞 2020-08-12 19:36:17
    Linux快速入门1. Linux 概述1.11 Linux 是什么1.2 虚拟机1.3 centOs 1. Linux 概述 1.11 Linux 是什么 Linux和windows一样是操作系统,我们所使用的应用软件都需要依赖操作系统来运行 1.2 虚拟机 由于我们不可能在...
  • CentOS7 Linux入门实战视频课程

    万人学习 2016-05-03 10:14:10
    此课程基于CentOS7.2 64位版本,讲解了CentOS7的安装、基础网络命令、网卡设置、文件与目录管理、进程与线程管理、VI编辑器、用户与权限、软件包管理、YUM软件仓库的搭建,在后教会大家如何地在Linux上搭建Discuz...
  • Kali Linux 使用教程

    万次阅读 2017-06-15 11:23:58
    Kali Linux 秘籍:wizardforcel/kali-linux-cookbook-zh - 码云 - 开源中国 Kali Linux Web 渗透秘籍:wizardforcel/kali-linux-web-pentest-cookbook-zh - 码云
  • linux视频教程百度网盘分享

    万次阅读 2013-11-01 16:27:38
    linux系统下载、linux操作系统、linux工程师、linux视频教程百度网盘分享:http://yun.baidu.com/s/17oFzC
  • Linux教程+操作系统教程

    万次阅读 多人点赞 2018-08-24 14:08:53
    Linux简介Linux文件管理Linux目录Linux文件权限和访问模式Linux环境变量Linux打印文件和发送邮件Linux管道和过滤器Linux进程管理Linux网络通信工具vi编辑器Linux文件系统Linux文件存储结构Linux用户管理Linux系统...
  • 10套高质量Linux教程,放在百度网盘了

    万次阅读 多人点赞 2018-04-07 18:39:34
    Linux就该这么学》- 必读的Linux系统与红帽认证自学手册点此阅读:http://www.linuxprobe.com/Linux技术交流社区:http://bbs.linuxprobe.com/本书是由全国多名红帽架构师(RHCA)基于RHEL7系统共同编写的高质量...
  • win10系统安装Linux虚拟机详细教程

    万次阅读 多人点赞 2018-01-15 13:57:41
    本博参考http://blog.csdn.net/naomiedna/article/details/51752788 1.下载虚拟机 我用的是VMware 官方下载地址:...
  • 一、 Kali linux是什么? Kali Linux是基于Debian的Linux发行版, 设计用于数字取证操作系统。Kali Linux面向专业的渗透测试和安全审计.因此,Kali Linux已经进行了...二、 Kali linux新手入门教程目录(视频教程)...
  • Linux入门培训_Linux基础培训教程_Linux系统入门学习视频课程,Unix基础培训教程(如aix,hp-ux),针对linux系统初级者开设的课程,是linux入门简单的视频教程.
1 2 3 4 5 ... 20
收藏数 275,114
精华内容 110,045
关键字:

linux