精华内容
参与话题
问答
  • Import: Release 11.2.0.1.0 - Production on 星期日 5月 10 13:55:14 2015 ... All rights reserved. 连接到: Oracle Database 11g ...IMP-00010: 不是有效的导出文件, 标头验证失败 IMP-00000: 未成功终止导入
  • 原因:备份dmp文件版本和需要导入oracle数据库版本不一致。 1、查看目标库版本 2、修改备份dmp文件版本号,使其与目标库版本对应,如下 3、重新导入即可

    原因:备份的dmp文件版本和需要导入的oracle数据库版本不一致。

    1、查看目标库版本

    2、修改备份的dmp文件版本号,使其与目标库版本对应,如下

    3、重新导入即可

    展开全文
  • 连接到: Oracle Database 12c Enterprise Edition Release 12.1.0.1.0 - 64bit Production With the Partitioning, OLAP, Advanced Analytics and Real Application...IMP-00010: 不是有效的导出文件, 标头验证失败...

    连接到: Oracle Database 12c Enterprise Edition Release 12.1.0.1.0 - 64bit Production

    With the Partitioning, OLAP, Advanced Analytics and Real Application Testing options

     

    IMP-00010: 不是有效的导出文件, 标头验证失败

    IMP-00000: 未成功终止导入

     

     

    DMP头部

    TEXPORT:V18.00.00 ===>修改为V12.01.01

     

    注意: 用11g客户端无法将数据库文件(11g)导入到12c的数据库中去 ,但是能导入10g的数据库文件 前提修改头部版本号

    也可以把11g客户端卸载掉,因为安装了12c数据库可以直接导入10.02.01 和11g的数据库文件

     

    展开全文
  • IMP-00010:不是有效的导出文件,头部验证失败

    备注:

    前些天在将dmp文件导入Oracle数据库12c的时候,使用dos中Oracle的imp导入,出现错误,

    提示:

    IMP-00010:不是有效的导出文件,头部验证失败!


    导入命令:

    imp GDSDYTH/GDSDYTH@ORCL_10.10.10.28 full=y ignore=y file=C:\gdsd_apa_20160608.dmp log=C:\gdsd_apa_20160608.log






    后面对比了两台客户端机器发现

    其中一台装的oracle客户端是10.2.0.1.0,在导入到12C的时候错误;

    另外一台装的oracle客户端是11g的,在导入到12C的时候可以正常导入;


    后面卸载了10.2.0低版本的oracle客户端,装上11g版本的,问题没有再出现;

    总结,这个问题 应该是由于Oracle导入时oracle_client,或者oracle_db版本太低了导致无法验证文件,安装高版本即可,也可以参考exp导出数据的客户端版本,

    比导出的客户端版本高出或者相同即可,低于导出的版本,可能会出现上述的问题。





    展开全文
  • IMP-00010不是有效的导出文件,头部验证失败
  • Oracle 导入错误IMP-00010不是有效的导出文件,头部验证失败,内含操作说明
  • copy 1st.jpg/b+2st.txt/a 3st.jpg 将2st.txt内容藏身到1st.jpg中生成3st.jpg新的文件,注:2st.txt文件头要空三排,参数:/b指二进制文件,/a指ASCLL格式文件 copy ipadmin$svv.exe c: 或:copyipadmin$*.* 复制...
  • IMP-00010: 不是有效的导出文件,标题验证失败 IMP-00000: 未成功终止导入 <br />在google上查找了一下,大概有两种情况: <br />1.imp/exp的版本不对,也就是说低版本的导出,可以用高版本...

    IMP-00010: 不是有效的导出文件,标题验证失败
    IMP-00000: 未成功终止导入

    在google上查找了一下,大概有两种情况:

    1.imp/exp的版本不对,也就是说低版本的导出,可以用高版本的导入,但高版本导出不能用低版本的导入,这个版本不只是指imp/exp的版本,也是指数据库的版本

    2.可能你在用ftp download时未设置binary的传输方式,导致文件损坏

    用UltraEdit-32打开dmp文件可看到版本信息,美国传过来的dmp文件的信息如下:

    XPORT:V10.02.01

    从中可以看出其版本是10.02.01

    所以我执行imp时报错是因为版本问题,后来用10g的imp导入到10g的数据库就成功了

    还有expdp备份的dmp文件不可以用imp导入!

    展开全文
  • Java访问权限控制源代码 1个目标文件 摘要:Java源码,文件操作,权限控制 Java访问权限控制,为Java操作文件、写入文件分配合适权限,定义写到文件的信息、定义文件,输出到c:/hello.txt、写信息到文件、关闭输出流...
  • 解决“不是有效的导出文件,头部验证失败”" title="ORACLE: 解决“不是有效的导出文件,头部验证失败”" height="164" width="665"> 网上查到的原因:  1)IMP客户端与目标服务端的版本不一致  2)导出的DMP文件...
  • oracle导入时IMP-00010: 不是有效的导出文件, 头部验证失败 将oracle 11g导出的dmp文件导入到oracle10g 问题:进行导入表操作,提示: IMP-00010: 不是有效的导出文件, 头部验证失败 IMP-00000: 未成功终止...
  • 此工具可以针对dmp文件太大,notepad++打不开情况,方便快速。 2、查询导入oracle数据库版本号 通过select * from v$version查看版本号,如下图 3、修改dmp版本号 4、重新导入dmp到数据库...
  • 导入某人给dmp文件时在dos环境下imp em/123456@orcl fromuser=em touser=em file=c:\em1013.dmp报错如标题原因是,那人是在在oracle11g导出的而我导入数据库也是oracle11g,但是客户端是oracle10g解决:把原来...
  • oracle导入时IMP-00010: 不是有效的导出文件, 头部验证失败 将oracle 11g导出的dmp文件导入到oracle10g 问题:进行导入表操作,提示: IMP-00010: 不是有效的导出文件, 头部验证失败 IMP-00000: 未成功终止...
  • 8) 环境说明:dmp来源版本:11.02.00...使用NotePad将dmp文件的版本号11.02.00修改为10.02.00之后成功导入,原因是低版本的数据库无法识别高版本的数据库的导出文件。文件太大的话可以使用切分工具将文件切分后修改...
  • 导出数据库版本号是 Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production TNS for Linux: Version 11.2.0.1.0 - Production 导出数据库版本号是 Oracle Database 11g
  • IMP-00010: 不是有效的导出文件,标题验证失败 IMP-00000: 未成功终止导入 在google上查找了一下,大概有两种情况: 1.imp/exp的版本不对,也就是说低版本的导出,可以用高版本的导入,但高版本导出不能用低版本...
  • Oracle导入dmp文件报错IMP-00010: 不是有效的导出文件, 头部验证失败
  •  1)导出的DMP文件为11g  2)进行IMP导入客户端是10g  3)目标服务端是11g 网上查到原因:  1)IMP客户端与目标服务端版本不一致  2)导出的DMP文件与目标服务端版本不一致 解决方法:  1)安装...
  • 这是由于导出的dmp文件与导入数据库版本不同造成 用Notepad++查看了dmp文件,在头部具修改成你将导入目标数据库版本号 以下对应版本号:  11g R2:V11.02.00  11g R1:V11.01.00  10g:V10.02.01 ...
  •  问题描述,由于是从11G导入到10G,那么只需要修改imp的dmp文件使其为本库 版本即可。 在此感谢一下一个网友开发一个小工具。 解决办法: 将dmp文件头部“V11.02.00“ 改为”V10.02.00“即可。   本软件下载...
  • 1.imp/exp的版本不对,也就是说低版本的导出,可以用高版本的导入,但高版本导出不能用低版本的导入,这个版本不只是指imp/exp的版本,也是指数据库的版本。 也就是说,低版本的SQL Developer/Oracle database/...
  • Oracle 11gdmp备份文件导入到Oracle 10g,出现错误信息:Import: Release 10.2.0.1.0 - Production on 星期四 7月 9 13:47:04 2015Copyright (c) 1982, 2005, Oracle. All rights reserved. 连接到: Oracle ...

空空如也

1 2 3 4 5 ... 11
收藏数 208
精华内容 83
关键字:

不是有效的导出文件