2018华为网络技术
2018-04-21 14:44:14 u012122840 阅读数 2261

  刚刚考试完。只有一个感觉,考的太细了。扣一个图都能给你考道题,焦急的等待成绩中。笔记上传希望对后来人有用。心烦没事的时候水水群,欢迎来西北赛区群,全国人最多最热闹的群。大佬遍地,一望无际。

笔记上传至csdn当做纪念。。https://download.csdn.net/download/u012122840/10364721

2018-05-08 14:34:20 wtdm_160604 阅读数 4175

    华为网络技术大赛复赛落下帷幕,考完上机ensp配置我已经基本知道结果了,题目真的不难,但是真的需要用心准备,包括前期学习的准备,也包括考试前半个小时准备,我就是那个前期花了很多时间,最后在考试环节出问题的那个人,下面先把题目更新出来,最后再总结下经验。

    下面是网络拓扑图:


pc1                                                        pc2                                                    pc3    

  

服务器端:


下面给出详细配置:

[R1]配置
#
sysname R1
#
router id 1.1.1.1
#
interface Ethernet0/0/0
 ip address 12.1.1.1 255.255.255.252
#
interface GigabitEthernet0/0/1
 ip address 12.1.1.5 255.255.255.252
#
ospf 100
 area 0.0.0.0
  network 12.1.1.0 0.0.0.3
  network 12.1.1.4 0.0.0.3
#

[R2]配置
#
sysname R2
#
router id 2.2.2.2
#
interface Ethernet0/0/0
 ip address 12.1.1.2 255.255.255.252
#
interface GigabitEthernet0/0/1
 ip address 12.1.1.9 255.255.255.252
#
interface GigabitEthernet0/0/2
 ip address 180.1.1.1 255.255.255.252
#
ospf 100
 area 0.0.0.0
  network 12.1.1.0 0.0.0.3
  network 12.1.1.8 0.0.0.3
 area 0.0.0.3
  network 180.1.1.0 0.0.0.3
#

[SW1]配置
sysname S1
#
router id 3.3.3.3
#
vlan batch 10 20 40 50
#
interface Vlanif10
 ip address 10.1.1.126 255.255.255.128
#
interface Vlanif20
 ip address 10.1.2.254 255.255.255.0
#
interface Vlanif40
 ip address 12.1.1.6 255.255.255.252
#
interface Vlanif50
 ip address 12.1.1.13 255.255.255.252
#
interface Eth-Trunk1
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 2 to 4094
#
interface Eth-Trunk2
 port link-type trunk
 port trunk pvid vlan 20
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 40
#
interface GigabitEthernet0/0/2
 eth-trunk 1
#
interface GigabitEthernet0/0/3
 eth-trunk 2
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk pvid vlan 50
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/5
 eth-trunk 1
#
interface GigabitEthernet0/0/6
 eth-trunk 2
#
ospf 100
 area 0.0.0.0
  network 12.1.1.12 0.0.0.3
  network 12.1.1.4 0.0.0.3
 area 0.0.0.1
  network 10.1.1.0 0.0.0.127
  network 10.1.2.0 0.0.0.255

[SW2]配置
#
sysname S2
#
router id 4.4.4.4
#
vlan batch 30 50 60
#
interface Vlanif30
 ip address 10.1.1.254 255.255.255.128
#
interface Vlanif50
 ip address 12.1.1.14 255.255.255.252
#
interface Vlanif60
 ip address 12.1.1.10 255.255.255.252
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 60
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 30
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk pvid vlan 50
 port trunk allow-pass vlan 2 to 4094
#
ospf 100
 area 0.0.0.0
  network 12.1.1.8 0.0.0.3
  network 12.1.1.12 0.0.0.3
 area 0.0.0.2
  network 10.1.1.128 0.0.0.127

[SW3]配置
#
sysname S3
#
vlan batch 10
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.128
#
interface Eth-Trunk1
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/2
 eth-trunk 1
#
interface GigabitEthernet0/0/5
 eth-trunk 1
#
ip route-static 0.0.0.0 0.0.0.0 10.1.1.126

[SW4]配置
#
sysname S4
#
vlan batch 20
#
interface Vlanif20
 ip address 10.1.2.1 255.255.255.0
#
interface Eth-Trunk2
 port link-type trunk
 port trunk pvid vlan 20
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/3
 eth-trunk 2
#
interface GigabitEthernet0/0/6
 eth-trunk 2
#
ip route-static 0.0.0.0 0.0.0.0 10.1.2.254

下面给出测试结果:

pc1分别ping pc2、pc3以及服务器:



pc2 ping pc3和服务器:



pc3 ping 服务器:



2019-04-12 08:11:33 weixin_41913019 阅读数 21

2018模拟题目

  1. 弹性伸缩不是微服务应用本身的能力(对)

  2. 交换机划分了VLAN后,收到的广播报文如果携带VLAN信息,则该广播报文只能在该
    VLAN内广播转发(对)

  3. Kafka是Cloudera的开源日志系统,是分布式海量日志聚合系统 错 (??????)

  4. NAS对大量块类型的数据传输具有最优性能 错(????)

  5. 一个DDL或DCL语句执行可以代表一个数据库事务的结果
    A. 对

  6. IaaS是把开发环境或运行平台作为一种服务交付给客户 (?????)
    B. 错

  7. 在Linux中使用groupdel删除用户组时,所有归属于该组的用户也会自动被删除
    A. 对
    B. 错
    8B

  8. (单选)下列选项中,哪个选项是对于处理海量数据的并行编程模式和大规模数据集的
    并行运算的软件架构?
    A. MapReduce
    B. GFS
    C. BitTable
    D. Chubby
    9A

  9. (单选)以下有关NAT的说法,错误的是哪一项?
    A. NAT是将IP数据报报头中的IP地址转换为另一个IP地址的过程
    B. NAPT方式不转换端口(错)
    C. NAT隐藏了内部网络的结构,具有“屏蔽”内部主机的作用,但是在实际应用中,可能
    需要提供一个访问内部主机的途径,NAT server可以解决如上问题,提供内部主机给外部
    访问
    D. NAPT方式允许多个私有地址映射到同一个公有地址上
    12.(单选)以下关于虚拟化的说法,错误的一项是?
    A. vCPU个数=物理CPU个数*核数(错)
    B.虚拟机的虚拟磁盘以vmdk文件格式存放在存储中
    C.网络虚拟化通过虚拟交换机实现,虚拟交换机工作在第二层
    D.虚拟机通过虚拟网卡对外进行通信
    13.(单选)关于虚拟机、容器、服务的关系,以下哪项是不正确的?
    A.在虚拟机上可以创建容器(对)
    B.在容器里可以部署服务(对)
    C.在虚拟机上不可以部署服务
    D.在物理机上可以创建容器(对)

  10. (单选)在vi编辑器,命令“dd”用来删除当前的以下哪项?
    A.字
    B.行
    C.字符
    D.变量

  11. (单选)Nova组件架构中各个模块描述正确的是哪一项?
    A.Nova-scheduler通过直接与数据库交互从而调度分配将虚拟机起到哪个计算节点
    B.Nova-conductor不可以与数据库直接交互
    C.Nova-api不能提供rest风格的接口
    D.

Nova-compute主要负责在计算节点上启动虚拟机实例

16.(单选)微服务12要素中的“Code Base基准代码”,哪项理解是正确的?

A.所有部署的基准代码相同,但每份部署只能使用相同的版本
B.基准代码和应用之间总是保持一多对应的关系
C*.尽管每个应用只对应一份基准代码,但可以同时存在多份部署*
D.多个应用需要共享一份基准代码

16C

17.(多选)华为FusionStage平台微服务运行与治理框架中的关键技术有哪些?
A.高可靠:采用可隔离舱、熔断机制等技术、保障用户应用的高可靠性
B.可扩展:提供可扩展框架,支持不断扩展微服务的能力
C.虚拟化:将一台计算机虚拟为多台逻辑计算机,提高资源利用率
D.可监控:采用跟踪链分析,可监控端到微服务调用链、各服务的调用频率、时延等各项
指标
E.多语言:支持多语言的原生接口

17.ABDE

18.(多选)Hadoop系统中YARN资源管理可以为如下哪几个组件进行资源管理和调度?
A.MapReduce
B.Spark
C.Zookeeper
D.Storm

18ABD

19.(多选)以下哪些命令能够停止httpd服务?

A.service httpd stop
B./etc/init.d/httpd stop
C.killall httpd
D.kill httpd

19.ABC

20.(多选)下列描述中哪些对Docker镜像特性描述不正确?

A.docker镜像是一种非层级的文件系统
B.镜像是可读写模板
C.镜像是容器的基础
D.镜像只能自己编写

20.ABD

2018-03-24 17:25:59 weixin_41890067 阅读数 3537

微服务基础概念

一、从单体架构到微服务架构的演进

1、Monolithic单体式架构简介

Monolithic单体式架构指的是尽管是模块化逻辑,但是最终还是会打包并部署为一个单一应用。

2、Monolithic单体式架构的优缺点

缺点:随着市场变化快、用户需求变化快、用户访问量增加,单体式架构运用的维护成本、人员的培养成本、缺陷修复成本、技术架构演进的成本、系统扩展成本等等都在增加。单块架构曾经的优势已无法适应互联网时代的快速变化。

3、单体式架构面临的挑战

4、微服务架构模式倡导的做法

提倡将monolithic单体式架构应用划分为一系列小的服务,服务之间相互协调、相互配合,为用户提供服务。  

5、想微服务架构演进的推荐顺序

规划——中间件和数据库——服务和应用

6、微服务架构的优点

每个服务足够内聚,代码容易理解,开发效率高,服务之间可独立部署,使得持续部署成为可能。

二、基于Docker的微服务应用架构设计

1、微服务架构设计需要遵循的模式

12-Factor

2、12-Factor”方法论

提供相应的方法论,使用标准化流程,自动配置,从而使新的开发者花费最少的学习成本加入这个项目,和操作系统之间尽可能的划清界限,在各个系统中提供做大的可移植性。适合部署在现在的云计算平台,从而在服务器和系统管理方面节省资源。将开发环境和生产环境的差异降至最低。并使用持续交付,实施敏捷开发。可以在工具、架构和开发流程不发生明显变化的前提下实施扩展。

3、基准代码

基准代码和应用之间总是保持一一对应的关系。

一旦有多个基准代码,就不能称之为一个应用,而是一个分布式系统。分布式系统中的每一个组件都是一个应用,每一个应用可以分别使用12-Factor进行开发。

多个应用共享一份基准代码有悖于12-Factor原则。解决方案是将共享的代码拆分为独立的类库,然后使用以来管理策略去加载它们。

4、依赖关系

应用程序不会隐式依赖系统级的类库。它一定通过依赖清单,确切的声明所有依赖项。

此外,在运行过程中通过依赖隔离工具来确保程序不会调用系统中存在但清单中未声明的依赖项。

5、配制

环境变量可以非常方便的在不同的部署间做修改,却不动一行代码。

与配置文件不同,不小心把他们签入代码库的概率微乎其微。

与一些传统的解决配制问题的机制(比如Java的属性配制文件)相比,环境变量与语言和系统无关。

6、后端服务

12-Factor应用不会区别对待本地或第三方服务。对应用程序而言,两个都是附加资源。

12-Factor应用支持任意部署。如,可以在不进行任何代码改动的情况下,将本地的MySQL数据库换成第三方服务。

2018-05-11 20:31:54 leitingjiang 阅读数 416

      今年华为网络技术大赛我成功地进入了第一轮,成功地倒在了粤港澳赛区复赛进入总决赛的路上。刚收到HR小姐姐的感谢短信的时候心情还是十分低落的,如倨着身子捂热的大捧白糖,被撞撒了大半地,勾芡着霜白和苔泥那种可惜。

       我去年知道这个比赛并拉着海鹏报名,跑去大学城岛另一半的中大小教室里听华为宣讲。后来下定决心报了名,和广东省省赛不期而遇,偏偏两家考场还是华工B7楼的一家楼上,一家楼下,138和238。我是两家门前都走过,选了楼下亏了楼上。于是今年的网技倒是我的初体验了。初赛,准备csdn上的资料,过了。复赛,埋了本实验操作书,逃课接线。准备了很多考纲外的(考纲给的真的不清楚),到考场才发现想象的完全不一样。考的全会,可是ping之前的时间完全不够。真的是考的操作熟练度,又要快、又要狠、又要准。资料什么的完全不用带很多,而且上机的比重比面试大很多。面试我倒是应该发挥很好,应该是那一场(18个人)发挥最好的一个吧。结果是两个大三的同校同场师兄双双总决,我回家钓鱼,来把弄这篇失败纪念。

     保罗的西决梦都圆了,我的梦又在哪?

没有更多推荐了,返回首页