erlang升级 linux
2014-03-17 18:45:40 iteye_7114 阅读数 761
#!/bin/sh
NODE_ID=1
NODE_NAME=NodeName
NODE_PATH=NodePath
NODE_IP=localhost
TCP_PORT=9527
COOKIE='necolas'
ulimit -SHn 102400
# define default configuration
POLL=true
SMP=auto
DATETIME=`date "+%Y%m%d%H%M%S"`
LOG_PATH="../logs/app_${NODE_NAME}.$DATETIME.log"
cd $NODE_PATH
erl +P $ERL_PROCESSES \
+K $POLL \
-smp $SMP \
-pa config ../kernel \
-sname ${NODE_NAME}@${NODE_IP} \
-setcookie $COOKIE \
-kernel error_logger \{file,\"$LOG_PATH\"\} \
-s main start \
-config sasllog \
-noshell \
-detached \
-extra $NODE_ID $NODE_NAME 127.0.0.1 $TCP_PORT &
2016-08-08 17:40:38 wolvesqun 阅读数 3238
一:安装perl ->  
yum -y install perl-devel.x86_64
二: 首先要先安装GCC GCC-C++ Openssl等以来模块:

yum -y install make gcc gcc-c++ kernel-devel m4 ncurses-devel openssl-devel

二:下载erlang source 包 
http://erlang.org/download/otp_src_19.0.tar.gz 
三:解压包
tar -zxvf otp_src_19.0.tar.gz
四:进入包里,执行(/opt/modules/erlang是我安装目录)
./configure --prefix=/opt/modules/erlang --without-javac

五:执行 make
六:执行make install
七:把我安装路径/opt/modules/erlang/bin路径添加到etc 下面的 profile 文件
八:source /etc/profile
2012-12-03 15:09:57 phyzhou 阅读数 685

1>下载srcdoc

    1 wget  http://www.erlang.org/download/otp_src_R15B03.tar.gz  -P /usr/local/src

     2 wget http://www.erlang.org/download/otp_doc_man_R15B03.tar.gz -P /usr/local/src

2> 安装基本的软件包

   1 yum groupinstall Base "Development Tools" "Perl Support" 

3> tar xzf otp_src_R15B03.tar.gz
4>  cd otp_src_R15B03

5> ./configure --prefix=/home/erlang

6> make && make install


7 在/etc/profile的最下面添加
 
    
 PATH=$PATH:/home/erlang/bin

8>reboot


9>打开终端

    >erl


2016-01-07 14:46:00 weixin_33937778 阅读数 1

1 下载erlang安装包

2 解压安装包:下载的安装包是经过压缩的gz格式,在linux下解压用到系统自带的tar工具,在安装包所在目录执行命令:tar -zxvf otp_src_R16B03-1.tar.gz

3 打开解压后的目录-执行命令:cd otp_src_R16B03-1,因R16+版本和最新的openssl不兼容,所以需要修改crypto源码(参考链接http://www.kongqingquan.com/archives/145)

#if OPENSSL_VERSION_NUMBER >= 0x009080ffL \
&&!defined(OPENSSL_NO_EC) \
&&!defined(OPENSSL_NO_ECDH) \
&&!defined(OPENSSL_NO_ECDSA)
# define HAVE_EC
#endif

改为

#if OPENSSL_VERSION_NUMBER >= 0x009080ffL \
&&!defined(OPENSSL_NO_EC) \
&&!defined(OPENSSL_NO_EC2M) \
&&!defined(OPENSSL_NO_ECDH) \
&&!defined(OPENSSL_NO_ECDSA)
# define HAVE_EC
#endif

4 ./configure --prefix=/usr/local/erlang --with-ssl --enable-threads --enable-smp-support --enable-kernel-poll --enable-hipe 

5 make && make install

 

转载于:https://www.cnblogs.com/wangjunshusheng/p/5109844.html

2017-06-03 16:17:00 weixin_34212762 阅读数 3

1.下载erlang

官网地址 http://www.erlang.org/download 挑选合适的版本 然后 wget 比如目前最新版本 19.3
运行命令 wget http://erlang.org/download/otp_src_19.3.tar.gz

2.使用yum安装下必须的配件:  

yum install gcc glibc-devel make ncurses-devel openssl-devel autoconf
yum install unixODBC unixODBC-devel

3.开始安装

tar -zxvf otp_src_19.3.tar.gz
cd otp_src_19.3
./configure --prefix=/usr/local/erlang --enable-hipe --enable-threads --enable-smp-support --enable-kernel-poll --without-javac
这步可能会出现提示提示缺少的组件,详情见常见问题
make && make install (ps:超慢)
ln -s /usr/local/erlang/bin/erl /usr/local/bin/
如果上步都已经完成 则可以使用了
输入 erl

4.常见问题:

*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************

jinterface     : Java compiler disabled by user

*********************************************************************
*********************************************************************
**********************  APPLICATIONS INFORMATION  *******************
*********************************************************************

wx             : wxWidgets not found, wx will NOT be usable

*********************************************************************
*********************************************************************
**********************  DOCUMENTATION INFORMATION  ******************
*********************************************************************

documentation  : 
                 fop is missing.
                 Using fakefop to generate placeholder PDF files.

*********************************************************************

其中APPLICATIONS DISABLED 标示是必须要安装的,另外两个项目可以忽略
jinterface : Java compiler disabled by user
如果不用java编译可以忽略 在编译的时候 加入--without-javac

转载于:https://www.cnblogs.com/datacoding/p/6937493.html

Linux 安装Erlang

阅读数 3

Erlang安装,Linux

阅读数 115

linux 下 erlang安装

阅读数 59

Erlang环境搭建(linux)

阅读数 2190

没有更多推荐了,返回首页