11.3.1真机调试 ios

2020-02-17 22:50:36 weixin_45243181 阅读数 361
  • APP兼容性测试方法

    全面而详尽的从测试方法、内核分析、策略选择、工具使用等多个角度详解web和APP兼容性测试,让学员能够认识到兼容性测试的重要性、了解兼容性测试的意义、掌握web及app兼容性测试分析、设计、执行方法。

    14人学习 任健勇
    免费试看

对于iOS开发人员,在真机调试的时候经常会遇到问题:“Could not locate device support files”。原因就是 你的手机版本 大于 你的Xcode所能支持的最高版本。
Could not locate device support files
一不小心把iPhone升级到了最新版本,是很可能会发生的事情,而且有时只是升级了个小版本,你的Xcode可能就不支持了。升级Xcode到最新版本当然可以解决问题。
 
但是中断手头的工作,去更新5、6个G大小的Xcode,这次数发生的多了,也太折磨人。

如何在不升级Xcode的情况下,真机调试升级了新版本的iPhone呢?

先来看看 device support files

打开Finder应用,使用快捷键command+shift+g进入目录:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

里面以版本号命名的文件夹就是你当前Xcode所支持的真机iOS版本,如果想要支持新的版本,就把新版本对应的DeviceSupport文件拷贝到这个文件夹就行了。

如果身边有朋友已更新Xcode,可从朋友那里拷贝与真机版本对应的DeviceSupport文件,如若没有,可在网上找找看,有不少人分享新版的DeviceSupport文件。

DeviceSupport下载地址

github-iGhibli
作者对新版本的更新比较及时,只是github国内下载比较慢。

笔者的实践

github下载很慢,经常中断,导致下载失败。我百度云盘共享了13.2、13.3、13.4和13.5,有需要可以下载。
链接: https://pan.baidu.com/s/1Tz1KfdAFJDTbmL5acpwCWQ 提取码: hgdp
 
我的Xcode版本是11.1,手机不小心更新了最新版13.3.1,不想升级Xcode,也没在网上没有找到对应的DeviceSupport文件,就把13.2的DeviceSupport文件夹拷贝过去,并重命名为13.3.1,亲测可行。

推荐阅读

很开心你读完此篇。
我是夕月,程序媛一枚。
30而立,2020年是摸索前行的一年,和星辰一起立下了发文分享的flag。
如果你感兴趣,不妨常来看看,我们成长路上或许会有共鸣。

我们的博客站:https://xiyuechen.net
微信公众号「星辰和夕月」。
星辰和夕月

2018-06-21 10:26:29 PianZhideNanRen 阅读数 462
  • APP兼容性测试方法

    全面而详尽的从测试方法、内核分析、策略选择、工具使用等多个角度详解web和APP兼容性测试,让学员能够认识到兼容性测试的重要性、了解兼容性测试的意义、掌握web及app兼容性测试分析、设计、执行方法。

    14人学习 任健勇
    免费试看

使用方法需要哪一个iPhone系统的支持包,下载解压,放进去就可以了,然后插入你的手机,等Xcode解析好你的手机文件就可以真机运行了。

支持包放置位置:点击应用程序-》选择Xcode-》Contents-》Developer-》Platforms-》iPhoneOS.platform-》DeviceSupport


原作者连接: https://www.jianshu.com/p/1a33e36c4b67

2017-06-07 11:25:01 mtc1256 阅读数 3199
  • APP兼容性测试方法

    全面而详尽的从测试方法、内核分析、策略选择、工具使用等多个角度详解web和APP兼容性测试,让学员能够认识到兼容性测试的重要性、了解兼容性测试的意义、掌握web及app兼容性测试分析、设计、执行方法。

    14人学习 任健勇
    免费试看
/Applications/Xcode_beta.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk 
复制到
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk

/Applications/Xcode_beta.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.0.sdk
复制到
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk


/Applications/Xcode_beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0 (15A5278f)
复制到
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

参考:http://blog.csdn.net/u013316626/article/details/54100011

2016-03-04 15:39:13 IDOshi201109 阅读数 4493
  • APP兼容性测试方法

    全面而详尽的从测试方法、内核分析、策略选择、工具使用等多个角度详解web和APP兼容性测试,让学员能够认识到兼容性测试的重要性、了解兼容性测试的意义、掌握web及app兼容性测试分析、设计、执行方法。

    14人学习 任健勇
    免费试看

Xcode真机调试出现“Could not find Developer Disk Image”

一、原因:
手机是最新的iOS版本:9.2.1。而查看Xcode(Xcode 版本7.1.0)支持的真机没有9.2的。原因截图:
原因
二、排查方法(怎么查看Xcode支持的设备版本)
1、在文件目录,快捷键:command+shift+G,调出“前往文件夹”。如截图:
前往文件夹

2、在“/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport”里列出了Xcode支持的设备。
这里写图片描述

三、解决方法:
升级Xcode。

2019-07-23 10:23:00 chenliqiu8518 阅读数 63
  • APP兼容性测试方法

    全面而详尽的从测试方法、内核分析、策略选择、工具使用等多个角度详解web和APP兼容性测试,让学员能够认识到兼容性测试的重要性、了解兼容性测试的意义、掌握web及app兼容性测试分析、设计、执行方法。

    14人学习 任健勇
    免费试看

老款mac pro已经升级不了系统了,导致最新版的xcode10.2及以上也安装不了,最新版的ios12.3.1也联机调试不了,apple是要逼着大家升级硬件啊,软件即服务,就是这样来的,大部分计算机软件公司现在都是卖saas服务赚钱了,apple还是软硬通吃,确实牛。

转发的链接是怎么使用老款xcode联机调试的方法,亲测有效。

转载于:https://my.oschina.net/swingcoder/blog/3077656