2017-10-19 16:14:50 ziyuzhiye 阅读数 11104
在我们升级到Xcode9时,最低的编译版本为iOS8,但是在使用一些SDK的时候就会报出Compiling IB documents for earlier than iOS7 is no longer supported.

这句错误,这个时候我们点击错误跳转到Xib或Storyboard中随后按照截图操作,把build for 的版本更改为iOS7.1或以上错误即可解决



2017-09-25 12:05:42 shihuboke 阅读数 6936

 //联系人:石虎  QQ: 1224614774昵称:嗡嘛呢叭咪哄

一、在升级到Xcode9 遇到以下错误:

  Compiling IB documents for earlier than iOS 7 is no longer supported

  翻译:在ios7之前编译IB文档不再受支持.

二、解决办法如下: 

图一:


图二:


Builds for 选项设置为iOS10 以后就OK了。

谢谢!!!

2018-02-16 20:49:39 u010105969 阅读数 2412

问题:

在利用Xcode9运行之前的项目的时候报错:

Compiling IB documents for earlier than ios 7 is no longer supported。(编译比ios7更早的IB文档不再受支持。)
报错

需要修改的地方![](http://img.blog.csdn.net/20180216205007962?watermark/2/text/aHR0cDovL2Jsb2cuY3Nkbi5uZXQvdTAxMDEwNTk2OQ==/font/5a6L5L2T/fontsize/400/fill/I0JBQkFCMA==/dissolve/70)

找到报错的IB,将Interface Builder Document中的Builders for改为“iOS 7.0 and Later”即可。

本篇文章到这里就结束了,愿大家加班不多工资多,男同胞都有女朋友,女同胞都有男朋友。

没有更多推荐了,返回首页