小程序tls版本_小程序要求的tls版本 - CSDN
精华内容
参与话题
  • 对应的服务器 TLSTLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2"; 解决办法:在部署了SSL证书的服务器上执行下面注册升级文件,然后重启服务器; 文件下载路径: ...

    使用微信开发者工具调试微信小程序,预览的时候提示报异常提示:“对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2”;
    解决办法:在部署了SSL证书的服务器上执行下面注册升级文件,然后重启服务器;
    文件下载路径: https://pan.baidu.com/s/1z-NqQlsCPVuUh7rBJPjthw

    展开全文
  • 微信小程序与第三方服务器通讯的域名5个必要条件 ... 服务器的 TLS 版本支持1.2及以下版本,一般就是1.0、1.1、1.2要同时支持这三个版本,一个也不能少,要不然就会出现下面这种情况   5、微信小程序后台加上合
    微信小程序与第三方服务器通讯的域名5个必要条件

    1、一个已备案的域名,不是localhost、也不是127.0.0.1,域名不能加端口

    2、加ssl证书,也就是https://~~~

    4、HTTPS 服务器的 TLS 版本支持1.2及以下版本,一般就是1.0、1.1、1.2要同时支持这三个版本,一个也不能少,要不然就会出现下面这种情况
     


    5、微信小程序后台加上合法域名设置(一个月内改的次数是有限的,且行且珍惜)如下图

     
    以上5个条件,必需全满足,要不然你手机预览的时候就会发现通讯不了~~~





    另外说一下,TLS版本的问题,这个也是很多朋友经常掉的坑,我也掉过,然后直接去微软官网查了一下资料发现
    windows服务器系统的2008R2以下都不支持,所以大家xp、20003系统什么的就不用折腾了,没用的~~

    发一个windows对TLS版支持的状况图表
    NOTE: Windows Server 2008 R2 and Windows 7 are the only 2 OS which support TLS 1.1 and TLS 1.2 as of now. All the OS’s before this don’t support these 2 protocols.


     

    好了,看了这个图大家应该明白 什么系统可以用了~~

    另附一个查询版本支持的网站,输入你搭好的服务器然后测试一下(要几分钟时间)
    https://www.ssllabs.com/ssltest/index.html
    然后下拉可以看到结果,当1.0、1.1、1.2都是yes了就可以用了,如下
     









    -------------------------------------免费证书问题----------------------------
    我知道的就两个
    一个startssl,网址https://www.startssl.com/
    但startssl我只在2003服务器上面配置成功,但发现03不支持一些TSL版本,换系统2008R2后,死活配置不成功。

    另一个就是阿里云的,也就是我正在用的
    网址:https://wanwang.aliyun.com/
    注册登陆后,要 实名认证
    然后点左则,证书服务
     
    然后点右上则购买证书

     
    然后选DV免费证书
     
    然后写一些资料就可以了
    然后回到证书服务(要审几分钟)
    点下载
     
    拉到下面,根据你的服务器类型下载相应的证书,按照说明配置就可以了(IIS6就不用搞了,记得上面所说的一些windows系统支持问题)
     

    配置好后,不要忘了到这个网站测试一下TLS版本支持,1.0  1.1  1.2都要支持才能用到微信小程序!

    https://www.ssllabs.com/ssltest/index.html


    文章转载自:http://www.wxapp-union.com/forum.PHP?mod=viewthread&tid=1175&highlight=https

    展开全文
  • 微信小程序TLS版本大于1.2

    千次阅读 2017-05-09 15:45:50
    微信小程序与第三方服务器通讯的域名5个必要条件 1、一个已备案的域名,不是localhost、也不是127.0.0.1,域名不能加端口 2、加ssl证书,也就是https://~~~ 4、HTTPS 服务器的 TLS 版本支持1.2及以下版本,一般...

    首先声明下,我自己的服务器是windowsserver2008R2的。

    微信小程序与第三方服务器通讯的域名5个必要条件
    1、一个已备案的域名,不是localhost、也不是127.0.0.1,域名不能加端口
    2、加ssl证书,也就是https://~~~
    4、HTTPS 服务器的 TLS 版本支持1.2及以下版本,一般就是1.0、1.1、1.2要同时支持这三个版本,一个也不能少,要不然就会出现下面这种情况
    这里写图片描述
    5、微信小程序后台加上合法域名设置(一个月内改的次数是有限的,且行且珍惜)如下图
    这里写图片描述

    现在说下TLS版本的问题,这个也是很多朋友经常掉的坑,我也掉过,然后直接去微软官网查了一下资料发现windows服务器系统的2008R2以下都不支持,所以大家xp、20003系统什么的就不用折腾了,没用的~~
    发一个windows对TLS版支持的状况图表
    这里写图片描述

    另附一个查询版本支持的网站,输入你搭好的服务器然后测试一下(要几分钟时间)
    https://www.ssllabs.com/ssltest/index.html
    查询后大家可以在下面看到自己服务器支持的TLS版本,大部分都是只支持1.0

    当大家查询到自己服务器不支持1.1、1.2后,可以选择下面网址的软件,进行配置
    https://www.pianyissl.com/support/page/60

    这里写图片描述

    选择best按钮,发现工具自动选择中了1.0 1.1 1.2版本,然后点击”apply“,一瞬间就完事了,然后他会提醒你,需要自己重启服务起才能生效,工具不会帮你重启。

    展开全文
  • 1、在服务器中新建文本文档,复制粘贴下面代码:Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols] [HKEY_LOCAL_MACHINE\SYSTEM\...

    1、在服务器中新建文本文档,复制粘贴下面代码:

    Windows Registry Editor Version 5.00  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\Multi-Protocol Unified Hello]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\Multi-Protocol Unified Hello\Client]  
    "Enabled"=dword:00000000  
    "DisabledByDefault"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\Multi-Protocol Unified Hello\Server]  
    "Enabled"=dword:00000000  
    "DisabledByDefault"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\PCT 1.0]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\PCT 1.0\Client]  
    "Enabled"=dword:00000000  
    "DisabledByDefault"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\PCT 1.0\Server]  
    "Enabled"=dword:00000000  
    "DisabledByDefault"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Client]  
    "DisabledByDefault"=dword:00000001  
    "Enabled"=dword:00000000  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Server]  
    "Enabled"=dword:00000000  
    "DisabledByDefault"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 3.0]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 3.0\Client]  
    "Enabled"=dword:00000000  
    "DisabledByDefault"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 3.0\Server]  
    "Enabled"=dword:00000000  
    "DisabledByDefault"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client]  
    "Enabled"=dword:00000001  
    "DisabledByDefault"=dword:00000000  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server]  
    "Enabled"=dword:00000001  
    "DisabledByDefault"=dword:00000000  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]  
    "DisabledByDefault"=dword:00000000  
    "Enabled"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]  
    "DisabledByDefault"=dword:00000000  
    "Enabled"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2]  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]  
    "DisabledByDefault"=dword:00000000  
    "Enabled"=dword:00000001  
      
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]  
    "Enabled"=dword:00000001  

    "DisabledByDefault"=dword:00000000  

    2、另存为ssl.reg文件,双击运行,然后重启服务器。

    展开全文
  • 微信小程序 TLS 版本必须大于等于1.2问题解决(自己以亲身试验可以用) 在解决这个问题之前,我们需要...windows2008R2在配置SSL做小程序开发时候提示小程序TLS版本必须大于等于1.2。 解决方法: 请先备份导...
  • 问题 最近开发微信小程序项目,向服务器发起请求时, 遇到一个问题: TLS 版本必须大于等于1.2 解决方案:如何解决:小程序要求的TLS版本必须大于等于1.2...
  • 我自己的服务器是windowsserver2008R2的。 1:开始->运行-&...# Enables TLS 1.2 on windows Server 2008 R2 and Windows 7 # These keys do not exist so they need to be created p...
  • 主要介绍了微信小程序 TLS 版本必须大于等于1.2问题解决的相关资料,需要的朋友可以参考下
  • 最近开发一个小程序,而小程序对后台接口服务器的要求是: 1、请求域名在request合法域名中 2、基于 https 协议 3、TLS 版本 1.2+ 1、2 两条都满足了,但是第三条亟待解决,导致小程序调用接口时报错: 三、...
  • 处理小程序TLS 版本必须大于等于 1.2.zip解压后是一个reg注册表执行文件,然后直接双击执行,最后重启一下服务器即可。 原创文章如转载,请注明出处“伊人博客” ...
  • 如何查看自己服务器的TLS版本呢,windows服务器上可直接到注册表中查看 Ctrl + R 打开命令端 输入 "regedit" 打开注册表 进入路径:[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\...
  • 微信小程序发现wx.request调试报错: 小程序要求的 TLS 版本必须大于等于 1.2 解决方法 执行powershell脚本 Powershell拥有自己的脚本,扩展名为“.ps1”.把下列内容复制保存成.ps1的后缀名,然后...
  • 我这里出现此错误的原因是,搭载域名网站的...小程序报错 TLS 版本必须大于等于 1.2 --文章所有权归周伯通的麦田 ,以下是直接赋值的处理内容: 服务器是windows 2008 server环境是IIS7SSL是申请用的阿里免费...
  • 开发微信小程序时域名http转s,申请完了腾讯云的ssl证书部署完后,小程序出现了对应的服务器 tls 为 tls 1.0,小程序要求的TLS版本必须大于等于1.2的问题,问了一下前辈,给了一个reg文件双击运行,重启服务器,好了...
  • 一、谷歌浏览器访问域名,查看TLS版本,下面是我解决后的已经是1.2了,解决之前一直是1.0,而小程序必须要TLS1.2 二、排查方向: 注意:要想服务器上支持 TLSv1.2,要求基于 OpenSSL 环境的,但是只有 OpenSSL ...
  • 此问题最近在微信小程序开发中,比较常见。 在解决这个问题之前,我们需要了解一下,当前的系统环境是否支持TLS1.2以上,可以参考一下表格: 来源:微软官方 确认系统支持以后,进行一下操作: Windows ...
  • request:fail 小程序要求的 TLS 版本必须大于等于 1.2 request:fail 小程序要求的 TLS 版本必须大于等于 1.2 即当前客户端版本tls多低, 请看是否有代理? filddler的版本是否太低? 不设置fildder代理看看?
1 2 3 4 5 ... 20
收藏数 39,186
精华内容 15,674
关键字:

小程序tls版本