精华内容
参与话题
问答
  • 前言: 好麻烦,早知道就选编程类的了,工程类的实在是麻烦,但是原理是真的简单,就是调式会麻烦一些。走了很多的弯路,写下博客,希望后来人少走弯路。 思路 vlan划分(子网划分) ...vlan:虚拟局域网技术,按...

    前言:
    好麻烦,早知道就选编程类的了,工程类的实在是麻烦,但是原理是真的简单,就是调式会麻烦一些。走了很多的弯路,写下博客,希望后来人少走弯路。
    思路

    1. vlan划分(子网划分)
    2. IP分配(静态+DHCP)
    3. 配置服务器(DNS,WWW等)

    具体步骤

    1. vlan划分

      vlan:虚拟局域网技术,按道理来讲,一台交换机相连的主机都在一个局域网内,但是划分vlan后他们位于不同局域网内。

      划分vlan原因:可以减少网络风暴,提高安全性

      这里主要讲一下如何快速为所有的交换机进行vlan配置,使用VTP(VTP是什么请自行百度)

      VTP有三种模式,我们这里用到服务器端客户端两种模式
      使用VTP的优点:只要在服务器端的交换机进行配置,客户端会自动学习配置
      注意,这里有些小细节!
      1.switch 默认是开启vtp server模式
      2.客户端会学习到vtp domain 名、vlan信息
      3.客户端自动学习的前提是vtp domain name 相同vtp password 相同服务器端交换机和客户端交换机连接接口均开启trunk模式

      VTP配置样例
      1.物理连线
      这里服务器端Switch 我用的是三层交换机,用二层交换机也一样。
      在这里插入图片描述
      2.开启服务器和客户端trunk
      在这里插入图片描述 其实吧,只要服务器端Switch 连接端口开启trunk,客户端会自动开启,嘿嘿
      3.配置服务器端Switch
      在这里插入图片描述
      4.配置客户端Switch
      配置Switch 1 和2
      在这里插入图片描述
      5.测试
      这里测试在服务器Switch 上配置两个vlan 看看client 能否自动学习到
      服务器端Switch
      为vlan 命名
      在这里插入图片描述
      为vlan 划分网段
      在这里插入图片描述Client switch
      在这里插入图片描述
      可以看到Client switch 已经自动学习到了,成功!!!

      将Client 的指定端口加入相应的vlan 就OK了,(PC1在vlan 100,PC 2在vlan 200)
      在这里插入图片描述
      接下来可以为PC1 PC2分配一下静态IP进行连通性测试

    PC1 192.168.100.2 255.255.255.0
    PC2 192.168.200.2 255.255.255.0

    在这里插入图片描述
    ping 不通说明在不同的局域网内,OK!

    1. IP分配(静态+DHCP)
      静态没什么好讲的,直接配置就行,讲一下DHCP服务器如何为不同VLAN内主机分配IP
      思路
      1.为DHCP服务器分配静态IP
      2.配置DHCP服务器的地址池
      3.配置DHCP中继
      4.配置三层交换机端口IP(和DHCP服务器相连的端口)
      5.开启三层交换机路由功能
      6.客户端开启DHCP
      DHCP为不同VLAN划分样例
      先放一张拓扑图
      在这里插入图片描述
      1.为DHCP服务器分配静态IP
      注意,这里DHCP服务器的默认网关是核心交换机的端口IP
      在这里插入图片描述
      2.配置DHCP服务器的地址池
      在这里插入图片描述在这里插入图片描述这里有两个细节需要注意
      1.DHCP service 记得选on
      2.192.168.100.1 之前进行vlan划分时已经作为vlan 100 的IP地址,所以Start IP只能从192.168.100.2开始,默认网关是 vlan 子网 IP,不同vlan的默认网关不同!

    3.配置DHCP中继
    打开三层交换机的clk
    在这里插入图片描述
    为什么要配置DHCP中继的原理就不说了,自行百度。要注意中继指向的是DHCP服务器
    4.配置三层交换机端口IP
    在这里插入图片描述5.开启三层交换机路由功能
    在这里插入图片描述
    6.开启客户端DHCP
    在这里插入图片描述在这里插入图片描述如图,DHCP为不同VLAN分配IP成功!!!

    1. 配置服务器(DNS,WWW等)

    不想写了,有空再写…
    附上样例的pkt文件
    样例pkt文件

    展开全文
  • 哈尔滨理工大学荣成学院 ...计算机网络基础 课程设计   学生姓名: 李秉鹏 学 号: 1030370216    学 院: 哈尔滨理工大学荣成学院    系 别: 软件工程系    专业班级: 计应10-

    哈尔滨理工大学荣成学院

    计算机网络基础

    课程设计

      

    学生姓名:    李秉鹏            学  号:  1030370216            

     

    学   院:     哈尔滨理工大学荣成学院       

     

    系    别:        软件工程系                            

     

    专业班级:         计应10-2                            

     

    设计(论文)题目:        计算机网络技术                        

     

    指导教师:                                  

       

       

    2011年12月


     

                       中文摘要

     

    信息化高速发展的今天,企业局域网的建设已经成为提升企业核心竞争力的关键因素。企业网已经越来越多的被人们提到,利用网络技术,现在企业可以在主分公司、客户、合作伙伴、员工之间实现优化的信息沟通。这直接关系到企业能否获得关键的竞争优势。近年来,越来越多的企业都在加快构建自身的信息网络,而其中绝大多数都是中小企业。目前我国企业尤其是中小企业网络建设正在如火如荼的进行着,据IDC预测:在未来的五年中,中小企业的网络建设将以每年15%的速度增长。

     

     

    关键词  企业网,网络协议,服务器,VLAN

     

    英文摘要

      

      Rapid development of information technology today, the building has become the enterprise LAN to enhance the core competitiveness of the key factors. More and more enterprise network has been mentioned, the use of network technology, companies can now in the main branch, customers, partners and employees to achieve optimal communication between. This is directly related to the availability of key competitive advantage. In recent years, more and more companies are speeding up to build their own information network, most of which are SMES. At present, China enterprises, especially SMES, network construction is in full swing with, according to IDC forecasts: in the next five years, the SME network construction will be an annual growth rate of 15%.

    Keyword:Enterprise network, Network protocol, Server,VLAN


     

    引言

      Internet在全球的发展和普及,企业网络技术的发展,以及企业生存和发展的需要促成了企业网的形成。为了适应网络经济的飞速发展,扩大企业经营的规模和范围,方便企业内部和企业之间的交流,节省办公的开销,提高企业的管理水平,企业发展Intranet(企业内部网)已经是刻不容缓。

    目录  1.  公司的规模及要求

            2.  企业局域网组建需求分析

             2.1企业组网总需求

             2.2 发展需求分析

           2.3 性能需求分析

           2.4 internet接入方案

    3.  局域网的设计要求

           3.1公司需求为前提原则

    3.2品质与成本匹配原则

    4.  网络设计规划

        4.1局域网组网拓扑图

           4.2信息的安全

    4.3操作系统的选择

    4..4服务器的配置

    5.  网段及VLAN的划分

    6.  设备选型

     

    1、公司的规模及要求

    公司名字:xxx保险公司威海分公司

    公司规模:30人,30台电脑

    总经办:经理1名,秘书1名

    人力资源部:部长1名,管理员2名

    市场部:部长1名,秘书1名,业务员20

    财务部:部长1名,会计2名

    组网要求:使用网络将企业的各种计算机、终端设备和局域网连接起来,形成企业内部的Intranet网络,并通过路由器接入Internet,以满足企业办公、研究、生产等需要,可扩充至50台电脑。

     

    2、企业局域网组建需求分析

    2.1企业组网总需求

    1实用性:网络建设从应用实际需求出发,坚持为领导决策服务,为经营管理服务,为生产建设服务。另外,如果是对现有网络升级改造,还应该充分考虑如何利用现有资源,尽量发挥设备效益。

    2 适度先进性:规划局域网,不但要满足用户当前的需要,还应该有一定技术前瞻性和用户需求预见性【1】,考虑到能够满足未来几年内用户对网络功能和带宽的需要。采用成熟的先进技术,兼顾未来的发展趋势,即量力而行,又适当超前,留有发展余地。

    3 经济性:要求价格适中,设备及耗材要求采用质量过硬,物美价廉,投资预算不超过20万。

    4 安全可靠性:确保网络可靠运行,在网络的关键部分应具有容错能力,提供公共网络连接、通信链路、服务器等全方位的安全管理系统【2】

    5 开放性:采用国际标准通信协议、标准操作系统、标准网管软件、采用符合标准的设备,保证整个系统具有开放特点,增强与异机种、异构网的互联能力。

    6 可扩展性:系统便于扩展,保证前期的投资的有效性与后期投资的连续性。

    7 安全保密性:为了保证网上信息的安全和各种应用系统的安全,在规划时就要为局域网考虑一个周全的安全保密方案。

    2.2发展需求分析

    不仅要考虑到容纳网络中当前的用户,而且还应当为网络保留至少 3-5 年的可扩展能力,从而使在用户增加时,网络依然能够满足增长的需要。由于本公司网络采取树型拓扑结构扩展性相对比较好施工时留有额外的接口插头.有扩展需求时只消购买网络连接设备就可以完成扩展工作。

    2.3 性能需求分析

    不同厂家乃至同一厂家不同型号的交换机在性能和功能上都有较大差异,有的安全性高、有的稳定性好、有的转发速率快、有的拥有特殊性能。因此,应当慎重考察和分析本网络对性能的根本需求,以便选择相应品牌和型号的交换机。由于公司规模相对较小,用户端口数量不多且日常工作基于基本的互联网应用就可以完成,设备采购方面首先考虑性价比。

    2.4 internet接入方案

    由于ADSL和LAN等存在传输距离短,接入宽带有限,安全性不高,QoS没有很好地保证等问题,另一方面随着光纤接入技术的快速发展光纤的成本已经不是很高,而传输速率却很高,所以选择光纤接入技术中的SDH接入技术特点是便于设备间的互联,网络管理能力强,具有自愈保护能力等SDH接入的主要设备:终端复用器,分插复用器,数字交叉连接设备,再生器

    SHD接入分层模型:电路层,通道层,传输媒介层在各种局域网技术中,以太网以其造价低、技术成熟、产品丰富、可靠性高、可扩展性好、传输介质丰富和易于管理等有点而成为建设局域网的主流技术。以太网使用CSMA/CD协议,它是一种基于冲突检测机制的网络协议。

    2.5建设目标及原则

    通过建设一个高速、安全、可靠、可扩充的网络系统,实现公司内部信息的高度共享、传递,教学及管理信息化,领导能及时、全面、准确地掌握全公司管理、财务、人事等各方面情况,并通过与广域网的互联,实现与其他公司间的信息共享及与INTERNET 的连接,实现远程管理,为公司管理、日常办公、内外交流、远程会议等各方面提供全面、切实的支持。 随着互联网应用的普及,电子商务有了实质性的进展。对于一个企业来说,产品的介绍、销售、技术服务和售后服务等越来越多地采用网络的形式来完成,最主要的优点是:方便、快捷和成本低廉。

    公司共四个办公室处于同一个楼面。针对在技术规格上的特点,我们采用了交换机用树型(星型的一种特殊结构)集连的拓扑结构【4】,这种拓扑结构的优点是:

    1容易实现:它所采用的传输介质一般都是采用通用的双绞线,这种传输介质相对来说比较便宜,如目前正品五类双绞线每米也仅1.5元左右,而同轴电缆最便宜的也要2.00元左右一米,光缆那更不用说了。这种拓扑结构主要应用于IEEE 802.2、IEEE 802.3标准的以太局域网中。

    2节点扩展、移动方便:节点扩展时只需要从集线器或交换机等集中设备中拉一条线即可,而要移动一个节点只需要把相应节点设备移到新节点即可,而不会像环型网络那样“牵其一而动全局”。

    3 便于维护:采用树型结构,网络故障将先以层为单位被定位在不同的交换层面上,随后在被定位的层面上很快就可以找出发生故障的交换机或节点,这种方法把复杂的维护问题简单化。

    4 采用广播信息传送方式:任何一个节点发送信息在整个网中的节点都可以收到,这在网络方面存在一定的隐患,但这在局域网中使用影响不大。

    5网络传输数据快:这一点可以从目前最新的1000Mbps到10G以太网接入速度可以看出【5】

     

    拓扑图1-1如

          

     

    2、局域网的设计要求

    3.1公司需求为前提原则

     坚持以公司具体需求为小型局域网信息系统方案设计的根本和前 提,同时,也要注重源于需求又高于需求的原则,注意用专业化的技术思想来帮助家庭、公司方进行小型局域网的规划与设计,确保局域网的实用性、先进性和便于扩展性。

    3.2品质与成本匹配原则

    选择品质最好的设备不一定是最佳方案,成本因素也是一个不容忽视的问题,只有将品质与成本实现最佳匹配,才是一个最优秀的方案。技术应用全面原则在技术应用方面,我们全面考虑其实用性、先进性、开放性、可扩充性、可靠性、安全保密性及友好性。坚持标准原则一切局域网设计和布线,均要遵循国际标准。

     

    3、网络设计规划

      4.1局域网组网拓扑图

      公司网络采用了交换机用树型(星型的一种特殊结构)集连的拓扑结构,一个核心交换机连接四个二层交换机

    4.2信息的安全

    在部门之间也实行 VLAN 的划分,将不同的用户的数据流进行隔离以免不合法的用户访问。采用 VLAN 则我们扩展用户就有了极大的灵活性,并且安全性也增加了。由于每个 VLAN 都是一个单独的网络,所以广播只限旨在其源点所在的 VLAN 之中。也就是所,我们需要路由器来实现 VLAN 之间的通信。 8 《计算机网络技术》课程设计 为了将来网络的发展,对每个 VLAN 预备了备用 IP 地址。为了方便管理,在管理机上配置 DHCP 服务。网络中心路由交换机采用 DHCP RELAY 的技术隔离用户和 DHCP服务器,可以通过 IP 地址、MAC 地址与 VLAN ID 绑定技术防止 MAC 地址、IP 地址的盗用。

    4.3操作系统的选择

    操作系统:作为服务器的PC采用windows server 2003,普通PC采用windows XP

    4.4务器的配置

    4.4.1 www服务器的配置

    1.    安装IIS 6.0

    控制面板—添加/删除程序—添加/删除windows组件—windows组件向导—应用程序服务器—internet信息服务(IIS)—万维网服务

    2.    创建WEB站点

    控制面板—管理工具—internet信息服务(IIS)管理器—Server Name(本地计算机)—网站—新建网站(根据公司的具体需求进行详细的设置)

    3.    设置WEB站点属性

    1.检查web站点的运行状态

    2.指定好默认的内容文档

    4.4.2 DNS服务器的设置

    1.    安装DNS服务器组件

    控制面板—添加/删除程序—添加/删除windows组件—windows组件安装向导—网络服务—域名系统(DNS)

    2.    创建正向查找区域

    开始—管理工具—DNS—配置DNS服务器:主服务器位置—这台服务器维护该区域

                                           区域名称—按公司的要求输入

                                           区域文件—保持默认值

                                           动态更新—允许非安全和安全动态更新

                                           转发器—配置ISP.

    3. 设置DNS转发器

    4. 创建辅助区域

    4.4.3 电子邮件服务器的配置

    1.    邮件服务器的安装

    控制面板—管理工具—配置您的服务器向导—预备步骤—邮件服务器

    2.    邮件服务器的配置

    控制面板—管理工具—POP3服务

    4.4.4 DHCP服务器的配置

    1.    DHCP服务的安装

    控制面板—添加/删除程序—windows组建向导—网络服务—动态主机配置协议

    2.    创建DHCP作用域

    控制面板—管理工具—DHCP—新建作用域向导:IP地址范围—设置起始IP地址

                                               添加排除

                                               租约期限—设置为8天

                                               配置DHCP选项

                                               路由器—添加网关地址

                                               激活作用域

    3.    设置DHCP的客户端

    网上邻居—属性—网络连接—本地连接—属性—internet协议(TCO/IP)属性

     

    5、网段及VLAN的划分

    为了设计的方便,Cisco2650交换机与Cisco2650交换机的通信通过三层交换机实现。

    部      门

    所属VLAN

    IP 地 址

    总经办

    Vlan101

    10.65.1.1/2

    财务处

    Vlan102

    10.65.1.3/4

    人力资源部

    Vlan103

    10.65.1.5/6

    市场部

    Vlan104

    10.65.1.7/30

     

     

    路由器的初始化:

     

    交换机的初始化:

    配置主机ip地址

     

    A ping B B ping A

    B ping D A ping D

    A ping E A ping G

     

    D ping A   D ping C

    E ping A   E ping F

     

    G ping A

    G ping H

     

    6、设备选型

     

    编号

    类型

    商品

    数量

    价格/元

    1

    防火墙

    SONICWALL TZ 150

    1

    4200

    2

    服务器

    Dell Power Edge T110 II

    1

    5080

    3

    路由器

    迅捷(FAST)FR48

    1

    79

    4

    交换机

    腾达(TENDA) S105

    3

    150

    5

    交换机

    欧雅图24

    1

    1800

    6

    交换机

    华为Quid way S6502

    1

    9000

    7

    网线

    安普五类非屏蔽双绞线

    1

    234

    8

    水晶头

    TCL RJ45

    100

    100

                                  总计

    20643

     

    结论

    通过这次课程设计,一方面我熟记了老师所讲的知识并学到了很多书本上没有的知识,平时老师讲的都是基础,在这门学科里还有很多的知识需要自己去学习、去实践,所谓师傅领进门,修身在个人,只有自己亲自动手做了,才会学的更快,记得更牢。完成毕业设计后,我心情舒畅并有一丝丝的成就感!本次设计使我对局域网组建及相关的网络知识有了更广泛的了解,更重要的是系统地了解了有关局域网的组建及其作用。在设计中有很多地方都是因为自己的粗心所造成的一些不必要的错误,也让我了解组建局域网时有太多高端的设备时我以前没有见过的,信息时代发展的是如此的快速。要想掌握最前端的设备必须关注信息的发展。

    另一方面现代社会是一个信息化的社会,人们对信息的需求越来越大,对信息的传递速度要求越来越快,因此现代化的办公网络应具有先进的信息检索、快速的传输方式及完备的信息管理手段。而宽带业务的产生,Intranet技术的发展给我们带来一个这样的新机遇。同时,Internet的发展也给我们带来了一个新的名词--Intranet,它在局域网中采用Internet的技术,使得局域网也能获得Internet的种种好处。例如可以让频道的员工无需复杂的培训便能使用统一的浏览界面查看频道发布的各种信息;频道的信息发布可以实现集中式管理,24小时发布,并可以实现无纸化、低成本;频道各部门及各员工之间可以更加方便地相互通讯;在Intranet上为员工提供技术培训具有方便、快捷的特点;此外,通过Web进行数据库检索,可以使频道人员更加方便地查找到所需要的信息。本设计以小型企业局域网的组建实现了,信息的传递和信息安全,满足企业内部之间的办公。

    致谢

    大二学年的学习生活即将结束,在此,我要感谢所有曾经教导过我的老师和关心过我的同学,他们在我成长过程中给予了我很大的帮助。本文能够成功的完成,要特别感谢我的指导老师徐辉老师的关怀和教导,以及梁永先老师、梁夫永老师、王进科老师等等,还有我同窗3年的同学们,在此要特别感谢我宿舍的兄弟在这一年中给我的帮助。

    参考文献

    [1]王晓东. SDH接入完全手册  51CTO.com

    [2]杨创群. FTTP各种光纤接入技术的探讨  广东通信技术期刊

    [3]孙波. 计算机网络技术 机械工业出版社

     

    展开全文
  • 计算机网络课设

    万次阅读 多人点赞 2017-09-15 13:18:15
    计算机网络课程设计报告书         专业:计嵌 班级:计嵌151 学号:1513052017 姓名:张耀           目录   一、 设计题目 二、 设备选型 三、 IP地址规划 四、 拓扑图设计 五、 主要技术 六...

     

     

     

     

     

     

    《计算机网络》

    课程设计报告书

     

     

     

     

    专业:计嵌

    班级:计嵌151

    学号:1513052017

    姓名:张耀

     

     

     

     

     

    目录

     

    一、   设计题目

    二、   设备选型

    三、   IP地址规划

    四、   拓扑图设计

    五、   主要技术

    六、   配置清单

    七、   总结

     

     

     

     

     

     

     

     

     

     

     

     

     

    一、设计题目

    1、课设目的

    巩固《计算机网络》和《网络通信》两门课程的知识,在本次课程设计中充分利用前面所学的知识,熟练应用所有技术,系统掌握一个较为复杂的网络配置过程。在课设中有少量需要的技术教学过程中没有涉及,请自己查阅CCNA资料。

     

    2、课设内容

    项目背景:某中小型企业有两个部门,销售部(vlan10)与行政部(vlan 20)。要求同部门之间采用二层交换网络相连;不同部门之间采用单臂路由方式互访。企业有一台内部web服务器,承载内部网站,方便员工了解公司的即时信息.局域网路由器启用多种路由协议(静态路由、动态路由协议),并实施路由控制、负载均衡、链路认证、访问限制等功能.企业有一条专线接到运营商用以连接互联网,采用HDLC封装,由于从运营商只获取到一个公网IP地址,所以企业员工上网需要做NAT网络地址转换,具体拓扑结构如上图所示。


    二、设备选型

    名称

    型号

    数量

    路由器

    2811

    6台

    交换机

    2960-24

    2台

    PC主机

    PC-PT

    2台

    直通线

    --

    6根

    多模光缆

    Serial DTE/DCE

    5根

    交叉线

    --

    5根

    Server主机

    Server-PT

    1台

    Laptop主机

    Laptop-PT

    2台

    网云

    Cloud-PT

    1个

     

    三、IP地址规划

    设备

    接口

    IP地址

    网关

    ZY_PC1

    Fa0

    192.168.1.1

    192.168.1.254

    ZY_PC2

    Fa0

    192.168.2.1

    192.168.2.254

    ZY_PC3

    Fa0

    192.168.1.2

    192.168.1.254

    ZY_PC4

    Fa0

    192.168.2.2

    192.168.2.254

    ZY_Web Server

    Fa0

    10.10.10.10

    10.10.10.11

     

    ZY_Router1

    Fa0/0

    172.16.1.1/24

     

    Fa0/1

    192.168.1.254/24

    Se1/0

    10.10.20.13/24

    Se1/1

    10.1.1.1/24

    ZY_Router2

    Se1/1

    10.1.1.1/24

    Se1/2

    10.2.2.2/24

     

    ZY_Router3

    Fa0/0

    192.168.2.254/24

    Fa0/1

    172.16.2.3/24

    Se1/2

    10.2.2.3/24

    ZY_Router4

    Fa0/0

    172.16.1.4/24

    Fa0/1

    172.16.2.3/24

    Se1/1

    200.1.1.1

    ZY_Router5-运营商

    Se1/0

    200.1.1.2

     

     

     

    四、拓扑图设计


    五、主要技术

    Trunk:在路由/交换领域,VLAN的中继端口叫做trunk。trunk技术用在交换机之间互连,使不同VLAN通过共享链路与其它交换机中的相同VLAN通信。交换机之间互连的端口就称为trunk端口。trunk是基于OSI第二层数据链路层(DataLinkLayer)的技术。

    Vlan:在计算机网络中,一个二层网络可以被划分为多个不同的广播域,一个广播域对应了一个特定的用户组,默认情况下这些不同的广播域是相互隔离的。不同的广播域之间想要通信,需要通过一个或多个路由器。这样的一个广播域就称为VLAN。

    单臂路由:在计算机网络中,一个二层网络可以被划分为多个不同的广播域,一个广播域对应了一个特定的用户组,默认情况下这些不同的广播域是相互隔离的。不同的广播域之间想要通信,需要通过一个或多个路由器。这样的一个广播域就称为VLAN。

    默认路由:默认路由是一种特殊的静态路由,指的是当路由表中与包的目的地址之间没有匹配的表项时路由器能够做出的选择。如果没有默认路由,那么目的地址在路由表中没有匹配表项的包将被丢弃,默认路由在某些时候非常有效,当存在末梢网络时,默认路由会大大简化路由器的配置,减轻管理员的工作负担,提高网络性能。

    动态路由:动态路由是指路由器能够自动地建立自己的路由表,并且能够根据实际情况的变化适时地进行调整。 (RIP、OSPF)

    ACL:访问控制列表(Access Control List,ACL)是路由器和交换机接口的指令列表,用来控制端口进出的数据包。

    帧中继:帧中继(Frame Relay)是一种用于连接计算机系统的面向分组的通信方法。它主要用在公共或专用网上的局域网互联以及广域网连接。大多数公共电信局都提供帧中继服务,把它作为建立高性能的虚拟广域连接的一种途径。

    NAT:NAT(NetworkAddress Translation,网络地址转换)是1994年提出的。当在专用网内部的一些主机本来已经分配到了本地IP地址(即仅在本专用网内使用的专用地址),但现在又想和因特网上的主机通信(并不需要加密)时,可使用NAT方法。

    六、配置清单

    一、基本配置

    1、按上面的拓扑结构搭建仿真网络硬件


    2、给路由器和交换机命名(可以自己选择命名)

    -->为Router5命名(其他设备操作相同)


    ->所有设备重新命名后


    3、配置和启动交换和路由的接口,配置终端设备的IP地址和默认网关。

    -->配置PC1的IP地址和默认网关(其他设备操作相同)


    -->开启并配置Router1的Fa0/0接口,并为其配置IP地址等属性(其他设备操作相同)


    二、交换机配置

    1、配置Etherchanne,捆绑Sw1与Sw2的F0/11,F0/12接口.要求使用Cisco PAGP协议中的主动协商模式。

    -->配置Sw1和Sw2


    2、配置VTP,在Sw1与Sw2上配置VTP, 域名为nantong.Sw1作为Server;Sw2作为Client,设置密码为student。

    -->配置Sw1


    -->配置Sw2


    3、配置创VLAN,建vlan 10,命名为sales;vlan 20命名为Admin.并把相应的接口划分到所属vlan中。在Sw1上设置管理vlan 10,地址为192.168.1.10/24;再设置管理vlan 20,地址为192.168.2.10/24.做一个ACL访问控制,要求只有PC1/PC2可以远程访问Sw1.

    -->在Sw1上创建Vlan


    -->在Router1上做ACL访问控制


    4、单臂路由配置。单臂路由:vlan 10以R1的F0/1.10作为出口网关;vlan 20以R3的F0/0.20作为出口网关。(若无法实现,可以在一台路由器实现单臂功能)

    三、路由配置

    1、默认路由配置,在R4上配置默认路由,出口指向R5运营商。


    2.、在内网路由器上配置RIPv2(关闭自动汇总),使得全网互通,关闭R4与运营商R5的S1/1 S1/0接口宣告。


    3、在内网路由器配置单区域(area0)OSPF,使得全网互通,关闭R4与运营商R5的S0/0接口宣告。


    4、配置ACL,在R1上设置ACL访问限制:所有用户都可以ping通Server; 除PC1和PC4以外,其他用户都可以访问内部网站。


    -->测试(PC1、PC2、PC3、PC4都可以ping通Server)

    --测试(PC2、PC3可以访问Server)

     

    --测试(PC1、PC4不可以访问Server)


    四.广域网配置
    1.PPP链路配置,在R1/R2的串行链路封装PPP,进行PAP认证,R1为R2创建用户名Bob,密码为11111111;R2为R1创建用户名Alice,密码为22222222.

    -->R1为R2创建


    -->R2为R1创建


    2.边界路由R4和运营商R5链路配置HDLC。

    -->网云(Cloud-PT)配置

    串口S0配置(S1操作相同)



    3.NAT配置,在边界路由器R4上配置NAT,使得企业内部所有PC都能上网(ping通运营商的200.1.1.2), 但Server不允许连接外网。





    --测试(PC1、PC2、PC3、PC4可以ping运营商)


    --测试(Server不可以ping运营商)


    七、总结

    1.调试过程中出现的问题以及解决办法

    这次课设还是遇到了挺多问题的,具体问题和解决办法如下:

    1、刚开始的时候,是在设置路由器的各种端口的时候,子网掩码出现了问题,老是会出现overlap这个单词,查了词典才知道是覆盖的意思,所以它的子网掩码可能被覆盖了,所以我就将子网掩码改了一下,就可以了。

    2、之后遇到问题的就是配置默认路由了,因为它需要出口指向运营商,所以我就有点矛盾了,所以我就设置了两种在里面,也不知道哪一种是对的。

    3、之后就是ACL,因为之前也没有学过这个,所以拿到这个的时候有点蒙,所以就各种查资料,查百度,问同学,最终还是顺利的解决了这个问题。

    4、之后是帧中继,这个我按照老师发给我们的实验手册一步一步的输入代码,舍友也跟我的步骤一模一样,但是他的就是可以执行,但是我的就是不行,后来发现是网云配置出现了问题,虽然被这个问题困惑了好久,但是受益匪浅。

    5、最后一个NAT,在指定NAT的内部接口和外部接口一开始忘记配置了,后来检查导出的文件才检查到的。

    2.个人体会及建议

    这次课设说实话还是很充实的,因为一步一步下来,每一步自己做出来都会有成就感,当然也会有挫败感啦,但是这次课设还是很好的把上学期所学的东西巩固。还是很想多学一点关于这门课的知识,因为实践起来真很有趣。

    3.参考文献

    1.谢希仁 ,计算机网络(第7版),电子工业出版社

    2.曹利,Packet Tracer5.0 使用手册

    3.(美)Todd Lammle,CCNA学习指南:路由和交换认证:100-101、200-101、200-120:exams100-101,200-101,and200-120,人民邮电出版社

    4.(美)Richard Deal,CCNA学习指南,人民邮电出版社

    5.百度文库

     

    注意:如果您需要doc格式的该文档。可以去查看本人的百度文库:https://wenku.baidu.com/view/6e54faf7b1717fd5360cba1aa8114431b80d8e50自行下载。

    展开全文
  • 计算机网络课程设计(一)

    万次阅读 2019-07-08 16:14:59
    这里写自定义目录标题欢迎使用Markdown编辑器新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码片生成一个适合你的列表创建一个表格设定内容居中、居左、...

    VLAN划分和动静态基础配置

    实验二 使用单交换机进行VLAN划分

    1. 实验目的:
      通过本次实验,让读者对交换机的配置方法有一个初步的认识,并熟悉交换机配置的各种常用命令。能对虚拟局域网配置是否正确进行测试。
      2.实验要求
      按照下面的网络模型图,进行VLAN的配置。

      图2
      表2.1:计算机 PC1到PC6的IP地址和子网掩码分配如下表所示:
      设备 IP 掩码
      PC0 192.168.100.1 255.255.255.0
      PC1 192.168.100.2 255.255.255.0
      PC2 192.168.100.3 255.255.255.0
      PC3 192.168.100.4 255.255.255.0
      3.实验所需要的设备
      S1216交换机一台、网络连线(若干根)
      4.写出实验步骤
      根据图2的拓扑结构来配置,把PC0和PC1划分为VLAN30,把PC2和PC3划分为VLAN40,配置步骤如下:
      (1)首先配置PC0计算机的IP地址和默认网关。
      同理,把PC1到PC3按这个方法设置成不同的IP地址,IP地址的值如表2-1所示。
      (2)设置交换机,具体使用的命令如下所示:
      在这里插入图片描述
      在这里插入图片描述
    2. 实验中所使用的命令的详细解释
      enable
      !进入特权命令状态
      config terminal
      !进入全局设置状态
      vlan 30

    name test1
    !定义VLAN30并命名为test1

    interface fastethernet 0/1
    !进入快速以太口fa0/1端口
    switchport mode access

    switch access vlan 30
    !将端口静态配置到VLAN30
    exit
    !返回到全局配置模式
    interface fastethernet 0/2
    !进入快速以太口fa0/2端口
    Switchport mode access

    Switch access vlan 30
    !将端口静态配置到VLAN30
    exit
    !返回到全局配置模式
    interface range fastethernet 0/1-2
    !进入一个端口范围
    Switchport access vlan 30
    !将端口0/1,0/2加入vlan 30
    exit
    !返回到全局配置模式
    vlan 40

    name test2
    !定义VLAN40并命名为test2

    interface fastethernet 0/3
    !进入快速以太口fa0/3端口
    Switchport mode access

    Switch access vlan 40
    !将端口静态配置到VLAN40
    exit
    !返回到全局配置模式
    interface fastethernet 0/4
    !进入快速以太口fa0/4端口
    Switchport mode access

    Switch access vlan 40
    !将端口静态配置到VLAN40
    exit
    !返回到全局配置模式
    interface range fastethernet 0/3-4
    !进入一个端口范围
    Switchport access vlan 40
    !将端口0/3,0/4加入vlan 40
    exit
    !返回到全局配置模式
    6.实验的验证方式
    (1)给出PC0机PING到PC1的屏幕截图:
    在这里插入图片描述
    给出PC0机PING到PC2的屏幕截图:
    在这里插入图片描述
    给出PC2机PING到PC3的屏幕截图:

    在这里插入图片描述

    给出PC2机PING到PC1的屏幕截图:

    在这里插入图片描述

    (2)给出显示交换机的VLAN信息的屏幕截图:
    在这里插入图片描述

    1. 实验总结
      熟悉了如何去为端口命名,如何进入端口,如何将端口静态配置到vlan,如何进入配置一个端口范围,如何显示路由信息的命令;
      在交换机中,一个端口只属于一个VLAN;
      经同一交换机连接的不同PC机,即使连接同一个交换机,但划分为不同vlan的PC机,不能进行通信,Ping命令失败,只有划分为相同的vlan才可以进行通信,ping命令成功;

    2. 思考题
      为什么要使用虚拟局域网?有什么好处?
      VLAN有着和普通物理网络同样属性,但其划分不受网络端口实际物理位置限制。
      在交换机组成的网络里所有主机都在同一个广播域内,容易引发“广播风暴”;虚拟局域网限制了接受广播信息的计算机数,使得网络不会因传播过多的广播信息而引起性能恶化;VLAN 第二层单播、广播和多播帧在一个VLAN内转发、扩散,而不会直接进入其他VLAN之中。

    使用虚拟局域网的好处:
    安全:通过划分不同vlan网,可以对网络进行一个安全的隔离,不同vlan之间的网络不能直接访问,让相关部门数据安全得到了保证;
    隔离广播:通过分割广播域,限制网络上的广播,将网络划分为多个VLAN可减少参与广播风暴的设备数量,降低了整个网络的广播流量,提高了性能。
    不受物理位置限制:可以跨地域(跨交换机)将其设置在同一VLAN中实现不同地域的数据共享。
    分段管理更具有灵活性;

    实验三 多个交换机间的VLAN配置

    1. 实验目的:
      通过本次实验,让读者能够实现在多个交换机之间如何来进行VLAN的配置。
      2.实验要求
      按照下面的网络模型图,进行VLAN的配置。
      在这里插入图片描述
      图3
      表3-1:计算机 PC1到PC6的IP地址和子网掩码分配如下表所示:
      设备 IP 掩码
      PC0 192.168.100.1 255.255.255.0
      PC1 192.168.100.2 255.255.255.0
      PC2 192.168.100.3 255.255.255.0
      PC3 192.168.100.4 255.255.255.0
      3.实验所需要的设备
      S1216G交换机2台、网络连线(若干根)
      4.实验步骤
      根据图3的拓扑结构来配置,把PC0和PC2划分为VLAN30,把PC1和PC3划分为VLAN40,配置步骤如下:
      (1)首先配置PC0计算机的IP地址和默认网关。
      同理,把PC1到PC3按这个方法设置成不同的IP地址,IP地址的值如表3-1所示。
      (2)设置交换机,具体使用的命令如下所示:
      在这里插入图片描述

    在这里插入图片描述

    1. 实验中所使用的命令的详细解释
      Switch0交换机的命令行解释:
      enable
      !进入特权命令状态
      config terminal
      !进入全局设置状态
      vlan 30

    name test1
    !定义VLAN30并命名为test1
    exit
    !返回到全局配置模式
    interface fastethernet 0/1
    !进入快速以太口fa0/1端口
    switchport mode access

    switch access vlan 30
    !将端口0/1静态配置到VLAN30
    exit
    !返回到全局配置模式
    interface fastethernet 0/2
    !进入快速以太口fa0/2端口
    Switchport mode access

    Switch access vlan 40
    !将端口0/2静态配置到VLAN40
    exit
    !返回到全局配置模式
    interface fastethernet 0/3
    !进入快速以太口fa0/3端口
    Switchport mode trunk
    !把Fa 0/1配成Trunk口
    no shutdown
    !开启端口
    exit
    !返回到全局配置模式

    Switch1交换机的命令行解释:
    enable
    !进入特权命令状态
    config terminal
    !进入全局设置状态
    vlan 30

    name test1
    !定义VLAN30并命名为test1
    exit
    !返回到全局配置模式
    interface fastethernet 0/1
    !进入快速以太口fa0/1端口
    switchport mode access

    switch access vlan 30
    !将端口0/1静态配置到VLAN30
    exit
    !返回到全局配置模式
    interface fastethernet 0/2
    !进入快速以太口fa0/2端口
    Switchport mode access

    Switch access vlan 40
    !将端口0/2静态配置到VLAN40
    exit
    !返回到全局配置模式
    interface fastethernet 0/3
    !进入快速以太口fa0/3端口
    Switchport mode trunk
    !把Fa 0/1配成Trunk口
    no shutdown
    !开启端口
    exit
    !返回到全局配置模式
    6.实验的验证方式
    (1)给出PC0机PING到PC1和PC4的屏幕截图:
    在这里插入图片描述
    给出PC3机PING到PC1和PC2的屏幕截图:
    在这里插入图片描述
    (2)给出显示交换机的VLAN信息的屏幕截图:
    在这里插入图片描述

    7.实验总结
    熟悉了如何设置Trunk端口以及开启端口的命令;
    当交换机与交换机相联系时,将交换机之间连接的链路设置为trunk链路,使得连接不同交换机之间的链路可以传递多个VLAN的信息,通过多个交换机通信的实现可以保证跨地域,不同地理位置的数据共享。

    实验四 静态路由的实验报告要求

    1. 实验目的:
      通过本次实验,让读者对路由器的配置方式有一个初步的认识,对路由器各端口和手工建立路由表的方法有一个大概的了解。同时能够理解计算机网络书中网络数据包的传递过程和路由器的转发机制。
      1.实验要求
      按照下面的网络模型图,进行静态路由器的配置。
      在这里插入图片描述
      图4
    2. 实验所需要的设备
      路由器3台,PC机两台,网络连线(若干根)
      3.实验步骤
      根据图4的拓扑结构来配置:
      (1)首先配置PC0和PC1计算机的IP地址和默认网关,IP地址的值如表4-1所示。
      表4-1:计算机 PC0和PC1的IP地址和子网掩码和默认网关如下表所示:
      设备 IP 掩码 默认网关
      PC0 10.0.0.2 255.0.0.0 10.0.0.1
      PC1 40.1.0.2 255.0.0.0 40.1.0.1

    (2)设置路由器route0,其接口,IP地址和子网掩码如表4-2所示;
    表4-2:路由器route0的IP地址好子网掩码如下表所示:
    接口 IP 掩码
    0/0 20.1.0.1 255.0.0.0
    0/1 10.0.0.1 255.0.0.0

    (3)设置路由器route1,其接口,IP地址和子网掩码如表4-3所示;
    表4-3:路由器route1的IP地址好子网掩码如下表所示:
    接口 IP 掩码
    0/0 20.1.0.2 255.0.0.0
    0/1 30.1.0.1 255.0.0.0

    (4)设置路由器route2,其接口,IP地址和子网掩码如表4-4所示;
    表4-4:路由器route2的IP地址好子网掩码如下表所示:
    接口 IP 掩码
    0/0 30.1.0.2 255.0.0.0
    0/1 40.1.0.1 255.0.0.0

    (5)添加路由器R1,R2,R3的静态路由选择,其相关信息如表4-5所示:
    表4-5:路由器R1,R2,R3静态路由的相关信息如下表所示:
    设备 目的网络 掩码 默认网关
    Route0 40.1.0.0 255.255.0.0 20.1.0.2
    Route1 40.1.0.0 255.255.0.0 30.1.0.2
    10.0.0.0 255.0.0.0 20.1.0.1
    Route2 10.0.0.0 255.0.0.0 30.1.0.1

    (6)启动路由器R1,R2,R3的接口;

    1. 实验中所使用的命令的详细解释
      Route0:
      interface fastethernet0/0
      !进入快速以太口fa0/0端口
      Ip address 20.1.0.1 255.0.0.0
      !配置接口0/0端口的网关和掩码
      no shutdown
      !开启f0/0端口
      exit
      !返回到全局配置模式
      interface fastethernet0/1
      !进入快速以太口fa0/1端口
      ip address 10.0.0.1 255.0.0.0
      !配置接口的网关和掩码
      no shutdown
      !开启f0/1端口
      exit
      !返回到全局配置模式
      ip route 40.1.0.0 255.255.0.0 20.1.0.2
      !配置静态路由
      exit
      !返回到全局配置模式

    Route1:
    interface fastethernet0/0
    !进入快速以太口fa0/0端口
    Ip address 20.1.0.2 255.0.0.0
    !配置接口0/0端口的网关和掩码
    no shutdown
    !开启f0/0端口
    exit
    !返回到全局配置模式
    interface fastethernet0/1
    !进入快速以太口fa0/1端口
    ip address 30.1.0.1 255.0.0.0
    !配置接口的网关和掩码
    no shutdown
    !开启f0/1端口
    exit
    !返回到全局配置模式
    ip route 40.1.0.0 255.255.0.0 30.1.0.2
    !配置静态路由
    ip route 10.0.0.0 255.0.0.0 20.1.0.1
    !配置静态路由
    exit
    !返回到全局配置模式

    Route2:
    interface fastethernet0/0
    !进入快速以太口fa0/0端口
    Ip address 30.1.0.2 255.0.0.0
    !配置接口0/0端口的网关和掩码
    no shutdown
    !开启f0/0端口
    exit
    !返回到全局配置模式
    interface fastethernet0/1
    !进入快速以太口fa0/1端口
    ip address 40.1.0.1 255.0.0.0
    !配置接口的网关和掩码
    no shutdown
    !开启f0/1端口
    exit
    !返回到全局配置模式
    ip route 10.0.0.0 255.0.0.0 30.1.0.1
    !配置静态路由
    exit
    !返回到全局配置模式
    6. 实验的验证方式
    (1)给出路由器R1、R2、R3的路由表
    路由器R1的路由表相关信息:
    在这里插入图片描述
    路由器R2的路由表相关信息:
    在这里插入图片描述
    路由器R3的路由表相关信息:
    在这里插入图片描述

    (2)给出从一个PC机PING另一个PC机的屏幕截图:
    在这里插入图片描述

    7. 实验总结
    静态路由是由网络管理员在路由器的路由表中手动配置的,是固定的,不会改变。除非网络管理员干预,否则静态路由不会发生变化。
    静态路由具有简单、高效、可靠和网络安全保密性高的优点,但一旦静态路由的拓扑结构和链路状态发生变化,路由器中的静态路由信息需要大范围地调整,这一工作的难度和复杂程度非常高。
    8. 思考题
    在Cisco的路由器中,如果同时存在去往同一网段的静态路由信息与动态路由信息,路由器会采用哪一个?
    路由器会优先选择静态路由;因为静态路由更易于监管,可达性更高;且静态路由管理距离值更低,学到的路由更可信;
    实验五 RIP路由配置方法

    1. 实验目的:
      通过本次实验,让读者了解RIP协议和IGRP协议的工作过程,并能对这两种协议通过路由器进行设置,同时查看所生成的路由表,是否和按照工作原理所生成的路由表表相同,对路由器的路由表有一个深刻的认识。
    2. 实验要求
      按照下面的网络模型图,进行RIP和IGRP的配置。
      在这里插入图片描述
      图5
      根据上图和RIP协议的路由选择算法,先手工计算出各路由器的路由表;然后再进行相应的配置,以实现PC1和PC2之间能够Ping通。
    3. 实验所需要的设备
      路由器3台,PC机两台,网络连线(若干根)
      4.实验步骤
      根据图5的拓扑结构来配置:
      (1)首先配置PC0和PC1计算机的IP地址和默认网关,IP地址的值如表5-1所示。
      表5-1:计算机 PC0和PC1的IP地址和子网掩码和默认网关如下表所示:
      设备 IP 掩码 默认网关
      PC0 10.0.0.2 255.0.0.0 10.0.0.1
      PC1 40.1.0.2 255.0.0.0 40.1.0.1

    (2)设置路由器route0,其接口,IP地址和子网掩码如表5-2所示;
    表5-2:路由器route0的IP地址好子网掩码如下表所示:
    接口 IP 掩码
    0/1 20.1.0.1 255.0.0.0
    0/0 10.0.0.1 255.0.0.0

    (3)设置路由器route1,其接口,IP地址和子网掩码如表5-3所示;
    表5-3:路由器route1的IP地址好子网掩码如下表所示:
    接口 IP 掩码
    0/1 20.1.0.2 255.0.0.0
    0/0 30.1.0.1 255.0.0.0

    (4)设置路由器route2,其接口,IP地址和子网掩码如表5-4所示;
    表5-4:路由器route2的IP地址好子网掩码如下表所示:
    接口 IP 掩码
    0/1 30.1.0.2 255.0.0.0
    0/0 40.1.0.1 255.0.0.0

    (5)添加路由器R1,R2,R3的RIP路由选择,其相关信息如表5-5所示:
    表5-5:路由器R1,R2,R3的RIP路由的相关信息如下表所示:
    设备 下一跳网络地址
    Route0 20.0.0.0
    10.0.0.0
    Route1 30.0.0.0
    20.0.0.0
    Route2 30.0.0.0
    40.0.0.0

    (6)启动路由器R1,R2,R3的接口;

    1. 实验中所使用的命令的详细解释
      Route0:
      Interface fastethernet0/0
      !进入快速以太口fa0/0端口
      ip address 20.1.0.1 255.0.0.0
      !配置接口0/0的网关和掩码
      no shutdown
      !开启端口0/0
      exit
      !返回到全局配置模式
      interface fastethernet0/1
      !进入快速以太口fa0/1端口
      Ip address 10.0.0.1 255.0.0.0
      !配置接口0/1的网关和掩码
      no shutdown
      !开启端口0/1
      exit
      !返回到全局配置模式
      route rip
      !开启RIP路由协议进程
      network 10.0.0.0
      !添加下一跳网络
      network 20.0.0.0
      !添加下一跳网络
      exit
      !返回到全局配置模式

    Route1:
    Interface fastethernet0/0
    !进入快速以太口fa0/0端口
    ip address 30.1.0.1 255.0.0.0
    !配置接口0/0的网关和掩码
    no shutdown
    !开启端口0/0
    exit
    !返回到全局配置模式
    interface fastethernet0/1
    !进入快速以太口fa0/1端口
    Ip address 20.0.0.1 255.0.0.0
    !配置接口0/1的网关和掩码
    no shutdown
    !开启端口0/1
    exit
    !返回到全局配置模式
    route rip
    !开启RIP路由协议进程
    network 20.0.0.0
    !添加下一跳网络
    network 30.0.0.0
    !添加下一跳网络
    exit
    !返回到全局配置模式

    Route2:
    Interface fastethernet0/0
    !进入快速以太口fa0/0端口
    ip address 40.1.0.1 255.0.0.0
    !配置接口0/0的网关和掩码
    no shutdown
    !开启端口0/0
    exit
    !返回到全局配置模式
    interface fastethernet0/1
    !进入快速以太口fa0/1端口
    Ip address 30.0.0.1 255.0.0.0
    !配置接口0/1的网关和掩码
    no shutdown
    !开启端口0/1
    exit
    !返回到全局配置模式
    route rip
    !开启RIP路由协议进程
    network 30.0.0.0
    !添加下一跳网络
    network 40.0.0.0
    !添加下一跳网络
    exit
    !返回到全局配置模式
    6. 实验的验证方式
    (3)给出路由器R1、R2、R3的路由表屏幕截图
    路由器R1的路由表相关信息:
    在这里插入图片描述

    路由器R2的路由表相关信息:

    在这里插入图片描述
    路由器R3的路由表相关信息:
    在这里插入图片描述

    (4)给出从一个PC机PING另一个PC机的屏幕截图:
    在这里插入图片描述

    7.实验总结
    动态配置路由表,不用在路由器的RIP路由表中添加目的网络和子网掩码,相对于静态路由,设置更方便;
    在动态路由中,路由器能够自动地建立自己的路由表,并且能够根据实际情况的变化,适应网络结构的变化并进行调整,相对于静态路由,更灵活;
    8. 思考题
    请说明RIP和IGRP两个协议之间的差异。
    (1)RIP协议每隔30秒定期向外发送一次更新报文,如果路由器经过180秒没有收到来自某一路由器的路由更新报文,则将所有来自此路由器的路由信息标志为不可达。
    IGRP协议每90秒发送一次路由更新广播,在3个更新周期内(即270秒),没有从路由中的第一个路由器接收到更新,则宣布路由不可访问。
    (2)RIP协议收敛缓慢,时间经常大于5分钟;利用广播更新路由信息,消耗带宽很大。IGRP协议采用更精确,度量值更小(包括采用路径中的最低带宽)的路由为最佳路由,收敛速度更快;
    (3)IGRP允许多路径路由,相对于RIP协议,灵活性更强;
    (4)RIP协议跳数有限,最大跳数为15,16为不可达,只能应用于小规模网络。
    IGRP协议支持更复杂的网络,其最大跳数更长,相比于RIP协议,这对于大型网络是很有帮助的;

    展开全文
  • 这个 word文件是本人(计算机科学与技术专业)大三下学期的计算机网络课程设计的报告.
  • 计算机网络课程设计

    2018-07-15 15:29:50
    本科课程《计算机网络》,教学老师为陈喆老师,本资源包括课程的课程设计报告,仅供参考,请勿直接粘贴复制,亲自实践才能学到知识。
  • 宾县第一中学经过进一百年的发展与建设,已经成为哈尔滨市重点高中,在哈尔滨具有很高的影响力。现在校园占地面积104亩,建筑面积4000余平方米。拥有170名教职工,36个教学班,在校学生1600余人。...
  • 计算机网络课程设计某中级校园网的设计实现,华为ENSP模拟器实现组网测试,里面含有21页的课程设计说明书,实验组网总拓扑,并附有设备配置信息,已经保存到设备,可直接ENSP打开使用。适合新手入门,以及课程设计...
  • 关键词: 计算机网络;网络规划;网络设计 ;校园网 1 一. 前言 2 二. 学校描述 3 三. 需求分析 4 3.1 带宽 4 3.2 子网与VLAN规划 4 3.3 实现的信息服务 4 3.4 应用程序 5 3.5 存储系统分析 5 3.6 系统及数据安全...
  • 计算机网络谢希仁第七版 课后答案

    万次阅读 多人点赞 2019-09-03 23:13:25
    谢希仁计算机网络第七版课后答案 第一章 概述 1-01 计算机网络向用户可以提供那些服务?答: 连通性和共享 1-02 简述分组交换的要点。答:(1)报文分组,加首部(2)经路由器储存转发(3)在目的地合并 1-03 试从多...
  • 不多说上代码 感觉好的请给个赞吧!朕的小可爱 /** Email客户端的实现 */ #include<windows.h>...#include&
  • (一)计算机网络课程设计教学大纲

    千次阅读 2013-06-03 17:41:06
    计算机网络课程设计教学大纲 任务一: 了解常用的网络命令的工作原理,掌握常用网络原理的使用 20分 Ping(http://baike.baidu.com/view/709.htm) Tracert/traceroute...
  • 计算机网络课程设计》大作业说明 1. 目的:本大作业的目的是希望同学们学以致用,能够将课程上教授的理论内容在自己的工作生活实践中加以印证,理解计算机网络设计的基本内容即可。 2. 方法:同学们可以结合自己...
  • 上代码 运行完打开浏览器访问127.0.0.1:8000 #include <cstdio> #include <string> #include <fstream> #include &...
  • 1. 网络协议解析(基于文件) (1)使用报文分析工具软件,wireshark捕获报文并进行存储为.txt,获得报文数据文件。 (2)编程,在图形界面下,对报文的协议进行解码 (3)对ethernet_II、ip、tcp、udp协议进行解码 ...
  • 计算机网络课程设计》大作业说明 1.目的:本大作业的目的是希望同学们学以致用,能够将课程上教授的理论内容在自己的工作生活实践中加以印证,理解计算机网络设计的基本内容即可。 2.方法:同学们可以结合自己的...
  • 计算机网络知识点汇总(谢希仁 第七版)

    万次阅读 多人点赞 2018-09-18 17:34:34
    写在前面 这篇博客是当时在大二的时候为了学习计网总结的一篇学习笔记,其实当时的做法和抄书差不多,但是时隔两年的时间没想到有这么多的 同学会来关注学习,实在受宠若惊; 现在我已经大四,而且刚刚经历过秋招...
  • 一、课程设计内容 实施背景: 为某企业构建一个高性能、安全可靠的网络。 该企业主要包括三个建筑:行政楼、销售部、生产厂区。中心机房设在行政楼。 应当对外提供WWW服务、对内提供文件传输服务、内外均可访问的...
  • 计算机网络》复习笔记

    万次阅读 多人点赞 2018-01-05 21:20:48
    计算机网络》复习笔记 本复习笔记基于谢希仁的《计算机网络》第五版教材整理。 计算机网络复习笔记 绪论 1 计算机网络 2 因特网概述 3 互联网的组成 P8 4 计算机网络的类别 P17 5 计算机网络的体系结构 P25 ...
  • 在成千上万的计算机中,为什么一台计算机能够准确着寻找到另外一台计算机,并且把数据发送给它呢? 可能很多人都听说过网络通信的 5 层模型,但是可能并不是很清楚为什么需要五层模型,五层模型负责的任务也有可能...
  • 074《计算机网络课程设计》题目

    千次阅读 2009-06-25 11:22:00
    计算机网络课程设计》Course Design of Computer Network总学时数:2 周 题目一、网络应用服务建设(1)采用Dvbbs 或 Discuz!建设一个学生社区论坛要求:硬件环境:采用VMware 6虚拟机,网络采用Bridge...
  • 第一次课 Router> #用户模式 Router# #特权模式 lhx(config)# #全局配置模式 Router&...enable #进入特权模式 Router#configure terminal #进入全局配置模式,80%命令要先进入该模式 ...
  • 计算机网络试题库 1单项选择题 1.1以下属于物理层的设备是(A) A.中继器 B.以太网交换机 C.桥 D.网关 1.2在以太网中,是根据_(B)__地址来区分不同的设备的. A. LLC地址 B. MAC地址 C. IP地址D. IPX地址 1.3下面...
  • 计算机网络第七版答案

    万次阅读 多人点赞 2019-08-08 20:07:12
    计算机网络第七版答案 第一章 概述 1-01 计算机网络向用户可以提供那些服务?答: 连通性和共享 1-02 简述分组交换的要点。答:(1)报文分组,加首部(2)经路由器储存转发(3)在目的地合并 1-03 试从多个方面...
  • 计算机网络核心知识点总结&面试笔试要点

    万次阅读 多人点赞 2019-08-21 22:22:23
    计算机网络之基础篇 一、计算机网络概述  1.什么是计算机网络   计算机网络主要由一些通用的、可编程的硬件互连而成,通过这些硬件,可以传送不同类型的数据,并且可以支持广泛和日益增长的应用。  2.计算机网络...
  • 成 绩 评 定 表学生姓名 班级学号1503030126专 业电子信息工程课程设计题目小型互联网的设计与实现评 语 组长签字: 成绩 日期 201 年 月 日 课程设计任务书学 院信息科学与工程学院专 业电子信息工程学生...
  • 计算机网络工程课程设计

    千次阅读 2019-06-18 09:50:38
    2.分析设计该校,制订拓扑结构,提出校园设计规划方案。 3.依据规划,进行设备选型。 4.在模拟平台上进行校园网组建和测试工作 环境 系统:windows 10 软件:华为ENSP模拟器 实验组网总拓扑 技术运用:OSPF,...
  • 计算机网络

    千次阅读 2018-06-05 17:28:41
    1、计算机网络的功能 a、连通性:使得上网用户之间可以交换信息 b、共享:共享资源 2、因特网的概述 网络:由若干结点和连接着这些结点的链路组成,网络中的结点可以是计算机、集线器、路由器、交换机等,...
  • 计算机网络学习总结(超赞!!!)

    万次阅读 多人点赞 2018-02-23 21:28:35
    原文地址第一章 概述网络网络网络把主机连接起来,而互联网是把多种不同的网络连接起来,因此互联网是网络网络。ISP互联网服务提供商 ISP 可以从互联网管理机构获得许多 IP 地址,同时拥有通信线路以及路由器等...
  • 计算机网络面试问题集锦

    万次阅读 多人点赞 2018-03-26 17:16:40
    转载自点击打开链接1、Http和Https的区别 Http协议运行在TCP之上,明文传输,客户端与服务器端都无法验证对方的身份;Https是身披SSL(Secure Socket Layer)外壳的Http,运行于SSL上,SSL运行于TCP之上,是添加...资...

空空如也

1 2 3 4 5 ... 20
收藏数 915,077
精华内容 366,030
关键字:

计算机网络课程设计