2016-10-24 11:55:48 tao767992245 阅读数 789

Xcode升级到8.0版本后,默认只支持iOS8.0了,这时无法支持iOS8.0以下的版本了,同时项目编译时会出现一大堆的黄色警告,警告的内容是一些方法已经被弃用了,但是这些方法是可以正常使用的,只是说未来的某一天不能使用,但编译器不知道,如果项目紧急上线不想改,但又不想出现这些警告,那怎么办?烦人!其实在iOS7的时候不会出现这些警告,所以只要让我们的项目兼容到iO7、iOS6就可以了。

下载Xcode支持的平台版本,这是别人网盘分享出来的,非常感谢这位仁兄,里面包含iOS6.0及以上版本
地址: https://pan.baidu.com/s/1dFaAqzf
下载后的结果如下:
这里写图片描述

然后把自己需要支持的版本拷贝到Xcode的DeviceSupport目录
步骤:Finder->应用程序->Xcode->右击,显示包内容 就能看到Contents目录了,然后按照下面步骤逐步打开,就能看到想看的文件
“/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport”
这里写图片描述

修改SDKSettings.plist文件
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/SDKSettings.plist
DefaultProperties -> DEPLOYMENT_TARGET_SUGGESTE 该数组中添加 6.0 6.1 7.0 7.1
这里写图片描述
在这里要注意一下,你在添加的时候可能出现无法添加,没有权限等提示,不用担心,回到上面的Contents目录,右击显示简介,图片如下:这里写图片描述
点击左下角的+号,添加当前用户,权限改成读与写,接着点击左下角的齿轮按钮,选择:应用到包含的项目,OK,重启Xcode,这时你就发现你可以添加了,添加好了之后,重新启动Xcode,大功告成,现在就可以在”Deployment Target”中选择需要支持的最低平台了。
这里写图片描述

最后也要谢谢@skylin19840101,http://blog.csdn.net/skylin19840101/article/details/52840622,我也是从他这里学习的,然后把自己在操作过程中遇到的问题再完善了一下。

2019-08-20 11:08:35 qq_39174723 阅读数 526

目前Xcode不支持12.3.1,可以将12.2的硬件支持文件改下名字,用于连接Xcode调试。方法如下:

1、下载假的支持文件(12.3 (16F5117h).zip):https://github.com/XiaoHeHe1/iOS12.3-,解压;

2、打开路径: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport ,将上一步的解压包放入;

3、修改SDKSettings.plist文件中的版本号,打开路径:/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk,将SDKSettings.plist 文件复制到桌面,打开复制文件,将里面所有版本有关的数字都修改为12.3,再拖到原路径,替换掉原来的,SDKSettings.plist 文件------可能有人会问直接修改原文件不就行了吗,干嘛复制出来怎么麻烦?因为我在操作中遇到了权限问题无法修改,通过复制替换可以解决。

完成以上步骤,重新启动Xcode就可以了。

参考文章:https://blog.csdn.net/duotemplar/article/details/80355402

                  https://blog.csdn.net/qq_15509071/article/details/89084267

在此感谢参考文章作者!

2019-09-29 21:25:31 xiaolinlife 阅读数 185

最近在整理手机打包的问题,Android studio和Xcode都要先配置起来,中间遇到的问题很多,想着总结下来,防止自己后面再忘记。
首先,我配置好之后再给苹果手机打包的时候,报错了,报版本太高不支持ios13.1这个版本,所以需要下载一个xcode支持的ios13.1的支持包。开始我的探索之路,包下载下来之后放在哪里呢?上网查了一些资料,慢慢摸清了路径所在。
在这里插入图片描述
在这里插入图片描述
把下载的包放在DeviceSupport这个文件夹里面就好了,这就可以了,就可以支持ios13.1了。

2016-10-17 18:22:32 skylin19840101 阅读数 5158

Xcode8 默认只支持iOS8及以上的平台,如果想兼容iOS7以及更低的版本,应该怎么办呢?

下载Xcode支持的平台版本

地址:https://pan.baidu.com/s/1dFaAqzf
下载后的结果如下:




拷贝版本到Xcode的DeviceSupport目录

将自己需要支持的版本拷贝到DeviceSupport目录

“/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport”



修改SDKSettings.plist文件

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/SDKSettings.plist  
DefaultProperties -> DEPLOYMENT_TARGET_SUGGESTE 该数组中添加 6.0 6.1 7.0 7.1


如果遇到权限问题,参考下面的地址

http://blog.csdn.net/lizitao/article/details/39475103


大功告成,现在就可以在"Deployment Target"中选择需要支持的最低平台了


2018-06-21 10:26:29 PianZhideNanRen 阅读数 396

使用方法需要哪一个iPhone系统的支持包,下载解压,放进去就可以了,然后插入你的手机,等Xcode解析好你的手机文件就可以真机运行了。

支持包放置位置:点击应用程序-》选择Xcode-》Contents-》Developer-》Platforms-》iPhoneOS.platform-》DeviceSupport


原作者连接: https://www.jianshu.com/p/1a33e36c4b67

没有更多推荐了,返回首页