导入android项目之后报错_android studio 导入项目 报错 - CSDN
  • Eclipse导入android项目出现很多错误 【问题描述】  使用Eclipse导入别人正确的android项目,会出现很多未知的错误错误。如下面的AndroidTest项目,在别人的Eclipse上是完全正常,而当导入到其他版本的Eclipse就会...

    Eclipse导入android项目出现很多错误

    【问题描述】
          使用Eclipse导入别人正确的android项目,会出现很多未知的错误。如下面的AndroidTest项目,在别人的Eclipse上是完全正常,而当导入到其他版本的Eclipse就会出现错误The import android.support.v7 cannot be resolved错误,ActionBarActivity cannot be resolved to a type错误,error: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light'等错误。
           这主要是版本配置的问题。主要原因是未导入该Android项目依赖的支持库文件:appcompat_v7

    【appcompat_v7】
          appcompat_v7是Google自己的一个兼容包,就是一个支持库,能让2.1以上全使用上4.0版本的界面。一般在创建新项目时,会自动导入。如果想要不要它,可在新建项目时直接把最小SDK(Minimum Required SDK)选在Android4.0以上即可。

          
          由于导入别人Android项目的最小SDK小于4.0,而本地导入项目时,并未把appcompat_v7导入,因此会出现错误。解决办法多种
    【解决方法1】在本地Eclipse,新建一个Android项目,最小SDK版本(Minimum Required SDK)小于4.0即可。这时新建完成后,会自动生成一个appcompat_v7文件,这时Project-->clean一下就没有错误啦。



    【解决方法2】导入appcompat_v7文件即可:下载地址http://download.csdn.net/detail/guyuealian/9548401 
    然后点击:File-->Import导入后,再Clean即可~!


    转载请注明出处】http://blog.csdn.net/guyuealian/article/details/51659793
    展开全文
  • 前段时间学习android程序开发,在用eclipse导入他人的Android项目,出现了许多报错,我针对报错内容逐一查找解决。...eclipse导入Android项目报错 android library projects cann’t be launched https://blog.c...

    前段时间学习android程序开发,在用eclipse导入他人的Android项目,出现了许多报错,我针对报错内容逐一查找解决。以下是我在调试项目过程中解决各种报错的参考链接。我将他们集合在一起,希望对初次学习Android的你有所帮助。

    展开全文
  • android 导入项目报错

    2012-08-25 11:29:42
    android 导入项目报错 1、打项目的properties -->android 为其指一个运版本, 2、修改default properties 文件 ,改相应版本等级 3、选中项目,单击右键,选中properties ,打开android 选中相应 sdk 4、project...

    android 导入项目报错  

    1、打项目的properties -->android 为其指一个运版本,

    2、修改default properties 文件 ,改相应版本等级

    3、选中项目,单击右键,选中properties ,打开android 选中相应 sdk

    4、project -->clean.      KO

    (blue moon 需指定 sdk 为Googles APIs )



    Eclipse启动时在Android SDK Content Loader卡住 

    右击android工程——》Java Build Path——》Order and Export
    选中Android X.X,并且将其移到第一个。

    展开全文
  • 日常工作中,难免要导入别人的项目,进行参考(阅读学习)、研究(黏贴复制)。但导入过程往往异常曲折,经常各种报错。**我们可以通过以下步骤,尽量减少报错的出现。**(以下步骤,需要本机gradle版本 >= ...
     日常工作中,难免要导入别人的项目,进行参考(阅读学习)、研究(黏贴复制)。但导入过程往往异常曲折,经常各种报错。**我们可以通过以下步骤,尽量减少报错的出现。**(以下步骤,需要本机gradle版本   >=   要比导入项目gradle)
    

    步骤1、
    修改build.gradle 文件中, classpath的gradle版本与自身电脑中,AndroidStudio创建的新项目gradle的版本相同。

    在这里插入图片描述
    步骤2、
    将自身电脑中,AndroidStudio创建新项目的gradle文件夹,替换要导入项目的gradle文件夹。
    在这里插入图片描述
    步骤3、
    及时调整网络状态,科学上网。
    项目导入时,AndroidStudio会检测要导入项目中需求的库文件,本机是否存在。不存在,则联网下载。这个下载过程,取决于网速。
    在这里插入图片描述

    展开全文
  • 前言  欢迎大家我分享和推荐好用的代码段~~ 声明  欢迎转载,但请保留文章原始出处:  CSDN:http://www.csdn.net  雨季o莫忧离:... 正文   ...重装操作系统后,要重新配置Android开发环境。配置成功后,添加
  • Android studio(简称as),谷歌的亲儿子,基本是目前编写Android软件的最好的开发工具,之前用习惯了eclipse,刚开始使用as怎么都不习惯,但是,能坚持使用as一个月,你会发现,eclipse真不好用,as各种爽。...
  • Android使用eclipse导入项目的时候报错解决方法 1、sdk的路径配置有问题,这时候无法找到adt工具;遇到这个问题,菜单preference->android修改SDK的路劲。 2、可能是和以前的SDK版本兼容的问题(以前的SDK可能...
  • ![图片说明](https://img-ask.csdn.net/upload/201610/31/1477879859_733440.png)
  • eclipse导入android开源项目报错Migrate Android Code今天用eclipse导入github开源的项目Android-ViewPagerIndicator,导入之后BaseSampleActivity报错Migrate Android Code 如图: 经过查询是switch case问题,把...
  • eclipse导入安卓项目报错找不到 原因 本地的sdk版本不够 解决 先查看需要的sdk是多少 打开这两个文件 project.properties里是原项目需要的sdk版本 AndroidManifest.xml里是你给项目分的最大最小...
  • 原因 :当前项目是使用Android Studio3.0+以上版本构建的,而idea中对android项目的构建没有使用最新的model。 解决方法:在项目gradle.properties中添加以下一行:指定构建是使用的model android.injected.build....
  • 第一种报错: 原文链接:https://blog.csdn.net/liangfeng093/article/details/72673241 问题在于当前电脑的sdk版本跟你的项目所需的sdk版本不匹配。看看project.properties中的target,它指定的是哪个版本的sdk。...
  • 在使用android studio导入外部项目时经常提示一些错误,现记录于下,并附上自己使用过程中的解决方法!
  • 之前一直用的eclipse开发,最近项目不忙用了下... 进入正题,网上下的项目导入android studio中,往往会因为sdk和gradle版本的问题报错,网上也提供了一些解决方法,如更新gradle版本等,其实不用那么麻烦,可以用自
  • 在安卓studio中导入flutter项目报错导入项目报错,flutter的导入包提示target of uri doesnt exist import ‘package:flutter/material.dart’; 报红线 main.dart文件一片红 解决办法:选择 Tools目录下的–》 ...
  • 在用Android Studio开发项目...当第一次创建Android Studio项目的时候如果发生创建项目报错,如图: 解决方法: 方法一:Android Studio联网下载解决 第一步:找到该项目中gradle包中的如图中的文件并打开编辑界面.
  • copy时不论是新建还是导入这个包,项目都会报错。 网上的方法试了各种clean各种fix等等。 今天研究了下报错的布局文件。个人建议。不喜勿喷 ps:我把布局换成了android自带的。对于appcompat_v7兼容的,实在是无力...
  • 在使用第三方平台的Demo时经常会在导入项目后发生gradle报错或者Android Studio会自己连接goole去下载demo配置中的gradle版本,通常应为连接下载失败会报错,在这里记录一下具体的解决方案。  1、创建一个新的工程...
  • 关于Android项目没有报错但是出现红叉的解决方法总结
  • 向Eclipse 里导入Android项目报错:Unable to resolve target 'android-17'。 解决方案:修改项目中project.properties:target=android-19
1 2 3 4 5 ... 20
收藏数 25,678
精华内容 10,271
关键字:

导入android项目之后报错