配置_配置文件 - CSDN
  • 神经网络学习小记录42——windows下的tensorflow-gpu=1.13.2环境配置学习前言环境内容Anaconda安装下载Cudnn和CUDA配置tensorflow环境安装VSCODE 学习前言 好多人问环境怎么配置,还是出个教程吧。 环境内容 ...

    神经网络学习小记录42——windows下的tensorflow-gpu=1.13.2环境配置

    学习前言

    好多人问环境怎么配置,还是出个教程吧。
    在这里插入图片描述

    环境内容

    tensorflow-gpu:1.13.2
    keras:2.1.5
    numpy:1.17.4

    Anaconda安装

    最新版本的Anaconda没有VSCODE,如果大家为了安装VSCODE方便可以直接安装旧版的Anaconda,百度网盘连接如下。也可以装新版然后分开装VSCODE。
    链接: https://pan.baidu.com/s/12tW0Oad_Tqn7jNs8RNkvFA
    提取码: i83n

    取网上搜索Anaconda的官网:https://www.anaconda.com/distribution/
    在这里插入图片描述
    下载左边的python3.7版本,64位的,下载完成后打开:
    在这里插入图片描述
    选择安装的位置,可以不安装在C盘。
    在这里插入图片描述
    我选择了Add Anaconda to my PATH environment variable,我用起来觉得更好用。
    在这里插入图片描述
    等待安装完之后,就安装了Anaconda了。

    下载Cudnn和CUDA

    我这里使用的是tensorflow-gpu=1.13.2,因此会用到cuda10.0,与cuda10.0对应的cudnn是7.4.1.5,这个组合我实验过了,绝对是可以用的。

    cuda10.0官网的地址是:
    cuda10.0官网地址
    cudnn官网的地址是:需要大家进去后寻找7.4.1.5。
    cudnn官网地址

    官网下载是比较慢的,可以在百度云上下载,我给大家分享一手。

    链接: https://pan.baidu.com/s/1znYSRDtLNFLufAuItOeoyQ
    提取码: 8ggr

    下载完之后得到这两个文件。

    在这里插入图片描述
    在这里插入图片描述
    下载好之后可以打开cuda_10的exe文件进行安装。
    在这里插入图片描述
    这里选择自定义。
    不
    然后直接点下一步就行了。
    在这里插入图片描述
    安装完后在C盘这个位置可以找到根目录。
    C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0
    然后大家把Cudnn的内容进行解压。
    在这里插入图片描述
    把这里面的内容直接复制到C盘的根目录下就可以了。
    在这里插入图片描述

    配置tensorflow环境

    Win+R启动cmd,在命令提示符内输入以下命令:

    conda create –n tensorflow-gpu python=3.6
    
    activate tensorflow-gpu 
    
    pip install tensorflow-gpu==1.13.2
    
    pip install keras==2.1.5
    

    需要注意的是,如果在pip中下载安装比较慢可以换个源,可以到用户文件夹下,创建一个pip文件夹,然后在pip文件夹里创建一个txt文件。
    在这里插入图片描述
    修改txt文件的内容,并且把后缀改成ini

    [global]
    index-url = http://pypi.mirrors.ustc.edu.cn/simple
    [install]
    use-mirrors =true
    mirrors =http://pypi.mirrors.ustc.edu.cn/simple/
    trusted-host =pypi.mirrors.ustc.edu.cn
    

    在这里插入图片描述
    在这里插入图片描述
    全部安装完成之后重启电脑。

    安装VSCODE

    我个人喜欢VSCODE……所以就安装它啦。
    打开anaconda,切换环境。
    在这里插入图片描述
    安装VSCODE,安装完就可以launch一下了,之后就可以把VScode固定到任务栏上,方便打开。
    在这里插入图片描述
    最新版本的Anaconda没有VSCODE因此可以直接百度VSCODE进行安装。

    安装完成后在左下角更改自己的环境就行了。
    在这里插入图片描述

    展开全文
  • 二、环境变量配置  1、右键桌面上“我的电脑”>>“属性”,在弹出的页面上点击“高级系统设置”。 2、在弹出的“系统属性”窗口中“高级”标签页下点击“环境变量”按钮。 3、在弹出的“环境变量”...

    一、环境准备

      Windows10

      jdk-9.0.1

    二、下载并安装JDK

    选择一个适合自己的JDK版本下载并安装即可,具体流程不详述。

    二、环境变量配置

       1、右键桌面上“我的电脑”>>“属性”,在弹出的页面上点击“高级系统设置”。

     

    2、在弹出的“系统属性”窗口中“高级”标签页下点击“环境变量”按钮。

    3、在弹出的“环境变量”窗口中,点击下方的“新建”按钮,在弹出的“新建系统变量”窗口中,新建一个名为“JAVA_HOME”的环境变量,变量值为Java的安装路径,本人为:D:\project\tool\Java\jdk_9.0.1。如图所示。

     4、设置Path环境变量,该变量已经存在,所以在列表中选择Path,点击下方的“编辑”按钮,在弹出的窗口中添加如下信息:%JAVA_HOME%\bin;%JAVA_HOME%\jre\bin,然后点击“确认”按钮即可。如图所示:

     

     5、和JAVA_HOME一样,新建一个名为“classpath”的环境变量,变量值为:%JAVA_HOME%\lib\dt.jar;%JAVA_HOME%\lib\tools.jar。如图所示:

      6、在配置好环境变量后,可以进入cmd中检查Java是否安装正确,检查的命令为 java -version,如图所示:

    如果能正确的输出Java的版本和JVM版本信息,则说明Java安装正确。

    根据本人多年从业以及学习经验,录制了一套最新的Java精讲视频教程,如果你现在也在学习Java,在入门学习Java的过程当中缺乏系统的学习教程,你可以加QQ群654631948领取下学习资料,面试题,开发工具等,群里有资深java老师做答疑,每天也会有基础部分及架构的直播课,也可以加我的微信renlliang2013做深入沟通,只要是真心想学习Java的人都欢迎。

    java基础教程:https://ke.qq.com/course/149432?tuin=57912c43


    Java分布式互联网架构/微服务/高性能/springboot/springcloud:

    https://ke.qq.com/course/179440?tuin=57912c43

    文章转自:https://www.cnblogs.com/boringwind/p/8001300.html

    展开全文
  • k8s部署配置中心

    2020-05-22 14:38:58
    本文假设您已经完成了 在Kubernetes上部署配置中心教程的前序步骤 配置中心项目搭建 构建docker镜像并推送到仓库 kuboard注册中心集群部署 部署配置中心 在 Kuboard 界面中进入 ocp 名称空间,并点击页头的按钮 ...

    本文假设您已经完成了 在Kubernetes上部署配置中心教程的前序步骤

    部署配置中心

    在 Kuboard 界面中进入 test 名称空间,并点击页头的按钮 创建工作负载,如下图所示:

    填写表单:

    字段名称 填写内容 备注
    服务类型 StatefulSet
    服务分层 中间件
    服务名称 config
    服务描述 配置中心
    副本数量 3
    容器名称 config-server
    镜像 harbor.hld.com/test/config:latest harbor镜像仓库镜像地址
    抓取策略 Always
    环境变量 eureka.client.service-url.defaultZone=http://cloud-eureka-0.cloud-eureka.test.svc.cluster.local:1111/eureka,http://cloud-eureka-1.cloud-eureka.test.svc.cluster.local:1111/eureka,http://cloud-eureka-2.cloud-eureka.test.svc.cluster.local:1111/eureka 填入 kuboard 时环境变量名后面不带 =
    Service NodePort:协议 TCP 服务端口 8991节点端口 31991 容器端口 8991 可从节点端口访问
    Ingress 域名:xxxxx 路由配置: 映射URL / 服务端口 8991 可通过域名访问

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    • 保存、应用。然后等待完成

    验证

    eureka-server 界面如下图所示:
    在这里插入图片描述

    展开全文
  • VLAN的基本配置

    2018-12-23 16:59:01
    (2)掌握vlan的配置方法、VLAN划分和Trunk链路的配置; (3)理解通过三层交换机实现VLAN间通信的工作原理,理解通过单臂路由方式实现VLAN间通信的工作原理,理解路由在不同网络间通信的作用。 ...

    实验目的:

    (1)了解vlan的用途、工作原理和几种实现技术;

    (2)掌握vlan的配置方法、VLAN划分和Trunk链路的配置;

    (3)理解通过三层交换机实现VLAN间通信的工作原理,理解通过单臂路由方式实现VLAN间通信的工作原理,理解路由在不同网络间通信的作用。

     

    实验要求:

    (1)交换机上连接两台主机,测试主机联通性;

    (2)在交换机上分别创建两个vlan,并为它们分配相应的端口,测试vlan内连通性和vlan间连通性;

    (3)利用交换机的三层功能,实现VLAN间的路由,用ping测试其连通性;

    (4)使用路由器的快速以太网接口以及802.1Q封装实现vlan间通信。

     

    要求:画出拓扑图,写出路由器、交换机的配置命令,写出为PC机设置的IP地址及测试情况。

    一.了解VLAN

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。Vlan的实现技术主要又一下四种:基于端口划分的vlan,基于mac地址划分valn,基于网络层划分vlan,根据ip组播划分vlan。

     

    二.网络拓扑图

       1.VLAN的配置

      

       2.两个VLAN间通信

         1.三层交换机

      

    2.路由器

     

    三.配置命令

      ①VLAN建立:全局模式下   vlan  + 1-1005

      ②改变接口模式:接口模式下  switchport mode + 模式

      ③将端口加入到VLAN:接口模式下  switchport access + VLAN  

      ④将端口改变为Trunk模式:接口模式下   switchport mode + trunk

      ⑤为接口封装802.1:接口模式下  switchport trunk encapsulation dot1q

      ⑥启用路由功能:全局模式下  ip routing

      ⑦为配置ip地址:接口模式下  ip address + ip地址 + 子网掩码

      ⑧开启端口:接口模式下  no shutdown

      ⑨虚拟端口:全局模式下 interface fastEthernet 0/0._ _为VLAN号

      ⑩封装802.1:Router(config-subif)#  encapsulation dot1Q +VLAN号

     

    四.准备和测试

       1.设置ip地址,子网掩码,网关

         

       2.ping命令

       

     

     

     

     

    实验过程描述

    • VLAN的配置
    1. 设置(四台pc机按上述拓扑配置)

    2.配置(两台交换机配置均相同)

    ①创建VLAN 10:

    Switch(config)#vlan 10

    Switch(config-vlan)#name MGY_10

    ②创建VLAN 20:  

    Switch(config)#vlan 20

    Switch(config-vlan)#name MGY_20

    ③将 fa 0/1 加入VLAN 10:

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 10

    ④将 fa 0/2 加入VLAN20:

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 20

    ⑤将 fa 0/3设置成trunk模式 :

    Switch(config)#interface  fastEthernet 0/3

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#exit

    ⑥结果

    3.测试

    • VLAN间的通信

    三层交换机:

    1. 设置(四台交换机按上述拓扑配置)

    1. 配置(两台二层交换机配置相同)

    ①配置Switch2

    1.创建VLAN10:

    Switch(config)#vlan 10

    Switch(config-vlan)#name MGY_10

    2.创建VLAN20:

    Switch(config)#vlan 20

    Switch(config-vlan)#name MGY_20

    3.将fa 0/3设置成trunk:

    Switch(config)#interface  fastEthernet 0/3

    Switch(config-if)#switchport mode trunk

    4.将fa 0/1 加入VLAN10

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 10

    5.将fa 0/2 加入VLAN20

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 20

          6.结果

          

    ②配置Switch3

      配置步骤同上配置Switch2。

    ③配置Multilayer Switch2

      1.创建VLAN10

    Switch(config)#vlan 10

    Switch(config-vlan)#name MGY_10

      2.创建VLAN20

    Switch(config)#vlan 20

    Switch(config-vlan)#name MGY_20

      3.将 fa0/1 fa0/2改成trunk模式

        Switch(config)#int fa 0/1

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode Trunk

    Switch(config-if)#exit

    Switch(config)#int fa 0/2

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode Trunk

      4.开启路由模式

    Switch(config)#ip routing

      5.创建VLAN接口VLAN10,配置IP地址并开启端口

        Switch(config)#interface vlan 10

    Switch(config-if)#ip address 192.168.2.1 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

      6.创建VLAN接口VLAN20,配置IP地址并开启端口

        Switch(config)#interface vlan 20

    Switch(config-if)#ip address 192.168.3.1 255.255.255.0

    Switch(config-if)#no shutdown  

           7.结果

           

       3. 测试

    路由器:

    1.设置(四台交换机按上述拓扑配置)

    2.配置(两台二层交换机)

    ①配置Switch2

    1.创建VLAN10:

    Switch(config)#vlan 10

    Switch(config-vlan)#name MGY_10

    2.创建VLAN20:

    Switch(config)#vlan 20

    Switch(config-vlan)#name MGY_20

    3.将fa 0/3设置成trunk:

    Switch(config)#interface  fastEthernet 0/3

    Switch(config-if)#switchport mode trunk

    4.将fa 0/1 加入VLAN10

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 10

    5.将fa 0/2 加入VLAN20

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 20

              6.结果

               

    ②配置Switch3

    1.创建VLAN10:

    Switch(config)#vlan 10

    Switch(config-vlan)#name MGY_10

    2.创建VLAN20:

    Switch(config)#vlan 20

    Switch(config-vlan)#name MGY_20

    3.将fa 0/3设置成trunk:

    Switch(config)#interface  fastEthernet 0/3

    Switch(config-if)#switchport mode trunk

    4.将fa 0/1 加入VLAN10

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 10

    5.将fa 0/2 加入VLAN20

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#sw access vlan 20

              6.fa 0/4设置成trunk模式

    Switch(config)#interface  fastEthernet 0/4

    Switch(config-if)#switchport mode trunk

              7.结果

               

    ③配置路由器

    1.开启接口f0/0

    Router(config)#interface f0/0

    Router(config-if)#no shutdown

    2.进入子接口f0/0.10和f0/0.20并配置IP地址

    Router(config)#interface f0/0.10

    Router(config-subif)#encapsulation dot1Q 10

    Router(config-subif)#ip address 192.168.2.1 255.255.255.0

    Router(config-subif)#no shutdown

    Router(config-subif)#exit

    Router(config)#interface f0/0.20

    Router(config-subif)#encapsulation dot1Q 20

    Router(config-subif)#ip address 192.168.3.1 255.255.255.0

    Router(config-subif)#no shutdown

         结果

         

       3. 测试

    三.流量分析

    1.ping 命令开始生成一个报文。

    2.报文到达交换机,由于跨网络通信交换机将报文转发给路由器。

    3.通过路由器,转发进另一个网段。此处路由器相当于网关,连接两个网络。

    4.报文通过交换机发送到目的主机。

    5.目的主机以同样的方法返回相应报文。

    回答问题

    1.说明划分虚拟局域网的意义。

    通过分割,在较大的LAN中创建不同的VLAN,可以抵御广播风暴的影响,同时可以多设置防火墙来大大提高网络的安全性。另外一个是有助于提高工作效率和接入速度。

    2.交换机在配置VLAN前后,冲突域和广播域各有什么不同?

    交换机是一种二层设备,所有的接口组成一个广播域。但是在VLAN配置后,每一个VLAN组成一个广播域。即VLAN是划分广播域的一种技术。

    交换机的每一个接口都是一个独立冲突域,划分后不改变冲突域。

    3. 实现vlan间通信有哪些方法?

    ①通过路由器的不同物理接口与交换机上的每个VLAN分别连接:

    ②通过路由器的逻辑子接口与交换机的各个VLAN连接:

    ③用三层交换机代替路由器实现VLAN间的通信:

        启用交换机的路由功能或者利用某些高端的交换机所支持的专用VLAN功能来实现CLAN间的通信。

    展开全文
  • IDEA 完整web项目配置

    2019-01-25 15:24:31
    一直用eclipse,最近自己配置了idea的,总结一下idea刚入手一个完整项目的配置过程。该处使用idea2018.3.3版本为例,大多数版本配置相似。 若刚安装idea,请从第2步开始,若项目已经下载完成,请从第4步开始 1、...

    一直用eclipse,最近自己配置了idea的,总结一下idea刚入手一个完整项目的配置过程。该处使用idea2018.3.3版本为例,大多数版本配置相似。

    若刚安装idea,请从第2步开始,若项目已经下载完成,请从第4步开始

    1、安装好idea,准备一个tomcat 安装包

    2、进行svn设置(以客户端svn为例,其余git等自行百度)

     File->Setting->Version Control->Subversion:填写svn地址,svn.exe.地址可在客户端svn安装后查看文件位置寻找路径

    3、下载项目,以svn为例。

    菜单栏VCS->Checkout from version control->Subversion

    新增一个svn地址,选择该地址,checkout

    选择一个下载目录,此处建议新建一个idea专用目录

    此处选择第二个选项,F:\ideaspaces\项目名,点击ok

    自动默认的即可,点击ok,等待项目下载完成

    项目下载完成后,会弹窗是否新建project选项框,选择否。

    4、引入项目,配置web项目

    File->open->找到下载svn项目,并且在this window打开

    选中项目,按F4 或者File->Project Structure

    4.1配置project,特别注意language level,编译不通过很多情况是level跟jdk不对应

    4.2配置Modules

    点击上方的+号,新建一个web,并将右边二处配置修改为项目实际路径。

    Deployment Descriptiors为项目web.xml实际路径

    Web Resource Directions为项目实际根目录,例如WebContent等

    选中项目,配置sources,选择项目的sources文件夹,即常见的src目录

    Sources:源代码的位置,java类等

    Tests:测试类(可选)

    Resources:源代码位置,配置文件,例如log4j、数据库配置properity等(可选)

    Test Resources:测试类的配置(可选)

    Excluded:排除编译的文件(可选)

    配置path路径,选择Use module compile output path,下面选择项目编译路径与测试类编译路径,一般为WEB-INF下的classes路径,根据项目自行选择

    配置Dependencies,为项目依赖的jar包,首先选择jars or directions选择项目中的jar路径。如果是需要tomcat启动的web项目,添加入library中的tomcat jar包(第5步查看完整tomcat配置),或者其他自己需要依赖的jar,并且去除列表中红色的项(无效jar包)

     

    4.3配置facets,点击上方+号。选择web,选择刚才配置的Modules即可

    4.4配置Artifacets,点击+号。选择Web Application Exploded->From Module,选择之前配置的Module。

     

    到达此处,项目配置完成

    5、配置tomcat(配置Modules中Denpendices可在完成该步后添加tomcat中jar)

    点击菜单栏Run->run Configurations,点击+号,选择Tomcat Server Local

    点击Configure,弹出Application Servers,点击+号。新增一个tomcat,并且选中tomcat目录

     

    6、部署tomcat并且启动

    刚才的run Configurations中,选择刚才添加的tomcat。并且完成基本配置(根据选择自行勾选)

    选择Deployment,添加第4步配置好的artificets。

    可在最下方中Application Servers中启动tomcat

     

    一个完整的web项目在idea中的配置启动完成。

    由于我的项目很多,常需要启动不同项目混合,所以我没有使用tomcat的Deployment功能,我通过修改配置文件启动。若有需要,可点击我主页查看具体方法https://blog.csdn.net/u010970951/article/details/86646653

    展开全文
  • 先秀一下我的Vim界面 语法补全我用的是YouCompleteMe, 有目录树插件,taglist插件等。 通过插件管理器Vundle来进行安装,具体方法自行百度。...背景可以通过换张自己喜爱的壁纸,然后调终端的透明度,就可以对着...
  • nginx配置https服务

    2019-06-22 14:27:14
    nginx配置https服务
  • Eclipse如何配置JDK

    2019-08-01 10:03:59
    第一步、首先需要大家安装好最新版的eclipse和jdk10,双击打开桌面eclipse图标。然后弹出窗口要我们选择工作空间路径,建议最好新建一个目录。 ...第一次打开会有些许慢,需要加载的东西多些。...
  • Maven配置教程

    2018-12-29 17:00:24
    Maven配置 Maven项目对象模型(POM),可以通过一小段描述信息来管理项目的构建,报告和文档的软件项目管理工具。 Maven 的配置却让一些初学者望而却步,这里我就把Maven的详细配置过程写下,希望能对你有所帮助...
  • 对于一般使用 STL 的用户而言,Allocator 是不可见的,如果需要对 STL 进行扩展,如编写自定义的容器,就需要调用 Allocator 的内存分配函数进行空间配置。 在C++中,一个对象的内存配置和释放一般都包含两个步骤,...
  • 现在是2019.7.21,由于这阵一直在忙,今天我用最新的VSCode(Version 1.36.1) 和最新的Cpp插件(version 0.24.0)按照本文的...)标示出来,供大家参考进行配置。也可以参考官方文档:https://code.visualstudio.c...
  • 人工智能,零基础入门!...这个是tomcat用的最多的地方,分享一下,但是其实Tomcat还可以作为其他来用,这里要讲的就是用tomcat来配置本地的文件服务器。下面是步骤: 二、配置步骤 【1】下载一个to...
  • 首先会去读取web.xml配置文件里的配置,当这一步骤没有出错并且完成之后,项目才能正常的被启动起来。  启动WEB项目的时候,容器首先会去读取web.xml配置文件中的两个节点: 和 如图:    紧接着,容器...
  • zookeeper 分布式配置中心
  • 使用jpa操作数据库,最终实现根据不同 的配置文件读取不同的数据源(数据库,缓存以及其他配置信息) 本文主要介绍的是多环境配置与部署,所以关于其他配置就简略的叙述 多环境配置配置application.properties(公共...
  • intellij IDEA配置tomcat

    2019-09-12 10:11:09
    intellij IDEA配置tomcat 如果网上流传的方法(即方法2)不能配置成功,点击加号什么都没有的话,请看方法一配置方法。 解决问题:intlellij IDEA配置tomcat点击加号没东西。 方法一:手动添加tomcat插件然后再...
  • 1、相信很多童鞋在换工作或者因为开辟新项目的工作空间的原因,有时就是要新建一个workspace,但是新建工作空间所有的配置都会是默认的,跟我们之前的习惯不一样,在这里总结一下需要配置的地方: (1)、编码格式...
  • 之前编写Python更多的是使用pycharm作为编译器进行开发,...在这里对vscode配置Python开发环境做一下记录。 步骤1:安装Python 安装Python的教程网上有很多。直接到官网下载安装就行。 下载链接:https://www.p...
  • 1. Git安装与配置

    2017-01-15 18:05:09
    本文介绍Windows下的Git安装与配置
  • phpwamp配置应该如何修改,Web服务器、php、mysql的具体的配置在哪里修改
1 2 3 4 5 ... 20
收藏数 6,539,974
精华内容 2,615,989
关键字:

配置