• 思科cisco路由器动态路由协议配置方法 配置IGRP动态路由协议 IGRP是

    思科cisco路由器动态路由协议配置方法

    •  配置IGRP动态路由协议

          IGRP是EIGRP协议的前身,虽然现在基本被EIGRP协议所取代,但在一些特殊场合我们仍然会用到该动态路由协议。他的使用配置和EIGRP协议很相似。我们简单介绍一下。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置IGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置IGRP动态协议。

        配置命令:

        ROUTER-A:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。


        network 10.0.0.0    宣告IGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。(如图3)

        小提示:IGRP会自动在边界上归纳路由信息为主类IP地址而且自动归纳无法取消。

        ROUTER-B:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告IGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为IGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置EIGRP动态路由协议

          EIGRP是结合了链路状态型和距离矢量型路由选择协议优点的CISCO专用协议。该混合协议具有快速收敛,减少带宽占用,支持多种网络层协议的特点。不过由于他是CISCO专用协议,所以其他厂商的路由器不支持该协议,他只应用于整个网络都是CISCO公司的路由器的情况。总的来说他是一种高级的距离矢量型路由选择协议,是从IGRP协议发展而来的。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置EIGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置EIGRP动态协议。


        配置命令:

        ROUTER-A

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。

        network 10.0.0.0    宣告EIGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。

        小提示:EIGRP会自动在边界上归纳路由信息为主类IP地址,如果要想取消自动归纳则需要使用no auto-summary命令。

        ROUTER-B

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告EIGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为EIGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置OSPF动态路由协议

          OSPF协议也叫开放最短路径优先协议,他是一项链路状态型技术,与路由选择信息协议(RIP)这样的距离矢量型技术相对,OSPF协议完成各路由选择协议算法的两大主要功能是路径选择和路径交换。目前最新版本是OSPF版本2。OSPF是一种内部网关协议(IGP),也就是说他在属于同一自治系统的路由器间发布路由选择信息。

        目前OSPF是应用最广泛的动态路由协议,他不是CISCO专有的路由协议,可以互连CISCO,华为和实达等多个公司的路由器,兼容性非常不错。因此适合于中小企业路由的互连。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置OSPF协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置OSPF动态协议。


        配置方法

        ROUTER-A

        router ospf 1    启动OSPF进程,进程号为1,值得注意的是进程号本地路由器有效。

        network 10.1.1.0 0.255.255.255 area 0    设置OSPF通告的网络范围,将对10.1.1.0/24这个网段通告。后头的0.255.255.255指的是反向掩码,他代表通告的网段的子网掩码是255.255.255.0。

        小提示:第二句也可以使用network 10.1.1.1 0.0.0.0 area 0代替,这样OSPF将宣告接口10.1.1.1连接的网络。


        ROUTER-B

        router ospf 1    启动OSPF进程,进程号为1。

        network 30.1.1.1 0.255.255.255 area 0    宣告30.1.1.0/24这个网段。

        小提示:第二句也可以使用network 30.1.1.1 0.0.0.0 area 0这个命令来宣告ROUTER-B上30.1.1.1这个接口连接的网段。

     
    展开全文
  • 动态路由配置

    2019-04-04 14:05:13
    2. 对路由器配置动态路由实现不同网段之间的通信,网络拓扑结构如下: 3. 按要求搭建上面的网络拓扑结构 使用鼠标拖动将所需要的结构放入到空白处 4. 配置好各台pc机的ip地址以及网关地址(ip地址以及各网关...

    1. 需要的环境PacketTracer6(思科)

    2. 对路由器配置动态路由实现不同网段之间的通信,网络拓扑结构如下:

    3. 按要求搭建上面的网络拓扑结构

    使用鼠标拖动将所需要的结构放入到空白处

    4. 配置好各台pc机的ip地址以及网关地址(ip地址以及各网关地址注明在上面)

    ip地址:

    网关:

    其他PC机的配置一样

    5. 对路由器连接的各个端口进行配置,命令如下:

    左边路由器:
    enable 15
    configure terminal
    interface fastethernet 0/0(查看端口号使用鼠标移入有连接的颜色的节点)
    ip address 222.1.3.2 255.255.255.0
    no shutdown 
    exit

    interface serial 3/0
    ip address 222.1.5.2 255.255.255.0
    no shutdown 
    exit

    interface serial 2/0
    ip address 222.1.4.2 255.255.255.0
    no shutdown 
    exit

    右边路由器:
    enable 15
    configure terminal
    interface fastethernet 0/0
    ip address 222.1.2.5 255.255.255.0
    no shutdown 
    exit

    interface serial 3/0
    ip address 222.1.6.2 255.255.255.0
    no shutdown 
    exit

    interface serial 2/0
    ip address 222.1.4.1 255.255.255.0
    no shutdown 
    exit

    上边的路由器:
    enable 15
    configure terminal
    interface fastethernet 0/0
    ip address 222.1.1.4 255.255.255.0
    no shutdown 
    exit

    interface serial 3/0
    ip address 222.1.6.1 255.255.255.0
    no shutdown 
    exit

    interface serial 2/0
    ip address 222.1.5.1 255.255.255.0
    no shutdown 
    exit

    6. 对各个路由器配置动态路由,命令如下:

    左边路由器:
    enable 15
    configure terminal
    router rip 
    version 2
    network 222.1.3.0
    network 222.1.4.0
    network 222.1.5.0

    右边路由器:
    enable 15
    configure terminal
    router rip 
    version 2
    network 222.1.2.0
    network 222.1.6.0
    network 222.1.4.0

    上边路由器:
    enable 15
    configure terminal
    router rip 
    version 2
    network 222.1.1.0
    network 222.1.5.0
    network 222.1.6.0

    7. 查看各个路由器的路由表

    为了方便查看,插入上面的网络拓扑结构图:

    使用show ip route查看

    对于左边的路由器,如果配置正确会显示:

    对于右边的路由器,如果配置正确会显示:

    对于上边的路由器,如果配置正确会显示:

    8.进入PC机的Command Prompt 终端ping各个主机查看联通情况:

    进入ip地址为222.1.1.1由近及远ping自己与各个主机

    (1)ping 软件回环地址:

    (2)ping自己的网卡:

    (3)ping其他PC机

    9. 分析第一次ping的时候为什么会丢包或者延时

    ping第一个是ARP广播包,建立MAC地址和IP地址对应表

    因为一开始不知道对方的MAC地址,所以包可能丢。

     

    展开全文
  • 配置动态路由协议OSPF

    2018-03-19 14:33:15
    但大型的网络和频繁变动的拓扑,就需要配置动态路由协议! 协议就是大家都遵循的规范。 比如你在廊坊,家在西藏,你爸让你回去买个普通的白炽灯灯泡,你爸不会担心你买回家的灯泡不能用,因为全国的白炽灯灯泡就都...

    前言:

    对于拓扑结构变化少网络规模小时可以为路由器配置静态路由。但大型的网络和频繁变动的拓扑,就需要配置动态路由协议

    协议就是大家都遵循的规范。
    比如你在廊坊,家在西藏,你爸让你回去买个普通的白炽灯灯泡,你爸不会担心你买回家的灯泡不能用,因为全国的白炽灯灯泡就都是这样子,国家制定了这样的标准,大家用的是一样的。
    再比如,秦始皇为了统一,指定了度量衡,统一货币,和文字,这样不同地方的人,大家都使用同一套标准,就可以相互之间交流,不然无法沟通交流,之间就无法进行信息传递!

    动态协议非常的无私,它会将自己的路由信息分享给它的邻居路由器,让邻居知道,我可以到哪里哪里,如果你想到那里,可以通过我到哪里哪里!

    每一个路由器都配置了OSPF协议,接下来只需要给重要的节点手动配置路由,就可以实现全网互通了!
    OSPF(open shortest pass first 开发式 最短路径 优先 算法)

    过程:

    这里写图片描述
    首先为每个路由器配置信息
    路由器> R1

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l1
    ip address 1.1.1.1  255.255.255.255 ‘配置回环口地址
    interface f0/0
    ip address 12.1.1.1  255.255.255.0 ‘配置接口f0/0的ip地址

    路由器>R2

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l2
    ip address 2.2.2.2  255.255.255.255 ‘配置回环口地址
    interface f0/0
    ip address 12.1.1.2  255.255.255.0 ‘配置接口f0/0的ip地址
    interface f0/1
    ip address 23.1.1.2  255.255.255.0 ‘配置接口f0/0的ip地址

    路由器>R3

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l3
    ip address 3.3.3.3  255.255.255.255 ‘配置回环口地址
    interface f0/1
    ip address 23.1.1.3  255.255.255.0 ‘配置接口f0/0的ip地址
    interface f0/0
    ip address 34.1.1.3  255.255.255.0 ‘配置接口f0/0的ip地址

    路由器>R4

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l4
    ip address 4.4.4.4  255.255.255.255 ‘配置回环口地址
    interface f0/0
    ip address 34..1.1.4  255.255.255.0 ‘配置接口f0/0的ip地址

    接着为R1 配置动态路由协议OSPF,首先需要进入配置模式

    configure termial ‘进入到配置模式下
    router OSPF 1
    表示在这台路由器上运行一个OSPF的进程,进程标号为1.这个标号只在这个路由器内部有效!
    路由器是一台专用的网络计算机,它也有CPU,内存,硬盘。它的操作系统被称为ios (internet operating system),它上面有很多接口,其实那是一个个的网卡,所以路由器就相当于一台多网卡的计算机!进程是驻留在内存上的一个程序,它像所有的进程一样,有自己的存活周期,不可能一直运行占用着内存空间!一个路由器上可以运行一个或多个OSPF进程!就比如microsoft的word,当你打开一个word文档,在打开一个,会出现另一个word进程!

    路由器上开始运行ospf协议后,下一步

    router-id 1.1.1.1 (ip-address formate)
    在全局范围下(也就是整个网络),存在很多路由器运行了ospf协议,这时候OSPF协议就要区分每一台路由器,这时候用ip地址来区分(这里用回环口的地址表示该路由器的ip)

    标识好全局范围下的路由器后开始配置重要节点的路由器信息

    network 1.1.1.1  0.0.0.0 area 0
    network 12.1.1.0  0.0.0.255 area 0
    network +该路由器所相连的网段的路由信息 +反掩码+区域号
    R1 路由器相连相当于两个网段 1.1.1.1 (只有一个终端主机的网段) 12.1.1.0 (路由器R1和路由器R2之间的网段)
    掩码ip subnet mask :为了确定该ip是在哪个网段
    反掩码wild card bits:宣告这个网段ip地址范围大小!
    area:划分区域,可以划分42亿个区域!但这个没有具体用到!

    通过反掩码和网段可以算出来
    network 12.1.1.0  0.0.0.255 area 0
    12.1.1.0
    0.0.0.255
    反掩码0对应的网段部分不变,反掩码1对应的网段部分任意变
    这样12.1.1.0这个网段前24位不变还是12.1.1
    12.1.1.0后面的0所对应的8位(因为255代表8个1)可以任意变。
    那么这个网段包括了12.1.1.0~12.1.1.1(256)个ip地址。
    OSPF协议通过这样的机制来判断路由器的接口地址是否落在了网段地址和反掩码所代表的网段里
    如果在,这个接口将会被激活!
    激活后就会与邻居路由器交换自己的路由信息(也就是从我的这个接口可以到那些接口)
    接着配置R2>R3>R4的OSPF协议

    R2
    configure termial
    router ospf 1
    router-id 2.2.2.2
    network 2.2.2.2 0.0.0.0  area 0
    network 12.1.1.0   0.0.0.255 area 0
    network 23.1.1.0 0.0.0.255 area 0
    R3
    configure termial
    router ospf 1
    router-id 3.3.3.3
    network 3.3.3.3 0.0.0.0  area 0
    network 23.1.1.0   0.0.0.255  area 0
    network 34.1.1.0 0.0.0.255 area 0
    R4
    configure termial
    router ospf 1
    router-id 4.4.4.4
    network 4.4.4.4 0.0.0.0  area 0
    network 34.1.1.0   0.0.0.255  area 0

    这里写图片描述
    最后ping 1.1.1.1 source 4.4.4.4
    出现!!!!!就代表互通了
    总结:
    Ctrl+6:结束ping
    Ctrl+A:光标移到最前面
    Ctrl+E:光标移到最后面
    do show run | i route ospf:查看现在运行OSPF协议的路由
    网络,编程,看多少遍文档都学不会,实验

    展开全文
  • 1.搭建如下网络拓扑结构 2.pc0设置如下ip和网关(第三个为网关,是连接的路由器端口的ip) 3.pc1设置如下ip和网关 ...Router(config-if)#ip address 192.168.1.254 255.255.255.0 Router(config-i

    1.搭建如下网络拓扑结构


    2.pc0设置如下ip和网关(第三个为网关,是连接的路由器端口的ip)


    3.pc1设置如下ip和网关


    4.router0设置端口ip

    Router(config)#int f0/0
    Router(config-if)#ip address 192.168.1.254 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#int se2/0
    Router(config-if)#ip address 192.168.3.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit


    5.router1设置端口ip
    Router(config)#int f0/0
    Router(config-if)#ip address 192.168.2.254 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#int se2/0
    Router(config-if)#ip address 192.168.3.2 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit


    6.router0设置动态路由

    Router(config)#route rip
    Router(config-router)#network 192.168.1.0      //路由器的端口连接的网络号(有几个就写几个)
    Router(config-router)#network 192.168.3.0        
    Router(config-router)#version 2            //修改版本号,默认为1
    Router(config-router)#no auto-summary      //如果版本号为默认的1,不需要写该语句,如果为2则需要写
    Router(config-router)#exit

    7.router1设置动态路由

    Router(config)#route rip
    Router(config-router)#network 192.168.3.0
    Router(config-router)#network 192.168.2.0
    Router(config-router)#version 2
    Router(config-router)#no auto-summary
    Router(config-router)#exit

    8.在pc0主机上ping pc1主机,发现可以连通,第一个超时是因为在连接过程中需要花费一些时间,不像以前那样简单又快速

    展开全文
  • 传送门
  • rip动态路由协议配置 网络拓朴图 在R1上的全部配置 Router>enable Router#conf Router(config)#intf0/0 Router(config-if)#ipaddress192.168.0.1255.255.255.0 Router(con...
  • 思科RIP路由协议配置

    2020-05-24 10:09:47
    思科路由器RIP协议配置 (供自己参考学习) RIP简介 RIP(Routing Information protocol) 路由信息协议. 是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议...
  • 问题 在相对较小而且结构不变的网络中,静态路由是很好的解决方案,它配置简单而且不过多消耗设备资源(动态路由协议在运行时要消耗路由器内部资源,在与其他...动态路由协议配置灵活,路由器会发送自身的路由信息...
  • 一、首先来看一下静态路由协议动态路由协议的区别: 静态路由:这种路由由网络管理员手动输入路由器命令管理。缺点:需要手工指定,网络过大无法使用。 动态路由:这种路由由网络路由协议根据拓扑或流量改变而...
  • 学习笔记:动态路由协议,距离矢量路由协议RIP(原理及配置) 1.动态路由 基于某种路由协议实现 特点: 减少了管理任务 占用了网络带宽 1.1基础 动态路由协议概述 路由器之间用来交换信息的语言 度量值 跳数...
  • 》OSPF动态路由协议  开放式最短路径优先协议是当今最流行和应用最广泛的路由协议之一。OSPF采用的是一种链路状态算法,并因此克服了RIP协议和其他采用距离适量算法协议的缺点。OSPF具有收敛速度快、路由汇聚使...
  • 一、实验目标  根据拓扑图完成网络电缆连接  删除路由器启动配置并将其重新... 掌握OSPF协议配置方法   二、实验环境  •思科3560三层交换机一台。 •计算机4台(已安装 Windows Server 2003 操作系统)...
  • RIP路由协议配置

    2020-05-07 21:45:03
    1、配置RIP动态路由协议,使得3台Cisco路由器模拟远程网络互联。 2、对运行中的RIP动态路由协议进行诊断。 二、实验原理:(写,该实验对应哪些协议?应用哪些技术?等等) RIP路由信息协议:是应用较早、使用较普遍...
  • cisco 动态路由RIP配置

    2019-05-05 00:57:08
    动态路由RIP运用在一个较大的企业网络,在有多个... 动态路由协议分类: 距离矢量路由协议 根据跳数来选择路由 如RIP IGRP 链路状态路由协议 根据度量值选择路由 如OSPF IS-IS RIP使用跳数作为唯一的度量值,最...
  • 》RIP动态路由协议  RIP路由协议只依据路由器跳数决定最佳路径,不考虑带宽、延时和其他因素。RIP总是把具有最小跳数值的路径作为最优路径。RIP限制最大跳数是15,如果跳数为16,则意味着路径不可达。RIP在路由...
  • 思科动态路由协议RIP

    2019-09-01 16:36:53
    思科动态路由协议 规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...
  • 1、配置OSPF动态路由协议,使得3台Cisco路由器模拟远程网络互联。 2、对运行中的OSPF动态路由协议进行诊断。 二、实验原理:(写,该实验对应哪些协议?应用哪些技术?等等) OSPF(Open Shortest Path First,开放...
  • RIP 协议配置命令: 1、配置终端设备 - PC1/2 2、配置网络设备 R1/R2/R3/R4 router rip // 启用路由协议 RIP version 2 // 配置路由器使用 RIP 版本2 no auto-summary // 关闭 RIP 协议的自动汇总 net...
  • 动态路由协议的基本配置---RIP 在上一篇博客中我们讲解了如何配置静态路由与缺省路由,这次,我们学习一下动态路由协议体系中的RIP协议。 RIP协议英文名称为Routing Information Protocol ,中文名称为路由信息协议...
1 2 3 4 5 ... 20
收藏数 23,422
精华内容 9,368