2019-05-20 17:37:41 qiujin_zebra 阅读数 2877
  • 阿里云ECS Linux服务器项目部署实战视频课程

    本套课程建立在阿里云linux(centos6.5) 具体内容如下: 1,购买云主机&安装上传工具 2,安装nginx 3,绑定域名(域名备案,虚拟主机绑定等) 4,安装mysql(设定开机启动,环境变量,更改连接密码等) 5,安装php 6,配置nginx识别php 7,安装thinkcmf完成pathinfo模式&伪静态模式的nginx设置 8,安装phpmyadmin&ftp;服务

    7121 人正在学习 去看看 吴华
@查看php是否启动
    1)ps -ef | grep php 或者 ps -A | grep -i php 
 
@开启php
 	1) php-fpm start
 
@停止php
	1) php-fpm stop

@重启php
	1) php-fpm restart
	
@杀死进程
	1) kill -9 【pid】
	
@杀死php全部进程
	1) killall -9 php
2018-07-11 13:56:01 qq_42572322 阅读数 502
  • 阿里云ECS Linux服务器项目部署实战视频课程

    本套课程建立在阿里云linux(centos6.5) 具体内容如下: 1,购买云主机&安装上传工具 2,安装nginx 3,绑定域名(域名备案,虚拟主机绑定等) 4,安装mysql(设定开机启动,环境变量,更改连接密码等) 5,安装php 6,配置nginx识别php 7,安装thinkcmf完成pathinfo模式&伪静态模式的nginx设置 8,安装phpmyadmin&ftp;服务

    7121 人正在学习 去看看 吴华

crontab  -e 编辑crontab服务文件

*/1 * * * * php /var/www/html/index.php

cron服务是Linux的内置服务,但它不会开机自动启动。可以用以下命令启动和停止服务:

/sbin/service crond start
/sbin/service crond stop
/sbin/service crond restart
/sbin/service crond reload

以上1-4行分别为启动、停止、重启服务和重新加载配置。

要把cron设为在开机的时候自动启动,在 /etc/rc.d/rc.local 脚本中加入 /sbin/service crond start 即可

查看当前用户的crontab,输入 crontab -l;

编辑crontab,输入 crontab -e;

删除crontab,输入 crontab -r

#每隔1个小时执行一次  ls
0 */1 * * * ls
#每隔2个小时执行一次 ls
0 */2 * * * ls
#每隔3个小时执行一次 ls
0 */3 * * * ls
#每隔4个小时执行一次 ls
0 */4 * * * ls
#每隔10天执行一次 ls
0 0 */10 * * ls
#每天1点执行 ls
0 1 * * * ls

保存退出就行了

linux php
2011-07-29 00:44:26 iteye_16338 阅读数 16
  • 阿里云ECS Linux服务器项目部署实战视频课程

    本套课程建立在阿里云linux(centos6.5) 具体内容如下: 1,购买云主机&安装上传工具 2,安装nginx 3,绑定域名(域名备案,虚拟主机绑定等) 4,安装mysql(设定开机启动,环境变量,更改连接密码等) 5,安装php 6,配置nginx识别php 7,安装thinkcmf完成pathinfo模式&伪静态模式的nginx设置 8,安装phpmyadmin&ftp;服务

    7121 人正在学习 去看看 吴华

今天安装linux版得php,又遇到了很多的问题,不会用ftp上传,怎样停止linux的下载,

还有就是linux的命令不熟练,这个还是要多多练习。下面的是今天不会用的一些命令。

 

 

 

网页页面乱码:要修改httpd.conf  php.ini  my.cnf

httpd.conf :addDefaultCharset UTF-8 改完重启apache
my.cnf:在[mysql]下加一行default-character-set=utf-8 改完重启mysql
php.ini:(最关键)要改php.ini ;default_charset = "iso-8859-1" 改成 default——charset = "UTF-8"

Wget –c 下载路径 下载文件

访问ip +配置的端口 能查看到apache的配置文件路径(documentRoot

ctrl+z 挂起执行

bg 后台执行

ctrl+c中断

find -name "文件名" –print 查看文件路径

ps -ef|grep httpd 查看进程(能查看到想重启程序启动命令在哪个目录下)

路径 restart 重启

rpm e xv卸载

RPM的常用参数还包括:

vh:显示安装进度;

  -U:升级软件包;

  -qpl:列出RPM软件包内的文件信息;

  -qpi:列出RPM软件包的描述信息;

  -qf:查找指定文件属于哪个RPM软件包;

  -Va:校验所有的RPM软件包,查找丢失的文件

2018-02-01 17:10:23 kangsf1989 阅读数 25522
  • 阿里云ECS Linux服务器项目部署实战视频课程

    本套课程建立在阿里云linux(centos6.5) 具体内容如下: 1,购买云主机&安装上传工具 2,安装nginx 3,绑定域名(域名备案,虚拟主机绑定等) 4,安装mysql(设定开机启动,环境变量,更改连接密码等) 5,安装php 6,配置nginx识别php 7,安装thinkcmf完成pathinfo模式&伪静态模式的nginx设置 8,安装phpmyadmin&ftp;服务

    7121 人正在学习 去看看 吴华

linux 下PHP服务操作

service php-fpm start  开启

service php-fpm stop   停止

service php-fpm restart  重启

2015-05-20 10:34:24 xsgnzb 阅读数 4765
  • 阿里云ECS Linux服务器项目部署实战视频课程

    本套课程建立在阿里云linux(centos6.5) 具体内容如下: 1,购买云主机&安装上传工具 2,安装nginx 3,绑定域名(域名备案,虚拟主机绑定等) 4,安装mysql(设定开机启动,环境变量,更改连接密码等) 5,安装php 6,配置nginx识别php 7,安装thinkcmf完成pathinfo模式&伪静态模式的nginx设置 8,安装phpmyadmin&ftp;服务

    7121 人正在学习 去看看 吴华

为了方便,在linux环境下安装了lnmp集成环境,但是后来在项目中,由于php5.3版本不支持数组以 ['a','b'] 的形式书写,所以需要更新php到5.3以上版本。

lnmp中php是以config & make & make install 的方式安装,所以卸载的话就直接停止php服务(service php-fpm stop 这里启动了php-fpm),再将安装的php目录(/usr/local/php,看phpinfo()里都有信息)。

之后下载了最新的php-5.6.9.tar.gz,解压后 ./configure 后面的参数由之前php-5.3.28的phpinfo()打印的./configure信息。

这样./configure后会有警告,说 ‘--enable-magic-quotes’ 和 ‘--enable-safe-mode’不可用,原因是php-5.4之后就不支持,同样去处的还有:'–enable-discard-path','–enable-fastcgi','–enable-force-cgi-redirect','–with-curlwrappers';

之后再make,又报错:

/bin/bash /root/php-5.6.9/libtool --silent --preserve-dup-deps --mode=link cc -DPHP_ATOM_INC -I/root/php-5.6.9/include -I/root/php-5.6.9/main -I/root/php-5.6.9 -I/root/php-5.6.9/ext/date/lib -I/root/php-5.6.9/ext/ereg/regex -I/usr/include/libxml2 -I/usr/include/freetype2 -I/root/php-5.6.9/ext/mbstring/oniguruma -I/root/php-5.6.9/ext/mbstring/libmbfl -I/root/php-5.6.9/ext/mbstring/libmbfl/mbfl -I/usr/local/include -I/root/php-5.6.9/ext/sqlite3/libsqlite -I/root/php-5.6.9/ext/zip/lib -I/root/php-5.6.9/TSRM -I/root/php-5.6.9/Zend    -I/usr/local/include -g -O2 -fvisibility=hidden   -o ext/opcache/opcache.la -export-dynamic -avoid-version -prefer-pic -module -rpath /root/php-5.6.9/modules -L/usr/lib/x86_64-linux-gnu -L/usr/local/lib ext/opcache/ZendAccelerator.lo ext/opcache/zend_accelerator_blacklist.lo ext/opcache/zend_accelerator_debug.lo ext/opcache/zend_accelerator_hash.lo ext/opcache/zend_accelerator_module.lo ext/opcache/zend_persist.lo ext/opcache/zend_persist_calc.lo ext/opcache/zend_shared_alloc.lo ext/opcache/zend_accelerator_util_funcs.lo ext/opcache/shared_alloc_shm.lo ext/opcache/shared_alloc_mmap.lo ext/opcache/shared_alloc_posix.lo ext/opcache/Optimizer/zend_optimizer.lo
libtool: link: `ext/opcache/zend_accelerator_blacklist.lo' is not a valid libtool object
make: *** [ext/opcache/opcache.la] Error 1

大概意思是说 xxx.lo不是有效的libtool object。

我想opcache是个php扩张,正常安装的时候一般不会扩张出问题,很可能是php-5.6版本太新,我下载的安装包有问题,所以就下了个php-5.5.25版本的试下。

果然按照之前的方式安装下来能正常的make & make install。

安装好php后试下php -v:

root@precise64:/usr/local/nginx/conf# php -v
Zend Guard Loader requires Zend Engine API version 220090626.
The Zend Engine API version 220121212 which is installed, is newer.
Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.

PHP 5.5.25 (cli) (built: May 20 2015 10:21:25)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies

没问题,php安装成功。

接下来就是启动php-fpm服务,service php-fpm start,报错了,

root@precise64:~/php-5.5.25# service php-fpm start
Starting php-fpm [20-May-2015 10:23:40] ERROR: failed to open configuration file '/usr/local/php/etc/php-fpm.conf': No such file or directory (2)
[20-May-2015 10:23:40] ERROR: failed to load configuration file '/usr/local/php/etc/php-fpm.conf'
[20-May-2015 10:23:40] ERROR: FPM initialization failed
 failed

说是不能导入php-fpm.conf文件,先查下这个/usr/local/php/etc/php-fpm.conf是不是存在,没有,就从原来的php-5.3.28中拷贝一份来,然后再启动就ok了。

root@precise64:/usr/local/php/etc# service php-fpm start
Starting php-fpm Zend Guard Loader requires Zend Engine API version 220090626.
The Zend Engine API version 220121212 which is installed, is newer.
Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.

 done

查看下phpinfo()



linux配置PHP环境

阅读数 197

没有更多推荐了,返回首页