动态路由_动态路由选择 - CSDN
精华内容
参与话题
  • 静态路由和动态路由

    万次阅读 多人点赞 2018-12-23 16:57:43
    (3)掌握动态路由的配置。   实验要求: (1)写出静态路由的配置过程; (2)写出动态路由的配置过程。   一、路由器的作用  所谓“路由”,是指把...

    实验目的:

    (1)了解路由器的作用;

    (2)掌握静态路由的配置;
    (3)掌握动态路由的配置。

     

    实验要求:

    (1)写出静态路由的配置过程;

    (2)写出动态路由的配置过程。

     

    一、路由器的作用

      所谓“路由”,是指把数据从一个地方传送到另一个地方的行为和动作,而路由器,正是执行这种行为动作的机器,它的英文名称为Router,是一种连接多个网络或网段的网络设备,它能将不同网络或网段之间的数据信息进行“翻译”,以使它们能够相互“读懂”对方的数据,从而构成一个更大的网络。

     

    路由器主要有以下几种功能:

    1,网络互连:路由器支持各种局域网和广域网接口,主要用于互连局域网和广域网,实现不同网络互相通信;

    2,数据处理:提供包括分组过滤、分组转发、优先级、复用、加密、压缩和防火墙等功能;

    3,网络管理:路由器提供包括路由器配置管理、性能管理、容错管理和流量控制等功能。

     

    为了完成“路由”的工作,在路由器中保存着各种传输路径的相关数据--路由表(Routing Table),供路由选择时使用。路由表中保存着子网的标志信息、网上路由器的个数和下一个路由器的名字等内容。路由表可以是由系统管理员固定设置好的,也可以由系统动态修改,可以由路由器自动调整,也可以由主机控制。在路由器中涉及到两个有关地址的名字概念,那就是:静态路由表和动态路由表。由系统管理员事先设置好固定的路由表称之为静态(static)路由表,一般是在系统安装时就根据网络的配置情况预先设定的,它不会随未来网络结构的改变而改变。动态(Dynamic)路由表是路由器根据网络系统的运行情况而自动调整的路由表。路由器根据路由选择协议(Routing Protocol)提供的功能,自动学习和记忆网络运行情况,在需要时自动计算数据传输的最佳路径。

     

    二、配置中需要用的命令

    1.进入高速端口:

       Router(config)#interface gigabitEthernet + 要开启的端口

     

    2.为端口设置ip地址:

       Router(config-if)#ip address + ip地址 +子网掩码

     

    3.开启端口:

        Router(config-if)#no shutdown

     

    4.为路由器配置静态路由:

        Router(config)#ip route + 网段 + 子网掩码 +下一跳地址

     

    5.删除静态路由:

        Router(config)#no ip route + 网段 + 子网掩码 +下一跳地址

     

    6.启用rip协议:

        Router(config)#router rip

     

    7.选择rip版本:

        Router(config-router)#version + 版本

     

    8.选择直连网段:

        Router(config-router)#net + 直连网段

     

    9. 查看当前设备上当前状态下所有接口的ip简单配置信息:

        Router#show ip interface brief

     

    10.查看路由表信息

        Router#show ip route

     

     

     

    实验过程描述

    一、实验拓扑图

    二、配置静态路由

      1.为router7配置两个口的IP地址,并开启。

        Router(config)#interface gigabitEthernet 0/0

    Router(config-if)#ip address 192.168.1.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

       

    Router(config)#interface  gigabitEthernet 0/1

    Router(config-if)#ip address 192.168.2.1 255.255.255.0

    Router(config-if)#no shutdown

     

      2.为router8配置两个口的IP地址,并开启。

    Router(config)#interface  gigabitEthernet 0/0

    Router(config-if)#ip address 192.168.3.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

     

    Router(config)#interface  gigabitEthernet 0/1

    Router(config-if)#ip address 192.168.2.64 255.255.255.0

    Router(config-if)#no shutdown

     

      3.为两台主机分别配置ip地址,子网掩码,网关。

    Pc2

    Pc3

      4.分别为两个路由器配置静态ip。

    Router7

     Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.64

    Router8

     Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

      5.测试。

       Router7

    Router#show ip route

       Router8

    Router#show ip route

    连通性测试

     

    三、动态路由配置

      1.在静态路由的基础上进行改变,删除静态路由。

    Router7

    Router(config)#no ip route 192.168.3.0 255.255.255.0 192.168.2.64

    Router#show ip route

    Router8

    Router(config)#no ip route 192.168.1.0 255.255.255.0 192.168.2.1

    Router#show ip route

      2.为7配置动态路由。

        Router(config)#router rip

        Router(config-router)#version 2

    Router(config-router)#net 192.168.1.0

    Router(config-router)#net 192.168.2.0

      3.为8配置动态路由。

        Router(config)#router rip

        Router(config-router)#version 2

    Router(config-router)#net 192.168.3.0

    Router(config-router)#net 192.168.2.0

      4.测试

       Router7

       

       Router8

       

    连通性测试

     

    四、数据流动分析

     1.数据包分析(用PC2 ping PC3)

       1.此数据包为第一个输入包,即PC2的第一个输出包。

    2.此输出包为R7的第一个输出包,也是R8的以一个输入包,同第一个包相比发现源目的MAC地址改变,说明MAC为两个节点之间通信使用的地址,源目的ip地址没有发生改变。观察发现此数据包的TTL值减一,即生存时间减少了,说明每经过一个路由器TTL值都会减少一个,即利用TTL变化可以判断经过的路由器的数量。

     

     

    3.此数据包与之前数据包相比符合之前所分析的结果,说明之前分析正确。

     

    4.此数据包为PC3的一个响应包,通过分析发现此源目的MAC地址恰好与上一个R8发送给PC3的MAC地址相反,所以说MAC地址即为两个相邻节点间通信用的地址,而与之前数据包相比发现源目的IP地址发生改变,IP为两台PC机通信的逻辑地址。

     2.rip包分析

       1.每过30s发送一次RIP包,发现R8生成两个RIP包。

     

       2.经过分析图2.2,发现IP地址为192.168.2.64说明为R8生成的一个数据包,通过查看目的IP可知,此包为一个组播包。通过查看rip报数据报可知R8通过192.168.2.64口向相邻路由器发送一个网段为192.168.3.0子网掩码为255.255.255.0下一跳地址为192.168.2.64距离为1路由表项。

     

       3.经过分析图2.3,发现IP地址为192.168.3.1,也为组播包。通过查看rip报数据报可知R8通过192.168.3.1口向相邻路由器发送一个网段为192.168.1.0子网掩码为255.255.255.0下一跳地址为192.168.3.1距离为2的路由表项和一个网段为192.168.2.0子网掩码为255.255.255.0下一跳地址为192.168.3.1距离为1的路由表项。

     

    4.经分析图2.4发现PC机会丢弃接收到的RIP包。

       

                                          图2.2

     

      

                                        图2.3

     

     

        

                                                       图2.4

     

    回答问题

    一、路由器的作用是什么?

     1,网络互连:路由器支持各种局域网和广域网接口,主要用于互连局域网和广域网,实现不同网络互相通信;

    2,数据处理:提供包括分组过滤、分组转发、优先级、复用、加密、压缩和防火墙等功能;

    3,网络管理:路由器提供包括路由器配置管理、性能管理、容错管理和流量控制等功能。

     

     

     

    展开全文
  • 动态路由

    2019-11-05 11:10:44
    动态主机配置协议–统一分发和管理IP地址,基于UDP协议,端口号67&68基于Client/Server架构 成为DHCP服务器的条件 1、自身拥有合法的IP地址 2、自身拥有接口或者网卡连接到所要下发地址的网络范围 DHCP数据包...

    1.HDCP

    动态主机配置协议–统一分发和管理IP地址,基于UDP协议,端口号67&68基于Client/Server架构

    成为DHCP服务器的条件

    1、自身拥有合法的IP地址
    2、自身拥有接口或者网卡连接到所要下发地址的网络范围

    DHCP数据包以及过程

    DHCP Discover(广播)
    DHCP Offer(广播) - //携带准备下发的IP地址
    DHCP Request(广播)
    DHCP Ack(广播)

    工作过程

    1.需要自动获取IP地址的客户端开启自动获取IP地址之后,本地广播发出DHCP Discover数据包
    2.源IP地址0.0.0.0,目标IP地址255.255.255.255,源MAC地址为本地网卡MAC,目标MAC为FFFF-FFFF-FFFF
    3.开启了DHCP服务的服务器收到此数据包后,发送免费ARP以确定所要下发的IP地址没有冲突,再本地基于广播的形式回复DHCP Offer数据包
    4.客户端使用DHCP Request数据包请求IP地址,服务器回复ACK给客户端,客户端拿到IP地址

    HDCP的租期

    租期:默认租期为1440min/24h/一天。
    续租:当租期到达1/2时,客户端若依然在线,客户端主动发出Request数据包来续租;若续租失败,继续在7/8的租期再次发送Request数据包续租;若依然失败,那租期到达时地址被收回,客户端若想继续使用,需要重新获取地址。

    2.路由器作为DHCP服务器

    ### 1)以全局的池塘下发地址
    [r1]dhcp enable //开启服务
    [r1]ip pool css //创建DHCP池塘,一个池塘只能服务一个网络范围
    [r1-ip-pool-css]network 172.16.1.0 mask 255.255.255.0 //定义池塘范围
    [r1-ip-pool-css]gateway-list 172.16.1.1 //配置网关
    [r1-ip-pool-css]dns-list 114.114.114.114 //配置DNS

    [r1]interface GigabitEthernet 0/0/0
    [r1-GigabitEthernet0/0/0]dhcp select global
    [r1-GigabitEthernet0/0/0]dhcp server excluded-ip-address 172.16.1.250 //排除某地址
    [r1-GigabitEthernet0/0/0]dhcp server static-bind ip-address 172.16.1.111 mac-add
    ress aaaa-1122-ab12 //给某个固定的MAC地址下发固定的IP地址

    2)以接口的IP地址的范围下发地址

    [r1]interface GigabitEthernet 0/0/0
    [r1-GigabitEthernet0/0/0]dhcp select interface
    [r1-GigabitEthernet0/0/0]dhcp server dns-list 1.1.1.1 //设置DNS

    3.动态路由

    各台路由器之间运行某种协议(算法),通过收发数据包的形式获取未知路径

    动态路由协议的追求

    1、收敛速度快
    2、选择路径佳
    3、占用资源少

    动态路由协议的分类

    1、基于AS的分类
    AS–Autonoumous System,自治系统。使用编号的方式表示,范围0-65535,其中0-64511为公有AS号,64512-65535私有AS号
    IGP(内部网关协议)协议–AS之内运行的协议:RIP、OSPF、EIGRP-Cisco私有、ISIS
    EGP(外部网关协议)协议–AS之间运行的协议:BGP
    2、IGP协议的分类
    DV型-距离矢量:RIP、EIGRP–共享路由表
    LS型-链路状态:OSPF、ISIS–共享拓扑

    3.RIP

    Routing Information Protocol,路由信息协议

    1)基本概念

    版本:RIPv1 RIPv2 RIPng(IPV6)
    标准的DV型路由协议–共享路由表基于UDP协议,端口号520
    更新方式:周期更新(30s)–确认、保活
    RIP优先级100 使用跳数作为度量值

    2)RIPv1和RIPv2的区别

    1、RIPv1平分割–同一个路由条目,从此口进不从此口再发出。用于消除重复更新。只能消除线型拓扑和星型拓扑的环路
    2、毒性 逆转水平分割–核心破环机制

    3) RIP的配置

    无论是哪个版本的RIP,宣告时均使用主类范围

    1、RIPv1的配置

    [r1]rip 1 //启动协议,需要配置进程号
    [r1-rip-1]version 1 //选择版本,必须选择
    宣告:1、激活接口 2、发布路由
    [r1-rip-1]network 1.0.0.0
    [r1-rip-1]network 12.0.0.0更新时不携带掩码,RIPv2更新时携带掩码

    2、RIPv1广播更新,RIPv2组播更新–224.0.0.9

    3、RIPv2支持手工认证–邻居间的身份核实

    RIP的扩展配置

    1、汇总

    [r1]interface GigabitEthernet 0/0/0 //更新发出的接口
    [r1-GigabitEthernet0/0/0]rip summary-address 1.0.0.0 255.252.0.0

    2、缺省路由-在连接运营商的边界路由器上

    [r3]rip 1
    [r3-rip-1]default-route originate

    3、静默接口–只接收不发送RIP数据包。一般用于连接用户的接口,禁止用于路由器之间的接口

    [r1]rip 1
    [r1-rip-1]silent-interface GigabitEthernet 0/0/1

    实验记录

    创建拓扑并分配IP范围
    在这里插入图片描述
    将路由器接口输入IP
    在这里插入图片描述
    给路由器创建IP池塘,并配置网关
    在这里插入图片描述
    打开接口宣告
    在这里插入图片描述
    之后可以查出PC的IP地址
    在这里插入图片描述
    进行RIP设置,并设置静默接口
    在这里插入图片描述
    并给R3设置缺省路由
    ![在这里插入图片描述](https://img-blog.csdnimg.cn/20191105105449472.png
    设置好后测试Ping
    在这里插入图片描述
    完成

    展开全文
  • 1 什么的动态路由 根据路径不同,显示内容不同。就像图片路径:image/1 ,其中变化的就是这个“1”,根据这个数字的变化会展示不同的图片。 2 页面编写 在src/components路径下创建item.vue,其中内容为(当然你也可以...

    该文章的项目是我的上篇文章的项目,上篇博客地址:上篇博文

    1 什么的动态路由

    根据路径不同,显示内容不同。就像图片路径:image/1 ,其中变化的就是这个“1”,根据这个数字的变化会展示不同的图片。

    2 页面编写

    在src/components路径下创建item.vue,其中内容为(当然你也可以不使用id,使用别的你想要的名字)

    <template>
        <div >
            传递来的数据是: {{ $route.params.id }}
        </div>
    </template>
    

    如果你想在脚本(script标签)中使用这个id值,可以这么写

    this.$route.params.id
    

    3 修改路由

    修改src/router/index.js,引入item组件

    import item from '@/components/item'
    

    添加路由设置(在item中你使用的如果是别的名字,这里的id也要改成相同的)

        {
          path: '/item/:id',
          name: 'Item',
          component: item
        }
    

    4 修改list

    修改src/components/list.vue, 增加链接

    <template>
      <div>
        这是一个列表
        <router-link to="/item/100">新闻100</router-link>
        <router-link to="/item/200">新闻200</router-link>
        <router-link to="/item/300">新闻300</router-link>
      </div>
    </template>
    

    成果

    进入项目页面,点击列表
    在这里插入图片描述
    点击“新闻100”
    在这里插入图片描述
    点击“新闻200”
    在这里插入图片描述

    相关文章

    vue嵌套路由:嵌套路由教学

    展开全文
  • 动态路由配置

    万次阅读 2019-04-04 14:05:13
    2. 对路由器配置动态路由实现不同网段之间的通信,网络拓扑结构如下: 3. 按要求搭建上面的网络拓扑结构 使用鼠标拖动将所需要的结构放入到空白处 4. 配置好各台pc机的ip地址以及网关地址(ip地址以及各网关...

    1. 需要的环境PacketTracer6(思科)

    2. 对路由器配置动态路由实现不同网段之间的通信,网络拓扑结构如下:

    3. 按要求搭建上面的网络拓扑结构

    使用鼠标拖动将所需要的结构放入到空白处

    4. 配置好各台pc机的ip地址以及网关地址(ip地址以及各网关地址注明在上面)

    ip地址:

    网关:

    其他PC机的配置一样

    5. 对路由器连接的各个端口进行配置,命令如下:

    左边路由器:
    enable 15
    configure terminal
    interface fastethernet 0/0(查看端口号使用鼠标移入有连接的颜色的节点)
    ip address 222.1.3.2 255.255.255.0
    no shutdown 
    exit

    interface serial 3/0
    ip address 222.1.5.2 255.255.255.0
    no shutdown 
    exit

    interface serial 2/0
    ip address 222.1.4.2 255.255.255.0
    no shutdown 
    exit

    右边路由器:
    enable 15
    configure terminal
    interface fastethernet 0/0
    ip address 222.1.2.5 255.255.255.0
    no shutdown 
    exit

    interface serial 3/0
    ip address 222.1.6.2 255.255.255.0
    no shutdown 
    exit

    interface serial 2/0
    ip address 222.1.4.1 255.255.255.0
    no shutdown 
    exit

    上边的路由器:
    enable 15
    configure terminal
    interface fastethernet 0/0
    ip address 222.1.1.4 255.255.255.0
    no shutdown 
    exit

    interface serial 3/0
    ip address 222.1.6.1 255.255.255.0
    no shutdown 
    exit

    interface serial 2/0
    ip address 222.1.5.1 255.255.255.0
    no shutdown 
    exit

    6. 对各个路由器配置动态路由,命令如下:

    左边路由器:
    enable 15
    configure terminal
    router rip 
    version 2
    network 222.1.3.0
    network 222.1.4.0
    network 222.1.5.0

    右边路由器:
    enable 15
    configure terminal
    router rip 
    version 2
    network 222.1.2.0
    network 222.1.6.0
    network 222.1.4.0

    上边路由器:
    enable 15
    configure terminal
    router rip 
    version 2
    network 222.1.1.0
    network 222.1.5.0
    network 222.1.6.0

    7. 查看各个路由器的路由表

    为了方便查看,插入上面的网络拓扑结构图:

    使用show ip route查看

    对于左边的路由器,如果配置正确会显示:

    对于右边的路由器,如果配置正确会显示:

    对于上边的路由器,如果配置正确会显示:

    8.进入PC机的Command Prompt 终端ping各个主机查看联通情况:

    进入ip地址为222.1.1.1由近及远ping自己与各个主机

    (1)ping 软件回环地址:

    (2)ping自己的网卡:

    (3)ping其他PC机

    9. 分析第一次ping的时候为什么会丢包或者延时

    ping第一个是ARP广播包,建立MAC地址和IP地址对应表

    因为一开始不知道对方的MAC地址,所以包可能丢。

     

    展开全文
  • vue动态路由配置,vue路由传参

    千次阅读 2019-10-05 16:16:47
    动态路由:  当我们很多个页面或者组件都要被很多次重复利用的时候,我们的路由都指向同一个组件,这时候从不同组件进入一个"共用"的组件,并且还要传参数,渲染不同的数据  这就要用到动态路由跟路由传参了! ...
  • 注意: 在子组件中 获取参数的时候是$route.params而不是 $router 这很重要~~~ 通过@click方法传参跳转 参考:https://www.cnblogs.com/qiu2841/p/11018190.html
  • 一,Vue页面跳转: 1,直接修改地址栏的地址或者a标签就行外部跳转; ... <router-link to=""> a标签,to为href </router-link>... 匹配路由组件的出口 </router-view> 3,JS跳转: ...
  • 路由传参 通过router-link的to属性中的params或query实现 params在地址栏显示的时候不会显示键值对,直接是值跟在后面 而query会有键名 //eg: <router-link :to = "{name: 'list',params: {id: xxx}, query: {...
  • 动态路由 & 路由传参 & 编程式导航 vue cli3 配置反向代理 在脚手架根目录下面新建一个 vue.config.js // vue.config.js中可以默认直接使用 http-proxy-middleware module.exports = {//暴露出去 dev...
  • Vue.js 中的动态路由

    万次阅读 2018-03-12 09:58:58
    而能传递参数的路由模式,由于可以传递参数,所以其对应的路由数量是不确定的,故称之为 动态路由 那么如何将参数作为路由呢? 在参数名前面加上 : ,然后将参数写在路由的 path 内 如下示例: routes: [ ...
  • 静态路由和动态路由的区别

    万次阅读 2012-10-17 10:11:14
    静态路由  是在路由器中设置的固定的路由表。...当动态路由与静态路由发生冲突时,以静态路由为准 动态路由  是网络中的路由器之间相互通信,传递路由信息,利用收到的路由信息更新路由器表的过程。它能实时
  • 静态路由和动态路由的比较

    千次阅读 2017-09-27 10:55:08
    现将静态路由和动态路由进行如下比较: 定义: 静态路由:静态路由是在路由器中设置固定的路由表;除非网络管理员进行干预,否则静态路由表不会发生变化。 动态路由:由网络中的路由器之间相互通信,传递路由信息...
  • vue-router 动态添加 路由

    万次阅读 2017-11-21 20:57:50
    动态添加路由可以用了做权限管理。登录后服务器端返回权限菜单,前端动态添加路由 然后在设置菜单  1、vue-router 有方法router.addRoutes(routes) 动态添加更多的路由规则。参数必须是一个符合 routes 选项...
  • 路由的定义,主要有以下几步: 如果是模块化机制,需要调用 Vue.use(VueRouter) 定义路由组件,如: const Foo = { template: '&lt;div&gt;foo&lt;/div&gt;' }; 定义路由(数组): const ...
  • 动态路由协议分类

    千次阅读 2015-12-03 10:21:12
    路由器根据路由表生成方式可以分为:直连路由,静态路由,动态路由 动态路由协议很多有点复杂。本文介绍一下动态路由的优缺点和分类。
  • 原项目是根据固定角色,判断已经固化的VUE路由文件中的数组生成菜单 改进后,根据后端axios返回的数组动态生成菜单,前端不再判断菜单权限 VUE原始项目https://github.com/PanJiaChen/vue-element-admin 路由动态生成...
  • 网络Cisco实验-动态路由协议配置

    万次阅读 多人点赞 2017-12-22 15:18:45
    1.搭建如下网络拓扑结构 2.pc0设置如下ip和网关(第三个为网关,是连接的路由器端口的ip) 3.pc1设置如下ip和网关 ...Router(config-if)#ip address 192.168.1.254 255.255.255.0 Router(config-i
  • vue-router如何进行路由动态添加

    万次阅读 2018-09-29 16:15:18
    1.页面路由跳转 //页面中使用下面语句代替a标签实现跳转,在写完标签后还需要在router中写下以下语句 &amp;lt;router-link to=&quot;/foo&quot;&amp;gt;Go to Foo&amp;lt;/router-link...
  • 什么是动态路由,其特点是什么? (1)静态路由是由系统管理员设计与构建的路由表规定的路由。适用于网关数量有限的场合,且网络拓朴结构不经常变化的网络。其缺点是不能动态地适用网络状况的变化,当网络状况变化...
  • 在没有OSPF等动态路由的情况下 A->B的时候 A必须知道如何到达B 所以A上应该有B的路由。   当A的数据包到达B,B需要做出回应,所以B要知道如何到达A。因此B上必须有到达A的路由。
1 2 3 4 5 ... 20
收藏数 181,826
精华内容 72,730
关键字:

动态路由