• 打开终端,使用命令xcrun swift -versionxcodebuild -showsdks如图所示: 转载于:https://juejin.im/post/5cde5a62f265da1bc55230e5

    打开终端,使用命令

    xcrun swift -version

    xcodebuild -showsdks 

    如图所示:




    转载于:https://juejin.im/post/5cde5a62f265da1bc55230e5

    展开全文
  • 我们知道Xcode中可能包含不知一个Swift版本,那么我们如何找到它们对应的路径呢?熟悉unix shell命令的童鞋都知道有一个find指令,在我们已知Xcode路径时,我们可以在其中找到Swift在哪里:find /Applications/Xcode....

    我们知道Xcode中可能包含不知一个Swift的版本,那么我们如何找到它们对应的路径呢?

    熟悉unix shell命令的童鞋都知道有一个find指令,在我们已知Xcode路径时,我们可以在其中找到Swift在哪里:

    find /Applications/Xcode.app -name swift -a -type f

    以上命令中的-a选项表示的是and逻辑,你也可以写全称为-and.所以你必须同时符合name为swift,同时type为一般文件这两个条件才可以哦.

    其他type的参数有:

    -type t
                 True if the file is of the specified type.  Possible file types are as follows:
    
                 b       block special
                 c       character special
                 d       directory
                 f       regular file
                 l       symbolic link
                 p       FIFO
                 s       socket

    在本猫的air上运行以上指令结果如下:

    /Applications/Xcode-beta.app/Contents/Developer/Toolchains/Swift_2.3.xctoolchain/usr/bin/swift
    /Applications/Xcode-beta.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/swift

    第一个swift版本显然是2.3,我们看一下后面Swift的版本:

    /Applications/Xcode-beta.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/swift -version
    Apple Swift version 3.0 (swiftlang-800.0.34.6 clang-800.0.33)
    Target: x86_64-apple-macosx10.9

    不出意外是Swift 3.0哦,我的Xcode是8.0beta4

    展开全文
  • xcode swift对应版本

    2019-08-13 12:14:53
    https://swift.org/download/#releases ...Swift 3.0.2 Xcode 8.2 Swift 3.0.1 Xcode 8.1 Swift 3.0 macOS 10.11.5 (El Capitan) Xcode 8.0 beta or later Swift 2.2.1 macOS 10.11 (El Capitan) Xc...

    https://swift.org/download/#releases  

    Swift 3.0.2 Xcode 8.2

     Swift 3.0.1 Xcode 8.1  

    Swift 3.0   macOS 10.11.5 (El Capitan)   Xcode 8.0 beta or later  

    Swift 2.2.1 macOS 10.11 (El Capitan)     Xcode 7.3.1

    Swift 2.2   macOS 10.11 (El Capitan)     Xcode  7.3

    转载于:https://www.cnblogs.com/xinjie/p/6397770.html

    展开全文
  • /应用程序/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

    /应用程序/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

    展开全文
  • 前两天,刚刚升级了Xcode到8.0, swift3.0, 然后运行项目就崩溃了,我的程序报了200多个错。 个人建议:刚开始使用Xcode8打开之前的项目会有很多问题,所以建议大家把Xcode7的版本也保留上 首先先给电脑上现有的...

    前两天,刚刚升级了Xcode到8.0, swift3.0, 然后运行项目就崩溃了,我的程序报了200多个错。

    个人建议:刚开始使用Xcode8打开之前的项目会有很多问题,所以建议大家把Xcode7的版本也保留上

    首先先给电脑上现有的Xcode改名,比如Xcode7.3.1,然后APP Store上继续更新Xcode,安装完成后会保留两个版本。

    当你更新Xcode8.0之后,你需要Convert,

    而这个时候你需要Convert, 否则编译是通不过的。

    Xcode默认是全部选择,如果没有提示的话需要手动convertXcode 手动convert   Edit-->Convert-->To Curent Swift Syntax...

    接下来,你会发现你的程序开始报错了,这时候你会发现有很多的错误都是因为版本的问题。


    你需要做的就是升级cocoapods 到最新版本,在终端里输入“Pod update”, 或"pod install", 来更新/安装Alamofire4.0。(如果不会安装,请自行Google)。

    如果你在使用CocoaPods时,报这个错误 no such module 'xxx'....

    那么你需要在终端里运行 pod 'RealmSwift', :git => 'https://github.com/realm/realm-cocoa.git', :tag => 'v1.1.0',:submodules => true

    swift3.0更新之后有了不少语法上的变化,所以如果原项目中有涉及到swift,就需要转换一下,比如说第三方类库,升级到xcode8后因为swift的原因总是报错.

    那么,首先你需要看一下该swift库是否已经有了swift3.0的版本,有的话则更新到最新版,即将旧文件进行替换,替换成最新的swift文件.你需要在Build Phase里的"Use Legacy Swift Language Version” 选项中改成“YES".

    还有另外一个办法,如果实在搞不定第三方类库或者对应的IOS10的网上还没有release, 那么你可以先降回Xcode7.3.1版本,当你升级ios10之后,真机测试的时候,会有报错,找不到disk image。这个时候你需要在网上下载一个Xcode8.0的disk Image即可。





    展开全文
  • iOS开发从入门到精通 基于Xcode9和Swift4视频培训教程,本教程手把手教您学习Xcode9和Swift4语言!一看就懂,一学就会! 视频教程拥有180节课程,包含iOS开发基础知识、数据处理、网络访问、多线程、社会化分享、...
  • Xcode 8 升级 Swift3.0 问题处理。 Use Legacy Swift Language Version” (SWIFT_VERSION) is required to be configured correctly for targets which use Swift. Use the [Edit > Convert > To Current Swift ...
  • xcode 从 v6.0开始正式支持framework的工程,也可以说是从iOS 8开始可以在项目中集成动态链接库,在iOS8之前除了系统自带的framework之外,第三方库只支持静态链接库。 我们此处只探讨如何基于swift构建...
  • 很多同学可能也不是很关心苹果公司的各种发布会,或者是对科技界不是很感兴趣,导致在学习/使用xcode开发swift时不是很确定自己的swift到底是哪个版本,现将本人在网上查找和自己探索到的几种查看swift版本的方法列...
  • 在安装Xcode时,会碰到跟OS X操作系统匹配的问题,对照下下面几个表,以免给自己带来编译不过或者奇怪的错误等问题 以下列表来自网络: Xcode 1.0 - Xcode 2.x (before iOS support) Version history Version ...
  • 而这个问题偏偏是我在升级xcode之后才出现的 问题 概要描述 终端执行 sudo 或者 brew 会输出 env: node\r xxx 遇到这个问题真的很迷,无缘无故跟 node 搭上边了。 排查姿势 根据提示执行对应的命令 无解,依旧...
  • 引言 1 - Storyboard 是一个能够节省你很多设计手机 App 界面时间的新特性,如图所示  (1)通过上图,你可以大致明白,如果你要制作一个页面很多很复杂的 App,Storyboard 可以帮助你解决写很多重复的跳转方法...
  • Xcode版本和iOS版本是开发者经常会被问到的问题,今天以列表的形式总结一下,希望对大家有用。 XcodeVerson OS X SDK(s) iOS SDK(s) iPhone Xcode(4.2-4.3) OS X(10.6.x-10.7.x) iOS (5.0-5.1) iPhone4s ...
  • 目前最新swift是4.1,但是pod导入的三方可能是3.3版本,此时使用pod导入三方可在podfile里配置以下内容 # Swift 版本声明 post_install do |installer| installer.pods_project.targets.each do |target| if ['...
  • 看到许多文章的标题是“xcode 5 特性Asset Catalogs”,当时就在想是不是只要是xcode 5开发,不管sdk是什么版本就可以用Asset Catalogs了,就是说这些特性是针对xcode的,跟sdk版本无关?网上查一些资料,基本没有...
  • 有时候会遇到需要一些旧的版本Xcode的情况,...Command Line Tools , 下载与当前系统和安装的Xcode对应的Command Line Tools(其他版本的Xcode也在这里下载) 1、显示当前使用的Xcode xcode-select -p //输出:Applic...
  • [已解决]XcodeSwift项目中导入XMPPFramework编译出错:libxml xmlversion.h file not found 现在代码中使用: ? 1 var curXmppStream: XMPPStream? 但
  • 官方下载, 用开发者账户... 官方下载地址: https://developer.apple.com/xcode/downloads/   Xcode 77.2 : https://developer.apple.com/services-account/download?path=/Developer_Tools/Xcode_7.2/Xcode_7.2
  • Xcode版本简介

    2018-11-12 09:12:22
    1、Xcode 验证 在终端输入 spctl 命令,并带上安装的 Xcode 的路径 $ spctl --assess --verbose /Applications/Xcode.app 之后会看到类似这样的结果,只要结果是 accepted 而且 source 是 Mac App ...
  • xcode编译后会出现这个错误的情况: 1.使用cocopod导入第三方swift包后,swift...在xcode对应的targets下面的build settings 里面 设置swift的语言版本,就ok。建议设置成最新的swift语言版本。 如图    ...
1 2 3 4 5 ... 20
收藏数 6,740
精华内容 2,696
关键字:

xcode 对应swift版本