订阅云计算RSS CSDN首页> 云计算

VMware Mac版本漏洞可任意执行恶意代码

发表于2009-04-17 09:36| 次阅读| 来源赛迪网| 0 条评论| 作者木淼鑫

摘要:日前安全研究人员发现了一个存在于虚拟化软件VMware Mac版本Fusion中的严重安全漏洞,该漏洞可以通过Windows虚拟机在Mac主机上执行恶意代码,VMware已经发布了Fusion 2.0.4修复了该漏洞。

日前安全研究人员发现了一个存在于虚拟化软件VMware Mac版本Fusion中的严重安全漏洞,该漏洞可以通过Windows虚拟机在Mac主机上执行恶意代码,VMware已经发布了Fusion 2.0.4修复了该漏洞。

Immunity公司研究人员Kostya Korchinsky表示,VMware虚拟机显示功能中的一个严重漏洞可以被用来在主机操作系统上读取和写入内存。Korchinsky制作了一个视频,演示了如何利用该漏洞对主机系统进行攻击。演示中,主机运行Vista SP1,虚拟机运行Windows XP。

Korchinsky认为,这确实是一种虚拟机对主机的攻击,它利用VMware中显示功能的一些漏洞在主机上任意读取和写入内存,也就是说虚拟机可以有效绕过Vista SP1上的ASLR和DEP而在主机上运行代码。

同样的方法适用于运行Mac OS X的主机,在Fusion中也存在同样的漏洞,运行Windows或Linux的虚拟机也可以利用该漏洞在Mac OS X主机上执行任意代码。

VMware已经提供了新版本Fusion解决这一问题,用户可以从VMware网站免费下载这个186MB大小的Fusion 2.0.4。

0
0
VMware Mac版本漏洞可任意执行恶意代码